精华内容
下载资源
问答
  • 华为交换机端口聚合

    2014-03-13 16:08:00
    1、 配置手工负载分担模式链路聚合示例 2 、配置静态LACP 模式链路聚合示例 配置手工负载分担模式链路聚合示例 拓扑: 配置思路 1、创建Eth-trunk; 2、加入Eth-trunk的成员 说明: 创建Eth-Trunk 后,缺省的工作...

    介绍了两种模式下的典型应用场景举例。

    1、 配置手工负载分担模式链路聚合示例

    2 、配置静态LACP 模式链路聚合示例

    配置手工负载分担模式链路聚合示例

    拓扑:

    clipboard

    配置思路

    1、创建Eth-trunk;

    2、加入Eth-trunk的成员

    说明:

    创建Eth-Trunk 后,缺省的工作模式为手工负载分担模式,所以,缺省情况下,不需要配置 其模式为手工负载分担模式。如果当前模式已经配置为其它模式,可以使用mode 命令更改

    配置步骤:

    A、创建Eth-trunk

    #配置杭州9312

    <Huawei>sys

    Enter system view, return user view with Ctrl+Z.

    [Huawei]sysname hangzhou-zhongya9312

    [hangzhou-zhongya9312]int Eth-Trunk 1

    [hangzhou-zhongya9312-Eth-Trunk1]quit

    #配置上海9312

    <Huawei>sys

    Enter system view, return user view with Ctrl+Z.

    [Huawei]sysname shanghai-zhongya9312

    [shanghai-zhongya9312]int Eth-Trunk 1

    [shanghai-zhongya9312-Eth-Trunk1]quit

    [shanghai-zhongya9312]

    B、加入Eth-trunk的成员接口

    #配置杭州9312

    [hangzhou-zhongya9312]int GigabitEthernet 0/0/1

    [hangzhou-zhongya9312-GigabitEthernet0/0/1]eth-trunk 1

    [hangzhou-zhongya9312-GigabitEthernet0/0/1]quit

    [hangzhou-zhongya9312]int GigabitEthernet 0/0/2

    [hangzhou-zhongya9312-GigabitEthernet0/0/2]eth-trunk 1

    [hangzhou-zhongya9312-GigabitEthernet0/0/2]quit

    #配置上海9312

    [shanghai-zhongya9312]int g0/0/1

    [shanghai-zhongya9312-GigabitEthernet0/0/1]eth-trunk 1

    [shanghai-zhongya9312-GigabitEthernet0/0/1]quit

    [shanghai-zhongya9312]int g0/0/2

    [shanghai-zhongya9312-GigabitEthernet0/0/2]eth-trunk 1

    [shanghai-zhongya9312-GigabitEthernet0/0/2]quit

    C、验证配置结果

    在任意视图下执行display trunkmembership 命令,检查Eth-Trunk 1 是否创建成 功,及成员接口是否正确加入,以杭州9312为例。

    [hangzhou-zhongya9312]dis trunkmembership eth-trunk 1

    Trunk ID: 1

    Used status: VALID

    TYPE: ethernet

    Working Mode : Normal

    Number Of Ports in Trunk = 2

    Number Of Up Ports in Trunk = 2

    Operate status: up

    Interface GigabitEthernet0/0/1, valid, operate up, weight=1

    Interface GigabitEthernet0/0/2, valid, operate up, weight=1

    [hangzhou-zhongya9312]

    ping 测试

    [hangzhou-zhongya9312]ping 172.40.1.7

      PING 172.40.1.7: 56 data bytes, press CTRL_C to break

        Reply from 172.40.1.7: bytes=56 Sequence=1 ttl=255 time=50 ms

        Reply from 172.40.1.7: bytes=56 Sequence=2 ttl=255 time=50 ms

        Reply from 172.40.1.7: bytes=56 Sequence=3 ttl=255 time=50 ms

        Reply from 172.40.1.7: bytes=56 Sequence=4 ttl=255 time=30 ms

        Reply from 172.40.1.7: bytes=56 Sequence=5 ttl=255 time=50 ms

      --- 172.40.1.7 ping statistics ---

        5 packet(s) transmitted

        5 packet(s) received

        0.00% packet loss

        round-trip min/avg/max = 30/46/50 ms

    [hangzhou-zhongya9312]

    配置文件

    #杭州9312的配置单#

    [hangzhou-zhongya9312]dis cu

    #

    sysname hangzhou-zhongya9312

    #

    vlan batch 3501

    #

    cluster enable

    ntdp enable

    ndp enable

    #

    drop illegal-mac alarm

    #

    diffserv domain default

    #

    interface Vlanif1

    #

    interface Vlanif3501

    ip address 172.40.1.8 255.255.255.224

    #

    interface Eth-Trunk1

    description HangZhou--to--ShangHai--DWDM-huiju

    set flow-stat interval 10

    port link-type trunk

    undo port trunk allow-pass vlan 1

    port trunk allow-pass vlan 3501

    stp disable

    #

    interface GigabitEthernet0/0/1

    description hangzhou--to--shanghai--DWDM-CH21

    eth-trunk 1

    #

    interface GigabitEthernet0/0/2

    description hangzhou--to--shanghai--DWDM-CH33

    eth-trunk 1

    #

    return

    #上海9312配置单#

    [shanghai-zhongya9312]dis cu

    #

    sysname shanghai-zhongya9312

    #

    vlan batch 3501

    #

    cluster enable

    ntdp enable

    ndp enable

    #

    interface Vlanif1

    #

    interface Vlanif3501

    ip address 172.40.1.7 255.255.255.224

    #

    interface Eth-Trunk1

    description SW--ShangHai--to--HangZhou--DWDM-huiju

    set flow-stat interval 10

    port link-type trunk

    undo port trunk allow-pass vlan 1

    port trunk allow-pass vlan 3501

    stp disable

    #

    interface GigabitEthernet0/0/1

    description shanghai--to--hangzhou--DWDM-CH21

    eth-trunk 1

    #

    interface GigabitEthernet0/0/2

    description shanghai--to--hangzhou--DWDM-CH33

    eth-trunk 1

    #

    return

    转载于:https://blog.51cto.com/19880423/1375777

    展开全文
  • 端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生 2.优点 2.1增加冗余链路:...

    1.含义

    端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生

    2.优点

    2.1增加冗余链路:只要组内不是所有的端口都down掉,两个交换机之间仍然可以继续通信。

    2.2增加带宽:带宽相当于组成组的端口的带宽总和。

    2.3负载均衡:可以在组内的端口上配置,使流量可以在这些端口上自动进行负载均衡。

    3. 汇聚类型

    3.1人为配置

    手工聚合和静态lacp聚合都是人为配置的聚合组,不允许系统自动添加或删除手工或静态聚合端口。手工或静态聚合组必须包含至少一个端口,当聚合组只有一个端口时,只能通过删除聚合组的方式将该端口从聚合组中删除。手工聚合端口的lacp协议为关闭状态,禁止用户使能手工聚合端口的lacp协议。静态聚合端口的lacp协议为使能状态,当一个静态聚合组被删除时,其成员端口将形成一个或多个动态lacp聚合,并保持lacp使能。禁止用户关闭静态聚合端口的lacp协议。

    在手工聚合组中,端口因存在硬件限制(如不能跨板聚合)无法聚合在一起,而无法与处于selected状态的最小端口聚合的端口将处于standby状态。

    在静态聚合组中,系统按照原则设置端口处于selected或者standby状态:与处于selected状态的最小端口所连接的对端设备不同,或者连接的是同一个对端设备但端口在不同的聚合组内的端口将处于standby状态。与处于selected状态的最小端口的基本配置不同的端口将处于standby状态。

    3.2动态聚合

    动态lacp聚合是一种系统自动创建/删除的聚合,不允许用户增加或删除动态lacp聚合中的成员端口,即使只有一个端口也可以创建动态聚合,此时为单端口聚合。动态聚合端口的lacp协议为使能状态。

    4.简单配置

    以下只列出了设备A 的配置,设备 B 上应作相应的配置,汇聚才能实际有效:

    (1) 采用手工聚合方式(华为交换机的端口聚合,与Cisco有不同之处)

    # 创建汇聚组1

    [Quidway] link-aggregation group 1 mode manual

    [Quidway] interface ethernet2/1/1

    [Quidway-Ethernet2/1/3] port link-aggregation group 1

    # 当聚合组端口序号连续时,可以直接把多个端口聚成一组,组号由系统自行分配。

    [Quidway] link-aggregation ethernet2/1/1 to ethernet2/1/3 both

    (2) 采用静态LACP 聚合方式

    # 创建静态汇聚组1

    [Quidway] link-aggregation group 1 mode static

    # 将以太网端口Ethernet2/1/1 Ethernet2/1/3 加入聚合组1

    [Quidway] interface ethernet2/1/1

    [Quidway-Ethernet2/1/1] port link-aggregation group 1

    [Quidway-Ethernet2/1/1] interface ethernet2/1/2

    [Quidway-Ethernet2/1/2] port link-aggregation group 1

    (3) 采用动态LACP 聚合方式

    # 开启以太网端口Ethernet2/1/1 Ethernet2/1/3 LACP 协议。

    [Quidway] interface ethernet2/1/1

    [Quidway-Ethernet2/1/1] lacp enable

    [Quidway-Ethernet2/1/2] interface ethernet2/1/2

    [Quidway-Ethernet2/1/2] lacp enable

    [Quidway-Ethernet2/1/2] interface ethernet2/1/3

    [Quidway-Ethernet2/1/3] lacp enable

    只有端口的基本配置、速率、双工等参数一致时,上述端口在开启LACP 协议之后

    才能聚合到同一个动态聚合组内,实现端口的负载分担。

    展开全文
  • Esxi是否支持华为交换机端口聚合

    千次阅读 2014-10-20 09:36:38
    华为交换机配置中端口聚合称为eth-trunk,是将多个物理端口组合成一个逻辑端口。目地是为了增加带宽、线路冗余各流量负载。工作模式有手工负载分担与LACP两种。 LACP模式是一种利用LACP协议进行聚合参数协商、确定...

        华为交换机配置中端口聚合称为eth-trunk,是将多个物理端口组合成一个逻辑端口。目地是为了增加带宽、线路冗余各流量负载。工作模式有手工负载分担与LACP两种。
        LACP模式是一种利用LACP协议进行聚合参数协商、确定活动接口和非活动接口的链路聚合方式。需手工创建Eth-Trunk,手工加入Eth-Trunk成员接口,由LACP协议协商确定活动接口和非活动接口。

        聚合真是个很好的概念,交换机与交换机进行聚合配置是没问题的。如今虚拟化横行的年代,Esxi本身也是支持网络负载均衡的在默认虚拟交换机上做完配置后无需对物理交换机进行设置。

        现在Esxi主机内的VM做了windows2008 NLB网络采用的多播模式,在交换上进行了ARP静态绑定。想把华为物理交换机两个口做成端口聚合,Esxi是否可以支持?

    查阅vmware官方资料说明如下:


    注意:在实施任何形式的链路聚合之前需要考虑许多要求。有关这些要求的详细/相关信息,请参见 Host requirements for link aggregation for ESXi and ESX (1001938)

    链路聚合概念:

    • EtherChannel:这是一种链路聚合(端口中继)方法,用于在交换机、路由器和服务器之间提供容错和高速连接(其方式是组合两个到八个物理以太网链接以通过其他故障切换链接创建逻辑以太网链接)。有关 Cisco EtherChannel 的其他信息,请参见 Cisco 提供的EtherChannel Introduction

    • LACP 或 IEEE 802.3ad:链路聚合控制协议 (LACP) 作为用于控制多个物理端口包以形成单个逻辑通道的方法包含在 IEEE 规范中。LACP 可以让网络设备通过将 LACP 数据包发送到对等设备(也可以实现 LACP 的直连设备)来协商自动链接包。有关 LACP 的其他信息,请参见 Cisco 提供的 Link Aggregation Control Protocol whitepaper

      注意:仅在使用 vSphere Distributed Switch (VDS) 的 vSphere 5.1 和 5.5 或 Cisco Nexus 1000v 中支持 LACP。

    • EtherChannel 与 802.ad:EtherChannel 和 IEEE 802.3ad 标准非常类似,实现的目标也相同。但它们之间也存在一些差异,最明显的差异就是 EtherChannel 为 Cisco 专有产品,而 802.3ad 是一种开放式标准。

    • 有关 EtherChannel 实现的其他信息,请参见 Cisco 提供的 Understanding EtherChannel Load Balancing and Redundancy on Catalyst Switches 文章。


    EtherChannel 支持的方案:

    • 一个 IP 到多个 IP 的连接。(主机 A 向主机 B 和主机 C 发起两个连接会话)

    • 多个 IP 到多个 IP 的连接。(主机 A 和主机 B 向主机 C、主机 D 等发起多个连接会话)

      注意:不支持在多个 NIC 上进行一个 IP 到一个 IP 的连接。(主机 A 向主机 B 发起的一个连接会话仅使用一个 NIC)。

    • 与所有的 ESXi/ESX VLAN 配置模式兼容:VST、EST 和 VGT。有关这些模式的详细信息,请参见 VLAN Configuration on Virtual Switch, Physical Switch, and Virtual Machines (1003806)

    • 支持的 Cisco 配置:EtherChannel 模式打开 – (仅启用 EtherChannel)

    • 支持的惠普配置:中继模式

    • 支持的交换机聚合算法:IP-SRC-DST(IP-源-目标的缩写)

    • 支持的虚拟交换机 NIC 组合模式:IP HASH

      注意:可与 EtherChannel 结合使用的 vSwitch 或 vDistributed Switch 的唯一负载平衡选项是 IP HASH:

      • 请勿将信号探测与 IP HASH 负载平衡结合使用。

      • 请勿使用 IP HASH 负载平衡配置备用或未使用的上行链接。

      • VMware 仅支持每个 vSwitch 或 vNetwork Distributed Switch (vDS) 一个 EtherChannel。

    华为交换机官方资料:

    将成员接口加入Eth-Trunk时,需要注意以下问题:

    • 每个Eth-Trunk接口下最多可以包含8个成员接口。

    • 成员接口不能配置某些业务和静态MAC地址。

        

        从官方资料来看端口聚合只支持分布式交换机与思科Nexus 1000v ,这两种交换机只支持vcenter环境才会出现。单个Esxi主机是不支持端口聚合的。且华为交换机端口加入到链路聚合时,也不支持静态MAC地址。

    转载于:https://blog.51cto.com/52czy/1565769

    展开全文
  • 华为端口聚合分为两种,手工负载分担eth-trunk链路和LACP eth-trunk链路,我这里只介绍前者。 手动的eth-trunk,可以把他看成是一种接口,可以是access,也可以是trunk,创建好了后,配置完全和配置接口一样。我这里...

           华为端口聚合分为两种,手工负载分担eth-trunk链路和LACP eth-trunk链路,我这里只介绍前者。

           手动的eth-trunk,可以把他看成是一种接口,可以是access,也可以是trunk,创建好了后,配置完全和配置接口一样。我这里演示成trunk模式。

    一、场景模拟为 pc1--sw1-----sw2--pc2

    vlan 2 sw1:192.168.20.1 ,sw2:192.168.20.33;pc1:192.168.20.11,pc2 19219.168.20.22

    (pc端的vlan配置不讲了,大家应该都会。)另外,sw2配置也相同,当然,聚合的接口自定义。

    1. interface Eth-Trunk 1 /创建聚合链路,数值可以随意。

    2.  port link-type trunk  /设置成trunk模式。(如果是接入vlan的话,link-type acess)

    3. port trunk allow-pass vlan all /设置允许所有vlan.(接入vlan的话,port default vlan 20)

    4. mode manual load-balance /设置为手动负载

    5. trunkport g0/0/10 to g0/0/11 /加入接口。

    6. port-group group-member g0/0/10 to g0/0/11  /创建临时端口组,同时进入接口10和11

    7. eth-trunk 1   /加入eth-trunk 1

    8. 效果:[sw1]dis eth-trunk 1
      Eth-Trunk1's state information is:
      WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP        
      Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8             
      Operate status: up          Number Of Up Port In Trunk: 2                    
      --------------------------------------------------------------------------------
      PortName                      Status      Weight
      GigabitEthernet0/0/10         Up          1     
      GigabitEthernet0/0/11         Up          1     

      这里简单解释一下:

      Operate status:显示成员接口状态,如果是down表示在物理接口上出现故障。

          workingMode:nomal是普通负载分担方式,static 表示静态LACP负载分担方式

          portName:接口名

    二、还可以根据源mac,ip,目的mac,ip进行负载,load-balance 命令后很多。可以根据实际情况加

    三、故障排除。

    我配置的时候出现过,用dis的时候portname下面是空的情况。原来是自己没有加入eth-trunk 1。

    第二个问题,原来g0/0/10 和11 是trunk.我更改接口的时候出现Error: Please renew the default configurations。我百度了一下,发现是因为接口下有非默认配置的配置,所以无法直接更改成eth-trunk,必须先清除原来的配置,但是清除接口时任然报这个错。就是因为默认接口是加入vlan 1 的。

    解决:1. 首先undo trunk port allow-pass vlan all./清除trunk所有vlan

      然后 2. port trunk allow-pass vlan 1,将vlan 1重新加入

               3. undo port link-type trunk /清除trunk。这个时候就不会报错了。

               4.然后就可以加入eth-trunk 1 了。

    转载于:https://blog.51cto.com/hyp0535/1674180

    展开全文
  • 很久没有动手写点什么,一方面因亦大工作较忙,另一方面最近太累不想动,今天...eNSP配置端口聚合实验:设备:2台S5700交换机,端口聚合选用g 0/0/23和 g 0/0/24 (实际一般默认最后2个端口聚合)配置如下:display...
  • ,端口聚合后原来端口的属性就会被聚合端口的属性所覆盖,也不能在源端口上做任何配置,实现端口聚合后,即使网络链路出现故障,只要不是所有链路都故障,网络还是可以继续运行的,只不过网络传输速度会降低而已. ...
  • 端口聚合介绍: TRUNK是端口汇聚的意思,就是通过配置软件的设置,将2个或多个物理端口组合在一起成为一条逻辑的路径从而增加在交换机和网络节点之间的带宽,将属于这几个端口的带宽合并,给端口提供一个几倍于独立...
  • 配置ESXi的端口聚合配置ESXi6.0的端口聚合由于本人只有华为S5700-48TP-SI的交换机,所以请根据实际情况配置交换机,本例中ESXi服务器的网卡3连接交换机的3端口,网卡4连接交换机的4端口。交换机配置创建聚合端口组,...
  • 华为交换机设置端口聚合的方法

    万次阅读 2014-11-19 15:09:11
     首先为什么要设置交换机端口聚合呢,因为网口绑定的话可以提高带宽,负载均衡,提高稳定性,好处多多,绑定的模式有Mode0-6这7种,有些是不需要交换机支持的,比如mode6,这些模式在主机设置几个配置文件就行了,...
  • 一、服务器环境和交换机环境 1、服务器 ubuntu18 4.15.0-159-generic 2、交换机 Huawei Versatile Routing Platform Software VRP (R) software, Version ...HUAWEI S5720S-28P-SI-AC Routing Switch uptime is ...
  • 端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,STP会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生。但是,失去了路径冗余的...
  • 华三H3C端口聚合与链路聚合

    万次阅读 2018-03-14 20:56:44
    端口聚合是思科的叫法,链路聚合是华为与华三的叫法,网上也有不同解释,自己查资料理解区别吧 端口聚合 把端口加入端口组(group),链路聚合 把链路聚合在一起 华三配置 静态聚合模式 <H3C>system-view ...
  • 思科、华为、锐捷的交换机端口聚合区别思科命令行配置:CLI:SW#conf t SW(config)#interface range f1/1 -2 SW(config-if)#channel-group 1 mode desirable/on SW(config-if)#swithport SW(config-if)#switchpo...
  • 华为链路聚合

    千次阅读 2019-09-01 15:58:16
    手工负载分担模式链路聚合 手工负载分担模式下,Eth-Trunk的建立、成员接口的加入完全由手工来配置。该模式下所有活动链路都参与数据的转发,平均分担流量,因此称为负载分担模式。如果某条活动链路故障,链路聚合组...
  • 端口聚合也叫做以太通道(ethernet channel),主要用于交换机之间连接。由于两个交换机之间有多条冗余链路的时候,如果存在STP,会将其中的几条链路关闭,只保留一条,这样可以避免二层的环路产生。但是,失去了...
  • 无论什么设备都无法保障运行的绝对稳定性,即使再优秀的产品也无法保证24×7不间断的工作。除去设备或模块损坏、传输线路中断等硬件故障原因以外,还可能由于网络流量过载、任务负荷过大而...华为HCIe认证价值,华...
  • 端口聚合 / 链路聚合

    2021-06-15 21:12:05
    端口聚合作用 › 端口聚合的链路成为一条逻辑链路 › 正常时两条物理链路负载均衡,提高带宽 › 一条物理链路失效,另外一条链路仍然正常转发数据,提高可靠性
  • 华为端口聚合配置:华为交换机的端口聚合可以通过以下命令来实现: S3250(config)#link-aggregation port_num1 to port_num2 {ingress | ingress-egress} 其中port_num1是起始端口号,port_num2是终止端口号。...
  • 一、需求描述现有H3C S9505E核心交换一台,HUAWEI S5720S-52P三层交换一台,S9505E的2个物理端口和S5720S的2个物理端口配置端口聚合,两端都采用静态聚合方式。二、配置简述1、华为创建Eth-trunk组,添加物理端口至...
  • 网络管理人人员在日常工作中,...打开今日头条,查看更多图片1 端口聚合简述端口聚合是指将多个物理端口和所连接的链路进行捆绑,构成一个逻辑端口或者链路,从而达到增加带宽、提供冗余、负载均衡的目的。端口聚...
  • 成员接口和成员链路:活动接口和非活动接口、活动链路和非活动链路:链路接口最大链路活动值:链路接口最小链路活动值:链路捆绑与端口聚合两种配置模式1、手工模式2、Lacp模式二级目录三级目录 链路捆绑与端口聚合...
  • 华为交换机LACP模式链路聚合配置

    千次阅读 2019-03-28 09:24:10
    交换机A和交换机B之间通过3条GE以太网连接,活动链路为2,配置如下: SwitchA配置 <HUAWEI> system-view [HUAWEI] sysname SwitchA ...[SwitchA-Eth-Trunk1] mode lacp # 配置LACP模式 [SwitchA-E...
  • 华为链路聚合配置

    万次阅读 多人点赞 2016-12-21 09:15:29
    运行环境:公司这边有2层楼 分别运行着不同的业务 本来两个楼层的网络是分开的 但都是一家公司难免会有业务往来(你不可能叫别人走外...原来的运行方式:2台S5700分别配置Eth-Trunk1 分别将需要通信的3条线路的端口加入
  • 链路聚合(端口聚合)

    千次阅读 2019-09-20 16:25:26
    链路聚合有成端口聚合,断口捆绑,英文名port trunking.功能是将交换机的多个低带宽端口捆绑成一条高带宽链路,可以实现链路负载平衡。避免链路出现拥塞现象。通过配置,可通过两个三个或是四 个端口进行捆绑,分别...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,369
精华内容 947
关键字:

华为端口聚合模式