精华内容
下载资源
问答
  • 转换函数

    2017-09-23 09:56:00
    厘秒 [-/,.;:] 日期时间中的分隔符 TH th 数字的后缀 SP,sp 拼读数字 SPTH,spth sp和th的组合 Tzh 时区小时 tzr 时区区域 二、数字格式说明 格式 例子 说明 , '9999,999' ...

    一、日期格式说明

    类型说明
    Cc两位数字的世纪
    scc有负号的两位数字的世纪,表示世纪前
    Q表示一位数季度
    yyyy表示4位数年
    iyyy表示4位数年,ISO格式
    rrrr表示当前年的4位数字的圆整年
    y,yyy有逗号的4位数字年
    Yyy年的最后3位数字
    Yy年的最后2位数字
    Iyy年的最后2位数字,ISO格式
    Rr基于当前年的两位数字的圆整年
    Y年的最后1位数字
    I年的最后1位数字,ISO格式
    YEAR年名称为大写字母
    Year年名称首为大写字母
    Mm两为数字月
    MONTH月名称全称,大写字母9个字符,位数不足用空格补
    Month月份的名称全程,首字母大写,9个字符,不足补空格
    MON月份名称的前3个字母,大写
    Mon月份名称的前3个字母,首字大写
    RM罗马数字月
    Ww年中的2位数字星期
    Iw年中的2位数字星期,ISO标准
    W月中的一位数字星期
    ddd年中的3位数字日
    Dd月中的两位数字日
    D周中的一位数字日
    DAY日的全称,大写字母
    Day日的全称,首字母大写
    DY日的前三个字母,大写
    Dy日的前三个字母,首字母大写
    hh24两位数字小时,24小时制
    Hh两位数字小时,12小时制
    Mi两位数字分钟
    Ss两位数字秒
    ff[1...9]小数数字秒,小数部分指定
    sssss过去12点的秒数
    Ms毫秒
    Cs厘秒
    [-/,.;:]日期时间中的分隔符
    TH th数字的后缀
    SP,sp拼读数字
    SPTH,spthsp和th的组合
    Tzh时区小时
    tzr时区区域

    二、数字格式说明

    格式例子说明
    ,'9999,999'逗号,一般以千分位出现,作为分组符号使用。如果需要您也可以当作是十分位,百分位出现,可以出现N次,视乎数字的大小而定。
    变态的例子是 to_char(1234,'9,9,9,9')。
    注意事项:只能出现在整数部分。
    .'99.99'点号,不要念为"句号",句号是个圆圈,点好只能出现在小数点对应的地方.只能出现一次.
    to_char(1234.34,'9,999.99')
    注意事项:只能出现在一个地方,就是原来数据小数点位置
    $'$999.99'美元.其实你可以放在任意地方(在10G下)
    to_char(1234.34,'9,999.$99') 
    注意事项:只能出现一次。
    0'0999.99'零.在对应位置返回对应的字符,如果没有则以'0'填充。
    to_char(1234,'9999.00')='1234.00';
    注意事项:这是一个强制的符号,对应位没有,则以'0'填充,这是9很大不同地方
    9'999.99'9 在小数位,则表示转换为对应字符,如果没有则以0表示;在整数位,没有对应则不填充字符。
    TO_CHAR(123,'999.99')=123.00;
    TO_CHAR(123,'99999.9')=123.0;
    注意事项:对于0和9而言,如果格式的位数不如数字的位数多,会返回'#'。
    譬如to_char(12345,'9999')='#####'
    B'B999''B999'
    没有其它特别作用,在整数部分最前面加一个空格,可以出现在任意位置.
    'S'||TO_CHAR(1234,'99B99')='S 1234';
    注意事项:只能出现在整数部位。
    C'C9999'在特定的位置返回一个ISO货币符号(就是NLS_ISO_CURRENCY参数所代表的值)
    TO_CHAR(1233,'C9999')='CNY1234',这是新的国际标准RMB,关于这个可查询“国际货币符号”
    注意事项:只能出现在整数部位第一位。
    可以通过alter session set NLS_ISO_CURRENCY='JAPAN';来修改当前会话的设置。
    D'999D99'这是“点号”的国际版本(ISO),作用等同于点号,也是只能出现一次。所不同的是,数据库会根据NLS_NUMERIC_CHARACTER的参数值来设置内容。默认的这个值是点号.
    注意事项:没有特别需要一般不要用这个格式符号。也不要轻易修改参数值。
    也可用alter sesssion set 来修改.
    alter session set nls_numeric_characters='!';
    to_char(1234.34,'9999d99')=1234!34
    EEEE9.9EEEE科学计算符号
    TO_CHAR(2008032001,'9.9EEEE')='2.01E+09',由于是科学计算方法,所以小数位前面加一个9或者0即可,多个是没有意义的。
    G999G999是逗号(,)的的ISO标准,作为分组符号使用,可以放在多个地方使用.
    TO_CHAR(123456,'999G9G99')=123,4,56
    注意事项:同第八项 -D, 此外如果要转换出小数点,则要和D配合使用,不能和点号配合。
    L'L999'是C的本地版本。可以放在整个格式的最前面和最后面.
    TO_CHAR(123456,'999G9G99D00L')=123,4,56.00¥
    注意事项:同第七项 C
    MI'9999MI'如果是负数,在尾部加上负号(-),如果是正数,则尾巴加上空格
    to_char(1234,'9999mi')||'S'||TO_CHAR(-5678,'9999MI') =1234 S5678-
    注意事项:只能放在格式尾巴
    PR9999PR是表达负数的另外一种方式。如果是正数,则头部加上空格;如果是负数,则用小简括号<>把数字包起来.
    TO_CHAR(-1234.89,'9G999D00PR')=<1,234.89>
    注意事项:同上
    RN(rn)RN(rn)把整数(1-3999)转换为罗马字符。RN表示转为大写,rn表示小写的.
    declare
    i int;
    begin
    for i in 1..20 loop
    dbms_output.put_line(to_char(i,'RN'));
    end loop;
    end;
    注意事项:只能自己使用,不能和其它符号组合使用。
    S'9999S'是以上两个符号的综合改进版本。为整数加一个正号+,为负数加一个符号-。S在前则加在前,在后则在后.
    TO_CHAR(-1234,'S9999')=-1234;
    TO_CHAR(1234,'S9999')=+1234
    TMTM9/TMe使用这个参数等于没有用参数to_char(number)一样,应为'tm9'是默认的格式参数。
    to_char(1234,'tme')=1234
    注意事项:格式要么是TM9,要么是TME。
    当数字长度超过64位时候,TM9的输出等同于TME的输出。
    UU999双币符号,例如欧元.作用同11的L
    TO_CHAR(999,'U999')=¥999
    注意事项:通过NLS_DUAL_CURRENCY 控制
    V999V9这是个比较古怪,又不是很常使用的符号。它的作用在于做一个计算。
    例如TO_CHAR(N,'999V9'),以p表示V的位置,则该表达式=to_char(N×(10的P-1次方))。但是9个数又必须保证大于等于乘积之后表示的位数。
    TO_CHAR(5,'9V')=5*1=5;
    TO_CHAR(5,'9V9')=5*10=50
    TO_CHAR(5,'9V99')=500
    TO_CHAR(50,'9V99')='######' 9的个数不够
    注意事项:格式中不能和小数表达写在一起,但是可以混合货币等。
    Xxxxx转换为16进制。
    TO_CHAR(100,'XX')= 64
    注意事项:数值必须是大于等于0的整数。前面只能和0或者FM组合使用。

    三、隐式转换

    1、日期:样式根据nls_date_format参数,一致可相互隐式转换

      a)  varchar2 -> to date

      b)  date -> to varchar2

    2、数字:纯数字格式可以相互转换

      a)  varchar2 -> to number

      b)  number -> to varchar2

    四、转换函数

    函数说明
    TO_CHAR语法:TO_CHAR(datatime|interval, format)
    说明:将NUMBER或DATE类型的值转换为字符串
    例句:
    SELECT TO_CHAR(SYSDATE,'YYYY-MM-DD') FROM DUAL;
    SELECT TO_CHAR(123456.78,'999,999.99') FROM DUAL;
    TO_DATE语法:TO_DATE(str, format)
    说明:将NUMBER、CHAR或VARCHAR2转换为DATE类型值
    例句:
    SELECT TO_DATE('1988-07-19','YYYY-MM-DD') FROM DUAL;
    TO_NUMBER语法:TO_NUMBER(str, format)
    说明:将CHAR或VARCHAR2转换为一个数值
    例句:
    SELECT TO_DATE('1988-07-19','YYYY-MM-DD') FROM DUAL;

    展开全文
  • Oracle时间信息特性

    2009-02-15 19:47:11
    而有时候操作的持续时间不到厘秒,但是起始和终止发生在两个相连的厘秒,所以操作时间不到厘秒但是却被记录为厘秒,造成时间记录的不准确。 在Oracle9i之前,最小的时间单位仍然是厘秒,这可以在跟踪文件、v$system_...
    在监控、诊断、处理数据库性能问题的时候,时间信息往往是非常重要的判断依据。有时候可能我们会使用一些比例来判断性能,但是使用比例而不使用时间往往会将我们带向错误的方向。在Oracle9i的第一版中关于时间的信息被进行了增强,提供了更多更有益的时间信息。除了9i的外貌发生了变化,在一些并没有被我们注意或者不为人知得一些v$视图的相关字段也发生了变化。这里提到的主要是他们发生了那些改变以及对DBA有什么帮助。这里也列出了零星的一些Oracle内部的未公开的信息。

    Second 1 秒
    Centi-second 1/100 百分之一秒 厘秒
    Milli Second 1/1000 千分之一秒 毫秒
    Micro Second 1/1.000.000 微妙
    Nano Second 1/1.000.000.000 纳秒

    在以前的版本中,Oracle的时间计量单位是厘秒,使用厘秒最显而易见的问题就是可能有些操作是小于厘秒的。看上去这似乎不太常见,但是实际上在操作系统上很多操作都是以微妙作为单位的,这意味着操作的起始和终止在不到厘秒就完成了,从厘秒级看就好像没有发生一样,因为持续时间近似为0。而有时候操作的持续时间不到厘秒,但是起始和终止发生在两个相连的厘秒,所以操作时间不到厘秒但是却被记录为厘秒,造成时间记录的不准确。
    在Oracle9i之前,最小的时间单位仍然是厘秒,这可以在跟踪文件、v$system_event和v$session_event中的超时字段看到。在9i之前,是不能在联机状态看到sql语句的执行(cpu消耗)时间和持续时间的,也不能看到一条Sql语句在等待着什么,实际上只有一种方法可以得到这些信息,就是通过启用10046 trace level 12的跟踪事件。这样做也会带来下面的一些问题:
    1. 生成进程跟踪文件带来很高的性能开销
    2. 如果有太多用于帮助调优的sql语句执行,将会产生大量的磁盘/文件空间需求。

    在oracle9i第一版中
    在oracle9i第一版中的持续时间以微妙作为时间单位,这能够显示出Oracle真正花费的时间。超时仍然以微妙作为计时单位。一些视图被扩展以便记录微妙数据。所有的时间信息由初始化参数timed_statistics 决定。

    一些视图的改变:
    V$SQLAREA:
    两个字段被加入到V$SQLAREA中,分别是CPU_TIME 和ELAPSED_TIME。两个字段都被设置为微妙级。然而,在这里可能会s看到一个有趣的现象:
    Select cpu_time, elapsed_time
    From v$sqlarea
    Order by 2
    CPU_TIME ELAPSED_TIME
    ---------- ------------
    230000 174567
    260000 258803
    260000 271808
    首先:三行中的第二行显示出了持续时间小于cpu执行时间,实际的情况是cpu字段记录单位是微妙级,但是数据被进位保留到了厘秒级。

    Sql 语句的等待时间等于ELAPSED_TIME减去CPU_TIME,但是很难看到精确的等待时间。在V$SYSTEM_EVENT 视图中能够看到数据库实例级的等待时间(并不是每条Sql语句的),但是看不到发生在操作系统上(cpu等待、内存的等待)的等待时间s。

    X$KSQST的改变 (对应视图V$ENQUEUE_STAT)

    基础表X$KSQST主要显示关于系统中队列的信息。在9i之前只能提供队列类型的get和wait数。一个队列有两种特征和两个标识组成(id1 and id2)。例如一个叫做TX队列,表示一个事务队列。从Oracle9i开始不但能够看到gets 和waits,而且等待的时间和得不到队列(中断或者超时)的失败次数都可以看到。

    X$KSQST
    KSQSTWTIM NUMBER 以微妙作为单位

    然而这里仍不能将队列等待与Sql语句关联,也不能够得到等待队列的Sql语句到底等待了多久。下面的一个新的视图v$enqueue_stat 将提供关于队列得更多信息:

    V$ENQUEUE_STAT
    INST_ID NUMBER
    EQ_TYPE VARCHAR2
    TOTAL_REQ# NUMBER
    TOTAL_WAIT# NUMBER
    SUCC_REQ# NUMBER
    FAILED_REQ# NUMBER
    CUM_WAIT_TIME NUMBER

    V$SYSSTAT的改变
    实际这个视图并没有什么改变,关于时间的信息仍然在厘秒级。

    V$SYSSTAT
    CPU used by this session 厘秒
    Parse time cpu 厘秒
    Parse time 厘秒
    Recursive cpu usage 厘秒
    当从不同资源中比较数据时应该注意。

    V$WAITSTAT的改变
    这个视图显示了发生在块级的buffer busy waits的细目描述,等待时间的单位在微妙级。

    V$WAITSTAT
    TIME NUMBER 厘秒单位
    这里无法通过视图中出现的等待找到对应的sql语句。

    V$FILESTAT的改变
    在这个视图中现在分成了单次块读取和累计块读取,这种分法更合理。

    V$FILESTAT
    MAXIORTM NUMBER 厘秒级的最大读取时间
    MAXIOWTM NUMBER 厘秒级的最大写入时间
    SINGLEBLKRDS NUMBER 单次块读取块数
    SINGLEBLKRDTIM NUMBER 厘秒级的累计单次块读取时间
    这个视图也不能找到相关的Sql语句,使用dbms_system.kcfrms()过程可以重设最大读、写时间,设置更准确的取样间隔。

    V$SESSION_EVENT的改变
    这个视图现在已经可以捕捉到微妙级的等待事件的持续时间了。它可以以微妙或者厘秒方式显示等待时间,因为这些改变,等待事件变得更加精确(等待时间以微妙方式捕捉,然后转换为厘秒方式)

    V$SESSION_EVENT
    TIME_WAITED_MICRO NUMBER 以微妙级等待的时间
    TIME_WAITED NUMBER 微妙级的等待时间 / 10000
    MAX_WAIT NUMBER 厘秒级的最大等待时间

    当然,这个视图也不能找到相关的Sql语句。
    一个被大多数DBA所感兴趣的字段是MAX_WAIT 字段,这个字段显示了一个事件的最大等待时间。这个信息只要会话一登陆就生效,将显示一个会话整个生命期中的最大等待时间。使用 dbms_system.kcfrms() 过程可以重置最大的值,以便让这个字段显示与测量周期更紧密的值。

    V$SYSTEM_EVENT的改变
    这个视图最主要的变化是增加了TIME_WAITED_MICRO字段,它以微妙为单位显示了持续的时间。.另外TIME_WAITED 也更加精确,,因为它来自于TIME_WAITED_MICRO的值。

    V$SYSTEM_EVENT
    TIME_WAITED_MICRO NUMBER 持续的等待时间(微妙)
    TIME_WAITED NUMBER 从time_waited_micro取值,以厘秒为单位

    SQL TRACE
    通过在会话级设置事件‘10046 trace name context level 12, forever’可以看到下面的跟踪信息。
    PARSING IN CURSOR #1 len=29 dep=0 uid=5 oct=3 lid=5 tim=1006862415399006 hv=4384
    51932 ad='84b05c04'
    select count(*) from tab, tab
    END OF STMT
    PARSE #1:c=10000,e=11334,p=0,cr=4,cu=0,mis=1,r=0,dep=0,og=4,tim=1006862415398976
    BINDS #1:
    EXEC #1:c=0,e=587,p=0,cr=0,cu=0,mis=0,r=0,dep=0,og=4,tim=1006862415399931
    WAIT #1: nam='SQL*Net message to client' ela= 10 p1=1650815232 p2=1 p3=0
    FETCH #1:c=2500000,e=2526458,p=0,cr=149542,cu=0,mis=0,r=1,dep=0,og=4,tim=1006862
    417926777
    WAIT #1: nam='SQL*Net message from client' ela= 1004 p1=1650815232 p2=1 p3=0
    FETCH #1:c=0,e=6,p=0,cr=0,cu=0,mis=0,r=0,dep=0,og=0,tim=1006862417928426
    WAIT #1: nam='SQL*Net message to client' ela= 7 p1=1650815232 p2=1 p3=0
    WAIT #1: nam='SQL*Net message from client' ela= 3636276 p1=1650815232 p2=1 p3=0
    注意:时间都是微妙级的,但是这里仍然有一些很有意思的地方:

    1. tim= 明显是微妙级的,这个tim 域给出了一个时间快照
    2. e= 和 ela= 也是微妙级的,这两个域表示持续的事件
    3. 比较有趣的是c=. 看上去好像是微妙级的,但是实际上是厘秒级的数据乘上了10000, 域c 表示cpu的消耗

    v$latch, / v$latch_parent / v$latch_children 的改变:
    在Oracle9i主要的改变是增加了wait_time字段。因此现在锁存器竞争更容易检测了,而在Oracle9i以前,只能通过察看sleeps次数来判断。在v$latch中主要相关的字段包括:
    V$LATCH
    NAME VARCHAR(64) 锁存器名称.
    SLEEPS NUMBER 锁存器由于忙而产生的sleep次数
    SLEEP1..11 NUMBER 显示了sleep的分布情况
    WAIT_TIME NUMBER 微妙级的等待时间

    在Orace9i以前与v$latch的 ‘latch free’等待事件的SLEEPS字段对应的是v$system_event的TOTAL_WAITS字段:
    select event, total_waits, time_waited
    from v$system_event
    where event = 'latch free'

    select name, trunc(sleeps*100/ total, 2) "Perc of Sleeps"
    from v$latch, (select decode(sum(sleeps), 0, 1, sum(sleeps)) total from v$latch)
    where sleeps != 0

    有很多sleeps的锁存器会显示为v$system_event的大量等待时间。在Oracle9i由于在v$latch中有了WAIT_TIME字段,所以提供了更准确的信息:
    select name, trunc(wait_time*100/time_waited, 2) "Perc. of Time Waited"
    from v$latch, (select time_waited from v$system_event where event = 'latch free')
    where wait_time != 0
    order by 2

    还有那些没有改变?
    其他与时间相关的信息都没有改变。在V$SYSSTAT中象 ‘CPU used by this session’, ‘parse cpu time’ and ‘recursive cpu usage’等事件仍然表示为厘秒。

    Oracle没有改变这些统计信息的单位是因为这些信息可能会影响着一些依赖于他们的应用或者脚本。

    Oracle的Precise/Indepth
    在 Oracle9i中由于使用了微妙做为单位,所以持续时间已经变得更加准确,但是仍然不能看到在一个特定的时间范围内的每个sql语句的资源消耗。了解每个sql语句的资源消耗能够帮助你确定那个sql语句是你首先应该调优的。使用Oracle的Precise/Indepth,通过不断的监视Oracle的环境,收集用于性能分析的数据,就能够看到每条Sql语句的资源消耗情况。这些资源消耗情况最终被细分为:

    Using CPU
    CPU wait
    I/O wait
    Memory wait
    Other host wait
    Table lock wait
    Row lock wait
    Shared pool wait
    Buffer wait
    Rollback segment wait
    Redo log buffer wait
    Log switch and clear wait
    Internal lock wait
    Background process wait
    Parallel query sync. Wait
    Parallel query server wait
    Other wait[@more@]

    来自 “ ITPUB博客 ” ,链接:http://blog.itpub.net/18921899/viewspace-1017384/,如需转载,请注明出处,否则将追究法律责任。

    转载于:http://blog.itpub.net/18921899/viewspace-1017384/

    展开全文
  • 华为交换机基本命令

    万次阅读 多人点赞 2018-11-10 21:10:55
    命令不区分大小写,支持“Tab”键补全,支持命令简写。 一、常用命令 用户视图 &lt;Huawei&gt;   进入系统视图 &lt;Huawei&gt; system-view 或者 sys 或者 system ...[Huawei]interfa...

    命令不区分大小写,支持“Tab”键补全,支持命令简写。


    一、常用命令

    用户视图

    <Huawei>

     

    进入系统视图

    <Huawei>  system-view   或者  sys  或者 system

    [Huawei]  

     

    更改设备的名字

    [Huawei] sysname  HW  

    [HW]

     

    进入接口视图

    [Huawei]interface Ethernet0/0/1  或者int         interface 接口类型+接口编号 

    [Huawei-Ethernet0/0/1]

     

    关闭接口

    [Huawei-Ethernet0/0/1] shutdown

    开启接口

    [Huawei-Ethernet0/0/1] undo shutdown

     

    查看vlan

    display vlan 或者 dis vlan

     

    查看当前配置:display  current-configuration 或者 display cu

    查看已保存配置:display saved-configuration  或者  display sa

    查看版本: display version

     

    保存配置:save

    清除已保存的配置:reset saved-configuration

     

    返回上级视图:quit

    返回用户视图:return

     

    重启设备:reboot

     

     

    二、配置和管理Vlan

    #1.基于接口划分VLAN -- 静态

    创建vlan  

    [Switch] vlan 10

    [Switch] vlan batch 10  20  同时创建两个vlan

    [Switch] vlan batch 10 to 20  创建10-20的vlan

     

    进入接口模式

    [Switch]  interface Ethernet0/0/1

    [Switch-Ethernet0/0/1]

     

    配置接口类型为Acces接口

    [Switch-Ethernet0/0/1]  port  link-type  access

    [Switch-Ethernet0/0/1]  port default vlan 10           配置接口所属的VLAN

     

    配置接口类型为Trunk口

    [Switch]  interface Ethernet0/0/3

    [Switch-Ethernet0/0/3]  port link-type trunk    

    [Switch-Ethernet0/0/3]  port trunk allow-pass vlan 10  20   配置接口所属的VLAN

                          port trunk allow-pass vlan all  运行所有vlan通过

     

    简写:int e0/0/1   int g0/0/1

     

     

    设置vlan描述

    [SW] vlan 10

    [SW-vlan10]  description  xxxxx  设置该vlan描述

     

    设置接口组(批量设置)

    [SW]  port-group vlan 10

    [SW-port-group-vlan10]  group-member Ethernet0/0/1  to Ethernet0/0/8

     

    # 2.基于MAC地址划分VLAN  -- 静态

    华为交换机上所有二层以太网端口缺省都是Hybrid类型并且发送数据帧时都是不带VLAN标签的

    如果该交换机的缺省配置有改变,需要重新恢复其缺省配置

    <HUAWEI>  system-view  

    [HUAWEI]  vlan 10       管理vlan10

    PC的MAC地址与VLAN 10关联

    [HUAWEI-Vlan10]  mac-vlan mac-address 22-22-22  

    [HUAWEI-Vlan10]  mac-vlan mac-address 33-33-33  

    [HUAWEI-Vlan10]  mac-vlan mac-address 44-44-44  

    [HUAWEI-Vlan10]  quit

    配置接口加入的VLAN10

    [HUAWEI] interface ethernet 0/0/1  

    [HUAWEI-Ethernet0/0/1] port hybrid Untagged vlan 10   允许VLAN 10的数据帧通过,且发送时不带VLAN标签[HUAWEI-Ethernet0/0/1] quit  

    [HUAWEI] interface ethernet 0/0/2

    [HUAWEI-Ethernet0/0/2] port hybrid Tagged vlan 10    允许VLAN 10的数据帧通过,且发送时带有VLAN标签 [HUAWEI-Ethernet0/0/2] quit  

     

    启用基于MAC地址的VLAN划分功能

    [HUAWEI] interface ethernet 0/0/1  

    [HUAWEI-Ethernet0/0/1] mac-vlan enable    

    [HUAWEI-Ethernet0/0/1] quit  

     

    三、链路和接口类型

    两种链路: 接入链路(Access Link) 、干道链路(Trunk Link)

     

    四种接口:  Access接口、   Trunk接口、  Hybird接口、  QinQ接口

    分别连接:   终端            交换机                         公网

     

     

    概述:

    Access类型:端口只能属于一个vlan,一般用于连接计算机。

     

    Trunk类型:端口可以属于多个vlan,可以接收和发送多个vlan报文,多用于交换机之间。

     

    Hybrid类型:端口可以属于多个vlan,可以接收和发送多个vlan的报文,可以用于交换机之间,也可以用于连接用户主机。  

     

    Trunk端口和Hybrid端口之间不能直接切换,只能先设为Access端口,再设置为Hybrid端口。

     

     

     

     

     

     

     

    配置交换机的管理

    [SW] interface vlanif10                创建vlan的vlanif接口

    [SW-vlanif10] ip address 1.1.1.1       创建vlanif的接口ip

     

    [SW]telnet server enable      开启telnet

    [SW]user-interface vty 0 4     开启vtf线路模式,开启0-4的5个用户终端

    [SW-ui-vty0-4]

    [SW-ui-vty0-4]  protocol inbound telnet   配置telnet协议

    [SW-ui-vty0-4] authentication-mod aaa     配置认证方式

    [SW-ui-vty0-4] quit

    [SW]  aaa

    [SW-aaa] quit

    <SW> save    用户视图下保存配置

     

    aaa服务器是验证、授权和记账(Authentication、Authorization、Accounting )

     

     

     

     

     

     

    其他概念:

    交换机Console口连接计算机串口。

    vlan(虚拟局域网)工作在第二层和第三层。

    每个vlan都形成一个广播域。

    vlan间通信需要通过路由器(第三层)组成的主干网段。

     

    静态vlan配置:基于端口 (管理员手动分配)

    动态vlan配置:基于MAC 或 IP

     

     

    STP生成树Spanning Tree Protocol

    网络中,存在二层环路的主要原因是对设备或链路存在冗余备份,以保障网络的可靠性。

    如果二层交换网络中存在环路,则会导致广播风暴、帧的重复复制、MAC地址表动荡

    生成树协议能发现并自动消除荣誉网络扩扑中的环路

     

    STP生成树协议作用:

    1. 消除环路:通过阻断冗余链路来消除环路()
    2. 链路备份:当活动路径发生故障是,激活备份链路,恢复网络连通性。

     

    生成树算法:进行环路分解

     

     

     

     

     

    展开全文
  •   (second),时间单位 : s,   毫秒(millisecond),时间单位:ms   微秒(microsecond),时间单位:μs 时间换算:        1s【】 = 1000ms【毫秒】   1ms【毫秒】 = ...

    时间单位:

      秒(second),时间单位 : s,
      毫秒(millisecond),时间单位:ms
      微秒(microsecond),时间单位:μs

    时间换算:

           1s【秒】 = 1000ms【毫秒】
      1ms【毫秒】 = 1000μs【微秒】
       1μs【微秒】 = 1000ns【纳秒】
      1ns 【纳秒】= 1000ps【皮秒】

    1秒(s) = 1000 毫秒(ms) = 1,000,000 微秒(μs) = 1,000,000,000 纳秒(ns) = 1,000,000,000,000 皮秒(ps)

    1秒 = 1000 毫秒
    = 1000000 微秒
    = 1000000000 毫微秒
    = 1000000000 纳秒
    = 1000000000000 皮秒
    又可表示为:
    1s = 1000 ms
    = 1000000 us
    = 1000000000 ns
    = 1000000000000 ps

    扩展知识:

     中国传统的计数单位有:

    个十百千万亿兆京垓
    分厘毫丝忽微

     至万以后,亿有两种不同的意义,即10万或万万;(现已不用前一意义)
     兆也有两种不同的意义,即百万或亿万;(现两种意义都在使用。)
     类似地,京为千万或兆万;垓为万万或京万。(现已不使用京和垓的单位)。
     即至万以后,有用十进位,但通常是万进位。

     在法定计量单位中,用词头计数:

    十、百、千、兆、吉、太、拍、艾、泽、尧。

     千以前是十进位,千以后是千进位。

    分、厘、毫、微、纳、皮、飞、阿、仄、夭。

    展开全文
  • 而有时候操作的持续时间不到厘秒,但是起始和终止发生在两个相连的厘秒,所以操作时间不到厘秒但是却被记录为厘秒,造成时间记录的不准确。 在Oracle9i之前,最小的时间单位仍然是厘秒,这可以在跟踪文件、v$system_...
  • 0.5MHz时钟用于秒表实际上按厘秒计数。(代码见附件) 第5步:显示模块 这个显示模块有五个输入,板的100MHz时钟,两个时钟模块,开始/停止和复位按钮,以及两个输出,阳极和阴极。该模块还具有秒表如何计算和合并有限...
  • 查询每平均事务数

    千次阅读 2014-08-10 00:18:12
    查询每平均事务数
  • 当满足以下两个条件之一将触发脏数据刷新到磁盘操作: 数据存在的时间超过了dirty_expire_centisecs(默认300厘秒,即30秒)时间; 脏数据所占内存 > dirty_background_ratio,也就是说当脏数据所占用的内存占总内存...
  • 有效监控的 10 条基本原则

    千次阅读 2021-10-07 10:57:16
    本文是从我自己作为站点可靠性工程师的经验中,...例如,Linux 就是这样做的,它跟踪花费的厘秒数,并且不断地计数。如果你想知道特定时间段内的速率,则可以在开始时进行测量,在结束时进行测量,然后减去,然后除..
  • H3C-- GVRP配置

    2021-07-15 16:24:45
    type interface-number - 配置Hold定时器、Join定时器和Leave定时器 garp timer { hold | join | leave }timer-value 可选 缺省情况下,Hold定时器为10厘秒,Join定时器为20厘秒,Leave定时器为60厘秒 需要注意的是...
  • 度量、预警及基线对性能进行监视时,需要使用一些统计...例如,每的物理读取数。可为各种度量设置阈值,当度量的值超过阈值时,就会生成预警。基线包含所存储的度量集和统计信息集。单个集称为快照。基线由两个或...
  • python 练习题目

    万次阅读 多人点赞 2020-02-26 21:11:38
    长度单位: 1 英 寸=2.5400  米    1 英 尺 =12 英 寸 =0.3048 米    1 码 =3 英 尺 =0.9144 米     1 英 里 =1760 码 =1.6093 千 米  ''' L = float ( input ...
  • 会随着spin次数而递增,以厘秒为单位,如1,1,2,2,4,4,8,8,。。。休眠的阀值限制由隐含参数_max_exponential_sleep控制,默认是2秒,如果当前进 程已经占用了别的Latch,则他的休眠时间不会太长(过...
  • riscos_date_time :类似于date_time元组,但末尾具有厘秒 riscos_objtype :文件或目录对象类型 riscos_loadaddr :加载地址 riscos_execaddr :执行地址 riscos_filetype :RISC操作系统文件类型编号 riscos_attr ...
  • SQL Server 注:以下指标取自SQL Server自身提供的性能计数器。 指标名称 指标描述 指标范围 指标单位 1.SQL Server中访问方法...全表扫描/ ...指每全表扫描的数量。全表扫...
  • 1究竟等于多少毫秒?

    万次阅读 2013-04-26 02:39:32
    10的-2次方 | | c  10的-3次方 | 毫 | m  10的-6次方 | 微 | μ  10的-9次方 |纳[诺] | n  10的-12次方 |皮[可] | p  10的-15次方 |飞[母托] | f  10的-18次方 ...
  • Oracle DB Time 解读

    万次阅读 2017-06-21 19:04:21
    IO等待的时间为35287厘秒 7、操作系统层面监控 Device: rrqm/s wrqm/s r/s w/s rkB/s wkB/s avgrq -sz avgqu -sz await svctm % util sdb 0.00 142.00 15.00 230.00 288.00 1116.00 11.46...
  • 资源,不过计算的时候要注意单位是厘秒 (cs) ,乘以 10 可以换算成毫秒。比如平均每秒这个指标值是 782.1 ,表示 ORACLE 消耗了 7821 毫秒 CPU 时间,如果这个系统是一个 16 个 CPU 的系统,那么这个指标可以说明 ...
  • Oracle-锁解读

    千次阅读 2016-11-03 14:13:05
    概念数据库是一个多用户使用的共享资源。当多个用户并发地存取数据时,在数据库中就会产生多个事务同时存取同一数据的情况。若对并发操作不加控制就可能会读取和存储不正确的数据,破坏数据库的一致性。...
  • STP和RSTP详解-配置篇

    千次阅读 多人点赞 2020-05-29 21:08:44
    128 路径开销缺省值的计算方法 Dotlt,即IEEE 802.1t标准 转发延时 1500厘秒 Hello 时间 200厘秒 Max Age Time 2000厘秒 注意:华为S系列的交换机支持STP/RSTP 都有以上缺省配置 二、配置 STP/RSTP基本功能 STP/RSTP...
  • VRRP3协议(RFC 5798)

    千次阅读 2019-08-20 14:21:33
    然而,典型的场景假设很可能涵盖绝大多数部署,主路由器的丢失并不频繁,并且主路由器选举收敛的预期持续时间非常短()。因此,VRRP优化代表了协议设计中的重要简化,同时不会导致短暂的网络退化。 4.配置样本 ...
  • CPU used by this session - This is the amount of CPU time (in 10s of milliseconds) used by a session betw...
  • 时间单位的种类

    2010-03-24 14:03:36
    最近看了一篇STATSPACK报告的解析,发现下面一段有关时间的说明: -> s - second 秒-> cs - centisecond - 100th of a second 厘秒-> ms ...
  • VRRP技术原理

    2021-01-18 17:40:53
    VRRPv3中单位为厘秒,缺省为100厘秒。 Checksum:16位校验和,用于检测VRRP报文中的数据破坏情况。 IP Address/IPv6 Address:备份组虚拟IP地址表项。所包含的地址数定义在Count IP Addrs/Count IPv6 Addrs字段。 ...
  • STP生成树协议

    万次阅读 多人点赞 2018-05-22 13:16:54
    缺省情况下,设备的Forward Delay时间是1500厘秒(15秒)。 stp timer hello 200 //配置设备的Hello Time时间。 缺省情况下,设备的Hello Time时间是200厘秒(2秒)。 stp timer mac - age 2000 //配置...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,141
精华内容 856
关键字:

厘秒