精华内容
下载资源
问答
  • Vaadin 是一款使用 Apache V2 许可协议的开源产品,它由位于芬兰的 IT Mill 公司开发。其前身是 IT Mill 公司由 2000 年起开始研发的 Millstone 用户界面类库。2006 年,IT Mill 公司以 IT Mill Toolkit 作为正式...
    Vaadin 是一款使用 Apache V2 许可协议的开源产品,它由位于芬兰的 IT Mill 公司开发。其前身是 IT Mill 公司由 2000 年起开始研发的 Millstone 用户界面类库。2006 年,IT Mill 公司以 IT Mill Toolkit 作为正式名称发布了它的 Release 4 版本,这个版本中包含了全新的基于 Ajax 的表现层引擎,使开发人员在开发 Ajax 应用程序时无需关注客户端与服务器端的通讯。2007 年末,IT Mill 使用 GWT 技术完全重写了 IT Mill Toolkit 的客户端界面渲染引擎并使用 Apache V2 协议将其开源,版本号为 IT Mill Toolkit Release 5。2009 年春季,为了消除命名的混淆 (IT Mill 是开发企业名称而不应是产品名称 ),IT Mill 以 Vaadin( 芬兰民间传说中的一种神话生物,是女神也是一种山岭驯鹿的神话祖先 ) 作为全新的名称发布了第六个版本,这个版本还提供了 Eclipse 和 Netbeans 插件的辅助开发工具,极大的提高了开发效率。

    [img]http://www.ithov.com/Linux/UploadFiles_1386/201101/2011012521423265.jpg[/img]

    Vaadin 6.x 版包含大量的功能特性,以下为其中最重要的几点:

    ·先进的 UI 组件框架:Vaadin 使用 Java 语言编写服务器端驱动的 UI 组件,包含几十种内建的 UI 组件。可以使用 HTML 模版或 Java 代码动态设置界面组件布局。组件内置有事件 - 监听器模块,可以方便快捷的处理 UI 事件。组件拥有 MVC 设计模式的数据绑定机制以及输入信息校验框架。

    ·可定制的界面外观: Vaadin 使用 CSS 来渲染界面外观样式,支持用户自定义修改或构造全新的程序主题外观。通过使用 GWT 技术,Vaadin 还支持浏览器的 Add-on 特性。

    ·自动化的浏览器 - 服务器通讯: Vaadin 开发的应用程序为单一 Web 页面的应用程序。Vaadin 会自动追踪程序 UI 组件的状态更新,部分的刷新页面内容,并且能够缓存客户端浏览器中页面的 DOM 子树。

    ·优秀的 Web 浏览器兼容性:使用 Vaadin 开发的应用程序不需安装插件即可直接在浏览器中运行,它支持浏览器后退按钮及深链接的使用,并且能够自动处理 URL 参数。

    ·强大的 Web 应用集成能力:Vaadin 可以在任意 JavaEE 兼容的系统中使用,它兼容 Java Servlet API 2.3,并且可以作为 JSR-168 兼容的 portlet 来运行,另外它还可以嵌入在单独的 HTML 或 JSP 页面中。

    ·优化的开发模式:开发 Vaadin 应用程序只需要使用 Java 语言即可,不需要使用 JavaScript 和 XML 配置,整个 Vaadin 运行时环境只需要一个 Jar 文件。

    ·强化的应用程序安全性:Vaadin 使用服务器进行应用程序状态管理,所有的业务逻辑代码均在服务器端运行。使用了双 cookie 提交模式以及双重事件过滤技术,同时拥有非法事件和请求的过滤功能。

    ·良好的集成开发环境 (IDE):Vaadin 拥有 Eclipse 和 Netbeans 的插件,可以在这两个 IDE 中集成应用服务器进行快速开发。生成的应用程序产品为标准的 War 文件。同时还支持使 Firebug 进行调试。

    ·广泛的应用服务器和 Web 浏览器的支持:Vaadin 支持 Java Servlet API 2.3 标准以及 JSR-168 Portlet 规范,可以运行在任何兼容这两个标准的应用服务器上,例如 Tomcat 4.1+,WebLogic 9.2+,WebSphere 6.1+,JBoss3.2.8+,Jetty5+,Glassfish2+ 以及 Liferay Portal4.3+ 等应用服务器。在浏览器方面,Vaadin 支持 IE6、7、8,Firefox 3+, Safari3、4, Opera10 以及 Chrome4+ 等浏览器。

    [img]http://www.ithov.com/Linux/UploadFiles_1386/201101/2011012521423278.jpg[/img]

    更新日志:

    ·Logging - You can now configure logging level with java.util.logging for Vaadin to get rid of unnecessary messages.
    ·GWT 2.1.0 - Update to the latest version of Google Web Toolkit gives you numerous features, optimizations and fixes.
    ·Windows (within a browser window) can now be ordered and their focus can be controlled programmatically.
    ·Chrome frame is now officially a supported browser. Hopefully this helps speeding up old installations of IE6.
    ·Text components can finally be configured to send key-presses immeately back to server

    下载地址:http://vaadin.com/download/release/6.5/6.5.0/vaadin-6.5.0.zip

    本文由风信网络提供 [url]http://www.ithov.com[/url] 欢迎免费转载,转载时请保留该信息,谢谢合作!
    展开全文
  • CANoe C-V2X Demo(V2I+V2V)说明: 此CANoe Demo根据网络层(GB/T31024.3)和应用层(TCSAE 53-2017)利用CANoe Option Car2x的C-V2X协议栈和Car2x场景编辑器以及CAPL编程实现了以下三个场景: 1.V2I场景:绿波车速...

    CANoe C-V2X Demo(V2I+V2V)说明:
    此CANoe Demo根据网络层(GB/T31024.3)和应用层(TCSAE 53-2017)利用CANoe Option Car2x的C-V2X协议栈和Car2x场景编辑器以及CAPL编程实现了以下三个场景:
    1.V2I场景:绿波车速引导(Green Light Otiponal Speed Advisory,GLOSA):
    如MAP窗口所示,交叉路口的交通灯实时周期性广播发送MAP和SPAT消息向周围的车辆广播该交叉路口的地图信息(路段信息、车道信息、转向信息等)、交通灯相位信息。
    主车(DuT节点)接收到MAP消息和SPAT消息后进行解析将重要的信息(交通灯当前相位、剩余时间、与交通灯的距离等)提取显示在面板(Panel)上。
    2.V2V场景:故障车辆(Disabled Vehicle):
    主车(DuT节点)行驶前方有一辆故障车辆(Disabled Vehicle节点),该故障车辆周期性向外广播BSM消息,其中包含故障车辆的事件信息,主车(DuT节点)接收到后进行处理预警,在面板(Panel)上显示相关的事件信息。
    3.V2V场景:紧急制动(Hard Braking):
    在T型路口,有一辆车(SimCar_EVA节点)驶过,主车(DuT节点)的前车发现后进行紧急制动,并发送BSM消息向主车(DuT节点)进行预警,主车(DuT节点)接收到后进行处理预警,适当减速,在面板(Panel)上显示相关的事件信息。

    展开全文
  • RTPS协议以太网报文,版本v2.1,可以用wireshark软件打开,适用于学习RTPSv2报文解析,学习各种工业以太网协议可参考本人其他下载文件
  • 该存储库包含用Rust编写的[Gnosis Protocol V2](TODO高级gpv2链接)的后端代码。 订购书 orderbook箱提供了http api,用户可以通过该api(通常通过前端Web应用程序)与订单进行交互。 用户可以将签名的订单添加到...
  • IEEE1588精密网络同步协议(PTP)-v2.0协议解析1 引言以太网技术由于其开放性好、价格低廉和使用方便等特点,已经广泛应用于电信级别的网络中,以太网的数据传输速度也从早期的10M提高到100M,GE,10GE。40GE,100GE...

    IEEE1588精密网络同步协议(PTP)-v2.0协议解析1 引言

    以太网技术由于其开放性好、价格低廉和使用方便等特点,已经广泛应用于电信级别的网络中,以太网的数据传输速度也从早期的10M提高到100M,GE,10GE。40GE,100GE正式产品也于2009年推出。

    以太网技术是“即插即用”的,也就是将以太网终端接到IP网络上就可以随时使用其提供的业务。但是,只有“同步的”的IP网络才是一个真正的电信级网络,才能够为IP网络传送各种实时业务与数据业务的多重播放业务提供保障。目前,电信级网络对时间同步要求十分严格,对于一个全国范围的IP网络来说,骨干网络时延一般要求控制在50ms之内,现行的互联网网络时间协议NTP (Network Time Protocol),简单网络时间协议SNTP(Simple Network Time Protocol)等不能达到所要求的同步精度或收敛速度。基于以太网的时分复用通道仿真技术(TDM over Ethernet)作为一种过渡技术,具有一定的以太网时钟同步概念,可以部分解决现有终端设备用于以太网的无缝连接问题。IEEE 1588标准则特别适合于以太网,可以在一个地域分散的IP网络中实现微秒级高精度的时钟同步。本文重点介绍IEEE 1588技术及其测试实现。

    2 IEEE 1588PTP介绍

    IEEE 1588PTP协议借鉴了NTP技术,具有容易配置、快速收敛以及对网络带宽和资源消耗少等特点。IEEE1588标准的全称是“网络测量和控制系统的精密时钟同步协议标准(IEEE 1588 Precision Clock Synchronization Protocol)”,简称PTP(Precision Timing Protocol),它的主要原理是通过一个同步信号周期性的对网络中所有节点的时钟进行校正同步,可以使基于以太网的分布式系统达到精确同步,IEEE 1588PTP时钟同步技术也可以应用于任何组播网络中。

    IEEE 1588将整个网络内的时钟分为两种,即普通时钟(Ordinary Clock,OC)和边界时钟(Boundary Clock,BC),只有一个PTP通信端口的时钟是普通时钟,有一个以上PTP通信端口的时钟是边界时钟,每个PTP端口提供独立的PTP通信。其中,边界时钟通常用在确定性较差的网络设备(如交换机和路由器)上。从通信关系上又可把时钟分为主时钟和从时钟,理论上任何时钟都能实现主时钟和从时钟的功能,但一个PTP通信子网内只能有一个主时钟。整个系统中的最优时钟为最高级时钟GMC(Grandmaster Clock),有着最好的稳定性、精确性、确定性等。根据各节点上时钟的精度和级别以及UTC(通用协调时间)的可追溯性等特性,由最佳主时钟算法(Best Master Clock)来自动选择各子网内的主时钟;在只有一个子网的系统中,主时钟就是最高级时钟GMC。每个系统只有一个GMC,且每个子网内只有一个主时钟,从时钟与主时钟保持同步。图1所示的是一个典型的主时钟、从时钟关系示意。

    展开全文
  • 支持苹果、三星、小米等PD协议Type-C充电器取电5V9V12V15v20V。支持20V 5A==100W
  • 动态路由协议 RIP(路由信息协议) 版本:V1 V2 NG(IPV6) RIP:路由信息协议 版本:v1/v2 ipv4 ng ipv6 RIPv1 有类距离矢量型路由协议 RIPv2 无类距离矢量型路由协议 更新机制 V1广播更新 V2组播更新 224.0.0.9 更新...

    动态路由协议 RIP(路由信息协议)
    版本:V1 V2 NG(IPV6)
    RIP:路由信息协议
    版本:v1/v2 ipv4 ng ipv6
    RIPv1 有类距离矢量型路由协议
    RIPv2 无类距离矢量型路由协议

    更新机制 V1广播更新 V2组播更新 224.0.0.9 更新时间30s
    基于UDP 520端口工作;支持等开销负载均衡,默认支持4条,最大6条,IOS版本12.4以上支持16条
    当前拓扑为例
    在这里插入图片描述
    IP地址规划
    R1:
    interface Loopback0
    ip address 1.1.1.1 255.255.255.0
    interface FastEthernet0/0
    ip address 12.1.1.1 255.255.255.0
    R2
    interface Loopback0
    ip address 2.2.2.2 255.255.255.0
    interface FastEthernet0/0
    ip address 12.1.1.2 255.255.255.0
    interface FastEthernet0/1
    ip address 23.1.1.1 255.255.255.0
    R3
    interface Loopback0
    ip address 3.3.3.3 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 23.1.1.2 255.255.255.0

    RIP基本配置
    R1:
    router rip(启用RIP协议)
    version 2(版本2)
    network 1.0.0.0(宣告路由器所在的直连网段)
    network 12.0.0.0
    no auto-summary(关闭自动汇总)
    以下由此类推
    R2:
    router rip
    version 2
    network 2.0.0.0
    network 12.0.0.0
    network 23.0.0.0
    no auto-summary
    R3:
    router rip
    version 2
    network 3.0.0.0
    network 23.0.0.0
    no auto-summary

    效果
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    扩展配置:
    RIPV2扩展配置:
    1、手工汇总
    R2(config)#int s1/1 进入到需要向外发送RIP更新的接口
    R2(config-if)#ip summary-address rip 2.2.2.0 255.255.254.0
    汇总后的路由
    2、认证
    1)明文认证
    先定义钥匙链
    R2(config)#key chain ccnp 创建钥匙链ccnp
    R2(config-keychain)#key 1 定义钥匙1
    R2(config-keychain-key)#key-string cisco 定义密钥
    注:钥匙链可以有多把钥匙 默认只使用编号最小钥匙 且编号和密钥都要一致 才能认证通过
    调用
    R2(config)#interface s1/0
    R2(config-if)#ip rip authentication key-chain ccnp
    2)密文认证
    在明文认证的基础上修改认证模式
    R2(config)#int s1/0
    R2(config-if)#ip rip authentication mode md5
    2、被动接口
    R1(config)#router rip
    R1(config-router)#passive-interface loopback 0
    只接受但不发送RIP更新
    2、加快收敛速度
    R1(config)#router rip
    R1(config-router)#timers basic 15 90 90 120
    更新时间 抑制计时器 超时时间 刷新时间
    全网需要一致
    2、缺省路由
    在边界路由器上下放缺省路由
    R1(config)#router rip
    R1(config-router)#default-information originate
    再一条静态指向ISP
    R1(config)#ip route 0.0.0.0 0.0.0.0 fastethernet 0/0

    展开全文
  • LUR\C2100V3/3000V3/1000V2/LU5000/LUM100V2/LU980 无纸记录仪通信协议V1.5.1
  • 代码遵循Apache v2许可证开源协议。使用。 提示:暂停更新! V1.0.0 可以查询任意城市天气,自由切换城市 可以手动更新天气,拖动刷新即可 V1.0.1 添加城市页面支持查询省,市,县数据,并提供多个选择 添加了更多...
  • 目前,中国区域已经正式发布Azure 应用程序网关标准版 v2 和 WAF v2 SKU, 并支持99.95% SLA (服务协议)。v2 SKU为自动缩放、静态 VIP 提供了额外的支持,这些网关提供了增强的性能、更好的预配、配置更新时间、...
  • RIP协议

    2021-03-02 14:21:44
    异步更新机制 (防环)V1 和V2区别:配置中的问题:v 1 的配置v 2 配置RIP 扩展配置rip(v2)认证 ---在邻居更新收发的接口上,配置相同的密钥,来保证安全性。v2 手工汇总---在更新源设备上,加快收敛 周期更新30s...
  • 高通QC2.0快充协议 分步阅读 高通QC2.0 握手协议: QC 2.0快充的充电器与手机通过micro USB接口中间两线(D+D-)上...此时输出电压为5v,手机正常充电。 若手机支持QC2.0快速充电协议,则Android用户空间的hv...
  • HL7 V2.x.zip

    2020-05-13 10:35:19
    详细包含了hl7 v2.3.1的详细协议规则,包含英文原版和中文翻译版本。资源包含HL7v231英文原版标准;HL7中文翻译资料完整版;HL7执行指南翻译汇总;HL7中文完整版;HL7课程ppt等
  • angular-wamp, 一个用于AutobahnJS的AngularJS库( WAMP v2 ) AngularWAMPAngularWAMP是用于 AutobahnJS ( v 0.9.5 )的AngularJS封装,适用于 WAMP v2 ( Web应用程序消息传递协议) 。它简化了WAMP集成到你的AngularJS...
  • 免费数字证书颁发机构 Let's Encrypt 发布了 ACME v2 协议 API 端点,正式宣布开始测试支持签发通配符数字证书的 ACME V2 版 API 接口。 可以使用以下的目录 URL 开始为你的客户端测试对于 ACME v2 的支持: ...
  • SNMP V1 V2 V3版本的联系和区别

    千次阅读 2016-11-30 16:02:58
    SNMP 是一个协议用来管理网络上的节点,(包括工作站,路由器,交换机,集线器和其他的外围设备)。SNMP是一个应用协议,使用UDP封装进行传输。... 当前,定义了三个版本的网络管理协议,SNMP v1,SNMP v2,SNMP v
  • SNMP V1 V2 V3版本相异点

    2015-03-11 16:03:38
    SNMP 是一个协议用来管理网络上的节点,(包括工作站,路由器,交换机,集线器和其他的外围设备)。SNMP是一个应用协议,使用UDP封装进行传输。... 当前,定义了三个版本的网络管理协议,SNMP v1,SNMP v2,SNMP v
  • 适用于HoshinoBot v2的授权插件,可控制cqhttp的事件过滤器。大部分功能以天枢授权为蓝本而开发。本插件以及带有web服务的页面,如果需要请按照注释开启web。本项目主体框架由,添加了一些重要功能。 本授权系统的...
  • 2、Modbus RTU设备恢复组桢功能I、不需要强制下载或更新系统的人机界面 根据如下标签红色方框内文字,TG/TE/TH系列触摸屏和XMH3系统一体机凡是背面铭牌上标注版本为V2.D.2V及以上版本的,TH系列触摸屏/XMH3系列...
  • Uniswap V2是链上交易所的下一个迭代产品。 Uniswap是Ethereum区块链上的一个链上流动性协议,它可以实现无信任的代币交换,这意味着所有的交易都是由智能合约执行的,而不需要中介或受信任方。这种去中心化的交换...
  • SNMP V1 V2 V3版本的联系和区别 .

    万次阅读 2012-01-31 12:03:33
    SNMP 是一个协议用来管理网络上的节点,(包括工作站,路由器,交换机,集线器和其他的外围设备)。SNMP是一个应用协议,使用UDP封装进行传输。... 当前,定义了三个版本的网络管理协议,SNMP v1,SNMP v2,SNMP v
  • PHP解析Http协议

    2019-10-03 03:48:37
    本文使用PHP解析Http协议 HTTP协议如下,包含两部分:请求头和请求体,我们主要是解析请求头,获取cookie,get,post等信息。 ... ...Date: Sun, 25 Oct 2015 15:43:...Set-Cookie: PHPSESSID=4v2actjf96v614r2kh363...
  • SNMP V1 V2 V3版本的联系和区别 . .

    千次阅读 2013-09-12 15:30:19
    SNMP 是一个协议用来管理网络上的节点,(包括工作站,路由器,交换机,集线器和其他的外围设备)。SNMP是一个应用协议,使用UDP封装进行传输。... 当前,定义了三个版本的网络管理协议,SNMP v1,SNMP v2,SNMP v
  • 从 docker v1.12 开始,docker 就不支持从 HTTP 仓库下载镜像,建立私有仓库必须走 HTTPs 加密协议。本文收集了网上中文、官方资料,总算搞定了自己签名证书的私有仓库。
  • Internet组管理协议

    2008-09-08 02:21:55
    Internet组管理协议 IGMP:Internet Group Management Protocol) Internet 组管理协议(IGMP)是因特网协议家族中的一个组播协议,用于 IP 主机向任一个直接相邻的...IGMP 具有三种版本,即 IGMP v1、v2v...
  • 车载网VANETs的车间通信V2V为车间紧急消息的传递提供了平台。为此,提出了基于网络编码的转发节点协作广播协议NCFMB。NCFMB协议首先利用节点的距离、方向以及局部密度信息计算节点的竞争权值,并择优选择节点作为...
  • DLNA__Guideline UPnP-arch-DeviceArchitecture-v1.0 UPnP-arch-DeviceArchitecture-v2.0 UPnP-av-AVArchitecture-v1 UPnP-av-AVArchitecture-v2
  • Activiti 用户手册5.21Activiti使用 the Apache V2 license 协议开源。 Activiti Modeler(Web设计器)使用了另一个开源协议 the LGPL 2.1 license 。
  • * 支持Flv,mp4,mov,f4v,3gp视频格式播放; * 支持视频分享,支持视频微博(新浪微博/腾讯微博/搜狐微博/网易微博等微博分享); * 支持播放器控制条色彩自定义(红色/黑色/蓝色/绿色/黑色…,万千色彩,由您...

空空如也

空空如也

1 2 3 4 5 ... 10
收藏数 197
精华内容 78
关键字:

v2v协议