精华内容
下载资源
问答
  • H3C DRNI跨设备链路聚合技术白皮书,普通聚合的链路只能够在一台设备上,只能提供链路级的保护,当设备故障以后,普通聚合将无法 工作,所以需要设备级保护的技术。DRNI(Distributed Resilient Network ...
  • linux系统配置网卡链路聚合

    千次阅读 2020-04-09 11:58:53
    title: 网卡链路聚合 tags: linux/network top: true cover: true 链路聚合 场景: 在数据量较大的服务器上,必须确保网络不中断的条件下,建立链路聚合,如果服务器一张网上宕机,另一张网上接替工作,而服务器的...

    网卡链路聚合

    链路聚合

    场景:
     在数据量较大的服务器上,必须确保网络不中断的条件下,建立链路聚合,如果服务器一张网上宕机,另一张网上接替工作,而服务器的地址不变。
    

    一、添加两张网上

    1.在vmware workstation 中为desktop1 添加两张网卡
    

    二、复制模板文件

    1.寻找文件
    cd /usr/share/doc/teamd-1.27/example_ifcfgs/3/
    
    文件:ifcfg-eth1  ifcfg-eth2 ifcfg-team-test0
    
    2.复制文件
    
    cp * /etc/sysconfig/network-scripts/          
    

    三、编辑模板文件

    1.来到网卡配置文件目录下
    cd /etc/sysconfig/network-scripts/
    
    2.查看网卡名称
    ifconfig 
    
    3.将复制过来的两个模板文改为与网卡名称对应的文件
    mv ifcfg-eth1 ifcfg-ens33
    mv ifcfg-eht2 ifcfg-ens38
    
    4.更改两个网卡文件
    vim ifcfg-ens33
    内容:
    DEVICE="ens33
    DEVICETYPE="TeamPort"
    ONBOOT="yes"
    TEAM_MASTER="team_test0"
    
    vim ifcfg-ens38
    内容:
    DEVICE="ens38"
    DEVICETYPE="TeamPort"
    ONBOOT="yes"
    TEAM_MASTER="team_test0"
    
    
    4.更改team_test0文件
    vim ifcfg-team-test0
    内容:
    DEVICE="team_test0"-----设备名
    DEVICETYPE="Team"-----设备类型
    ONBOOT="yes"-----开机自启
    BOOTPROTO=none-----手动指定IP地址
    NETMASK=255.255.255.0-----子网掩码
    IPADDR=192.168.1.234-----IP地址
    TEAM_CONFIG='{"runner": {"name": "activebackup"}}'----策略
    

    四、查看

    nmcli connection show 
    teamdctl team_test0 state    //查看两张网卡的工作状态
    内容:
    setup:
      runner: activebackup
    ports:
      ens33
        link watches:
          link summary: up
          instance[link_watch_0]:
            name: ethtool
            link: up
            down count: 0
      ens38
        link watches:
          link summary: up
          instance[link_watch_0]:
            name: ethtool
            link: up
            down count: 0
    runner:
      active port: ens33				//这里可以看到活动的网卡
    
    
    ifconfig ens33 down    		  //关闭ens33,可以看到ens38会自动接替ens33的工作
    
    展开全文
  • 链路聚合

    千次阅读 2018-03-11 11:07:14
    链路聚合是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。链路聚合能够提高链路带宽,增强网络可用性,支持负载分担。链路聚合有两种模式,一种是手动负载均衡模式,一种是...

    链路聚合是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。


    链路聚合能够提高链路带宽,增强网络可用性,支持负载分担。


    链路聚合有两种模式,一种是手动负载均衡模式,一种是静态lacp模式

    手动负载均衡模式下eth-trunk的建立、成员接口的加入由手工配置,没有链路聚合控制协议的参与。该模式下所有活动链路均参与流量转发,平均分担流量。最多支持8根链路同时转发数据。

    静态lacp模式下,两端设备互相发送lacp报文,进行参数协商,协商完成后,两台设备确定活动接口和非活动接口,活动接口负责转发数据,非活动接口用来实现冗余备份。如果一条活动链路发生故障,则该链路上传输的数据被切换到另一条优先级最高的备份链路上进行转发。

    (1)手动链路聚合配置:

      先通过命令eth-trunk 1创建一个eth-trunk接口 再通过命令trunkport e0/0/0把要聚合的接口添加进eth-trunk接口中

    在eth-trunk接口下通过命令load-balance可以指定负载分担方式是根据原ip和目的ip还是原mac和目的mac

    在eth-trunk接口下通过命令mode X可以选择手动模式还是静态lacp模式

    display eth-trunk X         查看eth-trunk接口的配置信息

    (2)路由器下进行三层接口的lacp链路聚合手动配置:

     静态LACP 模式下,两端设备所选择的活动接口必须保持一致,否则链路聚合组就无法建立

    先通过命令eth-trunk 1创建一个eth-trunk接口然后通过命令undo portswitch关闭路由器的二层接口功能接着在接口下配置ip地址再通过命令trunkport e0/0/0把要聚合的接口添加进eth-trunk接口中 

    在eth-trunk接口下设置最多活动接口           max active-linknumber 2
    查看聚合端口配置                                       display eth-trunk 1
    全局配置模式下设置链路聚合系统优先级     lacp priority 0
    开启接口聚合抢占模式                                lacp preempt enable 
    设置抢占的延时时间(默认为30s)             lacp preempt delay 10

    设置接口优先级                                          lacp priority 0

    链路聚合的每一端都有一个系统优先级,先根据系统优先级来选举主从端。从端根据主端的接口优先级来选择活动接口。系统优先级越低,就成为主动端,当系统优先级一样时就比较MAC地址。当选出主动端后,两端都会以主动端的接口优先级来选举活动接口,接口优先级越低,则成为活动接口。


    展开全文
  • 交换机链路聚合

    万次阅读 2018-04-10 21:41:41
    交换机链路聚合一、 实验目的1、 了解链路聚合技术的使用场合;2、 熟练掌握链路聚合技术的配置。二、 应用环境两个实验室分别使用一台交换机提供20多个信息点,两个实验室的互通通过一根级联网线。每个实验室的...

    交换机链路聚合

    一、       实验目的

    1、  了解链路聚合技术的使用场合;

    2、  熟练掌握链路聚合技术的配置。

    二、       应用环境

    两个实验室分别使用一台交换机提供20多个信息点,两个实验室的互通通过一根级联网线。每个实验室的信息点都是百兆到桌面。两个实验室之间的带宽也是100M,如果实验室之间需要大量传输数据,就会明显感觉带宽资源紧张。当楼层之间大量用户都希望以100M传输数据的时候,楼层间的链路就呈现出了独木桥的状态,必然造成网络传输效率下降等后果。

    解决这个问题的办法就是提高楼层主交换机之间的连接带宽,实现的办法可以是采用千兆端口替换原来的100M端口进行互联,但这样无疑会增加组网的成本,需要更新端口模块,并且线缆也需要作进一步的升级。另一种相对经济的升级办法就是链路聚合技术。

    顾名思义,链路聚合,是将几个链路作聚合处理,这几个链路必须是同时连接两个相同的设备的,这样,当作了链路聚合之后就可以实现几个链路相加的带宽了。比如,我们可以将4100M链路使用链路聚合作成一个逻辑链路,这样在全双工条件下就可以达到800M的带宽,即将近1000M的带宽。这种方式比较经济,实现也相对容易。

    三、       实验设备

    1  DCS-3926S交换机2台

    2  PC机2台

    3  Console线1-2根

    4  直通网线4-8根

    四、       实验拓扑

     

    五、       实验要求

    设备

    IP

    Mask

    端口

    交换机A

    192.168.1.11

    255.255.255.0

    0/0/1-2 trunking

    交换机B

    192.168.1.12

    255.255.255.0

    0/0/3-4 trunking

    PC1

    192.168.1.101

    255.255.255.0

    交换机A0/0/23

    PC2

    192.168.1.102

    255.255.255.0

    交换机B0/0/24

    如果链路聚合成功,则PC1可以ping 通PC2。

    六、       实验步骤

    第一步:正确连接网线,交换机全部恢复出厂设置,做初始配置,避免广播风暴出现

    交换机A:

    switch#config

    switch(Config)#hostname switchA

    switchA(Config)#interface vlan 1

    switchA(Config-If-Vlan1)#ip address 192.168.1.11 255.255.255.0

    switchA(Config-If-Vlan1)#no shutdown

    switchA(Config-If-Vlan1)#exit

    switchA(Config)#spanning-tree

    MSTP is starting now, please wait...........

    MSTP is enabled successfully.

    switchA(Config)#

     

    交换机B:

    switch#config

    switch(Config)#hostname switchB

    switchB(Config)#interface vlan 1

    switchB(Config-If-Vlan1)#ip address 192.168.1.12 255.255.255.0

    switchB(Config-If-Vlan1)#no shutdown

    switchB(Config-If-Vlan1)#exit

    switchB(Config)#spanning-tree

    MSTP is starting now, please wait...........

    MSTP is enabled successfully.

    switchB(Config)#

     

    第二步:创建port group

    交换机A:

    switchA(Config)#port-group 1

    switchA(Config)#

    验证配置:

    switchA#show port-group detail

    Sorted by the ports in the group 1:

    --------------------------------------------

    switchA#show port-group brief

    Port-group number : 1

    Number of ports in port-group : 0   Maxports in port-channel = 8

    Number of port-channels : 0   Max port-channels : 1

     

    switchA#

    交换机B

    switchB(Config)#port-group 2

    switchB(Config)#

    第三步:手工生成链路聚合组(第三、四步任选其一操作)

    交换机A:

    switchA(Config)#interface ethernet 0/0/1-2

    switchA(Config-Port-Range)#port-group 1 mode on

    switchA(Config-Port-Range)#exit

    switchA(Config)#interface port-channel 1

    switchA(Config-If-Port-Channel1)#

    验证配置:

    switchA#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- -------------------

    1    default      Static     ENET      Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

                                           Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

                                           Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23      Ethernet0/0/24

                                           Port-Channel1

    switchA#                                     !port-channel1已经存在

     

    交换机B:

    switchB(Config)#int e 0/0/3-4

    switchB(Config-Port-Range)#port-group 2 mode on

    switchB(Config-Port-Range)#exit

    switchB(Config)#interface port-channel 2

    switchB(Config-If-Port-Channel2)#

    验证配置:

    switchB#show port-group brief

    Port-group number : 2

    Number of ports in port-group : 2   Maxports in port-channel = 8

    Number of port-channels : 1   Max port-channels : 1

     

    switchB#

     

    第四步: LACP动态生成链路聚合组(第三、四步任选其一操作)

    switchA(Config)#interface ethernet 0/0/1-2

    switchA(Conifg-Port-Range)#port-group 1 mode active

    switchA(Config)#interface port-channel 1

    switchA(Config-If-Port-Channel1)#

    验证配置:

    switchA#show vlan

    VLAN Name         Type       Media     Ports

    ---- ------------ ---------- --------- -------------------

    1    default      Static     ENET      Ethernet0/0/3       Ethernet0/0/4

                                           Ethernet0/0/5       Ethernet0/0/6

                                           Ethernet0/0/7       Ethernet0/0/8

                                           Ethernet0/0/9       Ethernet0/0/10

                                           Ethernet0/0/11      Ethernet0/0/12

                                           Ethernet0/0/13      Ethernet0/0/14

                                           Ethernet0/0/15      Ethernet0/0/16

                                           Ethernet0/0/17      Ethernet0/0/18

                                           Ethernet0/0/19      Ethernet0/0/20

                                           Ethernet0/0/21      Ethernet0/0/22

                                           Ethernet0/0/23      Ethernet0/0/24

                                           Port-Channel1

    switchA#                                     !port-channel1已经存在

     

    交换机B:

    switchB(Config)#interface ethernet 0/0/3-4

    switchB(Conifg-Port-Range)#port-group 2 mode passive

    switchB(Config)#interface port-channel 2

    switchB(Config-If-Port-Channel2)#

    验证配置:

    switchB#show port-group brief

    Port-group number : 2

    Number of ports in port-group : 2   Maxports in port-channel = 8

    Number of port-channels : 1   Max port-channels : 1

    switchB#

     

    第九步:使用ping命令验证

        使用PC1 ping PC2

        交换机A

    交换机B

    结果

    原因

    0/0/1

    0/0/2

    0/0/3

    0/0/4

    链路聚合组连接正确

    0/0/1

    0/0/2

    0/0/3

    拔掉交换机B端口4的网线,仍然可以通(需要一点时间),此时用show vlan 看看结果,port-channel消失。只有一个端口连接的时候,没有必要再维持一个port-channel了。

    0/0/1

    0/0/2

    0/0/5

    0/0/6

    等候一小段时间后,仍然是通的。用show vlan看结果。此时把两台交换机的spanning-tree功能disable掉,这时候使用第三步和第四步的结果会不同。采用第四步的,将会形成环路。

     

    七、       注意事项和排错

    1、  为使Port Channel正常工作,Port Channel的成员端口必须具备以下相同的属性:

    a)       端口均为全双工模式;

    b)       端口速率相同;

    c)       端口的类型必须一样,比如同为以太口或同为光纤口;

    d)       端口同为Access端口并且属于同一个VLAN或同为Trunk端口;

    e)       如果端口为Trunk端口,则其Allowed VLAN和Native VLAN属性也应该相同。

    2、  支持任意两个交换机物理端口的汇聚,最大组数为6个,组内最多的端口数为8个。

    3  一些命令不能在port-channel上的端口使用,包括:arp,bandwidth,ip,ip-forward等;

    4  在使用强制生成端口聚合组时,由于汇聚是手工配置触发的,如果由于端口的VLAN信息不一致导致汇聚失败的话,汇聚组一直会停留在没有汇聚的状态,必须通过往该group增加和删除端口来触发端口再次汇聚,如果VLAN信息还是不一致仍然不能汇聚成功。直到VLAN信息都一致并且有增加和删除端口触发汇聚的情况下端口才能汇聚成功;

    5  检查对端交换机的对应端口是否配置端口聚合组,且要查看配置方式是否相同,如果本端是手工方式则对端也应该配置成手工方式,如果本端是LACP动态生成则对端也应该是LACP动态生成,否则端口聚合组不能正常工作;还有一点要注意的是如果两端收发的都是LACP协议,至少有一端是ACTIVE的,否则两端都不会发起LACP数据报;

    6  port-channel一旦形成之后,所有对于端口的设置只能在port-channel端口上进行;

    7  LACP必须和Security和802.1X的端口互斥,如果端口已经配置上述两种协议,就不允许被起用LACP;

    八、       配置序列

    九、       课后练习

    1  使用4根网线做链路聚合,通过插拔线缆观察结果。

    2  把链路聚合组作为交换机之间的trunk链路,实现跨交换机的VLAN。

    十、       相关配置命令详解

    port-group

    命令:port-group <port-group-number> [load-balance { src-mac|dst-mac | dst-src-mac | src-ip| dst-ip|dst-src-ip}]

    no port-group <port-group-number> [load-balance]

    功能: 新建一个port group,并且设置该组的流量分担方式。如果没有指定流量分担方式则为设置默认的流量分担方式。该命令的no操作为删除该group或者恢复该组流量分担的默认值,敲入load-balance表示恢复默认流量分担,否则为删除该组。

    参数:<port-group-number> 为Port Channel的组号,范围为1~16,如果已经存在该组号则会报错。dst-mac 根据目的MAC进行流量分担;src-mac 根据源MAC地址进行流量分担;dst-src-mac 根据目的MAC和源MAC进行流量分担;dst-ip 根据目的IP地址进行流量分担;src-ip 根据源IP地址进行流量分担;dst-src-ip 根据目的IP和源IP进行流量分担。如果是修改流量分担方式,并且该port-group已经形成一个port-channel,则这次修改的流量分担方式只有在下次再次汇聚时才会生效。

    缺省情况:缺省交换机端口不属于Port Channel,不启动LACP协议

    命令模式:交换机全局配置模式

    举例:新建一个port group,并且采用默认的流量分担方式

    Switch(Config)#port-group 1

    删除一个port group

    Switch(Config)#no port-group 1

    port-group mode

    命令:port-group <port-group-number> mode {active|passive|on}

             no port-group <port-group-number>

    功能:将物理端口加入Port Channel,该命令的no操作为将端口从Port Channel中去除

    参数:<port-group-number> 为Port Channel的组号,范围为1~16;active(0) 启动端口的LACP协议,并设置为Active模式;passive(1) 启动端口的LACP协议,并且设置为Passive模式;on(2) 强制端口加入Port Channel,不启动LACP协议。

    命令模式:交换机端口配置模式

    缺省情况:缺省交换机端口不属于Port Channel,不启动LACP协议

    使用指南:如果不存在该组则会先建立该组,然后再将端口加到组中。在一个port-group中所有的端口加入的模式必须一样,以第一个加入该组的端口模式为准。端口以on模式加入一个组是强制性的,所谓强制性的表示本端交换机端口汇聚不依赖对端的信息,只要在组中有2个以上的端口,并且这些端口的vlan信息都一致则组中的端口就能汇聚成功。端口以active和passive方式加入一个组是运行lacp协议的,但两端必须有一个组中的端口是以active方式加入的,如果两端都是passive,端口永远都无法汇聚起来。

    举例:在Ethernet0/0/1端口模式下,将本端口以active模式加入port-group 1

    Switch(Config-Ethernet0/0/1)#port-group 1 mode active

    interface port-channel

    命令:interface port-channel <port-channel-number>

    功能:进入汇聚端口配置模式

    命令模式:全局配置模式

    缺省情况:

    使用指南:进入汇聚端口模式下配置时,如果是对gvrp,spanningtree模块做配置则对汇聚端口生效,如果汇聚端口不存在,也就是说在端口没有汇聚起来时先提示错误信息,记录该用户配置操作,当端口真正汇聚起来以后恢复用户刚才对未形成汇聚端口的配置动作,注意只能恢复一次,如果因为某种原因汇聚组被拆散然后又汇聚起来,用户一开始的配置不能被恢复。如果是对其他模块做配置,比如做shutdown, speed配置,则是对该port-channel对应的port-group中的所有成员端口生效,起到一个群配的作用。

    举例:进入port-channel1 配置模式

    Switch(Config)#interface port-channel 1

    Switch(Config-If-Port-Channel1)#

    show port-group

    命令:show port-group [<port-group-number>] {brief | detail | load-balance | port | port-channel}

    参数:<port-group-number> 要显示的Port Channel的组号,范围为1~16;brief 显示摘要信息;detail 显示详细信息;load-balance 显示流量分担信息;port 显示成员端口信息;port-channel显示汇聚端口信息

    命令模式:特权配置模式

    使用指南:如果没有指定port-group-number则表示显示所有port-group的信息。

    举例:将端口0/0/1和0/0/2加入port-group 1中

    1. 显示交换机的port-group 1的摘要信息。

    Switch#show port-group 1 brief

    Port-group number : 1

    Number of ports in group : 2   Maxports = 8

    Number of port-channels : 0   Max port-channels : 1

    显示内容

    解释

    Number of ports in group

    在port-group中的端口数

    Maxports

    组中最大允许的端口数

    Number of port-channels

    是否已经汇聚成一个汇聚端口

    Max port-channels

    Port-group所能形成的最大汇聚端口数

     

    2. 显示交换机的port-group 1的详细信息。

    Switch# show port-group 1 detail

    Sorted by the ports in the group 1:

    --------------------------------------------

    port Ethernet0/0/1 :

    both of the port and the agg attributes are not equal

    the general information of the port are as follows:

    portnumber: 1             actor_port_agg_id:0  partner_oper_sys:0x000000000000

    partner_oper_key: 0x0001  actor_oper_port_key: 0x0101

    mode of the port: ACTIVE  lacp_aware: enable

    begin: FALSE    port_enabled: FALSE    lacp_ena: FALSE    ready_n: TRUE

     

    the attributes of the port are as follows:

    mac_type: ETH_TYPE  speed_type: ETH_SPEED_10M

    duplex_type: FULL   port_type: ACCESS

     

    the machine state and port state of the port are as the follow

    mux_state: DETCH   rcvm_state: P_DIS   prm_state: NO_PER

    actor_oper_port_state  :  L_A___F_

    partner_oper_port_state:  _TA___F_

     

     

    port Ethernet0/0/2 :

    both of the port and the agg attributes are not equal

    the general information of the port are as follows:

    portnumber: 2             actor_port_agg_id:0  partner_oper_sys:0x000000000000

    partner_oper_key: 0x0002  actor_oper_port_key: 0x0102

    mode of the port: ACTIVE  lacp_aware: enable

    begin: FALSE    port_enabled: FALSE    lacp_ena: TRUE    ready_n: TRUE

     

    the attributes of the port are as follows:

    mac_type: ETH_TYPE  speed_type: ETH_SPEED_100M

    duplex_type: FULL   port_type: ACCESS

     

    the machine state and port state of the port are as the follow

    mux_state: DETCH   rcvm_state: P_DIS   prm_state: NO_PER

    actor_oper_port_state  :  L_A___F_

    partner_oper_port_state:  _TA___F_

    显示内容

    解释

    portnumber

    端口号

    actor_port_agg_id

    该端口加入的channel号,如果由于端口参数与channel的参数不一致导致该端口不能进入channel,显示为0

    partner_oper_sys

    对端的system ID

    partner_oper_key

    对端的operational key

    actor_oper_port_key

    本端的operational key

    mode of the port

    端口加入组的模式

    mac_type

    端口的类型,分标准以太网口和光纤分布式数据接口

    speed_type

    端口的speed类型,分10M和100M口

    duplex_type

    端口的双工类型,分全双工和半双工

    port_type

    端口的vlan属性,分access口和trunk口

    mux_state

    端口绑定状态机的状态

    rcvm_state

    端口收包状态机的状态

    prm_state

    端口发包状态机的状态

     

    3. 显示交换机的port-group 1的显示流量分担信息。

    Switch# show port-group 1 load-balance

    The loadbalance of the group 1 based on src MAC address.

     

    4.显示交换机的port-group 1的成员端口信息。

    Switch# show port-group 1 port

    Sorted by the ports in the group 1 :

    --------------------------------------------

    the portnum is 1

    port Ethernet0/0/1 related information:

     

      Actor part

                         Administrative       Operational

      port number              1

      port priority         0x8000

      aggregator id            0

      port key              0x0100            0x0101

      port state

      LACP activety            .                 1

      LACP timeout             .                 .

      Aggregation              1                 1

      Synchronization          .                 .

      Collecting               .                 .

      Distributing             .                 .

      Defaulted                1                 1

      Expired                  .                 .

     

     

      Partner part

                        Administrative      Operational

      system               000000-000000     000000-000000

      system priority      0x8000             0x8000

      key                  0x0001             0x0001

      port number             1                  1

      port priority        0x8000             0x8000

      port state

      LACP activety           .                  .

      LACP timeout            1                  1

      Aggregation             1                  1

      Synchronization         .                  .

      Collecting              .                  .

      Distributing            .                  .

      Defaulted               1                  1

      Expired                 .                  .

     

      Selected                               Unselected

    显示内容

    解释

    portnumber

    端口号

    port priority

    端口优先级

    system

    system ID

    system priority

    System优先级

    LACP activety

    端口是否以active模式加入组,如果是置1

    LACP timeout

    端口超时方式,如果是短超时置1

    Aggregation

    端口是否可汇聚,如果为0表示该端口为独立端口,不允许参与汇聚

    Synchronization

    端口是否与对端同步

    Collecting

    端口绑定状态机状态是否到达collecting状态

    Distributing

    端口绑定状态机状态是否到达distributing状态

    Defaulted

    本端端口是否使用默认的对端参数

    Expired

    端口收包状态机的状态是否处在expire状态

    Selected

    端口是否已被选择

     

    5.显示交换机的port-group 1的汇聚端口信息。

    Switch# show port-group 1 port-channel

    Port channels in the group 1:

    -----------------------------------------------------------

    Port-Channel: port-channel1

    Number of port : 2      Standby port : NULL

     

    Port in the port-channel :

     

    Index         Port           Mode

    ------------------------------------------------------

    1             Ethernet0/0/1    active

    2             Ethernet0/0/2    active

    显示内容

    解释

    Port channels in the group

    如果不存在port-channel,则不会显示以上打印信息。

    Number of port

    Port-channel中的端口数

    Standby port

    处于standby状态的端口,standby的端口表示虽然端口满足进入channel的条件,但由于总共进入 channel的端口数已经大于最大数,所以将该端口的状态设为standby而不是selected。

     

    debug lacp

    命令:debug lacp

          no debug lacp

    功能:打开交换机的lacp的调试开关;本命令的no操作为关闭该调试开关。

    命令模式:特权配置模式

    缺省情况:缺省关闭交换机的lacp的调试开关。

    使用指南:用来打开交换机lacp调试开关,可以显示交换机处理lacp数据包信息。

    举例:打开lacp调试开关。

    Switch#debug lacp

     

    展开全文
  • 为了保证用户的带宽,当用户量较大时,可以部署多条链路或者链路聚合,达到增加链路带宽的目的,在实现增大带宽目的的同时,链路聚合采用备份链路的机制,可以有效的提高设备之间链路的可靠性。同时在链路之间实现...

    cf0308dd4f000e1f5247d30c84fc3017.gif

    组网需求

    在某小型企业网环境中部署了两台路由器router-1和router-2,router-1作为用户接入设备,router-2作为网络接入设备。为了保证用户的带宽,当用户量较大时,可以部署多条链路或者链路聚合,达到增加链路带宽的目的,在实现增大带宽目的的同时,链路聚合采用备份链路的机制,可以有效的提高设备之间链路的可靠性。同时在链路之间实现负载分担保证业务流量的转发。

    具体实现如下功能:

    1、router-1上接入的用户能够与router-2信息互通。

    2、router-1和router-2之间链路带宽增加,在信息传输过程中能够实现负载分担,达到分流的目的。

    3、router-1和router-2之间其中某条链路Down不影响信息互通,提高链路的可靠性。

    三层链路聚合组网图

    82d18c8f0ed1ab427bd4eaa533ac5c01.png

    步骤1router-1的配置

    sysname router-1

    //将该设备命名为“router-1”

    [router-1]interface Eth-Trunk1

    //进入链路聚合Eth-Trunk1端口视图

    [router-1-Eth-Trunk1]undo portswitch

    //开启改端口三层功能

    [router-1-Eth-Trunk1]ip address 10.1.1.1 255.255.255.0

    //配置该端口IP地址为10.1.1.1 255.255.255.0

    [router-1-Eth-Trunk1]quit

    //退出当前端口视图

    [router-1]interface GigabitEthernet0/0/0 

    //进入链路聚合GigabitEthernet0/0/0 端口视图

    [router-1-GigabitEthernet0/0/0]eth-trunk 1

    //将该端口加入Eth-Trunk1链路聚合组中

    [router-1-GigabitEthernet0/0/0]quit

    //退出当前端口视图

    [router-1]interface GigabitEthernet0/0/1 

    //进入链路聚合GigabitEthernet0/0/1 端口视图

    [router-1-GigabitEthernet0/0/1]eth-trunk 1

    //将该端口加入Eth-Trunk1链路聚合组中

    [router-1-GigabitEthernet0/0/1]quit

    //退出当前端口视图

    [router-1]interface GigabitEthernet0/0/2 

    //进入链路聚合GigabitEthernet0/0/2端口视图

    [router-1-GigabitEthernet0/0/2]eth-trunk 1

    //将该端口加入Eth-Trunk1链路聚合组中

    [router-1-GigabitEthernet0/0/2]return

    //返回到默认视图

    步骤2 router-2的配置

    sysname router-2

    //将该设备命名为“router-2”

    [router-2]interface Eth-Trunk1

    //进入链路聚合Eth-Trunk1端口视图

    [router-2-Eth-Trunk1]undo portswitch

    //开启改端口三层功能

    [router-2-Eth-Trunk1]ip address 10.1.1.2 255.255.255.0

    //配置该端口IP地址为10.1.1.2 255.255.255.0

    [router-2-Eth-Trunk1]quit

    //退出当前端口视图

    [router-2]interface GigabitEthernet0/0/0 

    //进入链路聚合GigabitEthernet0/0/0 端口视图

    [router-2-GigabitEthernet0/0/0]eth-trunk 1

    //将该端口加入Eth-Trunk1链路聚合组中

    [router-2-GigabitEthernet0/0/0]quit

    //退出当前端口视图

    [router-2]interface GigabitEthernet0/0/1 

    //进入链路聚合GigabitEthernet0/0/1 端口视图

    [router-2-GigabitEthernet0/0/1]eth-trunk 1

    //将该端口加入Eth-Trunk1链路聚合组中

    [router-2-GigabitEthernet0/0/1]quit

    //退出当前端口视图

    [router-2]interface GigabitEthernet0/0/2 

    //进入链路聚合GigabitEthernet0/0/2端口视图

    [router-2-GigabitEthernet0/0/2]eth-trunk 1

    //将该端口加入Eth-Trunk1链路聚合组中

    [router-2-GigabitEthernet0/0/2]return

    //返回到默认视图

    步骤3 验证配置结果

    # 在router-1router-2上执行display eth-trunk命令,显示GE0/0/0~GE0/0/3加入到Eth-Trunk 1中。

    [router-1]dis eth-trunk

    Eth-Trunk1's state information is:

    WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP         

    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8              

    Operate status: up          Number Of Up Port In Trunk: 3                     

    --------------------------------------------------------------------

    PortName                      Status      Weight 

    GigabitEthernet0/0/0          Up          1      

    GigabitEthernet0/0/1          Up          1      

    GigabitEthernet0/0/2          Up          1    

    [router-2]dis eth-trunk

    Eth-Trunk1's state information is:

    WorkingMode: NORMAL         Hash arithmetic: According to SIP-XOR-DIP         

    Least Active-linknumber: 1  Max Bandwidth-affected-linknumber: 8              

    Operate status: up          Number Of Up Port In Trunk: 3                     

    --------------------------------------------------------------------

    PortName                      Status      Weight 

    GigabitEthernet0/0/0          Up          1      

    GigabitEthernet0/0/4          Up          1      

    GigabitEthernet0/0/2          Up          1      

    # router-1和router-2能互相Ping通。

    [router-1]ping 10.1.1.2

      PING 10.1.1.2: 56  data bytes, press CTRL_C to break

        Reply from 10.1.1.2: bytes=56 Sequence=1 ttl=255 time=110 ms

        Reply from 10.1.1.2: bytes=56 Sequence=2 ttl=255 time=30 ms

        Reply from 10.1.1.2: bytes=56 Sequence=3 ttl=255 time=20 ms

        Reply from 10.1.1.2: bytes=56 Sequence=4 ttl=255 time=20 ms

        Reply from 10.1.1.2: bytes=56 Sequence=5 ttl=255 time=20 ms

      --- 10.1.1.2 ping statistics ---

        5 packet(s) transmitted

        5 packet(s) received

        0.00% packet loss

        round-trip min/avg/max = 20/40/110 ms

    配置注意事项

    1、一个Eth-Trunk接口中的成员接口必须是以太网类型和速率相同的接口。以太网类型和速率不同的接口不能加入同一个Eth-Trunk接口,如GE接口和FE接口不能加入同一个Eth-Trunk接口。

    2、在手工负载分担模式下,设备支持将GE接口和XGE接口加入同一个Eth-Trunk接口中。加入后,Eth-Trunk各成员接口支持的带宽以其能够承载的带宽上限为准,如GE接口为1G,XGE接口为10G。

    3、如果本端设备接口加入了Eth-Trunk,与该接口直连的对端接口也必须加入EthTrunk,两端才能正常通信。

    4、成员接口不能配置某些业务,例如成员接口不能配置IP地址。

    展开全文
  • eth-trunk链路聚合支持流量本地转发机制和特殊的链路聚合e-trunk。一、Eth-Trunk 支持接口流量本地优先转发(堆叠)1、堆叠设备:将多台设备通过专用的堆叠电缆连接起来,对外呈现为一台逻辑设备。2、跨框 Eth-Trunk ...
  • 1.配置的bond模式为mode1链路聚合模式 2.使用ip addr 查看网卡信息 ip addr #查看网卡信息 需要记录的信息是物理网卡名eth0、eth1 3.如果设备网卡信息比较多,可通过命令 ethtool eth0 #eth0是我的网卡名称 ...
  • 华为防火墙链路聚合

    2021-07-19 19:29:08
    以太网链路聚合:以太网链路聚合eth-trunk简称链路聚合,他通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的目的。同时,这些捆绑在一起的链路通过相互间的动态备份,可以有效提高链路...
  • 一、基本概念如图所示,DeviceA 与DeviceB 之间通过三条以太网物理链路相连,将这三条链路捆绑在一起,就成为了一条逻辑链路,这条逻辑链路的最大带宽等于原先三条以太网物理链路的带宽总和,从而...链路聚合接口...
  • 1. 链路聚合的作用 在原有设备的基础上提高链路带宽,增加可靠性,支持负载分担 需要更多网工学习资料,HCIA/HCIP/HCIE学习视频,可以点击:进入群聊 2. 链路聚合的原理 将多条物理链路聚合在一起当作一条逻辑...
  • 以上值Centos6的bond支持的模式,而在Centos7以后就开始选择team,即链路聚合的方式进行网卡的绑定。Centos7为了向后的兼容依然支持bond模式,目前红帽官方还是将Team作为备选的方案,目前team模式也出来好几年了...
  • 链路聚合的基本概念产生背景随着网络规模的扩大,用户对骨干链路的带宽和可靠性提出了越来越高的要求。在传统技术中,常用更换高速率的接口板或者更换高速率接口板的设备的方式来增加带宽,但这种方案需...
  • MSTP+链路聚合实验

    千次阅读 2020-02-29 18:05:52
    链路聚合一般用来连接一个或多个带宽需求大的设备,例如连接骨干网络的服务器或服务器群。 端口汇聚是将多个端口汇聚在一起形成一个汇聚组,以实现出/入负荷在汇聚组中各个成员端口中的分担,同时也提供了更高的...
  • 如图1所示,M-LAG是将ServerA(可以是设备或主机)与另外两台设备DeviceA和DeviceB进行跨设备链路聚合,如同ServerA和一台设备建立了链路聚合关系,从而把链路可靠性从单板级提高到了设备级。 目的 传统的聚合...
  • bond可以将多块网卡虚拟成为一块网卡,让多块网卡聚合后,看起来是一个单独的以太网接口设备并具有相同的 IP 地址。既能添加网络带宽,同时又能做相应的冗余,轮询和负载均衡。 bond 网卡的工作模式 网卡 bond 后...
  • 群晖的链路聚合(Link Aggregation)技术是针对于 Synology NAS 支持多 LAN 口的产品的一种技术,简单来说就是具备多个网络接口的群晖 NAS 支持链路聚合链路聚合简单理解就是把多个接口的带宽聚合在一起行成了类似 ...
  • 以太网链路聚合简介

    2021-03-16 20:02:44
    以太网链路聚合简介一、以太网链路聚合定义二、使用步骤三、用途 一、以太网链路聚合定义 以太网链路聚合Eth-Trunk简称链路聚合,它通过将多条以太网物理链路捆绑在一起成为一条逻辑链路,从而实现增加链路带宽的...
  • H3C 链路聚合

    千次阅读 2019-07-11 12:42:20
    端口聚合技术又称为快速以太网通道,通过增加链路条数来增加链路带宽,同时也可以增加链路的冗余性(即一条链路出现故障,另一条链路仍能继续工作,防止网络中断)。 实验设备: 两台H3C三层交换机,两条绞线。 ...
  • 软路由连接NAS做链路聚合

    千次阅读 2021-01-17 15:43:41
    群晖NAS支持多种链路聚合方式,如自适应负载平衡、IEEE 802.3ad动态Link Aggregation、平衡XOR等方式,其中,IEEE 802.3ad动态Link Aggregation模式需要第三方网络设备支持。 注意: 链路聚合功能在原版OpenWRT和较...
  • CentOS7 配置聚合链路

    千次阅读 热门讨论 2021-03-26 15:40:50
    一、聚合链路概述 作用:将主机的多块网卡通过逻辑的方式聚合在一起,目的是为了加大带宽、冗余备份。 聚合链路的几种状态: active-backup:一个端口处于主状态,一个处于从状态,所有流量都在主链路上处理,从...
  • 堆叠+链路聚合+OSPF

    2021-10-04 17:54:21
    inter loopback 0 ip addr 3.3.3.3 32 [swa]router id 3.3.3.3 [swa]ospf 1 area 1 network 3.3.3.3 0.0.0.0 network 192.168.255.6 0.0.0.3 network 10.0.0.0 0.0.0.255 display irf 显示本堆叠中所有设备的预配置...
  • ubuntu18.04设置链路聚合

    千次阅读 2020-11-19 16:28:13
    多网卡聚合把多个网络端口绑定到一个IP地址,可以提高网络总带宽和容错能力。 Ubuntu 18.04使用了netplan来管理网络,跟以前版本差别很大。以前版本修改/etc/network/interfaces的方法不再管用,设置多网卡聚合的 ...
  • 链路聚合(cisco、华为)

    千次阅读 2019-09-24 20:17:30
    背景:当交换机与交换机,服务器与服务器,交换机和服务器之间有的时候中间带宽会存在不足的情况-----链路聚合或者链路捆绑。 因为当我们在交换机与交换机增加线路时会出现环路,默认情况下CISCO启用了STP技术(会...
  • 文章目录VRRP的概述VRRP的作用虚拟路由器Master报文的发送VRRP状态机VRRP华为命令配置链路聚合命令 VRRP的概述 1.利用VRRP,一组路由器(同一个LAN中的接口),协同工作,但是只有一个处于Master状态,处于该状态的...
  • 华为S5700交换机链路聚合配置

    千次阅读 2019-04-27 21:44:19
    运行环境:公司这边有2层楼 分别运行着不同的业务 本来两个楼层的网络是...那又为什么要用配链路聚合呢(应为一根网线不够用啊) 原来的运行方式:2台S5700分别配置Eth-Trunk1 分别将需要通信的3条线路的端口加入Eth-...
  • 一、 LACP简介1、LACP协议简介基于 IEEE802.3ad 标准的LACP(Link Aggregation Control Protocol,链路汇聚控制协议)是一种实现链路动态汇聚与解汇聚的协议。LACP 协议通过LACPDU(Link Aggregation Control ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 5,289
精华内容 2,115
关键字:

双设备双链路聚合