精华内容
下载资源
问答
  • 以上目的便可实现负载均衡,同时当线路故障时可自动切换到另一条完好的线路,达到冗余备份的目的。 注意:当电信联通线路同时断掉时,就没辙了,不过这种几率很小,这里不做考虑。 本次过程用真机在真实环境中...

    现有条件:cisco2811路由器一台(插板卡,一共四个FE口)
    一根电信线路:48.210.41.170/30 (假设)
    一根联通线路:25.220.87.160/30 (假设)
    假设公司有192.168.8.0/24 192.168.9.0/24 192.168.10.0/24 192.168.11.0/24
    四个内网网段。

    想要实现目的:
    ①.192.168.8.0/24;192.168.9.0/24上外网默认走电信;
    ②.192.168.10.0/24;192.168.11.0/24上外网默认走联通
    ③.当电信线路断掉时,原本走电信的192.168.8.0/24和192.168.9.0/24能自动切换到联通线路。
    ④.当联通线路断掉时,原本走联通的192.168.10.0/24和192.168.11.0/24能自动切换到电信线路。
    以上目的便可实现负载均衡,同时当线路故障时可自动切换到另一条完好的线路,达到冗余备份的目的。
    注意:当电信联通线路同时断掉时,就没辙了,不过这种几率很小,这里不做考虑。

    本次过程用真机在真实环境中搭建,并完全实现上述功能,就不浪费时间在模拟器实验了,直接手写配置好了。

    拓扑:L3----R1-----因特网
    假设四个网段均在L3上
    R1的f0/0/0口作为连接网段与L3连接。
    连接网段10.100.100.2/30
    关键配置都在R1上,L3就写条默认路由指向R1

    路由器hostname:R1
    R1:
    interface f0/0
    description
    ip address 48.210.41.170 255.255.255.252
    no shut

    interface f0/1
    description
    ip address 25.220.87.160 255.255.255.252
    no shut

    interface f0/0/0
    description
    ip address 10.100.100.2
    ip policy route-map INTERNET
    no shut

    ip nat inside source route-map NAT_CT_2_CT interface FastEthernet0/0 overload
    ip nat inside source route-map NAT_CT_2_CU interface FastEthernet0/1overload
    ip nat inside source route-map NAT_CU_2_CT interface FastEthernet0/0overload
    ip nat inside source route-map NAT_CU_2_CU interface FastEthernet0/1overload
    //这里如果只写两条包含所有网段的列表分别应用在两个接口下的话,会一直走电信线路(亲测)所以用route-map调用列表分别做NAT。

    ip route 192.168.8.0 255.255.255.0 10.100.100.1 //l路由回指
    ip route 192.168.9.0 255.255.255.0 10.100.100.1 //l路由回指
    ip route 192.168.10.0 255.255.255.0 10.100.100.1 //l路由回指
    ip route 192.168.11.0 255.255.255.0 10.100.100.1 //l路由回指
    注意:可以不用写默认路由
    ip next-hop > 普通明细路由 > ip default next-hop > 默认路由

    ip access-list extended TO_CT
    permit ip 192.168.8.0 0.0.0.255 any
    permit ip 192.168.9.0 0.0.0.255 any
    ip access-list extended TO_CU
    permit ip 192.168.10.0 0.0.0.255 any
    permit ip 192.168.11.0 0.0.0.255 any
    //电信联通分开

    ip sla 1
    icmp-echo 48.210.41.169 source-interface FastEthernet0/0
    frequency 10
    ip sla schedule 1 life forever start-time now
    ip sla 2
    icmp-echo 25.220.87.159 source-interface FastEthernet0/1
    frequency 10
    ip sla schedule 2 life forever start-time now

    track 1 ip sla 1

    track 2 ip sla 2
    //sla与tracek关联,检测电信和联通线路是否故障,形成故障切换条件。

    route-map INTERNET permit 10
    match ip address TO_CT
    set ip next-hop verify-availability 48.210.41.169 10 track 1
    set ip next-hop verify-availability 25.220.87.159 20 track 2
    set ip next-hop 48.210.41.169 25.220.87.159
    !
    route-map INTERNET permit 12
    match ip address TO_CU
    set ip next-hop verify-availability 25.220.87.159 10 track 2
    set ip next-hop verify-availability 48.210.41.169 20 track 1
    set ip next-hop 25.220.87.159 48.210.41.169
    //判断下一跳是否可达,与track关联,ip next-hop后面加电信和联通的网关

    route-map NAT_CT_2_CT permit 10
    match ip address TO_CT
    match interface FastEthernet0/0
    !
    route-map NAT_CU_2_CU permit 10
    match ip address TO_CU
    match interface FastEthernet0/1
    !
    route-map NAT_CT_2_CU permit 10
    match ip address TO_CT
    match interface FastEthernet0/1
    !
    route-map NAT_CU_2_CT permit 10
    match ip address TO_CU
    match interface FastEthernet0/0
    //NAT中的route-map,需要注意的是一定要match对应的接口。

    结果:将电信线路断掉,192.168.8.0/192.168.9.0会自动切换到联通线路,然后将电信线路插回去,192.168.8.0/192.168.9.0会自动切换走电信线路,联通同理,完美!
    这样不管哪条线路出现什么问题,都能自动完成切换。
    PS:在L3上,一条默认路由 ip route 0.0.0.0 0.0.0.0 10.100.100.2即可。

    展开全文
  • 一个网段内,IP地址(末位奇数)走电信,IP地址(末位偶数)走联通当某个运营商不可达时,自动切换。通过NQA来确定运营商是否可达。,并与流行为、静态路由联动,实现自动切换。默认路由走电信,当电信不可达走联通(根据...

    一个网段内,IP地址(末位奇数)走电信,IP地址(末位偶数)走联通

    当某个运营商不可达时,自动切换。

    通过NQA来确定运营商是否可达。,并与流行为、静态路由联动,实现自动切换。

    默认路由走电信,当电信不可达走联通(根据配置的路由优先级,华为交换机静态路由默认优先级为60).

    acl number 3001

    description dan-dianxin

    rule 10 permit ip source 10.50.8.1 0.0.3.254

    acl number 3002

    description shuang-liantong

    rule 10 permit ip source 10.50.8.0 0.0.3.254

    #

    traffic classifier SSR2 operator or

    if-match acl 3002

    traffic classifier SSR1 operator or

    if-match acl 3001

    traffic behavior SSR1

    redirect ip-nexthop 27.191.229.129 track nqa xxf dan

    traffic behavior SSR2

    redirect ip-nexthop 60.2.202.149 track nqa xxf shuang

    //若不用NQA,只能保证路由器直连链路断掉后的路由自动切换,无法保证运营商内部的问题导致的断网被检测出来。

    #

    traffic policy SSR

    classifier SSR1 behavior SSR1

    classifier SSR2 behavior SSR2

    nqa test-instance xxf dan

    test-type icmp

    destination-address ipv4 1.1.1.2       //电信侧 测试用服务器IP

    frequency 5

    probe-count 1

    start now

    nqa test-instance xxf shuang

    test-type icmp

    destination-address ipv4 2.2.2.2     联通侧 测试用服务器IP

    frequency 5

    probe-count 1

    start now

    ip route-static 0.0.0.0 0.0.0.0 27.191.229.129 track nqa xxf //NQA联动,保持默认路由的有效性,当电信不可达时,此条路由自动失效,下条默认路由生效

    ip route-static 0.0.0.0 0.0.0.0 60.2.202.149 preference 100

    ip route-static 1.1.1.0 255.255.255.0 27.191.229.129  //到达电信公网某服务器(比如DNS服务器),(若没有这一条,比如电信网断了,默认路由切到了联通,,若电信网恢复了,设备由于路由问题,走电信的NQA测试依然无法测通与电信的连接,仍然认为电信不可达,还会走联通),从而无法自动切回去。作用:保持NQA测试的可用性

    ip route-static 2.2.2.0 255.255.255.0 60.2.202.149  到达联通公网某服务器,作用:在默认走电信的情况下,保持走联通的NQA测试的可用性

    ip route-static 10.50.8.0 255.255.254.0 10.50.8.254 //回指路由

    其他配置

    出端口NAT

    acl number 3000

    description NAT

    rule 10 permit ip source 10.50.8.0 0.0.3.255

    interface GigabitEthernet0/0/0

    ip address 27.191.229.133 255.255.255.128

    nat outbound 3000

    #

    interface GigabitEthernet0/0/1

    ip address 60.2.202.150 255.255.255.252

    nat outbound 3000

    #

    interface GigabitEthernet0/0/2

    traffic policy SSR inbound

    ip address 10.50.8.253 255.255.255.252

    备注:eNSP真垃圾,本来想放拓扑的,结果保存不了,,设备无法启动!!1

    展开全文
  • 域名线路智能负载均衡出现的原因:由于电信和网通分家之后,双方成为国内宽带运营商两大巨头,长江以北几乎都是网通的天下,而反之南方几乎是电信的天下。他们之间彼此成为同一等级的竞争对手;由于两间公司的经营...

    域名双线路智能负载均衡出现的原因:
    由于电信和网通分家之后,双方成为国内宽带运营商两大巨头,长江以北几乎都是网通的天下,而反之南方几乎是电信的天下。他们之间彼此成为同一等级的竞争对手;由于两间公司的经营策略问题,导致电信与网通之间的通讯速率不顺畅,这就是日常人们经常所提及的南北不互通问题。
    为了使得不同线路的用户获得较快的访问速度,现时市面上出现一种同时能拥有电信和网通线路的接入通讯线路,卖点就在于它能同时给电信、网通等线路通讯给予非常好的支持,不过这种接入线路价格非常昂贵,目前仅应用于主机托管业务上。
    为了用户能更好地对外服务,减少访问者等待解释时间和解析超时情况出现,也能感受到花生壳带来的增值服务,现推出域名记录自动均衡网通、电信线路的功能,帮助访问者能更加快速地访问到用户的服务器。但是,前提是您必须同时拥有电信、网通的固定IP地址以及对应服务器。

    在开始之前,先备课
    在注册和使用域名的时候都有下面对域名所有的记录存在过疑问罢?
    A记录?MX记录?CNAME记录?它们都有些什么用途?
    虚拟空间,域名解析,A记录,MX记录,CNAME记录,TTL 等 更多Web服务器相关名词解释: http://www.ad0.cn/netfetch/article.asp?id=499

    URL (Uniform Resource Locator )转发:网址转发
    功能:如果您没有一台独立的服务器(也就是没有一个独立的IP地址)或者您还有一个域名B,您想访问A域名时访问到B域名的内容,
    这时您就可以通过URL转发来实现。url转发可以转发到某一个目录下,甚至某一个文件上。也就是说,可以使用该功能把当前域名指向到互联网上任意可以用URL到达的地方。


    域名双线路智能负载均衡介绍(原理图如下):
    当用户申请的域名(xxx.vicp.net)绑定了两条线路上的ip(电信/网通)。只要稍做修改(修改方法见下文),就能通过花生壳的DNS服务器,自动判别访问请求者的ip所在的线路(电信/网通)解释并返回对应线路的服务器ip,做到网通的用户就访问服务器网通的ip,电信的用户就访问服务器电信的ip。(当然,如果用户的域绑定了多条线路上的ip,但是没有相应修改,所有的访问都会被解释为电信的ip的)
    例如:
    访问http://www.skycn.com,出现的第一页面就是要选择对应的线路服务器去访问,以达到快速访问的目的。(现在花生壳的DNS服务器帮用户做出最快的选择)
    又例如:
    访问http://www.mydrivers.com/首次访问的时候也是要用户选择对应的线路的。但是my drivers更加有一个自动选择的按钮,让服务器决定那个比较快的线路。(现在花生壳的DNS服务器把用户点击“自动选择”这一步都节省了)

    域名双线路智能负载均衡原理图
    点击在新窗口中浏览此图片

    域名双线路智能负载均衡操作方法:

    一、申请花生壳域名

    1、 注册花生壳护照
    点击在新窗口中浏览此图片
    打开Oray的主页(http://www.oray.net/),在左边的“我的控制台”下面点击“免费注册”,之后填上相关资料后就可以得到一个花生壳的护照了。

    2、 注册Oray所提供的免费域名
    点击在新窗口中浏览此图片

    使用第一步所建立的护照,点击屏幕右上的“我的控制台”
    点击在新窗口中浏览此图片

    进入“我的控制台”之后点击“申请免费域名”
    点击在新窗口中浏览此图片

    然后就注册你自己想要的免费域名,有多种组合可供选择。
    完成之后记得去激活这个免费的花生壳域名
    点击在新窗口中浏览此图片

    我的控制台 -> 域名管理 -> 花生壳管理 -> 点一下刚才注册的域名 -> 点击右边的“激活花生壳域名”按钮。
    完成以上步骤之后就能得到一个终身完全免费的花生壳域名了。当然还要记得去下载并且安装花生壳客户端哦~!
    下载地址: http://www.oray.net/PeanutHull/PeanutHull_Download.htm

    二、启用域名记录自动均衡网通、电信功能
    1、        找到“域名管理”
    点击在新窗口中浏览此图片
    点击我的控制台 -> 域名管理 -> 免费域名 -> A记录
    (注意:如果不取消花生壳服务器或者设置了CNAME或URL转发的话,此处的“A记录”是不可用的)

    2、        为域名绑定ip设置A记录
    点击在新窗口中浏览此图片
    这里是当前的A记录,默认为电信线路的ip,如果您有多个IP地址,请添加到“IP地址”栏上,完成后按添加;当然,如果不需要该ip的时候,也可以按删除来删除记录。
    (注意:这里添加的A记录是默认是用户服务器上电信线路的ip,在不设置下面所介绍的网通A记录功能时,全球访问该域名的用户都被解析到电信IP上)

    3、添加用户服务器上不同线路ip的A记录
    点击在新窗口中浏览此图片
    如果填上ip的时候如果选择电信,则你所填的ip将会被电信网络里面的用户所访问
    点击在新窗口中浏览此图片
    如果填上ip的时候如果选择网通,则你所填的ip将会被网通网络里面的用户所访问
    (注意:要分清楚手上的IP是电信还是网通的,不然的话两边访问都会很慢的哦。若来源IP地址非网通也非电信,Oray将其默认分配到您的电信线路IP上)

    4、恭喜!完成以上步骤之后,就能实现电信网通用户访问自动分流,无论是电信,还是网通的用户,都能快速地访问用户的服务器啦!

    按照以上操作解决了"单域名双服务器双线路双Ip(甚至双机房)"的问题,无需成本,适合中小型网站使用!

    域名双线路智能负载均衡的实现方案
    转载请保留本文链接:http://www.ad0.cn/netfetch/read.php/1072.htm
    原文来自:http://www.ad0.cn/netfetch/read.php/1072.htm
    展开全文
  • 实验环境: GNS3 1.0 + i86bi-linux-l3-adventerprisek9-15.4.1T拓扑中R4、R5分别模拟不同运营商(ISP_A和ISP_B)的两台路由,经过运营商的链路到达因特网中的R2,R2的lo0端口模拟网站服务器R3模拟本地PC,其中e0/0...

    20140813160945.png

    实验环境:

     

    • GNS3 1.0 + i86bi-linux-l3-adventerprisek9-15.4.1T拓扑中

    • R4、R5分别模拟不同运营商(ISP_A和ISP_B)的两台路由,经过运营商的链路到达因特网中的R2,R2的lo0端口模拟网站服务器

    • R3模拟本地PC,其中e0/0口和lo0口分别模拟两台不同网段的pc

    • R1为本地边界路由,需要在此路由上做双出口的策略及NAT,默认adventerprisek9-15.4.1T 设备的内存较小,实验中会报错,所以请先更改R1的内存

    20140813112359.png

    实验目的:

     

    通过策略路由后对不同原地址数据流量进行分流,使得不同原地址主机通过不同ISP接口访问Internet,并为不同原地址主机同不同NAT地址进行转换。

    当网络链接正常时,网段1(172.16.1.0/24)通过ISP_A到达2.2.2.2,,网段2(172.16.2.0/24)通过 ISP_B到达2.2.2.2 ,达到负载均衡的目的。当ISP_A或ISP_B其中一条链路出现故障时,能实现自动切换达到备份目的。

     

    知识点:
    思科路由器一般不用作nat,因为CPU利用率太高。但如果小型企业在内网用户数不多的情况下,防火墙成本较高,如果以现有路由器作上网设备,也是一个经济的选择。在适当的配置下,还能实现灵活的路由策略及nat策略。以下介绍相关的配置命令及实现方法。
    NAT相关的配置命令工具介绍。
    1、ACL
    ACL是用来定义内网上网用户的工具,可以是标准ACL,也可以是扩展ACL;当需要使用到route-map时,它是定义地位范围的工具。
    2、route-map
    route-map是灵活控制路由策略及NAT策略的有力工具。
    3、NAT配置策略
    接口命令:ip nat inside、ip nat outside
    全局命令:ip nat inside source route-map interface int_name overlaod
    4、路由配置策略
    接口命令:ip policy route-map name

     

    实验步骤:

     

    一  、按照拓扑配置各路由接口IP和路由协议,其中R4、R5、R2运行OSPF area0 ,R2的回环地址2.2.2.2作为internet的服务器做测试使用。

     

    配置R3:

     

    R3(config)#interface e0/0

    R3(config-if)#ip address 172.16.1.3 255.255.255.0

    R3(config-if)#no sh

    R3(config-if)#interface lo0

    R3(config-if)#ip address 172.16.2.3 255.255.255.0

    R3(config-if)#

    R3(config)#ip route 0.0.0.0 0.0.0.0 172.16.1.1

     

    配置R1:

     

    R1(config)#interface e0/0

    R1(config-if)#description to LAN

    R1(config-if)#ip address 172.16.1.1 255.255.255.0

    R1(config-if)#no sh

    R1(config-if)#interface s1/0

    R1(config-if)#description to ISP_B

    R1(config-if)#ip address 15.1.1.1 255.255.255.0

    R1(config-if)#no sh

    R1(config-if)#interface s1/1

    R1(config-if)#description to ISP_A

    R1(config-if)#ip address 14.1.1.1 255.255.255.0

    R1(config-if)#no sh

    R1(config-if)#exit

    R1(config)#ip route 0.0.0.0 0.0.0.0 14.1.1.4

    R1(config)#ip route 0.0.0.0 0.0.0.0 15.1.1.5

    R1(config)#ip route 172.16.2.0 255.255.255.0 172.16.1.3   ###到达LAN 172.16.2.0的回程路由

    R1(config)#

     

    配置R4:

     

    R4(config)#interface s1/1

    R4(config-if)#ip address 24.1.1.4 255.255.255.0

    R4(config-if)#no sh

    R4(config-if)#interface s1/0

    R4(config-if)#ip address 14.1.1.4 255.255.255.0

    R4(config-if)#no sh

    R4(config-if)#exit

    R4(configf)#router ospf 4

    R4(config-router)#network 0.0.0.0 255.255.255.255 area 0

     

    配置R5:

     

    R5(config)#interface s1/0

    R5(config-if)#ip address 25.1.1.5 255.255.255.0

    R5(config-if)#no sh

    R5(config-if)#interface s1/1

    R5(config-if)#ip address 15.1.1.5 255.255.255.0

    R5(config-if)#no sh

    R5(config-if)#exit

    R5(config)#router ospf 5

    R5(config-router)#network 0.0.0.0 255.255.255.255 area 0

     

    配置R2:

     

    R2(config)#interface lo0

    R2(config-if)#ip address 2.2.2.2 255.255.255.255

    R2(config-if)#interface s1/0

    R2(config-if)#ip address 24.1.1.2 255.255.255.0

    R2(config-if)#no sh

    R2(config-if)#interface s1/1

    R2(config-if)#ip address 25.1.1.2 255.255.255.0

    R2(config-if)#no sh

    R2(config-if)#exit

    R2(config)#router ospf 2

    R2(config-router)#network 0.0.0.0 255.255.255.255 area 0

    R2(config-router)#

    *Aug 13 10:58:47.840: %OSPF-5-ADJCHG: Process 2, Nbr 25.1.1.5 on Serial1/1 from LOADING to FULL, Loading Done

    *Aug 13 10:58:47.841: %OSPF-5-ADJCHG: Process 2, Nbr 24.1.1.4 on Serial1/0 from LOADING to FULL, Loading Done

     

    二  、验证基本配置

     

    R3:

     

    R3#show ip interface br

    R3#show ip interface brief

    Interface                  IP-Address      OK? Method Status                Protocol

    Ethernet0/0                172.16.1.3      YES manual up                    up

    Ethernet0/1                unassigned      YES unset  administratively down down

    Ethernet0/2                unassigned      YES unset  administratively down down

    Ethernet0/3                unassigned      YES unset  administratively down down

    Loopback0                  172.16.2.3      YES manual up                    up

     

    R3#show ip route

    Gateway of last resort is 172.16.1.1 to network 0.0.0.0

    S*    0.0.0.0/0 [1/0] via 172.16.1.1

    172.16.0.0/16 is variably subnetted, 4 subnets, 2 masks

    C        172.16.1.0/24 is directly connected, Ethernet0/0

    L        172.16.1.3/32 is directly connected, Ethernet0/0

    C        172.16.2.0/24 is directly connected, Loopback0

    L        172.16.2.3/32 is directly connected, Loopback0

    R3#

     

     

    R1:

     

    R1#show ip interface brief

    Interface                  IP-Address      OK? Method Status                Protocol

    Ethernet0/0                172.16.1.1      YES manual up                    up

    Ethernet0/1                unassigned      YES unset  administratively down down

    Ethernet0/2                unassigned      YES unset  administratively down down

    Ethernet0/3                unassigned      YES unset  administratively down down

    Serial1/0                  15.1.1.1        YES manual up                    up

    Serial1/1                  14.1.1.1        YES manual up                    up

    Serial1/2                  unassigned      YES unset  administratively down down

    Serial1/3                  unassigned      YES unset  administratively down down

     

    R1#show ip route

    Gateway of last resort is 15.1.1.5 to network 0.0.0.0

    S*    0.0.0.0/0 [1/0] via 15.1.1.5

    [1/0] via 14.1.1.4

    14.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C        14.1.1.0/24 is directly connected, Serial1/1

    L        14.1.1.1/32 is directly connected, Serial1/1

    15.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C        15.1.1.0/24 is directly connected, Serial1/0

    L        15.1.1.1/32 is directly connected, Serial1/0

    172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks

    C        172.16.1.0/24 is directly connected, Ethernet0/0

    L        172.16.1.1/32 is directly connected, Ethernet0/0

    S        172.16.2.0/24 [1/0] via 172.16.1.3

    R1#

     

    R4:

     

    R4#show ip ospf neighbor

     

    Neighbor ID     Pri   State           Dead Time   Address         Interface

    2.2.2.2           0   FULL/  -        00:00:38    24.1.1.2        Serial1/1

     

    R4#show ip route

    Gateway of last resort is not set

    2.0.0.0/32 is subnetted, 1 subnets

    O        2.2.2.2 [110/65] via 24.1.1.2, 00:09:27, Serial1/1

    14.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C        14.1.1.0/24 is directly connected, Serial1/0

    L        14.1.1.4/32 is directly connected, Serial1/0

    15.0.0.0/24 is subnetted, 1 subnets

    O        15.1.1.0 [110/192] via 24.1.1.2, 00:09:17, Serial1/1

    24.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C        24.1.1.0/24 is directly connected, Serial1/1

    L        24.1.1.4/32 is directly connected, Serial1/1

    25.0.0.0/24 is subnetted, 1 subnets

    O        25.1.1.0 [110/128] via 24.1.1.2, 00:09:27, Serial1/1

     

    R5:

     

    R5#show ip ospf neighbor

     

    Neighbor ID     Pri   State           Dead Time   Address         Interface

    2.2.2.2           0   FULL/  -        00:00:39    25.1.1.2        Serial1/0

     

    R5#show ip route

    Gateway of last resort is not set

    2.0.0.0/32 is subnetted, 1 subnets

    O        2.2.2.2 [110/65] via 25.1.1.2, 00:12:50, Serial1/0

    14.0.0.0/24 is subnetted, 1 subnets

    O        14.1.1.0 [110/192] via 25.1.1.2, 00:12:40, Serial1/0

    15.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C        15.1.1.0/24 is directly connected, Serial1/1

    L        15.1.1.5/32 is directly connected, Serial1/1

    24.0.0.0/24 is subnetted, 1 subnets

    O        24.1.1.0 [110/128] via 25.1.1.2, 00:12:50, Serial1/0

    25.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C        25.1.1.0/24 is directly connected, Serial1/0

    L        25.1.1.5/32 is directly connected, Serial1/0

     

    R2:

     

    R2#show ip ospf neighbor

    Neighbor ID     Pri   State           Dead Time   Address         Interface

    25.1.1.5          0   FULL/  -        00:00:38    25.1.1.5        Serial1/1

    24.1.1.4          0   FULL/  -        00:00:32    24.1.1.4        Serial1/0

     

    R2#show ip interface brief

    Interface                  IP-Address      OK? Method Status                Protocol

    Serial0/0                  unassigned      YES unset  administratively down down

    Serial0/1                  unassigned      YES unset  administratively down down

    Serial0/2                  unassigned      YES unset  administratively down down

    Serial0/3                  unassigned      YES unset  administratively down down

    Serial1/0                  24.1.1.2        YES manual up                    up

    Serial1/1                  25.1.1.2        YES manual up                    up

    Serial1/2                  unassigned      YES unset  administratively down down

    Serial1/3                  unassigned      YES unset  administratively down down

    Loopback0                  2.2.2.2         YES manual up                    up

    R2#

     

    连通性测试:

     

    R1#ping 2.2.2.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 59/61/63 ms

     

    三  、在R1上配置NAT协议

     

    1、配置ACL,定义允许NAT转换的流量:

     

    R1(config)#access-list 1 permit 172.16.1.0 0.0.0.255

    R1(config)#access-list 2 permit 172.16.2.0 0.0.0.255

    R1(config)#

     

    2、指定内部、外部接口:

     

    R1(config)#interface e0/0

    R1(config-if)#ip nat inside

    R1(config-if)#interface s1/1

    R1(config-if)#ip nat outside

    R1(config-if)#interface s1/0

    R1(config-if)#ip nat outside

     

    使用IOU设备配置nat时,此时如果报错如下错误,是因为默认存储空间不足,WR保存当前配置后,停止R1,增加设备内存即可:

    Regex parse error, please reconfigure!

    % NBAR Error: Activation failed due to insufficient Dynamic Memory

    % NBAR Error: Stile could not add protocol node

    %NAT: Error activating CNBAR on the interface Ethernet0/0

     

    3、配置route-map:

     

    R1(config)#route-map bearmr1 permit 10

    R1(config-route-map)#match ip address 1

    R1(config-route-map)#match interface s1/1

    R1(config-route-map)#exit

    ####定义route-map bearmr1的两个匹配条件,其中match interface s1/1意思为接口s1/1 up或down的情况,up为匹配,当两个条件都匹配时执行下列转换:ip nat insde source route-map bearmr1 interface  s1/1 overload

     

    R1(config)#route-map bearmr2 permit 10

    R1(config-route-map)#match ip address 1

    R1(config-route-map)#exit

    ####定义route-map bearmr2的匹配条件,匹配时执行下列转换:ip nat insde source route-map bearmr2 interface  s1/1 overload

     

    R1(config)#route-map bearmr3 permit 10

    R1(config-route-map)#match ip address 2

    R1(config-route-map)#match interface s1/0

    R1(config-route-map)#exit

    ####定义route-map bearmr3的两个匹配条件,其中match interface s1/0意思为接口s1/0 up或down的情况,up为匹配,当两个条件都匹配时执行下列转换:ip nat insde source route-map bearmr3 interface  s1/0 overload

     

     

    R1(config)#route-map bearmr4 permit 10

    R1(config-route-map)#match ip address 2

    R1(config-route-map)#exit

    ####定义route-map bearmr4的匹配条件,匹配时执行下列转换:ip nat insde source route-map bearmr4 interface  s1/1 overload

     

    4、配置NAT关联,调用以上配置的router-map

     

    R1(config)#ip nat inside source route-map bearmr1 interface s1/1 overload

    ### route-map bearmr1应用到NAT里,如果匹配条件,流量(172.16.1.0/24)从s1/1接口出去,通过ISP_A到达internet,如果s1/1接口down,则流量从s1/0接口出去,通过ISP_B到达internet

    R1(config)#ip nat inside source route-map bearmr2 interface s1/0 overload

    ###如果s1/1接口down,流量(172.16.1.0/24)从s1/0出去,通过ISP_B到达internet

    R1(config)#ip nat inside source route-map bearmr3 interface s1/0 overload

    ### route-map bearmr3应用到NAT里,如果匹配条件,流量(172.16.2.0/24)从s1/0接口出去,通过ISP_B到达internet,如果s1/0接口down,则流量从s1/1接口出去,通过ISP_A到达internet

    R1(config)#ip nat inside source route-map bearmr4 interface s1/1 overload

    ###如果s1/0接口down,流量(172.16.2.0/24)从s1/1出去,通过ISP_A到达internet

     

    5、配置PBR(基于策略的路由)

     

    R1(config)#route-map bearmr permit 10

    R1(config-route-map)#match ip address 1

    R1(config-route-map)#matnterface s1/1

    R1(config-route-map)#match interface s1/1

    R1(config-route-map)#set interface s1/1

    R1(config-route-map)#exit

    ###定义route-map bearmr,当两个match的条件成立时执行set的动作

     

    R1(config)#route-map bearmr permit 20

    R1(config-route-map)#match ip address 2

    R1(config-route-map)#match interface s1/0

    R1(config-route-map)#set interface s1/0

    R1(config-route-map)#exit

    ###定义route-map bearmr,当两个match的条件成立时执行set的动作

     

    6、在R1的s0/0入方向应用PBR

     

    R1(config)#interface e0/0

    R1(config-if)#ip policy route-map bearmr

    R1(config-if)#end

    R1#

     

    再来查看一些基本信息:

    R1#show ip nat statistics

    Total active translations: 0 (0 static, 0 dynamic; 0 extended)

    Peak translations: 18, occurred 00:23:35 ago

    Outside interfaces:

    Serial1/0, Serial1/1

    Inside interfaces:

    Ethernet0/0

    Hits: 146  Misses: 0

    CEF Translated packets: 116, CEF Punted packets: 30

    Expired translations: 44

    Dynamic mappings:

    – Inside Source

    [Id: 1] route-map bearmr1 interface Serial1/1 refcount 0

    [Id: 2] route-map bearmr2 interface Serial1/0 refcount 0

    [Id: 5] route-map bearmr3 interface Serial1/0 refcount 0

    [Id: 4] route-map bearmr4 interface Serial1/1 refcount 0

     

    Total doors: 0

    Appl doors: 0

    Normal doors: 0

    Queued Packets: 0

     

    四、测试

     

    1、在R1上打开debug

     

    R1#debug ip nat

    IP NAT debugging is on

     

    2、在R3上ping  internet,源地址为172.16.2.3

     

    R3#ping 2.2.2.2  source 172.16.1.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/20 ms

     

    在R1上查看NAT转换信息:

     

    R1#

    *Aug 13 14:54:16.887: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [0]  ###源地址被转换成S1/1的接口地址

    *Aug 13 14:54:16.908: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [0]

    *Aug 13 14:54:16.909: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [1]

    *Aug 13 14:54:16.928: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [1]

    *Aug 13 14:54:16.928: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [2]

    *Aug 13 14:54:16.947: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [2]

    *Aug 13 14:54:16.948: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [3]

    *Aug 13 14:54:16.967: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [3]

    *Aug 13 14:54:16.967: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [4]

    *Aug 13 14:54:16.987: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [4]

     

    3、在R3上ping  internet,源地址为172.16.2.3

     

    R3#ping 2.2.2.2 source 172.16.2.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

    Packet sent with a source address of 172.16.2.3

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 19/25/48 ms

     

    在R1上查看NAT转换信息:

     

    R1#

    *Aug 13 15:30:54.631: NAT*: s=172.16.2.3->14.1.1.1, d=2.2.2.2 [20]  ###源地址被转换成S1/1的接口地址

    *Aug 13 15:30:54.652: NAT*: s=2.2.2.2, d=14.1.1.1->172.16.2.3 [20]

    *Aug 13 15:30:54.653: NAT*: s=172.16.2.3->14.1.1.1, d=2.2.2.2 [21]

    *Aug 13 15:30:54.673: NAT*: s=2.2.2.2, d=14.1.1.1->172.16.2.3 [21]

    *Aug 13 15:30:54.674: NAT*: s=172.16.2.3->14.1.1.1, d=2.2.2.2 [22]

    *Aug 13 15:30:54.693: NAT*: s=2.2.2.2, d=14.1.1.1->172.16.2.3 [22]

    *Aug 13 15:30:54.694: NAT*: s=172.16.2.3->14.1.1.1, d=2.2.2.2 [23]

    *Aug 13 15:30:54.714: NAT*: s=2.2.2.2, d=14.1.1.1->172.16.2.3 [23]

    *Aug 13 15:30:54.714: NAT*: s=172.16.2.3->14.1.1.1, d=2.2.2.2 [24]

    *Aug 13 15:30:54.733: NAT*: s=2.2.2.2, d=14.1.1.1->172.16.2.3 [24]

     

    4、通过traceroute命令跟踪到达2.2.2.2所经过的路径信息

     

    R R3#traceroute 2.2.2.2 source 172.16.1.3  ###源地址172.16.1.3

    Type escape sequence to abort.

    Tracing the route to 2.2.2.2

    VRF info: (vrf in name/id, vrf out name/id)

    1 172.16.1.1 7 msec 1 msec 1 msec

    2 15.1.1.5 11 msec 11 msec 11 msec   ####通过ISP_B到达

    3 25.1.1.2 21 msec 17 msec *

     

    R3#traceroute 2.2.2.2 source 172.16.2.3  ###源地址172.16.2.3

    Type escape sequence to abort.

    Tracing the route to 2.2.2.2

    VRF info: (vrf in name/id, vrf out name/id)

    1 172.16.1.1 1 msec 2 msec 6 msec

    2 14.1.1.4 10 msec 6 msec 11 msec    ####通过ISP_A到达

    3 24.1.1.2 18 msec 20 msec *

     

    通过以上测试可以得到结果:网段172.16.2.0/24通过ISP_A到达2.2.2.2

    网段172.16.1.0/24通过ISP_B到达2.2.2.2

    不指定源地址在测试一次:

     

    R3#traceroute 2.2.2.2

    Type escape sequence to abort.

    Tracing the route to 2.2.2.2

    VRF info: (vrf in name/id, vrf out name/id)

    1 172.16.1.1 2 msec 1 msec 6 msec

    2 15.1.1.5 11 msec 11 msec 11 msec  ###默认情况下通过ISP_B

    3 25.1.1.2 20 msec 22 msec *

     

    五  、手工关闭R1的s1/1接口,模拟链路故障

     

    R1(config)#interface s1/1

    R1(config-if)#shutdown

     

    1、在R3上ping 2.2.2.2,使用源地址172.16.1.2

     

    R3#ping 2.2.2.2 source 172.16.1.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

    Packet sent with a source address of 172.16.1.3

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/27 ms

     

    在R1上查看NAT转换信息:

     

    R1#

    *Aug 13 15:46:26.979: %SYS-5-CONFIG_I: Configured from console by console

    R1#

    *Aug 13 15:47:50.944: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [30]  ###源地址被转换成S1/0的接口地址

    *Aug 13 15:47:50.965: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [30]

    *Aug 13 15:47:50.965: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [31]

    *Aug 13 15:47:50.985: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [31]

    *Aug 13 15:47:50.985: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [32]

    *Aug 13 15:47:51.006: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [32]

    *Aug 13 15:47:51.006: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [33]

    *Aug 13 15:47:51.026: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [33]

    *Aug 13 15:47:51.026: NAT*: s=172.16.1.3->15.1.1.1, d=2.2.2.2 [34]

    *Aug 13 15:47:51.047: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.1.3 [34]

    *Aug 13 15:48:51.978: NAT: expiring 15.1.1.1 (172.16.1.3) icmp 6 (6)

     

    2、在R3上ping 2.2.2.2,使用源地址172.16.2.2

     

    R3#ping 2.2.2.2 source 172.16.2.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

    Packet sent with a source address of 172.16.2.3

    !!!!!

     

    在R1上查看NAT转换信息:

     

    R1#

    *Aug 13 15:50:14.814: NAT*: s=172.16.2.3->15.1.1.1, d=2.2.2.2 [35]  ###源地址被转换成S1/0的接口地址

    *Aug 13 15:50:14.834: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.2.3 [35]

    *Aug 13 15:50:14.834: NAT*: s=172.16.2.3->15.1.1.1, d=2.2.2.2 [36]

    *Aug 13 15:50:14.854: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.2.3 [36]

    *Aug 13 15:50:14.854: NAT*: s=172.16.2.3->15.1.1.1, d=2.2.2.2 [37]

    *Aug 13 15:50:14.874: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.2.3 [37]

    *Aug 13 15:50:14.874: NAT*: s=172.16.2.3->15.1.1.1, d=2.2.2.2 [38]

    *Aug 13 15:50:14.894: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.2.3 [38]

    *Aug 13 15:50:14.895: NAT*: s=172.16.2.3->15.1.1.1, d=2.2.2.2 [39]

    *Aug 13 15:50:14.914: NAT*: s=2.2.2.2, d=15.1.1.1->172.16.2.3 [39]

    *Aug 13 15:51:15.649: NAT: expiring 15.1.1.1 (172.16.2.3) icmp 7 (7)

     

    3、通过traceroute命令跟踪到达2.2.2.2所经过的路径信息

     

    R3#traceroute 2.2.2.2 source 172.16.1.3

    Type escape sequence to abort.

    Tracing the route to 2.2.2.2

    VRF info: (vrf in name/id, vrf out name/id)

    1 172.16.1.1 1 msec 1 msec 9 msec

    2 15.1.1.5 6 msec 10 msec 10 msec   ####通过ISP_B到达

    3 25.1.1.2 20 msec 16 msec *

     

    R3#traceroute 2.2.2.2 source 172.16.2.3

    Type escape sequence to abort.

    Tracing the route to 2.2.2.2

    VRF info: (vrf in name/id, vrf out name/id)

    1 172.16.1.1 4 msec 2 msec 1 msec

    2 15.1.1.5 11 msec 11 msec 10 msec  ####通过ISP_B到达

    3 25.1.1.2 21 msec 21 msec *

     

    通过以上测试可以得到结果:网段172.16.2.0/24通过ISP_B到达2.2.2.2

    网段172.16.1.0/24通过ISP_B到达2.2.2.2

     

    R1#clear access-list counters

     

    R3#ping 2.2.2.2 so e0/0 re 1
    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    Packet sent with a source address of 172.16.1.3
    !
    Success rate is 100 percent (1/1), round-trip min/avg/max = 20/20/20 ms
    R3#ping 2.2.2.2 so l0 re 1
    Type escape sequence to abort.
    Sending 1, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
    Packet sent with a source address of 172.16.2.3
    !
    Success rate is 100 percent (1/1), round-trip min/avg/max = 20/20/20 ms

     

    R1#sh access-l
    Standard IP access list 1
    10 permit 172.16.1.0, wildcard bits 0.0.0.255 (3 matches)
    Standard IP access list 2
    10 permit 172.16.2.0, wildcard bits 0.0.0.255 (2 matches)

     

    access list 1 命中了3次,是一次策略路由、一次ICMP 请求时的NAT,一次ICMP回应的NAT。
    access list 2 命中了2次,是走的默认路由,一次ICMP 请求时的NAT,一次ICMP回应的NAT。
    结果证明,虽然ISP_A的链路发生了故障,但是流量可以通过ISP_B到达2.2.2.2internet,实现链路切换和备份功能。

     

    六  、实验完成

     

    打开ISP_A的链路接口

     

    R1(config)#inter s1/1

    R1(config-if)#no sh

     

    附详细配置:

    链接:http://pan.baidu.com/s/1sj1542T 密码:pfuj

    展开全文
  • 华为路由器出口负载均衡+备份

    千次阅读 2017-02-22 17:33:38
    一个网段内,IP地址(末位奇数)走电信,IP地址(末位偶数)走联通当某个运营商不可达时,自动切换。通过NQA来确定运营商是否可达。,并与流行为、静态路由联动,实现自动切换。默认路由走电信,当电信不可达走联通...
  • 适用于:有多个以太WAN口的机型。业务需求:运营商1分配的接口IP为100.100.1.2,子网掩码为255.255.255.252...实现通过静态IP上行接入Internet,链路1和链路2的出口路由采用等价默认路由进行负载分担。拓扑简图:...
  • 早期多WAN路由器产品刚上市时,有些...策略路由是具有中国特色的负载均衡功能,它考虑了中国不同运营商间带宽不足的问题,路由器不是依带宽大小决定转发WAN口,而是考虑响应速度,将网 络包转发到响应速度较快的WAN口。
  • 关于F5负载均衡的一点方案

    千次阅读 2011-08-23 18:10:16
    网络的作用是交付应用和服务,目标客户群体遍布各地,随着业务需求的变化和提升,XX网络系统的访问量将成倍增长,为了避免Internet...按照XX的网络规模,运营商的互通速度无法满足XX网络性能的要求,因此,在采用链路
  • 家庭宽带多运营商接入方案

    千次阅读 2018-08-16 21:37:09
    一、刷机路由器系统为OpenWRT 二、配置光猫 三、将路由器的一个lan口转换为wan口 四、路由器wan口pppoe拨号 五、配置负载均衡
  • 一、实践的实验内容 本次实践的内容为:模拟跨国公司,通过运营商网络如何...3、公司内部网络实现负载均衡。 二、实践的实验环境 1、硬件环境 本次实验采用的硬件为:lenovo ThinkPad L460 笔记本,笔记本基本...
  • 网吧用户同时申请了中国电信和中国网通两条宽带接入线路,如果此时线路采用常规的“负载均衡”方式,就会发生访问网通站点走电信线路,访问电信站点走网通线路的情况,由于当前网通和电信两个运营商之间存在着互联...
  • 实际工作中估计会碰到需要用一台ASA接两家ISP线路,比如电信和网通,而又没有足够的预算买负载均衡设备,但是又想实现链路负载分担和自动切换,从电信来的流量,从电信线路回去,从网通来的流量从网通线路回去,当...
  • 其次,单台E8000E设备的主控板1+1备份、交换板3+1备份、接口板可针对业务处理板进行负载均衡,当一块业务处理板故障时,该板原先所承载的流量将被均衡到其他业务板上继续处理。另外,电源、风扇等重要部件也进行了...
  • ASA链路SLA配置测试

    2013-09-27 19:31:26
    概述:实际工作中估计会经常碰到用ASA接两家ISP线路,比如电信和网通,而又没有足够的预算买负载均衡设备,但是又想实现链路负载分担和自动切换,从电信来的流量,从电信线路回去,从网通来的流量从网通线路回去,当...
  • 发送的时候可以说是重重关隘,从手机到移动网络、互联网,还要经过多个运营商才能到达数据中心,到了数据中心就进入第二个复杂的过程,从网关到VXLAN隧道,到负载均衡,到Controller层、组合服务层、基础服务层,...
  • OSS是电信运营商的一体化、信息资源共享的支持系统,它是跨业务的、端到端全过程的管理。用的是阿里云的oss对象存储,大概意思就是把自己的资源放到oss系统上,这样做的好处就是优化性能,降低服务器的压力,用户...
  • 因此大型互联网企业早已不满足于单一、或者活数据中心提供网站服务,越来越多的互联网企业开始考虑在不同地区、不同运营商部署多个数据中心集群,以实现用户访问就近接入、负载均衡和故障容灾。
  • 引言 现如今本地负载均衡技术已经解决服务器...因此大型互联网企业早已不满足于单一、或者活数据中心提供网站服务,越来越多的互联网企业开始考虑在不同地区、不同运营商部署多个数据中心集群,以实现用户访问就...
  • 服务容灾(转)

    千次阅读 2016-10-26 20:31:25
    【纲要】常见事故及如何容灾逻辑层容灾数据层容灾容灾判定负载均衡,过载保护【常见事故及如何容灾】服务器故障死机 ——备份(硬件方案,软件方案)服务雪崩——负载均衡,过载保护网络环境恶劣——多运营商,异步...
  • 瑞友天翼使用说明书

    2012-09-16 14:01:56
    天翼V4.0在天翼V3.x系列产品集群基础上,增加了基于IP动态漂移技术的负载均衡和故障转移能力,可以更好的支持大规模并发访问。 天翼V4.0提供了系统资源共享优化技术(共享程序代码段资源,缓存I/O信息),可以成倍...

空空如也

空空如也

1 2
收藏数 35
精华内容 14
热门标签
关键字:

双运营商负载均衡