精华内容
下载资源
问答
  • VRRP 工作原理

    2019-07-17 19:43:35
    VRRP 工作原理 实验需求: 1.R1与R2是VLAN 10 中的网关; 2.R1与R2启用 VRRP,虚拟网关为 10.250; 3.确保 R1 为主网关; 4.确定 VRRP 发送报文方式、协议号、目标地址 -发送方式:组播 -协议号:112 -目标地址:...

    VRRP 工作原理
    在这里插入图片描述
    实验需求:
    1.R1与R2是VLAN 10 中的网关;
    2.R1与R2启用 VRRP,虚拟网关为 10.250;
    3.确保 R1 为主网关;
    4.确定 VRRP 发送报文方式、协议号、目标地址
    -发送方式:组播
    -协议号:112
    -目标地址:224.0.0.18 (表示所有的VRRP路由器)
    5.确定 VRRP 发送报文周期
    -周期:1s
    6.确定 VRRP 默认优先级
    -默认是:100 (刚才的200,是人工修改的)
    -抓包时,刚才抓到的全都是 主网关 发送的 VRRP 报文;备份网关是不发送VRRP报文的;
    配置步骤:
    1.配置终端设备;
    2.配置网络设备;
    #配置交换设备
    *创建 VLAN ->配置接口类型和所属于 VLAN
    #配置路由设备
    *配置网关IP
    3.配置 VRRP
    *启用VRRP,配置虚拟 IP
    *调整优先级,确保 R1 为 主网关
    4.验证与测试
    *查看每个路由器的 VRRP 状态
    * PC-1 Ping 10.250,通过抓包确定数据转发路径

    配置命令:
    PC-1:
    192.168.10.1
    255.255.255.0
    192.168.10.250 ->必须配置为虚拟网关的IP地址;
    SW1:
    undo terminal monitor
    system-view
    sysname SW1
    vlan 10 # 创建 VLAN 10
    quit
    interface gi0/0/1 # 接口加入到 VLAN 10
    port link-type access
    port default vlan 10
    quit
    interface gi0/0/2 # 接口加入到 VLAN 10
    port link-type access
    port default vlan 10
    quit
    interface gi0/0/3 # 接口加入到 VLAN 10
    port link-type access
    port default vlan 10
    quit

    R1: 
      undo terminal monitor
      system-view
      sysname R1 
      interface gi0/0/0 # 进入真实的网关接口
         ip address 192.168.10.251 24  #配置真实网关的IP地址;
    	 vrrp vrid 1 virtual-ip 192.168.10.250 #配置VRRP虚拟网关
    	 vrrp vrid 1 priority 200  # 配置VRRP优先级为 200
    	 
    R2: 
      undo terminal monitor
      system-view
      sysname R2 
      interface gi0/0/0 
         ip address 192.168.10.252 24
    	 vrrp vrid 1 virtual-ip 192.168.10.250 
                               #没有指定VRRP优先级,使用默认值。
    						    VRRP默认优先级为 100 .
    

    验证命令:
    display vlan ->查看 vlan 以及与 接口的对应关系;
    display vrrp ->查看 vrrp 的状态,以及优先级;
    display ip interface brief -> 查看接口IP地址

    需要掌握的内容:
    @ VRRP的网关角色:
    -主网关
    -备份网关
    -虚拟网关
    @ 知道 VRRP 的默认优先级
    @ 知道 VRRP 选择主/备网关的原则
    -首先,比较优先级,越大越好;
    -优先级相同,比较IP地址,越大越好;

    展开全文
  • VRRP工作原理

    千次阅读 2016-12-05 19:25:02
    [b]VRRP工作原理[/b] 1.(Virtual Router Redundancy Protocol,简称VRRP),虚拟路由冗余协议 2.虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是解决局域网中配置静态网关时,静态网关出现...
    [b]VRRP工作原理[/b]
    


    1.(Virtual Router Redundancy Protocol,简称VRRP),虚拟路由冗余协议
    2.虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是解决局域网中配置静态网关时,静态网关出现单点失效现象的路由协议。


    [b]主机工作内容:[/b]
    1.设置定时通告定时器;
    2.用VRRP虚拟MAC地址响应针对虚拟路由器IP地址的ARP请求;
    3.转发目的MAC是VRRP虚拟MAC的数据包;
    4.如果是虚拟路由器IP的拥有者,将接受目的地址是虚拟路由器IP的数据包,否则丢弃;
    5.当收到shutdown的事件时,删除定时通告定时器,发送优先权级为0的通告包,转初始化状态;
    6.如果定时通告定时器超时时,发送VRRP通告信息;
    7.收到VRRP通告信息时,如果优先权为0,发送VRRP通告信息;
    8.否则判断数据的优先级是否高于本机,或相等而且实际IP地址大于本地实际IP,设置定时通告定时器,复位主机超时定时器,转BACKUP状态;否则的话,丢弃该通告包;


    [b]备机工作内容:[/b]
    1.设置主机超时定时器;
    2.不能响应针对虚拟路由器IP的ARP请求信息;
    3.丢弃所有目的MAC地址是虚拟路由器MAC地址的数据包;
    4.不接受目的是虚拟路由器IP的所有数据包;
    5.当收到shutdown的事件时,删除主机超时定时器,转初始化状态;
    6.主机超时定时器超时的时候,发送VRRP通告信息,广播ARP地址信息,转MASTER状态;
    7.收到VRRP通告信息时,如果优先权为0,表示进入MASTER选举;否则判断数据的优先级是否高于本机,如果高的话,承认MASTER有效,复位主机超时定时器;否则的话,丢弃该通告包;


    [b]工作原理:[/b]
    1. VRRP协议使用多播来传输VRRP数据,就是主机发送的是广播数据,主机收到时将其转发出去,从机接收到就不进行转发出去。
    2.主机宕机后,会从从机中选出一个主机。
    3.网卡应该工作在多播模式或混杂模式。因为这两种模式下网卡会接收所有接收到的数据帧。


    参考(VRRP协议详解):[url]http://www.cnblogs.com/ajianbeyourself/p/4150233.html[/url]
    参考(VRRP 学习):[url]https://yq.aliyun.com/articles/42004[/url]
    展开全文
  • Vrrp工作原理实验

    2019-09-18 05:16:31
    vrrp工作原理VRRP:-概述:vrrp ,virtual router redundancy protocol ,虚拟路由器冗余协议。该协议的主要作用,就是在多个真实的网关设备之间运行之后,形成一个“虚拟的网关”,从而实现多个真实网关之间的“冗余...
    1. vrrp工作原理
      VRRP:
      -概述:
      vrrp ,virtual router redundancy protocol ,虚拟路由器冗余协议。
      该协议的主要作用,就是在多个真实的网关设备之间运行之后,形成一个“虚拟的网关”,
      从而实现多个真实网关之间的“冗余备份”以及数据转发的负载均衡。
      -场景:
      当我们为了提高一个网络中的网关的健壮性,从而在同一个网络中部署多个网关设备的时候,
      此时,我们需要在多个网关设备之间运行 VRRP,如果仅有 1个 网关设备,是不需要运行VRRP
      的。
      -原理:
      VRRP在设备(接口)上运行之后,会形成一个虚拟的网关设备。会通过发送 VRRP 的报文,
      比较其中的参数,从而在多个真实的网关设备之间确定出不同的设备角色:
      master - 主设备;有且只有1个;
      backup - 备份设备;可以有很多;
      一旦确定设备的master和backup的角色之后,就仅有master一直 周期性的发送 vrrp 报文,
      如果backup 设备,在一定的时间内,没有收到 master 发送过来的 vrrp 报文,就认为
      master 设备出现了故障,从而进行设备角色的切换;
      发送周期:1s
      最大间隔:3s
      用户终端设备在向网关(虚拟网关)发送数据的时候,其实是由 master 设备在进行处理。
      当 master 设备故障以后,backup 设备才会变成 master ,继续为客户服务;
      如果原先的 master 设备故障恢复了,那么备份的网关设备会再次变为 backup 状态;
    2. vrrp实验环境
      实验需求:
      1.R1与R2是VLAN 10 中的网关;
      2.R1与R2启用 VRRP,虚拟网关为 10.250;
      3.确保 R1 为主网关;
      4.确定 VRRP 发送报文方式、协议号、目标地址
      5.确定 VRRP 发送报文周期
      6.确定 VRRP 默认优先级
    3. 配置步骤:
      1.配置终端设备;
      2.配置网络设备;
      #配置交换设备
      创建 VLAN ->配置接口类型和所属于 VLAN
      #配置路由设备
      配置网关IP
      3.配置 VRRP
      启用VRRP,配置虚拟 IP
      调整优先级,确保 R1 为 主网关
      4.验证与测试
      *查看每个路由器的 VRRP 状态
      • PC-1 Ping 10.250,通过抓包确定数据转发路径
    4. 实验拓扑
      Vrrp工作原理实验
    5. 实验过程
      配置交换机s1:
      [s1]vlan 10
      [s1]int g0/0/3
      [s1-GigabitEthernet0/0/3]port link-type acc
      [s1-GigabitEthernet0/0/3]port default vlan 10
      [s1-GigabitEthernet0/0/3]q
      [s1-port-group-1]group-member g0/0/1 g0/0/2
      [s1-port-group-1]port link-type access
      [s1-GigabitEthernet0/0/1]port link-type access
      [s1-GigabitEthernet0/0/2]port link-type access
      [s1-port-group-1]port default vlan 10
      [s1-GigabitEthernet0/0/1]port default vlan 10
      [s1-GigabitEthernet0/0/2]port default vlan 10
      [s1-port-group-1]

    配置路由器r1:
    [r1-GigabitEthernet0/0/0]ip add 192.168.10.251 24 //vlan10 真实网关
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.250 //作为 vlan 10 的主网关;
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 priority 200
    Dis vrrp brief:

    配置路由器r2
    [r2]int g0/0/0
    [r2-GigabitEthernet0/0/0]ip add 192.168.10.252 24 //vlan10 真实网关
    [r2-GigabitEthernet0/0/0]vrrp vrid 1 virtual-ip 192.168.10.250 //作为 vlan 10 的备份网关;
    [r2-GigabitEthernet0/0/0]vrrp vrid 1 priority 100

    通过抓包工具测试:ping 192.168.10.250

    Vrrp工作原理实验
    Vrrp工作原理实验

    理论知识:
    [R2] display vrrp int g0/0/0
    GigabitEthernet0/0/0 | Virtual Router 1
    State : Backup //当前的状态为 backup,不再是master;
    Virtual IP : 192.168.10.250
    Master IP : 192.168.10.254
    PriorityRun : 50 //该设备当前使用的优先级为:50
    PriorityConfig : 150 //该设备手动配置的优先级为:150
    MasterPriority : 100 //当前master的优先级为:100;
    Preempt : YES Delay Time : 0 s
    TimerRun : 1 s
    TimerConfig : 1 s
    Auth type : NONE
    Virtual MAC : 0000-5e00-0101
    Check TTL : YES
    Config type : normal-vrrp
    Backup-forward : disabled
    Track IF : GigabitEthernet0/0/2 Priority reduced : 100 // 跟踪接口 gi0/0/2 ;
    IF state : DOWN // 接口的状态变成了 down ;
    VRRP常见的故障:多个master。
    常见原因:
    1.多个真实网关之间不通
    2.两边配置的 VRID 不同
    3.两边配置的 virtual-ip 不同
    4.vrrp 认证不成功
    拓展实验:
    Vrrp工作原理实验
    路由器r3配置:
    接口IP地址配置
    路由配置:
    [Huawei]ip route-static 192.168.10.0 255.255.255.0 192.168.20.1 preference 20
    [Huawei]ip route-static 192.168.10.0 255.255.255.0 192.168.30.1
    路径优先通过左边的方向
    当down掉左边的接口:
    Vrrp工作原理实验
    Vrrp工作原理实验

    两边路由器状态发生交换
    Vrrp工作原理实验
    Vrrp工作原理实验

    Ping测试 右边路径正常通信
    Vrrp工作原理实验

    1 简述VRRP抢占模式的作用
    参考答案
    优先级高的路由器down掉后,备份路由器成为主路由器。
    当优先级高的路由器恢复后,如何重新成为主路由器?
    华为默认开启抢占模式,使之重新获得转发权,恢复为主路由器。

    打开端口,状态恢复。
    2 简述VRRP端口跟踪的作用
    参考答案
    跟踪端口不可用时,优先级降低,从而使备份路由器成为主路由器。
    端口跟踪命令:
    [r1-GigabitEthernet0/0/0]vrrp vrid 1 track int g0/0/1 reduced 150
    见上图backup 运行路由器优先级为50
    3 简述浮动路由的作用
    参考答案
    可以对链路进行备份,通常是配置一个优先级低的静态路由,作为应急触发的备份路径。在主路由有效的情况下,浮动路由不会出现在路由表中。
    默认优先级60,数值越大,优先级越低。
    4 简述VRRP配置命令vrrp vrid 1 preempt-mode timer delay 20的作用
    参考答案
    优先级高的路由器down掉后,备份路由器成为主路由器。当优先级高的路由器恢复后,将延迟20秒重新恢复为主路由器。

    展开全文
  • VRRP工作原理及配置

    2021-08-24 08:53:11
    一,VRRP的概念 VRRP(Virtual Router Redundancy Protocol)虚拟路由冗余协议用来做出口网关的备份 作用:用来做出口网关的备份保证出口网关的...VRRP工作原理: 通过在冗余网关间共享虚拟Mac和ip地址,保证数据转

    目录

    一,VRRP的概念

    二,VRRP的设置

    三,VRRP设置命令

    总结


    一,VRRP的概念

    VRRP(Virtual Router Redundancy Protocol)虚拟路由冗余协议用来做出口网关的备份

    作用:用来做出口网关的备份保证出口网关的高用性

    VRRP的好处:

    1,主路由失效后,备份路由器立即顶替主路由器的工作,保证数据不会丢失

    2,两个不同的路由器成为不同组的主路由器,相互备份

    3,跟踪上行链路接口状态,当上行链路接口失效时,自动将备份路由器提升为主路由器,保证数据不会丢失

    VRRP工作原理:

    通过在冗余网关间共享虚拟Mac和ip地址,保证数据转发时并不是转给某一个具体网关ip,而是把数据传给虚拟网关ip,因此不论那个路由器成为主路由器,都不会影响数据通信,通过组播协议对数据端口进行监控,一旦检测数据转发的端口坏掉,主路由器会停止hello包,备份路由提升为主路由器,实现数据的稳定高效转发。

    二,VRRP的设置

    vrrp默认接口优先级是100

    主路由器一旦失效后,默认优先级是自动降10

    怎样让路由器成为主路由器:

    保证主路由器的接口优先级比备份路由器的接口优先级大。注意:因为接口失效后优先级默认是降10的,所以主路由器的接口优先级不能比备份路由器大超过9,因为备份路由器抢占主路由器角色时会比较自身的接口优先级是否大于主路由器下降10之后的优先级,若大时才会抢占主路由器角色若小时不会抢占主路由器角色。

    成为vrrp组的接口ip(真实)必须存在,而且成员间的接口ip必须不一样

    接口虚拟ip必须一样因为承担同一个组的流量

    主路由器接口优先级必须大于备份路由器的接口优先级

    三,VRRP设置命令

    做一个拓扑让大家更好的理解

     配置命令:

    SW1设置
    <Huawei>u t m关闭弹出信息
    <Huawei>sys    
    [Huawei]sysname sw1 重命名    
    [sw1]user-int console 0
    [sw1-ui-console0]idle-timeout 0 0 永不超时
    [sw1]vlan bat 10 20 创建vlan10 20
    [sw1]int e0/0/1    进入接口
    [sw1-Ethernet0/0/1]port link-ty access 接口链路类型设为access
    [sw1-Ethernet0/0/1]port def vlan 10 接口划分进vlan10
    [sw1-Ethernet0/0/1]int e0/0/2 进入接口
    [sw1-Ethernet0/0/2]port link-ty acc 接口链路类型设为access
    [sw1-Ethernet0/0/2]port def vlan 20 接口划分进vlan20
    [sw1-Ethernet0/0/2]int g0/0/1 进入接口
    [sw1-GigabitEthernet0/0/1]port link-ty trunk 接口链路类型设为trunk
    [sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all 放行所有vlan
    [sw1-GigabitEthernet0/0/1]int g0/0/2 进入接口
    [sw1-GigabitEthernet0/0/2]port link-ty trunk 接口链路类型设为trunk    
    [sw1-GigabitEthernet0/0/2]port trunk allow-pass vlan all 放行所有vlan
    L-SW1设置
    <Huawei>u t m 关闭弹出信息
    <Huawei>sys    
    [Huawei]sysname l-sw1 重命名
    [l-sw1]user-int console 0    
    [l-sw1-ui-console0]idle-timeout 0 0 永不超时
    [l-sw1-ui-console0]int g0/0/1 进入接口
    [l-sw1-GigabitEthernet0/0/1]port link-ty trunk 接口链路类型设为trunk
    [l-sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all 放行所有vlan
    [l-sw1]vlan bat 10 20 100 创建vlan10 20 100
    [l-sw1]int vlan 10 进入虚拟接口vlanif10
    [l-sw1-Vlanif10]ip add 192.168.10.10 24 设置真实ip和子网掩码长度
    [l-sw1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.1    设置vrrp组1 虚拟ip
    [l-sw1-Vlanif10]vrrp vrid 1 priority 105 设置vrrp组1接口优先级105
    [l-sw1-Vlanif10]vrrp vrid 1 track int g0/0/2 跟踪上行链路接口g0/0/2
    [l-sw1-Vlanif10]int vlan 20 进入虚拟接口vlanif20
    [l-sw1-Vlanif20]ip add 192.168.20.10 24 设置真实ip和子网掩码长度    
    [l-sw1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.20.1 设置vrrp组2 虚拟ip
    [l-sw1-Vlanif20]vrrp vrid 2 track int g0/0/2 跟踪上行链路接口g0/0/2
    [l-sw1-Vlanif20]int vlan 100 进入虚拟接口vlanif100
    [l-sw1-Vlanif100]ip add 10.10.10.1 24 设置真实ip和子网掩码长度
    [l-sw1]int g0/0/2 进入接口
    [l-sw1-GigabitEthernet0/0/2]port link-ty access 接口链路类型设为access
    [l-sw1-GigabitEthernet0/0/2]port def vlan 100 接口划分进vlan100
    添加静态路由目的网段1.1.1.1子网掩码长度32下一跳入接口ip10.10.10.11    
    [l-sw1]ip route-static 1.1.1.1 32 10.10.10.11 添加静态路由目的网段1.1.1.1子网掩码长度32下一跳入接口ip10.10.10.11
    L-SW2设置
    <Huawei>u t m 关闭弹出信息
    <Huawei>sys
    [Huawei]sysname l-sw1重命名    
    [l-sw1]user-int console 0     
    [l-sw1-ui-console0]idle-timeout 0 0 永不超时
    [l-sw1-ui-console0]int g0/0/1 进入接口
    [l-sw1-GigabitEthernet0/0/1]port link-ty trunk 接口链路类型设为trunk    
    [l-sw1-GigabitEthernet0/0/1]port trunk allow-pass vlan all 放行所有vlan
    [l-sw1-GigabitEthernet0/0/1]int g0/0/2 进入接口
    [l-sw1-GigabitEthernet0/0/2]port link-ty access 接口链路类型设为access
    [l-sw1]vlan bat 10 20 200 创建vlan10 20 200
    [l-sw1]int g0/0/2 进入接口
    [l-sw1-GigabitEthernet0/0/2]port def vlan 200 接口计划分vlan200
    [l-sw1-GigabitEthernet0/0/2]int vlan 10 进入虚拟接口vlanif10
    [l-sw1-Vlanif10]ip add 192.168.10.11 24 设置真实ip和子网掩码长度
    [l-sw1-Vlanif10]vrrp vrid 1 virtual-ip 192.168.10.1设置vrrp组1 虚拟ip
    [l-sw1-Vlanif10]vrrp vrid 1 track int g0/0/2 跟踪上行链路接口g0/0/2
    [l-sw1-Vlanif10]int vlan 20 进入虚拟接口vlanif20
    [l-sw1-Vlanif20]ip add 192.168.20.11 24 设置真实ip和子网掩码长度    
    [l-sw1-Vlanif20]vrrp vrid 2 virtual-ip 192.168.20.1    设置vrrp组2 虚拟ip
    [l-sw1-Vlanif20]vrrp vrid 2 priority 105 设置vrrp组2接口优先级105
    [l-sw1-Vlanif20]vrrp vrid 2 track int g0/0/2 跟踪上行链路接口g0/0/2
    [l-sw1-Vlanif20]int vlan 200 进入虚拟接口vlanif200
    [l-sw1-Vlanif200]ip add 10.10.20.2 24 设置真实ip和子网掩码长度
    添加静态路由目的网段1.1.1.1子网掩码长度32下一跳入接口ip10.10.20.11
    [l-sw1]ip route-static 1.1.1.1 32 10.10.20.11
    R1设置
    <Huawei>u t m 关闭弹出信息
    <Huawei>sys    
    [Huawei]sysname r1 重命名    
    [r1]user-int console 0
    [r1-ui-console0]idle-timeout 0 0 永不超时
    [r1-ui-console0]int g0/0/0 进入接口
    [r1-GigabitEthernet0/0/0]undo shut  开启接口
    [r1-GigabitEthernet0/0/0]ip add 10.10.10.11 24 设置ip和子网掩码长度
    [r1-GigabitEthernet0/0/0]int g0/0/1 进入接口
    [r1-GigabitEthernet0/0/1]undo shut 开启接口
    [r1-GigabitEthernet0/0/1]ip add 10.10.20.11 24 设置ip和子网掩码长度    
    [r1]int LoopBack 0 进入虚拟接口loopback 0
    [r1-LoopBack0]ip add 1.1.1.1 32 设置ip和子网掩码长度
    添加静态路由目的网段192.168.10.1子网掩码长度24下一跳入接口ip10.10.10.1    
    [r1]ip route-static 192.168.10.0 24 10.10.10.1
    添加静态路由目的网段192.168.10.0子网掩码长度24下一跳入接口ip10.10.20.2路由优先级65    
    [r1]ip route-static 192.168.10.0 24 10.10.20.2 preference 65
    添加静态路由目的网段192.168.20.0子网掩码长度24下一跳入接口ip10.10.20.2
    [r1]ip route-static 192.168.20.0 24 10.10.20.2
    添加静态路由目的网段192.168.20.0子网掩码长度24下一跳入接口ip10.10.10.1路由优先级65    
    [r1]ip route-static 192.168.20.0 24 10.10.10.1 preference 65

    PC机设置

     测试通信:两台PC机都要测试

    可以关闭一侧的上行链路接口再测试一次tracert一下路由追踪,

     

    总结

    本文介绍了vrrp的作用和工作原理。这个是搞懂vrrp技术的关键,vrrp主要是做出口网关的备份保证出口网关的高可用性。在设置中主路由器和备份路由器的接口优先级一定要设置正确,才能正常的工作。

    展开全文
  • VRRP工作原理(ensp)

    2021-04-12 21:20:38
    VRRP 工作原理 原理VRRP:virtual router redundancy protocol 虚拟 路由器 冗余 协议 -该协议是公有的标准协议,可以适用于任何厂商的设备; -该协议是属于 OSI 模型第三层,该协议的报文位于IP头部后面,协议号...
  • 以太网链路集合、vrrp工作原理一、以太网链路集合1.认识链路聚合2.基础配置二、VRRP工作原理1.概念2.相关术语2.Master路由器2.Backup路由器 一、以太网链路集合 1.认识链路聚合 定义:以太网链路聚合----Eth-trunk多...
  • VRRP工作原理及作用

    2021-08-24 00:10:11
    一、VRRP的作用 出口网关的备份,保证出口网关的高可用性...三、工作原理 通过在冗余网关间共享虚拟MAC和IP地址,保证数据转发时并不是转给某一个具体网关的IP,而是把数据转发给虚拟网关的IP,因此,不论哪一个路...
  • VRRP报文格式 报文格式 VRRP报文被封装在IP包中。使用专门的VRRP IPv4组播地址。(协议号112,组播地址 224.0.0.18) IANA分配给VRRP的IP协议号为112(十进制)。 IANA给VRRP分配的IP组播地址为224.0.0.18。这是...
  • HSRP和VRRP工作原理详解

    千次阅读 2016-08-17 23:52:53
    2.3.3 VRRP基本工作原理  图2-4显示了一个配置了VRRP的局域网拓扑结构。在这个示例中,Router A、Router B和Router C是组成VRPP虚拟路由器的VRRP路由器成员。虚拟路由器IP地址与Router A的IP地址一样——10.0....
  • HSRP和VRRP工作原理

    万次阅读 2012-04-17 20:21:16
    2.3.3 VRRP基本工作原理  图2-4显示了一个配置了VRRP的局域网拓扑结构。在这个示例中,Router A、Router B和Router C是组成VRPP虚拟路由器的VRRP路由器成员。虚拟路由器IP地址与Router A的IP地址一样——10.0.0.1...
  • 虚拟路由器冗余协议(VRRP)是一种选择协议,它可以把一个虚拟路由器的责任动态分配到局域网上的 VRRP 路由器中的一台。控制虚拟路由器 IP 地址的 VRRP 路由器称为主路由器,它负责转发数据包到这些虚拟 IP 地址。...
  • VRRP原理VRRP原理

    千次阅读 2020-02-26 00:39:45
    vrrp工作原理 工作原理 1.网关之间发送VRRP爆粉,比较优先级。 2.优先级大为主网关,优先级小的为备份网关。 首先初始设备给三台交换机设置接口模式并加入到vlan sw1 <Huawei>u t m //取消消息提示 Info:...
  • VRRP相关工作原理

    2021-08-24 08:32:53
    4.工作原理 5.特点 1.什么是VRRP 虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP)是由IETF提出的解决局域网中配置静态网关出现单点失效现象的路由协议,VRRP广泛应用在边缘网络中,它的设计...
  • VRRP基本原理

    2019-09-18 05:18:17
    VRRP基本原理虚拟路由冗余协议(Virtual Router Redundancy Protocol,简称VRRP),是一个IP协议族,我们知道IP协议族里面有ICMP、OSPF,VRRP也是IP协议族的一员,协议号为112。在VRRP里面,设备有两种角色(Master,...
  • VRRPVRRP出现的背景VRRP工作原理VRRP报文 VRRP出现的背景 如图所示:几台主机只有一台路由器转发数据,当出现故障后,所有主机都将连不上网。设想一下这种情况如果发生在某家公司内部,会造成多大的损失,VRPP就是...
  • vrrp协议原理与应用, 本PPT主要介绍了VRRP协议的原理与应用,适用于对VRRP协议有一定了解的工程师和网络维护人员。
  • vrrp原理

    千次阅读 2017-07-20 16:20:42
    vrrp协议原理
  • VRRP工作原理与理论

    2021-10-18 22:19:27
    VRRP工作原理与理论 一个VRRP组由多 个VRRP路由器组成,使用相同的VRID虚拟路由器ID )进行标识,属于同-VRRP组的VRRP路由器互相交换信息,每个VRRP组中只能有一 个Master。 虚拟路由器对于每一一个VRRP组,抽象...
  • VRRP技术原理

    2021-08-23 21:52:36
    一、VRRP的作用 VRRP是一种主出口网关的备份,以确保主出口网关的可用性的一种技术 上图是我画一个网络的走向路径图,比较丑,还请不要在意。是每台PC都经过一个路由器进行上互联网,假如AR10突然故障了,不能...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 8,075
精华内容 3,230
关键字:

vrrp工作原理