精华内容
下载资源
问答
  • vue 安装依赖及卸载依赖

    万次阅读 2019-03-20 17:44:38
    参考链接:... --save 是在package.json的【dependencies】里面 --save-dev是在package.json的【devDependencies】里面 依赖安装在package.json的【dependencies】的三种方式 np...

    参考链接:https://docs.npmjs.com/uninstalling-packages-and-dependencies 

    --save 是在package.json的【dependencies】里面

    --save-dev  是在package.json的【devDependencies】里面

    依赖安装在package.json的【dependencies】的三种方式

     npm i element-ui

    npm i element-ui -S

     npm i element-ui --save

     依赖安装在package.json的【devDependencies】的两种方式

    npm install jquery --save-dev

     npm install jquery --D

    1. 安装jquery

    npm install jquery --save

      卸载jquery

    npm uninstall jquery --save

    2. 安装swiper

    npm install swiper --save-dev

      卸载swiper

    npm uninstall swiper --save-dev

     

    展开全文
  • vue安装依赖出错

    千次阅读 2018-11-20 09:43:39
    给项目安装依赖npm install  发现node-sass版本太低,不符合nodejs的版本环境。 注:npm install命令没有指定任何模块,这是因为npm在默认情况下会查找一个package.json文件,当你需要额外的模块式,将那些模块...

    给项目安装依赖npm install  

    发现node-sass版本太低,不符合nodejs的版本环境。

    注:npm install命令没有指定任何模块,这是因为npm在默认情况下会查找一个package.json文件,当你需要额外的模块式,将那些模块添加进依赖指令中,然后再次运行npm install。依赖指令在package.json文件的dependencies里。

    所以只需要更改package.json的node-sass版本号,提高点就行了。

    还有一种方法是用npm install --save,好像不行

    展开全文
  • vue安装依赖报serve: `vue-cli-service serve`

    万次阅读 多人点赞 2020-10-26 14:24:02
    下载依赖的的仓库没有被授权或者自己设置的下载依赖地址不对,导致依赖下载不下来。 解决办法 1.删除项目中原有的依赖,将整个文件夹删掉:“node_modules ” 执行命令 npm install chromedriver --...

    问题

    问题原因:

    下载依赖的的仓库没有被授权或者自己设置的下载依赖地址不对,导致依赖下载不下来。

    解决办法

    1.删除项目中原有的依赖,将整个文件夹删掉:“ node_modules ”

    执行命令

    npm install chromedriver --chromedriver_cdnurl=http://cdn.npm.taobao.org/dist/chromedriver

    2.再次执行npm install 下载完成

    展开全文
  • VUE安装依赖命令总结

    千次阅读 2019-05-13 09:27:00
    以下是个人用到过的vue安装包以及依赖命令(在接触项目时,有未写到的会随时补充) 1. vuex 作用:vue状态管理 安装:npm install vuex --save 开源地址:github 文档:...

    以下是个人用到过的vue安装包以及依赖命令(在接触项目时,有未写到的会随时补充)

    1. vuex
    作用:vue状态管理
    安装:npm install vuex --save
    开源地址:github
    文档:https://vuex.vuejs.org/zh/
    2. vue-resource
    作用:通过XMLHttpRequest或JSONP发起请求并处理响应
    安装:npm install vue-resource --save
    开原地址:github
    3. vue-router
    作用:路由,控制页面跳转
    安装:npm install vue-router --save
    开原地址:github
    文档:https://router.vuejs.org/zh-cn/
    4. babel-runtime
    作用:将es6编译成es5去运行,前端可以使用es6的语法来写,最终浏览器上运行的是es5
    安装:npm install --save babel-runtime
    5. babel-polyfill
    作用:Babel 默认只转换新的 JavaScript 语法,而不转换新的 API。例如,Iterator、Generator、Set、Maps、Proxy、Reflect、Symbol、Promise 等全局对象,以及一些定义在全局对象上的方法(比如 Object.assign)都不会转译。如果想使用这些新的对象和方法,必须使用 babel-polyfill,为当前环境提供一个垫片
    安装:npm install --save-dev babel-polyfill
    6. fastclick
    作用:处理移动端 click 事件 300 毫秒延迟。
    说明: 为什么存在延迟?从点击屏幕上的元素到触发元素的 click 事件,移动浏览器会有大约 300 毫秒的等待时间。为什么这么设计呢? 因为它想看看你是不是要进行双击(double tap)操作。
    安装:npm install fastclick -D
    开源地址:github
    7. axios
    作用:请求数据
    安装:npm install --save axios
    开源地址:github
    文档:https://www.kancloud.cn/yunye/axios/234845
    8. lodash
    作用:Lodash是一个具有一致接口、模块化、高性能等特性的 JavaScript 工具库。
    安装:npm i --save lodash
    开源地址:github
    文档:http://www.css88.com/doc/lodash/

    9. sass  

    作用:Sass 是一款强化 CSS 的辅助工具,它在 CSS 语法的基础上增加了变量 (variables)、嵌套 (nested rules)、混合 (mixins)、导入 (inline imports) 等高级功能,这些拓展令 CSS 更加强大与优雅。使用 Sass 以及 Sass 的样式库(如 Compass)有助于更好地组织管理样式文件,以及更高效地开发项目。

    安装:npm install node-sass --save-dev      npm install sass-loader --save-dev

    10.less

    作用:Less是一门css预处理语言,它扩展了css语言,革命了css,增加了变量、mixin、函数等特性、使得css更加易于维护和扩展。

    安装:npm install less less-loader --save-dev

     

    转载于:https://www.cnblogs.com/tis100204/p/10854900.html

    展开全文
  • mac vue安装依赖失败

    2019-04-16 09:25:09
    sudo -s 无论如何先执行上面的命令,基本都是权限报错⤵️,或是目录不存在 36 error errno: -13, 36 error code: '...36 error path: '/Users/用户名/Desktop/VUE/项目名称/node_modules' } 37 error The...
  • 1.vue安装依赖于node.js,要确保你的计算机上已安装过node.js。 可进入cmd编辑器,输入命令 node -v进行查看。出现版本信息即成功!没有则从浏览器上面下载安装即可,没有安装要求! 2.确定node安装后,就可以...
  • Vue安装依赖 npm install 失败报错

    千次阅读 2020-04-26 15:49:24
    npm install 报错情况如下 情况一 报错**:errno:-4048;** The operation was rejected by your operation system的解决方法 原因:操作系统不允许 解决方法: ...用管理员权限打开node,再执行命令npm ...再安装...
  • vue安装依赖的版本号控制 注意事项

    千次阅读 2020-12-07 11:00:29
    项目种因为一些的依赖包的版本不一样会造成一些不同的Bug,一般来说新版本都会兼容以前的版本,不过也有很多例外,之前项目种碰到过,比如vue-signature签名插件,之前装了两个不同的版本到导致,一个版本是自动注册...
  • vue安装依赖包时提示core.js安装失败

    千次阅读 2019-04-01 15:26:36
    问题:git上拉下代码,npm i安装依赖包完成后,报错,安装core.js的一些文件失败; 原因:我遇到的是版本问题; 解决:将core-js的版本由3.0.0换成2.6.5,安装成功,项目成功启动; "dependencies": { “axios”: ...
  • 问题: 使用git bash 在项目文node件下安装依赖,有报错,但是出现了node_modules,文件夹,就没解决,继续npm run dev,又报错 以下是npm install 报错 这是npm run dev 报错 ‘“node”’ ▒▒▒▒▒ڲ▒▒▒▒ⲿ...
  • vue项目代码复制到自己电脑上安装依赖时报错:checking for Python executable "python" in the PATH用cnpm来安装即可:步骤:1. 安装cnpm:npm install cnpm -g --registry=...
  • 出现以上的报错,可以用cnpm进行改正: 用cnpm来安装即可: 步骤: 安装cnpm: ...用cnpm安装依赖: cnpm install 完美解决,出现以上错误情况,如果想了解为什么不懂的地方,请看npm和cnpm的区别: ...
  • vue项目依赖安装命令总结

    万次阅读 2018-05-22 13:57:24
    大家都知道通过vue-cli搭建vue项目能够大大提高我们的开发效率,但是vue-cli环境搭建好之后,如果还需要用到一些依赖则需要自己手动安装了,下面我总结了一些可能会用到的依赖安装命令: 1. vuex 作用:vue状态...
  • Vue项目安装运行
  • 当启动vue项目安装依赖时报错

    千次阅读 2019-02-23 21:39:05
    当启动vue项目安装依赖时报错暂时想到四个原因: 1. node版本低,升级到新版本 2. 执行npm cache clean,再重新npm install 3. 如果是下载依赖包失败的话,可以使用cnpm淘宝镜像下载,或者yarn下载安装 4. 报错...
  • 创建vue项目并安装依赖

    万次阅读 2018-02-12 11:48:55
    1.由于vue项目依赖 node.js npm 需要先安装 win+r ==》cmd ==》node -v 回车 会出现node,js的版本  输入npm -v 回车 会出现npm的版本 输入vue -V 回车 会出现vue的版本   2.安装vue npm install -g vue-...
  • vue项目打包,移植到其他地方或者其他电脑上运行开发时往往会发生运行报错,安装依赖报错 一、node_modules版本与本机安装的node和npm版本不一致 我这里是已经修改过了,所以一样,如果版本不一样就修改为一致...
  • –打开cmd窗口 G: cd vueworkspace/pVue –等待安装完成即可 npm install
  • VUE安装环境搭建--依赖安装

    千次阅读 2018-12-12 15:23:32
    不过呢,在此之前,最好先安装一下相关的依赖项。vue的开发,尤其是单页面应用,一般推荐用 vue + vuex + vue-router + vue-resource 来开发,vuex状态管理,vue-router路由管理,vue-resource是与后端数据交互的...
  • Vue依赖注入

    千次阅读 2020-09-03 13:36:16
    Vue依赖注入 依赖注入官方文档 当一个module拥有超过两层的组件时,从后代组件一层层emit出去调用祖先组件的方法或一层层将祖先的数据用props传递到后代组件实在是太麻烦,当需要修改时也需要一层层去找需要修改的...
  • vue 安装 less-loader 依赖时报错

    千次阅读 2021-03-09 14:45:37
    vue-cli 中使用安装了 less-loader 依赖后使用时会报如下错误: 解决 可参考如下方式解决: 1.卸载安装的原 less-loader 版本: 2.项目路径下,打开 cmd 窗口: 3.键入命令:npm install less@3.9.0 less-...
  • vue安装jsx依赖包实现支持jsx语法

    千次阅读 2019-03-08 16:09:04
    1、首先安装依赖: npm install postcss-loader autoprefixer babel-loader babel-core 2、在 .babelrc文件中修改: 把 "presets": ["env", "stage-2"], "plugins"...
  • vue安装百度地图依赖包,以及使用(模块化引入百度地图)       百度地图已经基于Vue开发了对应的组件,我们可以通过引入百度地图依赖包,使用百度地图,步骤如下: 1.安装百度地图...
  • 一、介绍 vue-router是vue官方的路由解决方案,简单易用,中文官方地址如下:vue-router中文手册 二、安装 ...// 引入vue-router路由依赖 import Router from 'vue-router' // 引入首页组件 import i
  • vue-依赖-点击复制

    千次阅读 2020-08-19 15:17:28
    vue-依赖-点击复制 (v-clipboard) 知道它的位置 在vue 官网 /资源列表/Awesome Vue 里面搜索 clipboard 即可以找到 v-clipboard github的地址 https://github.com/euvl/v-clipboard 下载与使用 既然是依赖, ...
  • 基于Echarts的Vue组件依赖关系分析工具
  • 主要介绍了vue踩坑记-在项目中安装依赖模块npm install报错,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友们下面随着小编来一起学习学习吧

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 118,163
精华内容 47,265
关键字:

vue如何安装依赖

vue 订阅