精华内容
下载资源
问答
  • 同网段不同vlan相同网关组网

    千次阅读 2021-03-31 10:36:06
    同网段不同vlan用相同网关组网 一、网络拓扑图 二、网络设备配置 1.LSW1配置文件 sysname Huawei vlan batch 100 200 300 cluster enable ntdp enable ndp enable drop illegal-mac alarm diffserv domain ...

    前段时间遇到一个客户需求是要求同网段不同vlan用相同网关组网,如下拓扑图PC1和PC2是属于相同的网段,但是属于不同的vlan。

    一、网络拓扑图
    在这里插入图片描述

    二、网络设备配置
    1.LSW1配置文件
    display current-configuration

    sysname SW1

    vlan batch 100 200 300

    cluster enable
    ntdp enable
    ndp enable

    drop illegal-mac alarm

    diffserv domain default

    drop-profile default

    aaa
    authentication-scheme default
    authorization-scheme default
    accounting-scheme default
    domain default
    domain default_admin
    local-user admin password simple admin
    local-user admin service-type http

    interface Vlanif1

    interface MEth0/0/1

    interface GigabitEthernet0/0/1
    port hybrid pvid vlan 100
    port hybrid untagged vlan 100 200 300

    interface GigabitEthernet0/0/2
    port hybrid pvid vlan 200
    port hybrid untagged vlan 100 200 300

    interface GigabitEthernet0/0/3
    port hybrid pvid vlan 300
    port hybrid untagged vlan 100 200 300

    interface GigabitEthernet0/0/4

    interface GigabitEthernet0/0/5

    interface GigabitEthernet0/0/6

    interface GigabitEthernet0/0/7

    interface GigabitEthernet0/0/8

    interface GigabitEthernet0/0/9

    interface GigabitEthernet0/0/10

    interface GigabitEthernet0/0/11

    interface GigabitEthernet0/0/12

    interface GigabitEthernet0/0/13

    interface GigabitEthernet0/0/14

    interface GigabitEthernet0/0/15

    interface GigabitEthernet0/0/16

    interface GigabitEthernet0/0/17

    interface GigabitEthernet0/0/18

    interface GigabitEthernet0/0/19

    interface GigabitEthernet0/0/20

    interface GigabitEthernet0/0/21

    interface GigabitEthernet0/0/22

    interface GigabitEthernet0/0/23

    interface GigabitEthernet0/0/24

    interface NULL0

    user-interface con 0
    user-interface vty 0 4

    return
    2.LSW2配置文件
    display current-configuration

    sysname SW2

    vlan batch 2 300

    cluster enable
    ntdp enable
    ndp enable

    drop illegal-mac alarm

    diffserv domain default

    drop-profile default

    aaa
    authentication-scheme default
    authorization-scheme default
    accounting-scheme default
    domain default
    domain default_admin
    local-user admin password simple admin
    local-user admin service-type http

    interface Vlanif1

    interface Vlanif2
    ip address 192.168.2.1 255.255.255.252

    interface Vlanif300
    ip address 192.168.1.1 255.255.255.0

    interface MEth0/0/1

    interface GigabitEthernet0/0/1
    port hybrid pvid vlan 300
    port hybrid untagged vlan 100 200 300

    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 2

    interface GigabitEthernet0/0/3

    interface GigabitEthernet0/0/4

    interface GigabitEthernet0/0/5

    interface GigabitEthernet0/0/6

    interface GigabitEthernet0/0/7

    interface GigabitEthernet0/0/8

    interface GigabitEthernet0/0/9

    interface GigabitEthernet0/0/10

    interface GigabitEthernet0/0/11

    interface GigabitEthernet0/0/12

    interface GigabitEthernet0/0/13

    interface GigabitEthernet0/0/14

    interface GigabitEthernet0/0/15

    interface GigabitEthernet0/0/16

    interface GigabitEthernet0/0/17

    interface GigabitEthernet0/0/18

    interface GigabitEthernet0/0/19

    interface GigabitEthernet0/0/20

    interface GigabitEthernet0/0/21

    interface GigabitEthernet0/0/22

    interface GigabitEthernet0/0/23

    interface GigabitEthernet0/0/24

    interface NULL0

    user-interface con 0
    user-interface vty 0 4

    return
    3.PC1配置

    在这里插入图片描述
    4.PC2的配置
    在这里插入图片描述
    5.PC4的配置
    在这里插入图片描述
    三、测试
    1、PC1分别ping PC2和PC4
    在这里插入图片描述
    可以通。
    2、PC2分别ping PC1和PC4
    在这里插入图片描述
    3、PC4分别ping PC1和PC2
    在这里插入图片描述
    我们通过hybrid类型接口实现了客户的需求:在不同vlan相同网段下实现通讯

    展开全文
  • 你知道纯二层网络,如何实现同网段不同vlan通信吗? 你知道通过代理ARP,如何实现同网段不同vlan通信吗? 你知道Vxlan架构,如何实现同网段不同vlan通信吗? 我会通过一系列场景,给大家分析一下网络通信的原理...

    你知道纯二层网络,如何实现同网段不同vlan通信吗?

    你知道通过代理ARP,如何实现同网段不同vlan通信吗?

    你知道Vxlan架构,如何实现同网段不同vlan通信吗?

    我会通过一系列场景,给大家分析一下网络通信的原理,但是三种方式内容太多,所以今天就先给大家讲讲纯二层网络下,如何实现同网段不同vlan通信,后续再给大家分享另外两种方式。

    拓扑如图,pc1属于vlan 10,pc2属于vlan 20

    两台交换机互连接口为trunk模式,左边交换机trunk口的pvid是10,右边交换机的pvid是20

     

    通信原理:

    1. PC1访问PC2,判断目标主机是否同网段,是
    2. PC1发出针对PC2的ARP请求,ARP报文进入左边的交换机
    3. 左边的交换机会从trunk口将arp报文发出,因为pvid=10,所以属于vlan 10 的PC1的报文不带tag
    4. 右边的交换机从trunk口收到一个不带tag的arp报文,会查看这个接口的pvid是多少,发现pvid是20,那么就认为这个报文属于vlan 20
    5. 右边交换机从vlan 20的access接口将arp报文发出,PC2收到
    6. PC2给PC1回应ARP,完成ARP解析,接下来正常封装数据报文,实现双方的通信。

    配置过程:

    左边交换机配置

    interface GigabitEthernet0/0/1

     port link-type access

     port default vlan 10

    #

    interface GigabitEthernet0/0/3

     port link-type trunk

     port trunk pvid vlan 10

     port trunk allow-pass vlan 10

    右边交换机

    interface GigabitEthernet0/0/1

     port link-type access

     port default vlan 20

    #

    interface GigabitEthernet0/0/3

     port link-type trunk

     port trunk pvid vlan 20

     port trunk allow-pass vlan 20

    结果测试:

     

    小思考:如果两台交换机不用trunk互连,而是用access互连,是否可以实现PC间通信?

    在《纯二层网络,如何实现同网段不同VLAN通信》的内容已经讲完啦,喜欢记得点赞收藏哦~

       当然,如果你需要网工学习资料,可以私我哦~
     

     

    展开全文
  • 相同VLAN相同网段,相同VLAN不同网段不同VLAN相同网段不同VLAN不同网段,有这四种情况!首先大家要明白host发包的机制:Host们在将包发送到不同网段的主机时的机制是这样的:host会将目的地址与子网掩码进行与...

    最近上网看帖子,发现这个

    VLAN

    、网段之间很纠结。

    我想阐明一下;

    相同

    VLAN

    相同网段

    相同

    VLAN

    不同网段

    不同

    VLAN

    相同网段

    不同

    VLAN

    不同网段

    ,有这四种情况!

    首先大家要明白

    host

    发包的机制:

    Host

    们在将包发送到不同的网段的主机时的机制是这样的:

    host

    会将目的地址与子网掩码

    进行与运算(

    1^1=1

    剩下的都是

    0

    )

    ,得到的结果是

    host

    发现目的地址与自己不再同一网段,

    所以

    host

    要查看它有没有默认网关的

    MAC

    地址,没有的话就需要用配置好的网关的

    IP

    址来进行

    ARP

    请求了,得到

    MAC

    地址后,

    host

    就将数据包发送到网关别的什么都不管了。

    交换机的转发机制:

    如果它从某个端口收到数据包,它会向相同的

    VLAN

    端口去转发,或者向允许这个

    VLAN

    通过的

    TRUNK

    端口去转发。

    情况

    1.

    相同

    VLAN

    ,相同网段

    这个二层就能通信的,

    三层不能通信,

    所以同一交换机下或跨交换机能通信,

    但不能跨路由

    器通信,为什么呢?

    因为首先网段相同,所以

    host

    会进行

    ARP

    查询寻找目的地址的

    MAC

    地址,这个时候

    SW

    会先看看都有哪些端口和

    host

    是同一个

    VLAN

    的,然后转发泛洪,

    host

    会得到目的地址的

    MAC

    地址的。所以可以进行通信。但是三层不能通信,因为路由器不允许它的任意两个接

    口配置到同一个网段中。

    情况

    2.

    相同

    VLAN

    ,不同网段

    这个二层不能通信,

    三层可以通信的,

    所以同一交换机下或跨交换机不能通信,

    但能跨路由

    器通信,为什么呢?

    我们再来重复上面的步骤,首先网段是不同的,所以

    host

    会将数据包发送给网关,然后静

    候佳音,

    而网关发现这个网段需要路由就开始查找路由表,

    网关肯定找不到这个网段也就无

    法路由,

    丢包。

    网关为什么不能找到这个网段呢,

    因为一个路由器上的端口如果不配置子接

    口或者从地址的话是不能配置两个网段的。

    但是如果是两个交换机分别接到路由器的两个接

    口上就可以了,因为是通过三层路由转发,而二层的

    VLAN

    允许同

    VLAN

    端口间的

    ARP

    请求,所以这个要看网络拓扑。

    情况

    3.

    不同

    VLAN

    ,相同网段

    这个二层三层都不可能实现通信,

    所以同一交换机下或跨交换机不能通信,

    也不能跨路由器

    通信,为什么呢?

    首先,不同

    VLAN

    就意味着不能通过二层通信,而同网段就意味着路由器的两个接口要配

    置为同一个网段,但是这个根本就不符合路由器的配置规范。

    情况

    4.

    不同

    VLAN

    ,不同网段

    这个二层不能通信,

    但是三层可以通信,

    所以同一交换机下或跨交换机不能通信,

    但能跨路

    由器通信,为什么呢?

    不同的

    VLAN

    意味着不能通过二层通信,而不同网段却可以通过路由器路由转发。

    2015.4.25

    日——

    sniffer

    展开全文
  • 一:实验要求 二:实验目的 pc2 可以ping 通 pc4 5 6 ...①三台交换机 全部创建 所有vlan 2-6 SW1 2 3 下 ② SW1 用户接口配置 G0/0/11 interface GigabitEthernet0/0/11 port link-type access

    一:实验要求
    在这里插入图片描述二:实验目的
    pc2 可以ping 通 pc4 5 6
    pc4 可以ping 通 pc2 5 不能ping 通pc6
    pc5 可以ping 通 pc2 4 不能ping 通 pc6
    pc6 只能ping 通 pc2

    三:实验步骤

    ①三台交换机 全部创建 所有vlan 2-6 SW1 2 3 同下
    在这里插入图片描述

    ② SW1 用户接口配置

    G0/0/11 
    
    interface GigabitEthernet0/0/11
     port link-type access        //改接口为接入模式
     port default vlan 3       //划分到vlan3 仅允许vlan3通过  不标记 
    
    G0/0/12
    
    interface GigabitEthernet0/0/12
     port hybrid pvid vlan 2       
     port hybrid untagged vlan 2 4 to 6
     
      //混杂模式  接口不能直接划入vlan    手动修改pvlan  就是 vlan
     //手动添加允许列表,untagged 不标记 pc2 可以ping通 4 5 6  
             还需要允许自身vlan   不打标签
    

    ③SW2用户接口配置

    G0/0/13
    
    interface GigabitEthernet0/0/13
     port link-type access              //改接口为接入模式
     port default vlan 3      //划分到vlan3 仅允许vlan3通过  不标记
    
    G0/0/14
    
    interface GigabitEthernet0/0/14
     port hybrid pvid vlan 4
     port hybrid untagged vlan 2 4 to 5  //可以ping 2 5 不能ping 6
    

    ④SW3用户接口配置

    G0/0/15
    
    interface GigabitEthernet0/0/15
     port hybrid pvid vlan 5
     port hybrid untagged vlan 2 4 to 5  //可以ping 2 4 不能ping 6
    
    G0/0/16
    
    interface GigabitEthernet0/0/16
     port hybrid pvid vlan 6
     port hybrid untagged vlan 2 6      //只能ping 2
    

    四:TRUNK模式

    ①:
    在这里插入图片描述

    SW1        G0/0/2 
    
    interface GigabitEthernet0/0/2
     port link-type trunk                   //trunk模式
     port trunk allow-pass vlan 2 to 6      //允许通过的vlan
    
    SW2        G0/0/2
    
    interface GigabitEthernet0/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 6
    

    ②:
    在这里插入图片描述

    SW2        G0/0/3
    
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 6
    
    SW3        G0/0/3
    
    interface GigabitEthernet0/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 6
    

    五:pc 的IP地址和vlan 划分

    在这里插入图片描述六:测试

    1:pc2 可以ping 通 pc 4 5 6
    在这里插入图片描述在这里插入图片描述

    2:pc4 可以ping 通 pc2 5 不能ping 通pc6
    在这里插入图片描述在这里插入图片描述

    3:pc5 可以ping 通 pc2 4 不能ping 通 pc6
    在这里插入图片描述在这里插入图片描述

    4:pc6 只能ping 通 pc2

    在这里插入图片描述在这里插入图片描述

    七:实验总结

    1:关于 Hybrid 接口 tangged 和 untagged
    ①Tagged 用于交换机之间, 让所有 VLAN 的流量均带标签发送
    ②Untagged 用于连接用户的接口,让发送给用户的 VLAN 流量剥离标签。
    (一般将允许通信的 VLAN 设置为 untagged)

    2:trunk 干道
    进入接口后先修改接口类型为 trunk 模式;再定义该 trunk 干道可以允许通过的 vlan;
    默认 trunk 干道的 PVLAN-类似 cisco 的 native vlan 为 vlan1,默认对 vlan1 的流量不标记,
    且其他添加到允许 列表也可正常通过

    3:单臂路由—----子接口
    交换机连接路由器的那个交换机接口修改 trunk 模式

    [RTA]interface GigabitEthernet0/0/1.1 
    [RTA-GigabitEthernet0/0/1.1]dot1q termination vid 2 
    [RTA-GigabitEthernet0/0/1.1]ip address 192.168.2.254 24 
    [RTA-GigabitEthernet0/0/1.1]arp broadcast enable //分支开启arp
    
    [RTA]interface GigabitEthernet0/0/1.2 
    [RTA-GigabitEthernet0/0/1.2]dot1q termination vid 3 
    [RTA-GigabitEthernet0/0/1.2]ip address 192.168.3.254 24 
    [RTA-GigabitEthernet0/0/1.2]arp broadcast enable
    

    4:DHCP 池塘配置

    [r1]interface GigabitEthernet 0/0/0.1 
    [r1-GigabitEthernet0/0/0.1]dhcp select global
    

    再定义池塘

    ip pool v3 
    gateway-list 192.168.2.1                            // 网关 
    network 192.168.2.0 mask 255.255.255.0             //地址段 
    dns-list 114.114.114.114                          //dns
    
    展开全文
  • 在同一网段划分不同VLAN

    千次阅读 2020-03-17 23:56:58
    在同一网段划分不同VLAN 1.在不同网段划分vlan,与在同一网段划分vlan的区别? 划分VLAN其IP地址可能是在一个网段内,其主要作用是为了防止网络风暴 2.设置vlan与设置不同网段有什么区别? 通过交换机划分2个VLAN ...
  • hybrid实现相同网段不同VLAN通信

    千次阅读 2020-12-01 16:32:23
    实验说明:本次实验使用三台PC,三台PC配置为同一网段,划分为三个不同VLAN,通过PVID实现vlan30和vlan20能够互相通信,其余vlan不能通信。 交换机(LSW)配置 命令解析: port hybrid pvid vlan 10 PC1连接交换机的...
  • PC-10和PC-30是不同网段下,同一VLAN里的两台PC,现在想将其ping通 1. 两个PC都不设置网关 PC-10-1 ip:192.168.10.11 子网:255.255.255.0 网关:.0.0.0.0 PC-30-1 ip:192.168.30.13 子网:255.255.255.0 网关...
  • 同VLAN不同网段能否ping通

    千次阅读 2021-01-25 21:13:33
    一个vlan同一个网段的ip地址能够直接互通,那么一个vlan不同网段能不能互通呢?本期我们推荐一篇文章,可以解决大家在网络中遇到的一些奇怪的问题,也是加深对网络的理解。 同VLAN不同网段能否Ping通 前面我们...
  • 某企业网络中,同一VLAN的主机分别属于两个网段10.1.1.1/24和10.1.2.1/24,要求这两个网段的主机都可以通过Router访问Internet,且这两个网段中的主机能够互通。配置思路针对上述需求,如果在Router的VLANIF接口上只...
  • 是对IP地址的划分,不同网段之间必须通过三层设备访问,因为在寻址过程中,第一步就是判断是否位于同一网段,如果是则直接交付,否则发送给默认网关vlan同样是二层概念,与IP没有任何关系,也就和网段没有任...
  • eNSP网络仿真——VLAN间路由实验 实验拓扑如图: 实验配置如下: 设备 接口 IP地址 子网掩码 网关 PC-1 Ethernet 0/0/1 198.168.1.1 255.255.255.0 192.168.1.254 PC-2 Ethernet 0/0/1 198.168.1.2 255....
  • 在LSW1上配置vlan10内所有主机的网关,使所有主机之间能够相互通信。 三、网络配置 (1)、display current-configuration sysname SW1 vlan batch 10 interface Vlanif10 ip address 192.168.1.1 255.255.255.0 ...
  • 不同vlan不同网段互访

    千次阅读 2019-07-12 23:43:16
    那么,通过不同VLAN隔离的两个网段如何通讯呢? 实现不同VLAN之间的访问,有两种方式: 一种是通过三层交换机,通过默认网关的方式实现不同VLAN之间的访问;一种是通过路由器,利用路由器的子...
  • 配置技术部PC0得IP,子网掩码,网关等2:配置财务部PC1得IP,子网掩码,网关等3:配置技术部PC2得IP,子网掩码,网关等4:配置技术部PC3得IP,子网掩码,网关等二层交换机下配置划分各部门VLAN1:左侧sw1二层交换机创建...
  • VLAN间路由 即在不同VLAN 之间,配置好网关设备,确保不同网段互通 实现方案: 路由器 - 每个VLAN均使用一个独立的路由器接口,配置好网关IP 优点:简单易懂 缺点:浪费端口 多层交换机 - 为每个 VLAN 配置...
  • [(1)在二层交换机上配置VLAN2、...(3)在三层交换机上配置V一、华为三层交换机实现不同网段不同vlan间互通目标实现:pc1和pc2之间互通1、拓扑图 2、三层交换机配置:display current-configuration#sysname S1#VLAN...
  • 通过VLANIF实现同VLAN不同网段通信

    千次阅读 2019-01-01 20:59:06
    如图1所示,某企业网络中,同一VLAN的主机...图1 配置通过VLANIF实现同VLAN不同网段通信组网图 配置思路 针对上述需求,如果在Router的VLANIF接口上只配置一个IP地址,则只有一个网段的主机能够通过Router访问Inter...
  • 实现不同网段vlan互访

    2020-09-21 20:40:52
    二层设备依据拓扑创建vlan,实现同vlan互访。 1.sw1创建vlan100、vlan200. 2.将接口加入相应的vlan。 验证: 二、实现跨交换机相同vlan互访。 1.sw1、sw2开启trunk,并允许vlan通过。 2. 创建vlan100、vlan...
  • 发现不同网段,这个时候就要去找网关了,(默认情况下网关都跟自己是一个网段的,这里我们把网关设置跟自己不同一个网段,在windows下会提示警告的,不过PC自己可不关心,反正它就觉得网关就在我这个vlan里面的,...
  • 发表于2013-1-2414:53|来自51CTO网页[只看他]一个三层交换机上的VLAN,在配置完INTERFACEVLAN的IP以后,不同VLAN的主机,可以通过网关过进行转发。。这叫直连路由!!一个三层的直连地址段!!1、在一个VLAN...
  • 又开始纠结起来这个问题了,两个PC连接一台二层交换机,或者一台关闭路由功能的三层交换机,把连接PC的交换机端口划入一个vlan中,但是两个pc的ip地址不在一个网段,能否互相ping通?默认情况下所有交换机端口...
  • 摘要:描述:在三层交换机上配置DHCP,实现DHCP为PC1/PC3分配192.168.1.X网段;实现DHCP为PC2/PC4分配192.168.2.X网段;并且各个PC间要可以互相通信。(文末附实验题,排错题,答案)引言:强调几个重点的命令:ip...
  • 不同vlan不同网段的通信 - 副本

    千次阅读 2020-04-15 20:49:09
    1������vlan��ȫ��ģʽconf t��vlan * exit 2����vlan����˿ڣ�conf t�� ����˿� interface fastetherent 0/1 �������˿ڷ���˿ڣ� �� interface range fastetherent 0/1-...
  • 人主必信,信而又信,谁人不亲? ——吕不韦 文章目录简单概述从IP地址拓扑基本配置测试 简单概述 在园区网业务中,很多客户都强烈要求不划分VLAN的,但业务却不只一种...如何使用同一VLAN不同网段的数据互通? 首先.
  • 1.基于Hybrid端口的相同网段不同VLAN之间的相互通信 二、注意事项 1.port hybrid untagged/tagged vlan ID: ①.当这个端口收到VLAN帧时,表示允许通过的VLAN列表 ②.当这个端口发送VLAN帧时,不仅表示允许通过...
  • 1、实验要求:两台PC机vlan不相同网关不相同,要求互通2、实验步骤;--配置终端IP;--交换机创建vlan ,把 对应的端口加入vlan;--配置路由器网关;--验证两台PC机之间的互通。3、实验拓扑图;-物理接口4、配置命令;...
  • 如图可以使PC1、PC2、PC3、PC4、...配置PC1/PC2/PC3/PC4/PC5的IP,子网掩码,网关如图:2.配置Switch1如下:<Huawei>undo terminal monitor Info: Current terminal monitor is off.<Huawei>system-view...
  • 同vlan不同网段能否ping通

    万次阅读 2014-08-22 20:09:34
    发现不同网段,这个时候就要去找网关了,(默认情况下网关都跟自己是一个网段的,这里我们把网关设置跟自己不同一个网段,在windows下会提示警告的,不过PC自己可不关心,反正它就觉得网关就在我这个vlan里面的,...
  • 本次使用ensp模拟器模拟两台华为三层交换机如何配置不同网段不同vlan之间如何互通。网络拓补图如下图所示: IP地址如下: pc1:10.1.1.2 / 24 pc2 :10.1.2.2 / 24 pc3:192.168.1.2 /24 pc4:192.168.2.2 / 24 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 14,638
精华内容 5,855
关键字:

同网段不同vlan的网关