精华内容
下载资源
问答
  • vue.config.js module.exports={ davServer:{ port:8000, //端口号 open:true , //自动打开浏览器 https:false, //https host:'localhost', //端口号 }, // 关闭eslint lintOnSave:false }

    vue.config.js

    module.exports={
        davServer:{
            port:8000, //端口号
            open:true , //自动打开浏览器
            https:false, //https
            host:'localhost', //端口号
        },
        // 关闭eslint
        lintOnSave:false
    }
    

    安装iview

    npm install view-design --save
    

    main.js引入

    import ViewUI from 'view-design';
    import 'view-design/dist/styles/iview.css';
    
    Vue.use(ViewUI);
    

    引入bootstrap
    public文件夹下面新建一个static文件夹
    index.html引入

     <link rel="stylesheet" href="static/bootstrap.min.css" type='text/css'>
      <link rel="stylesheet" href="static/icon" >
    

    static下新建icon

    安装vue-router

    npm install vue-router --save
    

    src下新建router.js

    import Vue from "vue";
    import Router from "vue-router";
    import Home from "./views/Home.vue";
    
    Vue.use(Router);
    
    export default new Router({
      routes: [
        {
          path: "/",
          name: "home",
          component: Home
        },
    });
    

    main.js引入

    展开全文
  • VUE如何关闭Eslint 的方法 猿妞儿 2018-08-26 15:44:30 7477...

    vue新版本和旧版本关闭eslint总结

    一般创建vue项目时候,会遇见选择eslint,对于新手来说无疑是个麻烦,一不小心点了是一堆报错。这时候就要关了它。
    vue旧版本关闭eslint
    指vue cli3以前版本
    找到build文件夹—>webpack.base.conf.js—>module—rules
    在这里插入图片描述
    网上随便找的图,大致能看清。
    将这里关于eslint的代码注释掉就可以了
    vue新版本
    即vue cli3以后的构建环境时没有build文件夹
    一种办法重建个vue2的,当然不推荐了
    第二种建个vue.config.js,放在当前目录下,就是最外面。
    在这里插入图片描述
    截张图,就这个位置,再将下面代码copy进去就ok了

    module.exports = {
        lintOnSave: false
    }
    
         
    • 1
    • 2
    • 3

    再运行就没事了
    痛恨版本问题,当初webpack一些版本更新就让我头痛

    展开全文
  • 问题描述 遇到一种情况,就是使用...其实导致这个原因是从vue-cli 3.0版本开始原来的npm install -g vue-cli 安装的都是旧版,最高到2.9.6,安装新版必须是的命令npm install -g @vue/cli 这就导致了,如果我们再2.9.

    问题描述

    遇到一种情况,就是使用vue --version 查看版本始终是2.9.6,安装命令是npm install @vue/cli ,按理说是最新版本,但是还是显示旧版,使用vue create 【项目名称】 提示是要卸载脚手架在安装,但是安装后还是2.9.6.

    原因

    其实导致这个原因是从vue-cli 3.0版本开始原来的npm install -g vue-cli 安装的都是旧版,最高到2.9.6,安装新版必须是新的命令npm install -g @vue/cli 这就导致了,如果我们再2.9.6版本还存在的情况下再使用npm install -g @vue/cli 命令就会同时存在两个版本,你用vue create 【项目名称】命令会先找到旧版的,就会提示你卸载旧版安装新版。

    解决办法

    第一步(卸载老版本,卸载新版本)

    npm uninstall -g vue-cli 卸载旧版、 npm uninstall -g @vue/cli 卸载新版

    第二步(卸载本地残留文件,cmd进入,输入指令where vue 查找文件位置,然后进行删除)

    // cmd进入,输入指令where vue 查找文件位置,然后进行删除
    C:\Windows\system32>where vue
    C:\Users\岩\AppData\Roaming\npm\vue
    C:\Users\岩\AppData\Roaming\npm\vue.cmd
    
    C:\Windows\system32>
    

    第三步(安装vue-cli)

    C:\Windows\system32>npm install -g @vue/cli @vue/cli-service-global
    
    

    第四步(查看版本,看是否安装成功)

    C:\Windows\system32>vue --version
    @vue/cli 4.5.15
    
    C:\Windows\system32>
    
    
    展开全文
  • 1 查看 node 版本 node -v 2 查看npm 版本 npm -v 安装淘宝镜像cnpm ...3 安装最新的vue ...npm install -g vue-cli — 这个命令已经废弃了3.0以后 ...npm install -g @vue/cli@版本号 例如 : npm i.

    1 查看 node 版本

    node -v

    2 查看npm 版本

    npm -v

    安装淘宝镜像cnpm

    npm install -g cnpm --registry=http://registry.npm.taobao.org 

    3 安装最新的vue

    npm install -g vue-cli — 这个命令已经废弃了3.0以后

    npm/cnpm install -g @vue/cli

    4 安装指定版本的vue

    npm install -g @vue/cli@版本号

    例如 :

    npm install -g @vue/cli@3.11.0

    5 卸载vue

    npm uninstall -g @vue/cli

    展开全文
  • vue-cli安装最新版的: 卸载2.x版本vue-cli : npm uninstall -g vue-cli 或 yarn global remove vue-cli 安装3.x版本的@vue/cli : npm install -g @vue/cli 或 yarn global add @vue/cli 再次输入 vue -V 检验:
  • 1、vue-cli4.4.6版本创建项目,没有vue3的选项(vue-cli4.5.x才会有) 2、卸载vue-cli4.4.6版本后安装版本为2.9.6版本 3、vue-cli2.9.6版本一直卸载失败 npm uninstall : 《1》4.4.6版本时npm卸载报错, 《2》...
  • vue3.2版本新特性

    千次阅读 2021-08-16 09:50:54
    Vue 3.2 版本包括许多重要的功能和性能改进,但并不包含重大更改。 Vue 3.2 原文链接 主要更新如下: 1. 的单文件组件功能 <script setup> 是一种编译时语法糖,可在 SFC 内使用 Composition API 时极大...
  • npm create 命令是基于 vue.... npm install -g @vue/cli // 安装新版本cli @vue/cli3.0增加一个可视化项目管理工具,全局安装完成cli3.0之后,可以直接在cmd输入命令:vue ui 启动即可,地址默认是localhost:800...
  • import babel-polyfill
  • 如何升级Vue版本 vue2.9.6升级到vue3.0

    万次阅读 多人点赞 2020-12-19 15:45:04
    如何升级Vue的版本 vue2.9.6升级到vue3.0卸载原来的版本安装新版本通过GUI界面创建项目 卸载原来的版本 由于目前的vue3.0支持通过UI界面创建vue项目,所以对于学vue前端的人来说是相当大的诱惑。界面效果如下图所示 ...
  • vue2.9 升级到最新版本

    2021-05-21 15:03:54
    #卸载 npm uninstall vue-cli -g #安装 npm install -g @vue/cli
  • vue3:vue3版本变化

    2021-04-23 22:29:54
    css样式穿透 /deep/失效 vue3+vue-cli4里面/deep/自测不生效。 请使用 :deep(.className){ } 九. 增加 css动态样式 在style里面使用v-bind()动态更改样式,编译后是一个var()函数 <template> ...
  • npm install -g @vue/cli@3.12.0 @后面是版本号 2.安装完成后查看 使用过 vue -V 查看vue/cli版本号 (如果查看找不到版本,使用命令行创建项目vue create my-demo也无效,那就需要用管理员方式打开Windows ...
  • 脚手架版本和vue版本两者没有必然...新版本脚手架vue-cli3+,创建项目命令:官网介绍 vue create hello-world 老版本脚手架vue-cli,创建项目命令:官网介绍 vue init webpack <project-name> 两个版本.
  • vue cli 版本更改

    2021-08-17 20:35:09
    耗时6.18小时 快吐了 ...由于(vuevuecli)版本不同 一直报错 试了N种方法 最后一气之下 直接手动修改package.json 里的version版本 (不放心的话,改之前 复制一个package.json副本) 然后可以了 ...
  • 背景 开的vue3项目 需要用到层叠轮播图 首先想到了swiper插件,安装之后是 swiper7 版本 注意swiper7只能在vite中直接引入使用,因为它是基于esm模块编写的,webpack默认是cjs规范,不支持esm,除非你在webapck...
  • VUE安装与配置

    2021-10-20 20:19:14
    官网下载最新版本:Node.js官网下载https://nodejs.org/en/download/ 可以下载安装包Node.js安装教程https://www.runoob.com/nodejs/nodejs-install-setup.html 或者下载zip文件找个目录保存,解压...
  • Vue 新版本的理念成型于 2018 年末,当时 Vue 2 的代码库已经有两岁半了。比起通用软件的生命周期来这好像也没那么久,但在这段时期,前端世界已经今昔非比了。 在我们更新(和重写)Vue 的主要版本时,主要考虑两点...
  • 在默认情况下,node和vue并没有配置环境变量,所以默认npm安装路径在:C:\Users\Myn\AppData\Roaming\npm\node_modules文件夹下,而node.js我们一般安装在D盘,这样就会有路径冲突,所以需要通过修改环境变量的方式...
  • npm install vue-router -S # 卸载 npm uninstall vue-router vite # 安装 npm install vue-router@next -S # 卸载 npm uninstall vue-router@next 2. yarn 默认 # 安装 yarn add vue-router -S # 卸载 ...
  • 1.打开cmd,输入命令 where vue .查找文件的目录,根据目录找的vuevue.cmd文件,将其删除。 2.在cmd内,输入npm config set prefix命令。 3.输入npm install -g @vue/cli 命令即可。...4.查看vue/cli版本 vue -V
  • 关于卸载Vue版本

    2021-10-27 14:22:38
    vue ui 无反应,原因是旧版本不支持,于是得重装新版本。 卸载方式: 1. 打开cmd,输入where vue查看安装路径 2.复制路径找到npm文件夹下的node_modules,进去把关于Vue的文件夹都删除。 3.重新安装最新版本...
  • 在 使用npm install -g @vue/cli 命令安装Vue的脚手架之后,运行Vue -V 发现Vue版本竟然是2.9.6, 然后各种卸载重装一直都没有用,从网上找了各种方法,分别为以下几种: npm uninstall -g vue-cli npm install...
  • vue-cli4和vue-cli3区别还是挺大的,所以我想先卸载掉当前的vue版本 npm uninstall -g @vue/cli 然后指定版本下载 npm install -g @vue/cli@版本号 但是发现下载完还是之前的版本 这时候我们首先需要卸载掉不...
  • Ubuntu安装vue环境

    2021-04-07 23:14:37
    1 安装vmware(VMware Workstation v16.1.1),并且安装好ubuntu(本人下载的版本:ubuntu-21.04-beta-desktop-amd64),此处自行查找。安装好系统后,并设置root密码(第一次切换,请注意root密码设置),此处自行...
  • Vue-router的使用(vue3.0版本)

    千次阅读 2021-08-20 15:17:47
    vue-router 使用过程一级目录二级目录三级目录 一级目录 vue-router有三个概念 route, routes, router。 1, route,一条路由,它是单数,点击内容后跳转到指定内容,index按钮 => index内容, 这是一条route, ...
  • 版本升级步骤: 1.删除本地的node 重新下载最新版本 链接和步骤:https://nodejs.org/zh-cn/download/ 2.更新Vue的脚手架 命令行输入 cnpm install -g @vue/cli 3.版本查看 vue -V
  • 啊哈,相信很多学vue的新手跟我一样踩了vue3中插件和配置各个版本的坑! 呐,今天小琬就在这里分享一下vue3和vue2中router.js和main.js分别写什么吧! 先是Vue3 router.js的代码 main.js ————————...
  • 今天来记录一下vue脚手架的安装过程(macOS Monterey版本) 本次安装之前无node.js和webpack 第一步:下载和自己对应的node.js https://nodejs.org/en/ 第二步: 安装淘宝景象,否则后面下载会特别慢。 sudo npm ...
  • 查看Vue版本号 (1)法一:代码方式 `npm list vue` (2)法二:其他方式 找到package.json文件夹,找“dependencies”,然后就可以看到你装的vue版本了 ————————————————————————...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 75,159
精华内容 30,063
关键字:

vue新版本

vue 订阅