VPDN虚拟拨号<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

CISCO2600路由器配置ADSL线路实现中小企业上网(CISCO VPDN PPPOE应用)

 

  名词解释:VPDN

 

  VPDN是基于拨号接入(PSTNISDN)的虚拟专用拨号网业务,可用于跨地域集团企业内部网、专业信息服务提供商专用网、金融大众业务网、银行存取业务网等业务。

  VPDN采用专用的网络安全和通信协议,可以使企业在公共网络上建立相对安全的虚拟专网。×××用户可以经过公共网络,通过虚拟的安全通道和用户内部的用户网络进行连接,而公共网络上的用户则无法穿过虚拟通道访问用户网络内部的资源。

 

 

 

  VPDN技术适用于以下范围:

 

 

  地点分散,在各地有分支机构,移动人员特别多的用户,例如企业用户、远程教育用户。  人员分散,需通过长途电信甚至国际长途手段联系的用户。

  对线路的保密和可用性有一定要求的用户。

 

 

  此外,通过VPDN技术,可实现对特定站点的封闭,可向小ISP和大集团用户提供一次、多次端口批发业务。

  VPDN网络结构由局端(或称为中心端)和客户系统组成。VPDN客户系统包括两部分:企业端与远端。通常企业端是企业的内部局域网,以专线方式接入UNINET;远端是拨号客户,以拨号方式访问企业内部局域网。

  案例分析:

  此案例为XX电信adsl PPPoE接入,需要使用一个普通adsl modem和一台cisco 2600路由器(双以太口),IOS 12.215T,能够实现局域网共享上网。  此案例配置共分7步:

 

 

  第一步:配置vpdn

 

 

 

  vpdn enable(启用路由器的虚拟专用拨号网络——***d

vpdn-group 1(建立一个vpdn组,) 

 request-dialin(初始化一个***d tunnel,建立一个请求拨入的vpdn子组,)

 

  protocol pppoevpdn子组使用pppoe建立会话隧道)

 

第二步: 配置路由器连接adsl modem的接口

 

 

  interface fastethernet0/0

 

 

no ip address

NO SH

  pppoe enable允许以太接口运行pppoe

 

 

pppoe-client dial-pool-number 1

将以太接口的pppoe拨号客户端加入拨号池1 

 第三步:配置逻辑拨号接口:

 

 

 

 

  interface Dialer1

 

  ip address negotiatedadsl服务商动态协商得到ip地址

 

  ip nat outside为该接口启用NAT

 

 

  encapsulation ppp为该接口封装ppp协议

 

 

 

  dialer pool 1该接口使用1号拨号池进行拨号

  dialer-group 1该命令对于pppoe是意义不大的

 

  ppp authentication pap callin启用ppp pap验证

 

 

 

 

  ppp pap sent-username xxxxxxx password 000000使用已经申请的用户名和口令

 

 

 

 

  第四步:配置内部网络接口

 

 

interface FASTEthernet0/1(内部网络接口)

  ip address 192.168.10.254 255.255.255.0

 

 NO sh

  ip nat inside为该接口启用NAT

  第五步:配置路由器为内部网络主机提供dhcp服务

  ip dhcp excluded-address 192.168.10.254

  ip dhcp pool ABC

 

  import all(导入dnswins server

  network 192.168.10.0  255.255.255.0

 

  default-router 192.168.10.254

 

 

 

  第六步:配置NAT

 

 

 

  access-list 1 permit 192.168.10.0 <?xml:namespace prefix = st1 ns = "urn:schemas-microsoft-com:office:smarttags" />0.0.0.255

 

  ip nat inside source list 1 interface Dialer1 overload

 

 

  第七步:配置缺省路由

 

 

 

 

  ip route 0.0.0.0 0.0.0.0 Dialer1
 
这样就可以实现多台PC上网了