精华内容
下载资源
问答
  • JS检索下拉列表框中被选项目的索引号(selectedIndex)
    千次阅读
    2019-12-15 15:09:38

    前言

    在开始本文主题之前,先来看一个 HTML demo,一个非常简单的选择列表(select):

    <select>
        <option>one</option>
        <option>two</option>
        
    更多相关内容
  • VB中列表框添加与删除项目

    千次阅读 2019-02-11 16:50:17
  • VC6.0 MFC 列表框 列表控件 添加 修改 删除

    千次阅读 多人点赞 2020-06-28 15:46:24
    写在前面:列表框是很常用,并且很重要的一个控件,那么接下来,就跟随我的脚步,去探索它的奥秘吧! 一、未卜先知 1、编译运行后,点击“学生档案信息”,界面如下图所示。 2、添加记录,如下图所示。 3、修改...

    VC6.0 MFC 列表框 列表控件 添加 修改 删除

    写在前面:列表框是很常用,并且很重要的一个控件,那么接下来,就跟随我的脚步,去探索它的奥秘吧!

    一、未卜先知

    1、编译运行后,点击“学生档案信息”,界面如下图所示。
    在这里插入图片描述
    在这里插入图片描述
    2、添加记录,如下图所示。
    在这里插入图片描述
    3、修改记录,如下图所示。
    在这里插入图片描述
    4、删除记录,如下图所示。
    在这里插入图片描述
    二、实现步骤

    1、新建一个工程,如下图所示。
    在这里插入图片描述
    在这里插入图片描述
    2、建立菜单,并给菜单做一个消息响应函数,如下图所示。
    在这里插入图片描述
    在这里插入图片描述
    3、接下来在对话框中进行相应操作,具体步骤如下图所示。
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    4、建立类向导,取类名“CDlgStuInfo”,如下图所示。
    在这里插入图片描述
    5、接下来,我们通过编程添加一些数据。首先在CdlgStuInfo中右击添加消息响应句柄,如下图所示。
    在这里插入图片描述
    6、在OnInitDialog() 中添加代码,如下。

    BOOL CDlgStuInfo::OnInitDialog() 
    {
    	CDialog::OnInitDialog();
    	// TODO: Add extra initialization here
    	DWORD dwStyle;
    	dwStyle = m_listCtrl.GetExtendedStyle();
    	dwStyle |= LVS_EX_FULLROWSELECT | LVS_EX_GRIDLINES  | LVS_EX_ONECLICKACTIVATE;
    	m_listCtrl.SetExtendedStyle(dwStyle);
    	return TRUE;  // return TRUE unless you set the focus to a control
    	       // EXCEPTION: OCX Property Pages should return FALSE
    }
    

    记得要把头文件:#include "DlgStuInfo.h"对话框类嵌入进去!

    7、在OnMStuInfo()中添加代码,如下。

    void CChapterView::OnMStuInfo() 
    {
    	// TODO: Add your command handler code here
    	CDlgStuInfo dlg_stuInfo;
    	dlg_stuInfo.DoModal();
    }
    

    8、此时,运行结果如下图所示。
    在这里插入图片描述
    9、在第6步的基础上,继续往OnInitDialog() 中添加代码,如下。

    BOOL CDlgStuInfo::OnInitDialog() 
    {
    	CDialog::OnInitDialog();
    	// TODO: Add extra initialization here
    	DWORD dwStyle;
    	dwStyle = m_listCtrl.GetExtendedStyle();
    	dwStyle |= LVS_EX_FULLROWSELECT | LVS_EX_GRIDLINES  | LVS_EX_ONECLICKACTIVATE;
    	m_listCtrl.SetExtendedStyle(dwStyle); //设置显示风格
    	m_listCtrl.InsertColumn(0,"学号",LVCFMT_CENTER,100); //第一个参数是字段的编号
    	m_listCtrl.InsertColumn(1,"姓名",LVCFMT_CENTER,100); //第二个参数是字段的名字
    	m_listCtrl.InsertColumn(2,"性别",LVCFMT_CENTER,100); //第三个参数是字段的显示风格
    	m_listCtrl.InsertColumn(3,"专业",LVCFMT_CENTER,100); //第四个参数是字段的宽度
    	m_listCtrl.InsertColumn(4,"班级",LVCFMT_CENTER,100); //设置表格字段名
    	m_listCtrl.InsertItem(0,"0001"); //0即表格中的第一行
    	m_listCtrl.SetItemText(0,1,"张三");
    	m_listCtrl.SetItemText(0,2,"男");
    	m_listCtrl.SetItemText(0,3,"电子信息");
    	m_listCtrl.SetItemText(0,4,"202001"); //在表格中添加数据,插入一行记录
    	m_listCtrl.InsertItem(1,"0002");
    	m_listCtrl.SetItemText(1,1,"李丽");
    	m_listCtrl.SetItemText(1,2,"女");
    	m_listCtrl.SetItemText(1,3,"计算机");
    	m_listCtrl.SetItemText(1,4,"202002");
    	return TRUE;  // return TRUE unless you set the focus to a control
    	        // EXCEPTION: OCX Property Pages should return FALSE
    }
    

    10、新建一个对话框,具体如下图所示。
    在这里插入图片描述
    在这里插入图片描述
    11、紧接着建立它所对应的类,如下图所示。
    在这里插入图片描述
    12、双击“添加记录”按钮,把“添加一条学生记录信息”这个对话框给调出来,如下图所示。
    在这里插入图片描述
    13、把“添加一条学生记录信息”对话框的头文件:#include "Dlg_StuInfoAppe.h"嵌入进来。然后在OnBTNAppe()中编程。

    void CDlgStuInfo::OnBTNAppe() 
    {
    	// TODO: Add your control notification handler code here
    	CDlg_StuInfoAppe dlg_stuInfoAppe;
    	dlg_stuInfoAppe.DoModal();
    }
    

    14、接下来怎么把一条新的学生信息通过“添加一条学生记录信息”对话框加到上一个 “学生档案信息”对话框的列表中去,这是我们的目的。

    15、在对应部分添加如下代码:
    CString m_sNo,m_sName,m_sSex,m_sDept,m_sClass;
    在这里插入图片描述

    class CDlgStuInfo : public CDialog
    {
    // Construction
    public:
    	CDlgStuInfo(CWnd* pParent = NULL);   // standard constructor
    
    // Dialog Data
    	//{{AFX_DATA(CDlgStuInfo)
    	enum { IDD = IDD_DlgStuInfo };
    	CListCtrl	m_listCtrl;
    	//}}AFX_DATA
    
    	CString m_sNo,m_sName,m_sSex,m_sDept,m_sClass;
    
    	int m_listSelPos; //获取当前被选中的位置
    
    // Overrides
    	// ClassWizard generated virtual function overrides
    	//{{AFX_VIRTUAL(CDlgStuInfo)
    	protected:
    	virtual void DoDataExchange(CDataExchange* pDX);    // DDX/DDV support
    	//}}AFX_VIRTUAL
    
    // Implementation
    protected:
    
    	// Generated message map functions
    	//{{AFX_MSG(CDlgStuInfo)
    	virtual BOOL OnInitDialog();
    	afx_msg void OnBTNAppe();
    	afx_msg void OnBTNModi();
    	afx_msg void OnClickList1(NMHDR* pNMHDR, LRESULT* pResult);
    	afx_msg void OnBTNDele();
    	//}}AFX_MSG
    	DECLARE_MESSAGE_MAP()
    };
    

    16、点击“确定”按钮后接收添加的信息到上一个 (学生档案信息)对话框的列表中去,代码如下。

    void CDlgStuInfo::OnBTNAppe() 
    {
    	// TODO: Add your control notification handler code here
    	CDlg_StuInfoAppe dlg_stuInfoAppe;
    	if(IDOK == dlg_stuInfoAppe.DoModal())
    	{
    		m_sNo = dlg_stuInfoAppe.m_sNo;
    		m_sName = dlg_stuInfoAppe.m_sName;
    		m_sSex = dlg_stuInfoAppe.m_sSex;
    		m_sDept = dlg_stuInfoAppe.m_sDept;
    		m_sClass = dlg_stuInfoAppe.m_sClass; //把添加记录对话框中的数据传过来,保存到基础信息对话框中
    		int pos; //添加的位置
    		pos = m_listCtrl.GetItemCount();
    		m_listCtrl.InsertItem(pos,m_sNo);
    		m_listCtrl.SetItemText(pos,1,m_sName);
    		m_listCtrl.SetItemText(pos,2,m_sSex);
    		m_listCtrl.SetItemText(pos,3,m_sDept);
    		m_listCtrl.SetItemText(pos,4,m_sClass); //把获取进来的数据插进去
    	}
    }
    

    17、双击“修改记录”按钮,把“修改记录信息”这个对话框给调出来(同12)。

    18、把“修改记录信息”对话框的头文件:#include "Dlg_StuInfoModi.h"嵌入进来。然后在OnBTNModi()中编程(同13)。

    void CDlgStuInfo::OnBTNModi() 
    {
    	// TODO: Add your control notification handler code here
    	CDlg_StuInfoModi dlg_stuInfoModi;
        dlg_stuInfoModi.DoModal();
    }
    

    19、接下来怎么把 “修改记录信息”对话框中要修改的记录更新到上一个 “学生档案信息”对话框的列表中去,这是我们的目的(同14)。

    20、我们回到IDD_DlgStuInfo对话框,选中对话框,右击选择“事件…”,在弹出的事件句柄中选择“NM_CLICK”,如下图所示。
    在这里插入图片描述
    在这里插入图片描述

    void CDlgStuInfo::OnClickList1(NMHDR* pNMHDR, LRESULT* pResult) 
    {
    	// TODO: Add your control notification handler code here
    	m_listSelPos = m_listCtrl.GetSelectionMark();
    //获取当前被选行的信息,传送到编辑对话框中去
    	*pResult = 0;
    }
    

    21、添加代码如下(类似16)。

    void CDlgStuInfo::OnBTNModi() 
    {
    	// TODO: Add your control notification handler code here
    	CDlg_StuInfoModi dlg_stuInfoModi;
    	dlg_stuInfoModi.m_sNo = m_listCtrl.GetItemText(m_listSelPos,0); //获取当前记录的显示的文本
    	dlg_stuInfoModi.m_sName = m_listCtrl.GetItemText(m_listSelPos,1);
    	dlg_stuInfoModi.m_sSex = m_listCtrl.GetItemText(m_listSelPos,2);
    	dlg_stuInfoModi.m_sDept = m_listCtrl.GetItemText(m_listSelPos,3);
    	dlg_stuInfoModi.m_sClass = m_listCtrl.GetItemText(m_listSelPos,4);
    
    	if(IDOK == dlg_stuInfoModi.DoModal())
    	{ //把新数据传送给浏览对话框,实现信息的修改
    		UpdateData(true); //把对话框中的信息更新到内存中去
    		m_listCtrl.SetItemText(m_listSelPos,0,dlg_stuInfoModi.m_sNo);
    		m_listCtrl.SetItemText(m_listSelPos,1,dlg_stuInfoModi.m_sName);
    		m_listCtrl.SetItemText(m_listSelPos,2,dlg_stuInfoModi.m_sSex);
    		m_listCtrl.SetItemText(m_listSelPos,3,dlg_stuInfoModi.m_sDept);
    		m_listCtrl.SetItemText(m_listSelPos,4,dlg_stuInfoModi.m_sClass);
    	}
    }
    

    22、“删除记录”类似,不再叙述。这里仅将该部分代码附上,如下。

    void CDlgStuInfo::OnBTNDele() 
    {
    	// TODO: Add your control notification handler code here
    	CString str;
    	str.Format("确认删除第 %d 行",m_listSelPos + 1);
    	if(IDYES == AfxMessageBox(str,MB_YESNO|MB_ICONQUESTION))
    	{
    		m_listCtrl.DeleteItem(m_listSelPos);
    	}
    } 
    

    三、执行结果

    1、编译运行后,点击“学生档案信息”,界面如下图所示。
    在这里插入图片描述
    在这里插入图片描述
    2、添加记录,如下图所示。
    在这里插入图片描述
    3、修改记录,如下图所示。
    在这里插入图片描述
    4、删除记录,如下图所示。
    在这里插入图片描述

    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: 超级列表框实例教程 - 01.新手上路请上车 易语言TV

    展开全文
  • 工作表中添加列表框或组合框

    千次阅读 2012-05-04 10:29:40
    添加列表框(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 单击“Office 按钮” ,然后单击“Excel 选项”。 在“常用”类别的“使用 Excel 时采用的首选项”下,...
  • PyQT5控件:下拉列表框(QComboBox)

    千次阅读 2020-12-16 06:03:36
    QComboBox下拉列表框QComboBox以占用最少...QComboBox类属性editable 设置是否可编辑currentText设置当前列表框显示内容(前提是先在列表框添加内容)currentIndex设置当前列表框显示内容的索引(前提是先在列表框添加...
  • asp.net动态添加下拉列表框

    千次阅读 2014-12-02 21:26:46
    <p class="pLine"> 添加新链接" /> <asp:TextBox ID="txt_links" runat="server" Height="25px" Width="329px" Visible="false" ></asp:TextBox> .aspx.cs代码如下: using System; using...
  • MFC实例:[5] ListBox 列表框控件实例

    千次阅读 2019-04-01 17:39:52
    MFC实例:[4] ListBox 列表框控件实例
  • 1.在一个新建的项目模型里,在图形库选中下拉列表框,拖到空白处,如下所示:  2.编辑列表选项:双击下拉列表框,为列表框添加相应的选项(可单个添加也可选择一次性添加),这里举例子以网点为例,其他子选项...
  • vue实现简单的列表添加功能

    千次阅读 2020-07-17 10:25:32
    实现一个简单的列表添加功能 body加入如下代码 div框架部分 <div id="app"> <input type="text" v-model="inputValue" /> <button v-on:click="handleBtnClick">提交</button> ...
  • 组合框和列表框都可以在界面上同时显示多项内容,并且允许用户...例如控件发送“CB_ ADDSTRING”,就可以在控件的下拉列表中添加新项; 当组合框控件有通知事件发生时,控件会父窗口发出以“CBN_ ”开头的通知消
  • vb列表框ListBox的详细使用方法

    万次阅读 2018-06-12 15:19:45
    列表框(ListBox)控件表示一个选项清单,用户可能用鼠标选择其中一个或者几个选项。 列表框的特点是:列表框中项目是通过程序插入到其中的,用户无法清单输入数据,当选择其中的项
  • html下拉列表框默认值

    千次阅读 2020-12-29 04:53:59
    HTML 和 JavaScript 综合练习题一、单项选择 ... HTTP 2. HTTP 服务默认......name 的属性值必须要相同,必须有一个 value 值 实现默认选中的属性 :checked="checked" - 文件输入项(在后期上传时候用到): -下拉.........
  • 表单域包括文本框、复选框、列表框、组合框、按钮和签名域等,主要用于收集用户填写或选择的数据。这篇文章将介绍如何在Java应用程序给PDF文档添加表单域。 导入jar文件 本文所使用的PDF类库是Free Spire.PDF ...
  • 遇到过几次,转载以供查询,转自:... 1、将现有项目或文件夹拷贝到指定目录下 2、解决方案右上有显示所有文件的按钮 然后选中所有要添加的文件,右击 ...选择包含到项目中即可...
  • 前面两节讲了比较常用的按钮控件,并通过按钮控件实例说明了具体用法。...列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列
  • 相信很多小伙伴在学习完SSM三大架构以后,不知道该如何找到一个简单容易上手的项目进行实战训练,经常在博客上看到一个不错的项目下载下来以后全部都是代码,无处下手。因此本文力求以最简单易懂的项目结构和代码...
  • React 列表添加数据

    千次阅读 2020-07-01 09:30:23
    现在的列表还是写死的两标签,那要变成动态显示的,就需要把这个列表先进行数据化,然后再用javascript代码,循环在页面上。 我们先给上节课的list数组增加两数组元素,代码如下: constructor(props){ //// ...
  • 添加->新建筛选器 2.命令saveFiles 3.将需要添加的文件夹放入工程目录,文件夹名可以与新建的筛选器同名也可以不同名 4.选中头文件下的saveFiles筛选器,添加工程目录下的文件 5.选中源文件下的save...
  • 生成一个适合你的列表 项目 项目 项目 项目1 项目2 项目3 计划任务 完成任务 创建一个表格 一个简单的表格是这么创建的: 项目 Value 电脑 $1600 手机 $12 导管 $1 设定内容居中、居左、居右 使用:---------:居中 ...
  • Listbox:列表框用于显示项目列表 ...可以通过for循环Listbox插入项目列表和索引值其中添加项目两种方法。 selectmode   确定可以选择多少项,以及鼠标拖动的影响选择: BROWSE:通常,只能...
  • 文章目录继承关系细节描述示例 继承关系 细节描述 QComboBox提供了种以占用最少屏幕空间的方式用户显示选项列表的方法。 组合是显示当前项目的选择小部件,并且可以弹...
  • MFC可编辑列表框控件功能实现

    千次阅读 2016-08-28 21:29:10
    本文介绍了MFC中列表框控件扩展方法:可编辑功能的实现。
  • Java列表和组合

    千次阅读 2018-08-15 13:43:02
    程序可以在列表框中加入多文本选择项条目。列表事件的事件源有两种: 是鼠标双击某个选项:双击选项是动作事件,与该事件相关的接口是ActionListener,注册监视器的方法是addActionListener(),接口...
  • String 、Text Message 、Text Box 控件 2、列表框(List Box)、树控件(Tree)、表格控件(Table)  Create ——> Lists&Tables ——> List BOX 、Tree 、Table 控件功能函数:  Library ——>...
  • 您正在使用 PyCharm,那么该如何创建并运行您的第一个Python项目?在你开始之前#确保满足以下先决条件:您正在使用 PyCharm CE或Professional。您已经安装了Python本身。如果您使用的是macOS或Linux,那么您的...
  • MFC列表框实现可编辑功能

    千次阅读 2013-03-13 18:00:00
    列表控件上实现可编辑功能的原理非常简单,借助一个编辑控件即可达到目的。具体步骤如下:①从 CListCtrl派生一个子类,并拦截某个意味着进入编辑状态的消息,获取需要编辑的数据项的相关信息。所拦截的消息通常...
  • 1小时学会不打代码制作一个网页精美简历(1)

    万次阅读 多人点赞 2021-05-13 22:39:48
    ## 作者简介 ...15-16年曾在网上直播,带领批程序小白走上程序员之路。欢迎各位小白加我咨询我相关信息,迷茫的你会找到答案。系列教程将会在流量降低时转为付费位置,流量多时将不会,各位抓紧时间学习哟~
  • vue js中添加图片

    万次阅读 2019-02-20 10:29:48
    新年来到现在才将心思真正的摆在了工作上,故在此记录一个小要点引以作为新年博客坚持的起始吧~~~~ vue在js添加图片的方式如下: 方法一:在data里面将图片路径保存好 imgList: [ { openItem: '../static/...
  • Vue Popover 弹出在table列表中的使用

    千次阅读 2019-04-04 10:07:17
    最近在自己做一个前端项目 (纯个人娱乐), 在table希望对删除操作做一个弹窗提醒, 最初直接从ElementUI库找到Popover弹窗代码之后, 直接复制到项目中, 遇到了如下的坑: 1. 列表中每一项都需要单独的visible变量...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 210,729
精华内容 84,291
关键字:

向列表框中添加一个新项目