精华内容
下载资源
问答
  • H3C_IPv6 IP 业务分册 基础命令
  • IPv6- Linux-IPv6命令总结手册

    千次阅读 2019-03-04 18:29:41
    由于IPv6的普及正在进行,我用到的Linux中关于IPv6命令汇总到本文,以作备忘,日后也会更新。这里简要介绍一下IPv6地址的相关概念: 1)为什么IPv4之后就叫IPv6,而不是IPv5 在任何IP报头上,前4位保留给协议...

    引言:

          由于IPv6的普及正在进行,我用到的Linux中关于IPv6的命令汇总到本文,以作备忘,日后也会更新。这里简要介绍一下IPv6地址的相关概念:

    1)为什么IPv4之后就叫IPv6,而不是IPv5

          在任何IP报头上,前4位保留给协议版本。所以理论上,0到15之间的协议号是可能的。而4已经被使用,同时5保留给流协议(STP, RFC 1819 / Internet流协议版本2 [http://www.faqs.org/rfcs/rfc1819.html)(从未真正向公众开放)

    2)为什么IPv6具有128位这么多

          在IPv4的设计过程中,人们认为32位已经足够了。回顾过去,32位到目前为止已经足够了,也许在未来几年也足够了。但是,32位并不足以在未来为每个网络设备提供一个全局地址。想想手机、汽车(包括can总线上的电子设备)、烤面包机、冰箱、电灯开关等等……因此,设计者选择了128位,长度是目前IPv4的4倍,且128位是关于头开销和数据传输的最佳选择。

    3)IPv6地址——32个16进制数,每4个一组,共8组,代表128位二进制数

          标准写法:    fd20:0100:0000:0000:0200:0000:0000:0001

          由于标准写法比较繁琐,因此规定了缩写方法规范。

          缩写规范:第一,每组数中前置的0可以省略不写,全为0时至少要写1个0;第二,连续2组数为0可缩写成 ”::“ ,但是一个IPv6地址中不可出现2个 ”::“ 。

          例如,上述地址 fd20:0100:0000:0000:0020:0000:0000:0001 ,根据“前置的0省略不写,全为0则至少要写1个0”则为  fd20:100:0:0:20:0:0:1 ,根据“连续2组数为0可缩写成 ”::“ ,但是一个IPv6地址中不可出现2个 ”::“   ”则为  fd20:100::20:0:0:1 或者  fd20:100:0:0:20::1  。不可以写成  fd20:100::20::1  ,否则无法分辨两个 :: 分别代表的0的个数。

    4)IPv6地址类型

          全球唯一地址Global Unicast Address (GUA):相当于IPv4的公网地址。每个IPv6地址全球唯一,被定义用来穿越 IPv6 Internet,用高位3bits置位为001来标识,一般以  2XXX 或者 3XXX 为开头;

          唯一本地地址Unique Local Address (ULA) :相当于IPv4的私网地址,在本站点内唯一且有效,一般以 fcXX 或者 fdXX为开头;不可聚合;不可在Internet上路由,但是可在站点管理域内路由。

          本地链路地址Link-Local Address (LLA):个人认为类似于MAC地址,在本链路唯一且有效,对本链路以外没有意义,一定是  fe80:: 为开头;

          本地回环地址:相当于IPv4的lo地址,表示为  ::1  ;

          组播地址:ffXX 为开头 ,IPv6没有广播的概念。


    一 开启IPv6模块

    1 是否支持IPv6模块

    1)查看是否支持

    cat /proc/net/if_inet6              //检查当前运行的内核是否支持IPv6

    或者

    test -f /proc/net/if_inet6 && echo "Running kernel is IPv6 ready"       //如果失败,很可能IPv6模块没有加载

    或者

     lsmod |grep -w 'ipv6' && echo "IPv6 module successfully loaded"

    2)加载IPv6模块

    modprobe ipv6

    注意:目前不支持卸载模块,在某些情况下会导致内核崩溃。

    3)如果上面的操作结果都不成功,那就需要升级内核或者编译内核了。

    2 启用IPv6

    1)编辑sysctl.conf文件

    net.ipv6.conf.all.disable_ipv6 = 0

    2)CentOS还要编辑/etc/modprobe.d/disable_ipv6.conf

    options ipv6 disable=0

    3)编辑/etc/sysconfig/network

    NETWORKING_IPV6=YES

    4)编辑/etc/sysconfig/nework-scripts/ifcfg-eth*

    IPV6INIT=yes

    最后service network restart即可使这些配置生效!

    二 配置sysctl.conf

    1)sysctl中关于ipv6的基本配置——一般用于虚拟路由器的配置

    net.ipv6.conf.all.disable_ipv6 = 0          //启用ipv6          
    
    net.ipv6.conf.all.forwarding = 1            //启用ipv6转发
    
    net.ipv6.conf.all.accept_ra = 1             //启用路由通告
    
    net.ipv6.conf.all.accept_redirects = 0      //禁用路由重定向

    2)sysctl中关于ipv6的其他配置说明
     

    #在假设没有路由器出现之前,发送的路由器请求数。
    
    # 这是主机,不是路由器
    
    net.ipv6.conf.default.router_solicitations = 0
    
    # 在RA中接受路由器偏好设置?
    
    net.ipv6.conf.default.accept_ra_rtr_pref = 0
    
    #学习路由器广告中的前缀信息
    
    net.ipv6.conf.default.accept_ra_pinfo = 0
    
    # 设置控制系统是否接受来自路由器广告的跳转限制设置
    
    net.ipv6.conf.default.accept_ra_defrtr = 0
    
    #路由器广告可以使系统向接口分配一个全局单播地址
    
    net.ipv6.conf.default.autoconf = 0
    
    #每个地址要发送多少个邻居请求?
    
    net.ipv6.conf.default.dad_transmits = 0
    
    # 每个接口可以分配多少全局单播IPv6地址?
    
    net.ipv6.conf.default.max_addresses = 1

    3)启用sysctl.conf的配置

    sysctl -p

    三 配置IPv6地址及其网关

    注意:一张网卡可以配置多个IPv6地址

    1)临时配置ipv6地址

    ip -6 addr add [IPv6_ADDR] dev [INTERFACE]

    2)修改网卡配置文件

    BOOTPROTO=dhcp                       //虚机启动时会自动获取ipv4和ipv6的地址

    BOOTPROTO=dhcp6                     //虚机启动时只自动获取ipv6地址

    DHCPV6C=yes                             //开启dhcpv6

    IPV6INIT=yes                                //开机启用ipv6

    3)网卡配置文件中slaac的配置

    IPV6_AUTOCONF=yes                 //开启ipv6地址自动配置功能

    4)临时配置ipv6网关,查看路由信息

    ip -6 route add default via [IPv6_ADDR] dev [INTERFACE]

    route -A inet6 -n

    ip -6 route show

    ip -6 route show table [TABLE_NAME]

    四 查看网络联通性

    1)ping6命令的使用

    # ping6 <hostwithipv6address>
    # ping6 <ipv6address>
    # ping6 [-I <device>] <link-local-ipv6address>
    # ping6 <link-local-ipv6address>%<device>

    2)tcpdump

    tcpdump -i <interface-name> -vv ip6
    
    tcpdump -nn ip6 proto 6                    // proto 6代表tcp
    
    tcpdump -nr <file-name> ip6 proto 17       // proto 17 代表udp

    原创文章,转载请注明出处,谢谢!

    展开全文
  • linux关闭ipv6命令

    千次阅读 2021-05-13 06:40:56
    一、linux关闭IPV6命令使用vi编辑器,打开/etc/modprobe.conf,在文档中加入如下的两条:alias net-pf-10 offalias ipv6 off保存退出,并且重新启动系统。重启之后可以使用下面的三种方法去验证IPv6支持是否已经被.....

    linux操作系统下可以通过相关命令开启关闭ipv6,下面由学习啦小编为大家整理了linux关闭ipv6的相关命令,希望对大家有所帮助。

    一、linux关闭IPV6命令

    使用vi编辑器,打开/etc/modprobe.conf,在文档中加入如下的两条:

    alias net-pf-10 off

    alias ipv6 off

    保存退出,并且重新启动系统。

    重启之后可以使用下面的三种方法去验证IPv6支持是否已经被关闭。

    二、确认IPV6是否开启

    在Linux下确认IPv6是否已经被启用,可以从三个方面确定。

    1.使用ifconfig查看自己的IP地址是否含有IPv6地址。

    eth0 Link encap:Ethernet HWaddr 00:13:D4:05:B2:ED

    inet addr:119.119.xxx.xx Bcast:119.119.115.255 Mask:255.255.255.0

    inet6 addr: fe80::213:d4ff:fe05:b2ed/64 Scope:Link

    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

    RX packets:1054562 errors:0 dropped:0 overruns:0 frame:0

    TX packets:538136 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:1000

    RX bytes:346189738 (330.1 MiB) TX bytes:246935731 (235.4 MiB)

    Interrupt:209 Base address:0xd800

    2.查看服务监听的IP中是否有IPv6格式的地址。(netstat -tuln)

    tcp 0 0 0.0.0.0:8100 0.0.0.0:* LISTEN

    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN

    tcp 0 0 0.0.0.0:843 0.0.0.0:* LISTEN

    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN

    tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN

    tcp 0 0 :::8080 :::* LISTEN

    tcp 0 0 :::22 :::* LISTEN

    tcp 0 0 :::443 :::* LISTEN

    udp 0 0 0.0.0.0:68 0.0.0.0:*

    udp 0 0 0.0.0.0:111 0.0.0.0:*

    udp 0 0 0.0.0.0:631 0.0.0.0:*

    3.使用lsmod查看ipv6的模块是否被加载。

    [root@linux ~]# lsmod |grep ip

    ipt_MASQUERADE 7617 3

    iptable_nat 11077 1

    ip_nat 21101 2 ipt_MASQUERADE,iptable_nat

    ip_conntrack_netbios_ns 6977 0

    ipt_REJECT 9665 3

    ip_conntrack 53281 5 ipt_MASQUERADE,iptable_nat,ip_nat,ip_conntrack_netbios_ns,xt_state

    nfnetlink 10713 2 ip_nat,ip_conntrack

    iptable_filter 7105 1

    ip_tables 17029 2 iptable_nat,iptable_filter

    ip6t_REJECT 9409 1

    ip6table_filter 6849 1

    ip6_tables 18053 1 ip6table_filter

    x_tables 17349 8 ipt_MASQUERADE,iptable_nat,ipt_REJECT,xt_state,ip_tables,ip6t_REJECT,xt_tcpudp,ip6_tables

    ipv6 270433 18 ip6t_REJECT,cnic

    如果出现以上粗体显示的部分,代表您的机器上IPV6已经开启。

    三、扩展资料:开启IPV6

    IPv6是默认支持的,所以当你要重新开起IPv6支持时,将/etc/modprobe.conf中的两条指令注释掉就可以了。

    展开全文
  • IPv6命令行配置

    万次阅读 2018-05-27 08:05:06
    IPv6基础配置命令 ipv6 neighbor ipv6-address mac-addressipv6 //使能设备转发IPv6单播报文,包括本地IPv6报文的发送与接收。 ipv6 address anycast //用来配置IPv6任播地址。 ipv6 address auto global //使能...

    IPv6基础配置命令

    ipv6 neighbor ipv6-address mac-addressipv6
    //使能设备转发IPv6单播报文,包括本地IPv6报文的发送与接收。
    ipv6 address anycast
    //用来配置IPv6任播地址。
    ipv6 address auto global
    //使能无状态自动生成IPv6全局地址功能。
    ipv6 address auto link-local
    //配置自动生成的链路本地地址。
    ipv6 address link-local
    //配置接口的链路本地地址
    ipv6 address eui-64
    //配置接口的EUI-64格式的全球单播地址
    
    ipv6 enable
    //接口上使能IPv6功能。
    ipv6 icmp blackhole unreachable send
    //使能在匹配IPv6黑洞路由后回应ICMP目的不可达报文的功能。
    ipv6 icmp redirect send
    //使能系统发送ICMPv6重定向报文功能。
    ipv6 icmp port-unreachable send
    //使能接口的ICMPv6端口不可达报文的发送功能。
    ipv6 icmp hop-limit-exceeded send
    //使能接口的ICMPv6跳数超大报文的发送功能。
    ipv6 icmp receive
    //使能系统接收ICMPv6报文功能。
    //缺省情况下,系统接收ICMPv6报文的功能处于使能状态。
    ipv6 icmp send
    //使能系统发送ICMPv6报文功能。
    ipv6 icmp too-big-rate-limit
    //使能ICMPv6超大差错报文接收抑制功能。
    
    ipv6 mtu
    //置接口上发送IPv6报文的MTU。
    //缺省情况下,接口的IPv6的MTU值为1500字节。
    ipv6 nd autoconfig managed-address-flag
    //设置RA报文中的有状态自动配置地址的标志位。
    //缺省情况下,没有设置有状态自动配置地址的标志位。
    /* 如果设置了该标志位,则主机通过有状态自动配置获得IPv6地址。
       如果清除了该标志位,则主机通过无状态自动配置获得IPv6地址,即通过RA报文向主机发布IPv6地址前缀信息自动生成IPv6地址。*/
    ipv6 nd autoconfig other-flag
    //设置RA报文中的有状态自动配置其他信息的标志位。
    //缺省情况下,系统未设置有状态自动配置其他信息的标志位。
    /* 
        如果设置了该标志位,则主机可通过有状态自动配置获得除IPv6地址外的其他配置信息,包括路由器生存时间、邻居可达时间、邻居的重传时间、链路的MTU信息。
        如果清除了该标志位,则主机进行无状态自动配置。即路由设备通过RA报文向主机发布除IPv6地址外的其他配置信息,包括路由器生存时间、邻居可达时间、邻居的重传时间、链路的MTU信息。
      */
    ipv6 nd dad attempts
    //配置系统进行重复地址检测DAD时发送邻居请求报文的次数。
    //缺省情况下,系统进行重复地址检测时发送邻居请求报文的次数是1。
    ipv6 nd hop-limit
    //配置由设备初始发送的IPv6单播报文的跳数限制。
    //缺省情况下,由路由设备初始发送的IPv6单播报文的跳数限制是64。
    ipv6 nd learning strict
    //配置IPv6 ND严格学习。
    ipv6 nd neighbor-limit 1024
    //配置接口上允许动态学习的邻居表项的最大个数。
    ipv6 nd ns multicast-enable
    //使能QinQ或Dot1q终结子接口发送NS组播报文的功能。
    ipv6 nd ns retrans-timer
    //设置系统发送邻居请求报文的时间间隔。
    //缺省情况下,系统发送邻居请求报文的时间间隔是1000毫秒。
    ipv6 nd nud reachable-time
    //来配置IPv6邻居节点的可达时间。
    //缺省情况下,IPv6邻居节点的可达时间为1200000毫秒。
    ipv6 nd ra
    //置RA(Router Advertisement)报文的发布时间间隔。
    //缺省情况下,最大时间间隔是600秒,最小时间间隔是200秒。
    ipv6 nd ra halt
    //去使能系统发布RA报文功能。
    //缺省情况下,系统发布RA报文功能处于未使能状态。
    ipv6 nd ra hop-limit 64
    //配置RA报文的跳数限制。
    ipv6 nd ra preference medium {high | medium | low }
    //配置RA报文中的默认路由器优先级信息。
    ipv6 nd ra prefix
    //配置RA报文中的前缀信息。
    ipv6 nd ra route-information
    //配置RA报文中的路由选项信息。
    ipv6 nd ra router-lifetime
    //配置RA报文的存活时间。
    ipv6 nd stale-timeout 1200
     //配置邻居表项在STALE状态的老化时间。
      //缺省情况下,系统视图邻居表项STALE状态的老化时间是1200秒;
      //接口视图未配置邻居表项STALE状态的老化时间。
      ipv6 neighbor ipv6-address mac-address
      //配置静态邻居表项信息。
      ipv6 pathmtu
      //配置到指定IPv6目的地址的PMTU值。
      ipv6 pathmtu age
      //配置动态PMTU表项的老化时间。
      ipv6 soft-forward enhance enable
      //使能设备产生的IPv6控制报文的增强转发功能。
      dns relay ipv6 enable
      //开启IPv6 DNS Relay功能。
      dns server ipv6
      //配置实现动态域名解析的DNS服务器的IPv6地址。
      dns server ipv6 source-ip
      //配置本端作为DNS客户端与DNS服务端通信时的源IPv6地址。
      dns spoofing ipv6
      //使能IPv6 DNS Spoofing功能,并指定欺骗性应答的IPv6地址。
    ipv6 host
    //来配置IPv6静态域名解析表项。
    

    IPv6综合实验

    实验拓扑如下:

    这里写图片描述

    图:IPv6综合实验拓扑

    实验要求:

    IPv6网络如实验拓扑所示,请根据如下需求对网络进行部署:

    1. R1,R2和R3之间运行OSPFv3,区域ID为0,Router ID分别为10.1.1.1,10.2.2.2,10.3.3.3;
    2. R4,R5和R6之间运行ISIS IPv6区域ID为49.0001,并且都是Level-2级别路由器;
    3. R2和R4间的网络是一个纯IPv4网络,运行的是OSPFv2,区域ID为0,包含Loopback地址;
    4. R6,R7间的网络是纯IPv4网络,建立ISIS IPv4邻居,区域ID为49.0001;
    5. R1,R2和R3之间建立全互连IBGP4+ IPv6邻居关系,AS号为100,且R2向AS100通告默认路由;R4和R5建立IBGP4+ IPv6邻居关系,AS号为200;
    6. R2与R4间使用GRE手工隧道,隧道的地址为2001:db8:24::/64,R2和R4之间通过直连IPv6地址建立EBGP IPv6邻居关系;要求R2 将AS100中的2001:db8:100:00通告给AS200;
    7. 在R4和R5上要求将ISIS IPv6路由引入进BGP,保证AS100和AS200所有IPv6网段间的互通;
    8. R7的G0/0/1下用户连接到网络后有状态自动获取IPv6地址,DNS为R1。这里使用R8来模拟一台IPv6终端;
    9. R6和R7间使用6to4隧道,保证R7能Ping通AS200内的IPv6网络。

    配置文件:

    AR1:

    <AR1>display current-configuration 
    #
     sysname AR1
    #
    ipv6 
    #
    ospfv3 1
     router-id 10.1.1.1
    #
    interface GigabitEthernet0/0/0
     ipv6 enable 
     ipv6 address 2001:DB8:100::1/64 
     ospfv3 1 area 0.0.0.0
    #
    interface LoopBack0
     ip address 10.1.1.1 255.255.255.255 
     ospfv3 1 area 0.0.0.0
    #
    bgp 100
     router-id 10.1.1.1
     undo default ipv4-unicast
     peer 2001:DB8:100::2 as-number 100 
     peer 2001:DB8:100::3 as-number 100 
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      peer 2001:DB8:100::2 enable
      peer 2001:DB8:100::3 enable
    #
    return

    AR2:

    <AR2>dis current-configuration 
    #
     sysname AR2
    #
    ipv6 
    #
    ospfv3 1
     router-id 10.3.3.3
    #
    interface GigabitEthernet0/0/0
     ipv6 enable 
     ipv6 address 2001:DB8:100::2/64 
     ospfv3 1 area 0.0.0.0
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.24.2 255.255.255.0 
    #
    interface LoopBack0
     ip address 10.2.2.2 255.255.255.255 
     ospfv3 1 area 0.0.0.0
    #
    interface Tunnel0/0/0
     ipv6 enable 
     ipv6 address 2001:DB8:24::2/64 
     tunnel-protocol gre
     source 192.168.24.2
     destination 192.168.24.4
    #
    bgp 100
     router-id 10.2.2.2
     peer 2001:DB8:24::4 as-number 200 
     peer 2001:DB8:100::1 as-number 100 
     peer 2001:DB8:100::3 as-number 100 
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      network 2001:DB8:100:: 64 
      peer 2001:DB8:24::4 enable
      peer 2001:DB8:100::1 enable
      peer 2001:DB8:100::1 default-route-advertise
      peer 2001:DB8:100::3 enable
      peer 2001:DB8:100::3 default-route-advertise
    #
    ospf 1 router-id 10.2.2.2 
     area 0.0.0.0 
      network 10.2.2.2 0.0.0.0 
      network 192.168.24.0 0.0.0.255 
    #
    return

    AR3:

    <AR3>dis current-configuration 
    #
     sysname AR3
    #
    ipv6 
    #
    ospfv3 1
     router-id 10.2.2.2
    #
    interface Serial4/0/0
     link-protocol ppp
     ip address 192.168.35.3 255.255.255.0 
    #
    interface GigabitEthernet0/0/0
     ipv6 enable 
     ipv6 address 2001:DB8:100::3/64 
     ospfv3 1 area 0.0.0.0
    #
    interface LoopBack0
     ip address 10.3.3.3 255.255.255.255 
     ospfv3 1 area 0.0.0.0
    #
    bgp 100
     router-id 10.3.3.3
     undo default ipv4-unicast
     peer 2001:DB8:100::1 as-number 100 
     peer 2001:DB8:100::2 as-number 100 
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      peer 2001:DB8:100::1 enable
      peer 2001:DB8:100::2 enable
    #
    return

    AR4:

    <AR4>dis current-configuration 
    #
     sysname AR4
    #
    ipv6 
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 49.0001.0000.0000.0004.00
     #
     ipv6 enable topology standard
     ipv6 default-route-advertise always 
     #
    interface GigabitEthernet0/0/0
     ip address 192.168.24.4 255.255.255.0 
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ipv6 enable 
     ipv6 address 2002:A06:606:46::4/64 
     isis ipv6 enable 1
    #
    interface LoopBack0
     ip address 10.4.4.4 255.255.255.255 
    #
    interface Tunnel0/0/0
     ipv6 enable 
     ipv6 address 2001:DB8:24::4/64 
     tunnel-protocol gre
     source 192.168.24.4
     destination 192.168.24.2
    #
    bgp 200
     router-id 10.4.4.4
     undo default ipv4-unicast
     peer 2001:DB8:24::2 as-number 100 
     peer 2002:A06:606:56::5 as-number 200 
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      import-route isis 1
      peer 2001:DB8:24::2 enable
      peer 2002:A06:606:56::5 enable
      peer 2002:A06:606:56::5 next-hop-local 
    #
    ospf 1 router-id 10.4.4.4 
     area 0.0.0.0 
      network 10.4.4.4 0.0.0.0 
      network 192.168.24.0 0.0.0.255 
    #
    return

    AR5:

    <AR5>dis current-configuration  
    #
     sysname AR5
    #
    ipv6 
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 49.0001.0000.0000.0005.00
     #
     ipv6 enable topology standard
    #
    interface Serial4/0/0
     link-protocol ppp
     ip address 192.168.35.5 255.255.255.0 
    #
    interface Serial4/0/1
     link-protocol ppp
    #
    interface GigabitEthernet0/0/0
     ipv6 enable 
     ipv6 address 2002:A06:606:56::5/64 
     isis ipv6 enable 1
    #
    interface LoopBack0
     ip address 10.5.5.5 255.255.255.255 
     isis enable 1
    #
    bgp 200
     router-id 10.5.5.5
     undo default ipv4-unicast
     peer 2002:A06:606:46::4 as-number 200 
     #
     ipv4-family unicast
      undo synchronization
     #
     ipv6-family unicast
      undo synchronization
      import-route isis 1
      peer 2002:A06:606:46::4 enable
    #
    return

    AR6:

    <AR7>dis current-configuration  
    #
     sysname AR7
    #
    ipv6 
    #
    dhcp enable
    #
    dhcpv6 pool pool
     address prefix 2002:A07:707::/64
     dns-server 2001:DB8:100::1
    #
    isis 1
     is-level level-2
     cost-style wide
     network-entity 49.0001.0000.0000.0007.00
     #
     ipv6 enable topology standard
     #
    interface GigabitEthernet0/0/0
     ip address 192.168.67.7 255.255.255.0 
     isis enable 1
    #
    interface GigabitEthernet0/0/1
     ipv6 enable 
     ipv6 address 2002:A07:707::7/64 
     undo ipv6 nd ra halt
     ipv6 nd autoconfig other-flag
     isis ipv6 enable 1
     dhcpv6 server pool
    #
    interface LoopBack0
     ip address 10.7.7.7 255.255.255.255 
     isis enable 1
    #
    interface Tunnel0/0/0
     ipv6 enable 
     ipv6 address 2002:A07:707:67::7/64 
     tunnel-protocol ipv6-ipv4 6to4
     source LoopBack0
    #
    ipv6 route-static :: 0 Tunnel0/0/0 
    #
    return

    AR7:

    <AR8>dis current-configuration 
    #
     sysname AR8
    #
    ipv6 
    #
    dhcp enable
    #
    interface GigabitEthernet0/0/0
     ipv6 enable 
     ipv6 address auto link-local
     ipv6 address auto dhcp
     //配置通过dhcpv6获取IP地址
    #
    return

    展开全文
  • linux配置禁用启用IPv6

    千次阅读 2019-10-02 14:53:47
    IPv6被认为是IPv4的替代产品,它用来解决现有IPv4地址空间即将耗尽的问题。但目前,开启IPv6可能会导致一些...IPv6在CentOS6.5系统中默认是启用状态,通过以下方式可以确认IPv6的状态 1.1.查看系统IPv6启用状态...

    IPv6被认为是IPv4的替代产品,它用来解决现有IPv4地址空间即将耗尽的问题。
    但目前,开启IPv6可能会导致一些问题。因此有时我们需要关闭IPv6。
    下面是IPv6的关闭方法应该适用于所有主流的Linux发行版包括Ubuntu、Debian、CentOS。

     

    IPv6在CentOS6.5系统中默认是启用状态,通过以下方式可以确认IPv6的状态

    1.1.查看系统IPv6的启用状态

    以下命令返回值为0表示IPv6启用,1表示禁用

    cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    cat /proc/sys/net/ipv6/conf/default/disable_ipv6
    ifconfig 
    ip address list
    netstat -anptl

    1.2.查看内核模块调用

    # 有返回结果,说明IPv6模块已启用,可以看出那些程序进行了调用,反之没有启用

    lsmod | grep ipv6

    2.禁用IPv6

    2.1.临时禁用IPv6

    # 命令行调整内核参数,临时禁用IPv6

    echo 1 >/proc/sys/net/ipv6/conf/all/disable_ipv6
    echo 1 >/proc/sys/net/ipv6/conf/default/disable_ipv6
    # 或着
    sysctl -w net.ipv6.conf.all.disable_ipv6=1
    sysctl -w net.ipv6.conf.default.disable_ipv6=1

    2.2.永久禁用IPv6

    echo " ">>/etc/sysctl.conf
    echo "# made for disabled IPv6 in $(date +%F)">>/etc/sysctl.conf
    echo 'net.ipv6.conf.all.disable_ipv6 = 1'>>/etc/sysctl.conf
    echo 'net.ipv6.conf.default.disable_ipv6 = 1'>>/etc/sysctl.conf
    echo 'net.ipv6.conf.lo.disable_ipv6 = 1'>>/etc/sysctl.conf
    tail -5 /etc/sysctl.conf
    sysctl -p
    netstat -anptl

    也可以直接编辑系统内核配置文件

    vim /etc/sysctl.conf
    ------------------------------------------------------
    # Made for disabled IPv6 .
    net.ipv6.conf.all.disable_ipv6 = 1
    net.ipv6.conf.default.disable_ipv6 = 1
    net.ipv6.conf.lo.disable_ipv6 = 1
    -------------------------------------------------------

    # 如果想要为特定的网卡禁止IPv6,比如eth1,改为添加下面的行。

    net.ipv6.conf.eth1.disable_ipv6 = 1

    # 注意检查修改network配置文件中的IPv6配置

    vim /etc/sysconfig/network
    --------------------------------------
    NETWORKING_IPV6=no
    --------------------------------------
    

    # 注意修改ifcfg-eth0

    vim /etc/sysconfig/network-scripts/ifcfg-eth0
    ----------------------------------
    IPV6INIT=no
    ----------------------------------

    2.3.拓展:禁用IPV6后,可能会导致某些服务无法启动

    1)修改ssh配置,只监听IPv4地址

    vim /etc/ssh/sshd_config
    ----------------------------------------
    # 在第15行的前面去掉注释(#):
    ListenAddress 0.0.0.0
    AddressFamily inet
    ----------------------------------------
    service sshd restart
    netstat -anptl

    # 注意:inet为仅IPv4,inet6为仅IPv6,any为都支持

    2)mysql配置问题

    mysql安装后默认会监听IPv6地址,关闭IPv6后,需要编辑,在[mysqld]中添加

    vim /etc/my.cnf
    ----------------------------------------
    bind-address=0.0.0.0
    ----------------------------------------

    修改完重启mysql即可

    3)配置redis,监听IPv4地址

    vim  /usr/local/redis/conf/redis.conf
    ----------------------------------------
    bind 127.0.0.1
    ----------------------------------------

    4)配置memcached,监听IPv4地址

    # 配置memcached,监听地址需要使用IP,使用localhost无法启动memcached

    # memcached
    /usr/local/memcached/bin/memcached -u root -p 12001 -l 127.0.0.1 -d -P /tmp/memcached1.pid

    5)配置VSFTP

    vim /etc/vsftpd/vsftpd.conf
    ----------------------------------------
    listen=YES
    listen_ipv6=NO
    ----------------------------------------

    6)配置postfix监听IPv4地址

    vim /etc/postfix/main.cf
    ----------------------------------------
    inet_interfaces = 127.0.0.1
    ----------------------------------------

    7)配置dovecot监听IPv4地址

    vim /etc/dovecot/dovecot.conf
    ----------------
    listen *
    ----------------

    8)配置xinetd

    # xinetd.conf第32行修改为:
    vim /etc/xinetd.conf 
    ------------------------
    bind            = 0.0.0.0
    ------------------------
    # 重新载入配置文件
    service xinetd reload

    以上是禁用IPv6之后可能会受到影响的程序,可以根据自己的实际情况进行配置

    3.配置启用IPv6

    3.1.查看linux系统的IPv6状态

    cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    cat /proc/sys/net/ipv6/conf/default/disable_ipv6

    3.2.调整内核参数立即启用IPv6

    echo 0 >/proc/sys/net/ipv6/conf/all/disable_ipv6
    echo 0 >/proc/sys/net/ipv6/conf/default/disable_ipv6
    # 或着
    sysctl -w net.ipv6.conf.all.disable_ipv6=0
    sysctl -w net.ipv6.conf.default.disable_ipv6=0

    修改完是临时的,重启失效

    3.3. 修改内核参数,启用IPv6配置

    vim /etc/sysctl.conf
    ----------------------------------------------
    net.ipv6.conf.all.disable_ipv6 = 0
    net.ipv6.conf.default.disable_ipv6 = 0
    net.ipv6.conf.lo.disable_ipv6 = 0
    ----------------------------------------------
    sysctl -p

    3.4.手动调用系统ipv6内核

    modprobe ipv6

    3.5.报错处理

    [root@zstest ~]# modprobe ipv6
    FATAL: Module off not found.

    失败原因:未启用IPv6模块

    解决方法:
    需要编辑配置文件,启用IPv6内核模块,在禁用状态下无法调用ipv6模块
    该处理需要重启系统,启动后ipv6模块自动调用

    vim /etc/modprobe.d/disable_ipv6.conf 
    --------------------------------
    #alias net-pf-10 off
    #alias ipv6 off
    options ipv6 disable=0
    ---------------------------------
    [root@zstest ~]# lsmod |grep ipv6                      
    ipv6                  335781  14 

     

    完毕,呵呵呵呵

    转载于:https://www.cnblogs.com/tssc/p/9210990.html

    展开全文
  • linux下常用ipv6命令

    千次阅读 2021-05-08 23:41:46
    在运行的内核上,有不同的方法可以验证是否启用IPv6支持1.验证/proc/net目录下是否有if_net6文件2.显示接口信息 ifconfig 看是否有链路本地地址在linux上,配置ipv61.一旦内核启用IPv6支持,在/etc/sysconfig/...
  • 编辑99-sysctl.conf文件。 sudo vim/etc/sysctl.d/99-sysctl....net.ipv6.conf.all.disable_ipv6 = 1 net.ipv6.conf.default.disable_ipv6 = 1 net.ipv6.conf.lo.disable_ipv6 = 1 保存并关闭文件。 然后执行以下...
  • ipv6好像已经成为一种必不可少的趋势,但是当前国内机房大部分还不能支持ipv6,腾讯云亦如此。同时,现在有部分程序在服务器上运行的时候,需要服务器能监听一个ipv6地址才行,因此本文档指导如何在c...
  • 默认情况下,在RHEL / CenOS 7系统上启用IPv6。因此,如果故意在系统上禁用IPv6,则可以通过以下任一方法重新启用它。 1.在内核模块中启用IPv6(需要重启)2。使用sysctl设置启用IPv6(无需重启) 在内核模块中...
  • ECS启用ipv6

    2021-12-25 23:02:16
    1. 购买ECS时要记得筛选 ipv6 1. 购买ECS地址为https://ecs-buy.aliyun.com/wizard#/prepay/cn-shenzhen,筛选的最后一个选项就是ipv6 2. VPC专有网络开通ipv6 1. 登录[专有网络管理控制台]...
  • 在本文中,我将教你如何做到这一点,还介绍如何启用或重新启用IPv6,参考在Linux服务器上禁用IPv6的方法。在Ubuntu上禁用IPv6[仅限高级用户]下面我将介绍如何在Ubuntu计算机上禁用IPv6协议,打开一个终端(默认:CTRL...
  • Mac与Windows的ping IPv6命令

    万次阅读 2017-12-27 14:07:12
    关于IPv6的一些知识: IPv4是以.作为分隔符的,IPv6是以:作为分隔符。 IPv4是32位的,十进制表示:01234567.01234567.01234567.01234567,每位是2 ^ 8 = 256,在没有子网掩码的情况下数量是 256 * 256 * 256 * 256...
  • cisco ipv6配置详解

    2011-09-17 02:24:27
    cisco ipv6 配置手册 思科官方的ipv6配置手册,还有很多ipv6的基础知识
  • 怎么配置IPv6 静态路由

    千次阅读 2020-12-29 07:45:09
    开始配置路由器R1,配置命令是:Router#enRouter#conf tEnter configuration commands, one per line. End with CNTL/Z.Router(config)#ipv6 unicast-routingRouter(config)#int l0Router(config-if)#ipv6 address ...
  • H3C IPv6地址配置命令

    千次阅读 2019-07-09 13:20:00
    转载于:https://www.cnblogs.com/fanweisheng/p/11156709.html
  • 思科路由器配置 IPv6 和 OSPFv3 路由

    千次阅读 2020-12-29 07:45:09
    一、前言IPv6 最近是越来越火了,是时候该学习下 IPv6 路由的配置了。本文将介绍思科路由器 IPv6 地址以及路由协议的配置方法。本文纯属个人学习经验,希望可以帮到刚入门网络的新手,老司机勿喷。如有错误请及时...
  • Padavan启用ipv6并允许公网访问内网

    千次阅读 2020-12-27 15:13:33
    听说联通支持ipv6了,特地来试试。家里用的是padavan的路由器,取得了SSH,光猫也改成桥接了,采用的是联通家庭宽带FTTH,一切准备就绪,开始淦~! 1、路由器配置好拨号后,配置直接见下图吧,就不重复了。 目前...
  • 实现IPv6配置示例的静态路由

    千次阅读 2020-12-29 07:45:10
    本文描述如何配置IPv6的静态路由。静态路由是定义了两个设备之间的明确路径的手工配置的路由。一旦在网络的拓扑更改,静态路由没有自动地更新象那样动态协议,并且必须手工重新配置。静态路由为只有一个路径对外部...
  • 为高级用户配置 Windows IPv6 的指南09/08/2020本文内容WindowsVista、Windows Server 2008 和更高版本的 Windows 实现 RFC 3484 并使用前缀表确定当多个地址可用于域名系统 (DNS) 名称时将使用的地址。默认情况下,...
  • 可是一些用户在Win7系统创建家庭组出现“由于IPV6启用”的提示,怎么回事呢?大家只要启动IPV6问题即可解决了。下面一起来解决win7系统创建家庭组提示“由于IPV6启用”的解决方法。具体步骤:windows7 - 1、右键...
  • windows系统下使用netsh配置IPv6相关

    万次阅读 2015-07-24 12:49:15
    下面分享几个方便的命令操作。 释放地址 ipconfig /release "Local Area Connection 1" 重新获取地址 ipconfig /renew "Local Area Connection 1" 配置IPv6单播地址 netsh interface ipv6 add/del address
  • Linux下ipv6配置

    2021-01-12 01:15:28
    一:检查Linux是否已经开启ipv6ifconfig 查看系统网络配置,如有ipv6项,则说明,已配置,EOF.二:开启ipv61.找到配置sysctl.conf 文件,路径在:/etc/sysctl.conf ,找到如下配置:如果已经存在,则直接修改,如果...
  • Linux下配置IPv6地址的方法

    千次阅读 2021-05-10 01:03:17
    Linux在内核版本2.2.0以后就支持IPv6了,可查看/proc/net/if_inet6文件是否存在以确定你的系统是否支持IPv6如果没有,可尝试如下命令加载IPv6模组:# modprobe ipv6成功加载后就可以使用IPv6环境了,系统会自动获得...
  • 配置 IPv6 接口

    2020-12-29 06:31:33
    配置 IPv6 接口作为在网络上使用 ...如果在安装期间启用 IPv6 支持,则在安装完成后,将存在以下 IPv6 相关的文件和表:针对 IPv6 启用的每个接口现在都有一个与之关联的 /etc/hostname6.interface 文件,如 host...
  • linux常用命令3-虚拟机测试ping ipv6

    万次阅读 2018-11-08 01:03:55
    linux常用命令3-虚拟机测试ping ipv6 环境 vmwarwe NAT模式 windos7 默认都开启了支持ipv6 1.windows的ip 以太网适配器 本地连接:指有线网络连接 以太网适配器 bluetooth连接:蓝牙网络连接 媒体已断开:指当前...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,413
精华内容 9,765
关键字:

启用ipv6命令