精华内容
下载资源
问答
  • 32、Rip路由协议

    2021-02-04 21:53:20
    RIP路由信息协议(Routing information Protocol)。它是一种基于距离矢量(Distance-Vector)算法的协议,使用跳数作为度量来衡量到达 目的网络的距离。RIP主要应用于规模较小的网络中。 RIPv1和RIPv2的...

    RIP:路由信息协议(Routing information Protocol)。它是一种基于距离矢量(Distance-Vector)算法的协议,使用跳数作为度量来衡量到达

    目的网络的距离。RIP主要应用于规模较小的网络中。

    RIPv1和RIPv2的区别

    1、v1不带掩码(只能被认为是ABCD类地址),v2带掩码

    2、v2以组播(224.0.0.9)发送报文,v1以广播255.255.255.255发送报文

     

    报文格式

     

    RIP环路

    RIP触发更新:当路由信息发生变化时,立即向邻居设备发送触发更新报文

     

    阻止RIP环路的方法:

    进入相对应的接口后,开启水平分割。命令:rip split-harizon

    进入相对应的接口后,开启毒性反转。命令:rip poison-reverse

    注:开启RIP后,水平分割的特性默认开启,毒性反转默认关闭,当两者都开启时,毒性反转生效。

     

     

    RIP基本配置

    注意:RIP宣告网络network时,所宣告的网络段会自动的把属于该网络段的IP接口加入RIP

     

    如果想所属于宣告的网络的一个IP接口不发送RIP,可以配置input、output。相当于rip不宣告该IP地址

     

    命令:display rip 1   查看rip信息

               display rip 1 interface g0/0/0   简略查看g0/0/0信息

               display rip 1 interface g0/0/0 verbose    详细查看该接口rip信息

     

    通过更改度量Metric改变路由方向

    通过ACL策略来阻止、允许来更改路由表

     

    展开全文
  • RIP协议配置,组网。RIP路由协议典型配置。
  • 计算机网络原理实验五,是关于RIP路由协议的,自己做的实验,代码和结果截图都有,步骤详细
  • RIP路由协议原理

    2020-06-13 14:18:13
    路由协议基础1.1 自治系统(AS)1.2 路由协议分类2. RIP协议基本原理3. RIP路由表形成4. RIP消息格式5. RIP-1与RIP-25 .1RIP-1的报文格式5.2 RIP-2的报文格式5.3 运行RIP-1和RIP-2版本的不同5.3.1 运行RIP-1的时候...

    RIP


    思维导图

    1. 路由协议基础

    1.1 自治系统(AS)

    自治系统(Autonomous System,AS):在网络中一个自治系统指的是若干个二层网络及若干路由器组成的集合,集合中的这些网络和这些路由器属于同一个管理机构。规模大小不同,一个 internet 可以包含一个或多个AS

    1.2 路由协议分类

    • 路由协议分为两大类,一类是IGP(Interior Gateway Protocol,内部网关协议),一类是EGP(Exterior Gateway Protocol ,外部网关协议 )
    • IGP成员有RIP(Routing Information Protocol)OSPF(Open Shortest Path First)IS-IS(Intermediate System to Intermediate System)等;
    • EGP成员虽然也有若干个协议,但是目前使用的就只有一个BGP(Border Gateway Protocol)

    2. RIP协议基本原理

    • RIP是一种基于距离矢量(Distance Vector,简称DV)算法的IGP协议,其协议的优先级为100(华为),120(思科);

    • 以“跳数”作为开销,所谓“跳数”就是到达目的地需要经过的路由器个数,跳数>=16时视为不可达路由,使得RIP只能应用于小规模的网络;

    • 周期性更新路由表,即使在稳定状态下,路由交换过程仍然会继续进行;

    3. RIP路由表形成

    一台路由器在创建RIP路由表初期,RIP路由表中只包含直连路由。随后路由器会不断接收从邻居发来的路由信息,并根据这些路由信息来完善自己的路由表。同时路由器会每隔30s向邻居路由器发起更新请求。

    4. RIP消息格式

    • RIP的消息格式有两种:一种是RIP请求消息(Request),另一种是RIP响应消息(Response)

    • RIP路由器发送请求消息给邻居路由器,邻居路由器收到后就会立即发送响应消息给邻居路由器;

    • RIP路由器可以随时向邻居发出请求消息;

    • RIP路由器总是会每隔30s周期性向邻居路由器发送响应消息

      RIP请求消息有两种

      1. 请求消息用来请求关于某一些指定的路由信息;
      2. 请求关于整个RIP网络的路由信息,RIP刚刚启动的时候应该是采用第二种RIP请求消息

    5. RIP-1与RIP-2

    ​ RIP协议有两个版本,RIP-1和RIP-2,基于UDP协议,使用的端口号为520

    5 .1RIP-1的报文格式

    RIP-1报文由头部(Header)和多个路由表项(Route Entries)部分组成。在一个RIP报文中,最多可以有25个路由表项。RIP是一个基于UDP协议的,并且RIP-1的数据包不能超过512字节

    字段名长度含义
    Command(命令)8比特标识报文的类型: 1:Request报文,向邻居请求全部或部分路由信息; 2:Reponse报文,发送自己全部或部分路由信息,一个Response报文中最多包含25个路由表项。
    Version(版本)8比特RIP的版本号: 1:RIP-1 2:RIP-2
    Must be zero16 比特必须为零字段。
    AFI(Address Family Identifier)协 议簇16比特地址族标识,其值为2时表示IP协议。对于Request报文,此字段值为0。
    Route Tag16比特外部路由标记。
    IP Address32比特该路由的目的IP地址,可以是自然网段的地址,也可以是子网地址或主机地址。
    Metric32比特路由的开销值。对于Request报文,此字段为16。

    5.2 RIP-2的报文格式

    字段名长度含义
    Command(命令)8比特标识报文的类型: 1:Request报文,向邻居请求全部或部分路由信息; 2:Reponse报文,发送自己全部或部分路由信息,一个Response报文中最多包含25个路由表项。
    Version(版本)8比特RIP的版本号: 1:RIP-1 2:RIP-2
    Must be zero16比特必须为零字段。
    AFI(Address Family Identifier)协议簇16比特地址族标识,其值为2时表示IP协议。对于Request报文,此字段值为0。
    Route Tag16比特外部路由标记。
    IP Address32比特该路由的目的IP地址,可以是自然网段的地址,也可以是子网地址或主机地址。
    Subnet Mask32比特目的地址的掩码。
    Next Hop32比特提供一个更好的下一跳地址。如果为0.0.0.0,则表示发布此路由的路由器地址就是最优下一跳地址。
    Metric32比特路由的开销值。对于Request报文,此字段为16。

    5.3 运行RIP-1和RIP-2版本的不同

    5.3.1 运行RIP-1的时候

    1. 对于请求消息或周期性的响应消息(情况1),IP报文的目的地址为广播地址255.255.255.255,源地址为发送该请求消息或响应消息的接口的IP地址,协议字段的值为0x11

    2. 为了回应请求消息而发送的响应消息(情况2),IP报文的目的地址为发送请求消息接口的IP地址,源地址为发送响应消息的接口的IP地址,协议字段0x11

      • 接下来,IP报文又是封装在以太网帧中(假设路由器的接口都是以太网接口)
    • 对于情况1,以太网帧的目的MAC地址是ff-ff-ff-ff-ff-ff,源地址是发送请求消息或响应消息的接口的MAC地址,类型字段为0x0800。

    • 对于情况2,以太网帧的目的MAC地址是发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,类型字段为0x0800。

    5.3.2 运行RIP-2的时候

    1. 对于请求消息或周期性的相应消息(情况1),IP报文的目的地址为组播地址224.0.0.9,也可以为广播地址255.255.255.255,源地址为发送该请求消息或响应消息的接口的IP地址,协议字段的值为0x11。

    2. 为了回应请求消息而发送的响应消息(情况2),IP报文的目的地址为发送请求消息接口的IP地址,源地址为发送响应消息的接口的IP地址,协议字段0x11。

      • 接下来,IP报文又是封装在以太网帧中(假设路由器的接口都是以太网接口)

        • 对于情况1,以太网帧的目的MAC地址是ff-ff-ff-ff-ff-ff,源地址是发送请求消息或响应消息的接口的MAC地址,类型字段为0x0800。

        • 对于情况2,以太网帧的目的MAC地址是发送请求消息的接口的MAC地址,源地址为发送该响应消息的接口的MAC地址,类型字段为0x0800。

    5.3.3 RIP-1与RIP-2的不同

    1. RIP-1只支持有类路由;RIP-2支持无类路由,支持VLSM,CIDP等特性;
    2. RIP-1不支持认证功能;RIP-2可以支持认证功能,因此安全性得到提高;
    3. RIP-1不能采用组播方式发布消息;RIP-2可以采用组播方式发布消息,因此RIP-2比RIP-1占用更少的设备处理资源;

    6. RIP定时器

    RIP协议有三种定时器:分别是更新定时器(Update Timer)无效定时器(Invalid Timer)垃圾收集定时器(Carbage Collection Timer)

    6.1 更新定时器

    更新定时器也可以称为周期定时器(Periodic Timer),每台RIP路由器都有一个属于自己的RIP更新定时器。缺省情况下,周期值为30s。每当更新定时器倒计时值为0时,路由器就会向所有邻居发送RIP响应消息,当路由器收到RIP请求消息时候,会立即发送RIP响应消息,但是不影响基于更新定时器的周期性RIP响应消息的发送

    6.2 无效定时器

    每个路由器都建立并维护一个无效定时器。缺省情况下,无效定时器值为180s(更新定时器周期的6倍)。当一个路由项的无效定时器的值倒计时为0时,就说明该路由表项已经有180s的时间没有别更新,此时路由表会认为该路由项已经变为一个无效的路由项,也就是认为该路由项所指的所指的目的地已经变为不可达,于是路由器会将该路由的cost值设置为16.

    6.3 垃圾收集定时器

    • 当无效定时器值倒计时为0时,该路由项是一个无效路由项,其cost值就会被设置为16。此时路由器不会立即将这个无效的路由项删除掉,而是会为该路由项启用一个被称为垃圾收集定时器的倒数计时器。垃圾收集定时器的缺省值为120s。

    • 在垃圾收集定时器倒计时为0之前,该路由器仍然会周期性在RIP响应消息中携带这条无效的路由信息,其目的是为了告诉他的所有邻居这条路由项对于自己来说已经无效,以便路由器能够及时对各自的RIP路由表中的相应的路由项进行更新。

    • 一旦垃圾收集定时器的值倒计时为0时,路由器就会将这条无效路由项删除。(注意:在垃圾收集定时器为0前的某一时刻,该无效路由被更新,即Cost的值更新为小于16,则该路由项的的无效定时器会被复位成初始值,然后重新计时,相应的垃圾收集定时器则会被删除掉

    7. RIP环路问题

    假设路由器C发生故障(E0接口down掉),RC监测到该故障后会立即向RB发送故障信息(跳数设置为16)表示10.4.0.0为无效路由。然而,在RC准备将这条无效路由周期性响应消息发给RB的时候,收到RB周期性的相应消息,其中包含10.4.0.0 网段的路由信息,那么这个时候RC就会认为通过RB可以到达10.4.0.0网段,所以RC就在10.4.0.0路由项的跳数上+1,RB又会从RC学习到这条路由并且会通告给自己的邻居,那么不断往复,就产生了环路。

    8. 环路解决

    华为的环路解决方案提供了触发更新水平分割毒性逆转三种

    8.1 触发更新

    • 所谓触发更新,就是指RIP路由表中的某些路由项的内容发生改变时,路由器应立即向它的所有邻居发布响应消息,而不用等待更新定时器所规定的下一个响应消息的发送时刻。(立即更新)

    • 另外,触发更新响应消息中只需要包含路由信息发生了改变的路由项,减少带宽及路由器处理资源的消耗

    注意如果对方未收到触发更新的消息,本端就收到一个周期性响应消息,这种情况下仍然会产生路由。但是触发更新在一定程度上降低了环路产生的概率。

    8.2 水平分割

    水平分割的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由器在通过Interface-x接口向外发送响应消息时,响应消息一定不要包含关于z/y这个路由项的信息。(从哪里学到就不发回哪里

    8.3 毒性逆转

    毒性逆转的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由通过Interface-x接口向外发送消息时,响应消息中仍然需要包含z/y这个路由项,但是这个路由项的Cost值总是16。

    里`)

    8.3 毒性逆转

    毒性逆转的原理是:如果一台路由器的RIP路由表中目的地/掩码为z/y的路由信息是通过该路由器的Interface-x接口学习来的,那么该路由通过Interface-x接口向外发送消息时,响应消息中仍然需要包含z/y这个路由项,但是这个路由项的Cost值总是16。

    展开全文
  • RIP路由配置实验

    2021-02-03 19:18:48
    一、实验目的 掌握路由器中rip动态路由的配置方法和结果验证...图1-1 RIP路由的基本配置实例 2、业务配置流程图 图1-2 RIP路由的基本配置实验流程 3、实验配置过程 1.路由器的基本配置 步骤1:路由器R1的配置 ZXR10(c

    一、实验目的

    掌握路由器中rip动态路由的配置方法和结果验证。

    二、实验内容

    完成中兴1800路由器RIP动态路由的配基本置和结果查看。

    三、实验过程

    1、实验任务说明
    如图1-1所示,按照以下的网络拓扑完成网络的连接和设置,通过配置RIP动态路由实现192.168.2.0和192.168.1.0两个网络之间可以互相ping通。
    在这里插入图片描述

    图1-1 RIP路由的基本配置实例

    2、业务配置流程图
    在这里插入图片描述

    图1-2 RIP路由的基本配置实验流程

    3、实验配置过程
    1.路由器的基本配置
    步骤1:路由器R1的配置
    ZXR10(config)#interface gei_0/1
    ZXR10(config-if)#ip addresss 40.1.1.5 255.255.255.252
    ZXR10(config-if)#exit
    ZXR10(config)#interface loopback1
    ZXR10(config-if)#ip addresss 192.168.2.1 255.255.255.0
    ZXR10(config-if)#exit
    步骤2:路由器R2的配置
    ZXR10(config)#interface gei_0/1
    ZXR10(config-if)#ip addresss 40.1.1.6 255.255.255.252
    ZXR10(config-if)#exit
    ZXR10(config)#interface loopback1
    ZXR10(config-if)#ip addresss 192.168.1.1 255.255.255.0
    ZXR10(config-if)#exit

    1.RIP路由的基本配置
    步骤1:路由器R1的配置
    ZXR10(config)#router rip
    以上命令用来启动rip路由协议。接着宣告RIP路由器接口上的网络,命令如下:
    ZXR10(config-route)#network 192.168.2.0 0.0.0.255
    注:宣告网络时使用反掩码。
    ZXR10(config-route)#network 40.1.1.4 0.0.0.3
    指定RIP协议版本,命令如下:
    ZXR10(config-route)#version 2
    关闭路由协议的自动汇总功能,命令如下:
    ZXR10(config-route)#no auto-summary

    步骤2:路由器R2的配置
    ZXR10(config)#router rip
    以上命令用来启动rip路由协议。接着宣告RIP路由器接口上的网络,命令如下:
    ZXR10(config-route)#network 192.168.1.0 0.0.0.255
    注:宣告网络时使用反掩码。
    ZXR10(config-route)#network 40.1.1.4 0.0.0.3
    指定RIP协议版本,命令如下:
    ZXR10(config-route)#version 2
    关闭路由协议的自动汇总功能,命令如下:
    ZXR10(config-route)#no auto-summary

    3.查看和验证
    步骤1:查看两个路由器的路由表
    路由器R1的输出结果如图1-3所示:
    在这里插入图片描述

    图1-3 路由器R1的路由表

    路由器R2的输出结果如图1-4所示:
    在这里插入图片描述

    图1-4 路由器R2的路由表

    步骤2:从两台路由器互ping对方的loopback1接口的地址。
    从路由器R1ping路由器R2的loopback1接口地址192.168.1.1,结过可以ping通,如图1-5所示:
    在这里插入图片描述

    图1-5 在路由器R1上的ping通结果

    四、实验验证

    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述
    在这里插入图片描述

    五、实验思考与总结

    1. 动态路由:是运行在路由器上的软件进程,通过该进程路由器上相同路由协议之间交换路由信息。
      优点:是可以自动适应网络状态的变化,自动维护路由信息而不用网络管理员的参与。
      缺点:由于需要相互交换路由信息,需要占用网络带宽,并且要占用系统资源,另外安全性也不如静态路由。
    2. 常见的动态路由协议:
      1 ) RIP ( Routing Information Protocol )路由选择信息协议,使用UDP作为传输协议,端口号520,协议号为17。
      2 ) OSPF ( Open Shortest Path First )开放式最短路径优先, OSPF工作在网络层,协议报文直接封装在IP报文中,协议号89 ,可靠性需要自身保证。
      3 ) BGP ( Border Gateway Protocol )边界网关协议,使用TCP作为传输协议,端口号179,协议号是6。
    展开全文
  • 所有路由会自动汇总为有类路由.v2是一种无类路由协议,报文中携带掩码信息,支持手动汇总和自动汇总两种方式… 基于RIP进程的有类自动汇总:比如对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,...
    实验原理
    • 当路由条目很多的时候,可以使用路由汇总来减少路由条目,加快收敛和增强网络稳定性.,原理就是同一个网段内的不通子网的路由在向外发送时聚合成一个网段的路由发送.v1属于有类路由,报文内不携带掩码信息,也不支持不连续子网,所有路由会自动汇总为有类路由.v2是一种无类路由协议,报文中携带掩码信息,支持手动汇总和自动汇总两种方式…
    • 基于RIP进程的有类自动汇总:比如对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,聚合成自然网段路由10.0.0.0/8(metric=2)。自动汇总是按类聚合的,在华为设备上自动汇总总是默认关闭的,可手动更改配置使自动汇总生效。
    • 基于接口的手动汇总:用户可以指定汇聚路由。比如:对于10.1.1.0/24(metric=2)和10.1.2.0/24(metric=3)这两条路由,可以在此接口上配置聚合路由10.1.0.0/16(metric=2)。
    实验拓扑

    在这里插入图片描述

    实验步骤

    1,配置ripv1协议

     [R1]rip
     [R1-rip-1]network 192.168.12.0
     [R2]rip 
     [R2-rip-1]network 192.168.12.0
     [R2-rip-1]network 192.168.23.0
     [R3]rip
     [R3-rip-1]network 192.168.23.0
     [R3-rip-1]network 3.0.0.0
    

    可以看到可以观察到收到R3发来的3.0.0.0/8的汇总,没有其他任何路由明细条目;RIPv1不携带掩码信息,只处理有类路由;默认开的自动汇总
    在这里插入图片描述

    配置RIPv2的汇总

     [R1]rip
     [R1-rip-1]version 2
     [R2]rip
     [R2-rip-1]version 2
     [R3]rip
     [R3-rip-1]version 2
    

    查看R1的路由表,
    在这里插入图片描述

    观察到,有具体的明细路由,没有汇总路由,即此时的自动汇总失效(原因是华为设备时为了避免环路问题,在接口上采用了水平分割或毒性反转,因此默认的自动聚合失效)。
    为了自动聚合生效,可采用:

    [R3]rip
    [R3-rip-1]version 2
    [R3-rip-1]summary always 
    

    汇总路由已经生成.
    在这里插入图片描述

    配置手动汇总,在R3上 interface Serial 1/0/1

    rip summary-address 3.3.0.0 255 255.252.0
    

    在这里插入图片描述

    展开全文
  • 标准的距离矢量型路由协议,基于UDP 520端口工作,优先级100 采用跳数作为度量,默认仅存在更新包,邻居间直接共享路由表 更新包—数据包—携带路由条目 跳数:经过路由器的个数 周期更新—30s 触发更新—根据网络的...
  • 思科RIP路由协议配置

    千次阅读 2020-05-23 23:09:55
    RIP(Routing Information protocol) 路由信息协议. 是一种内部网关协议(IGP),是一种动态路由选择协议,用于自治系统(AS)内的路由信息的传递。RIP协议基于距离矢量算法(DistanceVectorAlgorithms),使用“跳...
  • RIP路由协议

    2021-03-16 18:25:01
    RIP是一种基于距离矢量(Distance-Vector)算法的路由协议RIP协议适用于中小型网络,分为RIPv1和RIPv2。RIP支持水平分割、毒性逆转和触发更新等工作机制防止路由环路。RIP协议基于UDP传输,端口号520。RIP协议逐跳...
  • (这里使用动态路由协议RIP) 动态路由基本原理: 动态路由是与静态路由是相对的一个概念,动态路由可以通过与相邻的路由建立连通,从而相邻双方将自身已知路由表信息进行交换、更新,动态调整自身的路由表...
  • 内部网关协议——RIP简介“距离”三个要点~~距离向量算法~~优缺点dddd:坏消息传得慢RIP路由协议的版本4.动态路由5.相关代码开始实验1. 预备知识 1.内部网关协议[IGP] IGP,Interior Gateway Protocol 在一个自治...
  • 一、动态路由概述: 动态路由是与静态路由相对的一个概念,指路由器能够根据路由器之间的交换的特定路由信息自动地建立自己的路由表,并且能够根据链路和节点的变化适时地进行自动调整...3、在路由器上运行路由协议...
  • RIP路由协议及工作原理

    千次阅读 2018-08-26 13:57:22
    RIP(Routing information Protocol,路由信息协议)是应用较早、使用较普遍的内部网关协议(Interior Gateway Protocol,IGP),适用于小型同类网络的一个自治系统(AS)内的路由信息的传递。RIP协议是基于距离矢量...
  • 4. 掌握RIP路由协议 三、实验设备和器材 1.安装了Windows操作系统的计算机 2. DCR-2650: 2台 3. CR-V35MT: 1根 4.CR-V35FC: 1根 5.网线: 6根 6.交换机:2台和PC: 4台 四、IP地址规划 Router--a ...
  • R2只发送给R3 10.10.10.0/24、10.10.11.0/24、10.10.20.0/24的路由条目给R3(使用ACL实现路由条目过滤) R3只接受R2发送的10.10.10.0/24、10.10.20.0/24的路由条目(使用ip-prefix实现路由条目过滤) R1: interface...
  • 实验环境 ...配置RIP路由协议基本功能的实现就是每一个路由都是相通的,电脑能够ping通1.1.1.1(离电脑最远的路由),代表每一个路由都是相通的 如有错误,欢迎指正!(有帮助的话,点个赞哟!) ...
  • rip路由协议简介

    千次阅读 2019-01-08 00:08:53
    RIP 是最早的距离矢量路由协议。尽管 RIP 缺少许多更为高级的路由协议所具备的复杂功能,但其简单性和使用的广泛性使其具有很强的生命力。RIP 不是“即将被淘汰”的协议。实际上,现在已经出现了一种支持 IPv6 ...
  • 本篇对于RIP中的水平分割,毒性逆转,触发更新等机制如何发挥作用讲得很好。 下面内容摘自笔者编著的《网管员必读——网络基础》(第2版)一书。...9.11.1 RIP路由协议及工作原理 RIP...
  • 距离矢量型的路由协议;基于UDP520端口工作;使用跳数作为度量;周期和触发更新均存在;周期更新–30s一次; 支持等开销负载均衡,默认4条,最大6条,IOS版本12.4以上为16条;周期更新----保活、确认的问题 管理距离...
  • RIP路由协议的汇总

    千次阅读 2019-06-23 11:25:38
    RIP路由协议的汇总 当网络中路由器的路由条目非常多时,可以通过路由汇总来减少路由条目数,加快收敛时间和增强网络稳定性。 路由汇总的原理是,同一个自然网段内的不通子网的路由在向外(其他网段)发送时聚合成一...
  • RIP(routing information ...RIP路由协议的配置 配置语法如下 Route(config)#router rip//启用RIP协议 Router(config-router)#network network-address//在指定的接口上启用RIP进程并通告直连路由 (network-addres
  • 实验四 RIP路由的应用与配置

    千次阅读 2020-11-28 21:55:56
    熟悉动态路由协议RIP的配置 [实验要求] 根据拓扑图完成路由器、PC机的基本配置 启用RIP V2版本实现全网的连通 在路由器R1上启用一个loopback虚拟端口 在三台路由器分别显示路由表并截图 在PC1 上分别ping PC2
  • GNS3配置RIP路由协议

    千次阅读 2019-09-09 11:32:12
    RIP(Routing Information Protocol)翻译为路由信息协议,是基于距离矢量算法的路由协议,使用跳数作为计量标准。在带宽、配置和管理方面要求较低,主要适用于较小规模的网络中。 版本:RIPv1、 RIPv2和RIPng,RIPv...
  • 路由协议 RIP 实验

    2019-03-19 18:33:42
    实验二、RIP 实验 实验要求: ...5、 掌握 RIP 配置默认路由的方法 6、 掌握 RIP 认证的基本配置 RIP 实验拓扑 1、 根据实验拓扑,对路由器各接口配置 IP 地址,配置清单如下。(注:每个 IP...
  • RIP动态路由协议的配置命令

    万次阅读 2017-05-21 11:34:00
     RIP路由协议只依据路由器跳数决定最佳路径,不考虑带宽、延时和其他因素。RIP总是把具有最小跳数值的路径作为最优路径。RIP限制最大跳数是15,如果跳数为16,则意味着路径不可达。RIP在路由更新报文中不能携带子网...
  • 本文写了:RIP的配置方法,工作原理,认证
  • 文章目录华为模拟器--动态路由器+RIP路由协议配置及验证前言一、动态路由1.1动态路由协议基础1.1.1动态路由1.1.2动态路由特点1.2动态路由协议概述1.2.1度量值1.2.2收敛1.2.3静态路由与动态路由的比较1.3动态路由协议...
  • 路由器的命令和rip路由协议,静态和动态路由

    千次阅读 多人点赞 2020-07-18 22:47:46
    enable 启用 Router#特权模式:用来查看show路由器的状态 Router#conf t Router(config)#全局模式:对整个路由器功能 Router(config)#interface f0/1 Router(config-if)#ip add 172.16.0.254 255.255.0.0(接口模式) ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,438
精华内容 2,975
关键字:

启用rip路由协议