精华内容
下载资源
问答
  • 生成树协议STP

    2019-04-22 19:37:51
    当广播帧经过交换机时,交换机就会以指数的形式生成广播帧(交换机从除收到该广播帧之外的所有端口转发广播帧)。这种广播帧会越来越多,最后形成广播风暴,导致网络瘫痪。 这种广播风暴只有在物理环路消失时才...

    在企业的网络设计中,一般都会设计具有冗余的拓补结构。因为单一的链路会导致单点故障,提高故障发生的概率。越是大型的网络,对冗余性要求越高。但是,当网络具有冗余性之后,就会产生一些问题,比如:
    1.广播风暴
    生成树协议(STP)
    当广播帧经过交换机时,交换机就会以指数的形式生成广播帧(交换机从除收到该广播帧之外的所有端口转发广播帧)。这种广播帧会越来越多,最后形成广播风暴,导致网络瘫痪。
    这种广播风暴只有在物理环路消失时才可能停止。
    2.多帧复制
    生成树协议(STP)
    指单播的数据帧被多次复制传送到接受端,很多协议都只需要每次传输一个副本。多帧复制会造成接收端收到数据帧的多个副本,不仅浪费接收端的主机资源,而且会导致上层协议在处理这些数据帧时无法选择,严重时还可能导致不可恢复的错误。
    3.MAC地址表紊乱
    生成树协议(STP)
    会导致交换机通过两个接口学到相同的MAC地址,从而导致MAC地址表紊乱,影响数据包的转发。
    虽然冗余链路会存在一些问题,但是环形的物理线路能够为网络提供备份线路,增强网络的可靠性,这在网络设计中是必要的。因此,就需要一种解决方法,一方面能够保证网络的可靠性,另一方面还要解决因为冗余链路所带来的一系列问题。
    STP就是用来解决这个问题的。STP并不是断掉物理环路,而是在逻辑上断开环路,防止冗余链路的一些问题的发生。
    STP(生成树协议)就是把一个环形的结构改变成一个树形的结构。
    STP就是用来将物理上存在环路的网络,通过一种算法,在逻辑上阻塞一些端口来生成一个逻辑上的树形结构。
    生成树协议(STP)
    生成树协议(STP)
    对于三台交换机构成环路的网络,在使用STP后,交换机SW2与SW3连接在链路上的一个端口被逻辑上阻塞,也就是这条线路不能传输数据了,当正常通信的线路发生故障时,被逻辑阻塞的线路将重新被激活,使得数据能从这条线上正常传输数据。
    STP运行STA(生成树算法)的过程很复杂。大致分为三个步骤:
    1.选择根网桥(交换机)
    生成树协议(STP)
    依据:
    1.网桥是唯一的;
    2.选择交换网络中网桥ID最小的交换机作为根网桥。
    生成树协议(STP)
    2.选择根端口
    离根网桥最近的端口(在一个非根网桥上有且只有一个根端口)
    选择根端口的依据:
    1.到根网桥最低的路径成本;
    2.直连的网桥ID最小;
    3.直连的端口ID最小。
    生成树协议(STP)
    网桥到根网桥的路径上所有链路的成本之和
    生成树协议(STP)
    带宽与路径成本的关系
    生成树协议(STP)
    3.选择指定端口
    为了消除环路形成的可能,STP进行最后的计算,在每一个网段上选择一个指定端口,选择指定端口的依据:
    1.根路径成本较低;
    2.所在交换机的网桥ID指较小;
    3.端口ID值较小。
    生成树协议(STP)
    和选择根端口不同,在比较端口ID时,比较的是自身的端口ID值。
    接下来我们简单的来看一下怎么查看生成树的状态
    生成树协议(STP)
    生成树协议(STP)
    根网桥的两个端口都是指定端口,而非根端口!
    交换机之间通过BPDU(桥协议数据单元)来交换网桥ID、根路径成本等信息。
    BPDU包中包括:
    1.根网桥ID;
    2.根路径成本;
    3.发送网桥ID;
    4.端口ID;
    5.及时器;
    根网桥的选择是一个持续的、反复进行的过程,每2s触发一次,检查BPDU的根网桥ID是否发生了变化,网络中是否有网桥ID值更低的交换机加进来。
    STP在交换机中自动运行,在交换机开机的时候可以看到,交换机的指示灯为×××的,并且大约30s的时间不能转发数据,这是交换机在做STP计算。
    生成树的端口状态
    生成树协议(STP)
    (仅供参考)
    生成树计时器
    1.HEIIO时间:IEEE802.1d规定的默认时间为2s;
    2.转发和延迟:默认值各为15s;
    3.最大老化时间:默认值为20s。
    典型的端口过渡:
    1.从阻塞到侦听20s;
    2.从侦听到学习15s;
    3.从学习到转发15s。
    生成树协议(STP)
    (STP计时器的时间可以使用命令进行调整,一般情况不建议修改)
    STP与VLAN的关系:
    IEEE的CST:不考虑vlan,所有vlan公用一个生成树;
    Cisco的PVST:每一个vlan都有一个生成树根;
    Cisco的PVST+:增强每个vlan生成树;
    IEEE的MST:多生成树。
    接下来我们根据一个简单的小拓补实验,来讲解一下如何配置生成树:
    1.Cisco的设备默认已经启用了生成树,(启用生成树的命令)
    生成树协议(STP)
    2.指定根网桥
    生成树协议(STP)
    3.如果在现实环境中,交换机某个接口连接的服务器,我们不可能让它30s之后在进行工作,可以配置速端口,命令
    生成树协议(STP)
    生成树的命令差不多就这些,以后如果用到别的会时时更新的!
    愿我们共同学习,共同进步!

    展开全文
  • 生成树协议STP PVST

    千次阅读 2020-05-31 08:32:41
    在所有交换机上启用PVST生成树模式,并查看此时哪个交换机是树根,有连接线的端口分别是什么模式端口 给交换机设置优先级,S2为4096,S1为8192,其余的为默认值;查看此时哪个交换机为根交换机,所

    网络互连要求:

    1. 规划和设计各路由接口的IP地址,并使用动态路由协议OSPF,进程号每人使用自己的序号
    2. 按照网络拓扑图,配置好三层交换机,创建VLAN,给VLAN配置适当的IP地址,把接口加入相应的VLAN,启用动态路由协议OSPF,使所有VLAN之间的主机能正确路由
    3. 配置所有计算机和服务器的IP地址
    4. 在所有交换机上启用PVST生成树模式,并查看此时哪个交换机是树根,有连接线的端口分别是什么模式端口
    5. 给交换机设置优先级,S2为4096,S1为8192,其余的为默认值;查看此时哪个交换机为根交换机,所有交换机有连接线的端口分别是什么模式端口
    6. 把交换机S2关电,查看此时哪个交换机为根交换机,三个计算机分别走哪些交换机线路到达FTP服务器的
    7. 把交换机S2关电,在交换机S3和S4之间的F0/24相连接;把S3和S2之间的线路带宽设置为10Mbps,看看此时PC1走哪些交换机线路到达FTP服务器的
    8. 把交换机S2恢复供电,在S1的VLAN 2上设置优先级为4096, 在S2的 VLAN 2上设置优先级为8192; 在S1的VLAN 3上设置优先级为8192, 在S2的 VLAN 3上设置优先级为4096;查看此时VLAN 2和VLAN 3的根交换机分别是哪一台

    配置代码:

    S1:
    en
    conf t
    host s1
    no ip domain-lookup
    vlan 2
    exit	
    vlan 3
    exit
    vlan 4
    Exit
    vlan 5
    Exit
    Vlan 6
    exit
    int vlan 2
    ip address 192.168.2.254 255.255.255.0
    int vlan 3
    ip address 192.168.3.254 255.255.255.0
    int vlan 4
    ip address 192.168.4.254 255.255.255.0
    int vlan 5
    ip address 192.168.5.254 255.255.255.0
    int vlan 6
    ip address 192.168.6.254 255.255.255.0
    int f0/1
    switchport access vlan 2
    int f0/2
    switchport access vlan 3
    int f0/3
    switchport access vlan 4
    int f0/4
    switchport mode access
    switchport mode trunk
    int f0/5
    switchport access vlan 6
    int f0/6
    switchport access vlan 5
    ip routing
    Router ospf 22
    Network 192.168.2.0 0.0.0.255 area 0
    Network 192.168.3.0 0.0.0.255 area 0
    Network 192.168.4.0 0.0.0.255 area 0
    Network 192.168.5.0 0.0.0.255 area 0
    Network 192.168.6.0 0.0.0.255 area 0
    spanning-tree mode pvst
    !就是启用基于VLAN的生成树模式,这是思科的独有用法,简单说就是一个VLAN
    !一棵树,在一个网络里,不同的VLAN可以有不同的根桥,不同的阻塞端口等等,其主要目
    !的是为了提高链路利用率(可以想象,如果所有VLAN都是同一棵树,必定有一部分线路
    !处于完全的block状态)
    exit
    show spanning-tree
    
    S2:
    en
    conf t
    host s2
    no ip domain-lookup
    vlan 2
    exit
    vlan 3
    exit
    vlan 4
    Exit
    vlan 5
    Exit
    Vlan 6
    exit
    int vlan 2
    ip address 192.168.2.253 255.255.255.0
    int vlan 3
    ip address 192.168.3.253 255.255.255.0
    int vlan 4
    ip address 192.168.4.253 255.255.255.0
    int vlan 5
    ip address 192.168.5.253 255.255.255.0
    int vlan 6
    ip address 192.168.6.253 255.255.255.0
    int f0/1
    switchport access vlan 2
    int f0/2
    switchport access vlan 3
    int f0/3
    switchport access vlan 4
    int f0/4
    switchport mode access
    switchport mode trunk
    int f0/5
    switchport access vlan 6
    ip routing
    Router ospf 22
    Network 192.168.2.0 0.0.0.255 area 0
    Network 192.168.3.0 0.0.0.255 area 0
    Network 192.168.4.0 0.0.0.255 area 0
    Network 192.168.6.0 0.0.0.255 area 0
    spanning-tree mode pvst
    exit
    show spanning-tree
    
    S3:
    En
    Conf t
    Host s3
    Int range f0/1-3
    Switchport access vlan 2
    exit
    spanning-tree mode pvst
    exit
    show spanning-tree
    
    S4:
    En
    Conf t
    Host s4
    Int range f0/1-3
    Switchport access vlan 3
    exit
    spanning-tree mode pvst
    exit
    show spanning-tree
    
    S5:
    En
    Conf t
    Host s5
    Int range f0/1-3
    Switchport access vlan 4
    exit
    spanning-tree mode pvst
    exit
    show spanning-tree
    
    S6:
    En
    Conf t
    Host s6
    spanning-tree mode pvst
    exit
    show spanning-tree
    
    R1:
    En
    Conf t
    Host r1
    No ip domain-lookup
    Int g0/0
    Ip address 192.168.6.1 255.255.255.0
    No shut
    Int g0/1
    Ip address 202.120.80.2 255.255.255.0
    No shut
    Int loopback 0
    Ip address 1.1.1.1 255.255.255.255
    No shut
    Exit
    Router ospf 22
    Network 192.168.6.0 0.0.0.255 area 0
    Network 202.120.80.0 0.0.0.255 area 0
    
    R2:
    En
    Conf t
    Host r2
    No ip domain-lookup
    Int g0/0
    Ip address 192.168.6.2 255.255.255.0
    No shut
    Int g0/1
    Ip address 202.120.80.3 255.255.255.0
    No shut
    Int loopback 0
    Ip address 2.2.2.2 255.255.255.255
    No shut
    Exit
    Router ospf 22
    Network 192.168.6.0 0.0.0.255 area 0
    Network 202.120.80.0 0.0.0.255 area 0

    配置前4步代码之后:

    注意:如果端口既做了根端口,又做了指定端口,又做了阻塞端口,那对于模拟器而言,就是优先依次显示了即显示为绿色

    S1:

    S2:

    S3:

    S4:

    S5:

    S6:

    疑问解答:

           S1和S6隔着路由器,已经不是一个VLAN了,同一个VLAN的话,要不就线路上都是一个VLAN,要不就是有TRUNK连接,如果被三层以上设备隔离了,就是不同VLAN了,虽然你在自己交换机上是这样叫的,实则不是一个VLAN,因为IP段已经不同了

    完成第4步之后,即配置完成

    S1:spanning-tree vlan 1-6 priority 8192

    S2:spanning-tree vlan 1-6 priority 4096之后

    S1:

    S2:

    S3:

    S4:

    S5:

    S6:

    6:把交换机S2关电,查看此时哪个交换机为根交换机,三个计算机分别走哪些交换机线路到达FTP服务器的;

    Int range f0/1-5

    Shutdown

    之后:

    S1:

    ftp:

    7:把交换机S2关电,在交换机S3和S4之间的F0/24相连接;把S3和S2之间的线路带宽设置为10Mbps,看看此时PC1走哪些交换机线路到达FTP服务器的;

     

    S3修改链路带宽:

    Int f0/2

    speed 10

     

    S3:

    Int f0/24

    Switchport access vlan 2

     

    S4:

    Vlan 2

    Exit

    Int f0/24

    Switchport access vlan 2

    Int f0/2

    Switchport mode trunk

    之后:

    S1:

    S3:

    S4:

    S5:

    PC1->ftp:

    8:把交换机S2恢复供电,在S1的VLAN 2上设置优先级为4096, 在S2的 VLAN 2上设置优先级为8192; 在S1的VLAN 3上设置优先级为8192, 在S2的 VLAN 3上设置优先级为4096;查看此时VLAN 2和VLAN 3的根交换机分别是哪一台

    S2:

    int range f0/1-5

    no shutdown

    S1:

    spanning-tree vlan 2 priority 4096

    spanning-tree vlan 3 priority 8192

    S2:

    spanning-tree vlan 2 priority 8192

    spanning-tree vlan 3 priority 4096

    配置之后:

    S1:

    S2:

    S3:

    S4:

    S5:

    展开全文
  • 生成树协议(英语:Spanning Tree Protocol,STP),是一种工作在OSI网络模型中的第二层(数据链路层)的通信协议,基本应用是防止交换机冗余链路产生的环路.用于确保以太网中无环路的逻辑拓扑结构.从而避免了广播风暴...

    生成树协议(英语:Spanning Tree ProtocolSTP),是一种工作在OSI网络模型中的第二层(数据链路层)的通信协议,基本应用是防止交换机冗余链路产生的环路.用于确保以太网中无环路的逻辑拓扑结构.从而避免了广播风暴,大量占用交换机的资源。

     

    如图所示,把四个交换机连成一个环路,从图中可以发现,Switch3交换机的左端口是橙色的,而其他交换机则是绿色指示灯,表明是正常工作状态。

    这是因为各个交换机都运行着生成树协议,当其中有环路时候,某些交换机会断掉其中一个端口,这样使得整个逻辑环路不存在了(虽然物理上的环路仍然存在)。

    下面,给整个拓扑结构添加两台计算机,如图

     

     添加完后,PC2可以ping通PC,然后,我们把Switch0的右端口和Switch1的左端口都关掉,如下图

     

    我们会发现,Switch3的左端口由橙色变为了绿色, 这是生成树协议的原因。

    交换机的生成树协议是在启动后默认自动运行的,我们可以手动关闭

    输入命令:no spanning-tree vlan 1 表示删除vlan1上面的生成树协议。

    当删除完所有交换机的生成树协议后,那么就会存在环路了。

    结果是会产生广播风暴。

    当存在环路之后,PC2也是PING不通PC1的。

    展开全文
  • 生成树协议STP

    万次阅读 多人点赞 2018-07-04 11:05:48
    4.1.1 实验目的(1)理解生成树协议STP的用途(2)理解生成树协议STP的工作过程(3)掌握根桥、根端口、指定端口的选举规则(4)掌握生成树协议STP中端口角色的变化(5)掌握基本生成树协议的配置4.1.2 实验原理1....

    4.1.1 实验目的

    1)理解生成树协议STP的用途

    2)理解生成树协议STP的工作过程

    3)掌握根桥、根端口、指定端口的选举规则

    4)掌握生成树协议STP中端口角色的变化

    5)掌握基本生成树协议的配置

    4.1.2 实验原理

    1.生成树协议STP

    网络设计通常采用冗余方法提高网络的健壮性、稳定性。常见的冗余方式有:链路冗余和设备冗余。如图4-1所示。该三层结构的网络中,核心层、分布层和接入层均采用了链路冗余。

                       

    不过,对网络中冗余链路会造成网络中的环路,而第二层的网络环路则会带来以下问题: 

    1)广播风暴。

    2)多帧复制。

    3MAC地址表的不稳定。

    为了解决第二层网络环路问题而又要保证网络的稳定和健壮性,引入了链路动态管理的策略。首先通过阻塞某些链路避免环路的产生,当正常工作的链路由于故障断开时,阻塞的链路立刻激活,迅速取代故障链路的位置,保证网络的正常运行。这就是生成树(STP)协议的主要思想。

    2.STP的工作过程

    STP通过协商阻断一些交换机端口,以确保网络中所有目的地之间只有一条逻辑路径,构建一棵没有环路的转发树。当一个端口阻止流量进入或离开时,该端口便视为处于阻塞状态。不过 STP 用来防止环路的网桥协议数据单元 (BPDU) 帧仍可继续通行。为了在网络中形成一个没有环路的拓扑,交换机要进行以下3个步骤:

    1)选举根桥。

    2)每个非根桥交换机计算到达根桥的最短路径。

    3)选择活动端口以及端口的角色类型。

    STP端口类型一共有3种,如表4-1所示种:

    4-1  STP端口类型

    端口类型

    功能说明

    根端口(root port)

    存在于非根桥上,指到达根桥路径开销最小的端口,每个交换机只能有一个。

    指定端口(designated port)

    负责发送网段BPDU的端口,每个物理网段只能有一个。

    非指定端口(non-designated )

    被阻塞的端口,不能转发数据帧

      STP的根桥和根端口选择过程中,哪个交换机能获胜将取决于以下因素(按顺序进行):

    最低的根桥ID,也叫BID;

    l 最低的根路径代价;

    最低发送者桥ID;

    最低发送者端口ID。

       下面举例说明了生成树的工作过程:

                  

    ①选举根桥:每个交换机都具有一个唯一的桥ID(BID, Bridge ID),这个ID由两部分组成,如下图所示:

                     

    网桥优先级是一个2字节的数,交换机的默认优先级为32768 ;MAC地址就是交换机的MAC地址。具有最低桥ID的交换机就是根桥。

    BID的信息被封装在BPDU中,每个交换机广播接收到的BPDU和发送自身的BPDU,通过BPDU泛洪,可以获知BID最小的交换机,该交换机即被选为根桥。例如在图4-2中,三台交换机的优先级(Priority)相同,SwitchA MAC地址最小,所以SwitchABID最小,被选举为根网桥。

    选取根端口:选举了根桥后,其他的交换就成为了非根桥。根桥上的接口都是指定端口,会转发数据包。每台非根桥要选举一条到根桥的根路径。STP使用路径代价Cost值来决定到达根桥的最佳路径(Cost是累加的,带宽大的链路Cost低),最低Cost值的路径就是根路径,该端口就是根端口;如果Cost一样,就根据选举顺序选举根口。根口转发数据包。生成树链路开销代价如表4-2所示。

    4-2 生成树链路开销代价表

    链路带宽

    旧标准

    新标准

    10Mbps

    100

    100

    100Mbps

    10

    19

    1Gbps

    1

    4

    10Gps

    1

    2

    >10Gbps

    1

    1

                   

    在图4-3中,各个非根网桥中的端口中,到根网桥路径开销最小的端口被指定为根端口,在图中,Switch B和C 的两个端口F0/1、F0/2的开销分别为19和38,所以F0/1被选定为根端口。

    选举指定端口和非指定端口:当交换机确定了根端口后,还必须将剩余端口配置为指定端口 (DP) 或非指定端口(非 DP),以完成逻辑无环生成树。交换网络中的每个网段只能有一个指定端口。当两个非根端口的交换机端口连接到同一个 LAN 网段时,会发生竞争端口角色的情况。这两台交换机会交换 BPDU 帧,以确定哪个交换机端口是指定端口,哪一个是非指定端口。一般而言,交换机端口是否配置为指定端口由 BID 决定。所以在网段2所连接的2个端口,Switch B的BID值小于Switch C的BID值,所以 Switch B的F0/2为指定端口,处于转发状态。Switch C的F0/2为非指定端口,处于阻塞状态。

    3.STP的收敛过程

    当网络的拓扑发生变化时,网络会从一个状态向另一个状态过渡,重新打开或阻断某些端口口。交换机的端口状态状态变换和时间如下图:

                            

    从上图可以看出STP的最长收敛时间为50s。

    当网络的拓扑发生变化时,网络会从一个状态向另一个状态过渡,重新打开或阻断某些端口。交换机的端口要经过几种状态:禁用(Disable)——>阻塞(Blocking)——>监听状态(Listenning)——>学习状态(Learning)——>转发状态(Forwarding)。每种端口状态对数据的处理如表4-2所示。

    4-3 生成树端口状态对数据的转发

    过程

    阻塞

    侦听

    学习

    转发

    禁用

    接收并处理BPDU

    不能

    转发接口上收到的数据

    不能

    不能

    不能

    不能

    转发其它接口发来的数据帧

    不能

    不能

    不能

    不能

    学习MAC地址

    不能

    不能

    不能

    4.STP的配置命令

    4-4 STP常用配置命令

    相关命令

    功能

    S1#show spanning-tree

    查看交换机生成树协议的配置情况

    S1(config)# spanning-tree  mode  pvst/rapid-pvst

    配置生成树的模式为STP或是RSTP

    S1(config)# spanning-tree vlan 1  priority   <0-61440>

    配置交换机在VLAN 1中的优先级(优先级为4096倍数),范围为0-61440

    S1(config)#spanning-tree vlan 1 root primary 

    将交换机配置为VLAN1中的根桥

    S1(config)#spanning-tree vlan 1 root secondary

    将交换机配置为VLAN1中的次根桥

    S1(config-if) # interface  fa0

    S1(config-if) # spanning-tree vlan  1  cost 18

    fa0端口在VLAN1生成树的路径开销修改为18

    S1(config-if) # interface  fa0

    S1(config-if) # spanning-tree vlan  1  port-priority 16

    fa0端口在VLAN1生成树的端口优先级修改为16,端口优先级为16的倍数,从0~240

    S1#show spanning-tree  interface  fastethernet 0/1   

    查看端口状态

    S1# show spanning-tree vlan vlan-id

    查看某个VLAN下的STP配置信息

    5.STP配置实例

                   

    实验背景思科的交换机默认启用STP生成树协议,所以不需要做任何配置,接通电源后,交换机自动协商成功。

        实验要求:要求配置STP,确保S1为网络中交换机的根桥,S2为网络中交换机的备用根桥,将和PC1连接端口配置为Portfast端口。

    步骤1:观察自动STP的根桥选举情况。(无须做任何配置)

    观察S1的生成树情况。

    S1#show spanning-tree  
    VLAN0001
      Spanning tree enabled protocol ieee
     //根桥的信息
      Root ID    Priority    32769      // 根桥的优先级
                 Address     0001.4240.48C4  // 根桥的MAC地址,可知S3为根桥
                 Cost        19   //  本交换机到根桥路径开销为19             
                 Port        1(FastEthernet0/1)  // 本交换机根端口为F0/1
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
      //本交换机的信息
      // 优先级 = 32768(默认优先级) +  1(VLAN 1的序号)
      Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1) 
                 Address     0001.43E9.8859  //本交换机MAC地址
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time  20


    Interface        Role Sts Cost           Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa0/1            Root FWD 19(根端口)      128.1    P2p     
    Fa0/2            Desg FWD 19(指定端口)    128.2    P2p
    Fa0/3            Desg FWD 19              128.3    P2p
    ②观察S2的生成树情况。
    S2#show spanning-tree 
    VLAN0001
      Spanning tree enabled protocol ieee
      Root ID    Priority    32769        //根桥优先级
                 Address     0001.4240.48C4  //根桥MAC地址
                 Cost        19 //  本交换机到根桥路径开销为19
                Port        1(FastEthernet0/1)  // 本交换机根端口为F0/1
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
    //本交换机的信息
      Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1) //优先级
                 Address     00E0.F980.4970   // MAC地址
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time  20


    Interface        Role Sts Cost                   Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa0/1            Root FWD 19(根端口)         128.1    P2p
    Fa0/2            Altn BLK 19(阻塞端口)        128.2    P2p
    注意:S3的F0/2端口和S1的F0/2端口竞争指定端口时失败,端口被阻塞,不转发报文。
    ③观察S3的生成树情况。
    S3#show spanning-tree 
    VLAN0001
      Spanning tree enabled protocol ieee
      Root ID    Priority    32769  // 根桥优先级
                 Address     0001.4240.48C4 //根桥MAC地址
                 This bridge is the root   // 本交换机为根桥
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
      //观察可以得知自身MAC地址和根桥MAC地址相同,即本交换机为根桥。
      Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
                 Address     0001.4240.48C4
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time  20


    Interface        Role Sts Cost                 Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa0/1            Desg FWD 19(指定端口)         128.1    P2p
    Fa0/2            Desg FWD 19 (指定端口)        128.2    P2p
    Fa0/3            Desg FWD 19(指定端口)         128.3    P2p
    步骤2:要让S1成为根桥,S2成为备份根桥,需要修改S1和S2的优先级,将其优先级降低,提高其在选举根桥中的地位。
    S1(config)#spanning-tree vlan 1 root primary  // 成为根桥
    S1(config)#interface f0/3
    S1(config-if)#spanning-tree portfast   //配置F0/3端口为portfast接口
    S2(config)#spanning-tree vlan 1 root secondary  // 成为备用根桥
    S1(config)#interface f0/3
    S1(config-if)#spanning-tree portfast  // 配置f0/3端口为portfast接口


    步骤3:结果与测试。
      查看S1的生成树情况。
    S1#sh spanning-tree  
    VLAN0001
      Spanning tree enabled protocol ieee
      Root ID    Priority    24577  // 已经发生改变,优先级降低
                 Address     0001.43E9.8859
                 This bridge is the root   // S1已经成为根桥
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
    … 省略部分无关内容
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa0/1            Desg FWD 19        128.1    P2p
    Fa0/2            Desg FWD 19        128.2    P2p
    Fa0/3            Desg FWD 19        128.3    P2p
    注意:所有的端口都变成了指定端口。
    查看S2的生成树情况。
    S2#sh spanning-tree 
    VLAN0001
      Spanning tree enabled protocol ieee
      Root ID    Priority    24577   
                 Address     0001.43E9.8859
                 Cost        19
                 Port        2(FastEthernet0/2) //根端口已经发生变化
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
     //S2的生成树信息
      Bridge ID  Priority    28673  (priority 28672 sys-id-ext 1) // 优先级降低,但比S1优  
                                                        先级要高
                 Address     00E0.F980.4970
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time  20
    … 省略部分无关内容
     从结果看到,我们通过改变交换机的优先级,让网络的根桥选举发生了变化,S1成为根桥,S2成为备用根桥,当S1发生故障时,S2将会取代S1成为网络中的根桥。
    展开全文
  • 在所有交换机上启用PVST生成树模式,并查看此时哪个交换机是树根,有连接线的端口分别是什么模式端口 给交换机设置优先级,S1为4096,S2为8192,其余的为默认值;查看此时哪个交换机为根交换机,所有交换机有连接...
  • 生成树协议1 STP生成树协议2 网桥ID 根端口的选择 路径成本3 BPDU(桥协议数据单元)4 生成树计时器5 VLAN与STP关系6 MSTP(多生成树协议)配置 1 STP生成树协议 STP-Spanning Tree Protocol(生成树协议) 逻辑上...
  • STP生成树协议)配置教程

    万次阅读 多人点赞 2019-12-29 21:05:08
    作用:防止交换环路 原理:通过允许STP算法,阻塞特定的接口实现冗余无环的网络 [SW3]dis stp brief //查看STP状态 MSTID Port Role STP State Protection 0 GigabitEthernet0/0/1 ROOT FORWARDING NO...
  • stp生成树协议的简单总结

    千次阅读 2021-01-16 18:49:42
    生成树协议STP)是一种为了解决企业网三层架构,二层桥接环路的类似于广播风暴的一系列问题的一种算法;而生成树是一种结构,是在一个二层交换网络中,生成一棵树型结构,逻辑的阻塞部分接口,使得从根到所有的...
  • 生成树协议STP

    2021-03-15 14:07:00
    生成树协议STP一. 生成树协议STP原理二. 生成树算法分为三个步骤三. 桥协议数据单位(BPDU) 一. 生成树协议STP原理 1. 广播风暴的形成 2. 多帧复制 3. MAC地址紊乱 二. 生成树算法分为三个步骤 1. 选择根网桥: ...
  • 交换机生成树协议STP

    千次阅读 2020-07-29 20:04:22
    STP STP:生成协议(Spanning-tree-...生成树协议(spanning-tree-protocol,stp),就是在具有物理环路的交换机网络上生成没有回路的逻辑网络的方法,生成树协议使用生成树算法,在一个具有冗余路径的容错网络中
  • 生成树协议STP)常用配置命令及原理STP简介:逻辑上断开环路,防止广播风暴的产生当线路故障,阻塞接口被激活,恢复通信,起备份线路的作用 生成树算法3个步骤:(1)选择根网桥(Root Bridge)(2)选择根端口...
  • 交换机生成树协议STP的配置命令

    万次阅读 2017-05-20 17:52:54
    》打开或关闭STP Catalyst 3548(Csico IOS系统) 命令格式:spanning-treevlan //启用STP  nospanning-tree vlan // 关闭STP  Switch-PHY-3548(config
  • **STP相关概念端口角色:端口状态:**STP的选举过程:**根桥的选举:指定端口的选举:BPDU 圆桥协议数据单元**BPDU的功能**BPDU报文的两种类型:设置成根网桥两种方法RSTF:快速生成树协议MSTP:多实例生成树STP配置...
  • STP生成树协议详解

    2021-04-25 10:23:53
    STP1.1 背景1.2 STP生成树协议)802.1d1.2.1 生成树形结构的过程1.2.1.1 生成树树形结构形成过程:1.2.1.2 根桥的选举规则1.2.1.3 端口角色选举规则1.2.1.4 临时环路1.2.2 端口状态1.2.2.1 STP的标准接口状态:...
  • 生成树协议STP使用哪两个参数来选举根网桥 ____________。 A.网桥优先级和IP地址 B.链路速率和IP地址 C.链路速率和MAC地址 D.网桥优先级和MAC地址 正确答案 D 答案解析 解析:该协议可应用于在网络中建立树形...
  • H3CNE-生成树协议STP

    千次阅读 2018-02-27 10:35:37
    交换机上开启STP协议stp协议通过stp计算,阻塞某些端口,计算出一个无环路的2层转发路径,简称stp被阻塞的端口下的链路,称为备份链路。没有阻塞的端口下的链路,称为主链路。v7 目前h3c交换机的stp模式有4种:...
  • 根交换机选举 STP 使用生成树算法 (STA) 计算网络中的哪些交换机端口应配置为阻塞才能防止环路形成。STA 会将一台交换机指定为根桥,然后将其用作所有路径计算的参考点。 所有参与 STP 的交换机互相交换 BPDU 帧,以...
  • stp生成树协议STP(Spanning Tree Protocol),主要作用是防止网桥网络中的冗余链路形成环路工作 实验组网图 配置步骤 1.两台pc设置好地址 pc3 10.0.0.1/24 pc4 10.0.0.2/24 2.查看两台pc是否可达 状态应为可达 3....
  • 生成树协议STP的简单了解一、生成树协议的产生原因1.1交换网络环路的产生1.2 多帧复制1.3 MAC地址紊乱二、生成树协议STP2.1 STP(Spanning Tree Protocol)2.2 生成树算法2.2.1 根网桥的选择2.2.2 根端口的选择 ...
  • 生成树协议(STP)

    2021-03-15 14:43:48
    生成树协议(STP)概述1.交换网络环路的产生2.生成树协议(STP)二.STP的工作原理1.生成树算法及验证2.BPDU(桥协议数据单元)3.交换机端口的STP状态三.Mstp(多生成树协议) 一.生成树协议(STP)概述 1.交换网络环路的产生...
  • 深入解析生成树协议STP

    千次阅读 2021-11-10 20:02:12
    深入解析生成树协议 目录深入解析生成树协议STP...启用STP的原因:二层网络冗余会使网络产生环路,而环路会使数据在成环设备上无止境的转发下去,最终导致网络瘫痪,而生成树协议可以有效地识别并阻止二层环路。 ...
  • STP生成树的应用一、拓扑图 1、拓扑图 2、要求二、配置接入层交换机 1、配置Trunk 2、接口划分VLAN三、核心交换机配置 1、配置Trunk 2、VTP创建VLAN 3、HSRP备份 4、DHCP中继 5、三层交换机路由设置四、...
  • 网络配置4:STP生成树协议配置

    千次阅读 2018-07-15 10:17:36
     交换机默认启用STP生成树协议,当形成环路时,交换机会堵塞一个端口(block状态),我们可以通过相应的命令来改变block状态的端口。更改堵塞的端口实验拓扑:(将设备连接之后自动创建的STP生成树)Switch&gt;...
  • 生成树协议,用于解决二层交换网络环路的协议,在二层交换网络一旦出现环路就会造成报文在环路中不断循环和增生,进而产生广播风暴(详情看下面实验),随后在它的基础上又出现了RSTP(快速生成树协议、PVST(每个...
  • STP 生成树协议 RSTP 快速生成树

    千次阅读 2017-10-10 21:53:24
    STP(Spanning Tree Protocol)是生成树协议的英文缩写  该协议可应用于在网络中建立树形拓扑,消除网络中的环路,并且可以通过一定的方法实现路径冗余,但不是一定可以实现路径冗余。生成树协议适合所有厂商的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,279
精华内容 1,311
关键字:

启用生成树协议stp