精华内容
下载资源
问答
  • go-lang安装
    2018-12-12 11:42:36

    本博客欢迎转发,但请保留原作者信息!
    博客地址:http://blog.csdn.net/kingsuper_
    内容系本人学习、研究和总结,如有雷同,实属荣幸!

    这里以安装go-lang1.4为例:

     

    1.首先下载go-lang 1.4的软件包

    2.解压到/usr/local目录

    tar -xzf go1.4.linux-amd64.tar.gz –C /usr/local

    3. 配置环境变量:

    sudo vim /etc/profile 
    #并添加下面的内容:
    GOPATH="/YOUR/USER/HOME/go"
    GOROOT="/usr/local/go"
    PATH=$GOROOT/bin:$PATH

    4.验证安装:

     

    root@SIA1000075019:/usr/local# go version
    go version go1.4 linux/amd64

     

    更多相关内容
  • 文渊阁-wenyan-lang的软件包管理 (wenyan-get,或文渊阁)是wenyan-lang的套件管理员。 就像Node.js的或Python的一样。 安装 npm i -g @wenyan/wyg 用法示例 wyg i ziyue 中文名称也可以接受 wyg i 子曰 上面的...
  • 您可以使用摘要快速编写Wenyan: 以下是一些常见的摘要。 有关完整列表,请签出。 扳机 片段 if 若⋯者。⋯也。 else 若非。⋯也。 for 為是⋯遍。⋯云云。 break 乃止。 while 恆為是。⋯云云。 function 吾...
  • wenyan-lang_jvm You can run WenYan Programming Language in JVM. 贡献您的标准库 找到在这里贡献标准库 在添加 final Map< Language , Map< String , String > > libs = [ ( Language . GROOVY ) : [ "算經...
  • simplified-dialect-wy-vscode:简化的方言wenyan-lang的vscode插件
  • 文言 wenyan-lang wy-lang.org | Wiki | The Book English | 简体中文 | 繁體中文 文言文編程語言。A programming language for the ancient Chinese. Try it online. CHANGELOG 序 夫唐、虞之世,結繩而足...
  • 官方网站 编程介绍 该语言是由github上一位名为【LingDong-】创制并发布分享出来的,项目地址是 https://github.com/LingDong-/wenyan-lang/。 夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械...

    站长寄语

    站长接触过易语言,是用简体中文来编程的语言,已经够奇葩的了,这次在github上遇到一个更奇葩的,竟然是用文言文打造的编程,文言文编程,文言文懂得把,之乎者也,而且更厉害得是图灵竟然完备,接下来咱们感受一下,分享给大家,于是就有了今天这篇文章。

    官方网站

    编程介绍

    该语言是由github上一位名为【LingDong-】创制并发布分享出来的,项目地址是 https://github.com/LingDong-/wenyan-lang/。

    夫唐、虞之世,結繩而足治,屈指而足算。是時豈料百代之後,計算機械之巧,精於公輸之木鳶,善於武侯之流馬;程式語言之多,繁若《天官》之星宿,奇勝《山經》之走獸。鼠、蟹、鑽、魚,或以速稱。蛇、象、駱、犀,各爭文采。方知鬼之所以夜哭,天之所以雨粟。然以文言編程者 ,似所未有。此誠非文脈之所以傳,文心之所以保。嗟予小子,遂有斯志。然則數寸之烏絲猶覆於頭,萬卷之素書未破於手;一身長羁于远邦,兩耳久旷于雅言。然夫文章者吾之所宿好,程式者偶承時人之謬譽。故希孟不慚年少,莊生不望無涯。乃作斯言。誠未能嘔瀝長吉之心血,亦庶幾免於義山之流沫。既成之後,復學干將鑄劍而自飼,越王嚐糞而當先。自謂偶追《十書》之筆意,但恨少八家之淋漓。此子山所謂士衡抚掌而甘心,平子見陋而固宜。然則雖實覆甕之質,尚存斧正之望;雖乏呂相之金,易字之渴蓋同。此亦開源之大義,吾輩之所以勉勵也。一笑。

    编程特点符合古汉语的语法

    可以编译成 JavaScript 或者 Python

    图灵完备

    在线 IDE,即刻体验

    通过 几个例子快速入门

    举个例子Hello World吾有一數。曰三。名之曰「甲」。

    為是「甲」遍。

    吾有一言。曰「「問天地好在。」」。書之。

    云云。

    输出問天地好在。

    問天地好在。

    問天地好在。

    怎么样,想不想试一试?

    更多内容可以扫描下方二维码,点击关注,或者打开浏览器来访。Luckydesigner​www.luckydesigner.space

    展开全文
  • 文言wenyan-lang | | 英文|| 文言文编程语言。一种用于古代汉语的编程语言。 序 夫,之世,,屈指而足算是时岂料百代之后,计算机械之巧,精于。之,善于之;程式语言之多,繁若之星宿,奇胜之走兽。,,,,或以速...
  • 在需要加密的Excel 表中,点击[工具]→[宏]→[Visual Basic编辑器],打开“工程资源管理器”,双击该工作表,在右边的是设置该表属性的编辑窗口,单击该窗口左上方的下拉列表框,选择Worksheet,再从该窗口右上方的...
  • 文言 wenyan-lang wy-lang.org | Wiki | The Book English | 简体中文 | 繁體中文 文言文編程語言。A programming language for the ancient Chinese. Try it online. CHANGELOG 序 夫唐、虞之世,結繩而足...
  • 而是一款由卡内基梅隆大学一名大四学生打造的文言文编程语言:文言(wenyan-lang)。 简介 该语言完全不使用英文字符,只包含繁体中文字符以及繁体的引号「」。 所以,它的Hello World画风是这样的: 这段文言...

           最近有个编程语言火了,不是C/C++,不是Java、也不是世界上最好的语言。而是一款由卡内基梅隆大学一名大四学生打造的文言文编程语言:文言(wenyan-lang)

    简介

    该语言完全不使用英文字符,只包含繁体中文字符以及繁体的引号「」。

    所以,它的Hello World 画风是这样的:

    这段文言文代码的意思是啥?看看等效的代码:

    这两个不同语言的代码最终都会实现如下输出内容:

    语言介绍

    是不是很就没读文言文,已经看不懂了?

    下面这些语法定义有没有让你想起学生时代的小学妹?

    变量

    控制

    运算

    容器

    数组从 1 开始索引。

    函数

    这也太有才了吧!你的看法呢?

           我是一名从事了10年开发在退休边缘垂死挣扎的高龄程序员,最近我花了一些时间整理了一个完整的学习C语言、C++的路线,项目源码和工具。对于想学习C/C++的小伙伴而言,学习的氛围和志同道合的伙伴很重要,笔者推荐我主页的C语言/C++编程爱好者的聚集地!

           欢迎初学和进阶中的小伙伴。希望你也能凭自己的努力,成为下一个优秀的程序员。工作需要、感兴趣、为了入行、转行需要学习C/C++的伙伴可以一起学习!”           

    关注我,带你遨游代码世界!

    展开全文
  • 考试中考总分120分。其中古代诗歌默写6分,文言文阅读11分,古诗鉴赏4分。总共21分。...简介这是一款由卡内基梅隆大学一名大四学生(作者名叫 Huang Lingdong)打造的文言文编程语言:文言(wenyan-...

    20200506164743148f7sclnfnbli4f7k_2.jpg

    考试

    中考总分120分。其中古代诗歌默写6分,文言文阅读11分,古诗鉴赏4分。总共21分。

    古代文学占17.5%

    高考总分150分。文言阅读9分,翻译10分,古诗词鉴赏8分,古诗文默写5分。总共32分。

    古代文学占21.3%

    可见文言文是十分重要的。

    然而。。。你想过用文言文编程吗???

    简介

    这是一款由卡内基梅隆大学一名大四学生(作者名叫 Huang Lingdong)打造的文言文编程语言:文言(wenyan-lang)。

    虽然不是最好的语言,但展现了中华民族传统文化的博大精深。

    该语言完全不使用英文字符,只包含繁体中文字符以及繁体的引号「」。

    例如:这是他的Hello Word

    吾有一數。曰三。名之曰「甲」。

    為是「甲」遍。

    吾有一言。曰「「問天地好在。」」。書之。

    云云

    编译为Javascript

    var n = 3;

    for (var i = 0; i < n; i++) {

    console.log("問天地好在。");

    }

    编译为Python

    a=3

    for _rand1 in range(a):

    _ans1="問天地好在。"

    print(_ans1);

    编译为Ruby

    a=3

    a.times do |_rand1|

    _ans1="問天地好在。"

    p([_ans1].join)

    end

    自译为c/c++

    int n = 3;

    for (int i=0;i

    printf("問天地好在。");

    }

    运行:

    問天地好在。問天地好在。問天地好在。

    wenyan目前可编译为JavaScript,Python或Ruby,并且将来会支持更多语言(例如C)。

    本篇文章的c/c++翻译,全为作者个人自译。

    基本语法

    变量

    文言(wenyan)

    Javascript

    c/c++

    吾有一數。曰三。名之曰「甲」。

    var a = 3;

    int a = 3;

    有數五十。名之曰「大衍」。

    var dayan = 50;

    int dayan = 50;

    昔之「甲」者。今「大衍」是矣。

    a = dayan;

    a = dayan;

    吾有一言。曰「「噫吁戲」」。名之曰「乙」。

    var b = "alas!";

    string b = "alas!";

    吾有一爻。曰陰。名之曰「丙」。

    var c = false;

    bool c = false;

    吾有一列。名之曰「丁」。

    var d = [];

    vector d;

    吾有三數。曰一。曰三。曰五。名之曰「甲」曰「乙」曰「丙」。

    var a=1,b=3,c=5;

    int a=1,b=3,c=5;

    顺序控制

    文言(wenyan)

    Javascript

    c/c++

    若三大於二者。乃得「「想當然耳」」也。

    if (3>2)

    { return "of course"; }

    if (3>2)

    {return"ofcourse";}

    若三不大於五者。乃得「「想當然耳」」。若非。乃得「「怪哉」」也。

    if(3<=5){return "of course"}else{return "no way"}

    if(3<=5){return "of course"}else{return "no way"}

    為是百遍。⋯⋯ 云云。

    for (var i = 0; i < 100; i++){ ... }

    for (int i = 0; i < 100; i++){ ... }

    恆為是。⋯⋯ 云云。

    while (true) { ... }

    while (true) { ... }

    凡「天地」中之「人」。⋯⋯ 云云。

    for (var human of world){ ... }

    for (int human : world){ ... }

    乃止。

    break;

    break;

    数学

    文言(wenyan)

    Javascript

    c/c++

    加一以二。

    1+2

    1+2

    加一於二。

    2+1

    2+1

    加一以二。乘其以三。

    (1+2)*3

    (1+2)*3

    除十以三。所餘幾何。

    10%3

    10%3

    減七百五十六以四百三十三。名之曰「甲」。

    var a = 756-433;

    int a = 756-433;

    夫「甲」「乙」中有陽乎。

    a || b

    a || b

    夫「甲」「乙」中無陰乎。

    a && b

    a && b

    Objects

    文言(wenyan)

    Javascript

    c/c++

    吾有一物。名之曰「甲」。

    var a = {};

    struct node {} a;

    吾有一物。名之曰「甲」。其物如是。物之「「乙」」者。數曰三。物之「「丙」」者。言曰「「丁」」。是謂「甲」之物也。

    var a = {b:3, c:"d"}

    struct node  {int b=3;char c="d";}a;

    函数

    文言(wenyan)

    Javascript

    c/c++

    吾有一術。名之曰「吸星大法」。是術曰。⋯⋯是謂「吸星大法」之術也。

    function f(){...}

    void xixingdafa () {...}

    吾有一術。名之曰「六脈神劍」。欲行是術。必先得六數。曰「甲」。曰「乙」。曰「丙」。曰「丁」。曰「戊」。曰「己」乃行是術曰。⋯⋯是謂「六脈神劍」之術也。

    function f(a,b,c,d,e,f){...}

    void liupaishengjian (int a,int b,int c,int d,int e,int f) {...}

    吾有一術。名之曰「翻倍」。欲行是術。必先得一數。曰「甲」。乃行是術曰。乘「甲」以二。名之曰「乙」。乃得「乙」。是謂「翻倍」之術也。

    function double(a){var b = a * 2; return b;}

    viod Double(int a){int b = a * 2; return b;}

    施「翻倍」於「大衍」。

    double(dayan);

    Double(dayan);

    吾有一術。名之曰「甲」。欲行是術。必先得一數曰「乙」。二言。曰「丙」。曰「丁」

    function a(float b, string c, string d)

    void a(int b, string c, string d);

    夫「甲」。夫「乙」。夫「丙」。取二以施「丁」。取二以施「戊」。名之曰「己」。

    var f = e(a,d(b,c))

    int f = e(a,d(b,c))

    夫「甲」。夫「乙」。夫「丙」。取二以施「丁」。取二以施「戊」。取一以施「己」。夫「庚」。夫「辛」。取三以施「壬」。名之曰「癸」。

    var j = i(f(e(a,d(b,c))),g,h)

    int j = i(f(e(a,d(b,c))),g,h)

    乃得四十九

    return 49;

    return 49;

    減五十以一。乃得矣

    return 50-1;

    return 50-1;

    乃歸空無

    return;

    return;

    注释

    文言(wenyan)

    Javascript

    c/c++

    批曰。「「文氣淋灕。字句切實」」。

    /*文氣淋灕。字句切實*/

    /*文氣淋灕。字句切實*/

    注曰。「「文言備矣」」。

    /*文言備矣*/

    /*文言備矣*/

    疏曰。「「居第一之位故稱初。以其陽爻故稱九」」。

    /*居第一之位故稱初。以其陽爻故稱九*/

    /*居第一之位故稱初。以其陽爻故稱九*/

    代码欣赏

    20200506164743148f7sclnfnbli4f7k_0.png

    20200506164743148f7sclnfnbli4f7k_1.png

    我自己的评价

    网上的一些评价也是参差不齐,我认为作者(Huang Lingdong),做这个项目其实只是一个期末作业亦或业余爱好。把这个当一件有趣的事罢了。并不希望成为主流或十分强大的语言。

    我认为,作者既然没说这是一个多么认真、能用于生产环境的正式项目。而从这玩笑中寻找意义和用途,才是没意义的是。

    因为文言语言可以解释成各种语言。他可做的是还是较多的。(其中洛谷题库支持文言语言是一个很好的例子。)

    这是A+B problem 的文言:

    施「require('fs').readFileSync」於「「/dev/stdin」」。名之曰「數據」。

    施「(buf => buf.toString().trim())」於「數據」。昔之「數據」者。今其是矣。

    施「(s => s.split(' '))」於「數據」。昔之「數據」者。今其是矣。

    注曰。「「文言尚菜,無對象之操作,故需 JavaScript 之语法」」。

    夫「數據」之一。取一以施「parseInt」。名之曰「甲」。

    夫「數據」之二。取一以施「parseInt」。名之曰「乙」。

    加「甲」以「乙」。書之。

    抱歉,我自己看文言代码是看不了的。我也不希望上面的一些有识之士把文言语言作为NOI信息竞赛或计算机专业的必学语言。(除非想复辟繁体字)

    Esolang

    Esoteric programming language,简称 Esolang,它们的设计被用于测试计算机语言设计的极限,作为一个概念的证明,或仅仅是一个玩笑。Esolang 创作者通常并不打算让它成为主流编程语言,他们几乎不会在意语言的可用性,甚至恰恰相反,会故意增加使用难度。(我介绍这个你们自己品)

    比如 Brainfuck,它是在 1993 年被创造的编程语言,语法仅包含八种符号,没有任何单词,用它打印 Hello world 是这样的:

    ++++++++++[>+++++++>++++++++++>+++>+<<<

    >++.>+.+++++++..+++.>++.<

    >.+++.------.--------.>+.>.

    再比如 MarioLANG,它同样只能使用符号,需要使用形似马里奥关卡的语法来书写:

    ++++: > > +:+:+:+:+:+:+:::::

    ====+ >^=== """=================

    +:-):(:^= = !

    ========= = #

    = ! .+.,:-<

    =### ======"

    Parenthesis Hell,言如其名,括号地狱,只能使用括号来书写:

    (()()(()()(()()()()((()()(()(()((()((()()()((()((()()()((()((((()()(()(

    )()()()()(((()(((()((()((((()(((()()(()()((()((()()()((()()(()()()()(()

    ()()()(()()()()(()(())))))))))))))))))))))))))))))))))))))))))))))))))

    传送门

    在线编辑器:http://wenyan-lang.lingdong.works/ide.html

    下载编译器:https://github.com/LingDong-/wenyan-lang#installation

    开源代码:https://github.com/LingDong-/wenyan-lang

    -----------------------------END--------------------------------

    展开全文
  • 大四学生发明文言文编程语言,设计思路清奇

    万次阅读 多人点赞 2019-12-18 15:02:49
    整理 | 夕颜出品 | AI科技大本营(ID:rgznai100)【导读】近日,GitHub 上一个叫做文言文(wenyan)的编程语言项目火了,就在本文成文期间,Git...
  • 现在它支持将wenyan lang转换成JavaScript和Python: ./build/wenyan.js examples/helloworld.wy -o helloworld.js 在这段命令中,如果不指定语言,程序将自动转化为JavaScript,若想转化成Python,请加入参数“—...
  • 整理 | 夕颜出品 | AI科技大本营(ID:rgznai100)【导读】近日,GitHub 上一个叫做文言文(wenyan)的编程语言项目火了,就在本文成文期间,GitHub 上的 Star 数已经从 2200 涨到 2800,并还有继续上涨的趋势。...
  • 图灵完备(https://github.com/LingDong-/wenyan-lang/blob/master/examples/turing.wy 在可计算性理论里,如果一系列操作数据的规则(如指令集、编程语言、细胞自动机)可以用来模拟单带图灵机,那么它是图灵完备的...
  • 整理 | 夕颜【导读】近日,GitHub 上一个叫做文言文(wenyan)的编程语言项目火了,就在本文成文期间,GitHub 上的 Star 数已经从 2200 涨到 2800,并还有继...
  • “ 阅读本文大概需要 8 分钟。 ” 【导读】近日,GitHub 上一个叫做文言文(wenyan)的编程语言项目火了。只需要在在线编辑器上,或下载一个编译器,就可以用文言文进...
  • http://wenyan-lang.lingdong.works/ide.html 你以为这就够了么?当然不, 作者还做了个图灵机demo: 相关语法表 下面,我们在来看看相关的语法表,比如他是如何定义一个变量的: 还有一些运算是如何定义的呢? 如下...
  • 文言文编程火了,可我完全学不懂

    万次阅读 多人点赞 2019-12-21 18:09:28
    毕竟有易语言在前,有人认为...最近有个 GitHub 项目火了 —— 文言编程语言 / wenyan-lang。 现在这个项目已经超过 10K Stars 了(昨天看还是 9K,一夜涨了 1K),咱赶紧来研究下。 学语言嘛,当然先从 “Hello wo...
  • 大四学生发明文言文编程语言最近有个 GitHub 项目火了 —— 文言文编程语言 / wenyan-lang。文言文编程语言的作者名叫Huang Lingdong,是卡内基梅隆大学(CMU)一名大四学生,高中毕业于上海世界外国语中学。据悉,这...
  • wenyan-lang 有哪些特性 > 可编译成 JS 或 Python; > 图灵完备; > 包括在线 IDE 和 编译器; > 源码开源了 语法备忘单 该项目团队正在加紧构建与上下文无关的语法描述。同时,可以查看以下备忘单或src/parser.js ...
  • 文言文亦能编程,该项目在GitHub摘得5500星!

    千次阅读 多人点赞 2019-12-20 10:08:00
    现在它支持将wenyan lang转换成JavaScript和Python: ./build/wenyan.js examples/helloworld.wy -o helloworld.js 在这段命令中,如果不指定语言,程序将自动转化为JavaScript,若想转化成Python,请加入...
  • 文言(wenyan-lang) 。 简介 该语言完全不使用英文字符,只包含繁体中文字符以及繁体的引号「」。 所以,它的  Hello World 画风是这样的: 这段文言文代码的意思是啥?看看等效的JavaScript代码: 这两个不同...
  • wenyan-lang :文言文编程语言。文言文语法,可以编译成 JavaScript、Python 或者 Ruby,你见过用文言文编写程序吗?快来试试吧。 在线尝试   29、 short_url :Elixir 语言开发的支持自定义短码的短链接...
  • http://wenyan-lang.lingdong.works 文言文編程語言。A programming language for the ancient Chinese. Try it online.
  • 现在它支持将wenyan lang转换成JavaScript和Python: ./build/wenyan.js examples/helloworld.wy -o helloworld.js 在这段命令中,如果不指定语言,程序将自动转化为JavaScript,若想转化成Python,请加入参数...
  • 现在它支持将wenyan lang转换成JavaScript和Python: ./build/wenyan.js examples/helloworld.wy -o helloworld.js 在这段命令中,如果不指定语言,程序将自动转化为JavaScript,若想转化成Python,请加入参数“—...

空空如也

空空如也

1 2 3 4 5 6
收藏数 102
精华内容 40
关键字:

wenyan-lang