精华内容
下载资源
问答
  • linux安装whl文件

    千次阅读 2021-05-10 04:47:53
    Windows环境:安装whl包:pip install ... pip install **.whl下载whl文件MySQL_python-1.2.5-cp27-none-win32.whlMySQL_python-1.2.5-cp27-none-win_amd64.whl执行pip install MySQL_python-1.2.5-cp27-none-win3...

    Windows环境:

    安装whl包:pip install wheel -> pip install **.whl

    下载whl文件MySQL_python-1.2.5-cp27-none-win32.whlMySQL_python-1.2.5-cp27-none-win_amd64.whl执行pip install MySQL_python-1.2.5-cp27-none-win32.whl 如果是安装64位的,需要把这个文件名改为“MySQL_python-1.2.5-cp27-none-any.whl”。  安装tar.gz包:cd到解压后路径,python setup.py install

    Linux环境:

    安装whl同上

    安装tar.gz,命令格式:tar -zxvf 压缩文件名.tar.gz解压后,cd文件 ->./configure -> make -> make install 或者 python setup.py install

    安装zip包,命令格式:unzip filename.zip 解压后,python setup.py install

    卸载安装包:

    python setup.py install --record files.txt 记录安装后文件的路径

    cat files.txt | xargs rm -rf 删除这些文件

    用pip安装一个包,报错误:python pip fatal error in launcher unable to create process using “”

    python2 -m pip install XXX   python3 的pip用python3 -m pip install xxx --upgrade pip

    pip更新软件包直接运行-cmd 控制台操作

    查看包 pip list

    安装a.whl包 pip install a.whl

    升级包 pip install --upgrade a.whl

    卸载包 pip uninstall a.whl

    查看待更新包 pip list --outdate

    升级pip自己 pip install --upgrade pip

    升级某个版本的包

    pip install SomePackage # latest version

    pip install SomePackage==1.0.4 # specific version

    Python 里面直接运行,更新多个包

    import pip

    from subprocess import call

    for dist in pip.get_installed_distributions():

    call("pip install --upgrade " + dist.project_name, shell=True)

    展开全文
  • pip 安装whl

    2021-01-30 20:55:46
    本文提供一种方法:直接下载whl文件,再运行命令安装就很快能安装完成。 1、先运行“pip --version”命令看看pip的版本号,如果太大,先降到pip 10.0.1(原因下面会说)。 2、运行pip install xxxxx安装想要包,...

    众所周知,在更新或者安装一个python组件时,可以使用pip install命令。

    但安装过程下载包会很慢,即使使用清华、中科大的镜像服务也经常因为超时等原因,要反复下载。本文提供一种方法:直接下载whl文件,再运行命令安装就很快能安装完成。

    1、先运行“pip --version”命令看看pip的版本号,如果太大,先降到pip 10.0.1(原因下面会说)。

    2、运行pip install xxxxx安装想要包,这里以“pip install scipy==1.2.0”为例,安装scipy 1.2.0.

    会出现下面这个:

    Collecting scipy==1.2.0
      Downloading https://files.pythonhosted.org/packages/f1/b8/800d98339427199305f8b4a7f02827ec9bfea438d677aecbe0bd297092d5/scipy-1.2.0-cp37-cp37m-win_amd64.whl (31.7MB)
        2% |▊                               | 686kB 6.8kB/s eta 1:16:25

    就是太慢,拷贝其中的“https://files.pythonhosted.org/packages/f1/b8/800d98339427199305f8b4a7f02827ec9bfea438d677aecbe0bd297092d5/scipy-1.2.0-cp37-cp37m-win_amd64.whl”用下载工具下载这个whl文件,会很快下完,就可以停止这个安装了。如果用高版本的pip这个文件名就只有“scipy-1.2.0-cp37-cp37m-win_amd64.whl”,看不到全部URL,没办法用下载工具下载。

    3、到下载好文件的目录下运行“pip install scipy-1.2.0-cp37-cp37m-win_amd64.whl”就可以很快完成安装。

    展开全文
  • python whl是什么文件

    2021-02-09 08:03:13
    在安装whl文件之前,我们需要先搞清楚什么是whl文件,whl格式本质上是一个压缩包,里面包含了py文件,以及经过编译的pyd文件。使得可以在不具备编译环境的情况下,选择合适自己的python环境进行安装。在Win7下安装...

    be4b463f01224716c393093b60648467.png

    在安装whl文件之前,我们需要先搞清楚什么是whl文件,

    whl格式本质上是一个压缩包,里面包含了py文件,以及经过编译的pyd文件。使得可以在不具备编译环境的情况下,选择合适自己的python环境进行安装。

    在Win7下安装whl文件,可以直接使用pip命令:pip install MySQL_python-1.2.5-cp36-none-win32.whl (1)

    虽然大多数情况下,这个方法课安装成功,但也会经常有错误发生,下边我列举几个自己安装时遇到的的错误。

    第一个错误Could not find a version that satisfies the requirement pywin32 (from versions: )

    No matching distribution found for pywin32

    出现这个错误需要先检查自己有没有安装过wheel,如果没有,先需要用pip安装pip install wheel

    确认安装成功后,在执行(1)处的代码。(更多学习内容,请点击Python学习网)

    第二个错误:mysqlclient-1.3.12-cp35-cp35m-win_amd64.whl is not a supported wheel on this platform.

    一般这种错误是因为下载的whl文件的命名格式和系统支持的格式不同导致的,import pip

    print(pip.pep425tags.get_supported())

    展开全文
  • python之PypI打包whl文件

    2021-01-14 06:20:08
    一.简单介绍python中我们经常会用到第三方的包作为工具,比如爬虫解析工具,网络请求工具等。之所以要把它封装成包,意识为了...二.Pypi打包whl文件首先,我们需要确认我们需要打包的package中已经包含了README.m...

    一.简单介绍

    python中我们经常会用到第三方的包作为工具,比如爬虫解析工具,网络请求工具等。之所以要把它封装成包,意识为了技术与业务分离,二是为了能多

    项目多平台共用。python里面用到的第三方工具包基本都是从Pypi.org里面下载的。下面具体介绍如何打一个自己的包上传到Pypi中作为工具使用。

    二.Pypi打包whl文件

    首先,我们需要确认我们需要打包的package中已经包含了README.md、LICENSE[非必须]和setup/py文件。三者分别是说明文档,许可证以及

    python setuptools所用来安装该package的构建脚本。

    2.1 setup.py

    setup.py中包含了package对应的信息(例如该package的名称、版本、作者)以及该package应当包含的程序文件和数据。

    下面是一个setup.py的示例文件:

    import os

    from setuptools import setup, find_packages

    path = os.path.abspath(os.path.dirname(__file__))

    try:

    with open(os.path.join(path, 'README.md')) as f:

    long_description = f.read()

    except Exception as e:

    long_description = "customize okta cli"

    setup(

    name = "okta-cmd",

    version = "0.1.0",

    keywords = ("pip", "okta", "cli", "cmd", "steven"),

    description = "okta cli",

    long_description = long_description,

    long_description_content_type='text/markdown',

    python_requires=">=3.5.0",

    license = "MIT Licence",

    url = "https://github.com/stevenQiang/okta-cmd",

    author = "steven",

    author_email = "qianggao7@gmail.com",

    packages = find_packages(),

    include_package_data = True,

    install_requires = ["requests", "click"],

    platforms = "any",

    scripts = [],

    entry_points = {

    'console_scripts': [

    'okta-cmd=oktacmd:main_cli'

    ]

    }

    )

    name: 该package的名字,该名字可以由字母、数字、-组成,注意这个名字不能与其它已经上传到pypi.org的项目相同

    version: 这个就是包的发布版本,可以直接写在这,也可以从其它地方引用

    author: author可以用来指定该package的作者信息

    author_email: 这个也是指定该package的作者信息

    description: 对当前package的较短的总结

    long_description: 是对当前package的详细说明。这一详细说明将被展示在Python Package Index上当前项目的主页

    long_description_content_type: 指定了long_description内容的格式。在当前情况下为markdown

    url: 是当前package的主页链接。大多数情况下这是一个GitHub, GitLab, Bitbucket或者其他代码存储服务的链接

    packages: 是一系列应当包含在发布软件包文件(distribution package)中的可被import的python包文件。我们可以手动在此处罗列所有文件。

    或者如本例中一样使用find_packages()函数自动包含所有的python包文件以及子包文件。

    python_requires: python依懒版本

    classifiers: 指定了当前package的其他元信息(metadata)。例如当前package兼容的python版本和操作系统,当前package提供的功能的类型,

    当前package的许可证等等。我们应当总是至少包括当前package所支持的python版本,操作系统和许可证。注意此处定义的classifiers关键字

    所包含的信息应当符合PyPI的规定。

    install_requires: 指定了当前package所依赖的其他python类库。这些指定的python类库将会在本package被安装的时候一并被安装。

    platforms: 程序适用的软件平台列表

    keywords: 程序的关键字列表

    include_package_data: 是否自动包含包内所有受版本控制(cvs/svn/git)的数据文件,默认True

    entry_points: 用来支持自动生成cli命令

    使用上面的配置信息之后,会生成一个okta-cmd的命令,可以直接使用,就是在entry_points里面配置的。

    目录结构:

    ├── LICENSE

    ├── README.md

    ├── oktacmd

    │ ├── __init__.py

    │ ├── cli.py

    │ ├── common.py

    │ ├── main.py

    │ └── okta.py

    ├── setup.py

    └── setup.sh

    生成包:

    1.安装最新版的setuptools和wheel

    python3 -m pip install --user --upgrade setuptools wheel

    2.使用sdist构建源码分发包

    python setup.py sdist bdist_wheel

    注意: 这里是固定的命令(确保setup.py存在于当前路径下)

    当这个命令运行结束后,确保在生成的dist/文件夹下存在相应的.whl文件和.tar.gz文件。其中.tar.gz文件是我们的python package的源文件文档,

    而.whl是一个软件分发包(build distribution)。新版本的pip将会首先尝试安装软件分发包,但在失败情况下会接着尝试采用源文件包安装。

    三.上传项目至PyPI

    首先注册一个PyPI的账号,链接https://pypi.org/

    安装最新版本twine

    python3 -m pip install --user --upgrade twine

    3.上传项目

    使用twine上传项目的时候需要输入相应的PyPI的账号和密码。

    python3 -m twine upload dist/*

    展开全文
  • 安装pip,whl文件

    千次阅读 2020-12-22 11:58:38
    第一步,我们先来安装Python,博主选择的版本是最新的3.4.2版本。windows下面的Python安装一般是通过软件安装包安装而不是命令行,所以我们首先要在Python的官方主页上面下载最新的Python安装包。...
  • 查看方法:python -m pip debug --verbose 直接安装可能会报错: 报错原因:当前的whl安装包和当前版本的python版本不匹配 解决方法:先查看当前python版本支持的whl文件名称,根据相应的文件名去下载相应的包
  • whl文件安装方法

    2021-10-05 21:33:47
       whl格式本质上是一个压缩包,里面包含了py文件,以及经过编译的pyd文件。使得可以在不具备编译环境的情况下,选择合适...4.使用“pip install 文件名” 安装下载的文件(绿色框) 5.安装完成 ...
  • 我已经从这个web-page下载了pycairo,并尝试用pip安装它:pip install pycairo-1.10.0-cp27-cp27m-win_amd64.whl结果是:pycairo-1.10.0-cp27-cp27m-win_amd64.whl is not a supported wheel on this platform....
  • whl下载地址

    2020-12-22 09:50:20
    https://pypi.org/project/matplotlib/3.2.0/#files https://pypi.tuna.tsinghua.edu.cn/simple/
  • 常用whl获取方式

    千次阅读 2021-01-19 10:14:13
    也就是使用whl文件进行安装 使用方法如下 pip install ***.whl 常见的whl获取方法 1、PyPI · The Python Package Index 2、Python Extension Packages for Windows - Christoph Gohlke 3、PYPI ...
  • python 安装本地whl

    2021-03-29 16:27:26
    下载需要的whl cmd 到 whl文件所在位置 前提:已经安装了pip 然后输入:python -m pip install xxx(需要安装的whl文件名称)
  • Python语言目前比较爆火,相对其它语言而言,Python在某些方面确实是有很大的优势,简单,...那么,pip下载的东西都是以whl为后缀的打包文件,正如Linux使用yum下载的东西是使用后缀rpm的打包文件。 那么,下载的w.
  • pip不会安装.WHL文件

    2021-07-19 18:53:18
    When I try to install any .WHL from gohike by typing into the cmd C:\Users\owner\Downloads>pip install TA_Lib-0.4.9-cp27-none-win_amd64.WHLI get this print out:`Processing c:\users\owner\downloads\...
  • 1.了解自己的Python版本的,方便后续下载合适的.whl文件。win+R进入命令运行窗口,输入cmd打开命令提示符,接着输入python即可这是我的版本3.7.1,win322.选择需要的.whl文件下载3.将文件复制到pip安装的位置,也...
  • python setup.py bdist_wheel 打包完成,在同目录下的dist文件夹找到whl文件。 pip安装包 pip install D:\工作\代码打包\dist\te11-1.0-py3-none-any.whl 导入包检验模块。 import过程中会运行py文件内所有代码,可...
  • 下载.WHL文件网站

    2021-08-11 18:06:29
    网站开始 比如寻找sqlalchemy 它是按照英文字母排序的 ,根据你的装置是32位还是64位 以及 你python对应的版本下载 比如我的是windows64位python3.7 就选择 对应网址:https://www.lfd.uci.edu/~gohlke......
  • conda安装本地whl文件

    千次阅读 2021-07-28 15:51:08
    conda安装本地whl文件(opencv, pytorch, torchvision等) 因为在线安装总是遇到报错,就直接离线下载安装 离线安装报错可能是因为代理没关,下图 下载torch,torchvision离线文件 网址:...
  • 赠送一个简单的爬虫代码导入请求#导入请求包导入pymysqlfrom lxml进口etreeclass豆瓣:def getResult(自我):url_fir = \开始= \你= \__yadk_uid = JXhZSYpp8B4Ni2Kxv7IB58DQc6X8cUy8;\u201Ctrc_cookie_storage = ...
  • python 打包成whl文件

    2021-03-04 10:29:36
    1.安装wheel pip install wheel; 2.使用指令打包; 根据setup.py中的设置将项目打包在sdist目录下 python setup.py sdist bdist_wheel 注意打包的时候,你的包路劲里面需要有 init.py 这个配置文件;...
  • Linux离线安装whl

    2021-07-19 21:16:19
    在PIPY搜索要安装的包,注意对应好版本号和系统(Linux) 将下载到的whl通过FileZilla上传到...通过pip install whl包的地址来安装指定的whl文件,例如 pip install ./matplotlib-2.2.3-cp36-cp36m-win32.whl ...
  • python安装.whl库详解

    2021-08-20 10:48:49
    一、选择对应的.whl库下载 例如: TA_Lib :库名 0.4.21 :库版本号 cp38 :需要安装的python版本号,这里的数字指的是2.7版本 win32、win_amd64:指的是需要安装的python是32位还是64位的 二、下载完成后...
  • python离线安装whl文件.

    2021-11-05 11:10:53
    离线安装whl文件 一般情况下,我们都是使用pip install命令在线安装**python第三方库的,但是有些库在安装的时候可能会遇到困难,这时我们可能需要离线安装whl文件来安装这个库,下面介绍一下具体操作步骤。 一.下载...
  • Successfully built pandas $ ls pandas* pandas-0.18.1-cp35-cp35m-linux_x86_64.whl $ pip install pandas-0.18.1-cp35-cp35m-linux_x86_64.whl Processing ./pandas-0.18.1-cp35-cp35m-linux_x86_64.whl ......
  • 1. 随便建立一个文件夹 (如cal_similarity)里面包括以下五个简单的文件: __init__.py :用于说明这个文件夹是一个python 的package包(可以为空文件)cal_similarity.py :这个是要打包的测试文件 ...
  • pipy 的whl和egg的区别

    2021-10-31 23:36:28
    done Created wheel for uwsgi: filename=uWSGI-2.0.20-cp27-cp27m-macosx_10_15_x86_64.whl size=461787 sha256=82931f5ae82d58901e6be4937c9294518318e63ad695aadc1eb0daef9d7e8ff4 Stored in directory: /Users/...
  • whl安装路径不支持

    2020-12-22 16:36:07
    XGBoost的whl安装包 #一般情况下,我们使用python pip install package来下载python的安装包 但当下载报错,我们考虑到下载whl文件来安装 https://www.lfd.uci.edu/~gohlke/pythonlibs/(whl网址) 之后再安装中出现...
  • 使用whl离线安装open3d,报错 xxx.whl is not a supported wheel on this platform 显而易见是whl的版本没对,使用pip debug --verbose,会输出pip可以使用的whl版本。在官网上下载对应的版本,pip install xxx.whl...
  • Python如何安装whl文件

    2021-01-05 17:37:09
    1、首先需要在网上下载好whl文件,比如: pyOpenSSL-20.0.1-py2.py3-none-any.whl 2、然后cmd命令进入到该文件所在的目录下 3、执行以下命令即可 pip3 install pyOpenSSL-20.0.1-py2.py3-none-any.whl
  • 生成whl文件 通过一下命令,生成whl文件,[path_to_save_wheel]为生成的whl文件的保存路径 bazel-bin/tensorflow/tools/pip_package/build_pip_package ~/path_to_save_wheel 6.使用pip命令进行安装即可 7.出现的坑 ...
  • CentOS离线安装rpm\whl

    2021-02-18 21:36:02
    软件:rpm包 可在有网的时候下载: 比如yum:yum install scipy --downloadonly --downloaddir=/opt/rpm 比如pip: pip3 download -d /opt/pip numpy 安装命令: yum安装rpm:yum ...pip安装whl: pip install numpy

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 60,665
精华内容 24,266
关键字:

whl4