精华内容
下载资源
问答
  • 易语言取超级列表框的检查框被选中项目源码,取超级列表框的检查框被选中项目
  • .版本 2 .支持库 iext 编辑框1.内容 = 超级列表框2.取标题 (超级列表框2.现行选中项, 5) 信息框 (编辑框1.内容, 0, , )
    .版本 2
    .支持库 iext
    
    编辑框1.内容 = 超级列表框2.取标题 (超级列表框2.现行选中项, 5)
    信息框 (编辑框1.内容, 0, , )
    
    
    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: https://www.eyuyan.tv/p1289

    展开全文
  • 取超级列表框标题.e

    2013-09-30 16:10:53
    取超级列表框标题.e
  • //获取当前选择项的值. var options=$("#fukusyaNendo option:selected");//获取当前选择项. options.val();//获取当前选择项的值. 2.获取内容 var options=$("#fukusyaNendo option:selected"); va...

    1 获取value

    $("#fukusyaNendo").val();//获取当前选择项的值.
    
    var options=$("#fukusyaNendo option:selected");//获取当前选择项.
    options.val();//获取当前选择项的值.
    
    

    2.获取内容

    var options=$("#fukusyaNendo option:selected");
    var nendoSS = options.text();

    3. 获取所有中value最后值。

    var lastVal = $("#fukusyaNendo option:last").val();    //2019

     

    展开全文
  • JS获取复选框中当前选中的值

    万次阅读 多人点赞 2019-03-11 16:11:54
    <!... <title>onchange ...这就是onclick与onchange的区别,这个例子点击onchange按钮并没有弹窗弹出,就是因为控件内容并没有发生变化。 最后,给你们碗鸡汤: 我不是想赢,我只是不想输
    <!DOCTYPE html>
    <html lang="en">
    <head>
        <meta charset="UTF-8" />
        <title>onchange</title>
    </head>
    <script type="text/javascript">
        window.function() {
            var aFruit=document.getElementsByName("checkfruit");
            var oSelectAll=document.getElementById("selectAll");
            var oP=document.getElementById("content");
            var str="";
            //全选/全不选
            oSelectAll.onchange=function() {
                if(this.checked) {
                    for(var i=0;i<aFruit.length;i++) {
                        aFruit[i].checked=true;
                        str+=aFruit[i].value+" ";
                    }
                    oP.innerText="你选择的瓜是:"+str;
                }else {
                    for(var i=0;i<aFruit.length;i++) {
                        aFruit[i].checked=false;
                    }
                    oP.innerText="你没有选择任何瓜";
                    str="";
                }
            }
            //单个点击复选框
            var str1="";
            for(var i=0;i<aFruit.length;i++) {
                aFruit[i].onchange=function() {
                    if(this.checked) {
                        str1=str1+this.value+" ";
                    }else {
                        str1=str1.replace(this.value,"");
                    }
                    oP.innerText="你选择的瓜是:"+str1;
                }
            }
        }
    </script>
    <body>
        <div>
            <label><input type="checkbox" id="selectAll"/>全选/全不选:</label><br /><br />
            <label><input type="checkbox" name="checkfruit" value="冬瓜"/>冬瓜</label>
            <label><input type="checkbox" name="checkfruit" value="南瓜"/>南瓜</label>
            <label><input type="checkbox" name="checkfruit" value="西瓜"/>西瓜</label>
            <label><input type="checkbox" name="checkfruit" value="北瓜"/>北瓜</label>
        </div>
        <p id="content"></p>
    </body>
    </html>
    

    效果图:
    在这里插入图片描述

    代码中用了今天看到的onchange事件,onchange事件常用于“具有多个选项的表单元素”中。

    • 单选框选择某一项时触发
    • 复选框选择某一项时触发
    • 下拉列表选择某一项时触发

    在代码中用onclick点击事件也是可以的,出来的效果是一样的!!!
    只不过,onchange与onclick还是有点区别的:
    onclick事件:点击控件时触发的事件
    onchange事件:控件内容发生改变时触发的事件(对象有了变化才触发事件)

    下面我写了一个例子对两个事件做了比较:

    <!DOCTYPE html>
    <html lang="en">
    <head>
        <meta charset="UTF-8" />
        <title>onchange</title>
    </head>
    <script type="text/javascript">
        window.function() {
            var oBtn1=document.getElementById("btn1");
            var oBtn2=document.getElementById("btn2");
            oBtn1.onclick=function() {
                alert("onlick事件");
            }
            oBtn1.onchange=function() {
                alert("onchange事件");
            }
        }
    </script>
    <body>
        <input type="button" id="btn1" value="onclick"/>
        <input type="button" id="btn2" value="onchange"/>
    </body>
    </html>
    

    运行图:
    在这里插入图片描述

    这就是onclick与onchange的区别,在这个例子中点击onchange按钮并没有弹窗弹出,就是因为控件内容并没有发生变化。

    最后,给你们碗鸡汤:

    	我不是想赢,我只是不想输
    
    展开全文
  • 列表框属性

    千次阅读 2019-11-22 14:01:41
    列表框允许用户从多个对象选择一项或多项,这些对象可以是文本、文件和位图等。当列表框的项不能全部显示出来时,可以用滚动条来滚动显示。 1. 基础知识 默认的列表框只允许用户单选,需要多选时,须把列表框的...
  • MFC实现的多选的列表框ListBox

    热门讨论 2011-10-20 23:05:00
    左边的“待选的历史人物”列表框包含历史人物的名字,当选人名并单击“添加”按钮,则名字会添加到右边的“你喜欢的历史人物”列表框,同时从左侧的列表框中删除;当选中“你喜欢的历史人物”列表框中的人名并...
  • 开始本文主题之前,先来看一个 HTML demo,一个非常简单的选择列表(select): <select> <option>one</option> <option>two</option> <option>three</option> </...
  • 用C#编写的一个添加、删除和清除列表框项目的程序,listBox的相关用法
  • 简易场景:用户点击列表框上的一个项目,将选中的项的值显示到界面上,取消勾选时,同步界面上取消。 注意,要ItemCheck事件里面写(如果mouseClick事件里写,会有很多坑爹的问题),该事件有参数为e,调用e....
  • 列表框_初始化 列表框_取行数 列表框_是否被选中 列表框_取当前焦点行 列表框_取鼠标最后选中行 表框_取指定行标题 列表框_选中指定行 列表框_取行高度 列表框_设置勾选
  • &lt;!DOCTYPE html&gt;&lt;html&gt; &lt;head&gt; &lt;meta charset="UTF-8"&gt; &... /*1、定义复选函数*/ function test(can) { str2 = can
  • 小甲鱼零基础入门学习python笔记

    万次阅读 多人点赞 2019-08-14 11:06:30
    哦,答案应该是 68 个 >>> dir(__builtins__) 查看 Python 提供的内置方法列表 >>> help(input) 查看input的具体使用说明 注: 只有当标识符已经赋值后( Python 的变量是不用先声明的)才能代码使用,未赋值...
  • LabVIEW(十六):多列列表框控件

    千次阅读 2018-09-25 08:51:00
    程序框图中选中多列列表框右键>创建>属性节点>项名:多列列表框所有的表格都称作项名。 (2)、选中项名属性右键>转换为写入 (3)、选中项名属性右键>创建>常量 (4)、调整输入常量的表格大小:可以调整单个表格和...
  • 做了一个需求 查询结果的表格,选取(可多选)一些值,获取到保单号后,打开一个elementUI的穿梭,然后获取到所有业务员,选取一些业务员后,将上一步获取到的保单号传递给业务员。 画个示意图 这里...
  • MFC 列表框使用技巧

    千次阅读 2016-02-05 08:15:23
    因工业项目中用到列表框的次数比较多,这里总结一下 通过工具箱把列表框控件拖入对话框,并为其添加控件变量m_listBox,然后看一下列表框的消息内容:  LBN_DBLCLK :用户用鼠标双击了一列表项,只有具有...
  • labview技巧——多列列表框

    万次阅读 2019-02-26 22:03:56
    【多行列表框】可用于显示包含多个横向信息的数据,列表本身支持鼠标选中行(默认为单行,可以右击更改其他),所以可以利用属性节点将当前选中行的数据提取出来方便处理,例如删除数据,导出当前行的信息等,可以...
  • Mysql Workbench使用教程

    万次阅读 多人点赞 2019-03-20 23:45:34
      SCHEMAS 列表中展开当前默认的 test_db 数据库,   Views 菜单上右击,选择“Create View…”,即可创建一个视图,如下图所示。 设置视图名称和视图的定义 设置完成之后,可以预览当前操作的...
  • 常用控件:列表框控件ListBox

    千次阅读 2017-09-29 10:10:18
     列表框给出了一个选项清单,允许用户从中进行单项或多项选择,被选中的项会高亮显示。列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。...
  • EXT grid 根据参数值,获取列表某一行数据并设置被选中,为防止分页导致不能使用,我选择了一个页面展示全部数据(有好办法记得分享给我) var selections = Ext.getCmp(&quot;grid_main&quot;).getStore...
  • 窗体上建立一个简单组合框,组合框的文本框输入数字字符,按回车键后加入到组合框的列表框内,如图E.8所示;单击“交换”按钮,将列表框中最小值项目和第0个项目交换;最大值与最后项目交换,如图所示: 提示...
  • (100% - 20px)" v-loading="tableLoading"> <el-table-column type="index" width="50">el-table-...: boolean): void 然后通过点击事件去执行该方法,就能达到点击当前列表的一行选中/不选中效果了,就是这么的简单。
  • 组合框和列表框都可以界面上同时显示多项内容,并且允许用户选中其中的某项内容,列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • HTML列表框元素的操作

    千次阅读 2016-02-25 17:23:48
    列表框元素的操作
  • Layui 数据表格单击行选中当前行复选并改变其背景色 第一种:行监听 实现思路 直接修改复选框选中状态和伪复选(DIV)Class 但是调用checkStatus获取不到选中的行 查看底层源代码checkStatus方法的实现是缓存...
  • 列表框控件简介

    千次阅读 2015-09-29 11:26:36
    列表框给出了一个选项清单,允许用户从中进行单项或多项选择,被选中的项会高亮显示。列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。 ...
  • MFC实例:[5] ListBox 列表框控件实例

    千次阅读 2019-04-01 17:39:52
    MFC实例:[4] ListBox 列表框控件实例
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框选择的项会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、项的添加和删除...
  • 下拉列表如何获取选中option的值

    千次阅读 2018-09-28 18:48:18
    对于无序列表ul,我们可以早ul元素上注册click事件,通过event.target来获取到当前点击的列表项,示例代码如下: &lt;!--html代码部分--&gt; &lt;ul id='list'&gt; &lt;li&gt;1&lt;/li...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 107,157
精华内容 42,862
关键字:

在列表框中当前被选中