精华内容
下载资源
问答
  • 文本框输入内容,点击“添加”按钮后添加到列表框中;点击“删除”按钮则从列表框中删除选中的元素。
    千次阅读
    2020-04-17 11:26:29

    在文本框中输入内容,点击“添加”按钮后添加到列表框中;点击“删除”按钮则从列表框中删除选中的元素。

    protected void Button1_Click(object sender, EventArgs e)
            {
                // ListBox1.Text= TextBox1.Text+ ListBox1.Text;
                this.ListBox1.Items.Add(TextBox1.Text);
            }
    
    protected void Button2_Click(object sender, EventArgs e)
            {
                string checkobject = this.ListBox1.SelectedItem.ToString();
                this.ListBox1.Items.Remove(checkobject);
            }

     

    更多相关内容
  • 超级列表框选择框是否有被选中
  • 超级列表框 复制当前点击列的数据例子源码
  • //button3_Click是删除按钮 //listBox1是列表框 ... //由于列表框控件允许多选所以需要循环删除所有已选项 int count = listBox1.SelectedItems.Count; List<string> itemValues = new List<string&g
    //button3_Click是删除按钮
    //listBox1是列表框
     private void button3_Click(object sender, EventArgs e)
            {
            //由于列表框控件中允许多选所以需要循环删除所有已选项
                int count = listBox1.SelectedItems.Count;//判断选中了几个
                List<string> itemValues = new List<string>();
               
                if (count == 0)
                {
                //如果所选项个数为0,则进行提示
                    MessageBox.Show("请选择需要删除的内容!");
                }
                else
                {
               		//将选中项的内容添加到字符串列表中
                    for (int i = 0; i < count; i++)
                    {
                       itemValues.Add(listBox1.SelectedItems[i].ToString());
                    }
                    //按照内容从列表框中移除数据
                    foreach (string item in itemValues)
                    {
                        listBox1.Items.Remove(item);
                    }
                    MessageBox.Show("删除成功!");
                }
    
            }
    
    //将文本框中的值添加到列表框中
    //button2_Click是添加按钮
    private void button2_Click(object sender, EventArgs e)
    {
        //当文本框中的值不为空时将其添加到列表框中
        if (textBox1.Text != "")
        {
            listBox1.Items.Add(textBox1.Text);
        }
        else
        {
            MessageBox.Show("请添加爱好!");
        }
    }
    
    //button1_Click 展示
    //用提示框显示选中的所有项内容
            private void button1_Click(object sender, EventArgs e)
            {
                string msg = "";
               // listBox1.SelectedItems.Count 选中项的总个数
                for (int i=0;i<listBox1.SelectedItems.Count;i++)
                {
                //listBox1.SelectedItems[i].ToString()选中项的值
                    msg = " " + msg + listBox1.SelectedItems[i].ToString();
    
                }
                if (msg != "")
                {
                    MessageBox.Show("您选择的水果是:" + msg, "提示");
                }
                else
                {
                    MessageBox.Show("您没有选择水果", "提示");
                }
            }
    
    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: 超级列表框实例教程 - 01.新手上路请上车 易语言TV

    展开全文
  • vue系列之获取多选框中被选中的值

    千次阅读 2020-12-19 14:24:47
    多个勾选,绑定到同一个数组:JackJohnMikeChecked names: {{ checkedNames }}new Vue({el: '...',data: {checkedNames: []}})结果angularJs获取复选框中id 进行批量删除主要思路:我们需要定义一个用于存储选中 ID...

    多个勾选框,绑定到同一个数组:

    Jack

    John

    Mike

    Checked names: {{ checkedNames }}

    new Vue({

    el: '...',

    data: {

    checkedNames: []

    }

    })

    结果

    angularJs获取复选框中id 进行批量删除

    主要思路:我们需要定义一个用于存储选中 ID 的数组,当我们点击复选框后判断是选择还是取消选择,如果是选择就加到数组中,如果是取消选择就从数组中移除.在点击删除按钮时需要用到这个存储了 ID 的数组. ...

    javascript如何获取复选框中的值?

    思路:获取checkbox对象→循环checkbox数组,根据checked属性判断是否选中→使用value属性获取选中项的值.实例演示如下: 1.HTML结构

    当select框变化时 获取select框中被选中的值

    DOM 1

    elementui-如何同时获取多选框的label和value

    展开全文
  • 列表框的selected属性

    千次阅读 2021-06-10 17:17:36
    Φ是什么意思?读"fai".是直径的意思不?...而用作列表框和组合框有没有select属性列表框有selected,表示是否选中:If List1.Selected(i) Then 组合框只允许选一个,没有select,Combo1.ListIndex即为当前选中...
  • 开始本文主题之前,先来看一个 HTML demo,一个非常简单的选择列表(select): <select> <option>one</option> <option>two</option> <option>three</option> </...
  • //获取当前选择的值. var options=$("#fukusyaNendo option:selected");//获取当前选择. options.val();//获取当前选择的值. 2.获取内容 var options=$("#fukusyaNendo option:selected"); va...
  • JS获取复选框中当前选中的值

    万次阅读 多人点赞 2019-03-11 16:11:54
    下拉列表选择某一时触发 代码中用onclick点击事件也是可以的,出来的效果是一样的!!! 只不过,onchange与onclick还是有点区别的: onclick事件:点击控件时触发的事件 onchange事件:控件内容发生改变...
  • 开发经常会遇到这样得场景 点击列表中得某一当前项激活,其他恢复默认 ( 单选样式 ) 点击列表中得某一当前项激活,再次点击,当前项目恢复默认,不影响其他( 多选样式 ) 上代码 test.js import...
  • 组合框和列表框都可以界面上同时显示多内容,并且允许用户选中其中的某内容,列表框还允许同时选择多。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • 如下图所示,当我们百度搜索框中搜索关键字时,百度...要实现上述功能,需要解决以下几个问题:所有的列表项需要集合数组或者单元格区域要实现的单元格区域触发Worksheet_SelectionChange事件;Worksh...
  • VC6.0 MFC 列表框 列表控件 添加 修改 删除

    千次阅读 多人点赞 2020-06-28 15:46:24
    前面:列表框是很常用,并且很重要的一个控件,那么接下来,就跟随我的脚步,去探索它的奥秘吧! 一、未卜先知 1、编译运行后,点击“学生档案信息”,界面如下图所示。 2、添加记录,如下图所示。 3、修改...
  • 列表框属性

    千次阅读 2019-11-22 14:01:41
    列表框允许用户从多个对象选择一或多,这些对象可以是文本、文件和位图等。当列表框不能全部显示出来时,可以用滚动条来滚动显示。 1. 基础知识 默认的列表框只允许用户单选,需要多选时,须把列表框的...
  • 做了一个需求 查询结果的表格,选取(可多选)一些值,获取到保单号后,打开一个elementUI的穿梭,然后获取到所有业务员,选取一些业务员后,将上一步获取到的保单号传递给业务员。 画个示意图 这里...
  •  小知识:如何读取整个超级列表框的每个内容 主要是取表数 取列数 两个函数    小知识:易语言下的 覆盖写入 追加写入的写法 核心就是打开文件的方式 覆盖写入  追加写入      小知识:超级i额表框...
  • 1.需求:需要下拉框列表中同时展示名称和id,将其两个字段进行拼接即可,但选中的展示内容不要id只要展示名称; 2.思路:展示时进行拼接,选中时强制改变选中内容即可; 3.实现 3.1代码 &lt;!DOCTYPE ...
  • 本演示介绍如何WPF的MVVM框架,通过数据绑定的方式获取下拉列表中选中项。程序运行后的效果如下图所示: 相关下载(代码、屏幕录像):http://pan.baidu.com/s/1sjwN357 在线播放:...
  • Access-控件解析-列表框-02-获取选项

    千次阅读 2018-08-25 19:50:05
    微信公众号原文 系统:Windows 7 ...本篇介绍的控件为:列表框。涉及功能为:后台获取用户的选择 UI界面存在大量与用户互动的部分,根据客户不同的选择展现不同的信息 功能动图 静图 Part 2:...
  • 本文要讲的是列表框控件(ListBox)及其使用实例。 Xtreme Toolkit Pro是屡获殊荣的VC界面库,是MFC开发最全面界面控件套包,它提供了Windows开发所需要的11种主流的Visual C++ MFC控件,包括Command Bars、...
  • 组态王下拉列表框问题

    千次阅读 2020-12-21 01:45:14
    首先认识一下列表框控件的函数:listLoadList("ControlName","Filename")此函数用于将CSV格式文件“Filename”列表项调入指定的列表框控件“ControlName”,并替换列表框中的原有列表项列表框中只显示列表项...
  • 【原创】带你玩转超级列表框(全套教程... 带你玩转超级列表框 1 新手上路请上车   第一节课没说什么  带你玩转超级列表框 2 常用属性来设置  主要说了超级列表框的属性 或者说 和 我门自己总结的 使用
  • MFC实例:[5] ListBox 列表框控件实例

    千次阅读 2019-04-01 17:39:52
    MFC实例:[4] ListBox 列表框控件实例
  • Qt QListWidget列表框用法详解

    千次阅读 2022-01-25 13:30:02
    Qt QListWidget列表框用法详解 很多应用程序需要以列表的形式向用户展示数据(资源),比如 Windows 操作系统会以列表的方式展示很多张桌面背景图(如图 1a) 所示),再比如很多音乐播放器以列表的形式展示音乐...
  • 1.后台请求初始化复选 常用属性 type:input的话是输入框,select是下拉选择,checkbox是复选 label:属性名对应的名称,也是前端列表所显示的列名 ...5.上面是新增表单初始化,如果是修改表单,需要在列表
  • 常用控件:列表框控件ListBox

    千次阅读 2017-09-29 10:10:18
    列表框可分为单选列表框和多选列表框,顾名思义,单选列表框中一次只能选择一个列表项,而多选列表框可以同时选择多个列表项。  列表框也会向父窗口发送通知消息。这些通知消息含义如下:  LBN_DBLCLK:用户...
  • 下拉列表如何获取选中option的值

    千次阅读 2018-09-28 18:48:18
    对于无序列表ul,我们可以早ul元素上注册click事件,通过event.target来获取到当前点击的列表项,示例代码如下: &lt;!--html代码部分--&gt; &lt;ul id='list'&gt; &lt;li&gt;1&lt;/li...
  • 下拉列表框 public Form2() { InitializeComponent();//由系统生成的对于窗体界面的定义方法,初始化窗体组件的 } public int index = -1;//设置 public int index1 = -1; public int index2 = -1; private ...
  • win32 使用列表框

    2019-05-24 17:27:53
    列表框介绍: ...WM_COMMAND 通知码:当列表框有 LBS_NOTIFY 风格的时候,用户有所动作时列表框会向父窗口发送 WM_COMMAND 消息,同时 wParam的高16位 指定 通知码,列表框的通知码很少,基本...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 63,496
精华内容 25,398
关键字:

在列表框中当前被选中的列表项