精华内容
下载资源
问答
  • 区域OSPF

    2012-12-03 20:17:29
    内部R 所有接口在同一区域, 只有一个区域的数据库。 ABR 区域边界路由器, 连接主干和常规区域的R,每区维护一个数据库。 ASBR OSPF系统边界路由器,至少有一个接口与外部网络( 非OSPF区域 ) 相连,可以将外部路由...

     

     

    一、多区域OSPF概念:

     

    内部R   所有接口在同一区域, 只有一个区域的数据库。
    ABR     区域边界路由器, 连接主干和常规区域的R, 每区维护一个数据库。
    ASBR    OSPF系统边界路由器,至少有一个接口与外部网络( 非OSPF区域 ) 相连,        可以将外部路由信息导入到OSPF 网络中.
     
    三种路由:
    内部路由: O       本区内路由,  通过LSA-1、LSA-2 学到
    域间路由 O IA     通过 LSA-3 学到
    外部路由 O E1/E2 通过LSA-5学到
               E1     外部成本+内部成本
               E2     只包含外部成本 ( 默认 )
     
    OSPF区域结构
    中转区域   又称主干区域 , 区域0(必须), 用来连接其它常规区域,通常中转区域中没有终端用户。 在OSPF网络中,要求所有的区域都必须与区0直接相连, 否则不能交换信息。 
    常规区域    非主干区域, 存在终端用户的区域, 默认常规区域不允许中转其它区域的流量。
     
    OSPF区域类型:
    标准OSPF区域:   默认情况下,OSPF的所有区域都是标准区域, 可以接收LSA-1/2、LSA-3/4、LSA-5, 即可以存在 O 、O IA、 O E2路由。
    特殊OSPF区域:  为对OSPF网络进一步优化,可以将OSPF网络设置为以下区域:
    未节区域   只收本区和汇总, 不收外部路由 ( 外部路由用默认处理 ) stub area
                      O      O IA     O *
    绝对未节    只收本区, 不收外部和汇总.
                      O      O *
    次未节区域NSSA     具有未节的优点, 但可以包含ASBR ( not so stub area)
                      O      O IA     O * O N2(本区内ASBR发布的外部路由)
                          说明: NSSA只过滤穿越ABR的外部路由
    绝对次未节   具有绝对未节的所有优点, 但可以包含ASBR
                       O       O *IA              
    说明: 设置未节可以缩小区域中的LSDB, 减小路由表, 降低内存需求.
     
    OSPF链路状态通告 
    1类LSA    路由器链路通告   O
        // 描述该路由器的链路状态信息    拓扑+路由
    2类LSA    网络链路通告, 由DR 发送  O
       // 描述该路由器一个接口所属的BMA网段的相关信息   拓扑+路由  
    3类LSA    汇总链路通告,通告由LSA-1/2学到的路由    O IA    
    4类LSA    汇总链路通告,描述前往ASBR的路由       ASBR-ID
                由和ASBR在同一区域的ABR生成, 在穿越边界时改为新的ABR.
    5类LSA    外部链路通告       // 描述如何前往外部网络   O E2
    7类LSA    次未节区域中外部链路通告         O N2
    说明:对于LSA-3/4/5/7, 每个LSA只包含一条路由信息,如果有多条路由,则需要多个LSA来通告。
    LSA总结:
            LINK-ID(名字)        ADV-Router             扩散范围
    LSA-1     R-ID                     R-ID                      本区内
    LSA-2     DR的IP            DR的R-ID                 本区内
    LSA-3     路由 IA            ABR-ID                     区域间
    LSA-4     ASBR-ID           同上                         区域间
    LSA-5     路由 E2         ASBR-ID(不改变)      区域间
    LSA-7     路由 N2         ASBR-ID                   本区内(跨越边界时由ABR重新生成5类LSA进行扩散)
     
    二、主要配置命令
     
     R1            (ASBR)  
    R1(config)# router ospf 1
            # router-id 1.1.1.1
            # net 172.17.0.0 0.0.255.255 area 1
            # redistribute rip subnets
            # summary-address 172.20.0.0 255.252.0.0   
            # area 1 nssa         次末节区域
            # area 1 nssa       绝对次末节区域
    # router rip
             # version 2
             # net 172.17.0.0
             # redistribute ospf 1 metric 3
    R2             ( ABR )
    R2(config)# router ospf 1
            # router-id 2.2.2.2
            # net 172.17.1.2 0.0.0.0 area 1
            # net 10.10.1.1 0.0.0.0  area 0            
            # area 0 range 172.17.0.0 255.255.0.0  域间路由汇总
     
            # area 1 nssa default-information-originage   (nssa默认不能自动注入默认路由, 此命令可以强制注入一条7类的默认路由)
     
            # area 1 nssa no-summary      //自动注入一条3类的默认路由
     
    R3             (ABR)
     
    R3(config)# router ospf 1
            # router-id 3.3.3.3
            # net 172.18.0.0 0.0.255.255 area 2
            # net 10.10.1.0 0.255.255.255 area 0
            # area 2 range 172.18.0.0 255.255.0.0         域间路由汇总
            # area 2 stub                     设置为末节区域
            # area 2 stub no-summary            绝对末节区域
    R4  同R3相似
    R5配置RIP
     
     

    转载于:https://blog.51cto.com/ghf00/1077554

    展开全文
  • 第 三 章 单 个 区 域 办...OSPF是一种内部网关协议(IGP),也就是说它属于同一自治系统的路由器间发布路由信息。OSPF是为解决RIP不能解决的大型、可扩展的 网络 需求而写的OSPF解决了以下问题:*收敛速率*对可变...

    第 三 章 在 单 个 区 域 办 配 置OSPF OSPF是一项链路状态型技术,比如路由选择信息协议(RIP)这样的距离矢量型技术相对。OSPF协议完成各路由选择协议算法的两大功能:路径选择和路径交换。

    OSPF是一种内部网关协议(IGP),也就是说它在属于同一自治系统的路由器间发布路由信息。

    OSPF是为解决RIP不能解决的大型、可扩展的 网络 需求而写的OSPF解决了以下问题:

    *收敛速率

    *对可变长度掩码(VLSM)的支持

    OSPF、RIPV2支持VLSM,RIP只支持固定长度子网掩码(FLSM)

    *网络可达性

    RIP跨度达16跳时被认为是不可达,OSPF理论上没有可达性限制

    *带宽占用

    RIP每隔30秒广播一次完整路由,OSPF只有链路发生变化才更新

    *路径选择方法

    RIP是基于跳数选择最佳路径的,OSPF采用一种路径成本(cost)值(对于 Cisco 路由器它基于连接速率)作为路径选择的依据。OSPF与RI P、IGRP一样直持等开销路径

    OSPF信息在IP数据包内,使用协议号89

    OSPF可以运行在广播型网络或非广播型网络上

    在广播型多路访问拓朴结构中的OSPF运行

    Hello协议负责建立和维护邻居关系

    通过IP多目组广播224.0.0.5,也被称为ALLSPFROUTER (所有SPF路由器)地址,Hello数据包被定期地从参与OSPF的各个接口发送出去。

    Hello数据包中所包含的信息如下:

    l路由器ID

    这个32比特的数字在一个自治系统内唯一的标识一个路由器。它缺省是选用活跃接口上的最高IP地址。这个标识在建立邻居关系和直辖市运行在网络中S PF算法拷贝的消息时是很重要的。

    *HELLO间隔和DOWN机判断间隔(dead interval)

    HELLO间隔规定了路由发送HELLO的时间间隔(秒)。DOWN机判定间隔是路由器在认为相邻路由器失效之前等待接收来自邻居消息的时间,单位为秒,缺省是H ELLO间隔的4倍。

    *邻居

    这些是已经建立了双向通信关系的相邻路由器

    *区域ID

    要能进行通信,两台路由器必须共享一个共同的网络分段

    *路由器优先级

    这8个比特数字指明了在选择DR和BDR时这台路由器的优先级。

    lDR和BDR的IP地址

    *认证口令

    *未节(stb)区域标志

    OSPF数据包头中的各个域:

    *版本号 1(字节数)

    *类型 1

    HELLO

    链路状态请求

    链路状态更新

    链路状态确认

    *数据包长度 2

    *路由器ID 4

    *区域ID 4

    *校验和 2

    *认证类型 2

    *认证 8

    *数据 可变的

    指定路由器DR和备用指定路由器BDR

    在一个以太网分段这样的多路访问环境中的路由器必须选举一个DR和BDR来代表这个网络。在DR运行时,BDR不执行任何DR功能。但它会接收所有信息,只是不做处理而已,由D R完成转发和同步的任务。BDR只有当DR失效时才承担DR的工作,

    DR和BDR的价值:

    *减少路由更新数据流

    DR和BDR为给定多路访问网络上的链路状态信息交换起着中心点的作用。每台路由器都有必须建立与DR和BDR的毗邻关系,DR向多路访问网中的所有其它路由器发送各路由的链路状态信息。这一扩散过程大大减少了网络分段上与路由器相关的数据流。

    * 管理 链路状态同步

    DR和BDR可保证网络上的其它路由器都有有关于网络的相同链路状态信息

    毗邻关系是存在于路由器与其DR和BDR之间的关系。毗邻的路由器将具有同步的链路状态数据库

    选举DR和BDR时,路由器将在HELLO数据包交换过程中查看相互之间的优先值。

    根据下列条件确定DR与BDR

    *有最高优先级值的路由器成为DR

    *有第二高优先值的路由器被称为BDR

    *优先级为0的路由器不能作茧自缚为DR或BDR,被称为Drother (非DR)

    *如果一台优先级更高的路由器被加到了网络中,原来的DR与BDR保持不变,只有DR或BDR它们失效时才会改变

    展开全文
  • OSPF

    2015-09-03 22:43:25
    OSPFIGP 适用于中到大型网络LS 链路状态协议无类协议,支持VLSM/CIDR三层协议中封装协议号89OSPF的传递特点:每台路由器都有整网的路由,且知道每条路由所对应的接偶口同一区域内的所有路由器都有相同的LSDB注意:...
    1. OSPF

    2. IGP    适用于中到大型网络

    3. LS     链路状态协议

    4. 无类协议,支持VLSM/CIDR

    5. 在三层协议中封装协议号89

    OSPF的传递特点:

    1. 每台路由器都有整网的路由,且知道每条路由所对应的接偶口

    2. 同一区域内的所有路由器都有相同的LSDB

    注意:多区域中必须有 area0骨干区域,单区域中可以不是area0

    划分区域的影响:(优化了整体网络)

    1. 减少了路由条目数量(同一区域内不可以汇总路由,只有区域间和域外才能汇总)

      注意:如果同一台路由器属于多个区域,有多张LSDB表

    2. 将拓扑表变根限制在同一个区域内

    3. LSA传递是基于泛洪

    4. ABR区域边界路由器,一个属于Area0,一个是非Area0区域

    OSPF的邻建立:

    1. point-to-point 

    2. MA (DR BDR Drothers)

    SPF的特点:

    1. 同区域内每台路由器拥有相同的LSDB

    2. 每台路由器在收敛完毕后都会以自己为根计算路由条目

    3. cost  计算公式  10^8/BW(bit/s)  计算出结果然后每段相加

    4. 路由表加条目

    LSA的 传递:

    当一台路由器收到一个LAS后

    LSA-----判断本地有没有这个LSA—(有)——查看跟自己的序列号一样不—(相同)——直接无视

                            |                                                       |

                          没有                                    比自己高    |    比自己低                        

                            |                                              |                  |

                     加入LSDB                              重复左边操作      给发送者发送LSU同步LSDB

                            |

                    send  LSAck

                            |

                          泛洪

                            |

         本地通过SPF算法加入路由表

    注意:OSPF发送LSU即支持周期性发送也支持触发更新

              LSA报文没30min更新一次,60min内LSDB中的LSA没有被更新就会被丢弃

    序列号:最小  0x80000001

                 最小  0x7FFFFFFF

    当前使用的是棒棒糖型(序列号)

    OSPF的报文:

    1.hello            周期10/30s   hold time 时间为40s (4倍)

    2.DBD             DBD包含本地LAS的摘要,双方进行交换(采用隐式确认)

    3.LSR             LSR包含需要的LSA摘要(显式确认,发送LSU)

    4.LSU             LSU包含完整的LSA报文

    5.LSAck          基于LSU中的每条LSA发送LSAck

    OSPF的确认:

    1. 显式确认:发送专门的ACK确认

    2. 隐式确认:把收到的DBD发送给发送者,但用的是对方的序列号

    注意 :隐式确认是基于序列号的确认机制,只有OSPF支持

    OSPF的封装:

      二层帧     IP   OSPF的载和    FCS

    OSPF的载和内容:

    version  type  packet长度  router ID  area0  校验和  认证(0/1/2)  data

    version : OSPF有两个版本,V2用来支持IPv4,V3用来支持IPv6

    type :五种,hello DBD LSR LSU LSAck

    RID:1.手工配置   2.双up下loopback IP最大  3.双up端口下,物理IP最大(既可以标识路由器,也可以标识LSA)

    data:DBD中不仅有data,还有MTU字段

    Hello报文:

    1. RID

    2. hello and dead (必须相同,EIGRP没有这个要求)

      10s/30s取决于网络的,跟带宽没有关系,跟EIGRP不同

    3. neighbors :存放RID

    4. Area ID

    5. router priority (不一定都有优先级)

    6. BR

    7. BDR

    8. 认证

    9. 相同区域类型

    OSPF的邻接建立过程:

    1. Down 初始状态,接口被宣告进EIGRP,没有发送任何的报文

    2. lnit     通过接口发送了一份hello报文

    3. Two-way   通过接口收到了一份hello报文,里面的neighbor字段包含自身的RID(当时MA网络时,在这个时候开始选举DR和BDR,而点对点网络直接进入下一步)

    4. Exstart    交互三个不带LSA包头的DBD选择Master/Slave(主/从)

    5. Exchange   有Master发起的带有LSA报头的DBD信息交互

    6. Loading     交互LSR、LSU以及LSAck实现LSDB的同步

    7. Full     一旦LSDB同步,邻接关系达到Full

     Area 0 = 0.0.0.0
             1 = 0.0.0.1
          255 = 0.0.0.255
          256 = 0.0.1.0

    debug命令:
    debug ip ospf packet
    debug ip ospf adj


    修改MTU:

    进入接口
    ip mtu 1492
    清除进程:
    clear ip ospf process

    建立邻接关系时无视MTU影响的命令:
    进入接口
    ip ospf mtu-ignore
    注意:一端设置和两端设置命令一样,建议两端设置


    修改hello时间后dead时间自动改为四倍,但修改dead时间后hello时间不会自动 减小四倍,EIGRP不具备这个特点

    当把loopback宣告进OSPF时,不管宣告的是几位的,OSPF都会默认是/32位的,因为OSPF默认下把loopback接口认为是末节主机

    禁止这个特点的命令:
    interface loopback 0
    ip ospf network point-to-point
    注意:当输入这个命令后loopback就不会被认为是末节主机了

    在MA网段建立OSPF邻接关系是DR和BBR的选举原则:(选举时间为40s,取决于wait时间)
    1.参与该MA网段的路由器接口的OSPF优先级,越高越好(0-255),默认为1
    2.该MA网段所连接的路由器的RID,越高越好

    DR和BDR的关系:
    1.DR和BDR无法被抢占
    2.DR挂了BDR会立即抢占成为新的DR,而新的BDR通过在所有DRother之间重新选举得出(二次选举不需要等40s)
    3.DR和BDR都是接口级别的概念,每个网段的DR和BDR都通过相同的机制单独选举
    4.在以太网环境中建议拥有DR和BDR实现备份,而在FR环境中,只能是Hub节点成为DR,任何Spoke节点都不能成为DR和BDR
    5.如果一个MA网段没有DR和BDR,没有任何的邻接关系也不会有任何的LSA传递

     

    修改OSPF的优先级:
    进入接口
    ip ospf priority 0
    注意:当输入这个命令之后路由器不会建立邻接关系,因为选举不出DR和BDR,路由器会停在Two-way状态


    一台运行OSPF的路由器,只要在一个接口开启了OSPF的进程,则该接口会立即监听发往224.0.0.5的组播流量,而仅当一个节点成为DR或BDR时,该接口才会同时监听发往224.0.0.5和224.0.0.6的组播流量
    在一个MA网段内,所有的路由器发送的DR和BDR的报文的目的地址都是.6而DR将LSA整合之后以.5的地址发送的网段内所有的其他路由器
    在点到点网段不会存在.6的地址,因为没有DR和BDR

     ASBR系统边界路由器(路由重分发)

     

    LSA:

    1. Router LSAs:

      传递范围:只能在一个Area内传递,不能穿越ABR

      通告者:每台属于区域内的路由器都会基于该区域通告一条1类LSA

      包含的内容:拓扑信息,其中描述该路由器所有宣告进该区域的链路的前缀,掩码,网络类型及其度量值

      Link_ID:通告该LSA的路由器RID

      ADV Router:通告该LSA的路由器RID

      查看命令:show ip ospf database

                      show ip ospf database router

      注意:串口会在Link count 中自动多生成一条stub

    2. Network LSAs:

      传播范围:同一类LSA

      通告者:MA网段中的DR

      包含的内容:纯拓扑信息,包含了该MA网段直连的所有路由器的RID信息,该MA网段的掩码

      Link-ID:该MA网段DR接口的IP地址

      ADV Router:该DR的RID

      查看命令:show ip ospf network

    3. Summary network LSAs:

      传播范围:除了该区域外的整个OSPF路由选择域

      通告者:ABR

      包含的内容:一条3类LSA包含一条OSPF域间路由  (O IA)

      Link-ID:3类LSA路由器的前缀

      ADV Router:ABR的RID,,3类LSA在OSPF路由选择域内传递的时候为了保证可达性,没跨越一个ABR都会自动改写成为该ABR的RID

      查看命令:show ip ospf database summary

    4. Summary ASB LSAs:

      传递范围:除了ASBR所在的区域外的整个路

      通告者:和ASBR在同一个区域的ABR路由器

      包含的内容:纯拓扑信息,描述了ASBR所在的位置

      Link-ID:ASBR的RID

      ADV Router:通告者ABR的RID,并且该值每跨越一个ABR都会自动改变,同3类LSA

      查看命令:show ip ospf database asbr-summary

    5. External LSA:

      传递范围:整个OSPF路由选择域

      通告者:ASBR

      包含的内容:纯路由信息,一条OSPF域外路由对应一条5类LSA

      Link-ID:域外路由的路由前缀

      ADV Router:ASBR的RID,该LSA在OSPF域内传递的时候,ADV Router 不会发生任何的改变,形成的路口为(0 E2     0E1),默认下为0 E2

    Seed Metric:

             种子度量值,对于OSPF而言,如果将BGP路由重分发进入,则Seed Metric 默认为1,如果将其他的外部路由重分发进入,默认为20

    修改0 E1的命令:

    在ASBR上做重分发的时候修改

    router ospf 110

    redistribute eigrp 90 subnets

    metric-type 1

    OSPF的汇总:

    1. 域间汇总:需要在ABR上部署,实现对3类LSA的汇总传递

    2. 域×××总:需要在ASBR上部署,实现对5类LSA的汇总传递

    域间汇总的命令:

    router ospf 110

    area 0 range 202.10.8.0 255.255.255.0

    所有的ABR上都要配置

    域×××总命令:

    router ospf 110

    summary-address 192.168.8.0 255.255.255.0

    两者都会生成Null0

     

    LSDB的过载保护:

    注意:只有12.4以上的版本才有

    进入进程

    max-lsa 4     负载的条数

    warning-only    默认为75%时报错,建议修改为100%,仅仅会报错

    ignore-time     默认为5分钟down邻居,最小可修改为1分钟

    ignore-count   邻居次数超过限制就不会再建立,一般设置为3次

    resent-time    down完邻居重新建立后等待时间,默认3分钟,3分钟内没有过载就会把ignore count清零

     

    修改度量值:

    1. int f0/0

      ip ospf cost 66

    2. router ospf 110

      auto-cost reference-bandwidth 10000Mbits(注意单位)

      注意:第二种修改是修改OSPF计算公式中的分子大小

    OSPF的stub区域:

    需要的条件:

    1. 建议只有一个ABR

    2. 能正常建立邻接关系

    3. 区域内不能有ASBR

    4. 不能是area0区域

    5. 不允许有虚链路

    6. 只能是末节区域

    实现的目的:

    1. 保证stub收不到任何4,5类报文

    2. 主动向区域内下放缺省路由

    配置命令:

    router ospf 110

    area 1 stub

    注意:区域内的路由器都要配置stub,路由会以O* IA显示,Metric=65

    总结:如果一个OSPF区域属于stub区域,该区域内的ABR会将入区域方向的4,5类LSA同时过滤,同时该ABR会主动向区域内发送一个O* IA的0.0.0.0/0的3类缺省路由,Seed Metric=1

    修改Seed Metric的命令:

    router ospf 110

    area 1 default-cost 36 (默认为1)

    注意:修改命令是在ABR上修改

    OSPF的Totally stub区域:

    配置命令:(在ABR上配置)

    router ospf 110

    area 1 stub no summary

    不仅能阻止4.5类LSA报文,还能阻止3类LSA报文

    总结:在stub区域基础上ABR路由器会同时将3,4,5类入向传递的LSA过滤,同时会主动向该区域注入一条0.0.0.0/0的O* IA缺省路由,Seed Metric=1

    OSPF的Not-So-Stuby-Area区域(次末节区域)(NSSA区域)

    优势:允许区域内部重在ASBR,但是它不会主动向区域内下放缺省路由

    1. 当NSSA区域内的路由器既属于ABR又属于ASBR时,它产生路由在NSSA区域内以7类LSA传递,在其他区域一4,5类LSA传递

    2. NSSA区域内的ABR能把区域外的5类LSA翻译为7类LSA下放到NSSA区域,路由以 O NA格式显示

    3. NSSA区域内ASBR产生的路由以7类LSA在该区域内传递

    4. NSSA的ABR会阻止4,5类LSA报文传递进入该区域

    查看路由器的角色:

    show ip ospf border-routers

    一台路由器只要可以产生5类LSA,则该路由器就是ASBR

    给NSSA区域下放缺省路由的命令:

    area 2 nssa default-information-originate

    当给区域配置了下放缺省路由的命令后就没必要下放明细路由

    禁止NSSA区域中ABR路由下放到该区域的命令:

    router ospf 110

    area 2 nssa default-information-originate no redistributi

    修改 O NA的命令:

    area 2 nssa default-information-originate metric-type 1

    修改Seed Metric的命令:

    area 2 nssa default-information-originate metric 36 metric-type 1

    修改forward address 为0.0.0.0的命令(在ABR上修改)

    area 2 nssa traslate type 1 suppress-fa

    注意:NSSA中的forward address 是为了告知外部路由器数据传送的真正方向,修改forward address可增加安全性

    OSPF的Totally NSSA区域:

    router ospf 110

    area 2 nssa no summary

    优点:

    1. 同时过滤3,4,5类LSA报文

    2. 主动下放0.0.0.0/0的缺省路由

    总结:在NSSA区域可以拥有ASBR,并且重分发进入的OSPF的路由是以7类LSA形式存在的,该类型的LSA只能存在NSSA区域,并且该区域所有的ABR会通过比较RID选举出一个转换器(最大的RID),该转换器会将内部传递给外部的NSSA的LSA报文转换为5类LSA,并且通告给其他的区域,所有该区域的ABR都会过滤重外部进入该区域的4,5 类LSA,但是该区域的任何ABR都不会主动向内部下放缺省路由,为了实现内部路由器的外网可达性,需要在该区域ABR上手工下放缺省路由,O N2   forward address 0,0,0,0

    Seed Metric=1

              在Totally NSSA区域中,基于NSSA区域的特性,ABR会主动阻止3,4,5类LSA进入该区域,并且ABR会主动向该区域下放缺省路由   O* NA  forward address 0.0.0.0/0   Seed Metric=1

    路由器的加表优先级:

    O >O IA >O E1/O E2 = O N1/ O N2

     

    不规则区域:

    1. 远离骨干区域的非骨干区域

    2. 被分割的Area0区域

    对不规则区域的三种临时解决方案:

    1. 在出现问题的ABR上(没有和Area0直连的ABR上),使用双OSPF进程,并且执行单点双向重分发

      缺点:影响次优路由的选择

    2. 在出现问题的ABR上建立一个Tunnel链路,连接到离其最近的Area0中的ABR路由器上,在这两台ABR上对Tunnel配置IP地址为同一个IP子网段,并且将其宣告进OSPF的区域0中

      建立Tunnel的命令:

          interface tunnel 3

          tunnel source 3.3.3.3              源地址

          tunnel destination 1.1.1.1         目的地址

          interface tunnel 3

          ip add 2.2.2.2 255.255.255.0

          注意:不要宣告源和目的地址进入OSPF进程,因为会引起路由翻动,把源目的地址以静态路由的方式写入路由表

    3.使用Virtual-Link在出现问题的ABR上以及离他最近的Area0中的ABR上部署

    注意:Virtual-Link不能跨越骨干区域,不能跨越特殊区域

    配置命令:router ospf 110

                    area 2 virtual-link 1.1.1.1(RID)          area 2 为自身现在所处的区域

    show ip ospf virtual-link

    注意:只能在同区域的两台路由器上建立Virtual-Link

    OSPF的认证:

    ospf既支持明文认证,也支持密文认证

    1. 基于链路级的认证

    (1)链路级明文认证

    interface s1/1

    ip ospf authentication-key cisco

    ip ospf authentication

    (2)链路级密文认证

    interface s1/1

    ip ospf message-digest-key 12 md5 cisco

    ip ospf authentication message-digest

    注意:两段都需要配置

     2. 基于区域级的认证

    (1)区域级明文认证

    interface s1/1

    ip ospf authentication-key cisco

    router ospf 110

    area 0 authentication

    (2)区域级密文认证

    interface s1/1

    ip ospf message-digest-key 12 md5 cisco

    router ospf 110

    area 0 authentication message-digest

    注意:区域内的路由器都要配置

     3.虚链路的认证

    (1)Virtual-Link明文认证                                                             

    router ospf 110

    area 0 virtual-link 1.1.1.1 authentication-key cisco

    area 2 virtual-link 1.1.1.1 authentication                                  1.1.1.1为路由器的RID

    (2)Virtual-Link密文认证

    router ospf 110

    area 2 virtual-link 1.1.1.1 message-digest-key 1 md5 cisco

    area 2 virtual-link 1.1.1.1 authentication message-key

    注意:不管是明文还是密文,只有在建立邻接关系的时候才有用,在建立邻接后才配置,就没什么卵用了

    OSPF的网络类型

    1. Loopback    无论接口掩码多少,都以/32位主机路由出现

    2. Point-To-Point    建立邻接关系的数量只能有一个,支持组播,没有DR,Hello时间为10s,一般用在Serial/ISDN BRI中

    3. Broadcast     以太网接口,支持组播,有DR,Hello时间为10s

    4. NBMA   主要用在FR主接口/FR多点子接口,不支持组播,有DR,Hello时间为30s

         配置:interface s1/1

                   ip ospf network non-broadcast

                   router ospf 110

                       neighbor 1.1.1.2   (一定要指定单播地址,因为不支持组播,只需要在一端配置)

     5.  Point-To-Multipoint(点到多点)  

         支持组播发送,没有DR,Hello时间为30s,本地路由表会自动生成直连邻居接口的/32为主机路由

           show ip ospf interface s1/1

           show ip route ospf

     6. Point-To-Multipoint  Non-Broadcast (点到多点非广播) 

         不支持组播发送,没有DR,会自动生成一条/32位的主机路由Hello时间为30s

    注意:1.其中3.5.6为思科私有的网络类型

              2.修改命令为  interface s1/1   ip ospf network ......

              3.直连链路两端网络类型必须一致,但有个特例(一端是点到点,一端是点到多点,配置时需要修改hello时间)

              4.其中4.5.6配置完成后show ip ospf interface s1/1看到的网络类型都是Non-Broadcast,所以需要查看用show run-config

    在FR环境中部署OSPF

    1. 网络类型为NBMA

      (1)为了建立邻居需要在Hub节点上手工指定neighbor

      (2)为了保证路由传递没有问题,需要手工修改接口的OSPF优先级,保证Hub为DR,Spoke什么都不是

      (3)为了保证Spoke节点所连接的下游网段的PC可以互访,需要在Spoke节点手工FR映射

    2. 网络类型为Broadcast

      (1)由于支持组播发送,所以不需要指定neighbor,但前提是FR开启了伪广播功能

      (2)需要修改接口的优先级,改变DR的位置

      (3)需要手工配置FR的映射,实现Spoke节点的互访

    3. 网络类型为Point-To-Point Non-Broadcast

      (1)需要手工指定neighbor建立邻居

      (2)不需要修改优先级,因为没有DR

      (3)不需要手工FR映射,因为有/32位的主机路由

    4. Point-To-Multipoint

      (1)不需要手工指定neighbor

      (2)不需要修改优先级

      (3)不需要手工映射

    向OSPF中注入缺省路由:

    1. router ospf 110

      default-infromation originate          注意:路由器中必须有一条全零的缺省路由才行

      ip route 0.0.0.0 0.0.0.0 null 0                     创建缺省路由

    2. router ospf 110

      default-information originate always  

    OSPF的被动接口

    router ospf 110

    passive-interface f0/1

    注意:OSPF设置为被动接口后,既不能发,也不能收,跟EIGRP一样

    OSPF关闭ARP的映射:

    no frame-relay inverse-arp

    no arp frame-relay

    只有两个命令同时使用才能关闭ARP的映射

     

     

     

     

     

     

    转载于:https://blog.51cto.com/llzzgg/1691242

    展开全文
  • 本篇为 ospf 网络协议详解完结篇 文章目录ospf 路由过滤同一区域...在同一区域内使用 filter-policy 进行路由过滤的时候,只能让路由表发生变化,实际真正的 LSA 其实是可以学习到的,在入方向进行过滤会影响路由表的

    本篇为 ospf 网络协议详解完结篇

    ospf 路由过滤

    路由过滤可以达到针对指定的路由条目进行限制,以及对网络进行优化

    路由过滤使用 filter-policy 进行过滤

    路由过滤分为几种情况:

    • 同一区域
    • 不同区域

    同一区域

    使用 filter-policy 对同一区域内的路由进行过滤

    在同一区域内使用 filter-policy 进行路由过滤的时候,只能让路由表发生变化,实际真正的 LSA 其实是可以学习到的,在入方向进行过滤会影响路由表的生成

    不同区域

    使用 filter-policy 对不同区域的路由进行过滤

    在区域间的 ABR 上做过滤可以把路由信息过滤掉,因为区域间传递的是真实的路由信息,而不是像域内的 LSA ,因此在域间使用 filter-policy 过滤可以达到路由过滤的目的


    小结:filiter-policy 在域内的时候,也就是同一区域的时候可以做到影响路由表的生成,LSA 是依然会学习到的。当在域间使用 filter-policy 进行过滤的时候,可以对路由信息进行过滤

    ospf 的认证

    ospf 认证是封装在 ospf 报文头部的,可以对邻居的建立进行影响,同时提高自己设备的安全性

    在 ospf 报文头部里面有认证字段:

    • 当认证字段的值为 0 时,表示不认证
    • 当认证字段的值为 1 时 ,表示的是使用明文认证
    • 当认证字段的值为 2 时 ,表示的时使用的 MD5 加密认证

    ospf 网络协议详解章节完


    作者:jerry

    展开全文
  • OSPF完全注解

    2020-11-09 16:05:03
    OSPF路由协议OSPF路由协议内部网关协议和外部网关协议OSPF的工作过程OSPF区域区域ID骨干区域Router IDRouter ID选取规则DR和BDR指定路由器(DR)DR和BDR的选举方法OSPF的组播地址OSPF的包类型OSPF启动OSPF网络类型...
  • OSPF两个选举机制

    千次阅读 2018-11-04 00:12:10
    ospf邻接关系建立过程中的两种选举机制 ...自治系统边界路由器(ASBR):至少连接有多个外部自治系统的路由器(使用非ospf的网络协议),将非ospf路由协议信息传进ospf区域内   ①DR/BDR选举 ...
  • 文章目录一、在不同区域二、在同一区域内一、在不同区域1、拓扑2、分析邻居关系正常, 区域内及区域间路由能学到进路由表。如果 R1 和 R3 不引入外部路由的话,是不会出现问题的。因为 ospf 在区域间使用 LSA3,...
  • OSPF链路状态协议

    2020-06-04 16:18:13
    ospf(链路状态路由协议) 文章目录ospf(链路状态路由协议)一、ospf的三种路由器二、链路状态通告(LSA)的6中类型三、区域分类四、ospf的7种...stub一般在配置在末梢区域(后面可以跟在同一area的路由)和完全末梢
  • 华为OSPF路由配置详解教程

    千次阅读 2017-02-27 09:17:24
    一、OSPF的基本功能在同一区域内配置多台交换机时,大多数的配置数据(如定时器、过滤、聚合等)都应该以区域为单位进行统一规划。错误的配置可能会导致相邻交换机之间无法相互传递信息,甚至导致路由信息的阻塞或者...
  • OSPF路由条目的类型

    2019-06-06 10:46:21
    代号描述OOSPF区域内部在同一区域内部的路由通告路由器LSAs以及网络LSAO|AOSPF内部区域在同一自制系统的不同区域的路由通告汇总LSAO E1类型一外部路由区域外部路由通告外部LSAO E2类型二外部路由O E1与O E2中默认...
  • ospf 故障排除思路

    2020-08-08 12:49:41
    broadcasst和nbma接口应该在同一网段。链路两端能ping通。并且区域ID,区域类型应一致。 检查接口优先级是否有非0,broadcast和NBMA需要保证至少接口优先级是非0的,保证能选举出DR,否则只能到2-way状态。使用...
  • 1.在同一区域内实现全网互通。2.在区域1里做NSSA区域。3.在区域2里做虚连接。4.在区域3里做完全stub区域。5.在不同的区域内实现全网互通。三.实验步骤。AR1<Huawei>system-view [Huawei]undo info-center ...
  • OSPF的5种报文和8中状态机 OSPF(Open Shortest Path First):开放式最短路径优先 基于链路状态的内部网关协议,以带宽作为参考/度量 ... router-id作用:用来标识唯一一台运行ospf的设备,并且在同一进程必须保
  • ospf中的三张表

    千次阅读 2010-11-05 21:20:00
    邻居表-----所有的已知的邻居的数据库拓扑表-----包括了在同一区域或网络里的所有路由器以及相关链路的状态信息-------同一区域内的所有路由器都已同样的一样的LSDB路由表----------路由表也叫做转发数据库...
  • OSPF动态路由协议的单区和多区一、OSPF路由协议(一)内部网关协议和外部网关协议(二)ospf工作过程(三)ospf区域三级目录 一、OSPF路由协议 ospf:链路状态路由协议 (一)内部网关协议和外部网关协议 1.AS自治...
  • ospf 理解

    2014-12-29 01:14:00
    from http://kingdee.blog.51cto.com/98119/27310可以把整个网络(一个自治系统AS)看成一个王国,这个王国可以分成几个 区(area),现在我们来看看区域内的某一个人(你所在的机器root)是怎样得到一张 世界地图...
  • 5.主IP地址跟对方的主IP地址需在同一网段(EIGRP可以不用,可以使用辅助地址建邻居) 6.接口子网掩码(多址网络需要一致、点对点链路无需完全一致,只需在同一网段即可) 7.MTU(双发接口的MTU不一致,会卡在...
  • ospf 故事

    2009-08-18 17:58:00
    可以把整个网络(一个自治系统AS)看成一个王国,这个王国可以分成几个区(area),现在我们来看看区域内的某一个人(你所在的机器root)是怎样得到一张世界地图(routing table)的。首先,你得跟你周围的人(同一网段如...
  • 我们知道做路由引入的时候,进入到ospf内部的外部路由都是以五类的lsa进行呈现,...拓扑介绍:A与B属于OSPF区域0,C不启用OSPF,C上配置LOOPBACK0,地址为1.1.1.1/32。A,B,C互联接口地址属于同一网段 192.168.1.0...
  • 文章目录前言一、路由重分发1.理解路由重分发2.路由重分发的考虑3.重分发到OSPF域中路由的路径类型4.路由器有两条到达外部目的网络的路径二、NSSA区域1.NSSA区域OSPF RFC的补遗2....在大型的企业中,可能在同一使
  • OSPF协议入门

    2009-06-08 21:38:25
    1.1. OSPF入门童话 可以把整个网络(一个自治系统AS)看成一个王国,这个王国可以分成b几个区(area),现在我们来看看区域内的某一个人(你所在的机器root)是怎样得到一张世界地图(routing table)的。 首先,你得跟...
  • 区域划分及LSA的种类

    2020-05-18 19:37:45
    内部路由器:所有接口都在同一区域 如R 3 区域边界路由器(ABR):接口属于不同的区域 如R1,R2,R4,R5 骨干路由器:所有的ABR和骨干区域中的内部路由器 AS边界路由器(ASBR):与其它AS相连,引入其他路由协议的...
  • 内部路由器:所有端口在同一区域的路由器,维护一个链路状态数据库。 2. 主干路由器:具有连接主干区域端口的路由器。 3. 区域边界路由器(ABR):具有连接多区域端口的路由器,一般作为一个区域的出口。ABR为每一个...
  • 初识OSPF(三)——路由重分发及虚链路前言一、路由重分发1、理解路由重分发2、路由重分发的考虑3、重分发到OSPF域中路由的路径类型4、配置...在大型的企业中,可能在同一使用到多种路由协议,为了实现多种路由协议
  • OSPF入门童话

    2007-06-20 12:06:02
    OSPF入门童话可以把整个网络(一个自治系统AS)看成一个王国,这个王国可以分成几个 区(area),现在我们来看看区域内的某一个人(你所在的机器root)是怎样得到一张 世界地图(routing table)的。 首先,你得跟你周围的...

空空如也

空空如也

1 2 3
收藏数 50
精华内容 20
关键字:

在同一ospf区域内