精华内容
下载资源
问答
  • 华为交换机常见STP/RSTP操作
    2021-10-26 14:42:00

    开启STP/RSTP
    [HUAWEI] stp enable
    [HUAWEI-GigabitEthernet0/0/1] stp enable
    关闭STP/RSTP
    [HUAWEI] undo stp enable
    [HUAWEI-GigabitEthernet0/0/1] undo stp enable
    配置根桥和备份根桥
    [HUAWEI] stp root primary
    [HUAWEI] stp root secondary
    4.配置根保护
    [HUAWEI-GigabitEthernet0/0/1] stp root-protection
    配置边缘端口
    [HUAWEI-GigabitEthernet0/0/1] stp edged-port enable
    修改STP/RSTP的cost值
    [HUAWEI-GigabitEthernet0/0/1] stp cost 20000
    查看STP/RSTP状态
    <HUAWEI> display stp brief
    查看根桥信息
    <HUAWEI> display stp bridge root


    更多建站及源码交易信息请见 GoodMai

    更多相关内容
  • 交换机怎么配置RSTP协议?一些通讯要求比较严格的行业,一般不允许通讯中断,那么为了防止链路因为某种原因而无法通讯,就需要将其配置成冗余链路,当主链路因为某种原因而断开时,会马上切换到备用链路,下面就...
  • RSTP配置_思科模拟器

    2022-04-11 22:21:30
    项目背景: 配置并分析以下网络拓扑中,各生成树状态。(跟交换机、端口状态、转发路径等) ...三个交换机配置原理相同,故SW2交换机进行配置演示: 第一步:配置接口vlan Switch>en Switch#conf t

    项目背景:

    配置并分析以下网络拓扑中,各生成树状态。(跟交换机、端口状态、转发路径等)

    项目要求&拓扑图:

    在这里插入图片描述
    要求:
    1.采用RSTP配置该项目
    2.SW1成为VLAN10的根交换机,SW2成为VLAN20的根交换机,SW3成为VLAN30的根交换机
    3.各VLAN区域内部之间可以互相通信
    4.各交换机与PC的接口都配置成Portfast

    实搭拓扑图:

    在这里插入图片描述

    具体配置:

    三个交换机配置原理相同,故SW2交换机进行配置演示:

    第一步:配置接口vlan

    Switch>en
    Switch#conf t
    Switch(config)#hostname SW2
    SW2(config)#vlan 10
    SW2(config-vlan)#vlan 20
    SW2(config-vlan)#vlan 30
    SW2(config)#interface range fastEthernet 0/1-9
    SW2(config-if-range)#switchport mode access 
    SW2(config-if-range)#switchport access vlan 10
    SW2(config)#interface range fastEthernet 0/10-15
    SW2(config-if-range)#switchport mode access 
    SW2(config-if-range)#switchport access vlan 20
    SW2(config)#interface range fastEthernet 0/16-20
    SW2(config-if-range)#switchport mode access 
    SW2(config-if-range)#switchport access vlan 30
    SW2(config)#interface range fastEthernet 0/21-24
    SW2(config-if-range)#switchport mode trunk 
    SW2(config)#interface fastEthernet 0/21
    SW2(config-if)#sw mo tr
    SW2(config-if)#ex
    SW2#show interfaces trunk 
    Port Mode Encapsulation Status Native vlan
    Fa0/21 on 802.1q trunking 1
    Fa0/23 on 802.1q trunking 1
    Fa0/24 on 802.1q trunking 1
    
    

    第二步:启用RSTP模式,设置为某vlan的根交换机,与PC连接的接口配置为Portfast

    SW3(config)#spanning-tree mode rapid-pvst
    SW3(config)#spanning-tree vlan 30 root primary 
    SW3(config)#interface range fa0/1-20
    SW3(config-if-range)#spanning-tree portfast
    

    项目完成,项目分析:

    Vlan10生成树:
    根交换机:SW1
    阻塞端口:SW2的fa0/23,fa0/24
    根端口:SW2的fa0/21,SW3的fa0/22
    指定端口:SW1的fa0/21,fa0/22,SW3的fa0/23,fa0/24

    Vlan20生成树:
    根交换机:SW2
    阻塞端口:SW3的fa0/22,fa0/23
    根端口:SW1的fa0/21,SW3的fa0/24
    指定端口:SW1的fa0/22,SW2的fa0/21,fa0/23,fa0/24

    Vlan30生成树:
    根交换机:SW3
    阻塞端口:SW2的fa0/21,fa0/23
    根端口:SW3的fa0/24,SW1的fa0/22
    指定端口:SW3的fa0/22,fa0/23,fa0/24,SW1的fa0/21

    相关概念

    RSTP解决的问题:
    RSTP主要针对STP技术收敛速度过慢的问题,在STP的基础上进行一些协议的优化,提高了收敛速度。
    解决方法

    1. 在RSTP中,端口角色中增加了替代端口和备份端口,分别作为根端口和指定端口的备份端口。当网络链路类型为点对点的链路类型时,如果根端口因网络故障无法转发数据时,替代端口代替根端口能够马上进入转发状态。当指定端口因为故障无法转发数据时,两台交换机通过一次握手的过程,备份端口就能够进入转发状态。从而大大地缩短网络收敛时间。在RSTP中,收敛时间最少可达到1s。但是当链路类型为共享链路时,备份端口进入转发状态仍然要等待两倍的延迟时间。
    2. 同时,为了在拓扑发生变化时,网络中的交换机能够更快地学习到新的链路,交换机直接向网络中扩散TC BPDU报文,而不需要像STP技术中使用TCN预先通知根交换机后,再由根交换机发送TC BPDU。
    3. 对于交换机上连接主机或者服务器的端口,通常可以配置为PortFast端口,PortFast端口UP后将立即过渡到Forwarding状态,而跳过生成树的中间状态,这样端口可以立即对用户数据进行转发。
    展开全文
  • 华三 h3c 交换机RSTP配置

    千次阅读 2020-12-14 11:06:46
    所有的交换机上面启动RSTP,以SWA为例,其它的配置相同 [SWA]stp global enable [SWA]stp mode rstp 这时PC之间是可以ping通的,并且通过dis stp root命令可以查看交换机的根桥和根端口信息,以SWA为例,可知根...

    首先交换机都是缺省配置,各端口都属于vlan1,pc虽然都是在同一网段,但是由于广播风暴,两者无法ping通。

    在所有的交换机上面启动RSTP,以SWA为例,其它的配置相同

    [SWA]stp global enable

    [SWA]stp mode rstp

    这时PC之间是可以ping通的,并且通过dis stp root命令可以查看交换机的根桥和根端口信息,以SWA为例,可知根桥id为32768.5025-06ea-0300(交换机的根桥id具体与实际为准),根端口是GE1/0/23。

    [SWA]dis stp root

     MST ID   Root Bridge ID        ExtPathCost IntPathCost Root Port

     0        32768.5025-06ea-0300  40          0           GE1/0/23

     

    继续查看其它的交换机,会发现有一台交换机没有根端口,那它就是网络中的根桥。我这里是SWD为根桥

    用dis stp brief可以查看交换机各端口的stp状态以为端口角色,以SWA为例,0/23端口为根端口,处于转发状态,0/24端口为Alternate端口,处于阻塞状态。

    [SWA]dis stp brief

     MST ID   Port                                Role  STP State   Protection

     0        GigabitEthernet1/0/23               ROOT  FORWARDING  NONE

     0        GigabitEthernet1/0/24               ALTE  DISCARDING  NONE

      通过修改交换机的桥优先级,指定网络中的某台交换机为网络中的根桥,这里使用stp priority 0设置SWA桥优先级为0,查看此时根桥信息,SWA成为了根桥

     

     

      通过修改端口开销,可以影响交换机端口的角色。命令为:

    [SWD]int g 1/0/23

    [SWD-GigabitEthernet1/0/23]stp cost 400

    具体修改哪一台交换机的端口,自己根据需要修改

    RSTP的收敛速度要比STP要快,具体体现之一就是可以把主机与交换机互联的端口配置为边缘端口,可以省两个Forward Delay时间直接进去Forwarding状态,没有延迟。

    [SWC]int g 1/0/1----------与PCB连接的端口

    [SWC-GigabitEthernet1/0/1]stp edged-port---------设置为边缘端口

    [SWA]int g 1/0/1---------与PCA连接的端口

    [SWA-GigabitEthernet1/0/1]stp edged-port

     

    展开全文
  • group 3 mode on sw01(config-if-range)# sw01(config-if-range)#end sw01# %SYS-5-CONFIG_I: Configured from console by console sw01#show spanning-tree VLAN0001 Spanning tree enabled protocol rstp Root ID ...

    拓扑:
    在这里插入图片描述

    1、为sw01、sw02、sw03设置生成树协议

    sw01(config)#spanning-tree mode rapid-pvst
    sw02(config)#spanning-tree mode rapid-pvst
    sw03(config)#spanning-tree mode rapid-pvst

    2、设置端口聚合(省略了一些无用的输出)

    1)sw01
    sw01(config)#interface port-channel 1
    sw01(config-if)#interface range f0/1-2
    sw01(config-if-range)#switchport mode trunk
    sw01(config-if-range)#
    sw01(config-if-range)#channel-group 1 mode on
    sw01(config-if-range)#
    sw01(config-if-range)#exit
    sw01(config)#interface port-channel 3
    sw01(config-if)#interface range f0/5-6
    sw01(config-if-range)#switchport mode trunk
    
    sw01(config-if-range)#
    sw01(config-if-range)#channel-group 3 mode on
    sw01(config-if-range)#
    sw01(config-if-range)#end
    sw01#
    %SYS-5-CONFIG_I: Configured from console by console
    
    sw01#show spanning-tree 
    VLAN0001
      Spanning tree enabled protocol rstp
      Root ID    Priority    32769
                 Address     0002.164A.39E2
                 This bridge is the root
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
                 Address     0002.164A.39E2
                 Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time  20
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Po1              Desg FWD 9         128.27   Shr
    Po3              Desg FWD 9         128.28   Shr
    
    sw01#show etherchannel sum
    sw01#show etherchannel summary 
    Flags:  D - down        P - in port-channel
            I - stand-alone s - suspended
            H - Hot-standby (LACP only)
            R - Layer3      S - Layer2
            U - in use      f - failed to allocate aggregator
            u - unsuitable for bundling
            w - waiting to be aggregated
            d - default port
    
    
    Number of channel-groups in use: 2
    Number of aggregators:           2
    
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+----------------------------------------------
    
    1      Po1(SU)           -      Fa0/1(P) Fa0/2(P) 
    3      Po3(SU)           -      Fa0/5(P) Fa0/6(P) 
    
    2)sw02

    (忘记保存项目了,只剩之前的截图)
    在这里插入图片描述

    3)sw03
    Switch>en
    Switch#conf t
    Enter configuration commands, one per line.  End with CNTL/Z.
    Switch(config)#hostname sw03
    sw03(config)#spann
    sw03(config)#spanning-tree mode ra
    sw03(config)#spanning-tree mode rapid-pvst 
    sw03(config)#
    sw03(config)#interface port-channel 2
    sw03(config-if)#interface range f0/3-4
    sw03(config-if-range)#switchport mode trunk
    sw03(config-if-range)#
    sw03(config-if-range)#channel-grou
    sw03(config-if-range)#channel-group 2 mode on
    sw03(config-if-range)#exit
    sw03(config)#interface port-channel 3
    sw03(config-if)#interface range f0/5-6
    sw03(config-if-range)#switchport mode trunk
    sw03(config-if-range)#channel-grou
    sw03(config-if-range)#channel-group 3 mode on
    sw03(config-if-range)#end
    sw03#show etherchannel summ
    sw03#show etherchannel summary 
    Flags:  D - down        P - in port-channel
            I - stand-alone s - suspended
            H - Hot-standby (LACP only)
            R - Layer3      S - Layer2
            U - in use      f - failed to allocate aggregator
            u - unsuitable for bundling
            w - waiting to be aggregated
            d - default port
    
    
    Number of channel-groups in use: 2
    Number of aggregators:           2
    
    Group  Port-channel  Protocol    Ports
    ------+-------------+-----------+----------------------------------------------
    
    2      Po2(SU)           -      Fa0/3(P) Fa0/4(P) 
    3      Po3(SU)           -      Fa0/5(P) Fa0/6(P) 
    

    3、配置vlan10、vlan20、vlan30,pc的ip

    1)sw01
    sw01>en
    sw01#conf t
    sw01(config)#vlan 10
    sw01(config-vlan)#interface f0/11
    sw01(config-if)#switchport mode access
    sw01(config-if)#switchport access vlan 10
    sw01(config-if)#exit
    sw01(config)#vlan 30
    sw01(config-vlan)#interface f0/10	
    sw01(config-if)#switchport mode access
    sw01(config-if)#switchport access vlan 30
    sw01(config-if)#end
    sw01#
    
    2)sw02
    sw02>en
    sw02#conf t
    sw02(config)#vlan 10
    sw02(config-vlan)#interface f0/11
    sw02(config-if)#switchport mode access
    sw02(config-if)#switchport access vlan 10
    sw02(config-if)#exit
    sw02(config)#vlan 20
    sw02(config-vlan)#interface f0/10	
    sw02(config-if)#switchport mode access
    sw02(config-if)#switchport access vlan 20
    sw02(config-if)#end
    sw02#
    
    3)sw03
    sw03>en
    sw03#conf t
    sw03(config)#vlan 20
    sw03(config-vlan)#interface f0/10
    sw03(config-if)#switchport mode access
    sw03(config-if)#switchport access vlan 20
    sw03(config-if)#exit
    sw03(config)#vlan 30
    sw03(config-vlan)#interface f0/11	
    sw03(config-if)#switchport mode access
    sw03(config-if)#switchport access vlan 30
    sw03(config-if)#end
    sw03#show vlan
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Fa0/1, Fa0/2, Fa0/7, Fa0/8
                                                    Fa0/9, Fa0/12, Fa0/13, Fa0/14
                                                    Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                    Fa0/23, Fa0/24, Gig0/1, Gig0/2
    20   VLAN0020                         active    Fa0/10
    30   VLAN0030                         active    Fa0/11
    1002 fddi-default                     act/unsup 
    1003 token-ring-default               act/unsup 
    1004 fddinet-default                  act/unsup 
    1005 trnet-default                    act/unsup 
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    20   enet  100020     1500  -      -      -        -    -        0      0
    30   enet  100030     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0   
    1003 tr    101003     1500  -      -      -        -    -        0      0   
    
    sw03#
    

    上面都需要配置一步:
    no spanning-tree vlan 10
    no spanning-tree vlan 20
    no spanning-tree vlan 30

    4、配置流量均衡

    port-channel load-balance method
    源地址src-ip
    目的地址 dst-ip
    源和目的地址 src-dst-ip
    源mac地址 src-mac
    目的mac地址 dst-mac
    源和目的mac src-dst-mac

    所以配置SW01基于源MAC地址,SW02基于目的MAC地址:

    Sw01(config)#port-channel load-balance src-mac Sw02(config)#port-channel load-balance dst-mac

    5、测试截图

    Vlan 10里的PC5 ping PC0
    在这里插入图片描述

    Vlan 10里的PC5 ping vlan 20里的PC1
    在这里插入图片描述

    展开全文
  • 一个完整的锐捷交换机RSTP配置试验。对于理解stp/RSTp工作原理比较有用
  • 建立了一个计算机教室和一个校办公区,这两处 的计算机网络通过两台交换机互联组成内部校园网,为了提高网络的可靠性,网络管理员用两条链路将交换机互联,现要在交换机上做适当配置,使网络避免环路。本实验以两台...
  • RSTP协议原理与配置

    千次阅读 2020-06-23 23:26:05
    RSTP协议原理与配置 前言:STP生成树协议虽然能够解决环路的问题,但是存在着网络拓扑收敛较慢,无法适应网络拓扑结构的频繁变化等缺点,基于以上不足,IEEE2001年发布的802.1w标准定义了RSTP(快速生成树协议)。 ...
  • 收敛较慢,对于用户来说,listening\Learing\blocking状态没有区别,都不转发流量,根据STP的不足,RSTP做出了改进.RSTP增加了两种端口角色,端口角色一共有4种,根端口\指定端口\alternate端口\backup端口.,根端口...
  • 关于交换机RSTP的基础知识

    千次阅读 2019-06-16 00:26:27
    STP针对网络拓扑发生变化的处理方式: 当网络拓扑发生的变化时,最先发现的交换机会往根桥的方向发送TCN(网络拓扑变更通告),收到TCN的上游交换机会回复TCA,然后继续往根桥的方向发送TCN,根桥会...一、RSTP --...
  • 生成树协议利用的是 SPA算法,存在交换环路的网络中生成一个没有环路的树形网络,运用该算法将交换网络的冗余备份链路从逻辑断开,当主线路出现故障时,能够自动的切换到备份链路,保证数据的正常转发。...
  • H3C_STP_RSTP_MSTP协议原理及配置。。。。。。。。。。。。。。。。。
  • RSTP基础配置

    千次阅读 2020-03-03 14:31:03
    RSTP基础配置 原理低述 IEEE于2001年发布的802.1标准定义了RSTP (Rupid Spanning-Tree Pocol, 快速生成树协议)。该协议基于STP协设。对原有的STP协谈进行了更加细数的修改 和补充。 STP协议风然能够解决环路问题。...
  • RSTP配置

    2022-04-27 20:21:35
    根据一个博客关于“STP的配置”中可知,当链路故障时,STP恢复连通性的时间30s以上,这是一个相当慢的收敛时间。由于收敛速度慢,目前现网中,人们已经基本不会再使用STP,而是会使用STP的升级版,快速生成...
  • 华为 配置RSTP预防环路

    千次阅读 多人点赞 2018-06-19 16:27:00
    一、组网需求1、一个复杂的网络中,...网络规划者规划好网络后,可以网络中部署RSTP协议预防环路。当网络中存在环路,RSTP通过阻塞某个端口以达到破除环路的目的。如图所示,当前网络中存在环路,SwitchA、Sw...
  • 实例拓扑如下: 当接入交换机到Core-1的线路故障,可以切换到Core-2线路 配置Core-1作为根桥 Configure Core-1 to be elected the root bridge by giving it the lowest priority value....在交换机开启STP Core-1 ...
  • SWA、SWB和SWC组成了一个环形的交换网络,为了消除环路对网络的影响,故使交换机都运行RSTP,最终将环形网络结构修剪成无环路的树形网络结构。 RSTP配置实现 配置实现: stp enable //全局开启STP stp mode rstp //...
  • 华为rstp配置实例

    千次阅读 多人点赞 2019-08-18 11:07:07
    配置RSTP功能示例 组网需求 一个复杂的网络中,网络规划者由于冗余备份的需要,一般都倾向于设备之间部署多条物理链路,其中一条作主用链路,其他链路作备份。这样就难免会形成环形网络,若网络中存在环路,...
  • RSTP实验说明指导

    2011-10-24 18:29:51
    实验五 RSTP ...2、启用两台交换机RSTP、并设置sw1为根交换机、F0/2为指定端口和根端口 SW1: sw1(config)#spanning tree sw1(config)#spanning tree mode RSTP sw1(config)#spanning tree priority 4096
  • 这是前几年通过一个项目的测试总结出来...每个互连以太网接口启动STP协议。 两边设备通过CLI察看STP的状态,直到每个STP的状态都显示为正常。 拔插相应以太网端口,观察STP拓扑的变化情况。 3、STP相关配置 Br
  • 一、配置需求 需求来自一名粉丝作业实验的在线指导技术答疑 1、通过生成树配置实现阻塞特定的端口实现流量...四台接入交换机SW统一配置创建相同的VLAN vlan batch 10 20 30 40//创建4个VLAN interface GigabitEt.
  • STP是用来避免数据链路层出现逻辑环路的协议...STP通过BPDU信息的交互,选举根交换机,然后每台非根交换机选择用来与根交换机通信的根端口,之后每个网段选择用来转发数据至根交换机的指定端口,最后剩余端口则被阻塞。
  • RSTP实验配置

    千次阅读 2019-12-24 20:29:28
    掌握RSTP的基本配置 掌握RSTP的边缘端口的应用 理解RSTP备份端口 实验内容   S3和S4是接入层交换机,负责用户的接入,S1和S2是汇聚层交换机,四台交换机组成一个环形网络。为了防止网络中出现环路,产生网络风暴...
  • 华为交换机配置acl规则

    千次阅读 2021-08-13 10:15:50
    华为交换机配置acl规则 1、实验拓扑 2、设备IP配置 3、基础环境组网配置 进入核心交换机 system-view [Huawei]sysname jigui-sw [jigui-sw]vlan batch 10 20 30 [jigui-sw]interface GigabitEthernet 0/0/1 [jigui...
  • 交换机RSTP配置时,出现了如何选举指定端口的问题,应该怎么选举指定端口,以及在交换机里面如何改变交换机的RPC的值,我尝试修改过端口的开销值,但是依旧不能把两个交换机之间的端口互相交换,不知道应该这么...
  • 锐捷网络交换机配置命令大全

    千次阅读 2021-05-25 10:13:18
    【欢迎关注微信公众号:厦门微思网络】 关注我,你的眼睛会怀孕 基本配置 >... #del flash:config.text 删除配置文件(交换机及1700系列路由器) #erase startup-config 删除配置文件...
  • 一、实验目的 掌握中兴三层交换机STP的基本配置和维护操作。...请两台交换机存在环路的情况下配置STP,并修改相应的参数值后进行结果验证。 图1-1 三层交换机STP配置实验 2、业务配置流程图 图1-2 三层交换机

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,120
精华内容 1,248
关键字:

在交换机上配置rstp

友情链接: Clock.rar