精华内容
下载资源
问答
  • 当三层交换机之间采用多条链路连接时,接口又会被STP阻塞,所以需要利用以太网通道技术channel(Cisco设备)或以太网中继技术Eth-Trunk(华为设备),将交换机之间的多个接口逻辑地整合为一个接口,实现带宽叠加的...

    网络三层架构

    核心层: 路由器
    汇聚层: 三层交换机
    接入层: 二层交换机、PC端

    以太网通道技术(以太网中级技术)

    三层交换机既具有路由功能又具有交换功能。根网桥、网关、汇聚层三个角色重叠,一般被汇聚层三层交换机担任。因此三层交换机间的带宽较高。当三层交换机之间采用多条链路连接时,接口又会被STP阻塞,所以需要利用以太网通道技术channel(Cisco设备)或以太网中继技术Eth-Trunk(华为设备),将交换机之间的多个接口逻辑地整合为一个接口,实现带宽叠加的作用。

    实例:

    拓扑:

    配置前提:
    ①通道的对端必须为同一设备;
    ②通道的所有接口应该具有相同的速率、类型、双工模式以及相同的VLAN允许列表。

    具体配置:
    【SW1】【SW2】相同配置
    interface Eth-Trunk 0 //创建通道接口
    q
    interface g0/0/1
    eth-trunk 0 //将物理接GE 0/0/1 口加入通道接口内
    interface g0/0/2
    eth-trunk 0 //GE 0/0/2 同理

    查看接口列表:

    在VLAN 1中G0/0/1接口和G0/0/2接口也合为了Eth-Trunk 0:

    在后续的配置中,大部分接口的配置不能将G0/0/1和G0/0/2分开来配置,而需要对Eth-Trunk 0进行配置,因为它们在逻辑上以及成为了同一个接口了。Cisco设备命令为channel-group ? mode on。

    二层网通道

    负载分担
    不同的流量,基于不同的链路传输。
    区别于负载均衡,相同的流量基于不同的链路传输。

    配置命令:
    [sw1-Eth-Trunk0]load-balance ? //基于流的选择
    ​ dst-ip According to destination IP hash arithmetic
    ​ dst-mac According to destination MAC hash arithmetic
    ​ src-dst-ip According to source/destination IP hash arithmetic
    ​ src-dst-mac According to source/destination MAC hash arithmetic
    ​ src-ip According to source IP hash arithmetic
    ​ src-mac According to source MAC hash arithmetic //推荐基于源MAC

    [sw1-Eth-Trunk0]load-balance { ip | packet-all } //修改基于流或包

    三层通道

    成为通道的所有物理链路必须先成为三层接口,三层通道的意义在于将多个需要IP地址的接口逻辑为一个接口,配置一个IP地址即可。

    配置命令:
    [SW]int Eth-Trunk 0
    [SW-Eth-Trunk 0]undo portswitch //切换为三层接口
    [SW-Eth-Trunk 0]ip ad 192.168.1.1 24 //配IP
    [SW]port-group group-member g0/0/1 to g0/0/2
    [SW-Port-Group]eth-trunk 0

    管理VLAN(SVI)

    接入层交换机,即二层交换机,一般有一个SVI(交换虚拟)接口,该接口烧录有MAC地址,可以进行IP地址配置。常规二层交换机仅存在一个SVI接口,三层交换机支持多个SVI接口,所有的SVI可以共存。

    实例:

    华为设备配置

    拓扑:

    配置:
    (1)在SW1上启用SVI接口:
    【SW1】
    display ip interface brief
    //可以看到接口列表最下面有个一名为Vlanif1的接口,该接口就是SVI接口,默认在VLAN1中:

    interface Vlanif1
    ip address 192.168.1.1 24

    (2)给PC1配IP:
    【PC1】
    给PC1手动配上IP地址:

    此时,PC1已经可以ping通SW1的SVI接口了:

    (3)在SW1上开启Telnet:
    【SW1】
    aaa //开启aaa认证
    local-user a privilege level 15 password cipher huawei //添加用户密码
    local-user a service-type telnet //指定用户服务类型
    q
    user-interface vty 0 4 //进vty线调用
    authentication-mode aaa //认证模式aaa

    (4)远程登陆SW1测试(华为的普通PC不支持远程登录),此处使用Router代替PC端:

    Cisco设备配置

    拓扑:

    配置:
    (1)在SW1上启用SVI接口:
    【SW1】
    enable
    show ip interface brief
    //可以看到接口列表最下面有一个名为Vlan1的接口,该接口就是SVI接口,默认在VLAN 1中:

    configure terminal //进入配置模式
    interface vlan1 //进入Vlan1接口
    ip address 192.168.1.1 255.255.255.0 //给Vlan1接口配IP地址
    no shutdown //开启接口

    (2)给PC0配IP:
    【PC0】
    给PC0手动配上IP地址:

    此时,PC0已经可以ping通SW1的SVI接口了:

    (3)在SW1上启用Telnet:
    【SW1】
    interface terminal
    username a privilege 15 secret cisco //添加账号密码
    line vty 0 4 //进vty线调用
    login local //登陆本地
    在PC0上远程登录SW1:
    【PC0】

    修改SVI所在VLAN

    当需要更换SVI所在VLAN时,只需要直接创建对应VLAN接口即可,一般二层交换机创建新的VLAN接口(SVI接口),旧的SVI接口会自动关闭,因为二层交换机只允许一个SVI存在。

    若其它网段设备需要访问SVI接口,则需要在SVI接口上定义网关或写缺省路由,否则数据有去无回。

    配置命令:

    Cisco switch: ip default gateway 192.168.2.254

    华为LSW: ip route-static 0.0.0.0 0.0.0.0 192.168.2.254
    写缺省与定义网关同理。

    三层交换机

    三层交换机在汇聚层扮演着路由器和交换机的角色,不同情况下功能不同。

    实例:

    拓扑:

    配置:
    将三层交换机上的接口设置为三层接口:
    【SW1】
    enable
    configure terminal
    int f0/1
    no switchport //二层接口变为三层接口
    ip ad 192.168.1.254 255.255.255.0 //给接口配IP地址
    end
    int f0/2
    no switchport //二层接口变为三层接口
    ip ad 192.168.2.254 255.255.255.0 //给接口配IP地址
    end
    ip routing //开启三层交换机的路由功能
    end
    show ip route
    //可查看路由表:

    给两个PC端配置不同网段IP地址后仍可以ping通,因为此时三层交换机具有了路由功能:

    因此三层交换机还解决了单臂路由较多子接口的缺陷。

    网关冗余

    HSRP协议(Cisco私有)

    热备份路由协议,工作原理:汇聚层作为网关的两个设备组成HSRP组,主备设备相互保活,并虚拟出一个的MAC地址与IP地址作为接入层设备的网关。主设备正常工作时,除拥有自己真实IP与MAC外,还具有虚拟IP与MAC,充当接入层设备网关。当主设备出现故障时,备份设备则继承虚拟IP与MAC,继续充当为接入层设备的网关。接入层设备只需要定义虚拟IP为网关,不受网关设备变更的影响。

    VRRP协议(公有)

    虚拟路由冗余协议,工作原理同HSRP协议。

    区别(在HSRP上的改进)

    ①支持多设备;
    ②仅主设备发送保活包(Hello),组播更新(224.0.0.18,TTL=1)周期为1s;
    ③可以使用物理接口的IP地址来作为网关,即不再虚拟出IP,只虚拟出MAC,但此时该物理接口必须当主(优先级变为最大值255),否则会出现主备设备同时回给接入层设备ARP的情况;
    ④抢占默认开启;
    ⑤Hold time为3s,切换速度快;
    ⑥支持上行链路追踪,在主设备下行链路断开时,会自动切换到备设备,但在上行链路断开时,由于在网关冗余技术中使用的是虚拟IP地址,ICMP重定向失效,所以在上行链路断开时,网关依然不会切换。此时,可以定义上行链路追踪(前提是抢占开启,且两台设备的优先级差值小于下调值),当主设备上行链路断开时,主设备自动下调优先级(主将网关让给备)。若本地存在多条上行或下行链路时,建议在配置时下调值之和略大于优先级差值,当上行链路全部断开时,才让备份设备抢占网关,下行链路大部分断开时,让出网关。

    选举规则

    在主设备故障后,多个备份设备间进行选举,先比较优先级,默认值为100,大者优;再比较接口IP地址,大者优。

    实例

    拓扑:

    具体配置:
    (1)三层配IP:
    【R1】
    int lo 0
    ip ad 1.1.1.1 24
    int g0/0/0
    ip ad 12.1.1.1 24
    int g0/0/1
    ip ad 23.1.1.1 24
    【R2】
    int g0/0/0
    ip ad 12.1.1.2 24
    int g0/0/1
    ip ad 10.1.1.1 24
    【R3】
    int g0/0/0
    ip ad 23.1.1.2 24
    int g0/0/1
    ip ad 10.1.1.3 24

    (2)R1-3运行动态路由协议OSPF
    【R1】
    ospf 1 router-id 1.1.1.1
    area 0
    network 1.1.1.1 0.0.0.0
    network 12.1.1.1 0.0.0.0
    network 23.1.1.1 0.0.0.0
    【R2】
    ospf 1 router-id 2.2.2.2
    area 0
    network 12.1.1.2 0.0.0.0
    network 10.1.1.1 0.0.0.0
    【R3】
    ospf 1 router-id 3.3.3.3
    area 0
    network 23.1.1.2 0.0.0.0
    network 10.1.1.3 0.0.0.0

    (3)开启VRRP:
    【R2】【R3】相同配置
    int g0/0/1
    vrrp vrid 1 virtual-ip 10.1.1.254 //VRRP组名为1,虚拟出IP地址10.1.1.254,MAC地址会自动生成
    display vrrp //查看vrrp:

    发现在优先级默认为100的情况下,按选举方式应该是IP地址较大的R3的G0/0/1接口抢占到主,但由于R2的G0/0/1先配置VRRP,所以R2的接口先抢到了主。

    (4)开启上行链路追踪:
    【R2】【R3】相同配置
    int g0/0/1
    vrrp vrid 1 track interface g0/0/0 reduce 10 //当上行链路断开,设备的优先级降10(默认值),即从100降到90,也就让出了网关

    结果测试:
    此时PC1可以ping通1.1.1.1且中途断关掉R2的G0/0/1接口,在一段时间后也会自动恢复通路:

    负载分担模式:

    负载分担模式不常用,不适用于三层架构,因为正常三层架构存在生成树,不同VLAN下根网桥位置不同,部分接口阻塞,负载分担模式可能导致接入层访问网关绕路,反而成为了累赘。因此建议在直接使用路由器作网关时考虑负载分担方式。

    展开全文
  • 报警、串口使用、主干(TrunkingTM)冗余、环网冗余、服务质量(QoS)、虚拟局域网(VLAN)、简单网络管理协议(SNMP)、端口镜像等其他工业以太网管理型交换机中可以提供的功能。控制工程师们可以根据自己的要求...

    由于工业环境对工业控制网络可靠性能的超高要求,工业以太网的冗余功能应运而生。从快速生成树冗余(RSTP)、环网冗余(RapidRing)到主干冗余(Trunking),都有各自不同的优势和特点。报警、串口使用、主干(TrunkingTM)冗余、环网冗余、服务质量(QoS)、虚拟局域网(VLAN)、简单网络管理协议(SNMP)、端口镜像等其他工业以太网管理型交换机中可以提供的功能。控制工程师们可以根据自己的要求进行选择,为了更好地帮助大家了解和学习工业以太网冗余技术的特点,接下来就由飞畅科技的小编来为大家普及下以太网设备的发展过程。

    集线器
    相信绝大多数人都熟悉集线器。很多人使用这种简易设备去连接各种基于以太网的设备,如个人计算机、可编程控制器等。集线器接收到来自某一端口的消息,再将消息广播到其他所有的端口。

    对来自任一端口的每一条消息,集线器都会把它传递到其他的各个端口。在消息传递方面,集线器是低速低效的,可能会出现消息冲突。然而,集线器的使用非常简单——实际上可以即插即用。集线器没有任何华而不实的功能,也没有冗余功能。

    非管理型交换机
    集线器的发展产生了一种叫非管理型交换机的设备。它能实现消息从一个端口到另一个端口的路由功能,相对集线器更加智能化。非管理型交换机能自动探测每台网络设备的网络速度。另外,它具有一种称为“MAC地址表”的功能,能识别和记忆网络中的设备。

    换言之,如果端口2收到一条带有特定识别码的消息,此后交换机就会将所有具有那种特定识别码的消息发送到端口2。这种智能避免了消息冲突,提高了传输性能,相对集线器是一次巨大的改进。然而,非管理型交换机不能实现任何形式的通信检测和冗余配置功能。

    管理型交换机
    以太网连接设备发展的下一代产品是管理型交换机。相对集线器和非管理型交换机,管理型交换机拥有更多更复杂的功能,价格也高出许多——通常是一台非管理型交换机的3~4倍。管理型交换机提供了更多的功能,通常可以通过基于网络的接口实现完全配置。它可以自动与网络设备交互,用户也可以手动配置每个端口的网速和流量控制。一些老设备可能无法使用自动交互功能,因此手动配置功能是必不可缺的。

    绝大多数管理型交换机通常也提供一些高级功能,如用于远程监视和配置的SNMP(简单网络管理协议),用于诊断的端口映射,用于网络设备成组的VLAN(虚拟局域网),用于确保优先级消息通过的优先级排列功能等。利用管理型交换机,可以组建冗余网络。使用环形拓扑结构,管理型交换机可以组成环形网络。每台管理型交换机能自动判断最优传输路径和备用路径,当优先路径中断时自动阻断备用路径。

     

    管理型冗余交换机
    高级的管理型冗余交换机提供了一些特殊的功能,特别是针对有稳定性、安全性方面严格要求的冗余系统进行了设计上的优化。构建冗余网络的主要方式主要有以下几种,STP、RSTP;环网冗余RapidRing

    1.STP及RSTP
    STP(Spanning Tree Protocol,生成树算法,IEEE 802.1D),是一个链路层协议,提供路径冗余和阻止网络循环发生。它强令备用数据路径为阻塞(blocked)状态。如果一条路径有故障,该拓扑结构能借助激活备用路径重新配置及链路重构。网络中断恢复时间为30~60s之间。RSTP(快速生成树算法,IEEE 802.1w)作为STP的升级,将网络中断恢复时间,缩短到1~2s。生成树算法网络结构灵活,但也存在恢复速度慢的缺点。

    2.环网冗余RapidRing
    为了能满足工业控制网络实时性强的特点,RapidRing孕育而生。这是在以太网网络中使用环网提供高速冗余的一种技术。这个技术可以使网络在中断后300ms之内自行恢复。并可以通过交换机的出错继电连接、状态显示灯和SNMP设置等方法来提醒用户出现的断网现象。这些都可以帮助诊断环网什么地方出现断开。

    RapidRing也支持两个连接在一起的环网,使网络拓朴更为灵活多样。两个环通过双通道连接,这些连接可以是冗余的,避免单个线缆出错带来的问题。

    3.主干冗余Trunking
    将不同交换机的多个端口设置为Trunking主干端口,并建立连接,则这些交换机之间可以形成一个高速的骨干链接。不但成倍的提高了骨干链接的网络带宽,增强了网络吞吐量,而且还还提供了另外一个功能,即冗余功能。

    如果网络中的骨干链接产生断线等问题,那么网络中的数据会通过剩下的链接进行传递,保证网络的通讯正常。Trunking主干网络采用总线型和星型网络结构,理论通讯距离可以无限延长。该技术由于采用了硬件侦测及数据平衡的方法,所以使网络中断恢复时间达到了新的高度,一般恢复时间在10ms以下。

    总结:不同的控制系统对网络的管理功能要求不同,自然对管理型交换机的使用也有不同要求。控制工程师们应该根据其系统的设计要求,挑选适合自己系统的工业以太网产品。

    好了,以上就是关于工业以太网交换机的冗余功能及发展历程的相关详解,希望能对你有所帮助!飞畅科技20年专业从事光端机、工业级交换机、光纤收发器、协议转换器等工业通信设备的研发、生产和销售。欢迎前来了解、交流。

    了解更多请浏览:http://www.futuretel.com.cn/

    展开全文
  • 本文对交换机端口汇聚配置进行说明

    配置思科交换机冗余链路汇聚

     


    一、端口聚合技术(EtherChannel)

    EtherChannel是Cisco研发的,应用于交换机之间的多链路捆绑技术。

    EtherChannel的基本原理和作用是:

    1.增加带宽

    将两个设备间多条相同特性的快速以太或千兆物理链路捆绑在一起组成一条逻辑链路,从而达到带宽倍增的目的。

    2.链路冗余

    除了增加带宽外,EtherChannel还可以在多条链路上均衡分配流量,起到负载均衡的作用;当一条或多条链路故障时,只要还有链路正常,流量将转移到其他的链路上,整个过程在几毫秒内完成,从而起到链路冗余的作用,增强了网络的稳定性和安全性。在EtherChannel中,负载在各个链路上的分布可以根据源IP地址、目的IP地址、源MAP地址、目的MAC地址、源IP地址和目的IP地址组合,以及源MAC地址和目的MAC地址组合等来进行分布。


    二、端口汇聚协议

    两台交换机之间是否形成EtherChannel也可以采用协议自动协商。

    目前有两种PAgP(端口汇聚协议)和LACP(链路汇聚控制协议)协商协议。

    PAgP(端口汇聚协议,Port Aggregation Protocol)是Cisco的私有协议。

    LACP(链路汇聚控制协议,Link Aggregation Protocol)是基于IEEE802.3ad的国际标准。


    三、链路汇聚语法

    channel-group+编号+mode+auto/on/desirable

    其中,auto:被动协商,on:不协商,desirable:主动协商。


    四、配置冗余链路汇聚

    1.创建和定义port-channel端口

    swtich-core#config terminal

    swtich-core(config)#interface prot-channel 10

    swtich-core(config-if)#no switchport

    2.分配ip地址

    swtich-core(config-if)#ip address 192.168.102.1 255.255.255.0

    swtich-core(config-if)#no shutdown

    swtich-core(config-if)#exit

    4.分配端口,并启用端口汇聚

    swtich-core(config)#interface range fastEthernet 0/1-4

    swtich-core(config-if-range)#no switchport

    swtich-core(config-if-range)#no ip address

    swtich-core(config-if-range)#channel-group 10 mode on

    swtich-core(config-if-range)#no shutdown

    swtich-core(config-if-range)#exit

    5.添加路由

    swtich-core(config)#ip route 192.168.40.0 255.255.255.0 192.168.102.2

    展开全文
  • 链路聚合、冗余、堆叠、热备份等这些功能,这些功能非常重要,决定了核心交换机在实际应用中的性能、效率、稳定性等,我们一起来了解下。一、链路聚合是将两个或更多数据信道结合成一...
    链路聚合、冗余、堆叠、热备份等这些功能,这些功能非常重要,决定了核心交换机在实际应用中的性能、效率、稳定性等,我们一起来了解下。

    一、链路聚合

    是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。链路聚合一般用来连接一个或多个带宽需求大的设备,例如连接骨干网络的服务器或服务器群。它可以用于扩展链路带宽,提供更高的连接可靠性。

    1、举例

    公司有2层楼,分别运行着不同的业务,本来两个楼层的网络是分开的,但都是一家公司难免会有业务往来,这时我们就可以打通两楼之前的网络,使具有相互联系的部门之间高速通信。

    如下图:

    640?wx_fmt=png

    如上图所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

    创建Eth-Trunk接口并加入成员接口,实现增加链路带宽,2台交换机分别配置Eth-Trunk1 分别将需要通信的3条线路的端口加入Eth-Trunk1,设置端口trunk, 允许相应的vlan通过;这样两楼的网络就可以正常通信了。

    2、实现配置步骤:

    在SwitchA上创建Eth-Trunk1并配置为LACP模式。SwitchB配置过程与SwitchA类似,不再赘述<HUAWEI> system-view[HUAWEI] sysname SwitchA[SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] mode lacp[SwitchA-Eth-Trunk1] quit配置SwitchA上的成员接口加入Eth-Trunk。SwitchB配置过程与SwitchA类似,不再赘述[SwitchA] interface gigabitethernet 0/0/1[SwitchA-GigabitEthernet0/0/1] eth-trunk 1[SwitchA-GigabitEthernet0/0/1] quit[SwitchA] interface gigabitethernet 0/0/2[SwitchA-GigabitEthernet0/0/2] eth-trunk 1[SwitchA-GigabitEthernet0/0/2] quit[SwitchA] interface gigabitethernet 0/0/3[SwitchA-GigabitEthernet0/0/3] eth-trunk 1[SwitchA-GigabitEthernet0/0/3] quit在SwitchA上配置系统优先级为100,使其成为LACP主动端[SwitchA] lacp priority 100在SwitchA上配置活动接口上限阈值为2[SwitchA] interface eth-trunk 1[SwitchA-Eth-Trunk1] max active-linknumber 2[SwitchA-Eth-Trunk1] quit在SwitchA上配置接口优先级确定活动链路[SwitchA] interface gigabitethernet 0/0/1[SwitchA-GigabitEthernet0/0/1] lacp priority 100[SwitchA-GigabitEthernet0/0/1] quit[SwitchA] interface gigabitethernet 0/0/2[SwitchA-GigabitEthernet0/0/2] lacp priority 100[SwitchA-GigabitEthernet0/0/2] quit

    二、链路冗余

    为了保持网络的稳定性,在多台交换机组成的网络环境中,通常都使用一些备份连接,以提高网络的效率、稳定性,这里的备份连接也称为备份链路或者冗余链路。

    三、交换机的堆叠

    通过专有的堆叠电缆连接起来,可将多台交换机堆叠成一台逻辑交换机。 该逻辑交换机中的所有交换机共享相同的配置信息和路由信息。当向逻辑交换机增加和减少单体交换机时不会影响其性能。

           叠加的交换机之间通过两条环路连接起来。交换机的硬件负责将数据包在双环路上做负载均衡。环路在这里充当了这个大的逻辑交换机的背板的角色,在双环路都正常工作时,数据包在这台逻辑交换机上的传输率为32Gbps。

           当一个数据帧需要传输时,交换机的软件会进行计算看哪条环路更可用,然后数据帧会被送到该环路上。如果一条堆叠电缆出故障,故障两端的交换机都会侦测到该故 障,并将受影响的环路断开,而逻辑交换机仍然可以以单环的状态工作,此时的数据包通过率为16Gbps。交换机的堆叠采用菊花链方式,连接的方式参考下图。

    640?wx_fmt=jpeg&tp=webp&wxfrom=5&wx_lazy=1&wx_co=1

    堆叠增加交换机端口与带宽的稳定性。

    四、热备份(HSRP


    核心交换机是整个网络的核心和心脏,如果核心交换机发生致命性的故障,将导致本地网络的瘫痪,所造成的损失也是难以估计的。所以我们在选择核心交换机时,经常会看到有的核心交换机具有堆叠或热备份等功能。

     对核心交换机采用热备份是提高网络可靠性的必然选择。在一个核心交换机完全不能工作的情况下,它的全部功能便被系统中的另一个备份路由器完全接管,直至出现问题的路由器恢复正常,这就是热备份路由协议.

           实现HSRP的条件是系统中有多台核心交换机,它们组成一个“热备份组”,这个组形成一个虚拟路由器。在任意时刻,一个组内只有一个路由器是活动的,并由它来转发数据包,如果活动路由器发生了故障,将选择一个备份路由器来替代活动路由器,但是在本网络内的主机看来,虚拟路由器没有改变。所以主机仍然保持连接,没有受到故障的影响,这样就较好地解决了核心交换机切换的问题。

           为了减少网络的数据流量,在设置完活动核心交换机和备份核心交换机之后,只有活动核心交换机和备份核心交换机定时发送HSRP报文。如果活动核心交换机失效,备份核心交换机将接管成为活动核心交换机。如果备份核心交换机失效或者变成了活跃核心交换机,将由另外的核心交换机被选为备份核心交换机。

    1、当某台接入层交换机到主核心交换机的线路出现故障,切换至备机,数据流走向

    640?wx_fmt=jpeg&tp=webp&wxfrom=5&wx_lazy=1&wx_co=1

           当接入层交换机1上联至核心交换机A的数据链路出现故障,导致接入层交换机1的数据链路切换至核心交换机B,但在切换期间接入层交换机1分丢6个数据包,如上图所示。

        

    当服务器与核心交换机A之间主链路出现故障(如线路、网卡等),服务器主网卡切换至备用网卡上时,会丢6个数据包,但当主链路恢复以后,服务器会自动从备用网卡切换至主网卡,而这次切换时数据包不会丢失。具体终端访问服务器的数据流走向如下图。

    640?wx_fmt=jpeg&tp=webp&wxfrom=5&wx_lazy=1&wx_co=1

    640?wx_fmt=png&tp=webp&wxfrom=5&wx_lazy=1&wx_co=1

    资料免费送(点击链接下载)


    加入运维管理VIP群(点击链接查看)

    扫描以下二维码加入学习群

    展开全文
  • 交换机

    千次阅读 2019-09-21 13:58:45
    交换机的分类 1、按照管理划分 网管交换机 非网管交换机 2、按照工作层次分 2层交换机 数据链路层 3层交换机 网络层 4层交换机 可以依靠传输层的端口进行转发 3、按照网络拓扑结构分 1、接入层交换机 : 将计算机和...
  • 实践专周交换机练习

    2014-05-30 14:27:45
    假设某企业采用两台交换机组成一个局域网,由于很多数据流量是跨过交换机进行转发的,因此需要提高交换机之间的传输带宽,并实现链路冗余备份,为此网络管理员两台交换机之间采用两根网线互连,并将相应的两个端口...
  • 交换机详解

    千次阅读 多人点赞 2016-11-20 20:27:50
    交换机一般分为三类单台交换机,堆叠式交换机,模块化...交换机堆叠技术采用了专门的管理模块和堆栈连接电缆,这样做的好处是,一方面增加了用户端口,能够在交换机之间建立一条较宽的宽带链路,这样每个实际使用的用
  • 图解Cisco交换机堆叠与HSRP之间的区别随着Internet的日益普及,人们对网络的依赖性也越来越强。这同时对网络的稳定性提出了更高的要求,人们自然想到了基于设备的备份结构,就像服务器中为提高数据的安全性而采用...
  • 接入层为用户提供了本地网段访问应用系统的能力,主要解决相邻用户之间的互访需求,并且为这些访问提供足够的带宽。大中型网络里,接入层还应当适当负责一些用户管理功能(如地址认证、用户认证、计费管理等),...
  • 叠加的交换机之间通过两条环路连接起来。交换机的硬件负责将数据包双环路上做负载均衡。 环路这里充当了这个大的逻辑交换机的背板的角色,双环路都正常工作时,数据包这台逻辑交换机上的传输率为32Gbps。...
  • 本文主要介绍接入层交换机、汇聚层交换机以及核心层交换机的区别,了解它们的区别之前,先来了解下这三种交换机的名称是不是交换机的分类以及接入层、汇聚层以及核心层,这样更方便于您了解这三种交换机之间的区别...
  • 这同时对网络的稳定性提出了更高的要求,人们自然想到了基于设备的备份结构,就像服务器中为提高数据的安全性而采用双硬盘结构一样。核心交换机是整个网络的核心和心脏,如果核心交换机发生致命性的故障,将导致...
  • ①由于Mac地址表是有上限的,所以泛洪攻击macof出现,导致MAC地址表被充满,网络卡顿,之后交换机收到信息都会采用广播的方式,嗅探也就出现。 ②由于交换机采用arp地址解析协议来确定目的地的MAC地址,
  • spanning tree 在冗余网络中的说明

    千次阅读 2012-04-19 09:17:55
    生成树协议(Spanning Tree Protocol,STP)是交换式以太网中的重要概念和技术,该协议的目的是实现交换机之间冗余连接的同时,避免网络环路的出现,实现网络的高可靠性。它通过在交换机之间传递桥接协议数据...
  • 实验目标 理解端口聚合基本原理; 掌握一般交换机端口聚合的配置方法;...端口聚合使用的是EtherChannel特性,交换机到交换机之间提供冗余的高速的连接方式。将两个设备之间多条FastEthernet或Gigabit...
  • 华为交换机STP的配置

    万次阅读 2015-12-08 21:24:56
    也就是说如果交换机之间用一条链路互连,那么一旦一条链路出了问题,将会导致整个网络的瘫痪,为了防止这种情况,交换机之间用多条链路互连,当一条链路故障时,还可以通过其他链路发送数据帧(是不是和电路交换/...
  • 一、网关冗余(一)网关冗余的基本知识:路由器冗余技术可分为:动态冗余和静态冗余两种。动态冗余不太合适,所以只讲静态冗余1、静态路由冗余:(1)HSRP 热备份路由协议 (cisco专有协议)(2) VRRP 虚拟路冗余协议(3)...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 14,580
精华内容 5,832
关键字:

在交换机之间采用冗余