精华内容
下载资源
问答
  • 访问控制列表--标准ACL

    万次阅读 多人点赞 2018-07-05 12:23:04
    访问控制列表通过过滤报文达到流量控制、攻击防范以及用户接入控制等功能,现实应用广泛。ACL根据功能的不同分为标准ACL和扩展ACL。标准ACL只能过滤报文的源IP地址;扩展ACL可以过滤源IP、目的IP、协议类型、...

    访问控制列表(Access Control List,简称ACL)是根据报文字段对报文进行过滤的一种安全技术。访问控制列表通过过滤报文达到流量控制、攻击防范以及用户接入控制等功能,在现实中应用广泛。ACL根据功能的不同分为标准ACL和扩展ACL。标准ACL只能过滤报文的源IP地址;扩展ACL可以过滤源IP、目的IP、协议类型、端口号等。ACL的配置主要分为两个步骤:(1)根据需求编写ACL(2)ACL应用到路由器接口的某个方向。本章主要介绍各种常用ACL的编写与应用。

    1.1 实验目的

    1)了解访问控制列表的工作过程

    2)掌握标准访问控制列表的配置和应用

    3)熟悉标准ACL的调试

    1.2 实验原理

    1. 什么是访问控制列表(Access Control List?

    访问控制列表(Access Control List)是一种路由器配置脚本,它根据从数据包报头中发现的条件来控制路由器应该允许还是拒绝数据包通过。通过接入控制列表可以在路由器、三层交换机上进行网络安全属性配置,可以实现对进入路由器、三层交换机的输入数据流进行过滤,但ACL 对路由器自身产生的数据包不起作用。

    当每个数据包经过关联有 ACL 的接口时,都会与 ACL 中的语句从上到下一行一行进行比对,以便发现符合该传入数据包的模式。ACL 使用允许或拒绝规则来决定数据包的命运,通过此方式来贯彻一条或多条公司安全策略。还可以配置 ACL 来控制对网络或子网的访问。另外,也可以在VTY线路接口上使用访问控制列表,来保证telnet的连接的安全性。

    默认情况下,路由器上没有配置任何 ACL,不会过滤流量。进入路由器的流量根据路由表进行路由。如果路由器上没有使用 ACL,所有可以被路由器路由的数据包都会经过路由器到达下一个网段。ACL 主要执行以下任务:

    限制网络流量以提高网络性能。例如,如果公司政策不允许在网络中传输视频流量,那么就应该配置和应用 ACL 以阻止视频流量。这可以显著降低网络负载并提高网络性能。

    提供流量控制。ACL 可以限制路由更新的传输。如果网络状况不需要更新,便可从中节约带宽。

    提供基本的网络访问安全性。ACL 可以允许一台主机访问部分网络,同时阻止其它主机访问同一区域。例如,“人力资源”网络仅限选定用户进行访问。

    决定在路由器接口上转发或阻止哪些类型的流量。例如,ACL 可以允许电子邮件流量,但阻止所有 Telnet 流量。

    l 控制客户端可以访问网络中的哪些区域。

    屏蔽主机以允许或拒绝对网络服务的访问。ACL 可以允许或拒绝用户访问特定文件类型,例如 FTP 或 HTTP。

    2.访问控制列表的分类

    ACL的类型主要分为IP标准访问控制列表(Standard IP ACL)和IP扩展访问控制列表(Extended IP ACL)两大类:

    l IP标准访问控制列表(Standard IP ACL)。标准 ACL 根据源 IP 地址允许或拒绝流量。数据包中包含的目的地址和端口无关紧要。   

    l IP扩展访问控制列表(Extended IP ACL )。扩展 ACL 根据多种属性(例如,协议类型、源和 IP 地址、目的 IP 地址、源 TCP 或 UDP 端口、目的 TCP 或 UDP 端口)过滤 IP 数据包,并可依据协议类型信息(可选)进行更为精确的控制。

    此外还包括一些复杂的ACL,例如命名ACL,基于时间的ACL,动态ACL,自反ACL等。

    3.ACL工作原理

    ACL 要么配置用于入站流量,要么用于出站流量。入站 ACL 传入数据包经过处理之后才会被路由到出站接口。入站 ACL 非常高效,如果数据包被丢弃,则节省了执行路由查找的开销。当测试表明应允许该数据包后,路由器才会处理路由工作。图1就是入站ACL的工作原理图。

                    

    1 入站ACL工作原理

    图中显示了入站 ACL 的逻辑。如果数据包报头与某条 ACL 语句匹配,则会跳过列表中的其它语句,由匹配的语句决定是允许还是拒绝该数据包。如果数据包报头与 ACL 语句不匹配,那么将使用列表中的下一条语句测试数据包。此匹配过程会一直继续,直到抵达列表末尾。最后一条隐含的语句适用于不满足之前任何条件的所有数据包。这条最后的测试条件与这些数据包匹配,并会发出“拒绝”指令。此时路由器不会让这些数据进入或送出接口,而是直接丢弃它们。最后这条语句通常称为“隐式 deny any 语句”或“拒绝所有流量”语句。由于该语句的存在,所以 ACL 中应该至少包含一条 permit 语句,否则 ACL 将阻止所有流量。出站 ACL 传入数据包路由到出站接口后,由出站 ACL 进行处理。

                 

    2 出站ACL工作原理

    2中显示了出站 ACL 的逻辑。在数据包转发到出站接口之前,路由器检查路由表以查看是否可以路由该数据包。如果该数据包不可路由,则丢弃它。接下来,路由器检查出站接口是否配置有 ACL。如果出站接口没有配置 ACL,那么数据包可以发送到输出缓冲区。

    4. 3P原则

    在路由器上应用 ACL 的一般规则我们简称为3P原则。即我们可以为每种协议 (per protocol)、每个方向 (per direction)、每个接口 (per interface) 配置一个 ACL:

    每种协议一个 ACL: 要控制接口上的流量,必须为接口上启用的每种协议定义相应的 ACL。

    每个方向一个 ACL:一个 ACL 只能控制接口上一个方向的流量。要控制入站流量和出站流量,必须分别定义两个 ACL。

    每个接口一个 ACL:一个 ACL 只能控制一个接口(例如快速以太网 0/0)上的流量。

    5. ACL的放置位置

    每一个路由器接口的每一个方向,每一种协议只能创建一个ACL在适当的位置放置 ACL 可以过滤掉不必要的流量,使网络更加高效。ACL 可以充当防火墙来过滤数据包并去除不必要的流量。ACL 的放置位置决定了是否能有效减少不必要的流量。例如,会被远程目的地拒绝的流量不应该消耗通往该目的地的路径上的网络资源。每个 ACL 都应该放置在最能发挥作用的位置。基本的规则是:

    将扩展 ACL 尽可能靠近要拒绝流量的源。这样,才能在不需要的流量流经网络之前将其过滤掉。

    因为标准 ACL 不会指定目的地址,所以其位置应该尽可能靠近目的地。

    6. 标准ACL的配置命令

    标准访问控制列表是通过使用IP包中的源IP地址进行过滤,使用的访问控制列表号199来创建相应的ACL。标准ACL占用路由器资源很少,是一种最基本最简单的访问控制列表格式。应用比较广泛,经常在要求控制级别较低的情况下使用。

    要配置标准ACL,首先在全局配置模式中执行以下命令:

        Router(config)#access-list access-list-number {remark | permit | deny} protocol source source-wildcard [log]

    参数说明:

    参数

    参数含义

    access-list-number

    标准ACL号码,范围从0-99,13001999

    remark

    添加备注,增强ACL的易读性

    permit

    条件匹配时允许访问

    deny

    条件匹配时拒绝访问

    protocol

    指定协议类型,egIP,TCP,UDP,ICMP

    source 

    发送数据包的网络地址或者主机地址

    source-wildcard

    通配符掩码,和源地址对应

    log

    对符合条件的数据包生成日志消息,该消息将发送到控制台

    其次,配置标准 ACL 之后,可以在接口模式下使用 ip access-group 命令将其关联到具体接口:

    Router(config-if)#ip access-group access-list-number  {in | out}

    参数

    参数含义

    ip access-group

    标准ACL号码,范围从0-99,13001999

    access-list-number

    标准ACL号码,范围从0-99,13001999

    in

    参数in限制特定设备与访问列表中地址之间的传入连接

    out

    参数out限制特定设备与访问列表中地址之间的传出连接

     

    7.标准ACL的配置实例

                     

    地址表:

    设备

    接口

    IP地址

    子网掩码

    R1

    Fa 0/0

    192.168.1.1

    255.255.255.0

    S 0/0/0

    172.16.1.2

    255.255.255.252

    R2

    S 0/0/0

    172.16.1.1

    255.255.255.252

    S 0/0/1

    172.16.1.5

    255.255.255.252

    Fa 0/0

    192.168.1

    255.255.255.0

    R3

    S 0/0/1

    172.16.1.6

    255.255.255.252

    Fa 0/0

    192.168.20.1

    255.255.255.0

    PC1

    NIC

    192.168.1.10

    255.255.255.0

    PC2

    NIC

    192.168.10

    255.255.255.0

    PC3

    NIC

    192.168.20.10

    255.255.255.0

    1 IP地址表

    本实验案例要求只允许PC1通过telnet方式登录路由器R1,R2R3。只允许PC1所在网段访问PC3所在网段。整个网络可以配置RIP或者OSPF路由协议保证整个网络的畅通。

    (1) 步骤1:配置路由器R1


    R1(config-if)#inter fa 0/0


    R1(config-if)#ip add 192.168.1.1 255.255.255.0


    R1(config-if)#no shut


    R1(config-if)#inter s 0/0/0


    R1(config-if)#ip add 172.16.1.2 255.255.255.252


    R1(config-if)#clock rate 64000


    R1(config-if)#no shut


    R1(config-if)#exit


    R1(config)#enable secret cisco  //配置enable密码


    R1(config)#router ospf 1


    R1(config-router)#network 172.16.1.0 0.0.0.3 area 0


    R1(config-router)#network 192.168.1.0 0.0.0.255 area 0  //以上3条为配置ospf路由协议,保证网络正常联通


    R1(config)#access-list 2 permit 192.168.1.10  //定义ACL2,允许源IP地址为192.168.1.10的数据包通过


    R1(config-if)#line vty 0 4


    R1(config-line)#access-class 2 in  //在接口下应用定义的ACL2,允许IP地址为192.168.1.10的主机通过TELNET连接到路由器R1


    R1(config-line)#password cisco   //配置TELNET远程登录密码为cisco


    R1(config-line)#login


    (2)步骤2:配置路由器R2


    R2(config)#inter s0/0/0


    R2(config-if)#ip add 172.16.1.1 255.255.255.252


    R2(config-if)#clock rate 64000


    R2(config-if)#no shut


    R2(config-if)#exit


    R2(config)#inter s0/0/1


    R2(config-if)#ip add 172.16.1.5 255.255.255.252


    R2(config-if)#clock rate 64000


    R2(config-if)#no shut


    R2(config-if)#exit


    R2(config)#inter fa 0/0


    R2(config-if)#ip add 192.168.1 255.255.255.0


    R2(config-if)#no shut


    R2(config-if)#exit


    R2(config)#enable secret cisco   //配置enable密码


    R2(config)# router ospf 1


    R2(config-router)#network 172.16.1.0 0.0.0.3 area 0


    R2(config-router)#network 172.16.1.4 0.0.0.3 area 0

    R2(config-router)#network 192.168.20.0 0.0.0.255 area 0  //以上4条为配置ospf路由协议,保证网络正常联通
    R2(config)#access-list 2 permit 192.168.1.10  //定义ACL2,允许源IP地址为192.168.1.10的数据包通过
    R2(config-if)#line vty 0 4
    R2(config-line)#access-class 2 in   //在接口下应用定义的ACL2,允许IP地址为192.168.1.10的主机通过TELNET连接到路由器R2
    R2(config-line)#password cisco    //配置TELNET远程登录密码为cisco
    R2(config-line)#login
    (3)步骤3:配置路由器R3
    R3(config)#inter s 0/0/1
    R3(config-if)#ip add 172.16.1.6 255.255.255.252
    R3(config-if)#clock rate 64000
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#inter fa 0/0
    R3(config-if)#ip add 192.168.20.1 255.255.255.0
    R3(config-if)#no shut
    R3(config-if)#exit
    R3(config)#enable secret cisco    //配置enable密码
    R3(config)# router ospf 1
    R3(config-router)#network 172.16.1.4 0.0.0.3 area 0
    R3(config-router)#network 192.168.20.0 0.0.0.255 area 0     //以上3条为配置ospf路由协议,保证网络正常联通
    R3(config)#access-list 1 permit 192.168.1.0  0.0.0.255  //定义ACL1,允许源IP地址为192.168.1.0/24的数据包通过
    R3(config)#access-list 1 deny any
    R3(config)#interface fa 0/0
    R3(config-if)#ip access-group 1 out   //在接口下应用ACL1, 允许IP地址为192.168.1.0/24的IP包从fa 0/0接口离开路由器R3
    R3(config)#access-list 2 permit 192.168.1.10     //定义ACL2,允许源IP地址为192.168.1.10的数据包通过
    R3(config-if)#line vty 0 4
    R3(config-line)#access-class 2 in   //在接口下应用定义的ACL2,允许IP地址为192.168.1.10的主机通过TELNET连接到路由器R3
    R3(config-line)#password cisco    //配置TELNET远程登录密码为cisco
    R3(config-line)#login
    【说明】
    ①ACL定义好后可以在很多地方应用,接口上应用只是其中之一,其他的常用应用包括在vty下用”access-class”命令调用,用来控制Telnet的访问,“access-class”命令只对标准ACL有效。
    ②访问控制列表表项的检查按自上而下的顺序进行,并且从第一个表项开始,所以必须考虑在访问控制列表中定义语句的次序;访问控制列表最后一条是隐含的拒绝所有deny any;
    ③路由器不对自身产生的IP数据包进行过滤;
    ④我们另外,尽量使标准的访问控制列表靠近目的,由于标准访问控制列表只使用源地址,如果将其靠近源会阻止数据包流向其他端口
    ⑤对于编号标准ACL,新添加的ACL条目只能加到最后,不能插到原来ACL条目中间,所以如果想在原来的编号标准ACL中插入某条条目,只能删掉原来的ACL内容,重新编写。
    (4)实验调试
    R3#show ip access-lists  //该命令用来查看所定义的IP访问控制列表
     Standard IP access list 1
       10 permit   192.160.1.0,wildcard bits 0.0.0.3(11 matches)
       20 deny any (405 matches)
    Standard IP access list 2
       10 permit 192.168.1.10(2 matches)
    以上输出表明路由器R2上定义的标准访问控制列表为”1”和”2”,括号中的数字表示匹配条件的数据包的个数,可以用”clear access-list counters”命令将访问控制列表计数器清零。
    R3#show ip interface fa 0/0
    FastEthernet0/0 is up, line protocol is up (connected)
      Internet address is 192.168.20.1/24
      Broadcast address is 255.255.255.255
      Address determined by setup command
      MTU is 1500
      Helper address is not set
      Directed broadcast forwarding is disabled
      Outgoing access list is 1
    Inbound  access list is not set  ......
    ***省略后面输出***
    以上输出表明在接口fa 0/0的出方向应用了访问控制列表1 

    展开全文
  • [ERP]ERP中标准成本的差异分析控制

    千次阅读 2015-10-12 09:07:37
    本文将着重讨论差异的分析控制。 一、 标准成本的差异类型标准成本的差异的来源主要存在三个阶段,也即:采购、存储和生产。采购过程的差异主要围绕订单、发票及收货环节的不配比造成。理论上三者的各要素应当一致,...

    当前大多成熟的ERP系统均集成了标准成本管理系统。由于ERP系统的高度集成的特性,各种因素对标准成本影响的结果需要耗费相关人员大量的时间和精力去分析,毕竟再智能的系统依然需要人的参与。本文将着重讨论差异的分析控制。

    一、 标准成本的差异类型
    
    标准成本的差异的来源主要存在三个阶段,也即:采购、存储和生产。
    
    采购过程的差异主要围绕订单、发票及收货环节的不配比造成。理论上三者的各要素应当一致,但事实上除了采购价格和标准成本的人为设置的原因之外,由于其他各种原因造成的差异因素千差万别。为便于控制主要因素,价格、发票、标准等差异几乎成为标准的设置。
    
    理论上存储是静止的,但由于各种原因,实物与账面的差异始终存在。物流过程中,任何存放物料的地点都存在账实不符的风险。
    
    生产环节可能由于各种原因造成的实际用料和物料单的不符,人工和制造费用也会由于标准费率与实际的偏离造成差异。
    
    二、 差异的分析控制
    
    只有充分把握差异的来源和成因,才能从根本上分析成本的差异,并采取有效的手段控制成本减少异常的差异出现,以保持存货和成本的真实性与合理性。
    
    采购环节的差异始终围绕订单,发票,接收三个环节产生。对于采购环节的差异,采购部门应逐月搜集相关信息,找到问题的根源加以解决。针对采购流程的全部作业活动的关键点实施跟踪控制,加强信息流的准确性和及时性。例如针对采购订单的下达和传递过程,应搜集采购员下达的订单信息和供应商收到的信息进行分析。通常由于控制的薄弱造成下单错误(数量,单价,单位,货币等),或者由于供应商的疏忽造成处理错误等。同时由于供应商用错误的订单信息会造成相应的发票,出货的错误。而事实上供应商财务人员的疏忽,以及发货的错误,同时接收人员的大意,都造成差异的产生。若果追溯采购差异,上述所有环节均可能成为问题的根源。所以相应的控制流程必须清晰而且有效。采购部门应在财务部门的配合下,考核差异到订单,加强对于这些控制点的控制,加重在考核指标中的权重。
    
    存储环节通常会由于公司管理的漏洞、库管人员的疏漏、物料价值的重估、BOM问题等造成差异产生。ERP系统中的记录的物料信息和实际的盘存差异,应由责任人员书面提请报告并批准后相应调整库存。由于物料价值重估产生的差异应用后进先出法在存货成本和销售成本之间进行分配。BOM错误会造成存货数量和价值的错误,制造企业应对BOM结构和版本进行审核和控制,避免由此造成的差异。
    
    制造环节的差异通常由于BOM的错误、库存、订单错误、领料等造成各种异常差异和成本波动。公司应对生产订单的差异原因进行分析,并由生产管理人员牵头组织相关人员对差异原因进行剖析,找出原因并采取措施。
    
    三、 结论及建议
    
    由于ERP系统的高度集成性,任何上游的异常业务均会造成差异的产生。公司应标准化各操作流程,加强对系统录入信息的质量控制,并采取差异负责制由责任人对差异负责,逐步从源头减少差异产生的几率,使得标准成本真正成为企业管理的利器。
    
    展开全文
  • 11.控制小数显示格式  fmtflags setf (fmtflags fmtfl);  Set specific format flags  sets the stream's format flags whose bits are set in fmtfl, leaving unchanged the rest    其中fmtflags是b
    11.控制小数显示格式
       fmtflags setf (fmtflags fmtfl);
             Set specific format flags
             sets the stream's format flags whose bits are set in fmtfl, leaving unchanged the rest

      
      其中fmtflags是bitmask类型的typedef名,用于存储格式标记,该名称是在ios_base类中定义的.
      ios_base类定义的代表位值的常量:(仅供参考,无需记忆)
       


      
    设置修改将一直有效,直到被覆盖为止
      Example:
      int main()
    {
       cout.setf(ios_base::boolalpha);
       cout<<true<<endl;
       cout<<false<<endl;
       cout.setf(ios_base::uppercase);
       cout.setf ( ios::showbase );                  
       cout <<hex<<100 << '\n';
       cout.setf(ios_base::showpoint);
       cout<<(float)1.1<<endl;
       return 0;
    }



     运行结果:
     






     fmtflags setf (fmtflags fmtfl, fmtflags mask):
              sets the stream's format flags whose bits are set in both fmtfl and mask, 
              and clears the format flags whose bits are set in mask but not in fmtfl.


     第一个参数包含了所需设置的fmtflags值,第二个参数指出要清除第一个参数中的哪些位 
      常用参数组合及其含义:
     
      
     

      解析:因为上图第二个参数ajustfield,basefield,floatfield,清除了不止一个位,而第一个参数只设置对应的一个位



      *将位恢复为0
      void unsetf (fmtflags mask);
                 Clear specific format flags
                 Clears the format flags selected in mask


      Example:
      int main()
    {
        cout.setf ( ios::hex, ios::basefield );  
    // set hex as the basefield
        cout.setf ( ios::showbase );             // activate showbase
        cout << 100 << endl; //0x64
        cout.unsetf (ios::showbase );      // deactivate showbase
        cout << 100 << endl; //64
       
       return 0;
    }






    12.标准控制符
       使用setf()进行格式化比较繁琐,为此C++提供了多个控制符,这些控制符能调用setf(),并自动提供正确的参数
       一些常用标准控制符
     





    13.头文件iomanip
       使用iostream工具来设置一些格式相当繁琐,为此,C++在头文件iomanip中提供了其他一些等价控制符
       setfill (char_type c):
                Set fill character
                Sets c as the stream's fill character.


       setprecision (int n):
                Set decimal precision
                Sets the decimal precision to be used to format floating-point values on output operations.


      setw (int n):
                Set field width
                Sets the field width to be used on output operations.


       setbase (int base):
                Set basefield flag
                Sets the basefield to one of its possible values: dec, hex or oct, according to argument base.


        setiosflags (ios_base::fmtflags mask):
                Set format flags
                Sets the format flags specified by parameter mask


       resetiosflags (ios_base::fmtflags mask);
                 Reset format flags
                 Unsets the format flags specified by parameter mask



       Example:
     #include<iostream>
    #include<iomanip> 
    using namespace std;


    int main()
    {


        cout << setfill ('*') <<setw(30);
    //设置填充和宽度 
        cout << "hello" << endl;
      
        double f =1.0/3; 
        cout <<setprecision(9) << f << endl; //设置精度 
        
         cout << setbase(16);  //设置16进制 
         cout << 13 << endl;

         cout << setiosflags (ios::showbase | ios::uppercase); //用大写表示前缀 
         cout << 100 << endl;
         cout << resetiosflags(ios::showbase) << 100 << endl;//去除前缀 
       
       return 0;
    }




      运行结果:
       
    展开全文
  • 交换机的标准访问控制

    千次阅读 2018-05-07 10:57:04
    项目目标:(1)了解IP标准访问控制列表的功能及用途(2)掌握交换机IP标准访问控制列表配置技能工作任务:你是公司网络管理员,公司的技术部、业务部和财务部分属不同的3个网段,三个部门之间通过三层交换机进行...

    项目目标:

    (1)了解IP标准访问控制列表的功能及用途

    (2)掌握交换机IP标准访问控制列表配置技能

    工作任务:

    你是公司网络管理员,公司的技术部、业务部和财务部分属不同的3个网段,三个部门之间通过三层交换机进行信息传递,为了安全起见,公司要求你对网络的数据流量进行控制,实现技术部的主机可以访问财务部的主机,但是业务部的主机不能访问财务部的主机。

    任务分析

    首先对三层交换机进行基本配置,实现三个网段可以相互访问(前提),然后对三层交换机配置IP标准访问控制列表,允许技术部主机发出的数据包通过,不允许业务部主机发出的数据包通过,最后将这一策略加到三层交换的相应端口。

    任务实施

    网络拓扑图


    第一步:在三层交换上创建3个vlan,并将3个vlan当成子接口配置IP地址


    使用show ip interface brief检验创建的vlan


    三个子接口分别给三个网段提供网关,由于是三层交换,要提供不同网段之间的通信,要打开三层交换的路由功能。


    接下来,开始配置二层交换,在各个二层交换机上创建vlan,并将主机放入vlan




    由于外部的主机发出的数据包都是跨交换机的,所以各个交换机之间的链路要配成干道,三层和二层互联的时候配置干道有两种方法,最简单的就是在二层交换机上面去配置,让三层交换机去学习,第二种方法就是在在三层交换机上去配置,但是要先把它的分装协议改成dot.1q。



    开始配PC的IP地址,测试PC和网管的连通性。




    然后在测试业务部、技术部与财务部之间主机的连同性。不再赘述。

    第二步:配置ACL(在三层交换)






    2.将创建的IP访问控制列表应用在三层交换的某个端口上面,因为数据包通过接口出入,所以要把这个策略加在某个接口上面。

    测试

    技术部继续可以访问财务部,但是业务部不可以访问财务部





























    展开全文
  • 标准访问控制列表

    千次阅读 2007-07-23 11:56:00
    规则序列号范围l到99之间的访问控制列表为标准访问控制列表。标准访问控制列表只是根据数据包的源地址对数据包进行区分。例如在上图,如果需要允许从202.110.10.0网段来的数据包通过,而拒绝从192.110....
  • 标准IP访问控制列表

    千次阅读 2018-02-12 17:33:41
    3.设置标准IP访问控制列表 R0: conf t ip accesst-list standard long(名随意取) permit 172.16.1.0 0.0.0.255(下面命令不跟配置信息则有默认其它都不能通过的命令) define 172.16.2.0 0.0.0.255 int ...
  • 标准访问控制列表 : 根据数据包的源IP地址来允许或拒绝数据包。 访问控制列表号是1-99以及1300~1999。 扩展访问控制列表: 根据数据包的源IP地址、目的IP地址、指定协议、端口和标志来允许或拒绝数据包。 访问控制...
  • ACL——标准访问控制列表

    千次阅读 2019-10-15 18:39:31
    (2)、基本原理:ACL使用包过滤技术,路由器上读取第三层及第四层包头的信息(如源地址、目的地址、协议口、端口号等),根据预先定义好的规则对包进行过滤,从而达到控制的目的 (3)ACL目的:限制网络流量、...
  • C++ 标准输出控制小数点后位数的方法代码示例改正原因 代码示例 #include <iostream> #include <math.h> using namespace std; int main() { double x1,y1,x2,y2; while(cin>>x1>>y1>...
  • ①ACLs的全称为接入控制列表(Access Control Lists),也称访问控制列表(Access Lists),俗称防火墙,有的文档还称包过滤。ACLs通过定义一些规则对网络设备接口上的数据包文进行控制;允许通过或丢弃,从而...
  • C/C++标准输入输出格式控制

    千次阅读 2018-03-21 20:30:09
    1、c语言输入输出格式控制 (1)输入格式控制–scanf() ...scanf()函数根据由format(格式)指定的格式从stdin(标准输入)读取,并保存数据到其它参数. 它和printf()有点类似. format(格式)字符串由控制字符,空白字符和...
  • ACLs 的全称为接入控制列表(Access Control Lists),也称访问控制列表(Access Lists),俗称防火墙,有的文档还称包过滤。ACLs 通过定义一些规则对网络设备接口上的数据 包文进行控制;允许通过或丢弃,从而...
  • 如果你通过继承UIViewController子类,并选择生成xib文件,你双击xib文件后,会看到一个标准的view视图,如果是ipad版本应用,该view的size应该是768*1004,而且是灰色,不能修改的。如下图:   ...
  • BBR 简介BBR 是 Google 推出的一个「TCP 拥塞控制算法」,它是以 Linux 内核模块的形式加载,可以最大化 Linux Server 的网络吞吐量。简单地说,开启 BBR 的 Linux Server 和不开启 BBR 的 Linux Server,持续传输...
  • c++ 标准输出如何控制小数点后位数

    万次阅读 2018-08-29 11:06:55
    c++ 标准输出如何控制小数点后位数 include include using namespace std; int main( void ) { const double value = 12.3456789; cout &lt;&lt; value &lt;&lt; endl; // 默认以6精度,...
  • meta标签控制IE渲染标准模式和兼容模式 从上面的例子可以看出“X-UA-Compatible”的值有两种方式:Emulate+IE版本号,单纯版本号。这两种有何区别呢? Edge:始终以最新的文档模式来渲染页面。忽略文档类型声明。...
  • OPC全称是OLE for Process Control,即用于过程控制的OLE,是针对现场控制系统的一个工业标准接口,是工业控制和生产自动化领域使用的硬件和软件的接口标准。基于微软的OLE(现在的Active X)、COM (部件对象模型)和...
  • c++标准输入输出流的控制

    千次阅读 2017-05-29 16:19:06
    dec 设置整数的基数为10 hex 设置整数的基数为16 oct 设置整数的基数为8 setbase(n) 设置整数的基数为n(n只能是16,10,8之一) setfill(c) 设置填充字符c,c可以是字符...以fixed(固定小数位数)形式和scientifi
  • Windows 的 UAC 用户账户控制

    千次阅读 2019-05-05 09:02:07
    阅读本文,你可以初步了解 Windows 上的 UAC 用户账户控制机制。本文不会涉及到 UAC 的底层... Windows 有多种不同的账户: SYSTEM Administrators 用户组 Administrator 管理员账户 Users 用户组 标准账户...
  • 如果要求按八进制或十六进制输入输出,cin或cout必须指明相应的数据形式,oct为八进制,hex为十六进制,dec为十进制。举例:int i, j, k, l;coutcin>>oct>>i; //输入为八进制数cin>>hex>>j;
  • 详解OPC协议-工业控制和自动化领域的接口标准

    万次阅读 多人点赞 2009-12-30 18:52:00
    OPC全称是OLE for Process Control,即用于过程控制的OLE,是针对现场控制系统的一个工业标准接口,是工业控制和生产自动化领域使用的硬件和软件的接口标准。基于微软的OLE(现在的Active X)、COM (部件对象模型)和...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,317,008
精华内容 526,803
关键字:

在控制标准中