精华内容
下载资源
问答
  • 在组合框中不能进行多项选择
    千次阅读
    2020-01-10 18:17:11

    一、允许多项选择

    代码如下

    Private Sub UserForm_Initialize()
        arr = Sheets("产品表").Range("a1").CurrentRegion
        With ListBox1
        '设置列表框属性
            .List = arr
            .MultiSelect = fmMultiSelectExtended
            .ColumnCount = UBound(arr, 2)
            .ListStyle = fmListStyleOption
        End With
    End Sub
    

    object.MultiSelect [= fmMultiSelect]

    • fmMultiSelect设置值
    常量说明
    fmMultiselectsingle0只可选择1个条目(默认)
    fmMultiselectMulti1按space键或单击以选中列表中1个条目或取消选中
    fmMultiselectExtended2按shift键可以扩展选中条目,按ctrl的同时单击可以选择多个

    object.liststyle [= fmliststyle]

    • fmliststyle设置值
    常量说明
    fmliststyleplain0外观与常规的列表框相似,条目的背景为高亮
    fmliststyleoption1显示选项按钮,或显示用于多重选择列表的复选框(默认)。当用户选中组中的条目时,与该条目相关的选项按钮即被选中,而该组其他条目的选项按钮被取消选中

    二、设置多列列表框

    Private Sub UserForm_Initialize()
        Dim lngLast As Long
        lngLast = Sheet1.Cells(Rows.Count, 1).End(xlUp).Row
        With lstData
            .ColumnCount = 7
            .ColumnWidths = "45;45;45;45;45;45;45"
            .BoundColumn = 1
            .ColumnHeads = True
            .RowSource = Sheet1.Range("A2:G" & lngLast).Address
        End With
    End Sub
    
    • object.columncount [= long],指定列表框或组合框的显示列数
    • object.columnwidths [= string],如果columnwidths属性设置为-1或空,则将空间宽度等分给列表中的各列;设置为0则隐藏该列。若要指定另一种不同的度量单位,在设置时则必须包括该度量单位。如listbox1.columnwidhths = “4.5厘米;4.5厘米;6厘米”
    • object.boundcolumn [= variant],boundcolumn属性标识多列组合框或列表框值得数据来源
      boundcolumn属性值
    说明
    0将被选中列表项的listindex属性的值赋予控件
    1或大于1将指定列中的值赋予控件。当采用此属性时,列从1开始计数(默认值)

    三、将多列列表框的数据写入工作表

    Private Sub lstData_Click()
        Dim lngLast As Long
        Dim i As Byte
        lngLast = Sheet1.Cells(Rows.Count, 1).End(xlUp).Row + 1
        For i = 1 To lstData.ColumnCount
            Sheet1.Cells(lngLast, i) = lstData.Column(i - 1)
        Next i
    End Sub
    

    当将多列列表框的数据写入工作表中时,只能将boundcolumn属性所指定列中的值写入工作表,而不能将选中的整行内容写入工作表中。如果需要将选中行的整行内容写入工作表,则需要用到以上循环。

    当然也可以用数组的方式写入数据到工作表,代码如下

    Private Sub ListBox1_DblClick(ByVal Cancel As MSForms.ReturnBoolean)
        '双击的时候也可以更改数据
        Dim crr()
        Dim m As Long
        For i = 0 To ListBox1.ListCount - 1
            If ListBox1.Selected(i) = True Then
                m = m + 1
                ReDim Preserve crr(1 To ListBox1.ColumnCount, 1 To m)
                For j = 0 To ListBox1.ColumnCount - 1
                    crr(j + 1, m) = ListBox1.List(i, j)
                Next
            End If
        Next
        If m > 0 Then ActiveCell.Resize(m, j) = Application.Transpose(crr)
    End Sub
    
    更多相关内容
  • 列表框和组合框的区别是什么?

    千次阅读 2021-06-10 17:17:14
    列表框和组合框的区别1、自动排序方式不同:当列表框不能同时显示所有项目的时候,将自动添加滚动条,使用户可以...组合框是一个编辑框带一个可以下拉的列表框,用户下拉框中选择会进入编辑框,再进行后续处...

    e7a18a1cad1a47a1114805dbd31007eb.png

    列表框和组合框的区别

    1、自动排序方式不同:

    当列表框不能同时显示所有项目的时候,将自动添加滚动条,使用户可以滚动查阅所有选项。组合框的风格取值定义了组合框的具体属性,包括是否自动排序,是否有滚动条。

    2、项目输入方式不同:

    列表框是显示一系列项供用户选择的控件,对选中的项可以进行后续的处理。用户选择可以是多项的。组合框是一个编辑框带一个可以下拉的列表框,用户在下拉框中选择的项会进入编辑框中,再进行后续处理,在编辑框中也可以直接输入。

    3、数据类型不同:

    在组合框中有Simple、Dropdown、Drop List三种类型。Simple类型的组合框和列表框部分是固定显示的,不能下拉;而其余两种带一个下拉手柄。设计中别忘记添加滚动条。Dropdown与Drop List的区别是后者的编辑框不能输入。

    在列表框中有Simple、 Multiple、Extended三种类型,它们决定了用户选取项的方法。Simple模式只能够选取单项,Multiple模式可以按Ctrl键+鼠标左键选取多个项,而Extended则可以通过鼠标拖处矩形一次选取连续的项,也可以加按Ctrl键作多次选择。

    想要了解更多相关知识,请关注 html中文网!!

    展开全文
  • C# ComboBox:组合框控件

    千次阅读 2019-06-11 23:19:40
    C#WinForm开发中组合框(ComboBox)控件也称下拉列表框, 用于选择所需的选项,例如注册学生信息时选择学历、专业等。 使用组合框可以有效地避免非法值的输入。 在组合框中也有一些经常使用的属性,如下表所...

           在 C# WinForm开发中组合框(ComboBox)控件也称下拉列表框,

     用于选择所需的选项,例如在注册学生信息时选择学历、专业等。
     
            使用组合框可以有效地避免非法值的输入。

    在组合框中也有一些经常使用的属性,如下表所示。

           在组合框中常用的事件是改变组合框中的值时发生的,即组合框中的选项改变事件 SelectedlndexChanged。

    【实例】

                实现一个选择专业的实例。

    Form1.cs

    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Data;
    using System.Drawing;
    using System.Linq;
    using System.Text;
    using System.Windows.Forms;
    
    namespace ComboBox
    {
        public partial class Form1 : Form
        {
            public Form1()
            {
                InitializeComponent();
            }
    
            //窗体加载事件,为组合框添加值
            private void Form1_Load(object sender, EventArgs e)
            {
                comboBox1.Items.Add("计算机应用");
                comboBox1.Items.Add("英语");
                comboBox1.Items.Add("会计");
                comboBox1.Items.Add("软件工程");
                comboBox1.Items.Add("网络工程");
            }
    
            //组合框中选项改变的事件
            private void comboBox1_SelectedIndexChanged(object sender, EventArgs e)
            {
                //当组合框中选择的值发生变化时弹出消息框显示当前组合框中选择的值
                MessageBox.Show("您选择的专业是:" + comboBox1.Text, "提示");
            }
    
            //“添加”按钮的单击事件,用于向组合框中添加文本框中的值
            private void button1_Click(object sender, EventArgs e)
            {
                //判断文本框中是否为空,不为空则将其添加到组合框中
                if (textBox2.Text != "")
                {
                    //判断文本框中的值是否与组合框中的的值重复
                    if (comboBox1.Items.Contains(textBox2.Text))
                    {
                        MessageBox.Show("该专业已存在!");
                    }
                    else
                    {
                        comboBox1.Items.Add(textBox2.Text);
                        MessageBox.Show("添加成功!");
                    }
                }
                else
                {
                    MessageBox.Show("请输入专业!", "提示");
                }
            }
    
            //“删除按钮的单击事件,用于删除文本框中输入的值”
            private void button2_Click(object sender, EventArgs e)
            {
                //判断文本框是否为空
                if (textBox2.Text != "")
                {
                    //判断组合框中是否存在文本框中输入的值
                    if (comboBox1.Items.Contains(textBox2.Text))
                    {
                        comboBox1.Items.Remove(textBox2.Text);
                        MessageBox.Show("删除成功!");
                    }
                    else
                    {
                        MessageBox.Show("您输入的专业不存在", "提示");
                    }
                }
                else 
                {
                    MessageBox.Show("请输入要删除的专业", "提示");
                }
            }
     
        }
    }
    

    Program.cs

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Windows.Forms;
    
    namespace ComboBox
    {
        static class Program
        {
            /// <summary>
            /// 应用程序的主入口点。
            /// </summary>
            [STAThread]
            static void Main()
            {
                Application.EnableVisualStyles();
                Application.SetCompatibleTextRenderingDefault(false);
                Application.Run(new Form1());
            }
        }
    }
    

                                  

                                   

                                       

     

     

     

     


     

    展开全文
  • 点击组合框里下拉列表选项里的账号... 易语言源码: .........子程序 _组合框1_列表选择 .局部变量 z_name, 文本型 .局部变量 word, 文本型 .局部变量 w_array, 文本型, , "0" .局部变量 i, 整数型 .局部变量 s_a

    点击组合框里下拉列表选项里的账号实现一键登录,什么意思,就是当我们点击组合列表框里的一个账号时,会实现自动登录,也及时说,它要读取本地配置文件里的账号所对应的密码,由于我们在保存账号和密码时采用了加密数据,所以这里读取时要解密数据,主要密钥的一致性。

    511yj.com

    易语言源码:

    511遇见(www.511yj.com)

    .版本 2
    .支持库 dp1
    
    .子程序 _组合框1_列表项被选择
    .局部变量 z_name, 文本型
    .局部变量 word, 文本型
    .局部变量 w_array, 文本型, , "0"
    .局部变量 i, 整数型
    .局部变量 s_array, 文本型, , "0"
    .局部变量 name, 文本型
    .局部变量 passd, 文本型
    .局部变量 pass, 字节集
    
    ' 要读取文本zhm.txt里面的账号和密码,和z_name对应的密码
    z_name = 组合框1.取项目文本 (组合框1.现行选中项)
    word = 到文本 (读入文件 (取运行目录 () + “\zhm.txt”))
    w_array = 分割文本 (word, #换行符, )
    .计次循环首 (取数组成员数 (w_array), i)
        s_array = 分割文本 (w_array [i], “|”, )
        name = s_array [1]
        passd = s_array [2]
        .如果 (z_name = name)
            账号 = name
            pass = 解密数据 (到字节集 (passd), “2”, 1)
            密码 = 到文本 (pass)
    
        .否则
    
        .如果结束
    
    .计次循环尾 ()
    ' 开始一键登录
    启动游戏 ()
    绑定游戏 ()
    开始游戏 ()
    选择服务器 ()
    输入账号密码 (账号, 密码)
    判断单选框 ()
    选择角色 (位置变量)
    

    源码:易语言大漠组合框列表选项一键登录

             511遇见易语言大漠游戏外挂一键登录

    展开全文
  • 适用范围:当你有个同级选项时,你又想创建很个单选框按钮,这时,组合框帮你完成这个复杂的创建过程。 组合框一共分为三种类型: 简易(Simple)组合框 下拉式(Dropdown)组合框 下拉列表式(Dro
  • 组合框是显示当前选择小部件,可以弹出可选择项的列表。组合框可以编辑,允许用户修改列表的每个组合框可以包含pixmap和字符串;insertItem()和setItemText()函数被适当重载。对于可编辑组合框,提供...
  • vb学习总结, 列表  1、属性  1、columns  该属性用来确定列表的列数。当该属性设置为0(默认)是,所用的项目呈单列显示。...list属性保存了列表框中所有值得数组,可以通过下标访问数组的值(下标值从
  • MFC 组合框的用法大全

    千次阅读 2018-06-18 23:31:14
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的例子...
  • 组合框同样相当常见,例如,Windows系统的控制面板上设置语言或位置时,有很选项,用来进行选择的控件就是组合框控件。它为我们的日常操作提供了很方便。 Xtreme Toolkit Pro是屡获殊荣的VC界面库,是MFC开发...
  • 列表框和组合框 列表框是CListBox类的对象,组合框是CComboBox的对象。 列表框 属性设置 ...列表框的重要属性有: ...该属性决定用户的选择方式,缺省值...③:Extended ── 允许使用 Ctrl 和 Alt 进行多项选择 ④...
  • uni-app下拉框 可输入下拉框 搜索+选择组合框功能 效果图 插件示例地址 https://ext.dcloud.net.cn/plugin?id=3756 <!-- 页面添加该标签 --> <template> <view> 选择职位:" labelWidth="130px" emptyTips="无匹配...
  • 组合框和列表框都可以界面上同时显示多项内容,并且允许用户选中其中的某项内容,列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • qml 组合框ComboBox

    千次阅读 多人点赞 2020-11-18 22:06:35
    ComboBox填充数据模型,数据模型通常是JavaScript数组,ListModel...currentIndex : int,保存组合框中当前的索引,只读 currentText : string,组合框中当前的文本,只读 delegate : Component,包含一个委托,该.
  • Java列表和组合框

    千次阅读 2018-08-15 13:43:02
    列表和组合框是又一类供用户选择的界面组件,用于一组选择项目选择组合框还可以输入新的选择。 列表 列表(JList)界面表现为列表框,是JList类或它的子类的对象。程序可以列表框加入个文本选择项条目...
  • Access-控件解析-组合框-01-下拉列表

    千次阅读 2019-04-03 20:35:44
    微信公众号原文 系统:Windows 7 软件:Excel 2010 / Access 2010 这个系列介绍常用的控件 包括界面端的设置及代码端的实现 Part 1:本篇目标 ...本篇介绍的控件为:组合框。...应用场景,组合框的下拉...
  • MFC组合框控件总结及用法示例

    万次阅读 2014-04-26 23:01:50
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单...组合框控件既可以进行输入,也可以列表框组成部分中进行选择。打开组合框控件的属性窗口,下图所示:
  • 组合框或列表框添加元素一、RowSource属性添加元素二、为工作表的ActiveX控件的列表框添加元素三、使用list属性添加元素四、使用additem方法添加列表五、列表框的其他属性 一、RowSource属性添加元素 ...
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框中选择会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、的添加和删除...
  • 编辑 文本编辑 -------------------------------------------------------------------------------------------------------------------------------- #输出无缺省值 driver.find_element_by_id(页面...
  • Designer输入工具部件的Combo Box组合框与其他可视化工具组合框功能相同,组合了按钮和弹出列表的功能,显示当前并可以弹出可选择项的列表。组合框可以编辑,允许用户修改列表的每个。Combo Box组合框对应...
  • 组合框控件用法大全

    千次阅读 2014-08-04 00:47:02
    当你界面上拖出来了combox控件后...如果你的内容比较,那么你刚刚拖得那个框框当你编译完运行后会自动产生一个滚动条的。 到此,combox的下拉框大小就设置好了。 参考知识点如下: 一、那就是设计界面里,
  • Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的例子...
  • 组合框控件

    千次阅读 2011-06-24 09:24:00
    用户既可以编辑框输入,也可以从列表框中选择一个列表来完成输入。组合框分为简易式(Simple combo box)、下拉式(Drop-down combo box)和下拉列表式(Drop-down list box)三种.简易式组合框包含一个编辑框和一...
  • VC编程之组合框

    千次阅读 2013-04-03 10:47:47
    1.如何正确的得到ComBox的指针 CComboBox *mComb = (CComboBox*)GetDlgItem(IDC_DuanCB); CComboBox *mComb = (CComboBox*)::GetDlgItem(m_...CComboBox控件又称作组合框控件,其有三种形态可供选择,1.简单组合框(Sim
  • VC组合框ComboBox控件用法

    千次阅读 2014-12-18 16:46:16
    1.关于CComboBox对话框没有下拉项目的问题 答: 资源编辑器对话框CComboBox组件的垂直范围拉大了下,就看见字体了。先点击右边向下的箭头,然后会出现上下可调的双向箭头,拖拉即可。 2、如果 ComboBox 的 ...
  • EX_UI使用系列教程(14)--EX组件(组合框EX) 1.组合框的简单使用(加入项目) 2.常用属性介绍 3.常用命令介绍 --------------- ' 组合框EX6.现行选中 = 2 ' 优先于 现行选中 设定每次弹出的顶端...
  • 向工作表添加列表框或组合框

    千次阅读 2012-05-04 10:29:40
    添加列表(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 ...“常用”类别的“使用 Excel 时采用的首选”下,选中“功能区显示‘开发工具’选项卡”复
  • javafX8初探(组合框

    万次阅读 2015-02-10 12:01:12
    本章介绍如何应用使用组合框,我们将会讲到可修改和可修改的组合框,告诉我们怎样跟踪可修改组合框的变化以及处理它们的事件,并且还会讲到如何利用单元格工厂修改默认的实现方式。 组合框是用户界面典型的...
  • Python3对股票的投资组合进行分析

    万次阅读 多人点赞 2019-04-21 10:45:27
    1、股票选择 2、获取每支股票的收盘价 3、计算股票的日收益率 二、投资组合的收益计算 1、给定权重的投资组合 2、等权重的投资组合 3、市值加权的投资组合 三、投资组合的相关性分析 1、投资组合的相关矩阵 ...
  • 组合框

    千次阅读 2012-05-23 15:31:04
    组合框控件的功能被封装Microsoft基础类库CComboBox类。本教程演示了这个类的一些常用功能。  如何获取列表的选项:(Ctrl+Enter换行添加个选项) 1.添加控件; 2.为控件添加CComboBox 类型的变量m_...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 192,673
精华内容 77,069
关键字:

在组合框中不能进行多项选择