精华内容
下载资源
问答
  • 2016-11-20 17:34:50
    组合框获取当前选择的文本
      
        int index = m_repeatCount.GetCurSel();
    CString str;
    m_repeatCount.GetLBText(index,str);
    MessageBox(str);
    更多相关内容
  • 今天小编就为大家分享一篇关于易语言获取组合框当前选中项目数值的方法,小编觉得内容挺不错的,现在分享给大家,具有很好的参考价值,需要的朋友一起跟随小编来看看吧
  • C# ComboBox:组合框控件

    千次阅读 2019-06-11 23:19:40
    C#WinForm开发中组合框(ComboBox)控件也称下拉列表框, 用于选择所需的选项,例如注册学生信息时选择学历、专业等。 使用组合框可以有效地避免非法值的输入。 在组合框中也有一些经常使用的属性,如下表所...

           在 C# WinForm开发中组合框(ComboBox)控件也称下拉列表框,

     用于选择所需的选项,例如在注册学生信息时选择学历、专业等。
     
            使用组合框可以有效地避免非法值的输入。

    在组合框中也有一些经常使用的属性,如下表所示。

           在组合框中常用的事件是改变组合框中的值时发生的,即组合框中的选项改变事件 SelectedlndexChanged。

    【实例】

                实现一个选择专业的实例。

    Form1.cs

    using System;
    using System.Collections.Generic;
    using System.ComponentModel;
    using System.Data;
    using System.Drawing;
    using System.Linq;
    using System.Text;
    using System.Windows.Forms;
    
    namespace ComboBox
    {
        public partial class Form1 : Form
        {
            public Form1()
            {
                InitializeComponent();
            }
    
            //窗体加载事件,为组合框添加值
            private void Form1_Load(object sender, EventArgs e)
            {
                comboBox1.Items.Add("计算机应用");
                comboBox1.Items.Add("英语");
                comboBox1.Items.Add("会计");
                comboBox1.Items.Add("软件工程");
                comboBox1.Items.Add("网络工程");
            }
    
            //组合框中选项改变的事件
            private void comboBox1_SelectedIndexChanged(object sender, EventArgs e)
            {
                //当组合框中选择的值发生变化时弹出消息框显示当前组合框中选择的值
                MessageBox.Show("您选择的专业是:" + comboBox1.Text, "提示");
            }
    
            //“添加”按钮的单击事件,用于向组合框中添加文本框中的值
            private void button1_Click(object sender, EventArgs e)
            {
                //判断文本框中是否为空,不为空则将其添加到组合框中
                if (textBox2.Text != "")
                {
                    //判断文本框中的值是否与组合框中的的值重复
                    if (comboBox1.Items.Contains(textBox2.Text))
                    {
                        MessageBox.Show("该专业已存在!");
                    }
                    else
                    {
                        comboBox1.Items.Add(textBox2.Text);
                        MessageBox.Show("添加成功!");
                    }
                }
                else
                {
                    MessageBox.Show("请输入专业!", "提示");
                }
            }
    
            //“删除按钮的单击事件,用于删除文本框中输入的值”
            private void button2_Click(object sender, EventArgs e)
            {
                //判断文本框是否为空
                if (textBox2.Text != "")
                {
                    //判断组合框中是否存在文本框中输入的值
                    if (comboBox1.Items.Contains(textBox2.Text))
                    {
                        comboBox1.Items.Remove(textBox2.Text);
                        MessageBox.Show("删除成功!");
                    }
                    else
                    {
                        MessageBox.Show("您输入的专业不存在", "提示");
                    }
                }
                else 
                {
                    MessageBox.Show("请输入要删除的专业", "提示");
                }
            }
     
        }
    }
    

    Program.cs

    using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Windows.Forms;
    
    namespace ComboBox
    {
        static class Program
        {
            /// <summary>
            /// 应用程序的主入口点。
            /// </summary>
            [STAThread]
            static void Main()
            {
                Application.EnableVisualStyles();
                Application.SetCompatibleTextRenderingDefault(false);
                Application.Run(new Form1());
            }
        }
    }
    

                                  

                                   

                                       

     

     

     

     


     

    展开全文
  • MFC编程之组合框控件

    2018-05-04 15:46:35
    什么是组合框这里我做了一个例程,选择不同的边缘会又不一样的值,并且能修改和保存。 下面是效果图。...简易组合框中的列表框是一直显示的。 下拉式组合框默认不显示列表框,只有点击了...

    什么是组合框? 在这里我做了一个例程,选择不同的边缘会又不一样的值,并且能修改和保存。 下面是效果图。
    这里写图片描述
    这里写图片描述

    组合框控件简介

    组合框其实就是把一个编辑框和一个列表框组合到了一起,分为三种:简易(Simple)组合框、下拉式(Dropdown)组合框和下拉列表式(Drop List)组合框。下面讲讲它们的区别。

    简易组合框中的列表框是一直显示的。

    下拉式组合框默认不显示列表框,只有在点击了编辑框右侧的下拉箭头才会弹出列表框。

    下拉列表式组合框的编辑框是不能编辑的,只能由用户在下拉列表框中选择了某项后,在编辑框中显示其文本。

    经过上面的介绍,大家应该知道,最常用的当属下拉式组合框和下拉列表式组合框了,它们在很多时候能使程序看起来更专业,更简洁,让用户在进行选择操作时更方便。

    组合框被操作时会向父窗口发送通知消息,这些通知消息及其含义如下:

    CBN_CLOSEUP:组合框的列表框组件被关闭,简易组合框不会发送该通知消息
    CBN_DBLCLK:用户在某列表项上双击鼠标,只有简易组合框才会发送该通知消息
    CBN_DROPDOWN:组合框的列表框组件下拉,简易式组合框不会发送该通知消息
    CBN_EDITUPDATE:在编辑框准备显示改变了的正文时发送该消息,下拉列表式组合框不会发送该消息
    CBN_EDITCHANGE:编辑框的内容被用户改变了,与CBN_EDITUPDATE不同,该消息是在编辑框显示的正文被刷新后才发出的,下拉列表式组合框不会发送该消息
    CBN_ERRSPACE:组合框无法申请足够的内存来容纳列表项
    CBN_SELENDCANCEL:表明用户的选择应该取消,当用户在列表框中选择了一项,然后又在组合框控件外单击鼠标时就会导致该消息的发送
    CBN_SELENDOK:用户选择了一项,然后按了回车键或单击了下滚箭头,该消息表明用户确认了自己所作的选择
    CBN_KILLFOCUS:组合框失去了输入焦点
    CBN_SELCHANGE:用户通过单击或移动箭头键改变了列表的选择
    CBN_SETFOCUS:组合框获得了输入焦点

    组合框控件的创建

    MFC将组合框控件的所有操作都封装到了CComboBox类中。

    我们在对话框中加入组合框时,可以往对话框模板中拖入Combo Box控件,而后添加CComboBox类型的控件变量使用,但如果我们想在程序中动态创建的话,就要使用CComboBox类的成员函数Create了。Create函数的原型如下:

    virtual BOOL Create(
    DWORD dwStyle,
    const RECT& rect,
    CWnd* pParentWnd,
    UINT nID
    );

    大家可以看出,CComboBox类的Create成员函数同前面几个控件类的Create成员函数非常类似,dwStyle指定组合框控件的风格,rect为列表框弹出后组合框的位置和尺寸,pParentWnd是指向父窗口的指针,不能为NULL,nID指定组合框控件的ID。最后还是重点讲讲dwStyle参数。组合框控件的风格包括以下几种,并给出了相应说明:

       CBS_AUTOHSCROLL:使编辑框组件具有水平滚动的风格
       CBS_DISABLENOSCROLL:使列表框在不需要滚动时显示一个禁止的垂直滚动条
       CBS_DROPDOWN:指定一个下拉式组合框
       CBS_DROPDOWNLIST:指定一个下拉列表式组合框
       CBS_HASSTRINGS:指定一个含有字符串的自绘式组合框
       CBS_LOWERCASE:将编辑框和列表框中的所有文本都自动转换为小写字符
       CBS_NOINTEGRALHEIGHT:组合框的尺寸由应用程序而不是Windows 指定,通常,由Windows指定尺寸会使列表项的某些部分隐藏起来
       CBS_OEMCONVERT:使编辑框组件中的正文可以在ANSI 字符集和OEM字符集之间相互转换。这在编辑框中包含文件名时是很有用的
       CBS_OWNERDRAWFIXED:指定自绘式组合框,即由父窗口负责绘制列表框的内容,并且列表项有相同的高度
       CBS_OWNERDRAWVARIABLE:指定自绘式组合框,并且列表项有不同的高度
       CBS_SIIMPLE:指定一个简易组合框
       CBS_SORT:自动对列表框组件中的项进行排序
       CBS_UPPERCASE:将编辑框和列表框中的所有文本都自动转换为大写字符
    
       dwStyle参数可以是以上风格的组合。跟其他控件一样,创建时一般也还要指定WS_CHILD、WS_VISIBLE、WS_TABSTOP和WS_VSCROLL等风格。
    
       在对话框模板中直接添加组合框控件时,其属性页中的属性包含了以上风格,例如属性Uppercase设为True就相当于指定了CBS_UPPERCASE风格。
    
       CComboBox类的主要成员函数
    

    因为组合框是由编辑框和列表框组合而成的,所以组合框的操作和编辑框与列表框的操作有很多相似之处,同样的,CComboBox类的成员函数也和CEdit类与CListBox类的成员函数有很多相似之处,不但功能相似,甚至函数名和参数也很相似。下面大概讲解下CComboBox类的主要成员函数,更详细的内容可以参见MSDN。

    int GetCount( ) const;
    获取组合框控件的列表框中列表项的数量。

    int GetCurSel( ) const;
    获取组合框控件的列表框中选中项的索引,如果没有选中任何项,该函数返回CB_ERR。

    int SetCurSel(int nSelect);
    在组合框控件的列表框中选择某项。nSelect参数指定了要选择的列表项的索引,如果为-1则列表框中当前选择项被取消选中,编辑框也被清空。

    DWORD GetEditSel( ) const;
    获取组合框控件的编辑框中当前选择范围的起始和终止字符的位置。该函数返回一个32位数,低16位存放起始位置,高16位存放选择范围后第一个非选择字符的位置。如果该函数用于下拉列表式组合框时,会返回CB_ERR。

    BOOL SetEditSel(int nStartChar,int nEndChar);
    用于在组合框控件的编辑框中选择字符。nStartChar参数指定起始位置,nEndChar参数指定终止位置。

    DWORD_PTR GetItemData(int nIndex) const;
    获取组合框中指定项所关联的32位数据。nIndex参数指定组合框控件的列表框某项的索引(从0开始)。

    int SetItemData(int nIndex,DWORD_PTR dwItemData);
    为某个指定的组合框列表项设置一个关联的32位数。nIndex参数指定要进行设置的列表项索引。dwItemData参数指定要关联的新值。

    void GetLBText(int nIndex,CString& rString) const;
    从组合框控件的列表框中获取某项的字符串。nIndex参数指定要获取字符串的列表项的索引,CString参数用于接收取到的字符串。

    int GetLBTextLen(int nIndex) const;
    获取组合框控件的列表框中某项的字符串长度。nIndex参数指定要获取字符串长度的列表项的索引。

    int GetTopIndex( ) const;
    获取组合框控件的列表框中第一个可见项的索引。

    int SetTopIndex(int nIndex);
    将组合框控件的列表框中某个指定项设置为可见的。nIndex参数指定了该列表项的索引。该函数成功则返回0,有错误发生则返回CB_ERR。

    BOOL LimitText(int nMaxChars);
    用于限制用户在组合框控件的编辑框中能够输入的最大字节长度。nMaxChars参数指定了用户能够输入文字的最大字节长度,如果为0则长度被限制为65535个字节。

    int AddString(LPCTSTR lpszString);
    为组合框控件中的列表框添加新的列表项。lpszString参数是指向要添加的字符串的指针。该函数的返回值如果大于等于0,那么它就是新列表项的索引,而如果有错误发生则会返回CB_ERR,如果没有足够的内存存放新字符串则返回CB_ERRSPACE。

    int DeleteString(UINT nIndex);
    删除组合框中某指定位置的列表项。nIndex参数指定了要删除的列表项的索引。该函数的返回值如果大于等于0,那么它就是组合框中剩余列表项的数量。如果nIndex指定的索引超出了列表项的数量则返回CB_ERR。

    int FindString(int nStartAfter,LPCTSTR lpszString) const;
    在组合框控件的列表框中查找但不选中第一个包含指定前缀的列表项。nStartAfter参数指定了第一个要查找的列表项之前的那个列表项的索引。lpszString指向包含要查找的前缀的字符串。该函数的返回值如果大于等于0,那么它是匹配列表项的索引,如果查找失败则返回CB_ERR。

    int InsertString(int nIndex,LPCTSTR lpszString);
    向组合框控件的列表框中插入一个列表项。nIndex参数指定了要插入列表项的位置,lpszString参数则指定了要插入的字符串。该函数返回字符串被插入的位置,如果有错误发生则会返回CB_ERR,如果没有足够的内存存放新字符串则返回CB_ERRSPACE。

    int SelectString(int nStartAfter,LPCTSTR lpszString);
    在组合框控件的列表框中查找一个字符串,如果查找到则选中它,并将其显示到编辑框中。参数同FindString。如果字符串被查找到则返回此列表项的索引,如果查找失败则返回CB_ERR,并且当前选择项不改变。

    此外,CComboBox类还继承了CWnd类的成员函数GetWindowText、SetWindowText等。

    CComboBox类应用实例

    最后给大家写一个简单的实例,说明CComboBox的几个成员函数及通知消息等的使用方法。此实例实现的功能:在组合框中包含一个网站列表,切换组合框控件的列表框中选择的列表项时,将新选中的列表项的文本显示到编辑框中。下面是具体实现步骤:

    1. 创建一个基于对话框的MFC工程,名称设置为“ComBoxtest”。

    2. 在自动生成的对话框模板IDD_ComBoxtest_DIALOG中,删除“TODO: Place dialog controls here.”静态文本控件、“OK”按钮和“Cancel”按钮。添加一个Combo Box控件,ID设置为IDC_COMBO,Type属性设为Drop List,为下拉列表式组合框,编辑框不允许用户输入,Sort属性设为False,以取消排序显示。再添加四一个静态文本控件和两个编辑框,静态文本控件的Caption属性分为设置为设为“边缘选择”,“找边宽度”,“阈值“,”mm“,编辑框的ID设为IDC_EDIT1和IDC_EDIT2,Read Only属性设为True。此时的对话框模板如下图:
      这里写图片描述

    3. 为组合框IDC_WEB_COMBO添加CComboBox类型的控件变量m_ComBox1。
      为两个编辑框添加变量,分别为m_EdgeThreshold,m_EdgeWidth。
      并定位6个double类型的变量用于存贮 每条边的找边宽度和阈值。

    //定义每条边的参数;
    double Up_EdgeWidth = 0;   //上边缘找边宽度
    double Up_Threshold = 0;    //上边缘阈值
    
    double Under_EdgeWidth = 0;
    double Under = 0;
    
    double L_EdgeWidth = 0;
    double L_Thresh// CComBoxTestDlg 消息处理程序
    
    BOOL CComBoxTestDlg::OnInitDialog()
    {
        CDialogEx::OnInitDialog();
    
        // 将“关于...”菜单项添加到系统菜单中。
    
        // IDM_ABOUTBOX 必须在系统命令范围内。
        ASSERT((IDM_ABOUTBOX & 0xFFF0) == IDM_ABOUTBOX);
        ASSERT(IDM_ABOUTBOX < 0xF000);
    
        CMenu* pSysMenu = GetSystemMenu(FALSE);
        if (pSysMenu != NULL)
        {
            BOOL bNameValid;
            CString strAboutMenu;
            bNameValid = strAboutMenu.LoadString(IDS_ABOUTBOX);
            ASSERT(bNameValid);
            if (!strAboutMenu.IsEmpty())
            {
                pSysMenu->AppendMenu(MF_SEPARATOR);
                pSysMenu->AppendMenu(MF_STRING, IDM_ABOUTBOX, strAboutMenu);
            }
        }
    
        // 设置此对话框的图标。当应用程序主窗口不是对话框时,框架将自动
        //  执行此操作
        SetIcon(m_hIcon, TRUE);         // 设置大图标
        SetIcon(m_hIcon, FALSE);        // 设置小图标
    
        // TODO: 在此添加额外的初始化代码
        m_ComBox1.AddString(__T("上边缘"));
        m_ComBox1.AddString(__T("左侧边缘"));
        m_ComBox1.AddString(__T("下边缘"));
        m_ComBox1.AddString(__T("右侧边缘"));
    
    
        return TRUE;  // 除非将焦点设置到控件,否则返回 TRUE
    }
    

    5.我们希望在组合框中选中的列表项改变时,将最新的选择项实时显示到编辑框中,那么这就要用到CBN_SELCHANGE通知消息。为列表框IDC_COMBO的通知消息CBN_SELCHANGE添加消息处理函数CComBoxTestDlg::OnCbnSelchangeCombo(),并修改如下:

    /****************************************
    *函 数 名: CComBoxTestDlg::OnCbnSelchangeCombo()
    *描    述: 当选中组合框中的字符串的时候会调用此函数
    *输入参数:无
    *输出参数:无
    *作    者:shirunfa
    ******************************************/
    void CComBoxTestDlg::OnCbnSelchangeCombo()
    {
        // TODO: 在此添加控件通知处理程序代码
        CString strtemp;
        int nsel;
        // 获取组合框控件的列表框中选中项的索引 
        nsel = m_ComBox1.GetCurSel(); 
        //根据索引获取该字符串
        m_ComBox1.GetLBText(nsel,strtemp);
    
        if(strtemp==__T("上边缘"))
        {
            m_EdgeThreshold = Up_Threshold;
            m_EdgeWidth     = Up_EdgeWidth;
        }
        if(strtemp==__T("下边缘"))
        {
            m_EdgeThreshold = Under_EdgeWidth;
            m_EdgeWidth     = Under_EdgeWidth;
        }
        if(strtemp==__T("左侧边缘"))
        {
            m_EdgeThreshold = L_Threshold;
            m_EdgeWidth     = L_EdgeWidth;
        }
        if(strtemp==__T("右侧边缘"))
        {
            m_EdgeThreshold = R_Threshold;
            m_EdgeWidth     = R_EdgeWidth;
        }
        UpdateData(FALSE);
    }

    6.然后给两个编辑框添加消息处理函数,代码如下:

    /****************************************
    *函 数 名: CComBoxTestDlg::OnEnChangeEdit1()
    *描    述: 当选中找边宽度编辑框的时候会调用此函数
    *输入参数:无
    *输出参数:无
    *作    者:shirunfa
    ******************************************/
    void CComBoxTestDlg::OnEnChangeEdit1()
    {
        UpdateData(TRUE);
        //先判断选择哪一条边
        int E_num;
        CString strtemp;
        E_num = m_ComBox1.GetCurSel();
        m_ComBox1.GetLBText(E_num,strtemp);
        if(strtemp == __T("上边缘"))
        {
    
            Up_EdgeWidth = m_EdgeWidth;
        }
        if(strtemp == __T("下边缘"))
        {
    
            Under_EdgeWidth = m_EdgeWidth;
        }
    
        if(strtemp == __T("左侧边缘"))
        {
    
            L_EdgeWidth = m_EdgeWidth;
        }
    
        if(strtemp == __T("右侧边缘"))
        {
    
            R_EdgeWidth = m_EdgeWidth;
        }
    
    }
    
    /****************************************
    *函 数 名: CComBoxTestDlg::OnEnChangeEdit2()
    *描    述: 当选中阈值编辑框的时候会调用此函数
    *输入参数:无
    *输出参数:无
    *作    者:shirunfa
    ******************************************/
    void CComBoxTestDlg::OnEnChangeEdit2()
    {
        UpdateData(TRUE);
        //先判断选择哪一条边
        int E_num;
        CString strtemp;
        E_num = m_ComBox1.GetCurSel();
        m_ComBox1.GetLBText(E_num,strtemp);
        if(strtemp == __T("上边缘"))
        {
            Up_Threshold = m_EdgeThreshold;
    
        }
        if(strtemp == __T("下边缘"))
        {
            Under_EdgeWidth = m_EdgeThreshold;
    
        }
    
        if(strtemp == __T("左侧边缘"))
        {
            L_Threshold = m_EdgeThreshold;
    
        }
    
        if(strtemp == __T("右侧边缘"))
        {
            R_Threshold = m_EdgeThreshold;
    
        }
    }
    

    7.运行程序,弹出结果对话框,在对话框的组合框中改变选择项时,编辑框中的显示会相应改变。效果图如下:
    这里写图片描述

    展开全文
  • 组合框列表项选择源码: .版本 2 .局部变量 i, 整数型 .局部变量 当前省, 文本型 当前省 = 组合框1.取项目文本 (组合框1.现行选中项) 组合框2.清空 () 编辑框2.内容 = “” 编辑框2.加入文本 (“你选择了:...

    本节课通过自定义数据类型实现易语言组合框二级联动。

    组合框列表项被选择源码:

    .版本 2
    
    .局部变量 i, 整数型
    .局部变量 当前省, 文本型
    
    当前省 = 组合框1.取项目文本 (组合框1.现行选中项)
    组合框2.清空 ()
    编辑框2.内容 = “”
    编辑框2.加入文本 (“你选择了:” + 组合框1.取项目文本 (组合框1.现行选中项) + “省” + #换行符)
    
    .计次循环首 (取数组成员数 (所有城市), i)
    .如果真 (所有城市 [i].省份 = 当前省)
    组合框2.加入项目 (所有城市 [i].城市, i)
    .如果真结束
    
    .计次循环尾 ()
    组合框2.现行选中项 = 0
    编辑框2.加入文本 (“该省共有:” + 到文本 (组合框2.取项目数 ()) + “地区” + #换行符 + “地区分布:”)
    .计次循环首 (取数组成员数 (所有城市), i)
    .如果真 (所有城市 [i].省份 = 当前省)
    编辑框2.加入文本 (所有城市 [i].地区 + “;”)
    .如果真结束
    
    .计次循环尾 ()
    _组合框2_列表项被选择 ()

    窗口创建完毕初始化源码:

    .版本 2
    
    .局部变量 当前城市, 城市
    .局部变量 所有省份, 字节集
    .局部变量 当前省份, 字节集
    .局部变量 省份个数, 整数型
    .局部变量 i, 整数型
    .局部变量 城市列表, 文本型, , "0"
    
    城市列表 = 取配置节名 (取运行目录 () + “\data.ini”)
    
    .计次循环首 (取数组成员数 (城市列表), i)
    当前城市.id = 到整数 (城市列表 [i])
    当前城市.城市 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “城市”, )
    当前城市.地区 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “地区”, )
    当前城市.省份 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “省份”, )
    加入成员 (所有城市, 当前城市)
    
    当前省份 = 到字节集 (取文本长度 (当前城市.省份)) + 到字节集 (当前城市.省份)
    
    .如果真 (寻找字节集 (所有省份, 当前省份, ) = -1)
    所有省份 = 所有省份 + 当前省份
    
    省份个数 = 省份个数 + 1
    
    .如果真结束
    跳过 ()
    .计次循环尾 ()
    组合框1.列表项目 = 取字节集左边 (到字节集 (省份个数), 2) + 所有省份

    自定义数据类型

    .版本 2
     
    .数据类型 城市
        .成员 id, 整数型
        .成员 城市, 文本型
        .成员 地区, 文本型
        .成员 省份, 文本型

    配置文件Data.ini

    [1]
    城市=昌平
    地区=青岛
    省份=山东
    [2]
    城市=平邑
    地区=临沂
    省份=山东
    [3]
    城市=长清
    地区=济南
    省份=山东
    [4]
    城市=滕州
    地区=枣庄
    省份=山东
    [5]
    城市=莱山
    地区=烟台
    省份=山东
    [6]
    城市=利津
    地区=东营
    省份=山东
    [7]
    城市=寿光
    地区=潍坊
    省份=山东
    [8]
    城市=曲阜
    地区=济宁
    省份=山东
    [9]
    城市=新泰
    地区=泰安
    省份=山东
    [10]
    城市=荣成
    地区=威海
    省份=山东
    [11]
    城市=莒县
    地区=日照
    省份=山东
    [12]
    城市=邹平
    地区=滨州
    省份=山东
    [13]
    城市=夏津
    地区=德州
    省份=山东
    [14]
    城市=临清
    地区=聊城
    省份=山东
    [15]
    城市=巨野
    地区=菏泽
    省份=山东
    [16]
    城市=阳曲
    地区=太原
    省份=山西
    [17]
    城市=左云
    地区=大同
    省份=山西
    [18]
    城市=应县
    地区=朔州
    省份=山西
    [19]
    城市=盂县
    地区=阳泉
    省份=山西
    [20]
    城市=平顺
    地区=长治
    省份=山西
    [21]
    城市=泽州
    地区=晋城
    省份=山西
    [22]
    城市=五台
    地区=忻州
    省份=山西
    [23]
    城市=文水
    地区=吕梁
    省份=山西
    [24]
    城市=平遥
    地区=晋中
    省份=山西
    [25]
    城市=洪洞
    地区=临汾
    省份=山西
    [26]
    城市=夏县
    地区=运城
    省份=山西
    [27]
    城市=河曲
    地区=忻州
    省份=山西

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言组合框自定义数据类型二级联动

    展开全文
  • 组合框是显示当前项的选择小部件,可以弹出可选择项的列表。组合框可以编辑,允许用户修改列表的每个项。 组合框可以包含pixmap和字符串;insertItem()和setItemText()函数适当重载。对于可编辑组合框,提供...
  • 组合框控件是我们工作中用得很频繁的一个控件,其实就是把一个编辑框和列表框组合一起。 适用范围:当你有多个同级选项时,你又不想创建很多个单选框按钮,这时,组合框就能帮你完成这个复杂的创建过程。 组合框...
  • 组合框同样相当常见,例如,Windows系统的控制面板上设置语言或位置时,有很多选项,用来进行选择的控件就是组合框控件。它为我们的日常操作提供了很多方便。 Xtreme Toolkit Pro是屡获殊荣的VC界面库,是MFC开发...
  • MFC 组合框的用法大全

    千次阅读 2018-06-18 23:31:14
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的例子...
  • ③下拉列表式组合框的编辑框是不能编辑的,只能由用户下拉列表框选择了某项后,编辑框显示其文本。    经过上面的介绍,大家应该知道,最常用的当属下拉式组合框和下拉列表式组合框了,
  • 组合框和列表框都可以界面上同时显示多项内容,并且允许用户选中其中的某项内容,列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • Combo Box (组合框)控件的使用方法

    千次阅读 2019-09-29 17:06:43
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的例子...
  • 简介: 使用 (可通过单击箭头以显示或隐藏控件的表示选择控件下拉列表。ComboBox 控件的文本框允许用户选择项目从下拉列表或选择输入...此控件一般不适用。 Items 获取一个对象,该对象表示该 ...
  • MFC组合框控件总结及用法示例

    万次阅读 2014-04-26 23:01:50
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单...组合框控件既可以进行输入,也可以列表框组成部分进行选择。打开组合框控件的属性窗口,下图所示:
  • qml 组合框ComboBox

    千次阅读 2020-11-18 22:06:35
    ComboBox填充数据模型,数据模型通常是JavaScript数组,ListModel...currentIndex : int,保存组合框中当前项的索引,只读 currentText : string,组合框中当前项的文本,只读 delegate : Component,包含一个委托,该.
  • MFC 组合框(下拉框) CComboBox

    千次阅读 2018-11-03 20:28:07
    获取组合框中当前选中项的下标 CComboBox::GetLBText 获取指定位置的内容 CComboBox::DeleteString 删除指定位置的字符串 CComboBox::...
  • //当下拉列表框中的项重新选择时 产生一个currentIndexChanged(int index)信号 弹出一个消息提示你重新选择了哪一项    connect(comboBox, SIGNAL(currentIndexChanged( int )),  this , SLOT...
  • 复选框、单行文本框、组合框

    千次阅读 2017-06-28 11:33:41
    bool isChecked() const //判断这个复选是否被选中 void setChecked(bool) //设置这个复选选中情况 复选的信号 void stateChanged(int state) //状态改变信号 例1创建一个是否同意协议的复选框选中后下一步...
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框选择的项会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、项的添加和删除...
  • CString CellID; GetDlgItem(IDC_COMBO_CellID)->GetWindowText(CellID); //获得组合框中选中内容
  • 从ComboBox取出选择项,并显示另外的label控件上 第一步:建立界面如下: 包含一个组合框ComboBox和一个label 第二步:编写ComboBox的SelectIndexChanged代码 第三步:为ComboBox添加数据 using...
  • VB.net组合框笔记

    2016-09-06 23:36:11
    2、获取当前选中的元素下标: Dim id As Integer  id = Combo_net.SelectedIndex() 当组合框未选中任何内容是,id值为-1,否则为某个合法下标(大于等于0) 3、向组合框添加新元素: Combo_net.Items.Add("已经...
  • idea怎么设置选中文件时,自动左侧弹出文件所在位置及文件快捷键Alt 1WORD选中光标前所有文字和光标后面所有文字的快捷键是什么?那不是全部选择了?Ctrl A就行了。光标前后所有的内容就都包括了(不过这是所有...
  • Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的例子...
  • 组合框控件用法大全

    千次阅读 2014-08-04 00:47:02
    当你界面上拖出来了combox控件后,点击它的属性,把No integral height这一项选成true ... 如果你的内容比较多,那么你刚刚拖得那个框框当你编译完运行后会自动产生一个滚动条的。...一、那就是设计界面里,
  • 1、常用属性 (1)DropDownStyle 组合框的样式 (2)SelectedIndex 当前选定项的索引 (3)SelectedItem 当前选定项 ...(4)Itmes 该组合框中所包含项的集合   2、Items的属性和方法 (1)count
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表可显示的项目数,列表会自动添加滚动条,可以方便用户以滚动的方式来选择列表列表的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能程序代码调用和设置...
  • 组态王下拉列表问题

    千次阅读 2020-12-21 01:45:14
    对于列表控件数据项的添加、修改、获取或删除等操作都是通过列表控件函数实现的。首先认识一下列表控件的函数:listLoadList("ControlName","Filename")此函数用于将CSV格式文件“Filename”的列表项调入...
  • VC编程之组合框

    千次阅读 2013-04-03 10:47:47
    1.如何正确的得到ComBox的指针 CComboBox *mComb = (CComboBox*)GetDlgItem(IDC_DuanCB); CComboBox *mComb = (CComboBox*)::GetDlgItem(m_...CComboBox控件又称作组合框控件,其有三种形态可供选择,1.简单组合框(Sim
  • Visual Studio 组合框ComboBox使用

    千次阅读 2017-11-22 20:48:56
    直接图形界面实现的方法:选中ComboBox控件,点击右键,右键菜单选择“添加变量”,向导完成ComboBox连接变量的创建。二.代码实现的方法:1.界面文件的ComboBox控件:名字为:IDC_COMBO12.h文件...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 50,450
精华内容 20,180
关键字:

在组合框中当前被选中