精华内容
下载资源
问答
  • MFC中组合框获取当前选中文本

    千次阅读 2016-11-20 17:34:50
    组合框获取当前选择的文本    int index = m_repeatCount.GetCurSel(); CString str; m_repeatCount.GetLBText(index,str); MessageBox(str);
    组合框获取当前选择的文本
      
        int index = m_repeatCount.GetCurSel();
    CString str;
    m_repeatCount.GetLBText(index,str);
    MessageBox(str);
    展开全文
  • 组合框函数

    千次阅读 2011-11-06 15:01:25
    MFC,CComboBox类实现了对组合框控件的封装,它提供了组合框操作相关的函数,常用的函数及其功能如表7-16所示。 表7-16 CComboBox类主要成员函数及其功能 ...取得组合框的列表框中当前选中项(如果有的话
     
    

    在MFC中,CComboBox类实现了对组合框控件的封装,它提供了组合框操作相关的函数,常用的函数及其功能如表7-16所示。

    表7-16 CComboBox类主要成员函数及其功能

    函数名称

    函数功能

    GetCount

    取得组合框的列表框中项的个数

    GetCurSel

    取得组合框的列表框中当前选中项(如果有的话)的下标

    SetCurSel

    在组合框的列表框中选择一个字符串

    GetEditSel

    取得组合框的编辑控件中当前选项的起止字符位置

    SetEditSel

    选中组合框的编辑控件中的字符

    SetItemData

    设置组合框中指定项的值

    GetItemData

    检索应用为组合框的项提供的值

    GetTopIndex

    返回组合框中列表框的第一个可见项的下标

    SetTopIndex

    让组合框的列表框显示指定下标所在的项

    SetHorizontalExtent

    设置组合框中列表框的水平宽度(以像素为单位),如果列表超过该宽度,将需要用滚动条

    GetHorizontalExtent

    返回组合框中列表框的水平宽度(以像素为单位)

    LimitText

    设置用户可以在组合框的编辑控件中输入的文本的最大长度

    SetItemHeight

    设置组合宽中列表框的项的高度或编辑控件(或静态控件)中文本的高度

    GetItemHeight   

    取得组合框中列表项的高度

    GetLBTextLen

    取得组合框的列表框中某个字符串的长度

    GetLBText

    从组合框的列表框中取得一个字符串

    GetDroppedState

    检测组合框的列表框是否可见(是否已经下拉)

    AddString

    在组合框的列表框的列表末尾添加一个字符串,或在具有CBS_ SORT风格的的列表框中按次序所在的位置插入一个字符串

    DeleteString

    删除组合框中的列表框中的一个字符串

    InsertString

    在组合框的列表框中插入一个字符串

    ResetContent

    删除组合框的列表框和编辑控件中的所有项

    FindString

    在组合框的列表框中查找具有指定前缀的第一个字符串

    FindStringExact

    在组合框的列表框中查找具有与指定字符串完全匹配的第一个字符串

    SelectString

    在组合框的列表框中查找字符串,找到后选中它,并把它复制到编辑控件中

    在对话框中,组合框的最常用操作就是获取用户的选择项,其使用可表示如下:

    CComboBox* m_combo=GetDlgItem(“IDC_COMBOBOX”)                     //获取组合框的指针

    int nselect= m_combo->GetCurSel();                                                             //获取当前组合框选项的索引

            CString szname;

            m_combo->GetLBText(nselect,szname);                                                        //组合框选项的标题

    另外,经常还需要通过AddString和DeleteString添加、删除组合框项。可见,其使用与列表框有很大的相似

    展开全文
  • 组合框

    千次阅读 2012-05-23 15:31:04
    组合框控件的功能封装Microsoft基础类库CComboBox类。本教程演示了这个类的一些常用功能。  如何获取列表的选项:(Ctrl+Enter换行添加多个选项) 1.添加控件; 2.为控件添加CComboBox 类型的变量m_...

    组合框控件显示一个字符串在下拉菜单式的列表。提供一种方法来显示多个选项,同时节省空间,组合框结合了列表框和编辑框的功能。组合框控件的功能被封装在Microsoft基础类库CComboBox类。本教程演示了这个类的一些常用功能。

     如何获取列表中的选项:(Ctrl+Enter换行添加多个选项)

    1.添加控件;

    2.为控件添加CComboBox 类型的变量m_Combox;

    3.添加CBN_SELENDOK消息响应函数,在该函数中添加以下代码:

     int nIndex = m_Combox.GetCurSel(); 
     CString strCBText;
     m_Combox.GetLBText( nIndex, strCBText);
     此时列表中被选中的选项被放入strCBText中;

    4.根据需要添加代码; 


    这就是你需要:

    微软的Visual Studio IDE

    书上的MFC,如“编程与MFC窗口”,由Jeff Prosise

    1。启动Microsoft Visual Studio中。产生点击文件>新建>项目(标签),并选择了这个项目基于对话框的应用程序“的MFC AppWizard(EXE)。”类型“MyCombobox”下的“项目名称”按确定,选择“基于对话框”然后点击完成。

    2。创建一个组合框,并修改其属性。单击工作区左侧的资源选项卡。展开对话框文件夹并选择IDD_MYCOMBOBOX_DIALOG。请从右侧工具箱组合框图标,把它的对话。调整下拉组合框的扩展通过点击箭头并拖累矩形。然后右键单击,选择属性,单击样式选项卡,并根据类型,选择简单。关闭属性框的组合框。

    3。将项目添加到组合框。你可以在两种方式。为了在设计时添加它们,右击组合框,选择属性,单击数据选项卡,然后输入项目。要进入下一个项目,按Ctrl + Enter键。要在运行时添加它们,调用CComboBox:AddString(),添加项目到底部,或CComboBox: InsertString()中插入特定位置的项目。该项目的类型lpszString。

    4。更改组合框的宽度。您可以设置显示任何项目充分显示,不管它有多长。使用CComboBox::SetDroppedWidth()成员函数。它的参数以像素为单位设置字符串宽度。

    5。执行其他常用功能。选择一个项目在运行时使用CComboBox::SetCurSel()。它接受一个整数作为参数的索引。找到与CComboBox选定项的索引::GetCurSel()。数据检索使用CComboBox::GetItemData()。确定项目计数通过CComboBox::GetCount()。

    6。消除从MFC组合框项目。如果字符串是已知的,你可以使用CComboBox::FINDSTRING()来确定索引,然后使用CComboBox::DeleteString()。 CComboBox::清除()删除当前的选择,如果有的话,而CComboBox::剪切()删除当前选择并将其放在剪贴板上。

    7。了解消息映射通知消息,一个组合框可以发送。当组合框的列表框是封闭的,例如,ON_CBN_CLOSEUP发送。当组合框失去,因为它的边界之外点击鼠标的输入焦点时,它发送ON_CBN_KILLFOCUS。有一个为每个可能的状态变化,一个组合框可以进行消息映射。

    8.动态修改下拉菜单的高度

    用到了一个动态创建的组合框,当组合框中的菜单项比较多的时候,默认的组合框下拉菜单高度就显得不够了,为了能改变默认的下拉菜单高度到合适的位置,可以作如下操作:

            CRect rc;
            NewCombo.GetDroppedControlRect(&rc);  //获得屏幕坐标
            NewCombo.GetParent()->ScreenToClient(&rc);  //转换成父窗口客户区的坐标
            rc.bottom += 150;
            NewCombo.MoveWindow(&rc);  //CWnd的成员函数MoveWindow在移动子窗口时将使用父窗口的客户区坐标

          这样就改变了默认的下拉菜单高度,其中NewCombo是一个被动态创建的组合框。


    关于坐标问题:

    m_bnClickhere.AutoLoad(IDC_CLICKHERE, this);

    CRect rect1,rect2;

    CButton *pClickhere=(CButton*)GetDlgItem(IDC_CLICKHERE);

    GetClientRect(&rect1);

    pClickhere->GetWindowRect(&rect2);

    ScreenToClient(&rect2);

    pClickhere->MoveWindow(rect2.left,(rect1.Height()-rect2.Height())/2,

    rect2.Width(),rect2.Height());

    其中第一个参数IDC_CLICKHERE是位图按钮的资源ID,第二个参数为指向该位图按钮的父窗口的CWnd对象的指针,这里即类CBitmapButtonDlg的this指针。类CBitmapButton的成员函数AutoLoad完成以下几步工作:

    (1) 将按钮与CBitmapButton对象相关联;

    (2) 自动加载按钮所使用的位图,条件是这些位图资源满足步骤2中的命名约定;

    (3) 自动改变控件的大小以适合所加载的位图资源。

    接下来的几行代码将位图按钮在对话框中进行垂直居中。首先类CWnd的成员函数GetClientRect返回了对话框的客户区矩形,

    接着,类CWnd的成员函数GetWindowRect返回了控件IDC_CLICKHERE的窗口矩形,

    然后使用类CWnd的成员函数ScreenToClient将rect2由屏幕坐标转换为对话框的客户坐标,

    这是因为类CWnd的成员函数MoveWindow在移动子窗口时将使用父窗口的客户区坐标,而不是使用屏幕坐标。




    展开全文
  • 组合框列表项选择源码: .版本 2 .局部变量 i, 整数型 .局部变量 当前省, 文本型 当前省 = 组合框1.取项目文本 (组合框1.现行选中项) 组合框2.清空 () 编辑框2.内容 = “” 编辑框2.加入文本 (“你选择了:...

    本节课通过自定义数据类型实现易语言组合框二级联动。

    组合框列表项被选择源码:

    .版本 2
    
    .局部变量 i, 整数型
    .局部变量 当前省, 文本型
    
    当前省 = 组合框1.取项目文本 (组合框1.现行选中项)
    组合框2.清空 ()
    编辑框2.内容 = “”
    编辑框2.加入文本 (“你选择了:” + 组合框1.取项目文本 (组合框1.现行选中项) + “省” + #换行符)
    
    .计次循环首 (取数组成员数 (所有城市), i)
    .如果真 (所有城市 [i].省份 = 当前省)
    组合框2.加入项目 (所有城市 [i].城市, i)
    .如果真结束
    
    .计次循环尾 ()
    组合框2.现行选中项 = 0
    编辑框2.加入文本 (“该省共有:” + 到文本 (组合框2.取项目数 ()) + “地区” + #换行符 + “地区分布:”)
    .计次循环首 (取数组成员数 (所有城市), i)
    .如果真 (所有城市 [i].省份 = 当前省)
    编辑框2.加入文本 (所有城市 [i].地区 + “;”)
    .如果真结束
    
    .计次循环尾 ()
    _组合框2_列表项被选择 ()

    窗口创建完毕初始化源码:

    .版本 2
    
    .局部变量 当前城市, 城市
    .局部变量 所有省份, 字节集
    .局部变量 当前省份, 字节集
    .局部变量 省份个数, 整数型
    .局部变量 i, 整数型
    .局部变量 城市列表, 文本型, , "0"
    
    城市列表 = 取配置节名 (取运行目录 () + “\data.ini”)
    
    .计次循环首 (取数组成员数 (城市列表), i)
    当前城市.id = 到整数 (城市列表 [i])
    当前城市.城市 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “城市”, )
    当前城市.地区 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “地区”, )
    当前城市.省份 = 读配置项 (取运行目录 () + “\data.ini”, 城市列表 [i], “省份”, )
    加入成员 (所有城市, 当前城市)
    
    当前省份 = 到字节集 (取文本长度 (当前城市.省份)) + 到字节集 (当前城市.省份)
    
    .如果真 (寻找字节集 (所有省份, 当前省份, ) = -1)
    所有省份 = 所有省份 + 当前省份
    
    省份个数 = 省份个数 + 1
    
    .如果真结束
    跳过 ()
    .计次循环尾 ()
    组合框1.列表项目 = 取字节集左边 (到字节集 (省份个数), 2) + 所有省份

    自定义数据类型

    .版本 2
     
    .数据类型 城市
        .成员 id, 整数型
        .成员 城市, 文本型
        .成员 地区, 文本型
        .成员 省份, 文本型

    配置文件Data.ini

    [1]
    城市=昌平
    地区=青岛
    省份=山东
    [2]
    城市=平邑
    地区=临沂
    省份=山东
    [3]
    城市=长清
    地区=济南
    省份=山东
    [4]
    城市=滕州
    地区=枣庄
    省份=山东
    [5]
    城市=莱山
    地区=烟台
    省份=山东
    [6]
    城市=利津
    地区=东营
    省份=山东
    [7]
    城市=寿光
    地区=潍坊
    省份=山东
    [8]
    城市=曲阜
    地区=济宁
    省份=山东
    [9]
    城市=新泰
    地区=泰安
    省份=山东
    [10]
    城市=荣成
    地区=威海
    省份=山东
    [11]
    城市=莒县
    地区=日照
    省份=山东
    [12]
    城市=邹平
    地区=滨州
    省份=山东
    [13]
    城市=夏津
    地区=德州
    省份=山东
    [14]
    城市=临清
    地区=聊城
    省份=山东
    [15]
    城市=巨野
    地区=菏泽
    省份=山东
    [16]
    城市=阳曲
    地区=太原
    省份=山西
    [17]
    城市=左云
    地区=大同
    省份=山西
    [18]
    城市=应县
    地区=朔州
    省份=山西
    [19]
    城市=盂县
    地区=阳泉
    省份=山西
    [20]
    城市=平顺
    地区=长治
    省份=山西
    [21]
    城市=泽州
    地区=晋城
    省份=山西
    [22]
    城市=五台
    地区=忻州
    省份=山西
    [23]
    城市=文水
    地区=吕梁
    省份=山西
    [24]
    城市=平遥
    地区=晋中
    省份=山西
    [25]
    城市=洪洞
    地区=临汾
    省份=山西
    [26]
    城市=夏县
    地区=运城
    省份=山西
    [27]
    城市=河曲
    地区=忻州
    省份=山西

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言组合框自定义数据类型二级联动

    展开全文
  • MFC获取组合框中元素的索引值

    千次阅读 2013-05-03 23:33:27
    MFC中组合框控件的使用 分类: Windows(C/C++,MFC,C#) 2011-07-18 23:431254人阅读 评论(1)收藏 举报 mfc 由于是第一次使用组合框, 今天要使用组合框时还真是波折不少,所以将过程总结一下,避免下次...
  • VB.net组合框笔记

    2016-09-06 23:36:11
    2、获取当前选中的元素下标: Dim id As Integer  id = Combo_net.SelectedIndex() 当组合框未选中任何内容是,id值为-1,否则为某个合法下标(大于等于0) 3、向组合框添加新元素: Combo_net.Items.Add("已经...
  • 组合框控件

    2011-06-24 09:24:00
    组合框把一个编辑框和一个单选择列表框结合了一起.用户既可以编辑框输入,也可以从列表框选择一个列表项来完成输入。组合框分为简易式(Simple combo box)、下拉式(Drop-down combo box)和下拉列表式(Drop-...
  • 那么这次就让我们来模仿它做个十分常用的控件:"颜色组合框"。如果你现在正在做关于字处理类的软件时这个"东东"一定对你有用。程序编译运行后的界面效果如图一所示: 图一、颜色选择组合框 ...
  • CString CellID; GetDlgItem(IDC_COMBO_CellID)->GetWindowText(CellID); //获得组合框中选中内容
  • 组合框控件CComboBox

    千次阅读 2011-01-22 22:48:00
    当用户列表框中选中一个项目时,该项目将显示静态文本或编辑框中。 CComboBox控件的主要方法、消息如下。 (1)GetTopIndex方法 该方法返回列表框中第一个可见项目的索引。 语法: int GetTopIndex( ) ...
  • 组合框控件Combo Box和CComboBox类

    千次阅读 2014-06-24 14:54:27
    组合框同样相当常见,例如,Windows系统的控制面板上设置语言或位置时,有很多选项,用来进行选择的控件就是组合框控件。它为我们的日常操作提供了很多方便。  组合框控件简介  组合框其实就是把一个编辑...
  • 组合框和列表框都可以界面上同时显示多项内容,并且允许用户选中其中的某项内容,列表框还允许同时选择多项。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • MFC组合框控件总结及用法示例

    万次阅读 2014-04-26 23:01:50
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单...组合框控件既可以进行输入,也可以列表框组成部分进行选择。打开组合框控件的属性窗口,下图所示:
  • 1、常用属性 (1)DropDownStyle 组合框的样式 (2)SelectedIndex 当前选定项的索引 (3)SelectedItem 当前选定项 ...(4)Itmes 该组合框中所包含项的集合   2、Items的属性和方法 (1)count
  • MFC 组合框ComboBox总结

    千次阅读 2013-07-23 17:01:24
    Combo Box (组合框)控件很简单,可以节省空间。从用户角度来看,这个控件是由一个文本输入控件和一个下拉菜单组成的。用户可以从一个预先定义的列表里选择一个选项,同时也可以直接文本框里面输入文本。下面的...
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表可显示的项目数,列表会自动添加滚动条,可以方便用户以滚动的方式来选择列表列表的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能程序代码调用和设置...
  • 组合框的使用

    千次阅读 2014-03-22 17:41:27
    组合框控件动态创建的用法,包括消息机制、属性修改等。
  • 列表框与组合框

    千次阅读 2005-05-02 13:26:00
    列表框是窗口类名为"ListBox"的预定义子窗口,窗口矩形内包含有一些可以滚动显示的栏状字符串列表。标准的列表框只能允许选中一个条目,选中的条目将以系统...另一种与列表框相关的控件是组合框,该控件预定义类名为
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框选择的项会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、项的添加和删除...
  • 向工作表添加列表框或组合框

    千次阅读 2012-05-04 10:29:40
    添加列表(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 ...“常用”类别的“使用 Excel 时采用的首选项”下,选中功能区显示‘开发工具’选项卡”复
  • 列表框和组合框的使用

    千次阅读 2010-06-24 15:21:00
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框选择的项会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、项的添加...
  • 复选框、单行文本框、组合框

    千次阅读 2017-06-28 11:33:41
    bool isChecked() const //判断这个复选是否被选中 void setChecked(bool) //设置这个复选选中情况 复选的信号 void stateChanged(int state) //状态改变信号 例1创建一个是否同意协议的复选框选中后下一步...
  • OnInitDialog添加初始化程序;sort风格的去与留;UpdateData(TRUE/FALSE)与成员变量的更新; 指向对象的指针函数GetDlgItem;选中Radio ID号码请用GetCheckedRadioButton; _CRT_SECURE_NO_WARNINGS去除安全性警告;
  • MFC 组合框(下拉框) CComboBox

    千次阅读 2018-11-03 20:28:07
    获取组合框中当前选中项的下标 CComboBox::GetLBText 获取指定位置的内容 CComboBox::DeleteString 删除指定位置的字符串 CComboBox::...
  • VC编程之组合框

    千次阅读 2013-04-03 10:47:47
    1.如何正确的得到ComBox的指针 CComboBox *mComb = (CComboBox*)GetDlgItem(IDC_DuanCB); CComboBox *mComb = (CComboBox*)::GetDlgItem(m_...CComboBox控件又称作组合框控件,其有三种形态可供选择,1.简单组合框(Sim
  • 组合框控件(combobox)

    千次阅读 2008-10-20 09:11:00
    组合框把一个编辑框和一个单选择列表框结合了一起.用户既可以编辑框输入,也可以从列表框选择一个列表项来完成输入。组合框分为简易式(Simple combo box)、下拉式(Drop-down combo box)和下拉列表式(Drop-...
  • MFC学习笔记--组合框Combo Box一些操作

    千次阅读 2015-07-19 10:08:12
    Combo Box对应的空间变量CComboBox m_...2、组合框中编辑框自动选中列表的一项 m_CbDrive.SelectString(-1,"C:"); //第一个参数是-1时,从列表开始处开始搜索,假如为2时,从第三个项开始搜索到底部,再从开始处
  • Group Box组合框的简单使用

    千次阅读 2014-10-31 17:01:08
    分类: 2010.9-14.72013-07-13 11:59 5325人阅读 评论(0) 收藏 举报 目录(?)[+] ...1 组合框 Group Box作用 ...MFC基于对话框的应用程序,Group Box组合框就是将组合框内的控件标识为一

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 46,199
精华内容 18,479
关键字:

在组合框中当前被选中