精华内容
下载资源
问答
  • android获取设备eth0,eth1,wlan0的IP地址

    千次阅读 2017-03-16 11:04:32
     这个时候用什么方法来获取这个IP地址呢?楼主在之前的开发中,找到了以下方法,代码如下,仅供参考: /** * Get Ip address 自动获取IP地址 * * @throws SocketException */ public

       在做一些跟网络相关的需求时,很多时候需要获取到相关网络类型的IP地址,如下图:

           

      这个时候用什么方法来获取这个IP地址呢?楼主在之前的开发中,找到了以下方法,代码如下,仅供参考:


    /**
         * Get Ip address 自动获取IP地址
         *
         * @throws SocketException
         */
        public static String getIpAddress(String ipType) throws SocketException {
            String hostIp = null;
            try {
                Enumeration nis = NetworkInterface.getNetworkInterfaces();
                InetAddress ia = null;
                while (nis.hasMoreElements()) {
                    NetworkInterface ni = (NetworkInterface) nis.nextElement();
    
                    if (ni.getName().equals(ipType)) {
    
    
                        Enumeration<InetAddress> ias = ni.getInetAddresses();
                        while (ias.hasMoreElements()) {
    
                            ia = ias.nextElement();
                            if (ia instanceof Inet6Address) {
                                continue;// skip ipv6
                            }
                            String ip = ia.getHostAddress();
    
                            // 过滤掉127段的ip地址
                            if (!"127.0.0.1".equals(ip)) {
                                hostIp = ia.getHostAddress();
                                break;
                            }
                        }
                    }
                }
            } catch (SocketException e) {
                e.printStackTrace();
            }
            Log.d("vivi", "get the IpAddress--> " + hostIp + "");
            return hostIp;
        }
        其中的ipType就是需要获取的网络ip地址类型,我们可以传入eth1,eth0,wlan0,等,为了正确获取到ip地址,我们需要过滤掉ipv6的地址和127.0.0.1。

        感谢阅读,有什么不对的地方还请大家指正。

       


    展开全文
  • 最近碰到了这种情况 估计是装虚拟机搞得 解决办法是把共享关掉重新开一下

    最近碰到了这种情况

    估计是装虚拟机搞得

    解决办法是把共享关掉重新开一下

    展开全文
  • 前景提示 ...业务vlan就是我们使用无线设备获取到的IP地址所属的vlan 管理vlan: 管理vlan就是我们的AP设备自身的IP地址 实验目的 通过此次实验,熟练掌握AP在AC上上线的过程,体会模板调用...

    前景提示

    安全一直是一个很重要的话题,尤其在企业AC+AP组网的方式中。我们通常会把业务vlan和管理vlan区分开来,使用不同的VLAN,增加安全性,这二者其实可以分离的。

    业务vlan:

    业务vlan就是我们使用无线设备获取到的IP地址所属的vlan

    管理vlan:

    管理vlan就是我们的AP设备自身的IP地址

    实验目的

    通过此次实验,熟练掌握AP在AC上上线的过程,体会模板调用的方法。顺便理解traffic-filter和traffic-policy 用法,从而实现业务vlan的用户无法访问AP管理地址以及各个AP的IP地址的实验目的。

    实验拓补

    实验过程

    [AC6005]sysname AC-1029 //更改设备名
    [AC-1029]dhcp enable //开启dhcp服务
    Info: The operation may take a few seconds. Please wait for a moment.done.
    [AC-1029]undo  info-center enable //关闭信息中心提示
    Info: Information center is disabled.
    [AC-1029]vlan batch 10 20 //创建vlan10,20
    Info: This operation may take a few seconds. Please wait for a moment...done.	
    [AC-1029]port-group ap //创建“ap”组
    [AC-1029-port-group-ap]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0
    /2  //组成员是G1端口和G2端口
    [AC-1029-port-group-ap]port link-type trunk //设置端口为trunk
    [AC-1029-port-group-ap]port trunk allow-pass vlan 10 //允许vlan10通过
    [AC-1029-port-group-ap]port trunk pvid vlan 10	//设置PVID值
    [AC-1029-port-group-ap]undo  port trunk allow-pass vlan 1 //禁止vlan1通过
    [AC-1029-port-group-ap]quit 
    [AC-1029]interface Vlanif 10
    [AC-1029-Vlanif10]ip address 192.168.10.254 24
    [AC-1029-Vlanif10]dhcp  select interface 
    [AC-1029-Vlanif10]quit 
    [AC-1029]interface Vlanif 20
    [AC-1029-Vlanif20]ip address  192.168.20.254 24
    [AC-1029-Vlanif20]dhcp  select interface 	
    [AC-1029-Vlanif20]quit 
    [AC-1029]capwap source interface Vlanif 10 //配置源接口地址
    [AC-1029]wlan //进入WLAN视图
    [AC-1029-wlan-view]regulatory-domain-profile name domain1 //创建域名模板,名为“domain1”
    [AC-1029-wlan-regulate-domain-domain1]country-code cn //设置国家码是CN
    Info: The current country code is same with the input country code.	
    [AC-1029-wlan-regulate-domain-domain1]quit 	
    [AC-1029-wlan-view]ap-group name hydq //创建一个组,名“hydq”
    Info: This operation may take a few seconds. Please wait for a moment.done.
    [AC-1029-wlan-ap-group-hydq]regulatory-domain-profile domain1
    Warning: Modifying the country code will clear channel, power and antenna gain c
    onfigurations of the radio and reset the AP. Continue?[Y/N]:y
    [AC-1029-wlan-ap-group-hydq]quit 
    [AC-1029-wlan-view]ap auth-mode mac-auth //设置ap上线的认证方式是Mac认证
    [AC-1029-wlan-view]ap-id 0 ap-mac 00e0-fcba-7e40 //设置ap ID和它的Mac地址
    [AC-1029-wlan-ap-0]ap-name factory1 //命名该ap
    [AC-1029-wlan-ap-0]ap-group hydq //使得该ap加入hydq这个组
    Warning: This operation may cause AP reset. If the country code changes, it will
     clear channel, power and antenna gain configurations of the radio, Whether to c
    ontinue? [Y/N]:y
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-1029-wlan-ap-0]ap-id 1  ap-mac 00e0-fc9e-0ed0 //和上面同理
    [AC-1029-wlan-ap-1]ap-name factory
    [AC-1029-wlan-ap-1]ap-group hydq
    Warning: This operation may cause AP reset. If the country code changes, it will
     clear channel, power and antenna gain configurations of the radio, Whether to c
    ontinue? [Y/N]:y
    Info: This operation may take a few seconds. Please wait for a moment.. done.
    [AC-1029-wlan-ap-1]

    我们用命令查看AP上线情况

    [AC-1029-wlan-ap-1]display ap all
    Info: This operation may take a few seconds. Please wait for a moment.done.
    Total AP information:
    nor  : normal          [2]
    --------------------------------------------------------------------------------
    ------------
    ID   MAC            Name     Group IP            Type            State STA Uptim
    e
    --------------------------------------------------------------------------------
    ------------
    0    00e0-fcba-7e40 factory1 hydq  192.168.10.78 AP4050DN-E      nor   0   2M:49
    S
    1    00e0-fc9e-0ed0 factory  hydq  192.168.10.1  AP4050DN-E      nor   0   1M:53
    S
    --------------------------------------------------------------------------------
    ------------
    Total: 2
    [AC-1029-wlan-ap-1]

     然后我们开始配置各种模板,使得AP正常工作

    
    [AC-1029-wlan-ap-1]quit 	
    [AC-1029-wlan-view]security-profile name hydq //创建安全模板,名为“hydq”
    [AC-1029-wlan-sec-prof-hydq]security wpa-wpa2 psk pass-phrase liuxunyu1314 aes //配置WiFi密码,为liuxunyu1314
    [AC-1029-wlan-sec-prof-hydq]quit 
    [AC-1029-wlan-view]ssid-profile name hydq //创建ssid模板,名为“LXU1314”
    [AC-1029-wlan-ssid-prof-hydq]ssid LXU1314
    Info: This operation may take a few seconds, please wait.done.	
    [AC-1029-wlan-ssid-prof-hydq]quit 	
    [AC-1029-wlan-view]vap-profile name hydq	//创建VAP模板。名为“hydq”
    [AC-1029-wlan-vap-prof-hydq]forward-mode tunnel //转发模式为隧道转发
    Info: This operation may take a few seconds, please wait.done.	
    [AC-1029-wlan-vap-prof-hydq]service-vlan vlan-id 20 //选择业务vlan是,vlan20
    Info: This operation may take a few seconds, please wait.done.
    [AC-1029-wlan-vap-prof-hydq]security-profile hydq //引用security模板,hydq
    Info: This operation may take a few seconds, please wait.done.
    [AC-1029-wlan-vap-prof-hydq]ssid-profile hydq //引用ssid模板,hydq
    Info: This operation may take a few seconds, please wait.done.
    [AC-1029-wlan-vap-prof-hydq]quit 
    [AC-1029-wlan-view]ap-group name hydq //进入组,hydq
    [AC-1029-wlan-ap-group-hydq]vap-profile hydq wlan 1 radio all //组里调用VAP模板,并配置射频,all里面包括,2.4Ghz和5Ghz
    

     

    有两种方式可以实现业务vlan的用户无法访问AP管理地址以及各个AP的IP地址

    在此之前:

    traffic-filter的前身其实是traffic-policy ,由于日益增多的访问控制需求,华为公司简化了traffic-policy,就是traffic-filter的由来。

    事实上,traffic-policy的功能更全面,traffic-filter则相对简单。

    本次实验发现有个有趣的地方,在ENSP模拟器上面,接口下居然没有调用traffic-filter的这个命令,但是有traffic-policy 的选项,大概是不支持?不过我没有去真机环境中测试,所以引发了在vlanif下调用策略路由的血案。

    traffic-filter(流量过滤),只需要配置了ACL,然后在接口或者vlanif下调用即可

    traffic-policy(流量策略),这种方式稍微麻烦,却功能丰富。总体思路,配置流分类(classifier),配置流行为(behavior),配置流策略(traffic policy),在流策略里面引用流分类和流行为,这一点和AP在AC里面VAP模板调用security和SSID模板有异曲同工之妙。

    第一种:调用traffic-filter

    [AC-1029]acl	
    [AC-1029]acl 3000	//创建高级acl,3000
    [AC-1029-acl-adv-3000]step 3 //设置步长为3
    [AC-1029-acl-adv-3000]rule deny ip source 192.168.20.0 0.0.0.255 destination 192
    .168.10.0 0.0.0.255	//拒绝源是192.168.20.0的网段访问192.168.10.0的网段,掩码规则可以参考之前文章
    [AC-1029-acl-adv-3000]quit 
    [AC-1029]interface Vlanif 20 //进入vlanif20虚拟接口
    [AC-1029-Vlanif20]traffic-filter inbound acl 3000 //在入方向调用策略acl3000
    

    我们前后测试,发现实现了实验目的。

     

    第二种:调用traffic-policy 

    
    [AC-1029]traffic classifier test	//创建流分类,名为“test”
    [AC-1029-classifier-test]if-match acl 3001 //匹配规则acl3000
    [AC-1029-classifier-test]quit 	
    [AC-1029]traffic behavior test	 //创建流行为,名为“test”
    [AC-1029-behavior-test]deny //动作是拒绝	
    [AC-1029-behavior-test]quit 
    [AC-1029]traffic policy test //创建流策略,名为“test”
    [AC-1029-trafficpolicy-test]classifier test behavior test 	//引用流分类和流行为
    [AC-1029-trafficpolicy-test]quit 
    [AC-1029]interface Vlanif 20
    [AC-1029-Vlanif20]traffic-policy test inbound //在入方向调用策略“test”
    

    然后测试

    然后我们看到两种方式实现了我们的实验目的

    展开全文
  • 什么是高精准IP地址定位——IP问问

    千次阅读 2017-06-02 10:15:09
    说起位置服务,大多数朋友想到的是GPS定位技术。但除了GPS之外,还有基站和WIFI...不需要用户参与的定位技术以IP地址为基础,对IP地址使用人群进行定位,定位结果覆盖IP地址使用人群的位置。已经发展了15年之久的IP...

    说起位置服务,大多数朋友想到的是GPS定位技术。但除了GPS之外,还有基站和WIFI定位等技术,以及我们今天要讨论的重点——高精准IP地址定位技术。我们把定位技术系统的分为不需要用户参与的定位及与需要用户参与的定位两种情况进行介绍。

    一、不需要用户参与的定位技术

    不需要用户参与的定位技术以IP地址为基础,对IP地址使用人群进行定位,定位结果覆盖IP地址使用人群的位置。已经发展了15年之久的IP地址定位市场,产品的定位精度多年维持在城市级别和区县级别。埃文科技的高精准IP地址定位产品——“IP问问”能够将基于IP地址的定位精度提升至街道级别,提供高精准的IP地址定位服务。

    1. 高精准IP地址定位的原理

    IP问问是基于埃文科技创始人王永发表的论文及专利。“IP问问”的定位原理是基于Whois和BGP数据、基准点数据挖掘、网络主被动测量和路径分析等多种方式组合而成的定位方法,定位精度最高可达街道级别。

    1.1 Whois数据

    全球IP分配机构的注册信息;什么Whois

    1.2 BGP数据

    搜集整理全球AS自制域广播的IP段信息,及AS所属机构信息;什么BGP/什么AS

    1.3 基础数据挖掘

    基于合作厂商提供的IP与GPS映射数据、公司采集的IP与GPS映射数据和基于Web的IP与街级位置映射数据;

    1.4 网络测量和路径分析

    通过VP(探测机,英文全称Vantage Point,缩写:VP)探测机对目标IP进行探测,并且在路径分析的基础上,把目标IP定位到一个离它相近的基准点的位置,给出定位结果;专利简述

     

    1.5 其他IP地址定位专业术语

    详见《IP地址定位专用术语》(请看下篇blog)

    2. IP应用场景

    全球IPV4全库约有43亿IP地址数据,由于不同的IP地址有不同的属性,埃文科技将使用中的IP地址分成了9种不同的应用场景。分别是住宅用户、企业专线、学校机构、移动网络(3G/4G)、WLan热点、基础设施、数据中心、交换中心、卫星通信。这9种应用场景可分为非人类使用的场景和有真人使用的场景。

    2.1 非人类使用的场景

    如交换中心、数据中心和基础设施。这三类场景下的IP地址会定位到其所在机房,能定位到街道级别,但此类IP地址一般不用于普通用户访问互联网;

    2.2真人使用的场景

    如企业专线和学校机构,IP地址使用人群出现的位置相对固定,能定位到街道级别;

    住宅用户、WLan热点、移动网络(3G/4G)和卫星通讯,IP地址使用人群出现的位置覆盖相对较广,能定位到一定的区域。

    住宅用户这类场景下的IP地址可以覆盖一个行政区的部分区域,能定位到街道级别或者区县级别;WLan热点可定位到区县级别或者城市级别;移动网络(3G/4G)可定位到省级别;卫星通讯可定位到国家级别。

    二、需要用户参与的定位

    1.GPS定位

    1.1 基于用户设备上的GPS模块进行定位,需要满足的条件:

    1.2 用户使用的设备上带有GPS模块;

    1.3 用户在访问网络服务时主动上传其GPS位置信息给服务提供商;

    2.WIFI和基站定位

    2.1 基于用户设备连接的WIFI路由器硬件地址或基站编号进行定位,需要满足的条件有:

    2.2 用户使用的设备上带有WIFI模块;

    2.3 用户在访问网络服务时主动上传其连接的WIFI路由器硬件地址或基站编号信息给服务提供商;

    2.4 服务提供商已提前搜集用户连接的WIFI路由器的位置信息或基站的位置信息;

    总结:需要用户参与的定位,能定位到唯一的设备和用户,但是需要用户主动上传位置信息或相关信息。不需要用户参与的定位方式——高精准IP地址定位,不需要硬件支持,普适性更强。在GPS/WIFI/基站等定位方式无法提供定位服务的情况下,可以使用“IP问问”提供高精准的定位服务。

    客户可选择定位到区县、街道级别的“IP问问”数据使用(如住宅用户、企业专线、学校机构等)。城市级别以上的数据可作为常规分析使用。至于特殊类型的IP地址,如危害网络安全等类型的IP地址,请交给埃文进行专业的探测分析,为大家进行安全服务支持。

    至于将移动网络(3G/4G)场景下的IP地址定位至街道级别的方法,IP地址定位行业内专家研究后给出的结论是无法定位至街道级别。埃文科技针对这一问题在持续研究,希望能找出一个合理的解决方案为大家提供服务。但有技术突破之前,建议大家依靠传统GPS的定位方式解决定位互联网用户的问题。试用IP问问。

    展开全文
  • 我们知道在互联网上,如果想要被其他终端访问,就需要给每台主机(或路由器)的每一个接口分配一个在全世界范围内是唯一的标识符,这就是我们所说...一、什么是ip地址? 简介( IPv4): IPv4地址由四段组成,每个...
  • ubuntu下wlan固定ip

    千次阅读 2013-12-04 13:25:10
    转自:http://www.cnblogs.com/keygle/archive/2013/04/27/3048273.html 1 扫描wifi iwlist wlan3 scan ubuntu@ubuntu:~$ iwlist wlan3 scan wlan3 Scan completed : Cell 01 - Address: C8:D3:A3:50:8B
  • 解决方法: 1,清除浏览器的浏览历史记录及cookies...2,若可以ping通网址,而无法ping通ip地址,可以尝试刷新dns Ipconfig /flushdns 3,若还不行,尝试修复浏览器及tcp/ip协议。使用360的lsp修复网络。 另外需检
  • QT5修改windows电脑IP地址

    千次阅读 2018-12-13 00:59:22
    1、QT修改IP地址程序原理 通过系统调用windows的dos命令来修改IP地址。 例如:netsh interface ip set ...该条命令的意思是将名为WLAN的网卡的IP地址修改为静态IP,192.168.10.88,子网掩码为255.255.255.0,网...
  • 1.设置静态IP sudo nano /etc/dhcpcd.conf interface wlan0 static ip_address=192.168.124.3/24 static routers=192.168.124.1 static domain_name_servers=114.114.114.114 wlan0是无线配置 ip_address...
  • WLAN没有有效的IP配置如何一招解决

    万次阅读 2021-01-02 13:20:37
    WLAN没有有效的IP配置如何一招解决前言一、电脑连不上网?二、具体步骤1.命令提示符(管理员)输入netsh winsock reset2.重启电脑总结 前言 自己的笔记本原本好好的突然就连不上网了,该怎么办?别急,博主也遇到过...
  • 树莓派静态配置IP地址

    千次阅读 2019-03-02 14:52:37
    而且DHCP给树莓派分配的是动态IP地址。最后用树莓派制作路由器修改hostapd程序的配置文件的时候,SecureCRT远程登录断开,再去找IP链接的时候发现已经找不到了,无奈只好重新开始做。所以今天我要给树莓派配置静态IP...
  • Android IP地址查看

    千次阅读 2017-06-16 17:07:55
    1、查看手机内网IP adb shell ip -f inet addr show wlan0 2、解析inet后的IP地址
  • 通过sed命令获取IP地址

    千次阅读 2015-10-25 12:28:41
    通过sed命令获取IP地址,linux获取IP地址
  • 理解IP地址什么 对于IP地址,大家并不陌生,特别是在网络访问中我们会经常使用到(平时对域名如百度,淘宝的www.baidu.com,www.taobao.com的访问,本质就是对域名所绑定的IP地址的访问),那么IP地址什么呢? ...
  • C# 修改本地以太网ip地址

    千次阅读 2019-10-14 12:56:23
    因为某项需求,要修改以太网的ip地址,研究了一段时间,因不太懂网络的知识,只实现了最基本的修改以太网ip的功能。如果有错误,欢迎指出 等价于在这里修改: 实现代码: //设置ip地址 private void ...
  • 1.修改Ubuntu16.04的网卡名称(默认的Ubuntu网卡名称不是eth0 wlan0) 执行:sudo gedit /etc/default/grub 找到GRUB_CMDLINE_LINUX="" 改为GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"...
  • 由于远程连接树莓派需要其ip地址,但由于ip地址的获取是通过dhcp自动分配,每次基本上的也都不一样,为了方便以后的连接,我们可以通过修改其配置文件,将其地址固定。
  • 树莓派的IP地址查找

    千次阅读 2020-10-21 17:08:56
    陈拓 chentuo@ms.xab.ac.... 1. 概述 ... 和《树莓派修改HostName》 ...两篇文章中我们介绍了电脑用SSH通过主机名Host Name连接树莓派的方法。...用IP地址连接树莓派更快一些,但局域网一般都使用动态.
  • 通过QQ电话获取好友IP地址并实现地址定位

    千次阅读 多人点赞 2020-04-10 22:04:16
    1、先查看本机IP地址 2、安装工具Wireshark 3、QQ拨打好友电话 3、观察Wireshark获取ip地址 4、OpenGPS查询地址 查看本机ip地址,为了方便等下在Wireshark中观察数据。打开CMD,输入命令ipconfig查看自己的IP地址 ...
  • 以太网2出现两个ip地址-解决办法

    万次阅读 2018-04-21 15:15:06
    有线连接上后,出现两个ip地址,一个手动获取一个自动获取,在cmd命令行中输入ipconfig,显示自动获取的ip地址,导致不能连接内网 目标: cmd输入ipconfig,只显示 手动输入的ip地址 解决办法: 在服务...
  • 查看树莓派ip地址的几种方法

    万次阅读 多人点赞 2018-03-20 22:14:59
    远程登录的前提就是需要获得树莓派的ip地址。下面我介绍几种方法可以找到树莓派的ip地址。 将树莓派连接显示器 连接显示器,在Terminal里面输入 $hostname -i 就可以看到树莓派的ip地址。 没有显示器 通过...
  • Internet的接入与IP地址 概述

    千次阅读 2020-03-20 15:33:23
    无线接入二.IP地址1.IP地址的格式2.IP地址分类3.子网掩码4.域名系统三.Windows网络查看与配置1.win10查看所有的网络连接状况2.win10查看网卡、修改IP3.win10命令行查询TCP/IP配置信息 一.计算机接入Internet ...
  • 1、Win+R打开运行界面----->cmd 2、输入ipconfig,查找到无线局域网适配器WLAN的IPV4地址
  • 在校园网络中,最方便的捣乱方法就是盗用别人的IP地址,被盗用IP地址的计算机不仅不能正常使用校园网络,而且还会频繁出现IP地址被占用的提示对话框,给校园网络安全和用户应用带来极大的隐患。捆绑IP地址和MAC地址...
  • 手机在联网时,就会被分配一个IP地址,它在开启热点时,它本身作为一个“路由器”也会生成一个IP地址,我们需要的就是后面这个IP地址,目前论坛上关于手机IP地址的帖子都是获取手机被分配的IP地址。我在解决这个问题...
  • 笔者在安装ubuntu后,出现一个小问题 ...针对此问题,笔者认为路由器没有问题,问题出在了电脑无法自动获取ip 1、按下电脑的Win+X键    3.输入密令:netsh winsock reset,重新启动电脑即可  ...
  • 无法自动获取IP地址

    千次阅读 2015-09-11 16:18:35
    现象:某天突然无法自动获取IP地址,手工指定IP地址可以上网。 愿景:恢复到自动获取IP地址。 处理过程:重新制作网线水晶头,无效; 重新制作网线为交叉线,无效,排除是网线原因。 用8PE启动计算机,尝试获取地址...
  • IP地址我都填对的。(如果是两个网络调试助手在两台电脑上是能成功连接的,但是我找不到网络调试助手的源代码) 有谁知道是什么情况导致了这种情况吗?两台电脑应该是在一个局域网里的,但也可能不是,我不知道怎么...
  • **wlan没有有效的ip配置** 1.以管理员身份运行命令控制符:在开始菜单上搜索cmd,然后右键cmd,以管理员身份进入。 2.然后输入netsh winsock reset,回车运行,会提示需要重启计算机,重启即可解决。![在这里 L ...
  • 获取设备Mac地址和IP地址

    千次阅读 2018-08-07 14:29:13
    app开发,难免会遇到需要获取设备信息,作为标示,使用比较多的,那肯定是mac或者设备的ip地址来标识当前使用的用户。这些信息也经常会出现在网络请求的请求头里面。 1.获取设备的mac地址 /** * 获取设备mac...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 18,607
精华内容 7,442
关键字:

wlan的ip地址是什么