精华内容
下载资源
问答
  • 思科设备配置自动备份脚本功能:本脚本示范:从一个文件里面自动读取设备IP地址,密码等,自动将设备配置备份,打开保存设备管理地址以及密码的文件,读出每行参数、如IP地址和密码,Telnet到这个设备上,输入telnet...
  • 思科交换机配置笔记

    2020-04-03 16:05:33
    取消设置 取消设置只需要在前面加个no,如下: sw2960(config-if-range)#no ...在配置模式中查看接口状态需要加 do 前缀 sw2960(config)#do show ip interface brief Interface IP-Address OK? Method Status ...

    取消设置

    取消设置只需要在前面加个no,如下:
    sw2960(config-if-range)#no switchport access vlan 10
    

    在配置模式中查看接口状态需要加 do 前缀

    sw2960(config)#do show ip interface brief
    Interface              IP-Address      OK? Method Status                Protocol
    Vlan1                  unassigned      YES NVRAM  up                    down    
    FastEthernet0/1        unassigned      YES unset  up                    up      
    FastEthernet0/2        unassigned      YES unset  down                  down    
    FastEthernet0/3        unassigned      YES unset  down                  down    
    FastEthernet0/4        unassigned      YES unset  down                  down    
    FastEthernet0/5        unassigned      YES unset  up                    up      
    FastEthernet0/6        unassigned      YES unset  down                  down           
     --More-- 
    

    使用 end 命令退出到普通模式

    sw2960(config)#end
    sw2960#
    

    设置名字

    Switch>enable  //进入特权模式
    Switch#
    Switch#configure terminal  //从特权模式进入全局配置模式
    Switch(config)#
    Switch(config)#hostname sw1 //修改交换机名称
    

    进入交换机某一端口

    switch> enable
    switch#configure terminal
    switch(conf)# interface fastehernet 0/1
    switch(conf-if)#
    

    设置密码

    sw1(config)#enable password cisco //配置交换机明文密码,登录特权模式时需要输入该密码
    sw1(config)#enable secret ciscoswitch  //配置交换机密文密码,登录特权模式时需要输入该密码
    

    创建VLAN并命名

    sw1(config)#vlan 2
    sw1(config-vlan)#name test
    sw1(config-vlan)#exit
    

    单个端口导入VLAN并设置端口类型

    sw1(config)#interface  fastEthernet 0/1
    sw1(config-if)#switchport mode access
    sw1(config-if)#switchport access vlan 2
    

    多个端口导入VLAN并设置端口类型

    sw2960(config)#interface range f0/2-10 
    sw2960(config-if-range)#switchport mode access
    sw2960(config-if-range)#switchport access vlan 10
    

    show命令,交换机的所有配置和其它相关信息

    switch> enable
    switch#show version //查看系统中的所有版本信息
    switch#show  vlan id 1 //查看交换机有关vlan配置信息
    switch#show running-configure //查看交换机当前起作用的配置信息
    switch#show interface fastethernet 0/1 //查看交换机1 接口具体配置和统计信息
    switch#show mac-address-table //查看mac地址转发表
    

    交换机恢复出厂设置

    switch>enable
    switch#erase startup-configure
    switch# reload
    

    telnet远程登录设置

    switch>en
    switch#configure terminal
    swich(conf)#enable password cisco //以cisco为特权模式密码
    swich(conf)#interface vlan 1 //以vlan 1端口作为远程登录的接口,其他端口亦可
    swich(conf-if)#ip address 192.168.1.1 255.255.255.0
    swich(conf-if)#no shut
    swich(conf-if)#exit
    swich(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆
    swich(conf-line)#password 123456
    swich(conf-line)#login
    
    

    SSH配置

    Switch(config)#hostname cisco-sw1   //交换机重新命名
    cisco-sw1(config)#ip domain-name cisco.com //配置域名
    cisco-sw1(config)#line vty 0 4
    cisco-sw1(config-line)#transport input ssh //登录方式为SSH
    cisco-sw1(config-line)#exit
    cisco-sw1(config)#crypto key generate rsa //配置秘钥
    

    DHCP设置

    swich(conf)#interface vlan 10
    swich(conf-if)#ip address 192.168.10.254 255.255.255.0
    
    #############开启dhcp server 功能
    R1(config)#service dhcp
    R1(config)#ip dhcp pool R123
     
    R1(dhcp-config)#network 192.168.10.0 255.255.255.0
     
    #############将客户端的网关指向 dhcp server 接口的IP
    R1(dhcp-config)#default-router 192.168.10.254
     
    #############将客户端的DNS指向 dhcp server 接口的IP
    R1(dhcp-config)#dns-server 123.1.1.1
     
    #############设置租期为101R1(dhcp-config)#lease 1 0 1
     
    #############配置域名为cisco.com
    R1(dhcp-config)#domain-name cisco.com
    

    静态路由和默认路由

    1,静态路由
    ip route 192.168.10.0 255.255.255.0 192.168.20.1
    
    2,默认路由
    二层交换机,如思科2960系列不支持静态路由,只能配置默认路由:
    sw2960(config)#ip default-gateway 192.168.88.1
    

    端口镜像

    设置源镜像口,设置15口为源镜像,其中gigabitEthernet1/0/1表示千兆端口1,如果是百兆的话就换成fastEthernet,这条命令的-10之间有空格的。both,默认监听双向数据,10后面加上rx只监听接收数据,10后面加tx只监听发送数据:
    
    Switch(config)#monitor session 1 source interface fastEthernet 0/1- 10
    
    配置目的镜像口,使端口48为目的镜像口:
    
    Switch(config)#monitor session 1 destination interface fastEthernet 0/48
    
    查看配置:
    
    Switch(config)#do show monitor
    Session 1
    ---------
    Type                   : Local Session
    Source Ports           : 
        Both               : Fa0/1-10
    Destination Ports      : Fa0/48
        Encapsulation      : Native
              Ingress      : Disabled
    
    如果配置错误,删除方法:
    
    Switch(config)#no monitor session 1
    Switch(config)#do show monitor     
     No SPAN configuration is present in the system. 
    

    常用巡检命令

    show logging 查看日志
    show processes cpu | e 0.00% 查看cpu使用率(排除含0.00%的行)
    show processes memory | i Use 查看内存使用率(只包含Use的行)
    show ip route 查看路由
    show vlan brief 查看vlan信息
    show ip interface brief 查看各个端口
    

    acl

    ACL 类型
    标准ACL: access-list-number编号1~99之间的整数,只针对源地址进行过滤。
    扩展ACL: access-list-number编号100~199之间的整数,可以同时使用源地址和目标地址作为过滤条件,还可以针对不同的协议、协议的特征、端口号、时间范围等过滤。可以更加细微的控制通信量。
    动态ACL
    自反ACL
    基于时间的ACL
    
    对某个网段进行过滤。命令如下:access-list 10 deny 192.168.1.0 0.0.0.255
    
    例子:禁止端口f0/5访问IP211.84.160.6的网站
    Switch(config)#access-list 110 deny tcp any host 211.84.160.6 eq www
    Switch(config)#access-list 110 permit ip any any
    Switch(config)#interface fastEthernet 0/5
    Switch(config-if)#ip access-group 110 in 
    

    备份

    Switch#copy running-config tftp:					//选择tftp方式
    Address or name of remote host []? 192.168.10.2   //tftp服务器IP地址
    Destination filename [switch-confg]? test		//备份名字
    !!
    2617 bytes copied in 1.258 secs (2080 bytes/sec)
    

    升级

    先把本机电脑和交换机配到一个网段,ping通继续下面操作(备份好就bin)
    
    1,删除就bin腾出空间:
    Switch#delete flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin 
    Delete filename [/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin]? 
    Delete flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin? [confirm]
    Switch#dir flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin
    %Error opening flash:/c2960-lanbase-mz.122-50.SE/c2960-lanbase-mz.122-50.SE.bin (No such file or directory)
    Switch#dir flash:/c2960-lanbase-mz.122-50.SE/                              
    Directory of flash:/c2960-lanbase-mz.122-50.SE/
    
        4  drwx        4800   Mar 1 1993 00:03:37 +00:00  html
      554  -rwx         518   Mar 1 1993 00:05:37 +00:00  info
    
    32514048 bytes total (29056000 bytes free)
    
    
    2,复制tftp下载好的bin升级包到flash
    Switch#copy tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin fla       
    Switch#$lanbasek9-mz.150-2.SE5.bin flash:/c2960-lanbase-mz.122-50.SE/        
    Destination filename [/c2960-lanbase-mz.122-50.SE/c2960-lanbasek9-mz.150-2.SE5.bin]? 
    Accessing tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin...
    Loading c2960-lanbasek9-mz.150-2.SE5.bin from 192.168.80.2 (via Vlan80): !... [timed out]
    
    %Error reading tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin (Timed out)
    Switch#$lanbasek9-mz.150-2.SE5.bin flash:/c2960-lanbase-mz.122-50.SE/
    Destination filename [/c2960-lanbase-mz.122-50.SE/c2960-lanbasek9-mz.150-2.SE5.bin]? 
    Accessing tftp://192.168.80.2/c2960-lanbasek9-mz.150-2.SE5.bin...
    Loading c2960-lanbasek9-mz.150-2.SE5.bin from 192.168.80.2 (via Vlan80): !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    [OK - 11787969 bytes]
    
    11787969 bytes copied in 191.981 secs (61402 bytes/sec)
    
    3,检查是否成功
    Switch#dir flash:c2960-lanbase-mz.122-50.SE 
    Directory of flash:/c2960-lanbase-mz.122-50.SE/
    
        4  drwx        4800   Mar 1 1993 00:03:37 +00:00  html
      553  -rwx    11787969   Mar 1 1993 00:21:30 +00:00  c2960-lanbasek9-mz.150-2.SE5.bin
      554  -rwx         518   Mar 1 1993 00:05:37 +00:00  info
    
    32514048 bytes total (17267200 bytes free)
    
    4,reload重启
    
    展开全文
  • 思科交换机配置命令大全 switch> 用户模式 1:进入特权模式enable switch> enable switch# 2:进入全局配置模式configure terminal switch> enable switch#c onfigure terminal switch(conf)# 3...

    思科交换机配置命令大全
    switch> 用户模式
    1:进入特权模式enable
    switch> enable
    switch#
    2:进入全局配置模式configure terminal
    switch> enable
    switch#c onfigure terminal
    switch(conf)#
    3:交换机命名hostname aptech2950 以aptech2950 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch-2950
    aptech2950(conf)#
    4:配置使能口令enable password cisco 以cisco 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# enable password cisco
    5:配置使能密码enable secret ciscolab 以cicsolab 为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# enable secret ciscolab
    6:设置虚拟局域网vlan 1 interface vlan 1
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# interface vlan 1
    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0 配置交换机端口ip 和子网掩

    aptech2950(conf-if)#no shut 是配置处于运行中
    aptech2950(conf-if)#exit
    aptech2950(conf)#ip default-gateway 192.168.254 设置网关地址
    7:进入交换机某一端口interface fastehernet 0/17 以17 端口为例
    switch> enable
    switch#c onfigure terminal
    switch(conf)#hostname aptch2950
    aptech2950(conf)# interface fastehernet 0/17
    aptech2950(conf-if)#
    8:查看命令show
    switch> enable
    switch# show version 察看系统中的所有版本信息
    show interface vlan 1 查看交换机有关ip 协议的配置信息
    show running-configure 查看交换机当前起作用的配置信息
    show interface fastethernet 0/1 察看交换机1 接口具体配置和统计信息
    show mac-address-table 查看mac 地址表
    show mac-address-table aging-time 查看mac 地址表自动老化时间
    9:交换机恢复出厂默认恢复命令
    switch> enable
    switch# erase startup-configure
    switch# reload
    10:双工模式设置
    switch> enable
    switch#c onfigure terminal
    switch2950(conf)#hostname aptch-2950
    aptech2950(conf)# interface fastehernet 0/17 以17 端口为例
    aptech2950(conf-if)#duplex full/half/auto 有full , half, auto 三个可选

    11:cdp 相关命令
    switch> enable
    switch# show cdp 查看设备的cdp 全局配置信息
    show cdp interface fastethernet 0/17 查看17 端口的cdp 配置信息
    show cdp traffic 查看有关cdp 包的统计信息
    show cdp nerghbors 列出与设备相连的cisco 设备
    12:csico2950 的密码恢复
    拔下交换机电源线。
    用手按着交换机的MODE 键,插上电源线
    在switch:后执行flash_ini 命令:switch: flash_ini
    查看flash 中的文件: switch: dir flash:
    把“config.text”文件改名为“config.old”: switch: rename flash: config.text flash: config.old
    执行boot: switch: boot
    交换机进入是否进入配置的对话,执行no :
    进入特权模式察看flash 里的文件: show flash :
    把“config.old”文件改名为“config.text”: switch: rename flash: config.old flash: config.text
    把“ config.text ” 拷入系统的“ running-configure ”: copy flash: config.text system :
    running-configure
    把配置模式重新设置密码存盘,密码恢复成功。
    13:交换机telnet 远程登录设置:
    switch>en
    switch#c onfigure terminal
    switch(conf)#hostname aptech-2950
    aptech2950(conf)#enable password cisco 以cisco 为特权模式密码
    aptech2950(conf)#interface fastethernet 0/1 以17 端口为telnet 远程登录端口
    aptech2950(conf-if)#ip address 192.168.1.1 255.255.255.0
    aptech2950(conf-if)#no shut
    aptech2950(conf-if)#exit
    aptech2950(conf)line vty 0 4 设置0-4 个用户可以telnet 远程登陆
    aptech2950(conf-line)#login
    aptech2950(conf-line)#password edge 以edge 为远程登录的用户密码
    主机设置:
    ip 192.168.1.2 主机的ip 必须和交换机端口的地址在同一网络

    netmask 255.255.255.0
    gate-way 192.168.1.1 网关地址是交换机端口地址
    运行:
    telnet 192.168.1.1
    进入telnet 远程登录界面
    password : edge
    aptech2950>en
    password: cisco
    aptech#
    14:交换机配置的重新载入和保存
    设置完成交换机的配置后:
    aptech2950(conf)#reload
    是否保存(y/n) y: 保存设置信息n:不保存设置信息
    1.在基于IOS 的交换机上设置主机名/系统名:
    switch(config)# hostname hostname
    在基于CLI 的交换机上设置主机名/系统名:
    switch(enable) set system name name-string
    2.在基于IOS 的交换机上设置登录口令:
    switch(config)# enable password level 1 password
    在基于CLI 的交换机上设置登录口令:
    switch(enable) set password
    switch(enable) set enalbepass
    3.在基于IOS 的交换机上设置远程访问:
    switch(config)# interface vlan 1
    switch(config-if)# ip address ip-address netmask
    switch(config-if)# ip default-gateway ip-address
    在基于CLI 的交换机上设置远程访问:
    switch(enable) set interface sc0 ip-address netmask broadcast-address
    switch(enable) set interface sc0 vlan
    switch(enable) set ip route default gateway
    4.在基于IOS 的交换机上启用和浏览CDP 信息:
    switch(config-if)# cdp enable
    switch(config-if)# no cdp enable
    为了查看Cisco 邻接设备的CDP 通告信息:
    switch# show cdp interface [type modle/port]
    switch# show cdp neighbors [type module/port] [detail]
    在基于CLI 的交换机上启用和浏览CDP 信息:
    switch(enable) set cdp {enable|disable} module/port
    为了查看Cisco 邻接设备的CDP 通告信息:
    switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]
    5.基于IOS 的交换机的端口描述:
    switch(config-if)# description description-string
    基于CLI 的交换机的端口描述:
    switch(enable)set port name module/number description-string
    6.在基于IOS 的交换机上设置端口速度:
    switch(config-if)# speed{10|100|auto}
    在基于CLI 的交换机上设置端口速度:
    switch(enable) set port speed moudle/number {10|100|auto}
    switch(enable) set port speed moudle/number {4|16|auto}
    7.在基于IOS 的交换机上设置以太网的链路模式:
    switch(config-if)# duplex {auto|full|half}
    在基于CLI 的交换机上设置以太网的链路模式:
    switch(enable) set port duplex module/number {full|half}
    8.在基于IOS 的交换机上配置静态VLAN:
    switch# vlan database
    switch(vlan)# vlan vlan-num name vla
    switch(vlan)# exit
    switch# configure teriminal
    switch(config)# interface interface module/number
    switch(config-if)# switchport mode access
    switch(config-if)# switchport access vlan vlan-num
    switch(config-if)# end
    在基于CLI 的交换机上配置静态VLAN:
    switch(enable) set vlan vlan-num [name name]
    switch(enable) set vlan vlan-num mod-num/port-list
    9. 在基于IOS 的交换机上配置VLAN 中继线:
    switch(config)# interface interface mod/port
    switch(config-if)# switchport mode trunk
    switch(config-if)# switchport trunk encapsulation {isl|dotlq}
    switch(config-if)# switchport trunk allowed vlan remove vlan-list
    switch(config-if)# switchport trunk allowed vlan add vlan-list
    在基于CLI 的交换机上配置VLAN 中继线:
    switch(enable) set trunk module/port [on|off|desirable|auto|nonegotiate]
    Vlan-range [isl|dotlq|dotl0|lane|negotiate]
    10.在基于IOS 的交换机上配置VTP 管理域:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    在基于CLI 的交换机上配置VTP 管理域:
    switch(enable) set vtp [domain domain-name]
    11.在基于IOS 的交换机上配置VTP 模式:
    switch# vlan database
    switch(vlan)# vtp domain domain-name
    switch(vlan)# vtp {sever|cilent|transparent}
    switch(vlan)# vtp password password
    在基于CLI 的交换机上配置VTP 模式:
    switch(enable) set vtp [domain domain-name] [mode{ sever|cilent|transparent }][password
    password]
    12. 在基于IOS 的交换机上配置VTP 版本:
    switch# vlan database
    switch(vlan)# vtp v2-mode
    在基于CLI 的交换机上配置VTP 版本:
    switch(enable) set vtp v2 enable
    13. 在基于IOS 的交换机上启动VTP 剪裁:
    switch# vlan database
    switch(vlan)# vtp pruning
    在基于CL I 的交换机上启动VTP 剪裁:
    switch(enable) set vtp pruning enable
    14.在基于IOS 的交换机上配置以太信道:
    switch(config-if)# port group group-number [distribution {source|destination}]
    在基于CLI 的交换机上配置以太信道:
    switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}
    15.在基于IOS 的交换机上调整根路径成本:
    switch(config-if)# spanning-tree [vlan vlan-list] cost cost
    在基于CLI 的交换机上调整根路径成本:
    switch(enable) set spantree portcost moudle/port cost
    switch(enable) set spantree portvlancost moudle/port [cost cost][vlan-list]
    16.在基于IOS 的交换机上调整端口ID:
    switch(config-if)# spanning-tree[vlan vlan-list]port-priority port-priority
    在基于CLI 的交换机上调整端口ID:
    switch(enable) set spantree portpri {mldule/port}priority
    switch(enable) set spantree portvlanpri {module/port}priority [vlans]
    17. 在基于IOS 的交换机上修改STP 时钟:
    switch(config)# spanning-tree [vlan vlan-list] hello-time seconds
    switch(config)# spanning-tree [vlan vlan-list] forward-time seconds
    ` switch(config)# spanning-tree [vlan vlan-list] max-age seconds
    在基于CLI 的交换机上修改STP 时钟:
    switch(enable) set spantree hello interval[vlan]
    switch(enable) set spantree fwddelay delay [vlan]
    switch(enable) set spantree maxage agingtiame[vlan]
    18. 在基于IOS 的交换机端口上启用或禁用Port Fast 特征:
    switch(config-if)#spanning-tree portfast
    在基于CLI 的交换机端口上启用或禁用Port Fast 特征:
    switch(enable) set spantree portfast {module/port}{enable|disable}
    19. 在基于IOS 的交换机端口上启用或禁用UplinkFast 特征:
    switch(config)# spanning-tree uplinkfast [max-update-rate pkts-per-second]
    在基于CLI 的交换机端口上启用或禁用UplinkFast 特征:
    switch(enable) set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols off|on]
    20. 为了将交换机配置成一个集群的命令交换机,首先要给管理接口分配一个IP 地址,然后使
    用下列命令: switch(config)# cluster enable cluster-name
    21. 为了从一条中继链路上删除VLAN,可使用下列命令:
    switch(enable) clear trunk module/port vlan-range
    22. 用show vtp domain 显示管理域的VTP 参数.
    23. 用show vtp statistics 显示管理域的VTP 参数.
    24. 在Catalyst 交换机上定义TrBRF 的命令如下:
    switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]
    25. 在Catalyst 交换机上定义TrCRF 的命令如下:
    switch (enable) set vlan vlan-num [name name] type trcrf
    {ring hex-ring-num|decring decimal-ring-num} parent vlan-num
    26. 在创建好TrBRF VLAN 之后,就可以给它分配交换机端口.对于以太网交换,可以采用如
    下命令给VLAN 分配端口:
    switch(enable) set vlan vlan-num mod-num/port-num
    27. 命令show spantree 显示一个交换机端口的STP 状态.
    28. 配置一个ELAN 的LES 和BUS,可以使用下列命令:
    ATM (config)# interface atm number.subint multioint
    ATM(config-subif)# lane serber-bus ethernet elan-name
    29. 配置LECS:
    ATM(config)# lane database database-name
    ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address
    ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address
    ATM(lane-config-databade)# name …
    30. 创建完数据库后,必须在主接口上启动LECS.命令如下:
    ATM(config)# interface atm number
    ATM(config-if)# lane config database database-name
    ATM(config-if)# lane config auto-config-atm-address
    31. 将每个LEC 配置到一个不同的ATM 子接口上.命令如下:
    ATM(config)# interface atm number.subint multipoint
    ATM(config)# lane client ethernet vlan-num elan-num
    32. 用show lane server 显示LES 的状态.
    33. 用show lane bus 显示bus 的状态.
    34. 用show lane database 显示LECS 数据库可内容.
    35. 用show lane client 显示LEC 的状态.
    36. 用show module 显示已安装的模块列表.
    37. 用物理接口建立与VLAN 的连接:
    router# configure terminal
    router(config)# interface media module/port
    router(config-if)# description description-string
    router(config-if)# ip address ip-addr subnet-mask
    router(config-if)# no shutdown
    38. 用中继链路来建立与VLAN 的连接:
    router(config)# interface module/port.subinterface
    router(config-ig)# encapsulation[isl|dotlq] vlan-number
    router(config-if)# ip address ip-address subnet-mask
    39. 用LANE 来建立与VLAN 的连接:
    router(config)# interface atm module/port
    router(config-if)# no ip address
    router(config-if)# atm pvc 1 0 5 qsaal
    router(config-if)# atm pvc 2 0 16 ilni
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-mask
    router(config-if)# lane client ethernet elan-num
    router(config-if)# interface atm module/port.subinterface multipoint
    router(config-if)# ip address ip-address subnet-name
    router(config-if)# lane client ethernet elan-name
    router(config-if)# …
    40. 为了在路由处理器上进行动态路由配置,可以用下列IOS 命令来进行:
    router(config)# ip routing
    router(config)# router ip-routing-protocol
    router(config-router)# network ip-network-number
    router(config-router)# network ip-network-number
    41. 配置默认路由:
    switch(enable) set ip route default gateway
    42. 为一个路由处理器分配VLANID,可在接口模式下使用下列命令:
    router(config)# interface interface number
    router(config-if)# mls rp vlan-id vlan-id-num
    43. 在路由处理器启用MLSP:
    router(config)# mls rp ip
    44. 为了把一个外置的路由处理器接口和交换机安置在同一个VTP 域中:
    router(config)# interface interface number
    router(config-if)# mls rp vtp-domain domain-name
    45. 查看指定的VTP 域的信息:
    router# show mls rp vtp-domain vtp domain name
    46. 要确定RSM 或路由器上的管理接口,可以在接口模式下输入下列命令:
    router(config-if)#mls rp management-interface
    47. 要检验MLS-RP 的配置情况:
    router# show mls rp
    48. 检验特定接口上的MLS 配置:
    router# show mls rp interface interface number
    49. 为了在MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置访问列表:
    set mls flow [destination|destination-source|full]
    50. 为使MLS 和输入访问列表可以兼容,可以在全局模式下使用下列命令:
    router(config)# mls rp ip input-acl
    51. 当某个交换机的第3 层交换失效时,可在交换机的特权模式下输入下列命令:
    switch(enable) set mls enable
    52. 若想改变老化时间的值,可在特权模式下输入以下命令:
    switch(enable) set mls agingtime agingtime
    53. 设置快速老化:
    switch(enable) set mls agingtime fast fastagingtime pkt_threshold
    54. 确定那些MLS-RP 和MLS-SE 参与了MLS,可先显示交换机引用列表中的内容再确定:
    switch(enable) show mls include
    55. 显示MLS 高速缓存记录:
    switch(enable) show mls entry
    56. 用命令show in arp 显示ARP 高速缓存区的内容。
    57. 要把路由器配置为HSRP 备份组的成员,可以在接口配置模式下使用下面的命令:
    router(config-if)# standby group-number ip ip-address
    58. 为了使一个路由器重新恢复转发路由器的角色,在接口配置模式下:
    router(config-if)# standy group-number preempt
    59. 访问时间和保持时间参数是可配置的:
    router(config-if)# standy group-number timers hellotime holdtime
    60. 配置HSRP 跟踪:
    router(config-if)# standy group-number track type-number interface-priority
    61. 要显示HSRP 路由器的状态:
    router# show standby type-number group brief
    62. 用命令show ip igmp 确定当选的查询器。
    63. 启动IP 组播路由选择:
    router(config)# ip muticast-routing
    64. 启动接口上的PIM:
    dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}
    65. 启动稀疏-稠密模式下的PIM:
    router# ip multicast-routing
    router# interface type number
    router# ip pim sparse-dense-mode
    66. 核实PIM 的配置:
    dallasr1># show ip pim interface[type number] [count]
    67. 显示PIM 邻居:
    dallasr1># show ip neighbor type number
    68. 为了配置RP 的地址,命令如下:
    dallasr1># ip pim rp-address ip-address [group-access-list-number][override]
    69. 选择一个默认的RP:
    dallasr1># ip pim rp-address
    通告RP 和它所服务的组范围:
    dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number
    为管理范围组通告RP 的地址:
    dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1
    dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255
    设定一个RP 映像代理:
    dallasr1># ip pim send-rp-discovery scope ttl
    核实组到RP 的映像:
    dallasr1># show ip pim rp mapping
    dallasr1># show ip pim rp [group-name|group-address] [mapping]
    70. 在路由器接口上用命令ip multicast ttl-threshold ttl-value 设定TTL 阀值:
    dallasr1>(config-if)# ip multicast ttl-threshold ttl-value
    71. 用show ip pim neighbor 显示PIM 邻居表。
    72. 显示组播通信路由表中的各条记录:
    dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]
    73. 要记录一个路由器接受和发送的全部IP 组播包:
    dallasr1> #debug ip mpacket [detail] [access-list][group]
    74. 要在CISCO 路由器上配置CGMP:
    dallasr1>(config-if)# ip cgmp
    75.配置一个组播路由器,使之加入某一个特定的组播组:
    dallasr1>(config-if)# ip igmp join-group group-address
    76. 关闭CGMP:
    dallasr1>(config-if)# no ip cgmp
    77. 启动交换机上的CGMP:
    dallasr1>(enable) set cgmp enable
    78. 核实Catalyst 交换机上CGMP 的配置情况:
    catalystla1>(enable) show config
    set prompt catalystla1>
    set interface sc0 192.168.1.1 255.255.255.0
    set cgmp enable
    79. CGMP 离开的设置:
    Dallas_SW(enable) set cgmp leave
    80. 在Cisco 设备上修改控制端口密码:
    R1(config)# line console 0
    R1(config-line)# login
    R1(config-line)# password Lisbon
    R1(config)# enable password Lilbao
    R1(config)# login local
    R1(config)# username student password cisco
    81. 在Cisco 设备上设置控制台及vty 端口的会话超时:
    R1(config)# line console 0
    R1(config-line)# exec-timeout 5 10
    R1(config)# line vty 0 4
    R1(config-line)# exec-timeout 5 2
    82. 在Cisco 设备上设定特权级:
    R1(config)# privilege configure level 3 username
    R1(config)# privilege configure level 3 copy run start
    R1(config)# privilege configure level 3 ping
    R1(config)# privilege configure level 3 show run
    R1(config)# enable secret level 3 cisco
    83. 使用命令privilege 可定义在该特权级下使用的命令:
    router(config)# privilege mode level level command
    84. 设定用户特权级:
    router(config)# enable secret level 3 dallas
    router(config)# enable secret san-fran
    router(config)# username student password cisco
    85. 标志设置与显示:
    R1(config)# banner motd ‘unauthorized access will be prosecuted!’
    86. 设置vty 访问:
    R1(config)# access-list 1 permit 192.168.2.5
    R1(config)# line vty 0 4
    R1(config)# access-class 1 in
    87. 配置HTTP 访问:
    Router3(config)# access-list 1 permit 192.168.10.7
    Router3(config)# ip http sever
    Router3(config)# ip http access-class 1
    Router3(config)# ip http authentication local
    Router3(config)# username student password cisco
    88. 要启用HTTP 访问,请键入以下命令:
    switch(config)# ip http sever
    89. 在基于set 命令的交换机上用setCL1 启动和核实端口安全:
    switch(enable) set port security mod_num/port_num…enable mac address
    switch(enable) show port mod_num/port_num
    在基于CiscoIOS 命令的交换机上启动和核实端口安全:
    switch(config-if)# port secure [mac-mac-count maximum-MAC-count]
    switch# show mac-address-table security [type module/port]
    90. 用命令access-list 在标准通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny} source-address [source-address]
    91. 用命令access-list 在扩展通信量过滤表中创建一条记录:
    Router(config)# access-list access-list-number {permit|deny{protocol|protocol-keyword}}{source
    source-wildcard|any}{destination destination-wildcard|any}[protocol-specific options][log]
    92. 对于带内路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name in [type number]
    93. 对于带外路由更新,配置路由更新的最基本的命令格式是:
    R1(config-router)#distribute-list access-list-number|name out [interface-name] routing-process|
    autonomous-system-number
    94. set snmp 命令选项:
    set snmp community {read-only|ready-write|read-write-all}[community_string]
    95. set snmp trap 命令格式如下:
    set snmp trap {enable|disable}
    [all|moudle|classis|bridge|repeater| auth|vtp|ippermit|vmps|config|entity|stpx]
    set snmp trap rvcr_addr rcvr_community
    96. 启用SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable chassis
    97. 启用所有SNMP chassis 陷阱:
    Console>(enable) set snmp trap enable
    …………以下由about 于2002 年12 月6 日增加…………
    98. 禁用SNMP chassis 陷阱:
    Console>(enable) set snmp trap disable chassis
    99. 给SNMP 陷阱接收表加一条记录:
    Console>(enable) set snmp trap 192.122.173.42 public
    100. show snmp 输出结果。
    101. 命令set snmp rmon enable 的输出结果。
    102. 显示SPAN 信息:
    Consile> show spanCISCO 交换机配置命令大全

    转载于:https://blog.51cto.com/hanzheng/883475

    展开全文
  • 思科交换机配置快速导出导入

    万次阅读 2018-10-10 00:26:23
    通过tftp服务器进行交换机配置的导出 一、安装tftp服务器 这里有Cisco的tftp服务器软件,在E:\04 网络工具\03 FTP\Cisco TFTP Server,直接解压后即可运行。 TFTPServerCisco.exe 运行后如图: 二、运行界面解析 ...

    通过tftp服务器进行交换机配置的导出
    一、安装tftp服务器
    这里有Cisco的tftp服务器软件,在E:\04 网络工具\03 FTP\Cisco TFTP Server,直接解压后即可运行。
    TFTPServerCisco.exe
    运行后如图:
    这里写图片描述
    二、运行界面解析
    运行的是思科TFTP服务器;
    主机地址是:192.168.250.35;
    运行默认位置:E:\04 网络工具\03 FTP\Cisco TFTP Server。
    这里写图片描述,出现下图:
    其中:TFTP服务器根目录表示文件传输的根。
    四、配置Widnows 7防火墙
    配置Widnows 7防火墙允许程序或功能通过Windows防火墙通信:
    控制面板→系统和安全→Windows防火墙→允许程序通过Windows防火墙→
    允许运行另一程序→浏览→选择TFTPServerCisco.exe→打开→添加→确定
    按上述步骤设置即可。
    配置后,运行在192.168.250.35服务器上的TFTP服务器即处于正常运行状态。
    五、测试TFTP服务器
    进入cmd模式
    如图:
    这里写图片描述
    1、建立一个临时文件:abc.txt
    键入下面命令可以建立abc.txt文件:
    cd c:\
    echo abcdefg>abc.txt
    2、传送abc.txt到TFTP服务器的根目录中
    tftp -i 192.168.250.35 put abc.txt
    3、在TFTP根目录中建立文件123.txt
    下面的命令是在E:\04 网络工具\03 FTP\Cisco TFTP Server下运行的。
    cd E:\04 网络工具\03 FTP\Cisco TFTP Server
    echo 123456789>123.txt
    4、接收TFTP服务器的根目录中的123.txt文件到C:\中
    tftp -i 192.168.250.35 get abc.txt

    部分运行情况如下图所示:
    这里写图片描述
    5、TFTP服务器上的显示内容:
    这里写图片描述
    至此测试完成,结果为通过。

    六、导出交换机配置文件
    使用Telnet进入交换机,
    Telnet 192.168.100.20
    输入远程密码和超级密码后,进入交换机命令域。然后输入命令并依次回答主机IP地址和目的文件名。如果出现传输错误,请退出并重新启动TFTP服务器后再试一试。
    B1-H0S2928G#copy flash:config.text tftp:
    Address of remote host []?192.168.250.35
    Destination filename [config.text]?
    Accessing flash:config.text…

    Transmission finished, file length 5994 bytes.
    B1-H0S2928G#

    参见下图:
    这里写图片描述

    --------------------- 作者:彖爻之辞 来源:CSDN 原文:https://blog.csdn.net/paul50060049/article/details/78751990?utm_source=copy 版权声明:本文为博主原创文章,转载请附上博文链接!

    展开全文
  • 主要内容为思科交换机、路由器的IP互连、配置备份还原、交换机IOS备份还原升级。 工作中发现很多搞Linux系统运维的人由于缺乏基础的网络知识而遇到瓶颈,而且还是一个比较常见的现象(拜国内不实用的教育系统所赐...

    本视频是Linux系统工程师集训之网络部分视频课程的第九集。

    主要内容为思科交换机、路由器的IP互连、配置备份还原、交换机IOS备份还原升级。

     

    工作中发现很多搞Linux系统运维的人由于缺乏基础的网络知识而遇到瓶颈,而且还是一个比较常见的现象(拜国内不实用的教育系统所赐)。出于公益 和个人 知识分享的角度,打算做一系列网络知识的分享,使用了CCNA的课件(实在是找不出不用CCNA的课件的原因,非常经典无法拒绝,但是稍作修改,本节课件 可从附件中下载),每周不定期推出2~3个视频,并在51cto进行同步(由于视频制作的原因会有1~2天延迟,如想抢先观看请关注我的微博或者易柏微博

    转载于:https://blog.51cto.com/johnwang/1160083

    展开全文
  • FTP导出思科S3560配置 一、连接物理设备 二、打开CRT,使用串口相连 三、搭建电脑为FTP服务器 四、导出配置到FTP服务器 实验环境: 交换机Cisco S3560 电脑:ThinkPad,WIN10系统 软件:CRT、Xshell等均可,...
  • TFTP协议简介 TFTP是用来下载远程文件的最简单网络协议,它其于UDP...因为u-boot本身内置支持tftp-client,所以嵌入式目标系统端就不用配置了。下面就详细介绍一下linux服务器端tftp-server的配置。本文来自成都明...
  • 交换机配置备份是交换机日常维护工作的一项重要内容,当交换机停止正常运行时,能够利用这些备份文件迅速恢复交换机配置。如果没有做好交换机配置备份,一旦交换机出了故障导致配置文件丢失的情况出现,恢复工作...
  • 思科交换机配置命令大全!

    千次阅读 2012-11-22 15:26:46
    1. 交换机支持的命令: 交换机基本状态: switch: ;ROM状态, 路由器是rommon> ...全局配置模式 hostname(config-if)# ;接口状态 交换机口令设置: switch>enable ;进入特权模式
  • 思科交换机配置命令大全,真的很全 CISCO, 大全, 交换机, 命令1.在基于IOS的交换机上设置主机名/系统名: switch(config)# hostname hostname 在基于CLI的交换机上设置主机名/系统名: switch(enable) set system name...
  • 思科交换机密码配置

    2012-02-29 16:10:58
    思科交换机密码配置 一.设置console密码 >enable #configure trminal (confing)#line console 0←console口 ①(config-line)#password (cisco)←密码 (config-line)#login ← 一定不能少的. console密码...
  • 思科交换机的基本配置命令

    千次阅读 2018-07-03 13:32:38
    思科交换机的基本配置命令思科交换机的基本配置命令学习CISCO交换机基本配置:Console端口连接用户模式hostname# ;特权模式hostname(config)# ;全局配置模式hostname(config-if)# ;交换机口令设置:switch&gt...
  • 思科交换机

    2018-12-06 23:40:00
    思科交换机配置命令大全 switch> 用户模式 1:进入特权模式 enable switch> enable switch# 2:进入全局配置模式 configure terminal switch> enable switch#c onfigure terminal switch...
  • 思科交换机备份与还原思路: 一台电脑通过console端口连接到cisco 2960交换机,配置一个VLAN 10并分配IP地址和网关,电脑设置固定IP地址连接到cisco 2960交换机,确认交换机ping通这台电脑的IP...
  • 在这里办公室电脑局域网地址为192.168.17.8,TFTP ...Cisco交换机备份startup-config文件命令: Sw#copy startup-config tftp 案例1: dabaicai>en Password: dabaicai#copy star dabaicai#copy sta...
  • ㈠网络设备的初始化配置可网管交换机(三层交换机除外)无需配置即可作为傻瓜交换机使用,但是没有配置交换机将不能发挥其功能和安全性。没有配置的路由器无法实现网络之间的通信。2,网络设备的管理方式外置配置源...
  • 思科交换机的常用配置1、 交换机的端口2、端口:以太网端口(e0、e1)、快速以太网端口(fast0、fast0/1[第一个模块的第一端口、fast1、fast1/1)、光纤接口(Tx、Rx)2、 交换机的配置方法a、 通过CONSOLE端口利用...
  • 交换机配置自动备份

    千次阅读 2020-06-09 11:03:11
    使用 python3 多线程 ssh 批量登录交换机并获取到交换机配置,自动删除 30 天以前的配置,将命令配置到 crontab 实现每天备份,支持新华三,华为,锐捷,思科交换机 源码:https://github.com/xin053/switchbackup ...
  • Cisco交换机中操作系统叫IOS,IOS升级主要是闪存中的IOS映像文件进行更换,本文就为大家整理了思科交换机配置备份及IOS升级方法,希望对大家有帮助
  • 思科交换机领命

    2019-06-28 14:09:51
    思科交换机的基本配置命令学习小结 【火热量贩】半价囤好货 大包装 超实惠 思科交换机的基本配置命令学习 CISCO交换机基本配置:Console端口连接 用户模式hostname# ; 特权模式hostname(config)# ; 全局配置模式...
  • 在上一篇文章中已经配置了...思科交换机基础–FTP远程备份 查看上一篇文章中的镜像文件是否存在 确认存在 接下来恢复镜像文件到交换机 总结: 跟TFTP相比较FTP相对安全,FTP需要用户跟密码;命令语法基本相同。 ...
  • archive)#path tftp://ip/$h- //$h为当前主机名R(config-archive)#time-period 10080 //10080周期时间 单位:分钟R(config-archive)#write-memory //当保存配置进行write操作时,立即备份 转载于:https://blog....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 3,098
精华内容 1,239
关键字:

备份思科交换机配置