精华内容
下载资源
问答
  • 边界网关协议(BGP)是运行于 TCP 上的一种自治系统的路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。 BGP 系统...

    一、BGP定义

    边界网关协议(BGP)是运行于 TCP 上的一种自治系统的路由协议。 BGP 是唯一一个用来处理像因特网大小的网络的协议,也是唯一能够妥善处理好不相关路由域间的多路连接的协议。 BGP 构建在 EGP 的经验之上。 BGP 系统的主要功能是和其他的 BGP 系统交换网络可达信息。网络可达信息包括列出的自治系统(AS)的信息。这些信息有效地构造了 AS 互联的拓扑图并由此清除了路由环路,同时在 AS 级别上可实施策略决策。
    AS是指由同一个技术管理机构管理、使用统一选路策略的一些路由器的集合。
    BGP网络中的每个As都被分配一个唯一的AS号,用于区分不同的AS。

    1.1、概述

    边界网关协议(Border Gateway Protocol, BGP)是一种实现自治系统AS之间的路由可达,
    并选择最佳路由的矢量性协议。早期发布的三个版本分别是BGP-1 (RFC1105 )、
    BGP-2 ( RFC1163 )和BGP-3 ( RFC1267 ),1994年开始使用BGP-4(RFC1771),
    2006年之后单播IPv4网络使用的版本是BGP-4(RFC4271),其他网络使用的版本是MP-BGP( RFC4760 )。

    1.2、特点

    1. BGP能够承载大批量的路由信息,能够支撑大规模网络。
    2. BGP使用TCP作为其传输层协议(监听端口号为179),提高了协议的可靠性
    3. BGP是外部路由协议,用来在As之间传递数据,对稳定性要求非常高。因此用TCP协议的高可靠性来保证BGP协议的稳定性。
    4. BGP的对等体之间必须逻辑上连通,并进行TCP连接。目的端口号为179,本地端口号任意。
    5. BGP对等体和IGP对等体不同,BGP对等体(Peer)是指使用TCP建立连接的两端,而非与IGP同概念的直连邻居,只要TcP能够建立连接并不一定需要直连。
    6. !!BGP本身只负责控制路由,数据转发依然靠静态或IGP路由。
    7. BGP支持无类别域间路由CIDR。
    8. 路由更新时,BGP只发送更新的路由,大大减少了BGP传播路由所占用的带宽,适用于在Internet.上传播大量的路由信息。
    9. BGP是一种增强的距离矢量路由协议,从设计上避免了环路的发生。
    10. AS之间:BGP通过携带As_Path信息标记途经的AS,带有本地As号的路由将被丢弃,从而避免了域间产生环路。
    11. AS内部:BGP在As内学到的路由不会再通告给AS内的BGP邻居,避免了As内产生环路。
    12. BGP提供了丰富的路由策略,能够对路由实现灵活的过滤和选择。
    13. BGP提供了防止路由振荡的机制(路由衰减),有效提高了Internet网络的稳定性。
    14. BGP易于扩展,能够适应网络新的发展(ipv4单/组播、vpv4单/组播)。主要是通过TLV进行扩展。

    1.3、分类

    BGP按照运行方式分为EBGP (External/Exterior BGP)和IBGP (Internal/Interior BGP)。

    EBGP:运行于不同As之间的BGP称为EBGP。为了防止.as间产生环路,当BGP设备接收EBGP对等体发送的路由时,会将带有本地As号的路由丢弃。

    IBGP:运行于同一AS内部的BGP称为IBGP。为了防止as内产生环路,BGP设备不将从IBGP对等体学到的路由通告给其他IBGP对等体,并与所有IBGP对等体建立全连接。为了解决IBGP对等体的连接数量太多的问题,BGP设计了路由反射器和BGP联盟。

    1.4、工作原理

    BGP对等体的建立、更新和删除等交互过程主要有5种报文、6种状态机和9个原则。

    1、五种报文

    BGP对等体间通过以下5种报文进行交互,其中Keepalive报文为周期性发送,其余报文为触发式发送:
    Open报文:用于协商BGP对等体的各项参数,
    主要包括BGP版本(V4)、AS号等信息,建立BGP对等体连接。Open是TCP连接建立后发送的第一个报文

    Update报文:用于在对等体之间交换路由信息。
    连接建立后,有路由需要发送或者路由变化时,发送Update通告对端可达或者撤销路由信息及路径属性。

    ·Notification报文:用于中断BGP连接。
    当BGP在运行中发现错误时,发送Notification报文通告BGP对端,随后与之相关的邻居关系将被关闭。

    Keepalive报文:用于保持BGP连接。(保活)
    定时发送Keepalive报文以保持BGP对等体关系的有效性。响应收到的正确的Open报文

    Route-refresh报文:用于在改变路由策略后软复位BcP路由表请求对等体重新发送路由信息。
    只有支持路由刷新(Route-refresh)能力的BGP设备会发送和响应此报文。

    2、六种状态机

    BGP对等体的交互过程中存在6种状态机:空闲(Idle)、连接(Connect)、活跃(Active)、Open报文已发送(OpenSent)、Open报文已确认(OpenConfirm)和连接已建立(Established)。在BGP对等体建立的过程中,通常可见的3个状态是: Idle、Active和Established。

    1. Idle状态是BGP初始状态。在Idle状态下,BGP拒绝邻居发送的连接请求。
      只有在收到本设备的Start事件后,BGP才开始尝试和其它BGP对等体进行TCP连接,并转至Connect状态。
    2. 在Connect状态下,BGP启动连接重传定时器(Connect Retry),等待TCP完成连接。
      如果TCP连接成功,那么BGP向对等体发送open报文,并转至OpenSent状态。
      如果TCP连接失败,那么BGP转至Active状态,反复尝试连接。
      如果连接重传定时器超时,BGP仍没有收到BGP对等体的响应,那么BGP继续尝试和其它BGP对等体进行TCP连接,停留在Connect状态。
    3. 在Active状态下,BGP总是在试图建立TCP连接。
      如果TCP连接成功,那么BGP向对等体发送Open报文,关闭连接重传定时器,并转至OpenSent状态。
      如果TCP连接失败,那么BGP停留在Active状态。
      如果连接重传定时器超时,BGP仍没有收到BGP对等体的响应,那么BGP转至Connect状态。
    4. 在OpenSent状态下,BGP等待对等体的Open报文,并对收到的Open报文中的AS号、版本号、认证码等进行检查。
      如果收到的Open报文正确,那么BGP发送Keepalive报文,并转至OpenConfirm状态。
      如果发现收到的Open报文有错误,那么BGP发送Notification报文给对等体,并转至Idle状态。
    5. 在OpenConfirm状态下,BGP等待Keepalive或Notification报文。
      如果收到Keepalive报文,则转至Established状态,如果收到Notification报文,则转至Idle状态。
    6. 在Established状态下,BGP可以和对等体交换Update、Keepalive、Route-refresh报文和Notification报文。
      如果收到正确的Update或Keepalive报文,那么BGP就认为对端处于正常运行状态,将保持BGP连接。
      如果收到错误的Update或Keepalive报文,那么BGP发送Notification报文通知对端,并转至Idle状态。
      如果收到Notification报文,那么BGP转至Idle状态。
      如果收到TCP拆链通知,那么BGP断开连接,转至Idle状态。
      Route-refresh报文不会改变BGP状态。

    3、九个原则

    BGP设备将最优路由加入BGP路由表,形成BGP路由。BGP设备与对等体建立邻居关系后,采取以下交互原则:

    1. 从IBGP对等体获得的BGP路由,BGP设备只发布给它的EBGP对等体
    2. 从EBGP对等体获得的BGP路由,BGP设备发布给它所有EBGP和IBGP对等体
    3. 当存在多条到达同一目的地址的有效路由时,BGP设备只将最优路由发布给对等体
    4. 路由更新时,BGP设备只发送更新的BGP路由
    5. 所有对等体发送的路由,BGP设备都会接收
    6. 所有EBGP对等体在传递过程中下一跳改变
    7. 所有IBGP对等体在传递过程中下一跳不变
    8. 默认EBGP传递时TTL值为1
    9. 默认工BGP传递时TTL值为255

    1.5、如何建立对等体

    直连建立对等体需要注意的点
    建立IBGP对等体时要让下一跳可达,处于边界的IBGP对等体需要将下一跳指向自己,这样才能建立IBGP对等体
    用回环口建立邻居需要注意的点
    需要修改更新源,默认更新源是物理口,需要修改成回环口。建立IBGP对等体时要保障下一跳可达,处于边界的IBGP对等体需要将下一跳指向自己,这样才能建立IBGP对等体
    建立EBGP对等体时因为EBGP只能传一跳,因而,在建立EBGP对等体时,需要修改EBGP多跳的跳数为2以上(自己回环到对端回环是两跳,默认一跳)
    关于为什么要用回环口建邻居
    原因是回环口稳定,只要路由器启动着,回环口就不Down,而物理链路可能会受线路或者接口等因素的影响导致对等体关系有问题,因而一般BGP建立对等体都是回环口来建

    1.6、相关配置

    [ ]bgp XXX
    //进入bgp
    [ -bgp]router-id
    //指定router 可设可不设
    [ -bgp]peer (另一个AS的EBGP的回环口IP地址) as-number (ebgp邻居所属的AS编号)
    [ -bgp]peer (另一个AS的EBGP的回环口IP地址) connect-interface LoopBack0(配置的回环口)
    [ -bgp]peer (另一个AS的EBGP的回环口IP地址) ebgp-max-hop (最大跳数)
    //从一个路由器跳到下一个路由器的回环口 最少需要两跳 所以设置最大跳数≥2
    [ -bgp]peer (同一个AS中其他对等体的回环口IP地址)next-hop-local
    //ASBR从ebgp邻居学习到的路由传递给ibgp邻居时,路由下一跳改为自己
    [ -bgp]network (自己的回环接口IP地址)
    ebpg用于配置静态路由或IGP路由的回环网口IP需要在两端ebgp都宣告
    [ -bgp]network (学习到的邻居路由)
    //宣告指定的从本区域ibgp邻居学到的路由给ebgp邻居(非必要)
    [ ]ip route-static x.x.x.x x.x.x.x x.x.x.x
    //配置指向EBGP邻居的静态路由

    二、实验

    在这里插入图片描述
    首先添加接口IP以及回环地址以及AS200的ospf路由
    然后配置默认路由
    R1为指向R2和R3的两条默认路由
    R2、R3 同样配置一条指向R1的默认路由
    R4指向R5
    R5指向R4
    ps :要先做完所有路由器常规配置 再做bgp 不然在bgp里宣告不了邻居的回环地址

    以上配置省略

    BGP配置如下:
    R1:
    [R1]bgp 100
    [R1-bgp]peer 2.2.2.2 as-number 200
    [R1-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [R1-bgp]peer 2.2.2.2 ebgp-max-hop 2
    [R1-bgp]peer 3.3.3.3 as-number 200
    [R1-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [R1-bgp]peer 3.3.3.3 ebgp-max-hop 2
    [R1-bgp]net 1.1.1.1 255.255.255.255

    R2:
    [R2]bgp 200
    [R2-bgp]peer 1.1.1.1 as-number 100
    [R2-bgp]peer 1.1.1.1 connect-interface LoopBack 0
    [R2-bgp]peer 1.1.1.1 ebgp-max-hop 2
    [R2-bgp]peer 3.3.3.3 as-number 200
    [R2-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [R2-bgp]peer 4.4.4.4 as-number 200
    [R2-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    [R2-bgp]peer 4.4.4.4 next-hop-local
    [R2-bgp]net 1.1.1.1 255.255.255.255
    [R2-bgp]net 2.2.2.2 255.255.255.255
    [R2-bgp]net 3.3.3.3 255.255.255.255
    [R2-bgp]net 4.4.4.4 255.255.255.255

    R3
    [R3]bgp 200
    [R3-bgp]peer 1.1.1.1 as-number 100
    [R3-bgp]peer 1.1.1.1 connect-interface LoopBack 0
    [R3-bgp]peer 1.1.1.1 ebgp-max-hop 2
    [R3-bgp]peer 2.2.2.2 as-number 200
    [R3-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [R3-bgp]peer 4.4.4.4 as-number 200
    [R3-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    [R3-bgp]peer 4.4.4.4 next-hop-local
    [R3-bgp]net 1.1.1.1 255.255.255.255
    [R3-bgp]net 2.2.2.2 255.255.255.255
    [R3-bgp]net 3.3.3.3 255.255.255.255
    [R3-bgp]net 4.4.4.4 255.255.255.255

    R4
    [R4]bgp 200
    [R4-bgp]peer 2.2.2.2 as-number 200
    [R4-bgp]peer 2.2.2.2 connect-interface LoopBack 0
    [R4-bgp]peer 2.2.2.2 next-hop-local
    [R4-bgp]peer 3.3.3.3 as-number 200
    [R4-bgp]peer 3.3.3.3 connect-interface LoopBack 0
    [R4-bgp]peer 3.3.3.3 next-hop-local
    [R4-bgp]peer 5.5.5.5 as-number 300
    [R4-bgp]peer 5.5.5.5 connect-interface LoopBack 0
    [R4-bgp]peer 5.5.5.5 ebgp-max-hop 2
    [R4-bgp]net 2.2.2.2 255.255.255.255
    [R4-bgp]net 3.3.3.3 255.255.255.255
    [R4-bgp]net 4.4.4.4 255.255.255.255
    [R4-bgp]net 5.5.5.5 255.255.255.255

    R5
    [R5]bgp 300
    [R5-bgp]peer 4.4.4.4 as-number 200
    [R5-bgp]peer 4.4.4.4 connect-interface LoopBack 0
    [R5-bgp]peer 4.4.4.4 ebgp-max-hop 2
    [R5-bgp]net 4.4.4.4 255.255.255.255
    [R5-bgp]net 5.5.5.5 255.255.255.255

    测试
    在这里插入图片描述
    R1能够通信R5
    并且数据流向是 R1>>R2>>R4>>R5

    三、BGP选路

    3.1、路径属性

    (1)定义
    路径属性:path attributes,作用类似于metric(度量标准),用于度量BGP的路由优劣(用来进行选路)

    (2)分类

    公认强制属性:所有的BGP的update消息都要包含该属性
    AS路径(AS-path)
    下一跳(next-hop)
    起源(Origin)

    公认自由属性:该属性是可选可不选的,但是所有的BGP进程都能识别
    本地优先级(local preferent)

    可选传递属性:即使BGP进程不能识别该属性,也会继续传递下去
    团体属性(community)

    可选非传递属性:如果BGP进程不能识别该属性,可以忽略这条update,并且不传递下去
    MED

    3.2、BGP选路原则

    1. 如果此路由的下一跳不可达,忽略此路由
    2. Preferred-Value值数值越高越优先,华为私有属性,仅本地有意义
    3. Local-Preference值最高的路由优先
    4. 聚合路由优先于非聚合路由
    5. 本地手动聚合路由的优先级高于本地自动聚合的路由
    6. 本地通过Network命令引入的路由的优先级高于本地通过Import-route命令引入的路由
    7. As-path的长度最短的路径优先
    8. 比较Origin属性,IGP优于EGP,EGP优于Incomplete
    9. 选择MED较小的路由
    10. EBGP路由优于IBGP路由
    11. BGP优先选择到BGP下一跳的IGP度量值最低的路径

    当以上全部相同,则为等价路由,可以负载分担(注意:AS_Path必须一致,当负载分担时,以下3条原则无效)

    1. 比较Cluster_list长度,短者优先
    2. 比较Originator_ID(如果没有Originator_ID,则用Router_ID比较),选择数值较小的路径。
    3. 比较对等体的IP地址,选择IP地址数值最小的路径。

    上述标黄字体为三种常用配置方法:
    Local-Preference值最高的路由优先

    1. 为公认自决属性,用于告诉AS中的路由器,哪条路径是离开AS的首选路径
    2. Local_Preference属性只能在IBGP对等体间传递(除非做了策略否则Local_Preference值在IBGP对等体间传递过程中不会丢失),而不能在EBGP对等体间传递,如果在EBGP对等体间收到的路由的路径属性中携带了Local_Preference,则会触发Notifacation报文,造成会话中断;
    3. 但是可以在AS边界路由器上使用Import方向的策略来修改Local_Preference属性值。也就是在收到路由之后,在本地为路由赋予Local_Preference。

    配置
    [R3]route-policy lop permit node 10
    // 创建名为lop的路由策略(名称自定义 )
    [R3-route-policy]apply local-prefernce 666
    // 设置本地优先级为666 (默认为200)
    [R3-route-policy]quit
    [R3]bgp 200
    [R3-bgp]peer 4.4.4.4 route-policy lop export
    // 在R3上对R1执行出站export方向的路由策略,使得其在收到对方通告的路由后,在路由的local-prefernce的属性值改为666,使得R4优选R3通告的路由;
    如果此路由策略在R4配置则方向为入站import
    <R3>reset bgp all
    // 重启BGP
    <R3>refresh bgp all export
    // 重启 BGP所有出接口

    As-path的长度最短的路径优先
    使用AS-PATH属性控制选路(越少越优)

    为公认必遵属性,是前往目标网络的路由经过的AS号列表

    1. 作用:确保路由在EBGP对等体之间传递无环;另外也作为路由优选的衡量标准之一;
      路由在被通告给EBGP对等体时,路由器会在该路由的AS_Path中追加上本地的AS号;路由被通告给IBGP对等体时,AS-path不会发生改变

    2. 使用route-policy修改BGP路由的AS_Path:
      apply as-path xxx additive 在已有AS_Path基础上追加xxx
      apply as-path xxx overwrite 将已有AS_Path值替换(覆盖)成xxx
      apply as-path none overwrite 清空路由的AS_Path属性

    3. 使用route-policy修改BGP路由的AS_Path时,可以在EBGP对等体之间改变EBGP路由的AS_Path属性,从而影响BGP路由的优选。在华为路由器上,在IBGP对等体之间,也可以使用route-policy修改BGP路由的AS_Path。无论何种场景,改变BGP路由的AS_Path都必须十分谨慎,建议跟上一个经过的AS号保持一直。

    配置
    [R2]route-policy as permit node 10
    [R2-route-policy]apply as-path 123 123 123 additive
    在已有AS_Path基础上追加
    [R2]bgp 200
    [R2-bgp]peer 1.1.1.1 route-policy as export
    <R2>refresh bgp all export

    选择MED较小的路由

    1. 为可选非传递属性,是一种度量值
    2. 一般情况下,BGP设备只比较来自同一AS(不同对等体)的路由的MED属性值。可以通过配置命令来允许BGP比较来自不同AS的路由的MED属性值。执行compare-different-as-med命令后,系统将比较来自不同AS中的对等体的路由的MED值。

    配置
    [R2]route-policy med permit node 10
    [R2-route-policy]apply cost + 666
    [R2-route-policy]quit
    [R2]bgp 200
    [R2-bgp]peer 1.1.1.1 route-policy med export
    <R2>refresh bgp all export

    display bgp routing-table
    查BGP的路由表
    display bgp routing-table 目标网段
    查看详细信息

    展开全文
  • 外部网关路由协议(二) 目录 一、BGP路径分类 二、BGP选路即配置 三、BGP反射器 四、BGP路由聚合 一、BGP路径分类 BGP路径分类 路径选择原则 二、BGP选路即配置 1.根据local-prefernce控制选路 越大越优先 为公认...

    外部网关路由协议(二)

    目录

    一、BGP路径分类

    二、BGP选路即配置

    三、BGP反射器

    四、BGP路由聚合

    一、BGP路径分类

    1. BGP路径分类
    2. 路径选择原则

    二、BGP选路即配置

    1.根据local-prefernce控制选路

    越大越优先

    为公认自由属性,用于告诉AS中的路由器,哪条路径是离开AS的首选路径
    Local Preference属性只能在IBGP对等体间传递(除非做了策略否则Local Preference值在IBGP对等体间传递过程中不会丢失) ,而不能在EBGP对等体间传递,如果在EBGP对等体间收到的路由的路径属性中携带了LocalPreference,则会触发Notifacation报文,造成会话中断;
    但是可以在AS边界路由器上使用Import(注入)方向的策略来修改Local Preference属性值。也就是在收到路由之后,为本地路由赋予Local Preference

    [R3] route-policy lop permit node 10 ###创建名为Lop的路由策略
    [R3-route-policy] apply local-prefernce 222 ##设置本地优先级为222(默认优先级是100)
    R3-route-policy]quit
    [R3]bgp 200
    [R3-bgp]peer 4.4.4.4 route-policy lop export ####在R3上对R4执行出站export方向的路由策略,使得R4在收到R3通告的路由后,在路由的local-prefernce的属性值改为222,使得R4优选R3通告的路由;如果此路由策略在R4配置则方向为入站import
    
    reset bgp all ##重启BGP
    refresh bgp all export
    
    

    2.使用AS-PATH属性控制选路

    越少越优先

    为公认必遵属性,是前往目标网络的路由经过的As号列表
    作用:确保路由在EBGP对等体之间传递无环;另外也作为路由优选的衡量标准之一
    路由在被通告给EBGP对等体时,路由器会在该路由的As-Path中追加上本地的As号;路由被通告给IBGP对等体时,AS-path不会发生改变
    使用route-policy修改BGP路由的As Path

    apply as-path xxx additive          ###在已有AS Path基础上追加xxx
    apply as-path xxx overwrite         ###将已有AS Path值替换(覆盖)成xxx
    apply as-path none overwrite        ###清空路亩的AS Path属性
    
    
    [R2] route-policy as permit node 10
    [R2-route-policy]apply as-path 123 123 123 additive   ##在已有AS Path基础上追加
    [R2-route-policy]quit
    [R2]bgp 200
    [R2-bgp]peer 1.1.1.1 route-policy as export
    <R2>reset bgp all
    <R2>refresh bgp all export
    
    

    3.通过MED属性控制选路

    越小越优先

    为可选非传递属性,是一种度量值
    一般情况下, BGP设备只比较来自同一AS (不同对等体)的路由的MED属性值。可以通过配置命令来允许BGP比较来自不同AS的路由的MED属性值。执行compare-different-as-med命令后,系统将比较来自不同AS中的对等体的路由的MED值。
    compare-different-as-med命令

    [R2] route-policy med permit node 10
    [R2-route-policy] apply cost + 500/- 500
    [R2-route-policy]quit
    [R2]bgp 200
    [R2-bgp]peer 1.1.1.1 route-policy med export
    < R2 >reset bgp all
    < R2 >refresh bgp all export
    
    display bgp routing-table        ###查BGP的路由表
    display bgp routing-table 目标网段       ##查看详细信息
    
    

    三、BGP反射器

    在AS内部,为保证IBGP对等体之间的连通性,需要在IBGP对等体之间建立全连接关系
    当IBGP对等体数目很多时,建立全连接网络的开销很大。使用路由反射器RR (Route Reflector)可以解决这个问题
    集群ID用于防止集群内多个路由反射器和集群间的路由环路
    当一个集群里有多个路由反射器时,必须为同一个集群内的所有路由反射器配置相同的集群ID
    RR向IBGP邻居发布路由规则如下:(相当于中继的作用)
    1.从非客户端学到的路由,发布给所有客户端

    2.从客户端学到的路由,发布给所有非客户端和客户端(发起此路由的客户端除外)

    3.从EBGP对等体学到的路由,发布给所有的非客户端和客户端

    • RR配置命令
      R1,R2,R3, R4、R5、R6之间不用建立全互联,只与它们直连网段的路由器建立邻居关系,然后在R2和R5上做路由反射器(R5的配置和R2的相似略)
    [R2]bgp 100
    [R2-bgp] router-id 2.2.2.2
    [R2-bgp]peer 1.1.1.1 as-number 100
    [R2-bgp]peer 1.1.1.1 connect-interface LoopBackO
    [R2-bgp]peer 3.3.3.3 as-number 100
    [R2-bgp]peer 3.3.3.3 connect-interface LoopBackO
    [R2-bgp]peer 4.4.4.4 as-number 100
    [R2-bgp]peer 4.4.4.4 connect-interface LoopBackO
    [R2-bgp]peer 5.5.5.5 as-number 100
    [R2-bgp]peer 5.5.5.5 connect-interface LoopBackO
    [R2-bgp]reflector cluster-id 2 ###配置路由反射器的集群ID
    [R2-bgp]peer 3.3.3.3 reflect-client ##指定客户端
    
    

    四、BGP路由聚合

    [R7-bgp] network 192.168.0.0 255.255.252.0 ###将这个聚合的路由通告出去
    [R7]ip route-static 192.168.0.0 255.255.252.0 NULL0 ###将聚合的路由通告出去,因为在手动汇总的这个192.168.0.0在路由表中是不存在的的,要把它加入到NULL0里才能在bgp进程里用上面的network来通告这条路由
    
    
    [R7-bgp] aggregate 192.168.0.0 255.255.252.0 detail-suppressed as-set ###配置手动路由聚合用aggregate, 
    
    detail-suppressed是抑制明细路由的通告,增加las-set关键字后,该汇总路由将继承明细路由的路径属性,其中对明细路由AS-Path属性可以起到汇总路由防环作用
    
    
    展开全文
  • 1. 路由表 ...路由表建立的主要目标是为了实现路由协议和静态路由选择。 查找路由表,根据目的网络地址就能确定下一跳路由器,这样做的结果是: IP数据报最终一定可以找到目的主机所在的网路...

    1. 路由表

        在计算机网络中,路由表(routing table)或称路由择域信息库(RIB, Routing Information Base),是一个存储在路由器或者联网计算机中的电子表格(文件)或类数据库。路由表存储着指向特定网络地址的路径(在有些情况下,还记录有路径的路由度量值)。路由表中含有网络周边的拓扑信息。路由表建立的主要目标是为了实现路由协议和静态路由选择。

        查找路由表,根据目的网络地址就能确定下一跳路由器,这样做的结果是:

    • IP数据报最终一定可以找到目的主机所在的网路上的路由器(可能要通过多次的间接交付
    • 只有到达最后一个路由器时,才试图向,目的主机进行直接交付

    2. 路由间数据传输

        路由A发送数据报给路由B,路由B会将数据从数据链路层、物理层、网络层依次解析,拿到目的IP地址,根据路由器本身的路由表,根据最长匹配原则,找到下一个路由器IP,再依次按照网络层、物理层、数据链路层封包发给下一个路由器。 期间,通过路由器的IP地址使用ARP协议找到路由器对应的MAC地址。

    3.自治系统AS(Autonomous System)

    • 自治系统AS的定义:在单一的技术管理下的一组路由器,而这些路由器使用一种AS内部的路由选择协议和共同的度量以确定分组在该AS内的路由,同时还使用一种AS之间的路由选择协议用以确定分组在AS之间的路由。
    • 现在对自治系统AS的定义是强调下面的事实:尽管一个AS使用了多种内部路由选择协议和度量,但重要的是一个AS对其他AS表现出的是一个单一的和一致的路由选择策略

    4.内部网关RIP协议

        RIP(Routing Information Protocol)是内部网关协议IGP中最先得到广泛使用的协议。

    • RIP是一种分布式的、基于距离向量的路由选择协议。
    • RIP协议要求网络中的每一个路由器都要维护从它自己到每一个目的网络的距离记录。

    距离的定义:

    • 从一个路由器到直接连接的网络的距离定义为1
    • 从一个路由器到非直接连接的网络的距离定义为所经过的路由器数加1
    • RIP协议中的“距离”也称为"跳数"(hop count),因为每经过一个路由器,跳数就加1
    • 这里的“距离”实际上指的是“最短距离”
    • RIP认为一个好的路由就是它通过的路由器的数目少,即“距离短”。
    • RI允许一条路径最多只能包含15个路由器
    • “距离”的最大值为16时即相当于不可达。可见RIP只适用于小型互联网
    • RIP不能再两个网络之间同时使用多条路由。RIP选择一个具有最少路由器的路由(即最短路由),哪怕还存在另一条高速(低时延)但路由器较多的路由。

    RIP协议之间交换信息与路由表更新

    • RIP协议让互联网中的所有路由器都和自己相邻路由器不断交换路由信息,并不断更新其路由表,使得从每一个路由器到每一个目的网络的路由都是最短的(跳数最少)
    • 虽然所有的路由器最终都拥有了整个自治系统的全局路由信息,但由于每一路由器的位置不同,它们的路由表当然也应当是不同的

    优缺点

    • RIP协议特点:好消息传播得快,坏消息传播得慢
    • RIP存在的一个问题:当网络出现故障时,要经过比较长的时间(例如数分钟)才能将此信息传送到所有的路由器

        优点: 实现简单,开销较小。

        缺点:RIP限制了网络的规模,它能使用的最大距离为15. 路由器之间交换的路由信息是路由器中的完整路由表,因而随着网络规模的扩大,开销也增加。“坏消息传播得慢”,使更新过程的收敛时间过长。

    5. 内部网关协议OSPF

        开放最短路径优先OSPF(Open Shortest Path First)是为克服RIP的缺点在1989年开发出来的。

        OSPF的原理很简单,但实现起来却较复杂。

    • “开放”表明OSPF协议不是受某一家厂商控制,而是公开发表的。
    • “最短路径优先”是因为使用了Dijkstra提出的最短路径算法SPF
    • 采用分布式的链路状态协议(link state protocol)
    • 注意:OSPF只是一个协议的名字,它并不表示其他的路由选择协议不是“最短路径优先”

    OSPF三个要点

    • 向本自治系统中所有路由器发送信息,这里使用的方法是洪泛法
    • 发送的信息就是与本路由器相邻的所有路由器的链路状态,但这只是路由器所知道的部分信息。(“链路状态”就是说明本路由器都和哪些路由器相邻,以及该链路的“度量”(metric))
    • 只有当链路状态发生变化时,路由器才用洪泛法向所有路由器发送此信息。

    链路状态数据库(link-state database)

    • 由于各路由器之间频繁地交换链路状态信息,因此所有的路由器最终都能建立一个链路状态数据库。
    • 这个数据库实际上就是全网的拓扑结构图,它在全网范围内是一致的(这称为链路状态数据库的同步)
    • OSPF的链路状态数据库能较快地进行更新,使各个路由器能及时更新其路由表。
    • OSPF的更新过程收敛得快是其重要优点

    划分区域

    • 划分区域的好处就是将利用洪泛法交换链路状态信息的范围局限于每一个区域而不是整个的自治系统,这就减少了整个网络上的通信量。
    • 在一个区域内部的路由器只知道本区域的完整网络拓扑,而不知道其他区域的网络拓扑的情况。
    • OSPF使用层次结构的区域划分。在上层的区域叫做主干区域(backbone area)
    • 主干区域的标识符规定为0.0.0.0 。主干区域的作用就是用来连通其他在下层的区域

    6. 外部网关协议BGP(Border Gateway Protocol)

        互联网的规模太大,使得自治系统之间路由选择非常困难。对于自治系统之间的路由选择,要寻找最佳路由是很不现实的。 当一条路径经过几个不同AS时,要想对这样的路径计算出有意义的代价是不太可能的。比较合理的做法是在AS之间交换“可达性”信息。

        自治系统之间的路由选择必须考虑有关策略

        因此,边界网关协议BGP只能是力求寻找一条能够到达的网络,且比较好的路由(不能兜圈子),而并非找一条最佳路由。

    BGP发言人

    • 每一个自治系统的管理员要选择至少一个路由器作为该自治系统的“BGP发言人”(BGP speaker)
    • 一般来说,两个BGP发言人都是通过一个共享网络连接在一起,而BGP发言人往往就是BGP边界路由器,但也可以不是BGP边界路由器。

    BGP交换路由信息

    • 一个BGP发言人与其他自治系统中的BGP发言人要交换路由信息,就要先建立TCP连接,然后在此连接上交换BGP报文以建立BGP会话(session),利用BGP会话交换路由信息。
    • 使用TCP连接能够提供可靠的服务,也简化了路由选择协议。
    • 使用TCP连接交换路由信息的两个BGP发言人,彼此称为对方的邻站(neighbor)或对等站(peer)

    BGP协议的特点

    BGP协议交换路由信息的节点数量级是自治系统数的量级,这要比这些自治系统中的网络数少很多。

    每一个自治系统中BGP发言人(或边界路由器)的数目是很少的。这样使得自治系统之间的路由选择不致过分复制。

     

    7. 转发和路由选择的区别

    • 转发(forwarding)就是路由器根据转发表将用户的IP数据报从合适的端口转发出去
    • 路由选择(routing)则是按照分布式算法,根据从各相邻路由器得到的关于网络拓扑的变化情况,动态地改变所选择的路由器。
    • 路由表是根据路由选择算法得出的,而转发是从路由表得出的

     

     

    参考资料:

    https://www.bilibili.com/video/BV1ia4y1e7Bp?t=1865

    https://www.bilibili.com/video/BV14K4y187im/?spm_id_from=333.788.videocard.1

    展开全文
  • 外部网关协议----BGP及实验bgp的特点bgp协议特征bgp报文类型open报文update报文natification报文Keepalive报文route-refreshbgp的六种状态 bgp的特点 1.能够承载大批量的路由信息,能够支撑大规模网络 2.不能自己...

    bgp的特点

    1.能够承载大批量的路由信息,能够支撑大规模网络
    2.不能自己发现邻居
    3.不能自己发现路由信息

    bgp协议特征

    基于tcp,端口号179
    1.运行bgp的路由器称为bgp发言者
    2.两个建立bgp会话的路由器互为对等体
    3.bgp路由器只发送增量的bgp路由更新,或进行触发更新(不会周期性更新)
    4.能够承载大批量的路由前缀,用于大规模网络

    bgp报文类型

    open报文

    建立邻居关系 ,先建立tcp连接,成功后向对等体发送open报文

    update报文

    用于发送bgp路由信息,连接建立后,发送路由或路由发生变化时,发送update通告对端

    natification报文

    报告错误,中止对等体关系,bgp在运行中发现错误时,发送此报文通告对方

    Keepalive报文

    维持bgp对等体关系,定时发送此报文以保持bgp对等体关系,默认60s,死亡时间是180s

    route-refresh

    改变路由策略后请求对等体重新发送路由信息,当理由策略发生变化后,触发请求对等体重新通告路由

    bgp的六种状态

    idle

    尝试建立tcp连接,开始准备tcp连接

    conncet

    发tcp包,正在进行tcp连接,失败进入active,反复尝试连接,成功进入opensent

    active

    发tcp包,tcp连接没成功,反复尝试连接

    opensent

    发open包,tcp连接成功,开始发open包,携带参数协商对等体的建立

    openconfirm

    发Keepalive包,协商成功,自己发送Keepalive包,等待对方的Keepalive包

    established

    发update包,收到对方的Keepalive,对等体建立成功

    两种bgp

    一种是ibgp,在同一个as区域里面的bgp路由
    一种是ebgp,跨越不同as区域的bgp路由

    ibgp的水平分割

    路由器不能将自己从ibgp对等体学到的路由再传递给其他的ibgp对等体

    bgp的两张表

    bgp邻居表

    记录bgp对等体的表,查看命令dis bgp peer

    bgp路由表

    记录bgp路由的表,查看命令dis bgp routing

    bgp路由通告规则

    ①bgp只把最优路由传给对等体
    ②路由器从ebgp对等体获得的路由传递给所有的bgp对等体
    ③路由器从ibgp对等体获得的路由不会传递给它的bgp对等体
    ④路由器从ibgp对等体获得的路由是否通告给ebgp对等体要视igp和bgp同步情况决定

    实验

    在这里插入图片描述

    首先配置所以路由器的IP地址,在如图所说的区域创建ospf协议和rip协议

    <R1>
    #
    ospf 1 router-id 1.1.1.1 
     area 0.0.0.0 
      network 1.1.1.1 0.0.0.0 
      network 12.0.0.0 0.0.0.255 
      network 15.0.0.0 0.0.0.255 
    <R2>
    #
    ospf 1 router-id 2.2.2.2 
     area 0.0.0.0 
      network 2.2.2.2 0.0.0.0 
      network 12.0.0.0 0.0.0.255 
    #
    rip 1
     version 2
     network 23.0.0.0
    <R3>
    #
    rip 1
     version 2
     network 23.0.0.0
     network 3.0.0.0
    #
    <R5>
    #
    ospf 1 router-id 5.5.5.5 
     area 0.0.0.0 
      network 5.5.5.5 0.0.0.0 
      network 15.0.0.0 0.0.0.255 
    

    能看到邻居已经建立

    <R1>
    
      Please check whether system data has been changed, and save data in time
    
      Configuration console time out, please press any key to log on
    
    <R1>dis ospf pee
    
    	 OSPF Process 1 with Router ID 1.1.1.1
    		 Neighbors 
    
     Area 0.0.0.0 interface 12.0.0.1(GigabitEthernet0/0/0)'s neighbors
     Router ID: 2.2.2.2          Address: 12.0.0.2        
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 12.0.0.2  BDR: 12.0.0.1  MTU: 0    
       Dead timer due in 31  sec 
       Retrans timer interval: 5 
       Neighbor is up for 00:13:17     
       Authentication Sequence: [ 0 ] 
    
    		 Neighbors 
    
     Area 0.0.0.0 interface 15.0.0.1(GigabitEthernet0/0/1)'s neighbors
     Router ID: 5.5.5.5          Address: 15.0.0.2        
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 15.0.0.2  BDR: 15.0.0.1  MTU: 0    
       Dead timer due in 37  sec 
       Retrans timer interval: 5 
       Neighbor is up for 00:13:18     
       Authentication Sequence: [ 0 ] 
    
    <R1> 
    

    然后R1,R2,R5互相建立ibgp邻居,R2,R3互相建立ebgp邻居

    <R5>
    #
    bgp 100
     router-id 5.5.5.5
     peer 1.1.1.1 as-number 100 
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100 
     #
     ipv4-family unicast
      undo synchronization
      network 202.0.0.0 
      network 202.0.1.0 
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
    <R1>
    #
    bgp 100
     router-id 1.1.1.1
     peer 2.2.2.2 as-number 100 
     peer 2.2.2.2 connect-interface LoopBack0
     peer 5.5.5.5 as-number 100 
     peer 5.5.5.5 connect-interface LoopBack0
     #
    <R2>
    #
    bgp 100
     router-id 2.2.2.2
     peer 1.1.1.1 as-number 100 
     peer 1.1.1.1 connect-interface LoopBack0
     peer 5.5.5.5 as-number 100 
     peer 5.5.5.5 connect-interface LoopBack0
     peer 23.0.0.2 as-number 200 
     #
    <R3>
    #
    bgp 200
     router-id 3.3.3.3
     peer 23.0.0.1 as-number 100 
    

    能看到邻居已经建立

    <R2>dis bgp peer
    
     BGP local router ID : 2.2.2.2
     Local AS number : 100
     Total number of peers : 3		  Peers in established state : 3
    
      Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State Pre
    fRcv
    
      1.1.1.1         4         100       16       22     0 00:14:11 Established    
       0
      5.5.5.5         4         100       18       22     0 00:14:11 Established    
       2
      23.0.0.2        4         200       17       24     0 00:14:41 Established    
       1
    <R2>
    

    然后将202.0.0.1和202.0.1.1的路由写进bgp路由表,

    [R5-bgp]dis th
    [V200R003C00]
    #
    bgp 100
     router-id 5.5.5.5
     peer 1.1.1.1 as-number 100 
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100 
     #
     ipv4-family unicast
      undo synchronization
      network 202.0.0.0 
      network 202.0.1.0 
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
    #
    return
    

    将ospf注入bgp协议中并将R2与R3相连的网段直连写进bgp路由表,然后修改R5到R3的bgp下一跳接口

    import-route ospf 1
      peer 1.1.1.1 enable
      peer 1.1.1.1 next-hop-local 
      peer 5.5.5.5 enable
      peer 23.0.0.2 enable
    

    此时R3可以ping通202.0.0.1和202.0.1.1的主机

    <R3>ping -a 3.3.3.3 202.0.0.1
      PING 202.0.0.1: 56  data bytes, press CTRL_C to break
        Reply from 202.0.0.1: bytes=56 Sequence=1 ttl=253 time=60 ms
        Reply from 202.0.0.1: bytes=56 Sequence=2 ttl=253 time=40 ms
        Reply from 202.0.0.1: bytes=56 Sequence=3 ttl=253 time=30 ms
        Reply from 202.0.0.1: bytes=56 Sequence=4 ttl=253 time=30 ms
        Reply from 202.0.0.1: bytes=56 Sequence=5 ttl=253 time=30 ms
    
      --- 202.0.0.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/38/60 ms
    
    <R3>ping -a 3.3.3.3 202.0.1.1
      PING 202.0.1.1: 56  data bytes, press CTRL_C to break
        Reply from 202.0.1.1: bytes=56 Sequence=1 ttl=253 time=40 ms
        Reply from 202.0.1.1: bytes=56 Sequence=2 ttl=253 time=30 ms
        Reply from 202.0.1.1: bytes=56 Sequence=3 ttl=253 time=30 ms
        Reply from 202.0.1.1: bytes=56 Sequence=4 ttl=253 time=40 ms
        Reply from 202.0.1.1: bytes=56 Sequence=5 ttl=253 time=40 ms
    
      --- 202.0.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 30/36/40 ms
    
    <R3>
    

    并且路由条目是ebgp

    <R3>dis ip ro
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 15       Routes : 15       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  EBGP    255  1           D   23.0.0.1        GigabitEthernet
    0/0/0
            2.2.2.2/32  EBGP    255  0           D   23.0.0.1        GigabitEthernet
    0/0/0
            3.3.3.3/32  Direct  0    0           D   127.0.0.1       LoopBack0
            5.5.5.5/32  EBGP    255  2           D   23.0.0.1        GigabitEthernet
    0/0/0
           12.0.0.0/30  EBGP    255  0           D   23.0.0.1        GigabitEthernet
    0/0/0
           15.0.0.0/30  EBGP    255  2           D   23.0.0.1        GigabitEthernet
    0/0/0
           23.0.0.0/30  Direct  0    0           D   23.0.0.2        GigabitEthernet
    0/0/0
           23.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           23.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  EBGP    255  0           D   23.0.0.1        GigabitEthernet
    0/0/0
          202.0.1.0/24  EBGP    255  0           D   23.0.0.1        GigabitEthernet
    0/0/0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    <R3>
    

    在R2上看202.0.0.1和202.0.1.1的主机路由条目是ibgp

    <R2>dis ip ro
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 17       Routes : 17       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
            1.1.1.1/32  OSPF    10   1           D   12.0.0.1        GigabitEthernet
    0/0/0
            2.2.2.2/32  Direct  0    0           D   127.0.0.1       LoopBack0
            3.3.3.3/32  RIP     100  1           D   23.0.0.2        GigabitEthernet
    0/0/1
            5.5.5.5/32  OSPF    10   2           D   12.0.0.1        GigabitEthernet
    0/0/0
           12.0.0.0/30  Direct  0    0           D   12.0.0.2        GigabitEthernet
    0/0/0
           12.0.0.2/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           12.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/0
           15.0.0.0/30  OSPF    10   2           D   12.0.0.1        GigabitEthernet
    0/0/0
           23.0.0.0/30  Direct  0    0           D   23.0.0.1        GigabitEthernet
    0/0/1
           23.0.0.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
           23.0.0.3/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
    0/0/1
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    127.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
          202.0.0.0/24  IBGP    255  0          RD   5.5.5.5         GigabitEthernet
    0/0/0
          202.0.1.0/24  IBGP    255  0          RD   5.5.5.5         GigabitEthernet
    0/0/0
    255.255.255.255/32  Direct  0    0           D   127.0.0.1       InLoopBack0
    
    <R2>
    

    总结:bgp协议的邻居和路由条目都必须手动进行操作,自己本身不能发现邻居和路由

    展开全文
  • 外部网关协议(EGP)外部网关协议用于在非核心的相邻网关之间传输信息。非核心网关包含互联网络上所有与其直接相邻的网关的路由信息及其所连机器信息,但是它们不包含Internet上其他网关的信息。对绝大多数EGP而言,只...
  • 外部网关协议BGP(一) 目录 一、自治系统 二、BGP 三、BGP的工作原理 四、BGP的简单配置命令 一、自治系统 定义 自治系统AS是指同一个技术管理机构管理、使用统一选路策略的一些路由的集合 AS号 BGP网络中的...
  • 外部网关协议:network IP 可能发布任意网段 bgp这个是个边界网关协议,他自己本身不能产生路由,也不能自主学习域内的路由。这个跟ospf这些igp协议是不太一样的,igp协议在接口使能之后,他可以通过这些接口学习到...
  • ospf路由协议

    2021-10-24 14:08:51
    ospf路由协议 ospf协议概述 1、 ospf协议是由内部网关协议和外部网关协议 自制系统(AS) 内部网关协议(lGP) 外部网关协议(EGP) OSPF–>开放的最短路径优先协议 ...EGP:外部网关路由协议,运行在As与As之间的
  • BGP:边界网关路由协议

    2021-01-16 15:37:18
    BGP:边界网关路由协议 无类别的路径矢量EGP协议; EGP类别的路由协议,用于AS与AS间进行路由条目共享; AS编号 0-65535标准编号,其中1-64511公有 64512-65535私有 32位二进制构建为扩展编号; ...
  • BGP 边界网关路由协议

    万次阅读 2021-11-10 16:37:52
    文章目录 边界网关协议 BGP协议详解 最全BGP路由协议技术详解
  • 初识BGP外部网关协议(一)前言一、自治系统1、定义2、AS号二、BGP1、BGP定义2、BGP特点3、BGP分类4、BGP的路由器三、BGP工作原理1、5种报文2、6种状态机3、9个原则总结 前言 边界网关协议(BGP)是运行于 TCP 上...
  • BGP边界网关路由协议

    2021-01-29 21:19:56
    HCIP 文章目录 前言 BGP边界网关路由协议(高阶版的重发布) BGP协议特点 BGP数据包 BGP过程 两个 BGP路由黑洞 BGP的防环机制: EBGP水平分割——携带本地AS号的路由不得进入本地AS IBGP水平分割——本地路由器从一...
  • BGP外部网关协议(二)前言一、BGP路由技术背景二、BGP路由优选规则三、路径属性分类1、定义2、分类四、BGP选路及配置1、根据local-prefernce控制选路( 越大越优)2、使用AS-PATH属性控制选路(越少越优)3、通过MED...
  • 内部网关协议

    2021-07-07 01:33:49
    内部网关协议(IGP/Interior Gateway Protocol)[编辑]什么是...[编辑]内部网关协议RIP路由信息协议(Routing Information Protocol,RIP)是内部网关协议(IGP)中最先得到广泛使用的协议。RIP是一种分布式的基于距离向量...
  • 本文介绍网关协议
  • 边界网关路由协议:BGP(4) 动态路由协议分为IGP 和EGP,而BGP为EGP的一种,它们都工作于AS中。 三种路由协议和AS自治系统简介: IGP:工作在同一AS中主要用来发现并计算路由,为AS间提供信息交换。 EGP:工作于不同...
  • 本文将分享网关路由测试开发过程中的经验和遇到的问题。 2.网关功能简介 网关主要功能是通过报文路由转发、报文过滤与信号重组等工作实现信息的交换,包括不同通信协议间的交互,如Ethernet、FlexRay、CAN、CAN FD...
  • 动态路由协议及RIP工作原理一级目录二级目录三级目录 一级目录 二级目录 三级目录 配置实例 1、配置R1 <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]un in en Info: Information ...
  • 4.5.4 外部网关协议 BGP

    2021-04-17 10:03:33
    使用BGP边界网关协议的原因 1、互联网的规模太大,AS之间的路由选择十分困难 目前互联网主干网上的路由器已超过5万个网络前缀,用之间的算法计算最短路径耗时太长 个
  • 外部网关协议BGP

    2021-04-27 21:55:35
    外部网关协议BGP(边界网关协议): 互联网的规模太大,使得AS之间路由选择非常困难(不同AS内部的度量不同) AS之间的路由选择必须考虑有关策略(政治、安全、经济) 路径向量选择协议 BGP所交换的网络可达性的...
  • 外部网关协议EGP(External Gateway Protocol):目前使用的协议就是BGP 下图是两个自治系统互连在一起的示意图: 对于比较大的自治系统,还可将所有的网络再进行一次划分。例如,可以构筑一个链路速率较高的主干网和...
  • ## 一. AS的概念 自治系统(Autonomous System ,AS),指的是在同一个...边界网关协议(Border Gateway Protocol,BGP )是一种实现自治系统AS之间的路由可达,并选择最佳路由的矢量性协议。早期发布的三个版本分别是B
  • BGP边界网关协议一、BGP的概述二、BGP的特点三、BGP的分类四、BGP的工作原理1.BGP的五报文2.BGP六状态3.BGP对等体之间交互九原则四、建立对等体...3.BGP是外部路由协议,用来在AS之间传递数据,对稳定性要求非常高。因
  • OSPF概述 OSPF--开放的最短路径优先协议 内部网关协议和外部网关协议 ...EGP:外部网关路由协议,运行在AS与AS之间的路由协议,他解决AS之间选路问题。 通常:BGP 2.按协议类型分类 距离矢量路由协议:
  • 文章目录前言一、层次路由二、RIP协议(Routing Information Protocol)三、OSPF协议(Open Shortest Path First)四、BGP协议(Border Gateway总结 前言 提示:以下是本篇文章正文内容 一、层次路由 将任意规模网络...
  • ®南昌大学实验报告学生姓名 ________学号 _专业班级______________________________实验类型 口验证■综合□设计□创新实验日期 2017/12/14__________实验成绩__________实验六动态路由协议RIP配置实训...
  • OSPF路由协议详解

    千次阅读 2021-03-23 14:25:37
    OSPF路由协议详解一、OSPF路由协议详概述AS自治系统分类二、OSPF...是对链路状态路由协议的一种实现,隶属内部网关协议(IGP),故运作于自治系统内部。著名的迪克斯彻(Dijkstra)算法被用来计算最短路径树。OSPF支持
  • 动态路由协议(OSPF)

    2021-03-23 14:13:22
    文章目录一、OSPF基本概念和工作过程1.AS概念与分类2.OSPF3.OSPF的工作过程4.OSPF路由协议概述二、OSPF区域1.骨干区域/非骨干区域2.路由器(DR和BDR)(1)Router ID :OSPF区域内唯一标识路由器的IP地址(2)DR和BDR3....

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 36,495
精华内容 14,598
关键字:

外部网关路由协议