精华内容
下载资源
问答
  • VLAN配置以及接口划分,与上联接口配置Trunk,只允许特定的VLAN通过 说明:这里以访客厅、高层人员、财务为例,生产部、业务部这里就不讲解了,配置方法与前面3一模一样。 3.1 访客厅需要配置的VLAN 访客厅为...

    http://ccieh3c.com/?p=508

    拓扑

    实战

    拓扑可以保存到本地,然后扩大查看,这样才能看的更清楚。

    VLAN配置以及接口划分,与上联接口配置Trunk,只允许特定的VLAN通过

    说明:这里以访客厅、高层人员、财务为例,生产部、业务部这里就不讲解了,配置方法与前面3个一模一样。

    3.1 访客厅需要配置的VLAN

    访客厅为VLAN 19,另外访客厅还有无线AP与VLAN 1的管理流量需要通过,所以放行的VLAN为1,19

    system-view
    [FKT]vlan 19
    说明:这里定义了一个VLAN为19,因为默认VLAN1已经存在了,19是该访客厅流量通过的。

    PC接入接口
    [FKT]port-group 1
    [FKT-port-group-1]group-member Ethernet 0/0/2 to Ethernet 0/0/22
    [FKT-port-group-1]port link-type access
    [FKT-port-group-1]port default vlan 19

    说明:port-group的作用就是,把多个接口加入到一个组中,然后集中配置策略,这样可以简化配置,这里配置了将E0/0/2-22号接口都定义为Access接口,划入VLAN 19中,默认为Hybrid端口

    接无线AP接口
    interface e0/0/1
    port hybrid tagged vlan 19

    说明:接无线AP的接口,必须允许2个VLAN 通过,一个为VLAN 1,一个为VLAN 19,默认情况下VLAN1就允许通过,而且不打标签,VLAN 1为AP的管理流量,AP获得地址后需要通过该IP地址与AC进行通信协商隧道的,而VLAN 19则是业务流量,是PC访问外网或者内部流量转发的,所以必须放行2个VLAN

    上联接口【连接核心1与2的接口】
    [FKT]port-group 2
    [FKT-port-group-2]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2
    [FKT-GigabitEthernet0/0/2]port link-type trunk
    [FKT-port-group-2]port trunk allow-pass vlan 1 19

    说明:Group的作用与上面一样,这里定义2个上联接口为Trunk,并且允许了VLAN 1与19的流量通过。G0/0/1连接核心1,G0/0/2连接核心2

    3.2 高层人员配置的VLAN

    高层人员VLAN 为20,另外访客厅还有无线AP与VLAN 1的管理流量需要通过,所以放行的VLAN为1,20

    说明,配置思路与访客厅一样,作用效果 也一样,参考访客厅的注释即可。
    system-view
    [boss]vlan 20
    [boss]port-group 1
    [boss-port-group-1]group-member e0/0/2 to e0/0/22
    [boss-port-group-1]port link-type access
    [boss-port-group-1]port default vlan 20

    [boss]int e0/0/1
    [boss-Ethernet0/0/1]port hybrid tagged vlan 20

    [boss]port-group 2
    [boss-port-group-2]group-member GigabitEthernet 0/0/1 to g0/0/2
    [boss-port-group-2]port link-type trunk
    [boss-port-group-2]port trunk allow-pass vlan 1 20

    3.3 财务需要配置的VLAN

    说明: 财务VLAN 为21,VLAN 1的管理流量需要通过,所以放行的VLAN为1,21 ,注意财务是没有无线的,其余的与访客厅,高层人员类似
    system-view
    [caiwu]vlan 21

    [caiwu]port-group 1
    [caiwu-port-group-1]group-member Ethernet 0/0/1 to e0/0/22
    [caiwu-port-group-1]port link-type access
    [caiwu-port-group-1]port default vlan 21

    [caiwu]port-group 2
    [caiwu-port-group-2]group-member g0/0/1 to g0/0/2
    [caiwu-port-group-2]port link-type trunk
    [caiwu-port-group-2]port trunk allow-pass vlan 1 21

    特别建议,建议在上联交换机的接口上面,定义一个description,它的作用可以让您更加知道该接口接口连接的哪,方便后续排错、或者查看。

    [FKT]int g0/0/1
    [FKT-GigabitEthernet0/0/1]description connection to Core-A g0/0/24
    这里的描述表示,就是该接口连接的核心A的G0/0/24号接口。

    3.4 核心层 A需要配置的VLAN以及接口

    由于案例这里只给出访客厅、高层人员、财务作为举例,所以只创建VLAN 19~21,而生产部与业务部是一样的配置,所以节省资源,就没配置了。

    [Core-A]vlan batch 19 to 21,

    说明:批量创建了VLAN 19~21,这里必须包含下面接入层所有的VLAN,因为,下面交换机都是连接到了核心A和B上面,所以需要创建所有VLAN,来总结所有的VLAN流量。

    [Core-A]interface g0/0/24
    [Core-A-GigabitEthernet0/0/24]description connection to fkt-g0/0/1
    [Core-A-GigabitEthernet0/0/24]port link-type trunk
    [Core-A-GigabitEthernet0/0/24]port trunk allow-pass vlan 1 19

    说明:该接口是连接访客厅的交换机,做了一个描述 description ,然后允许了vlan 1与19的流量通过,因为访客厅只有VLAN 1与19的流量通过。

    [Core-A]interface g0/0/23
    [Core-A-GigabitEthernet0/0/23]description connection to boss-g0/0/2
    [Core-A-GigabitEthernet0/0/23]port link-type trunk
    [Core-A-GigabitEthernet0/0/23]port trunk allow-pass vlan 1 20

    说明:该接口是连接boss的交换机,做了一个描述 description ,然后允许了vlan 1与20的流量通过,因为访客厅只有VLAN 1与20的流量通过。

    [Core-A]int g0/0/21
    [Core-A-GigabitEthernet0/0/21]port link-type trunk
    [Core-A-GigabitEthernet0/0/21]port trunk allow-pass vlan 1 21
    [Core-A-GigabitEthernet0/0/21]description connection to caiwu-g0/0/1

    说明:该接口是连接财务的交换机,做了一个描述 description ,然后允许了vlan 1与21的流量通过,因为访客厅只有VLAN 1与21的流量通过。

    特别建议:建议在重要的接口做description,这样只要一看就知道连接哪,并且标明了接口,很容易避免以后忘记接口接哪了,看下配置即可。

    3.5 核心B需要配置的VLAN以及接口

    由于案例这里只给出访客厅、高层人员、财务作为举例,所以只创建VLAN 19~21,而生产部与业务部是一样的配置,所以节省资源,就没配置了。
    [Core-B]vlan batch 19 to 21

    说明:批量创建了VLAN 19~21,这里必须包含下面接入层所有的VLAN,因为,下面交换机都是连接到了核心A和B上面,所以需要创建所有VLAN,来总结所有的VLAN流量。

    [Core-B]int g0/0/24
    [Core-B-GigabitEthernet0/0/24]description connection to FKT g0/0/2
    [Core-B-GigabitEthernet0/0/24]port link-type trunk
    [Core-B-GigabitEthernet0/0/24]port trunk allow-pass vlan 1 19

    说明:该接口是连接访客厅的交换机,做了一个描述 description ,然后允许了vlan 1与19的流量通过,因为访客厅只有VLAN 1与19的流量通过。

    [Core-B]int g0/0/23
    [Core-B-GigabitEthernet0/0/23]port link-type trunk
    [Core-B-GigabitEthernet0/0/23]port trunk allow-pass vlan 1 20
    [Core-B-GigabitEthernet0/0/23]description connection to boss g0/0/1
    说明:该接口是连接boss的交换机,做了一个描述 description ,然后允许了vlan 1与20的流量通过,因为访客厅只有VLAN 1与20的流量通过。

    [Core-B]int g0/0/22
    [Core-B-GigabitEthernet0/0/22]description connection to caiwu g0/0/2
    [Core-B-GigabitEthernet0/0/22]port link-type trunk
    [Core-B-GigabitEthernet0/0/22]port trunk allow-pass vlan 1 21

    说明:该接口是连接财务的交换机,做了一个描述 description ,然后允许了vlan 1与21的流量通过,因为访客厅只有VLAN 1与21的流量通过。

    特别建议:建议在重要的接口做description,这样只要一看就知道连接哪,并且标明了接口。
    【这里Core-A与B之间的两条链路还未配置,这是因为待会在配置聚合的时候在一起配置,那个是聚合用的】

    3.6 出口防火墙与核心交换机之间的接口划分

    分析:核心交换机与出口防火墙之间,是一个三角形的结构,在交换机上面肯定是做接口划分到VLAN,然后起VLAN接口,与防火墙进行通信。 而防火墙则有两种办法与交换机通信,一种是也通过VLAN接口进行通信,第二种则是通过三层口与三层交换机之间通信。 推选第一种比较好,这种结构比较简单,路由配置起来也明确。而第二种方法则需要配置2个VLAN,然后2个网段与防火墙进行通信。

    3.6.1 Core-A配置
    [Core-A]vlan 100
    说明:该100是用来单独连接防火墙的
    [Core-A]interface g0/0/22
    [Core-A-GigabitEthernet0/0/22]port link-type access
    [Core-A-GigabitEthernet0/0/22]port default vlan 100
    [Core-A-GigabitEthernet0/0/22]description connection to FW g0/0/8
    说明:把接口划分到100中,做了一个描述,说明连接防火墙的 g0/0/8接口

    3.6.2 Core-B配置
    [Core-B]interface g0/0/21
    [Core-B-GigabitEthernet0/0/21]port link-type access
    [Core-B-GigabitEthernet0/0/21]port default vlan 100
    [Core-B-GigabitEthernet0/0/21]description connection to FW G0/0/7
    说明:把接口划分到100中,做了一个描述,说明连接防火墙的 g0/0/7接口

    3.6.3 FW配置 
    system-view
    [USG-GW]portswitch batch GigabitEthernet 0/0/7 to 0/0/8
    说明:该命令的含义就是把三层接口切换为二层接口,默认为三层接口

    [USG-GW]vlan 100
    [USG-GW-vlan-100]port GigabitEthernet 0/0/7 to 0/0/8
    说明:创建了VLAN 100,并且把G0/0/7~8加入了VLAN 100中

    3.7 核心交换机与服务器集群交换机的配置

    3.7.1 核心交换机A与B 
    [Core-A]vlan 88
    [Core-A]int g0/0/20
    [Core-A-GigabitEthernet0/0/20]description connection to server g0/0/2
    [Core-A-GigabitEthernet0/0/20]port link-type trunk
    [Core-A-GigabitEthernet0/0/20]port trunk allow-pass vlan 1 88
    说明:这里配置Trunk,是因为为了后续方便管理服务器交换机,如果不需要管理的话,则可以直接通过Access接口即可。

    [Core-B]vlan 88
    [Core-B]int g0/0/20
    [Core-B-GigabitEthernet0/0/20]port link-type trunk
    [Core-B-GigabitEthernet0/0/20]port trunk allow-pass vlan 1 88
    说明:这里配置Trunk,是因为为了后续方便管理服务器交换机,如果不需要管理的话,则可以直接通过Access接口即可。

    3.7.2 服务器集群交换机配置
    system-view
    [Cluster Server]vlan 88

    [Cluster Server]port-group 1
    [Cluster Server-port-group-1]group-member g0/0/1 to g0/0/2
    [Cluster Server-port-group-1]port link-type trunk
    [Cluster Server-port-group-1]port trunk allow-pass vlan 1 88
    [Cluster Server-port-group-1]description connection to Core-A-B
    说明:第一个port-group是定义了连接核心交换机的接口为Trunk,并且允许1与88通过

    [Cluster Server]port-group 2
    [Cluster Server-port-group-2]group-member e0/0/1 to e0/0/2
    [Cluster Server-Ethernet0/0/2]port link-type access
    [Cluster Server-Ethernet0/0/2]port default vlan 88
    说明:该2个接口是连接服务器用的,划入了对应的VLAN 88。

    总结:至此整个VLAN的部署已经接口划分完毕,这里注意的地方就是Trunk,默认情况下只允许VLAN 1的流量通过,而其余流量是不允许的,所以需要允许需要的流量通过,如果不确定哪些VLAN的流量要通过,可以直接 permit all。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,,http://ccieh3c.com

    展开全文
  • 一个端口多个VLAN

    千次阅读 2018-11-15 11:01:00
    不想启路由的情况下,希望将一个端口多个VLAN中去,其目的有如下几点: 1、隔离不想让相互访问的端口。(如两个部门) 2、让都需要访问的端口到所有VLAN.(如共享服务器) 3、不启路由协议。(启路由会将降...

    不想启路由的情况下,希望将一个端口划到多个VLAN中去,其目的有如下几点:

    1、隔离不想让相互访问的端口。(如两个部门)

    2、让都需要访问的端口划到所有VLAN.(如共享服务器)

    3、不启路由协议。(启路由会将降处理速度)

     

    根据收集到的资料和自己的实际环境实验,列出以下*作步骤:

     

    (华为6506为例)

    sys
    vlan 100
    quit
    vlan 200
    quit
    vlan 300  //(假设只有三个VLAN,都可以访问端口1,VLAN100、200和300之间不能访问)
    quit
    vlan 100
    port e 1/1 to e 1/8
    quit
    vlan 200
    quit 
    vlan 300
    port e 1/17 to e 1/24
    quit
    
    int e 1/1  //(接服务器的端口) (多个vlan的端口)
    port link-type trunk
    port trunk permit vlan 100 200 300
    quit
    
    disp vlan 100
    发现1-8号端口属于VLAN 100
    disp vlan 200 
    发现1,9-16号端口属于VLAN 200
    disp vlan 300 
    发现1,17-24号端口属于VLAN 300
    这样,交换机上所有的端口都能访问端口1,而VLAN之间不能相互访问。
    
    注意事项:
    要接Trunk端口的服务器网卡支持802.1Q. 否则,即使该端口属于多个VLAN,也不会Ping通。这是实际中碰到过的
    
    总结:在实际中,可以有多种方式实现此功能:
    1、trunk
    2、hybrid
    3、multi
    4、pvlan
    
    这几种方式都可行,但只能选用一种(不能同时使用)

     

     

     

    转载于:https://www.cnblogs.com/code1992/p/9962287.html

    展开全文
  • 如何批量将接口加入VLAN

    千次阅读 2020-09-24 10:14:49
    通过端口组可以把接口批量加入VLAN。对于Access接口,还可以在VLAN视图下直接批量将接口加入VLAN。 Access接口类型 将接口Eth2/0/1~Eth2/0/5批量加入VLAN10。 通过端口组批量将接口加入VLAN [Huawei] port-group ...

    通过端口组可以把接口批量加入VLAN。对于Access接口,还可以在VLAN视图下直接批量将接口加入VLAN。

    Access接口类型

    将接口Eth2/0/1~Eth2/0/5批量加入VLAN10。
    • 通过端口组批量将接口加入VLAN
    [Huawei] port-group pg1  
    [Huawei-port-group-pg1] group-member Ethernet 2/0/1 to Ethernet 2/0/5  
    [Huawei-port-group-pg1] port link-type access  
    [Huawei-port-group-pg1] port default vlan 10  
    
    • 在VLAN视图下批量将接口加入VLAN
    [Huawei] vlan 10  
    [Huawei-vlan10] port Ethernet 2/0/1 to 2/0/5  
    

    执行此操作前,须先将所有要批量加入VLAN的接口类型配置为Access。

    Trunk接口类型

    将接口Eth2/0/1~Eth2/0/5批量加入VLAN10和VLAN20。
    [Huawei] port-group pg1  
    [Huawei-port-group-pg1] group-member Ethernet 2/0/1 to Ethernet 2/0/5  
    [Huawei-port-group-pg1] port link-type trunk  
    [Huawei-port-group-pg1] port trunk allow-pass vlan 10 20  
    

    Hybrid接口类型

    将接口Eth2/0/1~Eth2/0/5批量加入VLAN10和VLAN20。
    [Huawei] port-group pg1  
    [Huawei-port-group-pg1] group-member Ethernet 2/0/1 to Ethernet 2/0/5  
    [Huawei-port-group-pg1] port link-type hybrid  
    [Huawei-port-group-pg1] port hybrid tagged vlan 10  
    [Huawei-port-group-pg1] port hybrid untagged vlan 20  
    
    展开全文
  • VLAN配置以及接口划分,与上联接口配置Trunk,只允许特定的VLAN通过 说明:这里以访客厅、高层人员、财务为例,生产部、业务部这里就不讲解了,配置方法与前面3一模一样。 3.1 访客厅需要配置的VLAN 访客厅为...

    拓扑

    实战

    拓扑可以保存到本地,然后扩大查看,这样才能看的更清楚。

    VLAN配置以及接口划分,与上联接口配置Trunk,只允许特定的VLAN通过

    说明:这里以访客厅、高层人员、财务为例,生产部、业务部这里就不讲解了,配置方法与前面3个一模一样。

    3.1 访客厅需要配置的VLAN

    访客厅为VLAN 19,另外访客厅还有无线AP与VLAN 1的管理流量需要通过,所以放行的VLAN为1,19

    system-view
    [FKT]vlan 19
    说明:这里定义了一个VLAN为19,因为默认VLAN1已经存在了,19是该访客厅流量通过的。

    PC接入接口
    [FKT]port-group 1
    [FKT-port-group-1]group-member Ethernet 0/0/2 to Ethernet 0/0/22
    [FKT-port-group-1]port link-type access
    [FKT-port-group-1]port default vlan 19

    说明:port-group的作用就是,把多个接口加入到一个组中,然后集中配置策略,这样可以简化配置,这里配置了将E0/0/2-22号接口都定义为Access接口,划入VLAN 19中,默认为Hybrid端口

    接无线AP接口
    interface e0/0/1
    port hybrid tagged vlan 19

    说明:接无线AP的接口,必须允许2个VLAN 通过,一个为VLAN 1,一个为VLAN 19,默认情况下VLAN1就允许通过,而且不打标签,VLAN 1为AP的管理流量,AP获得地址后需要通过该IP地址与AC进行通信协商隧道的,而VLAN 19则是业务流量,是PC访问外网或者内部流量转发的,所以必须放行2个VLAN

    上联接口【连接核心1与2的接口】
    [FKT]port-group 2
    [FKT-port-group-2]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/0/2
    [FKT-GigabitEthernet0/0/2]port link-type trunk
    [FKT-port-group-2]port trunk allow-pass vlan 1 19

    说明:Group的作用与上面一样,这里定义2个上联接口为Trunk,并且允许了VLAN 1与19的流量通过。G0/0/1连接核心1,G0/0/2连接核心2

    3.2 高层人员配置的VLAN

    高层人员VLAN 为20,另外访客厅还有无线AP与VLAN 1的管理流量需要通过,所以放行的VLAN为1,20

    说明,配置思路与访客厅一样,作用效果 也一样,参考访客厅的注释即可。
    system-view
    [boss]vlan 20
    [boss]port-group 1
    [boss-port-group-1]group-member e0/0/2 to e0/0/22
    [boss-port-group-1]port link-type access
    [boss-port-group-1]port default vlan 2

    [boss]int e0/0/1
    [boss-Ethernet0/0/1]port hybrid tagged vlan 20

    [boss]port-group 2
    [boss-port-group-2]group-member GigabitEthernet 0/0/1 to g0/0/2
    [boss-port-group-2]port link-type trunk
    [boss-port-group-2]port trunk allow-pass vlan 1 20

    3.3 财务需要配置的VLAN

    说明: 财务VLAN 为21,VLAN 1的管理流量需要通过,所以放行的VLAN为1,21 ,注意财务是没有无线的,其余的与访客厅,高层人员类似
    system-view
    [caiwu]vlan 21

    [caiwu]port-group 1
    [caiwu-port-group-1]group-member Ethernet 0/0/1 to e0/0/22
    [caiwu-port-group-1]port link-type access
    [caiwu-port-group-1]port default vlan 21

    [caiwu]port-group 2
    [caiwu-port-group-2]group-member g0/0/1 to g0/0/2
    [caiwu-port-group-2]port link-type trunk
    [caiwu-port-group-2]port trunk allow-pass vlan 1 21

    特别建议,建议在上联交换机的接口上面,定义一个description,它的作用可以让您更加知道该接口接口连接的哪,方便后续排错、或者查看。

    [FKT]int g0/0/1
    [FKT-GigabitEthernet0/0/1]description connection to Core-A g0/0/24
    这里的描述表示,就是该接口连接的核心A的G0/0/24号接口。

    3.4 核心层 A需要配置的VLAN以及接口

    由于案例这里只给出访客厅、高层人员、财务作为举例,所以只创建VLAN 19~21,而生产部与业务部是一样的配置,所以节省资源,就没配置了。

    [Core-A]vlan batch 19 to 21,

    说明:批量创建了VLAN 19~21,这里必须包含下面接入层所有的VLAN,因为,下面交换机都是连接到了核心A和B上面,所以需要创建所有VLAN,来总结所有的VLAN流量。

    [Core-A]interface g0/0/24
    [Core-A-GigabitEthernet0/0/24]description connection to fkt-g0/0/1
    [Core-A-GigabitEthernet0/0/24]port link-type trunk
    [Core-A-GigabitEthernet0/0/24]port trunk allow-pass vlan 1 19

    说明:该接口是连接访客厅的交换机,做了一个描述 description ,然后允许了vlan 1与19的流量通过,因为访客厅只有VLAN 1与19的流量通过。

    [Core-A]interface g0/0/23
    [Core-A-GigabitEthernet0/0/23]description connection to boss-g0/0/2
    [Core-A-GigabitEthernet0/0/23]port link-type trunk
    [Core-A-GigabitEthernet0/0/23]port trunk allow-pass vlan 1 20

    说明:该接口是连接boss的交换机,做了一个描述 description ,然后允许了vlan 1与20的流量通过,因为访客厅只有VLAN 1与20的流量通过。

    [Core-A]int g0/0/21
    [Core-A-GigabitEthernet0/0/21]port link-type trunk
    [Core-A-GigabitEthernet0/0/21]port trunk allow-pass vlan 1 21
    [Core-A-GigabitEthernet0/0/21]description connection to caiwu-g0/0/1

    说明:该接口是连接财务的交换机,做了一个描述 description ,然后允许了vlan 1与21的流量通过,因为访客厅只有VLAN 1与21的流量通过。

    特别建议:建议在重要的接口做description,这样只要一看就知道连接哪,并且标明了接口,很容易避免以后忘记接口接哪了,看下配置即可。

    3.5 核心B需要配置的VLAN以及接口

    由于案例这里只给出访客厅、高层人员、财务作为举例,所以只创建VLAN 19~21,而生产部与业务部是一样的配置,所以节省资源,就没配置了。
    [Core-B]vlan batch 19 to 21

    说明:批量创建了VLAN 19~21,这里必须包含下面接入层所有的VLAN,因为,下面交换机都是连接到了核心A和B上面,所以需要创建所有VLAN,来总结所有的VLAN流量。

    [Core-B]int g0/0/24
    [Core-B-GigabitEthernet0/0/24]description connection to FKT g0/0/2
    [Core-B-GigabitEthernet0/0/24]port link-type trunk
    [Core-B-GigabitEthernet0/0/24]port trunk allow-pass vlan 1 19

    说明:该接口是连接访客厅的交换机,做了一个描述 description ,然后允许了vlan 1与19的流量通过,因为访客厅只有VLAN 1与19的流量通过。

    [Core-B]int g0/0/23
    [Core-B-GigabitEthernet0/0/23]port link-type trunk
    [Core-B-GigabitEthernet0/0/23]port trunk allow-pass vlan 1 20
    [Core-B-GigabitEthernet0/0/23]description connection to boss g0/0/1
    说明:该接口是连接boss的交换机,做了一个描述 description ,然后允许了vlan 1与20的流量通过,因为访客厅只有VLAN 1与20的流量通过。

    [Core-B]int g0/0/22
    [Core-B-GigabitEthernet0/0/22]description connection to caiwu g0/0/2
    [Core-B-GigabitEthernet0/0/22]port link-type trunk
    [Core-B-GigabitEthernet0/0/22]port trunk allow-pass vlan 1 21

    说明:该接口是连接财务的交换机,做了一个描述 description ,然后允许了vlan 1与21的流量通过,因为访客厅只有VLAN 1与21的流量通过。

    特别建议:建议在重要的接口做description,这样只要一看就知道连接哪,并且标明了接口。
    【这里Core-A与B之间的两条链路还未配置,这是因为待会在配置聚合的时候在一起配置,那个是聚合用的】

    3.6 出口防火墙与核心交换机之间的接口划分

    分析:核心交换机与出口防火墙之间,是一个三角形的结构,在交换机上面肯定是做接口划分到VLAN,然后起VLAN接口,与防火墙进行通信。 而防火墙则有两种办法与交换机通信,一种是也通过VLAN接口进行通信,第二种则是通过三层口与三层交换机之间通信。 推选第一种比较好,这种结构比较简单,路由配置起来也明确。而第二种方法则需要配置2个VLAN,然后2个网段与防火墙进行通信。

    3.6.1 Core-A配置
    [Core-A]vlan 100
    说明:该100是用来单独连接防火墙的
    [Core-A]interface g0/0/22
    [Core-A-GigabitEthernet0/0/22]port link-type access
    [Core-A-GigabitEthernet0/0/22]port default vlan 100
    [Core-A-GigabitEthernet0/0/22]description connection to FW g0/0/8
    说明:把接口划分到100中,做了一个描述,说明连接防火墙的 g0/0/8接口

    3.6.2 Core-B配置
    [Core-B]interface g0/0/21
    [Core-B-GigabitEthernet0/0/21]port link-type access
    [Core-B-GigabitEthernet0/0/21]port default vlan 100
    [Core-B-GigabitEthernet0/0/21]description connection to FW G0/0/7
    说明:把接口划分到100中,做了一个描述,说明连接防火墙的 g0/0/7接口

    3.6.3 FW配置 
    system-view
    [USG-GW]portswitch batch GigabitEthernet 0/0/7 to 0/0/8
    说明:该命令的含义就是把三层接口切换为二层接口,默认为三层接口

    [USG-GW]vlan 100
    [USG-GW-vlan-100]port GigabitEthernet 0/0/7 to 0/0/8
    说明:创建了VLAN 100,并且把G0/0/7~8加入了VLAN 100中

    3.7 核心交换机与服务器集群交换机的配置

    3.7.1 核心交换机A与B 
    [Core-A]vlan 88
    [Core-A]int g0/0/20
    [Core-A-GigabitEthernet0/0/20]description connection to server g0/0/2
    [Core-A-GigabitEthernet0/0/20]port link-type trunk
    [Core-A-GigabitEthernet0/0/20]port trunk allow-pass vlan 1 88
    说明:这里配置Trunk,是因为为了后续方便管理服务器交换机,如果不需要管理的话,则可以直接通过Access接口即可。

    [Core-B]vlan 88
    [Core-B]int g0/0/20
    [Core-B-GigabitEthernet0/0/20]port link-type trunk
    [Core-B-GigabitEthernet0/0/20]port trunk allow-pass vlan 1 88
    说明:这里配置Trunk,是因为为了后续方便管理服务器交换机,如果不需要管理的话,则可以直接通过Access接口即可。

    3.7.2 服务器集群交换机配置
    system-view
    [Cluster Server]vlan 88

    [Cluster Server]port-group 1
    [Cluster Server-port-group-1]group-member g0/0/1 to g0/0/2
    [Cluster Server-port-group-1]port link-type trunk
    [Cluster Server-port-group-1]port trunk allow-pass vlan 1 88
    [Cluster Server-port-group-1]description connection to Core-A-B
    说明:第一个port-group是定义了连接核心交换机的接口为Trunk,并且允许1与88通过

    [Cluster Server]port-group 2
    [Cluster Server-port-group-2]group-member e0/0/1 to e0/0/2
    [Cluster Server-Ethernet0/0/2]port link-type access
    [Cluster Server-Ethernet0/0/2]port default vlan 88
    说明:该2个接口是连接服务器用的,划入了对应的VLAN 88。

    总结:至此整个VLAN的部署已经接口划分完毕,这里注意的地方就是Trunk,默认情况下只允许VLAN 1的流量通过,而其余流量是不允许的,所以需要允许需要的流量通过,如果不确定哪些VLAN的流量要通过,可以直接 permit all。如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路博客,,http://ccieh3c.com

    如果大家有任何疑问或者文中有错误跟疏忽的地方,欢迎大家留言指出,博主看到后会第一时间修改,谢谢大家的支持,更多技术文章尽在网络之路Blog(其他平台同名),版权归网络之路Blog所有,原创不易,侵权必究,觉得有帮助的,关注、转发、点赞支持下!~。

    展开全文
  • 端口加入vlan

    千次阅读 2021-01-23 17:53:13
    vlan 100#创建vlan 100 vlan 200#创建vlan 200 inter e1/0/1-8 switch mode access switch access vlan 100 inter e1/0/9-16 switch mode access switch access vlan 200
  • 首先通过CONSOLE口或Telnet连接交换机,连接成功后,进入用户视图模式<...在系统视图模式下创建三个VLAN,一个VLAN 10,一个VLAN 20,一个VLAN 30 [H3C]vlan 10[H3C-vlan10]quit[H3C]vlan 20[H3C-vlan20]quit[H3C]vl...
  • root@dnd-26-plz# wildcard range set interfaces ge-0/0/[11-13,16,23,45] unit 0 family ethernet-switching vlan members v500 VLAN output after applying the configuration: {master:0}[edit] ...
  • 第一种方法: [Huawei]port-group 1 //创建一组 [Huawei-port-group-1]group-member GigabitEthernet 0/0/1 to GigabitEthernet 0/...[Huawei-port-group-1]port default vlan 10 //统一划分到vlan 10 第二种方...
  • Vlan技术把物理上LAN在逻辑上划分为多个广播域。这样可以使主机在Vlan内可以直接通信,在VLAN间不能通信。Access接口是交换机上连接主机的接口。 拓扑图: 步骤: 1.基本配置: 如拓扑图所示,配置好各个物理设备和...
  • 华为交换机接口单独加入vlan太麻烦,思科有批量加入vlan的方法,华为的如下: 方法一: [~XY-H-E6810-S21-NET1397]int range 10GE1/0/1 to 10GE1/0/20 [~XY-H-E6810-S21-NET1397-port-group]port link-type access ...
  • //将接口以untagged方式加入vlan10和vlan40,允许vlan10和vlan40成员脱标签  [SW1-port-group-1]quit [SW1]interface e0/0/3 [SW1-Ethernet0/0/3]port hybrid pvid vlan 20 [SW1-Ethernet0/0/3]port hybrid ...
  • 三种vlan接口类型实验

    2021-01-16 00:38:58
    题目: 分析: 三种接口类型: access:只能允许一个vlan进或出;修改该接口的默认vlan;及修改了允许列表和PVID; trunk :可以允许多个vlan进或出;...三、各个交换机的接口分别划入VLAN: 1、交换机SW1
  • VLANIF接口配置示例

    千次阅读 2021-01-13 18:59:47
    一.实验环境 ensp操作软件 两台s3700交换机,作为二层设备 一台s5700交换机,作为三层交换机 四台PC,作为终端用户 二....三....同时建立多个VLAN ...配置S1的端口类型,并划入相应的...g0/0/2端口划入Vlan20中后, 用displa.
  • 交换机配置VLAN及Access接口

    千次阅读 2019-12-05 15:46:35
    VLAN(Virtual Local Area Network,虚拟局域网),VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,...
  • 华为---VLAN实验

    2021-11-11 11:32:18
    局域网划分为两个vlan ; 相同vlan编号之间可以互通; 1.sw1中创建vlan: <Huawei> <Huawei>sys Enter system view, return user view with Ctrl+Z. [Huawei]sys SW1 //修改设备名称 [SW1]vlan 2 //创建...
  • VLAN

    2019-11-10 17:09:33
    VLAN:虚拟局域网,隔离广播域(将原本的一个广播域逻辑的切分成多个广播域) 本质—通过在交换机上创建不同的VLAN,并且将不通的接口 划入相应的VLAN,让交换机在洪泛时按照不同的VLAN发送数据,实现广播域的隔离 ...
  • VLAN基础配置及Access接口

    千次阅读 2018-04-19 18:39:30
    公司内网是一大的局域网,二层交换机S1放置在一楼,在一楼办公的部门有IT部和人事部;二层交换机S2放置在二楼,在二楼办公的部门有市场部和研发部。公司的策略:不同部门之间不能相互通信,同一部门内的主机才能...
  • vlan试验2021.1.14

    2021-01-14 21:08:17
    1,将pc1 pc3划分入vlan2, 2,将pc2划分为vlan2 3,将pc4,pc5划分为vlan4 4,将pc6划分为vlan5 三,配置交换机vlan [Huawei-Ethernet0/0/1]port link-type access 先将该接口定义为接入模式 * 四,创建trunk干道 ...
  • 华为路由器子接口vlan

    万次阅读 2019-04-22 23:06:55
    路由器和交换机协同工作,之后将原来的一个广播域逻辑的切分为多个; 配置思路: 1、交换机上创建vlan 2、交换机上各个接口划分到对应的vlan中 3、TRUNK干道----中继干道 SW-SW SW-ROUTER 4、Vlan间路由-----...
  • eNSP建立VLAN

    千次阅读 2019-09-28 20:39:18
    eNSP建立VLAN SW1的配置如下: [SW1] vlan batch 10 20 [SW1] interface gigabitEthernet 0/0/1 [SW1-GigabitEthernet0/0/1] port link-type access [SW1-GigabitEthernet0/0/1] port default vlan 10 [SW1] ...
  • vlan快速入门

    千次阅读 2020-03-27 10:27:23
    1.什么是VLANVLAN是一种在交换机上划分逻辑网段的二层技术。 2.为什么要通过交换机划分网段? ...第一因为交换机的端口密度比路由器高,并且价格比路由器低, ...access:是接入接口 trunk:中继接...
  • VLAN:虚拟局域网

    2019-11-19 19:09:51
    隔离广播域(将原本的一个广播域逻辑的切分成多个广播域)—通过在交换机上创建不同的VLAN,并且将不通的接口 划入相应的VLAN,让交换机在洪泛时按照不同的VLAN发送数据,实现广播域的隔离 VLAN的过程 1、创建VLAN ...
  • 在以太网上建立多个 VLAN,通过一个三层交换机的第三层路由交换技术,实现多个 VLAN 之间的通信。 二.实验要点: 1.在三层交换机与二层交换机间配置 trunk 实现多个 VLAN 数据的通过。 2.启用三层交换机上的...
  • vlan基础配置及access接口原理概述一、实验目的及编址二...为了避免冲突域,我们使用虚拟局域网即vlan把一个物理的lan划分成多个广播域,实现逻辑隔离,将一个报文泛洪限制在一个vlan域内,。 可用vlan 1-4094 保留 vl
  • 在eNSP上划分VLAN

    万次阅读 多人点赞 2019-07-29 20:13:11
    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一网段中一样,由此得名虚拟局域网。VLAN是一...
  • 交换机学习之划VLAN

    2021-03-20 15:06:36
    Trunk类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文, 一般用于交换机与交换机相关的接口。 Hybrid类型端口:可以允许多个VLAN通过,可以接收和发送多个VLAN 报文, 可以用于交换机的间连接也可以...
  • 基于多种方式的VLAN划分实验文档 实验拓扑: IP地址规划: ... 接口 VLAN IP地址 子网掩码 sw1 GE0/0/1 10 ...
  • VLAN(Virtual Local Area Network,虚拟局域网)是将一个物理以太网结构在逻辑上划分成多个广播域的通信技术。相同VLAN内的主机间可以直接通信,而不同VLAN间不能直接通信,从而将广播报文限制在一个VLAN内。 二层...
  • 华为交换机批量加入 Vlan 方法

    万次阅读 2018-06-21 13:30:00
    华为交换机单独加入vlan太麻烦,思科有批量加入vlan的方法,华为也有。要求 1~6口划分到vlan2,6~12口划分到vlan3,13~18口划分到...创建vlan 2~vlan4,4个vlan也可以使用命令 batch 2 to 52端口port1~port6划分到vlan2...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,426
精华内容 570
关键字:

多个接口划入vlan