精华内容
下载资源
问答
  • 实训十四 路由器多区域 OSPF 配置 定义:OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法的内部网关协议(IGP),在单一自治系统(AS)内部工作。 概述:开放式最短路径...

    路由器多区域 OSPF 配置

    实训三十四 路由器多区域 OSPF 配置

    定义:OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法内部网关协议IGP),在单一自治系统(AS)内部工作。

    概述:开放式最短路径优先(Open Shortest Path First,OSPF)是广泛使用的一种动态路由协议,它属于链路状态路由协议,具有路由变化收敛速度快、无路由环路、支持变长子网掩码(VLSM)和汇总、层次区域划分等优点。在网络中使用OSPF协议后,大部分路由将由OSPF协议自行计算和生成,无须网络管理员人工配置,当网络拓扑发生变化时,协议可以自动计算、更正路由,极大地方便了网络管理。但如果使用时不结合具体网络应用环境,不做好细致的规划,OSPF协议的使用效果会大打折扣,甚至引发故障。  

    OSPF协议是一种链路状态协议。每个路由器负责发现、维护与邻居的关系,并将已知的邻居列表和链路费用LSU(Link State Update)报文描述,通过可靠的泛洪与自治系统AS(Autonomous System)内的其他路由器周期性交互,学习到整个自治系统的网络拓扑结构;并通过自治系统边界的路由器注入其他AS的路由信息,从而得到整个Internet的路由信息。每隔一个特定时间或当链路状态发生变化时,重新生成LSA,路由器通过泛洪机制将新LSA通告出去,以便实现路由的实时更新。

    优点

    (1)OSPF适合在大范围的网络:OSPF协议当中对于路由的跳数,它是没有限制的,所以OSPF协议能用在许多场合,同时也支持更加广泛的网络规模。只要是在组播的网络中,OSPF协议能够支持数十台路由器一起运作。

    (2)组播触发式更新:OSPF协议在收敛完成后,会以触发方式发送拓扑变化的信息给其他路由器,这样就可以减少网络宽带的利用率;同时,可以减小干扰,特别是在使用组播网络结构,对外发出信息时,它对其他设备不构成其他影响

    (3)收敛速度快:如果网络结构出现改变,OSPF协议的系统会以最快的速度发出新的报文,从而使新的拓扑情况很快扩散到整个网络;而且,OSPF采用周期较短的HELLO报文来维护邻居状态。

    (4)以开销作为度量值:OSPF协议在设计时,就考虑到了链路带宽对路由度量值的影响。OSPF协议是以开销值作为标准,而链路开销和链路带宽,正好形成了反比的关系,带宽越是高,开销就会越小,这样一来,OSPF选路主要基于带宽因素。

    (5)OSPF协议的设计是为了避免路由环路:在使用最短路径的算法下,收到路由中的链路状态,然后生成路径,这样不会产生环路。

    (6)应用广泛:广泛的应用在互联网上,其他会有大量的应用实例。证明这是使用最广泛的IPG之一

    缺点

    (1)OSPF协议的配置对于技术水平要求很高,配置比较复杂的。因为网络会根据具体的参数,给整个网络划分区域或者标注某个属性,所以各种情况都会非常复杂,这就要求网络分析员对OSPF协议的配置要相当了解,不但要求具有普通的网络知识技术,还要有更深层的技术理解,只有具备这样的人员,才能完成OSPF协议的配置和日常维护。

    (2)路由其自身的负载分担能力是很低的。OSPF路由协议会根据几个主要的因素,生成优先级不同的接口。然而在同一个区域内,路由协议只会通过优先级最高的那个接口。只要是接口优先级低于最高优先级,那么路由就不会通过。在这个基础上,不同等级的路由,无法相互承担负载,只能独自运行。

    OSPF的数据包:
    Hello包
    DBD–数据库描述包
    LSR–链路状态请求
    LSU–链路状态更新 携带各种LSA
    LSack–链路状态确认

     

    一、实验目的

    1.掌握多区域 OSPF 的配置

    2.理解 OSPF 区域的意义

    二、应用环境 

    在大规模网络中,我们通常划分区域减少资源消耗,并将拓扑的变化本地化。 

    三、实验设备

    1.路由器三台

    2.网线 三条

    3.pc二台

    四、 

    实验拓扑

     

    五、实验要求

    路由器

    接口

    IP地址

    RA

    G0/3

    192.168.1.1/24

    G0/4

    192.168.0.1/24

    RB

    G0/3

    192.168.1.2/24

    G0/4

    192.168.2.1/24

    RC

    G0/3

    192.168.3.1/24

    G0/4

    192.168.2.2/24

    六、实验步骤

    第一步:参照上表配置各接口地址,并测试连通性

    路由器 A 的配置

    face g0/4 RA#config !进入全局模式

    RA_config#interface g0/3 !进入接口模式

    RA_config_g0/3#ip add 192.168.1.1 255.255.255.0 !设置 IP 地址

    RA_config_g0/3#no shutdown  开启接口

    RA_config_g0/3#exit !退出接口模式

    RA_config#

    RA_config#inter G0/4

    RA_config_g0/4#ip add 192.168.0.1 255.255.255.0

    RA_config_g0/4#no shutdown

    RA_config_g0/4#exit

    路由器 B C 的配置步骤同路由器 A 一样。

    第二步:路由器 A 的配置

    RA#confing

    RA_config#router ospf 1 !启动 OSPF 进程,进程号为 1

    RA_config_ospf_1#network 192.168.1.0 255.255.255.0 area 1 !宣称 IP 地址到 1 区域

    RA_config_ospf_1#network 192.168.0.0 255.255.255.0 area 1 !注意要写掩码和区域号

    RA_config_ospf_100#^Z !按 ctrl+z,直接进入特权模式

    第三步:路由器 B 的配置 

    Router-B#confing

    RB_config#router ospf 1

    RB_config_ospf_1#network 192.168.1.0 255.255.255.0 area 1 !注意区域的划分在接口上

    RB_config_ospf_1#network 192.168.2.0 255.255.255.0 area 0

    Router-B_config_ospf_100#^Z

    第四步:路由器 C 的配置

    Router-C#confing

    RC_config#router ospf 1

    RC_config_ospf_1#network 192.168.2.0 255.255.255.0 area 0

    RC_config_ospf_1#network 192.168.3.0 255.255.255.0 area 0

    Router-C_config_ospf_100#^Z

    第五步:查看路由表 

    RA_config#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    C 192.168.0.0/24 is directly connected, GigaEthernet0/4

    C 192.168.1.0/24 is directly connected, GigaEthernet0/3

    O IA 192.168.2.0/24 [110,2] via 192.168.1.2(on GigaEthernet0/3)

    O IA 192.168.3.0/24 [110,3] via 192.168.1.2(on GigaEthernet0/3) !区域间的路由

    RB_config#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2VRF ID: 0

    O 192.168.0.0/24 [110,2] via 192.168.1.1(on GigaEthernet0/3)

    C 192.168.1.0/24 is directly connected, GigaEthernet0/3

    C 192.168.2.0/24 is directly connected, GigaEthernet0/4

    O 192.168.3.0/24 [110,2] via 192.168.2.2(on GigaEthernet0/4)

    !对 ABR 来说是区域内的路由

    RC_config#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    O IA 192.168.0.0/24 [110,3] via 192.168.2.1(on GigaEthernet0/4)

    O IA 192.168.1.0/24 [110,2] via 192.168.2.1(on GigaEthernet0/4) !区域间的路由

    C 192.168.2.0/24 is directly connected, GigaEthernet0/4

    C 192.168.3.0/24 is directly connected, GigaEthernet0/3

    七、注意事项和排错

    1.区域的划分在接口上进行

    2.必须有 area 0 存在

    3. 宣称 IP 地址时要写掩码 

    八、配置序列

    路由器 A 的序列

    RA_config#show run

    Building configuration...

    Current configuration:

    !

    !version 1.3.3H

    service timestamps log date

    service timestamps debug date

    no service password-encryption

    !

    hostname RA

    !

    gbsc group default

    !

    interface FastEthernet0/0

    no ip address

    no ip directed-broadcast!

    interface GigaEthernet0/3

    ip address 192.168.1.1 255.255.255.0 !查看 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/4

    ip address 192.168.0.1 255.255.255.0 !查看 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/5

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/6

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/1

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/2

    no ip address

    no ip directed-broadcast

    !

    interface Async0/0

    no ip address

    no ip directed-broadcast

    !

    router ospf 1 !查看 ospf 进程

    network 192.168.1.0 255.255.255.0 area 1

    network 192.168.0.0 255.255.255.0 area 1 !查看 ospf 宣称的网段到哪个区域

    !

    路由器 B 的序列

    RB_config#show run

    Building configuration...

    Current configuration:

    !

    !version 1.3.3H

    service timestamps log date

    service timestamps debug date

    no service password-encryption

    !

    hostname RB

    !

    gbsc group default!

    interface FastEthernet0/0

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/3

    ip address 192.168.1.2 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/4

    ip address 192.168.2.1 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/5

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/6

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/1

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/2

    no ip address

    no ip directed-broadcast

    !

    interface Async0/0

    no ip address

    no ip directed-broadcast

    !

    router ospf 1 !查看 ospf 进程

    network 192.168.1.0 255.255.255.0 area 1

    network 192.168.2.0 255.255.255.0 area 0 !查看 ospf 宣称的网段到哪个区域

    !

    路由器 C 的序列

    RC_config#show run

    Building configuration...

    Current configuration:

    !

    !version 1.3.3H

    service timestamps log date

    service timestamps debug date

    no service password-encryption!

    hostname RC

    !

    gbsc group default

    !

    interface FastEthernet0/0

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/3

    ip address 192.168.3.1 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/4

    ip address 192.168.2.2 255.255.255.0 !查看接口 IP 地址

    no ip directed-broadcast

    !

    interface GigaEthernet0/5

    no ip address

    no ip directed-broadcast

    !

    interface GigaEthernet0/6

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/1

    no ip address

    no ip directed-broadcast

    !

    interface Serial0/2

    no ip address

    no ip directed-broadcast

    !

    interface Async0/0

    no ip address

    no ip directed-broadcast

    !

    router ospf 1 !查看 ospf 进程

    network 192.168.2.0 255.255.255.0 area 0

    network 192.168.3.0 255.255.255.0 area 0 !查看 ospf 宣称的网段到哪个区域

    !

    九、共同思考

    1.为什么必须有 area 0 存在?

    2.在路由器 A 和 C 宣告网段的时候有其他的方法吗?

    十、课后练习

    请将地址改为 10.0.0.0/25 重复以上实验

    十一、相关命令详解

    router ospf process-id

    network address mask area area-id

    此命令激活 OSPF 路由协议,并且进入路由器配置模式,然后配置 OSPF 运行的接口以及接口的区

    ID。 可以用命令 no router ospf process-id 去掉 ospf 进程

    展开全文
  • 路由器区域 OSPF 基本配置

    千次阅读 2021-10-08 03:50:18
    实训 路由器区域 OSPF 基本配置 实验目的 1.掌握单区域 OSPF 的配置 2.理解链路状态路由协议的工作过程 3.掌握实验环境中虚拟接口的配置 应用环境 1.在大规模网络中,OSPF 作为链路状态路由协议的代表...

    路由器单区域 OSPF 基本配置

    实训三十三 路由器单区域 OSPF 基本配置

    • 实验目的

    1.掌握单区域 OSPF 的配置

    2.理解链路状态路由协议的工作过程

    3.掌握实验环境中虚拟接口的配置

    • 应用环境

    1.在大规模网络中,OSPF 作为链路状态路由协议的代表应用非常广泛

    2.具有无自环,收敛快的特点

    • 实验设备 1.DCR-2655  两台
    1. 网线    一条

     

     

     

    六.实验步骤

    第一步:路由器环回接口的配置

    路由器 A:

    Router-A>enable                              !进入特权模式  Router-A#config                              !进入全局模式

    Router-A_config#interface g0/3                  !进入接口模式

    Router-A_config_g0/3#ip address 192.168.1.1 255.255.255.0    !配置 IP 地址 Router-A_config_g0/3#no shutdown              !开启端口 Router-A_config_g0/3#exit                      !退出接口模式 Router-A_config#interface loopback0               !进入环回接口

    Router-A_config_l0#ip address 10.10.10.1 255.255.255.0    !配置 IP 地址

    Router -A_config_l0#no shutdown                !开启环回接口路

    路由器 B:

    Router-B#config

    Router-B_config#int g0/3

    Router-B_config_g0/3#ip address 192.168.1.2 255.255.255.0

    Router-B_config_g0/3#no shutdown

    Router-B_config_g0/3#exit

    Router-B_config#interface loopback0

    Router-B_config_l0#ip address 10.10.11.1 255.255.255.0

    Router -B_config_l0#no shutdown   

    第二步:验证接口配置

    Router-B#show interface loopback0   

    Loopback0 is up, line protocol is up   

    Hardware is Loopback   MTU 1514 bytes, BW 8000000 kbit, DLY 500 usec   

    Interface address is 10.10.11.1/24                !查看环回 IP 地址   

    Encapsulation LOOPBACK

    第三步:路由器的 OSPF 配置

    路由器 A 的配置:

    Router-A_config#router ospf 2     !启动 OSPF 进程,进程号为 2 Router-A_config_ospf_2#network 10.10.10.0 255.255.255.0 area 0   !宣称 IP 地址到 0 区域 Router-A_config_ospf_2#network 192.168.1.0 255.255.255.0 area 0  !注意要写掩码和区域号 Router-A_config_ospf_2#^Z         !按 ctrl+z,直接进入特权模式 路由器 B配置: Router-B_config#router ospf 1

    Router-B_config_ospf_1#network 10.10.11.0 255.255.255.0 area 0 Router-B_config_ospf_1#network 192.168.1.0 255.255.255.0 area 0

    第四步:查看路由表

    路由器 A:

    Router-A#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected        

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area        

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2        

    OE1 - OSPF external type 1, OE2 - OSPF external type 2       

     DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    C      10.10.10.0/24        is directly connected, Loopback0

    O      10.10.11.1/32        [110,2] via192.168.1.2(on GigaEthernet0/3)                                           

    !注意到环回接口产生的是主机路由

    C      192.168.1.0/24       is directly connected, GigaEthernet0/3

    路由器 B:

    Router-B#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected        

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area        

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2        

    OE1 - OSPF external type 1, OE2 - OSPF external type 2        

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    O      10.10.10.1/32   [110,2] via 192.168.1.1(on GigaEthernet0/3)  !注意管理距离为 110

    C      10.10.11.0/24        is directly connected, Loopback0

    C      192.168.1.0/24       is directly connected, GigaEthernet0/3

    第五步:其他验证命令

    Router-B#show ip ospf 1           !显示该 OSPF 进程的信息

    OSPF process: 1, Router ID: 10.10.11.1

    Distance: intra-area 110,  inter-area 110,  external 150  

    SPF schedule delay 5 secs, Hold time between two SPFs 10 secs

    SPFTV:0(0), TOs:6, SCHDs:5

     All Rtrs support Demand-Circuit.

    Number of areas is 1  AREA: 0   Number of interface in this area is 2(UP: 2)   

    Area authentication type:  None    All Rtrs in this area support Demand-Circuit.

    Router-A#show ip ospf interface            !显示 OSPF 接口状态和类型  

    GigaEthernet0/3 is up, line protocol is up   

    Internet Address: 192.168.1.1/24          

    Interface index: 5   

    Nettype: Broadcast                            

    OSPF process is 2,  AREA: 0, Router ID: 10.10.10.1   

    Cost: 1, Transmit Delay is 1 sec, Priority 1   

    Hello interval is 10, Dead timer is 40, Retransmit is 5   

    OSPF INTF State is IDr   

    Designated Router ID: 10.10.10.1, Interface address 192.168.1.1   

    Backup Designated Router ID: 10.10.11.1, Interface address 192.168.1.2   

    Neighbor Count is 1, Adjacent neighbor count is 1     

    Adjacent with neighbor 10.10.11.1 (Backup Designated Router)

    Loopback0 is up, line protocol is up   

    Internet Address: 10.10.10.1/24           

    Interface index: 9   Nettype: Broadcast                 !环回接口的网络类型默认为广播   OSPF process is 2,  

    AREA: 0, Router ID: 10.10.10.1   

    Cost: 1, Transmit Delay is 1 sec, Priority 1   

    Hello interval is 10, Dead timer is 40, Retransmit is 5   

    OSPF INTF State is ILOOPBACK   

    Neighbor Count is 0, Adjacent neighbor count is 0

    Router-A#show ip ospf neighbor               !显示 OSPF 邻居 ----------------------------------------------------------------------------------------------------------------------                                 OSPF process: 2

                                     AREA: 0 Neighbor ID     Pri   State            DeadTime   Neighbor Addr   Interface 10.10.11.1      1     FULL/BDR         39         192.168.1.2     GigaEthernet0/3 ----------------------------------------------------------------------------------------------------------------------

    第六步:修改环回接口的网络类型

    Router-A#config

    Router-A_config#interface loopback 0

    Router-A_config_l0#ip ospf network point-to-point !将类型改为点到点

    第七步:查看接口状态和路由器 A 的路由表

    Router-A_config#show ip ospf

    interface GigaEthernet0/3 is up, line protocol is up   

    Internet Address: 192.168.1.1/24          

    Interface index: 5   

    Nettype: Broadcast    

    OSPF process is 2,  

    AREA: 0, Router ID: 10.10.10.1   

    Cost: 1, Transmit Delay is 1 sec, Priority 1   

    Hello interval is 10, Dead timer is 40, Retransmit is 5   

    OSPF INTF State is IDr   

    Designated Router ID: 10.10.10.1, Interface address 192.168.1.1   

    Backup Designated Router ID: 10.10.11.1, Interface address 192.168.1.2   

    Neighbor Count is 1, Adjacent neighbor count is 1     

    Adjacent with neighbor 10.10.11.1 (Backup Designated Router)

    Loopback0 is up, line protocol is up   

    Internet Address: 10.10.10.1/24           

    Interface index: 9   Nettype: Point-to-Point                  !环回接口的网络类型为 PPP   OSPF process is 2,  AREA: 0, Router ID: 10.10.10.1   

    Cost: 1, Transmit Delay is 1 sec, Priority 1   

    Hello interval is 10, Dead timer is 40, Retransmit is 5   

    OSPF INTF State is ILOOPBACK   

    Neighbor Count is 0, Adjacent neighbor count is 0

    Router-B#show ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected        

    D - BEIGRP, DEX - external BEIGRP, O - OSPF, OIA - OSPF inter area        

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2        

    DHCP - DHCP type, L1 - IS-IS level-1, L2 - IS-IS level-2

    VRF ID: 0

    O      10.10.10.1/32        [110,2] via 192.168.1.1(on GigaEthernet0/3)

    C      10.10.11.0/24        is directly connected, Loopback0

    C      192.168.1.0/24       is directly connected, GigaEthernet0/3

    展开全文
  • OSPF区域路由器角色详解

    千次阅读 2018-10-09 18:42:28
    首先我们需要知道为什么OSPF为什么需要区域,这技术是为了解决... 使网络具有层次化,每个区域路由器仅仅只需和同区域路由器同步链路状态数据库就可以了,而没必要去和整个OSPF路由域的所有路由器同步数据库...

    首先我们需要知道为什么OSPF为什么需要区域,这个技术是为了解决什么问题而存在的

    1. 超大型的网络如果扁平化,会使路由器负载过高,甚至超过路由器极限性能,虽然他的周期性泛洪与各种机制确实比RIP要优秀很多,但是大量的链路状态数据还是会给路由器带来无法承受的负担
    2. 使网络具有层次化,每个区域的路由器仅仅只需和同区域的路由器同步链路状态数据库就可以了,而没必要去和整个OSPF路由域的所有路由器同步数据库,这样一来,每台路由器只需要存放计算他所在的区域的所有链路状态,以此便可以大大的减少链路状态数据给路由器带来的负担
    3. 链路状态数据库的减少也就意味着更少的LSA,也就降低了CPU的消耗
    4. 由于路由器只需要维护自己所在的区域的数据库,因此LSA的泛洪范围也减小了
    5. 可以更容易的完成路由汇总,一旦拓扑发生变化也只会被限制在本区域内,而不会波及到整个网络

    OSPF区域的概念

           区域的编号是通过32位的ID表示的(area ID),就像IP那样,可以使用点分十进制的方式表示或者直接用十进制数字来表示,比如说area1,可以表示为区域1或0.0.0.16,无论使用哪一种方式,表达的结果还是相同的,依照个人喜好来打,不过我还是喜欢十进制的表示方式,因为方便

    OSPF区域定义了三种信息类型:

    1. 域内信息———指单个域内路由器之间交换的数据包
    2. 域间信息———指不同域的路由器之间互相交换的数据包
    3. 外部信息———指OSPF域中路由器
    展开全文
  • router)# R2的邻居表、数据表、路由器 R2#show ip ospf neighbor #邻居表 Neighbor ID Pri State Dead Time Address Interface 3.3.3.3 1 FULL/DR 00:00:37 20.0.0.2 GigabitEthernet0/1 1.1.1.1 1 FULL/BDR 00:00:...

    实验拓扑

    在这里插入图片描述

    R1配置

    
    R1(config)#no ip domain lookup 
    R1(config)#interface GigabitEthernet0/1
    R1(config-if)#ip address 192.168.10.254 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    
    R1(config)#interface GigabitEthernet0/0
    R1(config-if)#ip address 10.0.0.1 255.255.255.0
    R1(config-if)#no shutdown
    
    
    R1(config)#router ospf 100
    R1(config-router)#network 192.168.10.0 0.0.0.255 area 1
    

    R2配置

    R2(config)#interface GigabitEthernet0/0
    R2(config-if)#ip address 10.0.0.2 255.255.255.0
    R2(config-if)#
    R2(config-if)#exit
    R2(config)#interface GigabitEthernet0/0
    R2(config-if)#
    R2(config-if)#exit
    R2(config)#interface GigabitEthernet0/1
    R2(config-if)#ip address 20.0.0.1 255.255.255.0
    R2(config)#rout
    R2(config)#router os
    R2(config)#router ospf 100
    R2(config-router)#network 20.0.0.0 0.0.0.255 area 0
    R2(config-router)#network 10.0.0.0 0.0.0.255 area 0
    

    R3配置

    
    R3(config)#interface GigabitEthernet0/0
    R3(config-if)#ip address 20.0.0.2 255.255.255.0
    R3(config-if)#exit
    R3(config)#interface GigabitEthernet0/1
    R3(config-if)#ip address 192.168.20.254 255.255.255.0
    
    R3(config)#route
    R3(config)#router os
    R3(config)#router ospf 100
    
    R3(config-router)#network 192.168.20.0 0.0.0.255 area 2
    R3(config-router)#network 20.0.0.0 0.0.0.255 area 0
    R3(config-router)#
    

    R2的邻居表、数据表、路由器

    R2#show ip ospf neighbor    #邻居表
    
    
    Neighbor ID     Pri   State           Dead Time   Address         Interface
    3.3.3.3           1   FULL/DR         00:00:37    20.0.0.2        GigabitEthernet0/1
    1.1.1.1           1   FULL/BDR        00:00:34    10.0.0.1        GigabitEthernet0/0
    
    
    R2#show ip ospf database    #数据表
                OSPF Router with ID (2.2.2.2) (Process ID 100)
    
                    Router Link States (Area 0)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    2.2.2.2         2.2.2.2         745         0x80000025 0x0012ba 2
    3.3.3.3         3.3.3.3         1027        0x80000004 0x009d6f 1
    1.1.1.1         1.1.1.1         723         0x80000024 0x00ec10 2
    
                    Net Link States (Area 0)
    Link ID         ADV Router      Age         Seq#       Checksum
    10.0.0.2        2.2.2.2         745         0x80000003 0x005b6f
    20.0.0.2        3.3.3.3         1027        0x80000003 0x00149b
    
                    Summary Net Link States (Area 0)
    Link ID         ADV Router      Age         Seq#       Checksum
    3.3.3.3         3.3.3.3         1535        0x80000005 0x00a69b
    192.168.20.0    3.3.3.3         1535        0x80000006 0x00a02f
    192.168.10.0    1.1.1.1         713         0x80000003 0x005193
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    2.2.2.2         2.2.2.2         319         0x80000025 0x00bf70 0
    
                    Summary Net Link States (Area 1)
    Link ID         ADV Router      Age         Seq#       Checksum
    20.0.0.0        2.2.2.2         1032        0x8000000e 0x0038fc
    10.0.0.0        2.2.2.2         1022        0x8000000f 0x00b885
    3.3.3.3         2.2.2.2         1022        0x80000010 0x00b881
    
    R2#
    R2#
    R2#
    
    R2#show ip route      #路由器
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is not set
    
         1.0.0.0/32 is subnetted, 1 subnets
    O       1.1.1.1/32 [110/2] via 10.0.0.1, 01:17:10, GigabitEthernet0/0
         2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       2.2.2.0/24 is directly connected, Loopback0
    L       2.2.2.2/32 is directly connected, Loopback0
         3.0.0.0/32 is subnetted, 1 subnets
    O IA    3.3.3.3/32 [110/2] via 20.0.0.2, 01:21:53, GigabitEthernet0/1
         10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       10.0.0.0/24 is directly connected, GigabitEthernet0/0
    L       10.0.0.2/32 is directly connected, GigabitEthernet0/0
         20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C       20.0.0.0/24 is directly connected, GigabitEthernet0/1
    L       20.0.0.1/32 is directly connected, GigabitEthernet0/1
    O IA 192.168.10.0/24 [110/2] via 10.0.0.1, 01:16:39, GigabitEthernet0/0
    O IA 192.168.20.0/24 [110/2] via 20.0.0.2, 01:21:53, GigabitEthernet0/1
    
    展开全文
  • 随着网络规模日益扩大,当一大型网络中的路由器都运行OSPF 路由协议时,  路由器数量的增多会导致LSDB 非常庞大,占用大量的存储空间,并使得运行SPF 算法的复杂度增加,导致CPU 负担很重。
  • ospf概念复习 area 0 骨干区域,其他area 1、2都为普通区域/常规区域。普通区域/常规区域必须和骨干区域直接相连。 AR1 先按照拓扑图配好IP <Huawei>sys Enter system view, return user view with Ctrl+Z. ...
  • 一、OSPF的基本概念和工作过程1、OSPF路由协议概述1.1、自治系统(AS)1.2、内部网关协议(IGP)1.3、外部网关协议(IGP)1.4、OSPF是链路...OSPF基本概念3.1、OPSF区域3.2、Router ID3.3、Router ID选取规则3.4、DR 和...
  • OSPF多区域

    2021-10-27 19:03:07
    生成OSPF多区域的原因 改善网络的可扩展性 ...OSPF区域路由器OSPF区域或另一自治系统内的路由器之间交换数据包构成的通信量 OSPF路由器类型 内部路由器:只属于一个区域路由器,只保存本区域内的链...
  • 在企业的大型网络中,因为设备众多,静态路由...多区域OSPF配置现在需要通过运行多区域OSPF,让左边的华为设备的环回口上的100.64.0.1能与右边的华为设备上的环回口的100.65.0.1进行通信,我们将华为9306两接口...
  • 通过配置ospf路由协议,实现多区域之间主机的通信。 实验环境 GNS3,Windows10操作系统,SecureCRT8.0 四 实验过程 1.对路由器R1,R2,R3,R4进行接口ip配置: R1: conf t int f0/0 ip add 192.168.2.1 255.255....
  • ospf路由器配置.pkt

    2020-12-10 11:40:24
    采用ospf配置路由器,和三层交换机。
  • OSPF特殊区域配置-ZTE中兴路由器

    千次阅读 2019-05-29 09:38:49
    该类路由器的所有接口都属于同一个OSPF区域。 (2)区域边界路由器ABR(Area Border Routers): 该类路由器可以同时属于两以上的区域,但其中一必须是骨干区域。 ABR用来连接骨干区域和非骨干区域,可以...
  • 多区域OSPF就是将一OSPF网络划分成不同的两区域,一是骨干区域,一是非骨干区域,骨干区域只有area0,而非骨干区域有很除了area0其它的区域都属与非骨干。在OSPF网络中,非骨干区域必须要连着骨干区域,...
  • 划分多区域后,每个OSPF区域中的容量所支持的路由器数量范围是30~200。但是在一个区域内实际加入的路由器数量要小于单个区域所能容纳路由器的最大数量,这是因为还有更重要的因素影响着这数量,如一个区域内链路的...
  • network 192.168.5.0 0.0.0.255 pc1 ping pc3 pc1 ping pc2 pc2 ping pc3 实验:拓扑图如下 提前配置好主机IP地址以及端口IP地址 AR1配置 [AR1]ospf 1 router-id 1.1.1.1 [AR1-ospf-1]area 10 [AR1-ospf-1-area-...
  • 路由实验5多区域OSPF

    2019-12-20 15:47:47
    实验5:多区域OSPF配置实验 1 实验相关知识 (1)每区域都有自己独立的链路状态数据库,SPF路由计算独立进行。 (2) LSA洪泛和链路状态数据库同步只在区域内进行。(3) OSPF骨干区域Area0,必须是连续的。 (4)其它...
  • ospf多区域配置(思科和中兴)

    千次阅读 2019-10-13 19:39:30
    *中兴: 一、实验目的 掌握了OPSF动态路由协议的工作原理,以及OSPF区域划分的作用和原理,...如图1-1所示,在路由器R1和路由器R2上运行OPSF,并将网络划分为三个区域,请完成OSPF 多区域的基本配置,实现是三个区域...
  • 该实验中有3台路由器,组成2个OSPF区域; R1、R2组成Area 0,R2、R3组成Area 1; 各接口的ip地址如上图所示 实验目的: 在三台路由器上运行OSPF协议,使R1、R3可以相互ping通; 配置: 配置各个路由器的ip...
  • 多区域OSPF(理论详解)

    千次阅读 2020-11-05 15:17:31
    文章目录前言一、OSPF多区域1.优点2.OSPF种通信量3.OSPF路由器类型4.区域类型4.区域类型 前言 在OSPF区域中,每台路由器都要收集其他所有路由器的链路状态信息,随着网络规模的不断扩大,信息量也会不断...
  • ospf多区域的原理和配置实例

    千次阅读 2019-10-26 16:03:24
    (1)、防止环路(ospf区域无环路的,多区域是会通过spf算法防止环路) (2)、隔离LSA泛洪量(减少由于网络不稳定而造成的所有路由器泛洪LSA形成网络拥塞堵塞) OSPF区域类型 1) 标准区域:能接收...
  • eNSP模拟器用OSPF协议配置路由器互通

    千次阅读 2020-12-27 14:53:34
    三个路由器的端口IP: 敲完以后用dis th命令看一下是否已经成功配置 配置R2的loopback 0地址 2 配置OSPF网络宣告 R2有Loopback地址,所以router-id为Loopback地址 然后进行网络宣告,R2向其他路由器...
  • 网络中多区域OSPF路由协议配置

    千次阅读 2018-05-03 16:05:51
    在众多的路由协议中,ospf有好多优点,比如它适应各种规模的网络(最多支持几千台路由器)、无自环、支持区域划分、可以路由分级等。...2、每个自治系统又可划分为不同的区域,如果一个路由器端口被分配到区域...
  • OSPF多区域原理和配置

    2021-03-24 14:25:05
    生成OSPF多区域的原因2.OSPF种通信量①.域内通信量②.域间通信量③.外部通信量3.OSPF路由器类型4.OSPF区域类型5.链路状态数据库的组成6.链路状态通告(LSA)类型6.路由器对路由条目的选择①.如何选择②.路由...
  • OSPF多区域配置实验

    千次阅读 2021-02-03 19:33:04
    请完成OSPF多区域的基本配置,实现三个区域之间的互联互通。 图1-1 OSPF多区域配置实验 2、业务配置流程图 图1-2 OSPF多区域配置实验流程 3、实验配置过程 1路由器的基本配置 步骤1:路由器R1的配置 ZXR10(co
  • OSPF的原理及多区域的配置 一:什么是OSPFOSPF是一种内部网关协议,一种开放式最短路径优先选择协议,用于单一自治系统内决策路由,是对链路状态路由协议的一种实现。 二:OSPF的工作原理 简单来说就是两相邻...
  • ENSP实现OSPF多区域互通

    千次阅读 2020-11-29 11:01:10
    比如三个路由器中间路由两条线,它就是我们所说的网段。 配置步骤: system-view sysname ar1 int g0/0/1 ip address 192.168.1.254 24 int g0/0/0 ip address 192.168.2.1 24 ospf 1 router-id 1.1.1.1 area 10 ...
  • OSPF多区域原理

    2019-04-24 09:44:43
    OSPF网络中,随着条路径的增加,路由表变得越来越庞大,每一次路径的改变都使路由器不得不花大量的时间和资源去重新计算路由表,路由器变得越来越低效。 包含完整网络结构信息的链路状态数据库也会...
  • 要求: 在每台路由器上开启ospf进程,根据区域划分情况,指定各路由器接口的所属区域。 思路: area0负责其他区域的互联,将路由器接口划入所属区域 1、将接口IP配置好 2、配置3台路由器ospf,进程号为1,设置...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 10,315
精华内容 4,126
关键字:

多区域ospf三个路由器