精华内容
下载资源
问答
  • 多区域OSPF基本配置

    2011-08-23 19:57:42
    拓扑图: R1: intface lo0 ip add 1.1.1.1 255.255.255.0 ...ip ospf network point-to-point intface s0/0/0 ip add 192.168.12.1 255.255.255.0 no shut router ospf 1 router-id 1.1.1.1 net...
    拓扑图: 
     

    R1:
    intface lo0
    ip add 1.1.1.1 255.255.255.0
    ip ospf network point-to-point
    intface s0/0/0
    ip add 192.168.12.1 255.255.255.0
    no shut
    router ospf 1
    router-id 1.1.1.1
    network 1.1.1.0 0.0.0.255 area 1
    network 192.168.12.0 0.0.0.255 area 1
    R2:
    intface lo0
    ip add 2.2.2.2  255.255.255.0
    ip ospf network point-to-point
    int s0/0/0
    ip add 192.168.12.2 255.255.255.0
    no shut
    int s0/0/1
    ip add 192.168.23.2  255.255.255.0
    no shut
    router ospf 1
    router-id 2.2.2.2
    network 192.168.12.0 0.0.0.255 area 1
    network 192.168.23.0 0.0.0.255 area 0
    network 2.2.2.0 0.0.0.255 area 0
    R3:
    intface lo0
    ip add 3.3.3.3 255.255.255.0
    ip ospf network point-to-point
    int s0/0/1
    ip add 192.168.23.3 255.255.255.0
    no shut
    int s0/0/0
    ip add 192.168.34.3 255.255.255.0
    no shut
    router ospf 1
    router-id 3.3.3.3
    network 192.168.23.0 0.0.0.255 area 0
    network 3.3.3.0 0.0.0.255 area 0
    network 192.168.34.0 0.0.0.255 area 2
    R4:
    intface lo0
    ip add 4.4.4.4 255.255.255.0
    ip ospf network point-to-point
    int s0/0/0
    ip add 192.168.34.4 255.255.255.0
    no shut
    router ospf 1
    router-id 4.4.4.4
    network 192.168.34.0 0.0.0.255 area 2
    redistribute connected subnets      //将直连路由重发布到OSPF 中,一般将其他路由协议重发布到OSPF中都要加subnets
     
    OSPF外部路由分为两种:
    1.类型1(E1)-----外部路径成本+数据包在OSPF网络所经过的各链路成本;
    2.类型2(E2)-----外部路径成本,即ASBR(自治系统边界路由器)上的默认设置,默认为20,可以修改,例:R4  redistribute connected subnets metric 50  metric-type 1
     
     
     

    转载于:https://blog.51cto.com/heisebeileimao/647269

    展开全文
  • 区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置多区域OSPF配置
  • 区域OSPF基本配置
  • 实验十一、单区域OSPF 基本配置 一、 实验目的 1. 掌握单区域OSPF 的配置 2. 理解链路状态路由协议的工作过程 3. 掌握实验环境中虚拟接口的配置 二、 应用环境 1. 在大规模网络中,OSPF 作为链路状态路由协议的代表...

    实验十一、单区域OSPF 基本配置

    一、 实验目的

    1. 掌握单区域OSPF 的配置

    2. 理解链路状态路由协议的工作过程

    3. 掌握实验环境中虚拟接口的配置

    二、 应用环境

    1. 在大规模网络中,OSPF 作为链路状态路由协议的代表应用非常广泛

    2. 具有无自环,收敛快的特点

    三、 实验设备

    1. DCR-1751 两台

    2. CR-V35MT 一条

    3. CR-V35FC 一条

    四、 实验拓扑

    clip_image002

    五、 实验要求

    ROUTER-A ROUTER-B

    S1/1 192.168.1.1/24 S1/0 192.168.1.2/24

    Loopback0 10.10.10.1/24 Loopback0 10.10.11.1/24

    六、 实验步骤

    第一步:路由器环回接口的配置(其他接口配置请参见实验三)

    路由器A:

    Router-A_config#interface loopback0Router-A_config_l0#ip address 10.10.10.1 255.255.255.0

    路由器B:

    Router-B#config

    Router-B_config#interface loopback0

    Router-B_config_l0#ip address 10.10.11.1 255.255.255.0

    第二步:验证接口配置

    Router-B#sh interface loopback0

    Loopback0 is up, line protocol is up

    Hardware is Loopback

    Interface address is 10.10.11.1/24

    MTU 1514 bytes, BW 8000000 kbit, DLY 500 usec

    Encapsulation LOOPBACK

    第三步:路由器的OSPF 配置

    A 的配置:

    Router-A_config#router ospf 2 !启动OSPF 进程,进程号为 2

    Router-A_config_ospf_1#network 10.10.10.0 255.255.255.0 area 0 !注意要写掩码和区域号

    Router-A_config_ospf_1#network 192.168.1.0 255.255.255.0 area 0

    B 的配置:

    Router-B_config#router ospf 1

    Router-B_config_ospf_1#network 10.10.11.0 255.255.255.0 area 0

    Router-B_config_ospf_1#network 192.168.1.0 255.255.255.0 area 0

    第四步:查看路由表

    路由器A:

    Router-A#sh ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type

    VRF ID: 0

    C 10.10.10.0/24 is directly connected, Loopback0

    O 10.10.11.1/32 [110,1600] via 192.168.1.2(on Serial1/1)

    !注意到环回接口产生的是主机路由

    C 192.168.1.0/24 is directly connected, Serial1/1

    路由器B:

    Router-B#show ip routeCodes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type

    VRF ID: 0

    O 10.10.10.1/32 [110,1601] via 192.168.1.1(on Serial1/0) !注意管理距离为110

    C 10.10.11.0/24 is directly connected, Loopback0

    C 192.168.1.0/24 is directly connected, Serial1/0

    第五步:其他验证命令

    Router-B#sh ip ospf 1 !显示该OSPF 进程的信息

    OSPF process: 1, Router ID: 192.168.2.1

    Distance: intra-area 110, inter-area 110, external 150

    SPF schedule delay 5 secs, Hold time between two SPFs 10 secs

    SPFTV:11(1), TOs:24, SCHDs:27

    All Rtrs support Demand-Circuit.

    Number of areas is 1

    AREA: 0

    Number of interface in this area is 2(UP: 3)

    Area authentication type: None

    All Rtrs in this area support Demand-Circuit.

    Router-A#show ip ospf interace !显示OSPF 接口状态和类型

    Serial1/1 is up, line protocol is up

    Internet Address: 192.168.1.1/24

    Nettype: Point-to-Point

    OSPF process is 2, AREA: 0, Router ID: 192.168.1.1

    Cost: 1600, Transmit Delay is 1 sec, Priority 1

    Hello interval is 10, Dead timer is 40, Retransmit is 5

    OSPF INTF State is IPOINT_TO_POINT

    Neighbor Count is 1, Adjacent neighbor count is 1

    Adjacent with neighbor 192.168.1.2

    Loopback0 is up, line protocol is up

    Internet Address: 10.10.10.1/24

    Nettype: Broadcast !环回接口的网络类型默认为广播

    OSPF process is 2, AREA: 0, Router ID: 192.168.1.1

    Cost: 1, Transmit Delay is 1 sec, Priority 1

    Hello interval is 10, Dead timer is 40, Retransmit is 5

    OSPF INTF State is ILOOPBACK

    Neighbor Count is 0, Adjacent neighbor count is 0Router-A#sh ip ospf neighbor !显示OSPF 邻居

    ----------------------------------------------------------------------------

    OSPF process: 2

    AREA: 0

    Neighbor ID Pri State DeadTime Neighbor Addr Interface

    192.168.2.1 1 FULL/- 31 192.168.1.2 Serial1/1

    第六步:修改环回接口的网络类型

    Router-A#conf

    Router-A_config#interface loopback 0

    Router-A_config_l0#ip ospf network point-to-point !将类型改为点到点

    第七步:查看接口状态和路由器B 的路由表

    Router-A#sh ip ospf interface

    Serial1/1 is up, line protocol is up

    Internet Address: 192.168.1.1/24

    Nettype: Point-to-Point

    OSPF process is 2, AREA: 0, Router ID: 192.168.1.1

    Cost: 1600, Transmit Delay is 1 sec, Priority 1

    Hello interval is 10, Dead timer is 40, Retransmit is 5

    OSPF INTF State is IPOINT_TO_POINT

    Neighbor Count is 1, Adjacent neighbor count is 1

    Adjacent with neighbor 192.168.1.2

    Loopback0 is up, line protocol is up

    Internet Address: 10.10.10.1/24

    Nettype: Point-to-Point

    OSPF process is 2, AREA: 0, Router ID: 192.168.1.1

    Cost: 1, Transmit Delay is 1 sec, Priority 1

    Hello interval is 10, Dead timer is 40, Retransmit is 5

    OSPF INTF State is IPOINT_TO_POINT

    Neighbor Count is 0, Adjacent neighbor count is 0

    Router-B#sh ip route

    Codes: C - connected, S - static, R - RIP, B - BGP, BC - BGP connected

    D - DEIGRP, DEX - external DEIGRP, O - OSPF, OIA - OSPF inter area

    ON1 - OSPF NSSA external type 1, ON2 - OSPF NSSA external type 2

    OE1 - OSPF external type 1, OE2 - OSPF external type 2

    DHCP - DHCP type

    VRF ID: 0O 10.10.10.0/24 [110,1600] via 192.168.1.1(on Serial1/0)

    C 10.10.11.0/24 is directly connected, Loopback0

    C 192.168.1.0/24 is directly connected, Serial1/0

    转载于:https://blog.51cto.com/lorna8023/402905

    展开全文
  • 多区域OSPF基本配置

    2011-04-12 16:44:28
    小知识:多区域OSPF中所涉及的路由器的类型有:内部路由器、主干/内部路由器 ABR和主干路由器、ASBR和主干路由器。 内部路由器:OSPF路由器上所有直连的链路都处于同一个区域 主干路由器:具有连接区域0接口的...

     

     
    小知识:多区域OSPF中所涉及的路由器的类型有:内部路由器、主干/内部路由器
    ABR和主干路由器、ASBR和主干路由器。
    内部路由器:OSPF路由器上所有直连的链路都处于同一个区域
    主干路由器:具有连接区域0接口的路由器
    区域边界路由器(ABR):路由器与多个区域相连
    自治系统边界路由器(ASBR):与AS外部的路由器相连并相互交换路由信息。

    区域类型:
    标准区域:可以接受链路更新信息和路由汇总。
    主干区域:连接各区域的中心实体,所有其他的区域都要连接到这个区域上
                        交换路由信息
    末节区域:不接受外部自治系统的路由信息
    完全末节区域:即不接受外部自治系统的路由也不接受自治系统内部其他区域的
                                路由汇总。
    次末节区域:允许接受以类型7的LSA发送的外部路由信息,并且ABR要负责把类型
                            7的LSA转换成类型5的LSA.
    1》开启R1的OSPF进程
    R1(config)#router ospf 1
    R1(config-router)#router-id 1.1.1.1
    R1(config-router)#network 1.1.1.0 0.0.0.255 area 1
    R1(config-router)#network 192.168.12.0 0.0.0.255 area 1
    2》用同样的方法开启R2、R3的OSPF进程
    3》开启R4的OSPF进程
    R4(config)#router ospf 1
    R4(config-router)#router-id 4.4.4.4
    R4(config-router)#network 192.168.34.0 0.0.0.255 area 2
    4》R2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route

    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    O       1.1.1.1 [110/782] via 192.168.12.1, 00:25:06, Serial0/3/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback0
         3.0.0.0/32 is subnetted, 1 subnets
    O       3.3.3.3 [110/782] via 192.168.23.2, 00:23:35, Serial0/2/0
    C    192.168.12.0/24 is directly connected, Serial0/3/0
    C    192.168.23.0/24 is directly connected, Serial0/2/0
    O IA 192.168.34.0/24 [110/1562] via 192.168.23.2, 00:23:10, Serial0/2/0
    从以上结果可知,R2上通过OSPF获取了两条区域内路由和一条区域间路由。
    5》在R4上将4.4.4.0/24网络重分布进OSPF网络,在这里4.4.4.0模拟了一个外部自治系统
    命令是:
    R4(config-router)#redistribute connected subnets
    6》再在R2上查看路由显示的结果是
    Gateway of last resort is not set

         1.0.0.0/32 is subnetted, 1 subnets
    O       1.1.1.1 [110/782] via 192.168.12.1, 00:35:30, Serial0/3/0
         2.0.0.0/24 is subnetted, 1 subnets
    C       2.2.2.0 is directly connected, Loopback0
         3.0.0.0/32 is subnetted, 1 subnets
    O       3.3.3.3 [110/782] via 192.168.23.2, 00:33:59, Serial0/2/0
         4.0.0.0/24 is subnetted, 1 subnets
    O E2    4.4.4.0 [110/20] via 192.168.23.2, 00:00:21, Serial0/2/0
    C    192.168.12.0/24 is directly connected, Serial0/3/0
    C    192.168.23.0/24 is directly connected, Serial0/2/0
    O IA 192.168.34.0/24 [110/1562] via 192.168.23.2, 00:33:34, Serial0/2/0
    从上面的结果可以看出多了一条路由。
    注意:
    OSPF的外部路由分为:类型1(E1)和类型2(E2)他们计算外部路由度量值的方式不同
    类型1(E2):外部路径成本+数据包在OSPF网络所经过各链路成本;
    类型2(E2):外部路径成本,即ASBR上的默认设置(默认值为20)
    在重分布的时候,可以通过“metric-type”参数设置时类型1或2,也可以通过“metric”
    参数设置外部路径成本,默认值为20.例如:
    R4(config-router)#redistribute connected subnets metric 50 metric-type 1

    转载于:https://blog.51cto.com/xuzhiming302/542769

    展开全文
  • OSPF区域基本配置

    2011-12-08 11:09:12
    OSPF区域基本配置
  • OSPF多区域基本配置

    千次阅读 2018-03-22 21:12:23
    配置ospf配置环回地址 实验结果 实验拓扑 实验步骤及配置 ip配置 RA # sysname RA # interface GigabitEthernet0/0/0 ip address 10.1.1.1 255.255.255.0 # RB # sysname RB # ...

    目录

    实验拓扑

    这里写图片描述

    实验步骤及配置

    ip配置

    RA
    #
     sysname RA
    #
    interface GigabitEthernet0/0/0
     ip address 10.1.1.1 255.255.255.0 
    #
    
    
    RB
    #
     sysname RB
    #
    interface GigabitEthernet0/0/0
     ip address 10.1.1.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.1.2.1 255.255.255.0 
    #
    
    
    RC
    #
     sysname RC
    #
    interface GigabitEthernet0/0/0
     ip address 10.1.2.2 255.255.255.0 
    #
    interface GigabitEthernet0/0/1
     ip address 10.1.3.1 255.255.255.0 
    #
    
    RD
    #
     sysname RD
    #
    interface GigabitEthernet0/0/0
     ip address 10.1.3.2 255.255.255.0 
    #
    

    配置ospf及配置环回地址

    RA
    #
    router id 1.1.1.1 
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255 
    #
    ospf 1 
     area 0.0.0.1 
      network 1.1.1.1 0.0.0.0 
      network 10.1.1.1 0.0.0.0 
    #
    
    RB
    #
    router id 2.2.2.2 
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255 
    #
    ospf 1 
     area 0.0.0.0 
      network 2.2.2.2 0.0.0.0 
      network 10.1.2.1 0.0.0.0 
     area 0.0.0.1 
      network 10.1.1.2 0.0.0.0 
    #
    
    RC
    #
    router id 3.3.3.3 
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255 
    #
    ospf 1 
     area 0.0.0.0 
      network 3.3.3.3 0.0.0.0 
      network 10.1.2.2 0.0.0.0 
     area 0.0.0.2 
      network 10.1.3.1 0.0.0.0 
    #
    
    RD
    #
    router id 4.4.4.4 
    #
    interface LoopBack0
     ip address 4.4.4.4 255.255.255.255 
    #
    ospf 1 
     area 0.0.0.2 
      network 4.4.4.4 0.0.0.0 
      network 10.1.3.2 0.0.0.0 
    #
    

    实验结果

    测试RA-RD是否通

    这里写图片描述

    抓包检测RA-RB之间的关系变化

    这里写图片描述

    • A、B之间通过互发hello报文寻找邻居,关系变化:down——init——two-way;
      然后在通过DD报文选举DR、BDR,之后A、B在EXCHANGE状态下将自身的lsdb简介通过DD报文发送给对方,A、B关系:two-way——EXSTART——EXCHANGE,
      接着A、B在loading状态下发送lsq、lsu报文,最后在接收完成后full状态下发送lsack报文,A、B关系:EXCHANGE——LOADING——FULL。
    • two-way时建立邻居关系,full时建立邻接关系,ospf只有建立邻接时才算成功。
    展开全文
  • 区域OSPF基本配置

    2020-12-23 19:14:39
    区域OSPF基本配置 首先是5台路由器的接口配置: R1: [Huawei]interface g0/0/0 [Huawei-GigabitEthernet0/0/0]ip address 10.8.0.1 24 [Huawei-GigabitEthernet0/0/0]interface loopback0 [Huawei-LoopBack0]...
  • 目录 一、实验原理 二、实验拓扑 三、实验步骤 四、实验过程 ...OSPF是具有区域特性的协议,可以设计出单一区域的OSPF网络,也可以设计出区域的OSPF网络。...3.配置区域OSPF网络,网络的AS号为100,使用环回口...
  • 多区域ospf基本配置 好久没有做过实验了,今天按照按照工大瑞普的实验手册来做ospf的的实验。 拓扑图如图所示 实验目的: 1、掌握区域的OSPF配置方法。 2、区别不同区域的路由。 3、掌握OSPF的路由...
  • 多区域OSPF及认证配置

    2011-06-05 22:36:05
    详细介绍了多区域OSPF及认证配置,是一个很好的实例
  • OSPF路由协议基础(OSPF基本配置

    万次阅读 多人点赞 2020-12-04 11:50:25
    OSPF路由协议基础(OSPF基本配置) 文章目录OSPF路由协议基础(OSPF基本配置)一、拓扑图二、OSPF基本配置三、总结 一、拓扑图 二、OSPF基本配置 [R4]router id 4.4.4.4 [R4]ospf [R4-ospf-1] [R4-ospf-1]area 0...
  • OSPF(Open Shortest Path First):开放式最短路径优先 定义: OSPF(Open Shortest Path First开放式最短路径优先)是一个内部网关协议(Interior Gateway Protocol,简称IGP),用于在单一自治系统(autonomous ...
  • OSPF基本配置

    2021-06-29 21:58:34
    1、全网基本ip地址配置: 一般配置loopback口的地址做为ospf 的router-id; 2、全网路由启用ospf,并把对应的接口通告到指定的区域:注意: 1)ospf的进程号,只是代表本路由器上的一个ospf进程,全网路由器的...
  • ospf基本配置

    2016-12-28 12:05:09
    实验名称:ospf基本配置实验目的:掌握在路由器上配置ospf单区域路由器:三层交换机: 转载于:https://blog.51cto.com/12064606/1886848
  • OSPF 基本配置

    2016-12-14 14:48:36
    实验 OSPF 基本配置【实验名称】OSPF区域基本配置。【实验目的】掌握在路由器上配置 OSPF区域。【背景描述】假设校园网通过 1 台三层交换机连到校园网出口路由器,路由器再和校园外的另 1 台路由器连接,现做...
  • IP路由-OSPF基本配置.docx
  • 配置 OSPF 多区域基本实验

    千次阅读 2020-05-01 17:21:38
    OSPF 多区域基本配置 实验目的 多区域 OSPF 配置技术 背景描述 你是某集成商的高级技术支持工程师,现在让你为某企业设计一个网络,你选择了使用 ospf 路由协议来构建,整个 OSPF 网络设计区域。 实现功能 构建 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 6,543
精华内容 2,617
关键字:

多区域ospf基本配置