精华内容
下载资源
问答
  • 运营商们正在通过整合IP与光网络技术,力求提高服务效率和开发高级服务。然而,首先他们需要克服极其复杂的多层架构。即从第三层的IP一直延伸到第一层的光传输层。
  • 多协议标签交换》 简介 MPLS的起源 90年代中期,IP技术凭借技术简单和成本低廉实现快速发展,Internet数据海量增长。但由于硬件技术存在限制,基于最长匹配算法的IP技术必须使用软件查找路由,转发性能低下,...

    什么是MPLS?多协议标签交换

     

     

    简介


    MPLS的起源


    90年代中期,IP技术凭借技术简单和成本低廉实现快速发展,Internet数据海量增长。但由于硬件技术存在限制,基于最长匹配算法的IP技术必须使用软件查找路由,转发性能低下,因此IP技术的转发性能成为当时限制网络发展的瓶颈。

    为了适应网络的发展,ATM(Asynchronous Transfer Mode)技术应运而生。ATM采用定长标签(即信元),并且只需要维护比路由表规模小得多的标签表,能够提供比IP路由方式高得多的转发性能。然而,ATM协议相对复杂,且ATM网络部署成本高,这使ATM技术很难普及。

    如何结合IP与ATM的优点成为热门话题。多协议标签交换技术MPLS(Multiprotocol Label Switching)就是在这种背景下产生的。

    MPLS最初是为了提高路由器的转发速度而提出的。与传统IP路由方式相比,它在数据转发时,只在网络边缘分析IP报文头,而不用在每一跳都分析IP报文头,节约了处理时间。

    随着ASIC技术的发展,路由查找速度已经不是阻碍网络发展的瓶颈,这使得MPLS在提高转发速度方面不再具备明显的优势。但是MPLS支持多层标签和转发平面面向连接的特性,使其在VPN(Virtual Private Network)、流量工程、QoS(Quality of Service)等方面得到广泛应用。

     

    MPLS的定义


    MPLS位于TCP/IP协议栈中的链路层和网络层之间,用于向IP层提供连接服务,同时又从链路层得到服务。MPLS以标签交换替代IP转发,标签是一个短而定长的、只具有本地意义的连接标识符,与ATM的VPI/VCI以及Frame Relay的DLCI类似。

    MPLS不局限于任何特定的链路层协议,能够使用任意二层介质传输网络分组。MPLS起源于IPv4(Internet Protocol version 4),其核心技术可扩展到多种网络协议,包括IPv6(Internet Protocol version 6)、IPX(Internet Packet Exchange)、Appletalk、DECnet、CLNP(Connectionless Network Protocol)等。MPLS中的“Multiprotocol”指的就是支持多种网络协议。

    由此可见,MPLS并不是一种业务或者应用,它实际上是一种隧道技术,在一定程度上可以保证信息传输的安全性。

     

    MPLS的工作原理


    MPLS个工作原理主要包含两部分内容:

    • MPLS的体系结构是指运行MPLS的单个设备内部的独立工作原理。

    • MPLS的网络结构是指运行MPLS的多个设备互连的联合工作原理。

     

    MPLS的体系结构


    MPLS的体系结构由控制平面(Control Plane)和转发平面(Forwarding Plane)组成:

    • 控制平面是无连接的,主要功能是负责标签的分配、LFIB(标签转发表,Lable Forwarding Information Base)的建立、 LSP(标签交换路径,Label Switched Path)的建立、拆除等工作。

    • 转发平面也称为数据平面(Data Plane),是面向连接的,可以使用ATM、Ethernet等二层网络承载,主要功能是对IP包进行标签的添加和删除,同时依据标签转发表对收到的分组进行转发。

    MPLS的体系结构如图1-1所示。

    图1-1 MPLS体系结构示意图使用

    • A:IP路由协议建立邻居,交互路由信息,生成IP路由表。

    • B:标签交换协议从IP路由表中获取路由信息。IP路由表中的路由前缀匹配了FEC(转发等价类,Forwarding Equivalence Class),在传统的采用最长匹配算法的IP转发中,到同一条路由的所有报文就是一个FEC。

    • C:IP路由表中激活的最优路由生成IP转发表。

    • D:标签转换协议建立邻居,为FEC分配标签并发布给邻居,同时获取邻居发布的标签,生成标签转发表。

     

    MPLS转发平面建立以后,设备中已经生成了IP转发表和标签转发表,就可以对于接收到的数据包进行转发,其过程如图1-2所示。

    图1-2 MPLS转发数据包过程示意图

     

    MPLS的网络结构


    MPLS网络的典型结构如图1-3所示:

    图1-3 MPLS网络结构示意图

    MPLS网络的基本组成单元是标签交换路由器LSR(Label Switching Router):

    • 位于MPLS域边缘、连接其它网络的LSR称为边沿路由器LER(Label Edge Router),如果一个LSR有一个或多个不运行MPLS的相邻节点,那么该LSR就是LER。

    • 区域内部的LSR称为核心LSR(Core LSR),如果一个LSR的相邻节点都运行MPLS,则该LSR就是核心LSR。

     

    MPLS的实现原理


    MPLS的实现原理是指:为FEC(转发等价类,Forwarding Equivalence Class)分配标签来建立LSP(标签交换路径,Label Switched Path)。

     

    MPLS LSP


    IP包在MPLS网络中经过的路径称为MPLS的LSP,即标签交换的路径,如图1-4所示。

    图1-4 MPLS LSP

    MPLS LSP是一个单向路径,与数据流的方向一致。

    • LSP的起始节点称为入节点(Ingress):LSP的起始节点,一条LSP只能有一个Ingress。

      Ingress的主要功能是给报文压入一个新的标签,封装成MPLS报文进行转发。

    • 位于LSP中间的节点称为中间节点(Transit):LSP的中间节点,一条LSP可能有0个或多个Transit。

      Transit的主要功能是查找标签转发信息表,通过标签交换完成MPLS报文的转发。

    • LSP的末节点称为出节点(Egress):LSP的末节点,一条LSP只能有一个Egress。

      Egress的主要功能是弹出标签,恢复成原来的报文进行相应的转发。

     

    其中Ingress和Egress既是LSR,又是LER;Transit是LSR。

    根据数据传送的方向,LSR可以分为上游和下游。

    • 上游:以指定的LSR为视角,根据数据传送的方向,所有往本LSR发送MPLS报文的LSR都可以称为上游LSR。

    • 下游:以指定的LSR为视角,根据数据传送的方向,本LSR将MPLS报文发送到的所有下一跳LSR都可以称为下游LSR。

     

    MPLS标签


    标签是一个短而定长的、只具有本地意义的标识符,用于唯一标识一个分组所属的FEC。在某些情况下,例如要进行负载分担,对应一个FEC可能会有多个入标签,但是一台LSR上,一个标签只能代表一个FEC。

    标签长度为4个字节,封装结构如图1-5所示。

    图1-5 MPLS报文首部结构

    标签共有4个域:

    • Label:20bit,标签值域。
    • Exp:3bit,用于扩展。现在通常用做CoS(Class of Service),其作用与Ethernet802.1p的作用类似。
    • BoS:1bit,栈底标识。MPLS支持多层标签,即标签嵌套。S值为1时表明为最底层标签。
    • TTL:8bit,和IP分组中的TTL(Time To Live)意义相同。

    标签封装在链路层和网络层之间。这样,标签能够被任意的链路层所支持。标签在分组中的封装位置如图1-6所示。

    图1-6 标签在分组中的封装位置

    标签栈(Label stack)也称为多层标签,是指标签的排序集合,如图1-7所示。靠近二层首部的标签称为栈顶标签或外层标签;靠近IP首部的标签称为栈底标签,或内层标签。理论上,MPLS标签可以无限嵌套。

    图1-7 标签栈

    标签栈按后进先出(Last In First Out)方式组织标签,从栈顶开始处理标签。

     

    标签的操作类型包括标签压入(Push)、标签交换(Swap)和标签弹出(Pop),它们是标签转发的基本动作,是标签转发信息表的组成部分。

    • Push:指当IP报文进入MPLS域时,MPLS边界设备在报文二层首部和IP首部之间插入一个新标签;或者MPLS中间设备根据需要,在标签栈顶增加一个新的标签(即标签嵌套封装)。
    • Swap:当报文在MPLS域内转发时,根据标签转发表,用下一跳分配的标签,替换MPLS报文的栈顶标签。
    • Pop:当报文离开MPLS域时,将MPLS报文的标签去掉;或者MPLS倒数第二跳节点处去掉栈顶标签,减少标签栈中的标签数目。

     

    在最后一跳节点,标签已经没有使用价值。这种情况下,可以利用倒数第二跳弹出特性PHP(Penultimate Hop Popping),在倒数第二跳节点处将标签弹出,减少最后一跳的负担。最后一跳节点直接进行IP转发或者下一层标签转发。PHP在Egress节点上配置,通过分配特殊的标签值3来实现。标签值3表示隐式空标签(implicit-null),这个值不会出现在标签栈中。当一个LSR发现自己被分配了隐式空标签时,它并不用这个值替代栈顶原来的标签,而是直接执行Pop操作。Egress节点直接进行IP转发或下一层标签转发。

     

    分配标签来建立LSP


    MPLS需要为报文事先分配好标签,建立一条MPLS LSP,才能进行报文转发。标签由下游分配,按从下游到上游的方向分发。

    如图1-8所示,由下游LSR在IP路由表的基础上进行FEC的划分,并将标签分配给特定FEC,再通过标签发布协议通知上游LSR,以便建立标签转发表和LSP。

    图1-8 MPLS LSP的建立

    LSP分为静态LSP和动态LSP两种:静态LSP由手工配置,动态LSP则利用路由协议和标签发布协议动态建立。

    MPLS可以使用多种标签发布协议,例如LDP(Label Distribution Protocol)、RSVP-TE(Resource Reservation Protocol Traffic Engineering)和MP-BGP(Multiprotocol Border Gateway Protocol)。

    LDP是专为标签发布而制定的协议,也是其中使用较广的一种。LDP规定了标签分发过程中的各种消息以及相关的处理过程。LSR之间将依据转发表中对应于一个特定FEC的入标签、下一跳节点、出标签等信息联系在一起,从而形成标签交换路径LSP。

     

    静态LSP的配置方法


    组网图如图1-9所示,3个节点运行OSPF作为IGP,在节点上通过配置静态LSP来实现LSRA到LSRC之间的MPLS隧道承载。

    图1-9 静态LSP配置示例组网图

     

    本例中interface1,interface2分别代表GE 1/0/0,GE 2/0/0。

    配置文件示例如所表1-1示:

    表1-1 静态LSP配置文件示例

    LSRA

    LSRB

    LSRC

    #
    sysname LSRA
    #
    mpls lsr-id 192.168.1.9
    #
    mpls
    #
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.1.1 255.255.255.0
     mpls           
    #               
    interface LoopBack1
     ip address 192.168.1.9 255.255.255.255
    #               
    ospf 1          
     area 0.0.0.0   
      network 10.1.1.0 0.0.0.255
      network 192.168.1.9 0.0.0.0
    #               
     static-lsp ingress AtoC destination 192.168.3.9 32 nexthop 10.1.1.2 out-label 20
    #
    return
    #
    sysname LSRB
    #
    mpls lsr-id 192.168.2.9
    #
    mpls
    #
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.1.1.2 255.255.255.0
     mpls           
    #               
    interface GigabitEthernet2/0/0
     undo shutdown  
     ip address 10.2.1.1 255.255.255.0
     mpls           
    #               
    interface LoopBack1
     ip address 192.168.2.9 255.255.255.255
    #               
    ospf 1          
     area 0.0.0.0   
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      network 192.168.2.9 0.0.0.0
    # 
     static-lsp transit AtoC in-label 20 outgoing-interface GigabitEthernet2/0/0 nexthop 10.2.1.2 out-label 40
    #
    return
    #
    sysname LSRC
    #
    mpls lsr-id 192.168.3.9
    #
    mpls
    #
    interface GigabitEthernet1/0/0
     undo shutdown  
     ip address 10.2.1.2 255.255.255.0
     mpls           
    #               
    interface LoopBack1
     ip address 192.168.3.9 255.255.255.255
    #               
    ospf 1          
     area 0.0.0.0   
      network 10.2.1.0 0.0.0.255
      network 192.168.3.9 0.0.0.0
    #
     static-lsp egress AtoC incoming-interface GigabitEthernet1/0/0 in-label 40
    #
    return

    检查配置结果:在设备上查看静态LSP的状态,以LSRA为列,Lsp Status为Up。

    <LSRA> display mpls static-lsp verbose
     No              : 1
     LSP-Name        : AtoC
     LSR-Type        : Ingress
     FEC             : 192.168.3.9/32
     In-Label        : NULL
     Out-Label       : 20
     In-Interface    : -
     Out-Interface   : GigabitEthernet1/0/0
     NextHop         : 10.1.1.2
     Static-Lsp Type : Normal
     Lsp Status      : Up

     

    动态LSP(LDP)的配置方法


    组网图如图1-10所示,3个节点运行OSPF作为IGP,在节点上通过配置动态LSP来实现LSRA到LSRC之间的MPLS隧道承载。

    图1-10 动态LSP配置示例组网图

    本例中interface1,interface2分别代表GE 1/0/0,GE 2/0/0。

    配置文件示例如所表1-2示:

    表1-2 动态LSP配置文件示例

    LSRA

    LSRB

    LSRC

    #
    sysname LSRA
    #
    mpls lsr-id 192.168.1.9
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 192.168.1.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.9 0.0.0.0
    #
    return
    #
    sysname LSRB
    #
    mpls lsr-id 192.168.2.9
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 192.168.2.9 255.255.255.255
    #
    ospf 1          
     area 0.0.0.0   
      network 10.1.1.0 0.0.0.255
      network 10.2.1.0 0.0.0.255
      network 192.168.2.9 0.0.0.0
    # 
    return
    #
    sysname LSRC
    #
    mpls lsr-id 192.168.3.9
    #
    mpls
    #
    mpls ldp
    #
    interface GigabitEthernet1/0/0
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface LoopBack1
     ip address 192.168.3.9 255.255.255.255
    #               
    ospf 1          
     area 0.0.0.0   
      network 10.2.1.0 0.0.0.255
      network 192.168.3.9 0.0.0.0
    #
    return

    检查配置结果:在设备上查看LDP的会话状态,以LSRA为列,Status为Operational。

    <LSRA> display mpls ldp session
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDD:HH:MM)
     An asterisk (*) before a session means the session is being deleted.
    ---------------------------------------------------------------------------------
     PeerID          Status        LAM        SsnRole        SsnAge        KASent/Rcv
    ---------------------------------------------------------------------------------
    192.168.2.9:0    Operational   DU         Passive        0000:00:22    91/91
    ---------------------------------------------------------------------------------
    TOTAL: 1 Session(s) Found.

     

    相关信息


    如果您需要了解MPLS的更多信息及配置方法,可参考产品文档《NE40E V800R011C10SPC100 产品文档》。

     

    参考来源:


    https://support.huawei.com/enterprise/zh/doc/EDOC1100118965

     

    展开全文
  • 网络通信原理多协议标签交换技术MPLS.pptx
  • Multi-ProtocolLabelSwitching:多协议标签交换。 ampls-vpn 2各种运营者的设备如:LTE等。 注:MPLS是介于mac和ip之间的两层半协议。 通过直接查询MPLS标签传输,减少了运营商大型路由中的消息转发、降低了路由...

    多协议标签交换的MPLS原理

    Multi-ProtocolLabelSwitching:多协议标签交换。

    ampls-vpn

    2各种运营者的设备如:LTE等。

    注:MPLS是介于mac和ip之间的两层半协议。

    通过直接查询MPLS标签传输,减少了运营商大型路由中的消息转发、降低了路由递归查询等造成的性能消耗。

    注:MPLS只是数据层的转发方式,MPLS本身不能构成路由,不能控制数据的走向,也就是说,mpls是一个依赖于底层的路由协议。

    ..。

    配置MPLS

    全球R1。

    MPLSLSR-id1.1.1.1为MPLS路由器指定router-id。

    #mpls允许用mpls标签来抓发。

    #mplsldp支持mplsldp分发协议。

    #intg0/0/0#R1。

    电子邮件。

    mplsldp

    配置了所有的路由器。

    在配置好R1pingR4和R2到R3之间的包之后,发现MPLS标签已经添加了,这是一个2.5层。

    ..。

    LDP:标签分配协议。

    标签分发协议:LableDistributionProtocol。

    ‍。

    查看标签转发布dismplslsp(相当于查看路由表)

    ..。

    注意:①标签小于1024都有特殊意义,分配给普通路由的标签大于等于1024。

    注意:标签转发只是数据层的一种转发机制,它无法控制转发路径,而控制层依赖于路由表。

    注意③:标签在当地有效。

    微机原理。

    ..。

    展开全文
  • MPLS技术手册 MPLS技术 第 16 章 MPLS技术 本章主要讲述 MPLS(Multiprotocol Lable Switching 多协议标签交换 ) 的原 理及实现 本章主要内容 : , MPLS 相关术语解析 , MPLS 原理介绍 , 调试命令及调试信息 16.1 MPLS...
  • 介绍了MPLS(多协议标签交换)技术的概念、基本原理和应用现状,讨论了基于MPLS的实现过程,指出了基于MPLS技术的优势和存在问题,分析了基于MPLS在VPN、流量工程和服务等级方面的应用情况。
  • MPLS多协议标签交换

    2021-05-04 19:49:35
    MPLS(多协议标签交换) 1.1 概念 1.1.1 MPLS出现的背景 解决早期IP转发效率的低效,在近代因为基于硬件ANSI等芯片的出现,速度非常快,MPLS的快速转发体现不出来了。 现在主要解决路由黑洞问题,和无法形成流量分担...

    MPLS(多协议标签交换)

    1.1 概念

    1.1.1 MPLS出现的背景

    • 解决早期IP转发效率的低效,在近代因为基于硬件ANSI等芯片的出现,速度非常快,MPLS的快速转发体现不出来了。
    • 现在主要解决路由黑洞问题,和无法形成流量分担的问题。

    1.1.2 工作原理

    1. 生成标签转发表。
    2. 根据标签查找标签转发表进行数据转发。
    

    1.1.3 使用场景

    在MPLS TE(流量工程)中可以使用。
    在MPLS VPN中承担数据转发作用。

    2. MPLS体系结构

    在这里插入图片描述

    • 控制层面路由选择协议通过交换路由信息生成IP路由表,在路由表中选出一条最优路由加入到IP转发表中,当数据层面收到IP报文时,查IP转发表进行转发。
    • 控制层面运行LDP协议,通过相互交换标签形成标签转发表。当数据层面收到带有标签的报文是查标签转发表进行转发。

    2.1 术语

    • LER(标签边缘路由器)负责标签的压入(push)与弹出(pop)
    • LSR(标签交换路由器)主要负责标签的交换。
    • LSP(标签交换路径)
      • 静态LSP:管理员手工配置。手工分配标签需要遵循的原则是:上游节点出标签的值就是下游节点入标签的值。
      • 动态LSP:LDP、RSVP-TE、MP-BGP
    • FEC(转发等价类):为某一类属性相同的数据分配相同的标签。LSR认为具有相同转发处理方式的报文,使用同一个标签来标记这些报文。如:匹配相同目的IP前缀的多个IP报文可属于一个FEC。

    上游下游的概念
    在这里插入图片描述

    • 在控制层面传路由的时候,下游设备收到5.5.5.5的路由给其分配标签告知上游邻居,上游邻居收到下游分配的标签形成标签转发表,并同下游设备一样给其路由分配标签通告给自己的上游邻居。上游设备形成标签转发表,依次到边界路由器。
    • 数据层面数据的源为上游,数据的目的为下游

    2.2 标签操作类型

    标签由下游分配,标签压入压入的是下游传递来的标签。标签分发基于路由表。

    • push压入标签
    • swap替换标签
    • POP弹出标签,

    标签交换路径LSP是一个单向路径,LSP中的LSRs可以分为:

    • 入节点(Ingress):LSP的起始节点,一条LSP只能有一个Ingress。
      Ingress的主要功能是给报文压入一个新的标签,封装成MPLS报文进行转发。
    • 中间节点(Transit):LSP的中间节点,一条LSP可能有多个Transit。
      Transit的主要功能是查找标签转发信息表,通过标签交换完成MPLS报文的转发。
    • 出节点(Egress):LSP的末节点,一条LSP只能有一个Egress。
      Egress的主要功能是弹出标签,恢复成原来的报文进行相应的转发。

    3. MPLS的封装格式

    封装在L2之上,L3之下。

    • Ethernet类型值为0x0800为IPV4,0x8847为MPLS单播报文,8848MPLS多播报文
    • P2P类型值0x8021为IPv4,0x8281为MPLS单播报文,0x8283MPLS多播报文。
      在这里插入图片描述

    头部长度4B

    1. 标签长度20bit:标签个数位2^20。
      0-15为保留标签
      16-1023为静态LSP标签和静态CR-LSP共享的标签空间
      1024-2^20为动态标签,LDP、RSVP-TE、MP-BGP等动态协议
      特殊标签:0:ipv4显示空标签,2:ipv6显示空标签,3为隐式空标签,用于倒数第二跳弹出。

    2. EXP位:实验位3bit。用于qos

    3. S位:栈低位1位。标识是否为最后一个标签。1代表是,0代表否。意味着可以打多层标签

    4. TTL:用来防环。长度8bit

    4. MPLS的转发

    4.1 转发表

    • RIB(路由表):用于路由的选路,并将最优的路由下发到FIB
    • FIB(转发信息库):用于指导数据报文的转发
      • tunnel-id:系统自动为隧道分配的编号,本地有效
      • token:用于索引tunnel–id的。
    • LIB(标签信息库): 保存标签的信息
    • LFIB(标签转发信息库):用于标签的转发,有出接口下一跳等。
    • NHLFE(下一跳标签转发表项):用于指导MPLS报文的转发,包括tunnel-ID,出接口,下一跳,出标签标签操作类型。
    • ILM(入标签映射):入标签与NHLFE的映射称为ILM, 包括tunnel-id,入接口,入标签,标签操作类型等
    • FTN(FEC To NHLFE):FEC到一组NHLFE的映射,通过查看FIB表中tunnel-id不为0的表项。只在ingress节点中才有。

    4.2 转发流程

    1. 当IP报文进入MPLS域时,首先查看FIB,检查目的IP地址对应的Tunnel id的值是否为0,
      如果为0,则进入正常的IP转发流程
      如果不为0,则进入MPLS转发流程。
    2. 在Ingress节点,通过查询FIB表和NHLFE表指导报文的转发。
      查看FIB表的tunnel ID,通过Token找到对应的NHLFE。将FIB和NHLFE关联起来。
      display fib
      在这里插入图片描述
      通过查看Tunnel-id为0xd,然后去查看与之匹配的token所在的NHLFE表
      查看NHLFE表,得到出接口、下一跳、出标签和标签操作类型。
      在这里插入图片描述
      压入获得的标签,根据QOS处理EXP,同时处理TTL,封装MPLS报文发送给下一跳
    3. 在Transit节点,通过查看ILM表和NHLFE表指导MPLS报文的转发。
      根据MPLS标签值查看对应的ILM表,可以得到Token
      在这里插入图片描述
      根据token可以找到对应的NHLFE表,得到出接口,下一跳,出标签,类型等。
      在这里插入图片描述
      根据不同的标签处理方式进行处理。
    4. 在Egress节点,通过查询ILM表指导MPLS报文的转发。
      根据ILM表获得标签操作类型,同时处理EXP和TTL。
      如果标签中s=1,表示此标签是栈低标签,进行IP转发。
      如果标签中s=0,表示还有下一层标签,进行标签转发。
      在这里插入图片描述

    5. 配置静态LSP

    在这里插入图片描述

    • 在静态LSP环境中,只需要ingress节点上存在到达FEC目的地址的路由即可,transit和egress节点无需存在到达FEC目的地址的路由。
      此时在 ingress节点上 去往FEC目的地址的 tunnel ID 不为0x0,所以进行MPLS转发.

    6. 动态LSP

    6.1 LDP标签分发协议

    LDP支持TPC/UDP646端口。
    LDP只能为IGP分配标签,不能为BGP分配标签,MP-BGP能为BGP分配标签。RSVP协议也能分配标签。

    LDP的特点:倒数第二跳弹出

    • 标签对于最后一跳路由器来说已经没有用了,需要查多次表,为了减少最后一跳路由器的压力,最后一跳路由器为其直连的路由分配标签都为3。
    • 当倒数第二跳收到标签报文进行查表转发时,看到出标签为3,弹出标签转发给最后一跳路由器,最后一跳路由器收到报文之后进行ip层面路由转发。

    生成标签转发表

    1. 运行LDP协议,为每条路由产生标签。建立LDP邻居关系。
    2. 下游向上游传递标签。
    3. 根据IP路由表找出最优的路由加入标签转发表。

    6.2 LDP的报文类型

    6.2.1 ldp头部

    • version:版本1
    • pdu length:长度
    • lsr-id:由lsr-id地址大的一方发起TCP连接
    • label space ID:标签空间,默认为0,表示支持全局标签空间,为每一个接口分配相同的标签。为1表示支持接口标签空间,为每一个接口分配不同的标签。

    6.2.2 LDP的消息类型

    • discovery message:发现消息,用来发现网络中LSR的存在
      • Hello报文:LDP发现机制中宣告本LSR并发现邻居。带有LSR-ID字段。基于UDP,其他报文都是TCP。5s周期,15s超时。目的地址224.0.0.2
    • Session message:会话消息,建立、维护和终止LDP Peers之间的LDP Session
      • Initialization报文:初始化消息。进行参数的协商。类似BGP的open
        协商keepalive老化时间等。
      • KeepAlive报文:用来维护邻居关系。
    • Advertisement:通告消息,生成、改变和删除FEC的标签映射。
      • address:宣告接口地址
      • address withdraw:撤销接口地址
      • Label Mapping:来宣告FEC/Lable映射信息,
      • Label Request:请求FEC的标签映射
      • label abort request:终止未完成的label request报文
      • label withdraw:标签撤销
      • label release :释放标签
    1. Notification message:错误消息,宣告告警和错误信息。
      Notification:错误通告。

    6.3 LDP的邻居发现机制

    1. 本地邻居建立
      通过hello报文与直连的邻居建立
    2. 源端邻居建立
      通过手工建立与非直连的设备建立邻居
    全局视图下 
    mpls ldp remote-peer huawei    #和huawei建立远端邻居
    remote-ip 3.3.3.3              #远端地址为3.3.3.3
    display mpls ldp session all   #查看邻居是否建立成功,状态为Operational成功。
    

    6.4 LDP的邻居状态机

    1、non-existent:开始由地址大的一方发起进行TCP连接。连接成功进入initialized状态
    2、initialized:选举主动方和被动方。比较两端的LSR-ID越大越优先
                            主动方发送init消息进入opensent状态。
                            被动方收到init消息协商成功进入openrec状态。并发送init和KeepAlive消息。
    3、opensent:主动方收到被动方的init消息和keepalive消息进入openrec状态。
    4、openrec:收到对方的KeepAlive回应消息直接进入Operational状态。
    5、Operational:邻居建立成功。
    

    期间收到Notification消息都会返回non-existent状态

    6.5 LDP的标签管理

    6.5.1 标签分发模式

    • DU(下游自主)有标签就往上游传递。缺省工作在DU
    • DOD(下游按需)上游请求下游标签,下游回复标签。有需求才会发送。

    6.5.2 标签控制模式

    • independent:独立的标签控制方式。不管下游有没有回复标签,都给上游回复标签。
    • Ordered:有序的标签控制方式。只有从下游收到标签才能给上游回复标签。

    6.5.3 标签分发和控制组合

    • DOD+Ordered:向下游请求标签,下游必须通过它的下游邻居获得标签才能发送标签给上游传递。
    • DOD+independent:向下游请求标签,下游邻居不管有没有从它的下游邻居收到标签,都会回复标签。
    • DU+Ordered:只有收到下游通告的标签才会向上游通告标签。默认
    • DU+Independent:即使没有获得下游通告的标签,也会给上游通告标签。

    6.5.4 标签保留模式

    • Conservative保守保留模式:保守的标签保持方式。从多个方向收到下游标签只保留最优标签。对拓扑响应慢,节约标签在这里插入图片描述LSR-A工作在保守保留模式,对于LSR-B通告的FEC为172.16.1.0/24的标签生成下一跳为LSR-B的LSP,来此LSR-C的标签通告不被保留,当RA和RB之间链路Down掉之后,RA不会很快生成下一跳为RC的FEC为172.16.1.0/24的LSP
    • Liberal自由保留模式:自由的标签保持方式。从多个方向收到下游标签都保留。对拓扑响应较快,浪费标签。默认
      在这里插入图片描述LSR-A工作在自由保留模式,对于LSR-B通告的FEC为172.16.1.0/24的标签生成下一跳为LSR-B的LSP,来此LSR-C的标签通告将被保留,当RA和RB之间链路Down掉之后,RA重新生成下一跳为RC的FEC为172.16.1.0/24的LSP

    6.5.5 标签通告原则

    • 路由器默认只会为32位的主机路由分配标签。
      • 通过在MPLS视图下,敲 lsp-target all 给所有路由分配标签,也可以跟策略。
    • 设备产生标签和FEC的映射都会通告给自己的所有LDP邻居

    7. MPLS-VPN

    7.1 MPLS-VPN基本模型构成

    • CE:连接用户站点的设备
    • PE:运营商边缘设备
    • P:负责MPLS转发的运营商设备
    • site:用户站点,通过CE连接

    在这里插入图片描述

    7.2 控制层面路由传递问题

    1. 多个CE背后的site–本地PE出现地址重叠问题,就是运营商如何为不同客户且客户内网IP网段相同的提供转发服务,即如何在同一台PE区分不同VPN的相同路由?
      解决方法:通过VPN实例与接口绑定解决,将来自不同CE的私网路由放到不同的vrf表。VRF(VPN路由转发表)=VPN实例,这样PE拥有公网路由表和多个vrf表。
      配置 ip vpn-instance 1

    2. 本端PE—对端PE之间传递路由,将多个CE传递来的私网路由引入到BGP中出现路由传播的问题,传播过程中无法区分重叠的路由。
      解决方法: PE之间使用MP-BGP(Multiprotocol Extensions for BGP-4,BGP-4的多协议扩展)来发布VPN路由,并使用VPN-IPv4地址族来解决是BGP无法区分不同VPN中相同的IP地址前缀的问题。
      BGP的UPdate消息
      path attributes: 为BGP增加新属性MP_Reach_NLRI
      支持VPNV4地址族:用64bit的RD+ipv4地址构成VPNV4的地址=96bit
      RD用于区分使用相同地址空间的IPv4前缀
      在这里插入图片描述

    #配置
    ip vpn-instance 1
     ipv4-family
       route-distinguisher 100:1     #用于传播路由时打上该RD区分重叠路由。
    interface e0/0/0
       ip binding vpn-instance 1	 #在连接CE的接口下绑定该vpn instance 
    bgp 100
       ipv4-family vpn-instance 1
     		import-route ospf 10	#然后在将CE私网路由引入BGP时为其打上RD构成VPNV4地址在MPBGP中传递
    
    1. 对端PE–对端CE无法区分VPNV4路由装入哪个VRF表,即无法区分vpn路由对应对端哪个分部CE上。
      解决方法:使用32位的BGP扩展团体属性-VPN Target(也称为Route Target)来控制VPN路由信息的发布。

    RT:每个VPN实例关联一个或多个VPN Target属性。有两类VPN Target属性

    • Export Target:本地PE从直接相连site学到IPv4路由后,转换为VPN IPv4路由,并为这些路由设置Export Target属性。Export Target属性作为BGP的扩展团体属性随路由发布。
    • Import Target:PE收到其它PE发布的VPN-IPv4路由时,检查其Export Target属性。当此属性与PE上某个VPN实例的Import Target匹配时,PE就把路由加入到该VPN实例的路由表。
      在这里插入图片描述

    为什么使用VPN Target而不直接用RD作为BGP扩展团体属性的原因在于:

    • 一条VPN-IPv4路由只能有一个RD,但可以关联多个VPN Target属性;BGP如果携带多个扩展团体属性,可以提高网络的灵活性和可扩展性。
    • VPN Target用于控制同一PE上不同VPN之间的路由发布。即,同一PE上的不同VPN之间可以设置相同的VPN Target来实现路由的互相引入。

    配置:

    ip vpn-instance 1
     ipv4-family
      route-distinguisher 100:1
      vpn-target 100:10 export-extcommunity
      vpn-target 100:10 import-extcommunity
    interface Ethernet0/0/0
     ip binding vpn-instance 1
     ip address 13.1.1.3 255.255.255.0  
    bgp 100
     ipv4-family vpnv4
      policy vpn-target			#bgp中默认有此命令,表示检查对应的RT,如果undo这条命令则不收vpnv4路由。
    

    7.3 数据层面数据转发问题

    在这里插入图片描述
    环境:路由都已经学习完成,骨干也运行了MPLS。为什么运行MPLS?因为bgp的路由黑洞。

    • 当R1 ping -a 1.1.1.1 6.6.6.6时,下一跳为R3的接口地址13.1.1.3,R3收到IP包之后目的地址为6.6.6.6,下一跳5.5.5.5进行标签转发。R4收到报文进行转发出标签为3,执行倒数第二跳弹出,传递给R5,R5收到去往6.6.6.6的数据,默认查单播路由表,没有6.6.6.6的表项,丢弃该报文。
    • 解决方法:双重标签
      mp-bgp也会为其对应fec分配一个单独的标签和vrf(vpn-instance)进行关联,封装在UPdate消息中MP_Reach_NLRI属性中发送给IBGP邻居(对端PE),对端PE有流量访问本端的fec时,压入本端通告的标签。本端当收到该标签时,弹出标签,查对应的vrf表转发。

    过程分析

    1. R3通告的update消息中,对于1.1.1.1的前缀FEC分配的标签为1025。
      在这里插入图片描述
    2. 当R6 ping -a 6.6.6.6 1.1.1.1时,报文交给R5,R5先进行1025标签的封装,然后再封装R3通告的标签进行封装。
      在这里插入图片描述
      在这里插入图片描述
      在这里插入图片描述

    3.报文到达R4进行倒数第二跳弹出,发送给R3
    在这里插入图片描述

    4.R3收到报文之后根据in label查对应的vrf表进行转发。
    在这里插入图片描述
    在这里插入图片描述
    实验拓扑

    链接:https://pan.baidu.com/s/1bC8fddxsVgTOUHCR_VRmjA
    提取码:cvwg

    7.4 CE-PE之间运行的路由协议

    在这里插入图片描述
    运行多实例OSPF,,都是区域0
    当CE-R1上将11.11.11.11路由引入到OSPF产生5类LSA,1.1.1.1是正常的ospf内部路由,当R3将这两条路由通过MP-IBGP邻居传递给R5并引入到ospf多实例20的时候,将产生2条5类的LSA通告给公司A分部的设备。在此,无法将1.1.1.1的内部路由和11.11.11.11外部路由进行区分。所以为了使路由的其他属性在MP-IBGP进行传递时不丢失,就必须在MP-BGP中携带更多属性。
    display bgp vpnv4 all routing-table 6.6.6.6 32 查看详细属性
    在这里插入图片描述
    可以看到,OSPF的一些属性被放到扩展团体属性里携带。
    1、ospf domain-id 0.0.0.0:0
    如果两边domainID一样,会认为MPLS域是区域0,超级骨干区域,
    ospf三级架构

    • 超级骨干区域
    • 骨干区域
    • 非骨干区域

    修改domain-id配置
    ospf 2 进程下
    domain-id 2
    domain-id不一样,PE会将ospf路由以5类方式注入到CE。

    cisco domainID默认是进程号
    华为默认doamin-id都是0.
    封装在扩展团体属性中。

    2、ospf RT(router type):
    0.0.0.0:1:0 对应
    区域号:lsa类别:度量类型

    1类LSA,类别是1。根据类别还原到对应的LSA。最多还原成3类LSA

    3、ospf router-id:可携带也可不携带,因为3类LSA通告者也是这台PE。

    多实例OSPF
    在这里插入图片描述
    CE与PE之间运行OSPF,进程不一样,都是区域0。
    按照正常逻辑来讲,R1学到6.6.6.6的路由是R3通过将BGP引入到OSPF而学到的。学到的路由应该是o_ase的
    但是在路由表中却是普通的OSPF路由。在这里插入图片描述
    什么原因呢?

    • 在MPLS-VPN网络中,连接MPLS骨干网的CE与PE之间运行OSPF并且都是area 0的情况下,MPLS区域会被认为是一个超级骨干区域。超级骨干区域只是由MP-IBGP负责传递路由。R5和R3称为ABR,发送3类LSA。
    • 通过在ospf 20中有关6.6.6.6的1类LSA,引入到vpn-instance 1中进行传递,即使两个站点的OSPF配置成了一个区域,也无法沟通拓扑,只能沟通路由,在ospf中直接沟通路由的只有3类LSA和5类LSA,也就是说通过MP-IBGP传递的路由最多能还原成3类LSA。
      在这里插入图片描述
      在这里插入图片描述
      当收到的domain-id不一样的时候,以5类LSA注入
      在这里插入图片描述
      在这里插入图片描述

    什么时候是三类LSA,和5类LSA?

    • domain-id一样的情况下,认为mpls区域是超级骨干区域,以三类形式
    • domain-id不一样,以5类形式注入,
    • 从ce收到5类LSA时,以5类注入。
    • 当连接CE区域是NSSA区域时,以7类形式注入

    7.5 ospf sham-link(伪链路,后门链路)

    在这里插入图片描述
    通过在CE之间拉一条低速的专线,用于当运营商网络down掉之后走低俗链路。但是A总和A分建立邻居之后选路会直接走低速链路,因为通过R3传递而来的是3类LSA,R1通过R6直接获得了1类LSA。

    需求:当运营商DOWN之后再走低俗链路。通过sham-link解决。类似于虚连接,将R3和R5也宣告进ar 0。然后修改CE之间的cost值大于运营商。
    shamlink的作用就是抑制ospf路由而使bgpvpnv4路由生效。

    1. 首先R1和R6配置接口地址
      R1将其宣告进OSPF10 area 0,R6将其宣告进ospf 20 area 0。邻接建立成功
      在这里插入图片描述
    2. 然后在R3和R5上配置sham-link地址,必须是32位。
      然后将其绑定到vrf表中。
      在这里插入图片描述
    3. 然后将sham-link地址network进bgp的vpn-instance实例中。通过MP-BGP传递Sham-link地址给对方。
      配置伪连接时,伪连接端点地址的路由不能通过私网的OSPF进程发布到对端PE上。如果伪连接端点地址的路由通过私网的OSPF进程发布到对端PE上,则对端PE将同时存在两条到该伪连接端点地址的路由。其中一条是通过私网OSPF学习到的,另一条是通过MP-BGP学习到的。OSPF路由比BGP路由优先级高,对端PE错误地选择了OSPF路由,所以伪连接无法建立成功。
      在这里插入图片描述
    4. 查看vrf表获得对端sham-link地址。
      在这里插入图片描述
    5. R3在ospf进程10的area 0下启动sham-link,R5在ospf进程20的area 0下启动sham-link
      在这里插入图片描述
    6. 查看邻居状态
      在这里插入图片描述
    7. R1和R6修改ospfcost值大于运营商。此时在tracert 测试R1走运营商,当运营商接口down之后,直接走R6。
      在这里插入图片描述

    7.6 MPLS-VPN的DOWN位防环

    在这里插入图片描述
    R4会将R5的5.5.5.5的路由通过MP-IBGP传递给R1和R2,R1和R2都会以3类LSA形式注入到OSPF10的区域0中。那么R1和R2会相互收到对方传递的3类LSA并且接受计算。当运营商down掉之后,R1会走R2,R2会走R1。
    通过在3类LSA的option中设置down位置位,如果PE接收到的3类LSA中携带了Down位,则不计算。
    在这里插入图片描述
    此时当R5引入了一条直连路由,R4将5类LSA通过MP-IBGP传递给R1和R2,R1和R2以5类LSA形式注入。那么R1和R2都会相互收到对方发送的5类LSA。也可能产生环路,通过PE在将MP-IBGP路由还原成ASE LSA时,产生一个VPN tag携带在ASE LSA 的tag字段中,如果PE收到的ASE LSA中tag字段和本地tag一样则不计算。
    在这里插入图片描述

    8. MPLS解决BGP的路由黑洞

    在这里插入图片描述

    • 首先正常情况下R3会出现路由黑洞,所以在AS200内做MPLS转发域。
    • R2和R4使用环回口建立IBGP邻居
    • 当R1的1.0流量去往R5的5.0的流量通过R2,R2去往5.0的路由下一跳为4.4.4.4,通过查LFIB查看out label为1024,压入1024标签发送给R3,R3收到之后看到1024标签是本地为4.4.4.4的路由分发的int label,其对应的out label是3,原因是R4为其直连的4.4.4.4分发的PHP倒数第二跳标签。R3执行第二跳弹出,将纯IP包发送给R4,R4收到之后查看其目的地址为5.5.5.5,查路由表进行转发。
      R2收到R3分配的标签
      在这里插入图片描述
      R3收到R4分配的标签
      在这里插入图片描述
      在这里插入图片描述
    • BGP路由黑洞,中间3台路由器.
    • 两端通过物理接口建立IBGP邻居,做MPLS还是会有问题。
    • 首先正常情况下R3会出现路由黑洞,所以在AS200内做MPLS转发域。因为R3和两端都直连,R2和R4使用互联R3的接口建立的IBGP邻居关系,那么当R1的1.0流量去往R5的5.0的流量通过R2,R2去往5.0的路由下一跳为34.1.1.4,因为R4的34.1.1.4的网段是24位的,不是32位的,并且R3与34.1.1.0/24网段是直连的,路由器会为其直连的路由分配PHP倒数第二跳标签3。R2看到下一跳34.1.1.4的out label标签为3,则执行标签弹出发送给R3,R3收到之后是纯ip包,查路由表没有R5的5.5.5.5的路由则丢弃。此时路由和没做MPLS一样
      R2收到R3分发的标签
      在这里插入图片描述
      在这里插入图片描述
    展开全文
  • 多协议标签交换MPLS详解。


    image-20211129233049665

    • MPLS:互联网建议标准。
    • 多协议:在MPLS的上层可以采用多种协议。
    • 标签:MPLS利用面向连接技术,使每个分组携带一个叫做标签的小整数。标签交换路由器用标签值检索转发表,实现分组的快速转发。

    MPLS特点:

    • MPLS井没有取代IP,而是作为一种IP增强技术。
    • 特点:
      1. 支持面向连接的服务质量;
      2. 支持流量工程,平衡网络负载;
      3. 有效地支持虚拟专用网VPN。

    4.9.1 MPLS的工作原理

    image-20211129233611190

    • 当网络很大时,查找路由表要花费很多时间。
    • 在出现突发通信时,缓存会溢出,引起分组丢失、传输时延增大和服务质量下降。

    1. MPLS基本工作过程

    MPLS特点:

    1. 在MPLS域的入口处,给每一个IP数据报打上固定长度标签。
    2. 对打上标签的数据报在第二层(链路层)用硬件进行转发。
    3. 采用硬件技术对打上标签的IP数据报进行转发称为标签交换。
    4. 可以使用多种数据链路层协议,如PPP、以太网、ATM以及帧中继等。

    MPLS协议的基本原理:

    image-20211129233836574

    MPLS域:

    • MPLS域:指该域中有许多彼此相邻的路由器, 并且所有的路由器都是支持MPLS技术的标记交换路由器LSR。
    • LSR同时具有标记交换和路由选择这两种功能。标记交换功能是为了快速转发,路由选择功能是为了构造转发表。

    MPLS的基本工作过程

    1. 找出标签交换路径LSP。

      各LSR使用标签分配协议LDP交换报文,找出和标签相对应的标签交换路径LSP。整个标签交换路径就像一条虚连接一样。

    2. 打标签,然后转发。

      • 入口节点给进入MPLS域的IP数据报打上标签(实际上是插入一个MPLS首部),按照转发表把它转发给下一个LSR。以后的所有LSR都按照标签进行转发。
      • 给IP数据报打标签的过程叫做分类。
    3. 标签对换。

      • 一个标签仅在两个LSR之间才有意义。
      • LSR要做两件事:转发,更新标记。
      • 更新标记:把入标记更换成为出标记。称之为标签对换。

      image-20211129234350695

    4. 去除标签

      • 当分组离开MPLS域时,MPLS出口节点把分组的标签去除。
      • 把IP数据报交付给非MPLS的主机或路由器。
      • 这种“由入口LS确定进入MPLS域以后的转发路径“称为显式路由选择。
      • 与互联网中通常使用的“每一个路由器逐跳进行路由选择"有着很大的区别。

    2. 转发等价类FEC

    给IP数据报打标签的过程叫做分类。

    • 第三层(网络层)分类:只使用IP首部中的源和目的IP地址等。

    • 大多数运营商实现了第四层(运输层)分类:除了要检查IP首部外,运输层还要检TCP或UDP端口号。

    • 有些运营商则实现了第五层(应用层)分类:进一步地检查数据报的内部并考虑其有效载荷。

    • 转发等价类FEC:路由器按照同样方式对待的分组的集合。

    • 按照同样方式对待含义:从同样接口转发到同样的下一跳地址,并且具有同样服务类别和同样丢弃优先级等。

    • 例如:

      1. 目的IP地址与某一个特定IP地址的前缀匹配的IP数据报;
      2. 所有源地址与目的地址都相同的IP数据报;
      3. 具有某种服务质量需求的IP数据报。

    image-20211129235013851

    FEC用于负载平衡:

    image-20211129235054419

    4.9.2 MPLS首部的位置与格式

    • MPLS不要求下层的网络都使用面向连接的技术。
    • MPLS采用封装技术:在把IP数据报封装成以太网帧之前,先要插入一个MPLS首部。

    image-20211129235220661

    1. MPLS首部的格式

    image-20211129235252633

    给IP数据报打上标记就是在以太网帧首部和IP数据报首部之间插入一个4字节的MPLS首部。

    1. 标签值(占20位),可以同时容纳高达220个流(即1048576个流)。
    2. 实验(占3位)。保留用作试验。
    3. 栈S(占1位)。在有“标签栈”时使用。
    4. 生存时间TTL(占8位),用来防止MPLS分组在MPLS域中兜圈子。

    4.9.3 新一代的MPLS

    MPLS存在的问题:

    • 控制协议(如LDP)比较复杂,扩展性差,运行维护较困难。
    • 协议LDP无法做到基于时延或带宽等要求的流量调度。
    • 为灵活地选择流量的转发路径,还需要再使用资源预留协议RSVPO。
      • RSVP的信令非常复杂,每个节点都要维护一个庞大的链路信息数据库。
      • RSVP只会选择一条最优路径,不支持等价多路径路由选择ECMP。

    1. 段路由选择协议SR

    • 新一代的MPLS:段路由选择协议SR。
    • 段:标签,是转发指令的一种标识符。
    • SR工作原理
      • 基于标签交换,但不需要使用协议LDP。
      • 由源节点为发送的报文指定路径,并将路径转换成有序的段列表 ,即MPLS标签栈,它被封装在分组首部。
      • 网络中的其他节点执行首部中的指令(即标签)进行转发。

    2. 控制器

    • 即SDN控制器。负责:
      • 收集井掌握全网的拓扑信息和链路状态信息,计算出分组应传送的整个路径。
      • 给分组分配SR标签,指明分组从源点到终点的路径。

    SR向IPv6演进,这就是SRv60。SRv6直接利用IPv6字段作为标签寻址。


    参考资料:《计算机网络(第8版)》—— 谢希仁。

    展开全文
  • 目录 文章目录目录MPLSMPLS 解决了什么问题?MPLS 的术语MPLS 的协议头MPLS 的...MPLS(Multi-Protocol Label Switching,多协议标签交换)是一种 IP 骨干网技术。MPLS 在无连接的 IP 网络上引入面向连接的标签交...
  • MPLS(多协议标签交换

    千次阅读 2018-09-24 12:52:22
    1.MPLS的原理是什么? MPLS是利用标记(label)进行数据转发的。当分组进入网络时,要为其分配固定长度的短的标记,并将标记与分组封装在一起,在... 2)LSR(Label Switched Router)标签交换路由器 3.什么是L...
  • 计算机网络 多协议标记交换 MPLS

    千次阅读 2020-12-11 12:36:58
    IETF于1997年成立了 MPLS 工作组,开发出一种新的协议——多协议标记交换 MPLS (MultiProtocol Label Switching)。 “多协议”表示在 MPLS 的上层可以采用多种协议,例如:IP,IPX;可以使用多种数据链路层协议,...
  • 电路交换原理和分组交换原理

    千次阅读 2020-06-13 11:11:22
    基于电话网的交换原理 网络资源比如宽带被分片 路复用(Multiple Access) 分片分配到会话 分片没有被会话使用的情况下,分片空载 (不共享) 电路级性能(有保证) 要求呼叫建立–建立一个专门的端到端线路...
  • LSP连通性检测工作原理 ping lsp tracert lsp LSP连通性检测工作原理 RFC4379:MPLS PING/MPLS TRANCEROUTE,使用UDP封装,UDP目的端口3503,ICMP request报文中携带目的FEC字段实现对LSP的跟踪检测,MPLS标签...
  • 多协议标志交换(MPLS)基本原理

    千次阅读 2008-04-15 10:06:00
    1.多协议标志交换(MPLS)技术的提出 Internet业务量的飞速增长以及宽带技术的不断出现,对Internet服务提供商(ISP)的网络带宽提出了严峻的挑战。这种挑战不仅是对高带宽的要求,也是对目前Internet所基于的传统路由...
  • MPLS(英语:Multi-Protocol Label Switching,缩写为MPLS) 多协议标签交换 90年代初,互联网流量快速增长,而由于当时硬件技术的限制,采用的不是硬件,而是采用软件去转,路由器采用最长匹配算法逐跳转发数据包,...
  • MPLS多标签分发协议概述及实验配置

    千次阅读 2019-03-14 21:42:39
    MPLS多标签分发协议全称为Multi-Protocol Label Switching,其中Multi-Protocol代表其支持多种三层协议,例如IP,IPV6等,Label Switching说明了它的工作原理,即在其所承载的报文前加上标签栈,数据的转发就基于这个...
  • 二层交换机与三层交换机交换原理

    千次阅读 2018-11-23 15:35:09
    二层交换机原理 发展历程: 交换机之前为集线器,其做的是透明转发,即洪范式的转发,之后为网桥,软件式的网桥,其传输速度慢,然后出现...csma/cd:带冲突检测的载波侦听路访问技术,其侦听总线是否有数据传...
  • MPLS协议原理与配置详解

    千次阅读 2021-04-26 22:11:35
    多协议标签交换MPLS(Multiprotocol Label Switching ),MPLS在无连接的IP网络上引入面向连接的标签交换概念,将第三层路由技术和第二层交换技术相结合,充分发挥了IP路由的灵活性和二层交换的便捷性 MPLS并不是一种...
  • 详谈-MPLS的基础和工作原理

    万次阅读 多人点赞 2018-12-02 22:59:56
    (Multple Protocol Label Switching)多协议标签交换---ISP使用 以前的路由器需要1.查询路由表--要知道从哪个接口出去,  2.查询 ARP表 可以知道要打上什么mac地址  这样来看路由器的工作效率有点低,于...
  • 生成树协议原理

    万次阅读 多人点赞 2018-08-23 16:03:22
    STP是工作在OSI第二层(Data Link Layer)的协议。 STP协议通过在交换机之间传递特殊的消息并进行分布式的计算,来决定在一个有环路的网络中,某台交换机的某个端口应该被阻塞,用这种方法来避免掉环路 2.2 ...
  • MQTT协议简介及协议原理

    千次阅读 2019-09-18 09:39:30
    MQTT(Message Queuing Telemetry Transport,消息队列遥测传输协议),是一种基于发布/订阅(publish/subscribe)模式的“轻量级”通讯协议,该协议构建于TCP/IP协议上,由IBM在1999年发布。MQTT最大优点在于,...
  • Java 学习路线

    万次阅读 多人点赞 2018-01-06 13:21:35
    对于入门java将近两年的时间,曾经迷惘过,一直想知道java的具体学习路线,看过了许许多的java经验分享的帖子,评论,以及其他各种培训机构所谓的学习路线,发现没有一个符合我个人需求的学习路线,根据个人实际的...
  • 前端面试题(持续更新中)

    万次阅读 多人点赞 2019-11-06 17:16:33
    响应内容实体 10.HTTP协议工作原理? HTTPS在传输数据之前需要客户端(浏览器)与服务端(网站)之间进行一次握手,在握手过程中将确立双方加密传输数据的密码信息,通常情况下会配合数字证书实现。 13.ajax的同步...
  • 前端面试锦集

    千次阅读 多人点赞 2019-07-20 13:41:45
    ajax的工作原理: 通过XmlHttpRequest对象来向服务器发出异步请求,从服务器获得数据,然后用Javascript来操作DOM而更新页面 Ajax优势: 页面无刷新,在页面内与服务器通信,给用户的体验非常好 使用异步方式与...
  • 如果页面浮动布局,就要增加很空div,让人感觉很不好 3,父级div定义 伪类:after 和 zoom 原理:IE8以上和非IE浏览器才支持:after,原理和方法2有点类似,zoom(IE转有属性)可解决ie6,ie7浮动问题 优点:浏览器...
  • 前端面试题

    万次阅读 多人点赞 2019-08-08 11:49:01
    请尽可能详尽的解释ajax的工作原理 100 、为什么扩展javascript内置对象不是好的做法? 100 什么是三元表达式?“三元”表示什么意思? 100 浏览器标准模式和怪异模式之间的区别是什么? 100 modulo(12,5)//...
  • 路由器和交换机的工作原理

    千次阅读 2020-05-20 18:18:57
    路由器的工作原理 路由器的工作过程: 路由器的作用及工作原理 1)信息传输:路由转发 一个数据包进入路由器时,路由器先对其解封装到数据链路层以查看它的目标mac地址,然后再根据该目标mac地址判断是否进行下一步...
  • RFID学习笔记

    千次阅读 多人点赞 2017-06-06 13:18:46
    技术简介:  射频识别技术RFID(Radio Frequency ...可用于识别高速运动物体并可同时识别标签,过程中无需人工干预,操作快捷方便。可工作于各种环境,实现对各类物体或设备(人员、物品)在不同状态(移
  • MPLS协议原理与配置

    千次阅读 2020-04-19 14:53:56
    MPLS:(Multi-Protocol Lable Switching的缩写)多协议标签交换:是一种在开放的通信网上利用标签引导数据高速、高效传输的新技术。协议的含义是指MPLS不但可以支持多种网络层层面上的协议,还可以兼容第二层的...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 24,124
精华内容 9,649
关键字:

多协议标签交换的工作原理