精华内容
下载资源
问答
  • 路由器之间通过串口连接,DCE端连接在R1上,需要配置其时钟频率64000。 配置交换机S3560:其中VLAN10用于连接校园网主机,VLAN20用于连接R1。 (1)先划分基于接口的VLAN10和VLAN20,VLAN10端口成员(f0/10),...

    实验环境配置

    PC 2台;Switch_3560 1台;Router-PT 2台;直连线;交叉线;DCE 串口线

    实验步骤

    1. 新建拓扑图

    在这里插入图片描述
    主机和交换机通过直连线,主机与路由器通过交叉线连接。路由器之间通过串口连接,DCE端连接在R1上,需要配置其时钟频率64000。

    在这里插入图片描述

    1. 配置交换机S3560:其中VLAN10用于连接校园网主机,VLAN20用于连接R1。

    (1)先划分基于接口的VLAN10和VLAN20,VLAN10端口成员(f0/10),VLAN20端口成员(f0/20),

    switch(config)#int vlan 10
    switch(config-if)#exit
    switch(config)#int vlan 20
    switch(config-if)#exit
    switch(config)#int f0/10
    switch(config-if)#switchport access vlan 10
    switch(config)#int f0/20
    switch(config-if)#switchport access vlan 20
    

    (2)验证,显示VLAN信息

    在这里插入图片描述

    1. 配置VLAN10的IP地址:192.168.1.1 255.255.255.0,配置VLAN20的IP地址:192.168.3.1 255.255.255.0
    switch(config)#int vlan 10
    switch(config-if)#ip address 192.168.1.1 255.255.255.0
    switch(config-if)#no shutdown
    

    vlan 20 操作同上

    1. (1)配置路由器R1:
      配置 fa 0/0的ip地址 192.168.3.2 255.255.255.0,配置 serial 2/0的ip地址192.168.4.1 255.255.255.0和时钟频率64000。
    switch(config-if)#clock rate 64000
    

    (2) 配置RIP路由:

    switch(config)#router rip
    switch(config)#network 192.168.3.0
    switch(config)#network 192.168.4.0
    switch(config)#version 2
    
    1. (1)配置路由器R2:
      配置 fa 0/0的ip地址 192.168.2.1 255.255.255.0,配置 serial 2/0的ip地址192.168.4.2 255.255.255.0。

    (2) 配置RIP路由:

    switch(config)#router rip
    switch(config)#network 192.168.2.0
    switch(config)#network 192.168.4.0
    switch(config)#version 2
    

    在这里插入图片描述

    1. 配置交换机S3560 RIP路由(进入全局配置模式)
    switch(config)#router rip
    switch(config)#network 192.168.1.0
    switch(config)#network 192.168.3.0
    switch(config)#version 2
    

    遇到 IP routing not enabled 这种情况
    采用以下解决方案:

    switch(config)#router rip
    switch(config-router)#exit
    switch(config)#router rip
    switch(config-router)#
    

    验证

    测试PC1和PC2之间是否相通
    需要等待30s 验证结果

    在这里插入图片描述

    展开全文
  • 路由器的ospf动态路由配置

    一,实验步骤

    1. 接线方式

    放置一台3560交换机、两台Generic路由器和两台PC机,交换机和路由器用交叉线连接,路由器和路由器之间用DCE串口线连接,交换机和一台PC机之间用直通线连接,路由器和另一台PC机用交叉线连接。Pc机相关设置如下图:

    PC机1

    PC机2

    实验拓扑图如下:

    2,交换机3960设置

    创建并划分vlan2 vlan3

    Switch>

    Switch>en

    Switch#configure t

    Switch(config)#vlan 2

    Switch(config-vlan)#exit

    Switch(config)#vlan 3

    Switch(config-vlan)#exit

    Switch(config)#interface fastEthernet 0/1

    Switch(config-if)#sw ac vlan 2

    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#sw ac vlan 3

    Switch(config-if)#exit

    给vlan2和vlan3设置默认网关和子网掩码

    Switch(config)#interface vlan 2

    Switch(config-if)#ip address 192.168.1.1 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#interface vlan 3

    Switch(config-if)#ip address 192.168.2.1 255.255.255.0

    Switch(config-if)#exit

    Switch(config)#interface fastEthernet 0/2

    Switch(config-if)#no shut

    Switch(config-if)#exit

    发布路由

    Switch(config)#router ospf 1

    Switch(config-router)#network 192.168.1.0 0.0.0.255 area 0

    Switch(config-router)#network 192.168.2.0 0.0.0.255 area 0

    实验完成之后返回用户模式

    Switch>

    Switch>show ip route

    3,路由器r1设置

    Router>

    Router>en

    Router#configure t

    打开路由器0/0端口并设置IP地址和子网掩码

    Router(config)#interface fastEthernet 0/0

    Router(config-if)#no shut

    Router(config-if)#ip address 192.168.2.2 255.255.255.0

    Router(config-if)#exit

    打开路由器serial 2/0端口并设置默认网关和子网掩码

    Router(config)#interface serial 2/0

    Router(config-if)#no shut

    Router(config-if)#ip address 192.168.3.1 255.255.255.0

    Router(config-if)#clock rate 64000

    Router(config-if)#exit

    Router(config)#route ospf 1

    Router(config-router)#network 192.168.2.0 0.0.0.255 area 0

    Router(config-router)#network 192.168.3.0 0.0.0.255 area 0

    Router#show ip route

    4,路由器r2设置

    Router>

    Router>en

    Router#configure t

    打开路由器0/0端口并设置默认网关和子网掩码

    Router(config)#interface fastEthernet 0/0

    Router(config-if)#no shut

    Router(config-if)#ip address 192.168.4.1 255.255.255.0

    Router(config-if)#exit

    Router(config)#interface serial 2/0

    Router(config-if)#no shut

    Router(config-if)#ip address 192.168.3.2 255.255.255.0

    Router(config-if)#clock rate 64000

    Router(config-if)#exit

    发布路由

    Router(config)#route ospf 1

    Router(config-router)#network 192.168.4.0 0.0.0.255 area 0

    Router(config-router)#network 192.168.3.0 0.0.0.255 area 0

    Router>show ip route

    5,点击pc1机run调出命令提示行输入Ipconfig 查看自己的信息,在输入ping192.168.4.2看两台pc机之间能否进行正常的数据交流。

    6,实验结果

    在run界面中运行结果如下:

    实验结果:

    路由器中show ip route 结果:

    实验证明两台pc机之间是互通的。

    四、实验总结

    在本次实验中,用软件Cisco Packet Tracer配置路由器的OSPF动态路由,OSPF开放式最短路径优先协议是目前网路中应用最广泛的路由协议之一,最终得出实验结论:两台pc机之间是可以互通的。对比于上次实验我们可以知道RIP快于OSPF,OSPF不限定节点个数,每30秒发布一次路由信息,配置生效时间长,第一次实践操作路由器的OSPF动态路由配置,还存在许多问题,例如:在实验中,由于对IP地址的设置错误导致实验无法得出正确结果,最后用标注注明IP和连接的网关,以防实验过程中出现错误,以上问题通过询问同学和老师都能够解决。希望在以后实验中能够更加熟练的使用此软件。

    展开全文
  • 本文实例讲述了思科路由器静态路由配置实验。分享给大家供大家参考,具体如下:实验八 路由器静态路由配置一、实验...每个校区出口利用一台路由器进行连接,两台路由器间学校申请了一条2M的DDN专线进行相连,要求...

    本文实例讲述了思科路由器静态路由配置实验。分享给大家供大家参考,具体如下:

    实验八 路由器静态路由配置

    一、实验目标

    掌握静态路由的配置方法和技巧;

    掌握通过静态路由方式实现网络的连通性;

    熟悉广域网线缆的链接方式;

    二、实验背景

    学校有新旧两个校区,每个校区是一个独立的局域网,为了使新旧校区能够正常相互通讯,共享资源。每个校区出口利用一台路由器进行连接,两台路由器间学校申请了一条2M的DDN专线进行相连,要求做适当配置实现两个校区的正常相互访问。

    三、技术原理

    路由器属于网络层设备,能够根据IP包头的信息,选择一条最佳路径,将数据包转发出去。实现不同网段的主机之间的互相访问。路由器是根据路由表进行选路和转发的。而路由表里就是由一条条路由信息组成。

    生成路由表主要有两种方法:手工配置和动态配置,即静态路由协议配置和动态路由协议配置。

    静态路由是指有网络管理员手工配置的路由信息。

    静态路由除了具有简单、高效、可靠的优点外,它的另一个好处是网络安全保密性高。

    缺省路由可以看做是静态路由的一种特殊情况。当数据在查找路由表时,没有找到和目标相匹配的路由表项时,为数据指定路由。

    四、实验步骤

    新建packet tracer拓扑图

    (1)在路由器R1、R2上配置接口的IP地址和R1串口上的时钟频率;

    (2)查看路由器生成的直连路由;

    (3)在路由器R1、R2上配置静态路由;

    (4)验证R1、R2上的静态路由配置;

    (5)将PC1、PC2主机默认网关分别设置为路由器接口fa 1/0的IP地址;

    (6)PC1、PC2主机之间可以相互通信;

    五、实验设备

    pc 2台;Router-PT可扩展路由 2台(Switch_2811无V.35线接口);Switch_2960 2台;DCE 串口线;直连线;交叉线

    六、实验拓扑图

    b273b5487fa06ddd0cc2863dd2874c17.png

    七、实验命令

    PC1

    IP: 192.168.1.2

    Submask: 255.255.255.0

    Gateway: 192.168.1.1

    PC2

    IP: 192.168.2.2

    Submask: 255.255.255.0

    Gateway: 192.168.2.1

    R1

    en

    conf t

    hostname R1

    int fa 1/0

    no shut

    ip address 192.168.1.1 255.255.255.0

    exit

    int serial 2/0

    no shut

    ip address 192.168.3.1 255.255.255.0

    clock rate 64000(必须配置时钟才可通信)

    end

    R2

    en

    conf t

    hostname R2

    int fa 1/0

    no shut

    ip address 192.168.2.1 255.255.255.0

    exit

    int serial 2/0

    ip address 192.168.3.2 255.255.255.0

    no shut

    end

    R1

    en

    conf t

    ip route 192.168.2.0 255.255.255.0 192.168.3.2

    end

    show ip route

    R2

    en

    conf t

    ip route 192.168.1.0 255.255.255.0 192.168.3.1

    end

    show ip route

    八、实验结果

    配置PC0、PC1的IP地址:

    d4fe3f81108796667abc73f8d7f7d68e.png

    d6a4f5809f029b8896ddf55569b942d1.png

    配置R1,R2接口的IP地址和R1串口上的时钟频率:

    2b0fffd1b3f8e8a250ccbb538defb125.png

    28db06247680167cf509e94720b2b529.png

    在路由器R1、R2上配置静态路由,验证R1、R2上的静态路由配置

    53b88aef6eca09a061ca34f4fb6c4bc8.png

    e5ae76335f8ba8c5c8ccdfc0d3d70ecc.png

    PC0 ping PC1:

    4ec45a71b1a1fc7e1abc69108352d1c7.png

    展开全文
  • 为了安全和便于管理对这两个部门的主机进行了VLAN的划分,技术部和销售部分别处于不同的VLAN,现在于业务的需求要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台路由器进行了连接。...

    实现目标:

    • 掌握单臂路由器的配置方法
    • 通过单臂路由器实现不同VLAN之间相互通信

    实验背景:

    某企业有两个重要的部门,技术部和销售部,分别处于不同的办公室,为了安全和便于管理对这两个部门的主机进行了VLAN的划分,技术部和销售部分别处于不同的VLAN,现在于业务的需求要销售部和技术部的主机能够相互访问,获得相应的资源,两个部门的交换机通过一台路由器进行了连接。

    实验步骤:

    1. 新建packet tracer 拓扑图
    2. 当交换机设置两个VLAN时,逻辑上已经成为两个网络,广播被隔离了,两VLAN的网络要通信,必须通过路由器,如果接入路由器的一个物理接口,则必须有两个子接口分别与两个VLAN对应,同时还要求与路由器相连的交换机的端口fa0/1 要设置track,因为这个接口要同故宫两个VLAN的数据包。
    3. 检查设备情况,应该能够正确的看到VLAN和track的信息
    4. 计算机的网关分别指向路由器的子接口
    5. 配置子接口,开启路由器物理接口
    6. 默认封装dotlq协议
    7. 配置路由器子接口IP地址

    实验设备:

    PC 2台;Router_2811 1台;Switch_2960 1台

     

    1.配置PC0:

    IP:192.168.1.2

    Submask:255.255.255.0

    Gateway:192.168.1.1

    2.配置PC1:

    IP:192.168.2.2

    Submask:255.255.255.0

    Gateway:192.168.2.1

    3.此时PC0 ping PC1 是ping不通的。

    4.配置交换机0:

    Switch>en
    Switch#conf t
    Switch(config)#vlan 2                         //添加vlan 2
    Switch(config-vlan)#exit
    Switch(config)#vlan 3                         //添加vlan 3
    Switch(config-vlan)exit	
    Switch(config)interface f0/2                  //进入交换机0模块第2端口
    Switch(config-if)switchport access vlan 2     //加入vlan 2
    Switch(config-if)exit
    Switch(config)interface f0/3                 //进入交换机0模块第3端口
    Switch(config-if)switchport access vlan 3    //加入vlan 3
    Switch(config-if)exit	
    Switch(config)inter f0/1                     //进入交换机0模块第1端口
    Switch(config-if)switchport mode trunk 	 //设置端口的工作模式为trunk
    Switch(config-if)end

    5.配置路由器0:

    Router>en
    Router#config t
    Router(config)#int fa 0/0      //进入路由器0模块第0端口
    Router(config-if)#no shutdown  //开启该端口(此时路由连接交换机的端口 从block转到forward)
    Router(config-if)#exit	
    Router(config)#int fa 0/0.1    //进入路由器0模块第0端口第1虚拟子接口
    Router(config-subif)#encapsulation dot1Q 2  //封装协议设置为dot1q 允许通过的vlan 为2
    Router(config-subif)#ip address 192.168.1.1 255.255.255.0  //该子接口配置IP地址为192.168.1.1
    Router(config-subif)#exit	
    Router(config)#int fa 0/0.2    //进入路由器0模块第0端口第2虚拟子接口
    Router(config-subif)#encapsulation dot1Q 3 //封装协议设置为dot1q 允许通过的vlan 为3
    Router(config-subif)#ip address 192.168.2.1 255.255.255.0 //该子接口配置IP地址为192.168.2.1
    Router(config-subif)#end
    Router#show ip route          //查看路由表

    6.配置完成后,我们发现,原来交换机和路由器的连线上的点变成了绿色并闪烁,此时,我们用PC0 ping PC1,是可以ping通的。

    本实验主要是要让我们学会如何根据需求配置路由器单臂路由,实现不同VLAN之间的数据通信。

    展开全文
  • 一、实验目的掌握动态路由配置方法;理解RIP和OSPF协议的工作过程。二、实验拓扑图及详细设备三、实验内容及步骤1、实验设备说明本实验用到了三台路由器,三台交换机,3PC,一ServerIP地址分别如下:PC1:192....
  • 我们要想实现一个网段到另一个网段互相通信,就需要在路由器设置路由路由分为静态路由动态路由路由器如果很少的话添加静态路由即可,如果很就不能用静态去配置了,这章先配置静态路由实现不同网段互通,...
  • 一、实验拓扑图及详细设备二、实验内容及步骤各个设备的配置截图及主要节点状态截图(尽量详细):1、实验设备说明本实验用到了三台路由器,三台交换机,3PC,一ServerIP地址分别如下:PC1:192.168.10.10/24网关...
  • 本次实验完成了路由器静态路由配置。主要步骤有建立网络拓扑、二层交换机的接口设置路由器的接口设置设置网关、路由器间串口的设置、添加静态路由)。
  • 静态路由配置实现不同网段通信——实验一 实验拓扑 PC1经过R1和R2两个路由访问PC2,两PC处于不同网段,进行通信互访,这里我们使用静态路由的方式进行模拟配置实验 1.配置R1和R2接口ip地址 R1>enable R1#...
  • eNSP动态路由配置-RIP协议

    千次阅读 2021-04-27 17:10:19
    eNSP动态路由配置-RIP协议一、实验题目二、实验拓扑图三、实验内容1.配置确定2.主机配置3.配置路由器4.测试不同主机的连通性实验总结 一、实验题目 四台路由器,四台PC,实现动态路由的配置。具体实施:通过给...
  • 《实验报告OSPF动态路由配置》由会员分享,可在线阅读,更相关《实验报告OSPF动态路由配置(5页珍藏版)》请在人人文库网上搜索。1、淮海工学院计算机工程学院实验报告书课程名:网络管理技术 题 目: 动态路由...
  • 基础知识点: 1.每个主机都有IP地址,网关,子网掩码 网关是主机与外网连接的端口,网关就是与...动态路由:rip协议 Cisco Packet实验 配静态路由 先给每个端口,主句IP,记录在一边 头脑清醒, 给f4/0端口设IP,命令
  • 文章目录1、拓扑图2、R1配置3、R2配置4、R3配置 1、拓扑图 2、R1配置 进入特权模式:Router>en 进入全局模式:Router#conf t 修改设备名称:Router(config)#hostname R1 进入接口:R1(config)#int g0/0 配置ip...
  • 计算机网络实验六动态路由配置 (6页) 本资源提供全文预览,点击全文预览即可全文预览,如果喜欢文档就下载吧,查找使用更方便哦!19.90 积分计算机网络原理实验报告实验六动态路由配置 系 别:计算机科学与技术系...
  • 路由器静态路由配置

    2021-09-07 11:52:11
    每个校区出口利用一台路由器进行连接,两台路由器间学校申请了一条2M的DDN专线进行相连,要求做适当配置实现两个校区的正常相互访问。 2、技术原理: (1)路由器属于网络层设备,能够根据IP包头的信息,选择
  • 1. 掌握静态路由配置方法和技巧; 2. 掌握通过静态路由方式实现网络的连通性的方法。 三、实验设备和器材 1.安装了Windows操作系统的计算机 2. Switch_2960: 2; 3. PC:2; 4.Router-PT 可拓展路由:2...
  • 路由器的基本配置和单臂路由配置 实验目的: 题目一: 掌握路由器几种常用配置方法; 掌握采用Console线缆配置路由器的方法; 掌握采用Telnet方式配置路由器的方法; 熟悉路由器不同的命令行操作模式以及各种...
  • 2.动态配置 3.检验连通性 具体实施 实验总结 实验一 实验环境 实验思路 1. 规划并配置IP 3. 检验连通性 具体实施 规划并配置IP ##### PC1: ![在这里插入图片描述]...
  • 路由器的基本配置和单臂路由配置 实验目的 路由器的基本配置 掌握路由器几种常用配置方法; 掌握采用Console线缆配置路由器的方法; 掌握采用Telnet方式配置路由器的方法; 熟悉路由器不同的命令行操作...
  • 动态路由协议RIP配置

    2021-06-02 17:54:36
    动态路由是指网络中的路由器之间相互通信,并传递路由信息,再利用收到的路由信息,更新路由表的过程。它能实时的适应网络结构的变化。如果路由更新信息表明网络发生变化,路由选择协议就会重新计算路由,并发出新的...
  • 路由器的RIP动态路由配置
  • 目录前言一、关闭泛洪信息二、静态路由命令例题三、动态路由(一)RIP协议RIP命令例题(二)OSPF协议OSPF命令例题(单区域)例题(区域)四、查看全局路由表结语 前言 本章笔记将讲述如何配置静态路由动态路由...
  • 1. 掌握路由器的基本配置 2. 规划接口IP地址 3. 熟悉基本封装类型 4. 掌握RIP路由协议 三、实验设备和器材 1.安装了Windows操作系统的计算机 2. DCR-2650: 2 3. CR-V35MT: 1根 4.CR-V35FC: 1根 5.网线: ...
  • 路由器配置和静态路由 作者意图: 计算机网络第一次碰到让我头疼的实验,因为课程进度和实验进度不...现有两台路由器 R1 和 R2,每台路由器连接一台 PC(两台 PC 的 IP 地址分别为: 192.168.1.1 和172.16.1.1, 子网
  • 1、配置RIPv2动态路由协议,使得三台路由器所连接的网络互通。 2、对RIPv2进行版本控制。 3、观察RIP负载分担的效果。 4、配置RIPv2手工汇总。 三、实验设备 PC终端一,cisco packet tracer 软件一套。 四、实验...
  • 背景:局域网中不允许有动态分配ip的路由,想用路由器吧一个网口扩展为个网口,怎么办? 方案: 原理:把路由器当作集线器来用; 步骤: 1)将路由动态分配ip的功能关掉; 2)将路由器的广域网口用胶带封住...
  • 动态路由与RIP配置

    2021-03-19 12:22:11
    我们可以使用动态路由配置,让路由器自动学习将IP信息添加到路由表中。 一、动态路由 1.1 动态路由介绍  动态路由要基于某种路由协议实现,路由协议是路由器之间用来交换信息的语言。  特点:减少了管理任务,会...
  • 计算机网络原理实验报告?实验六?动态路由的配置系 别:计算机科学与技术系网络工程方向类 型...掌握RIP、OSPF协议路由配置三、实验器材1.华为R2811、R2831各一、PC机每组82.连接console电缆线两条、标准网线1...
  • 路由器多区域 OSPF 配置 实训三十四 路由器多区域 OSPF 配置 定义:OSPF路由协议是用于网际协议(IP)网络的链路状态路由协议。该协议使用链路状态路由算法的内部网关协议(IGP),在单一自治系统(AS)内部工作。...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 85,154
精华内容 34,061
关键字:

多台路由器动态路由配置