精华内容
下载资源
问答
  • 2022-03-12 18:27:15

    一、MSTP背景

    1、由于STP解决了环路及广播风暴相关网络问题,同时带来了收敛慢的问题,RSTP快速生成树提高了收敛时间,但是所有的VLAN都是一颗树。

    2、为了解决收敛时间问题及实现VLAN间的负载分担IEEE发布了802.1S标准MSTP

    3、MSTP兼容RSTP及STP可以构建无环路的生成树解决广播风暴及环路实现冗余备份

    二、MSTP配置

    1、拓扑及需求

    PC1与PC2分别属于VLAN10 及VLAN20

    配置实例1绑定VLAN10 ,实例2绑定VLAN20,SW1 作为实例1的主根,作为实例2的次根

    SW2 作为实例2的主根,作为实例1的次根,VLAN10数据走SW1,VLN20数据走SW2

    2、配置实现

    1)、SW1配置如下:

    vlan batch 10 20 //创建vlan10 vlan20

    interface GigabitEthernet0/0/1

    port link-type trunk

    port trunk allow-pass vlan 10 20 //交换机互联接口配trunk同时允许vlan10和vlan20通过

    更多相关内容
  • Cisco最全MSTP生成树配置手册,从基础概念开始介绍什么是生成树,然后详细分步配置(含命令)
  • ---1-49 VLAN运行一个STP生成树,这个生成树的主根桥在SW1,备份根桥在SW2; --50-100 VLAN运行另外一个生成树,这个生成树的主根桥在SW2,备份根桥在SW1 实现两个STP协议的互为主备关系,流量实现基于STP的负载...

    应用案例:

    交换网络采用双核心,核心SW1,核心SW2;拥有VLAN 100个,为了实现二层流量转发的负载均衡,需要在启用MSTP技术或者PVSTP技术,也就是说:
    ---1-49 VLAN运行一个STP生成树,这个生成树的主根桥在SW1,备份根桥在SW2;
    --50-100 VLAN运行另外一个生成树,这个生成树的主根桥在SW2,备份根桥在SW1

    实现两个STP协议的互为主备关系,流量实现基于STP的负载均衡行为


    一,配置第一步:在所有交换机启用MSTP配置,配置域名、修订号和实例与VLAN的映射关系


    核心层交换机SW1:
    spanning-tree mode mst  //启用MSTP配置
    spanning-tree mst config  //进入MSTP配置模式
      name aaa //域名要一致
      revision 1 //修订号也要一致,STP每收敛一次,修订号+1
      instence 1 vlan 100,200  //实例1里面包含VLAN 100和200( instence 1 vlan 100-200  //实例1里面包含VLAN 100到200的所有Vlan)
      instence 2 vlan 300 ,400 //实例2里面包含VLAN300和400
      exit

    注:MSTP里面实例0是个特殊实例,利用实例0和其他STP协议进行兼容,所以实列只能从1开始)

    核心层交换机sw2:

    spanning-tree mode mst
    spanning-tree mst config
      name aaa
      revision 1
      instence 1 vlan 100,200  //实例1里面包含VLAN 100和200
      instence 2 vlan 300 ,400 //实例2里面包含VLAN300和400
      exit

    接入层交换机:sw3:

    spanning-tree mode mst
    spanning-tree mst config
      name aaa
      revision 1
      instence 1 vlan 100,200  //实例1里面包含VLAN 100和200
      instence 2 vlan 300 ,400 //实例2里面包含VLAN300和400
      exit

    接入层交换机:sw4:

    spanning-tree mode mst
    spanning-tree mst config
      name aaa
      revision 1
      instence 1 vlan 100,200  //实例1里面包含VLAN 100和200
      instence 2 vlan 300 ,400 //实例2里面包含VLAN300和400
      exit


    第二步、针对实例运行STP生成树;要求:
    ---SW1作为VLAN100和VLAN200的主根桥;SW2作为VLAN100和200的备份根桥
    ---SW2作为VLAN300和400的主根桥,SW1作为VLAN300和400的备份根桥

    SW1配置:

    spanning-tree mst 1 root primary
    sapnning-tree mst 2 root secondary


    SW2配置:

    spanning-tree mst 2 root primary
    sapnning-tree mst 1 root secondary

    以上仅个人观点,如有错误,还请指出!欢迎留言讨论!感谢!

    展开全文
  • 运维开发网 ...MSTP多实例生成树协议;通过STP、RSTP协议可以实现1.逻辑上防止链路环路;2.物理上实现链路备份;通过MSTP协议不但可以实现上述两点,还可以实现负载均衡。下面我们通过实验详细讲...

    运维开发网 https://www.qedev.com

    2020-03-11 18:01

    出处:51CTO作者:爱草坪

    首先,我们弄清楚STP、RSTP、MSTP区别STP:单实例生成树协议;RSTP:快速生成树协议;MSTP:多实例生成树协议;通过STP、RSTP协议可以实现1.逻辑上防止链路环路;2.物理上实现链路备份;通过MSTP协议不但可以实现上述两点,还可以实现负载均衡。下面我们通过实验详细讲解MSTP协议,实验拓扑如下图所示实验目的:1.使PC1通过SW3的0/0/2接口访问Server1,实现负载均衡

    相关专题:交换路由首先,我们弄清楚STP、RSTP、MSTP区别

    STP:单实例生成树协议;

    RSTP:快速生成树协议;

    MSTP:多实例生成树协议;

    通过STP、RSTP协议可以实现

    1.逻辑上防止链路环路;

    2.物理上实现链路备份;

    通过MSTP协议不但可以实现上述两点,还可以实现负载均衡。

    下面我们通过实验详细讲解MSTP协议, 实验拓扑如下图所示

    实验目的:

    1.使PC1通过SW3的0/0/2接口访问Server1,实现负载均衡;

    2.使PC2通过SW3的0/0/3接口访问Server1,实现负载均衡;

    第一步,在SW1、SW2、SW3上面分别进行vlan、trunk相关配置

    SW1上面配置如下:

    [SW1]vlan batch 2 3

    [SW1]port-group 1

    [SW1-port-group-1]group-member eth0/0/1 eth0/0/2

    [SW1-port-group-1]port link-type trunk

    [SW1-port-group-1]port trunk allow-pass vlan all

    SW2上面配置如下:

    [SW2]vlan batch 2 3

    [SW2]port-group 1

    [SW2-port-group-1]group-member eth0/0/1 eth0/0/3

    [SW2-port-group-1]port link-type trunk

    [SW2-port-group-1]port trunk allow-pass vlan all

    SW3上面配置如下:

    [SW3]vlan batch 2 3

    [SW3]port-group 1

    [SW3-port-group-1]group-member eth0/0/2 eth0/0/3

    [SW3-port-group-1]port link-type trunk

    [SW3-port-group-1]port trunk allow-pass vlan all

    第二步,配置RSTP

    [SW1]stp region-configuration

    [SW1-mst-region]region-name 1806

    [SW1-mst-region]instance 1 vlan 2

    [SW1-mst-region]instance 2 vlan 3

    [SW1-mst-region]active region-configuration

    [SW1]stp instance 1 priority 4096

    [SW1]stp instance 2 priority 8192

    [SW2]stp region-configuration

    [SW2-mst-region]region-name 1806

    [SW2-mst-region]instance 1 vlan 2

    [SW2-mst-region]instance 2 vlan 3

    [SW2-mst-region]active region-configuration

    [SW2]stp instance 1 priority 8192

    [SW2]stp instance 2 priority 4096

    [SW3]stp region-configuration

    [SW3-mst-region]region-name 1806

    [SW3-mst-region]instance 1 vlan 2

    [SW3-mst-region]instance 2 vlan 3

    [SW3-mst-region]active region-configuration

    第三步,验证查看

    [SW1]dis stp brief

    MSTID Port Role STP State Protection

    0 Ethernet0/0/1 DESI FORWARDING NONE

    0 Ethernet0/0/2 DESI FORWARDING NONE

    1 Ethernet0/0/1 DESI FORWARDING NONE

    1 Ethernet0/0/2 DESI FORWARDING NONE

    2 Ethernet0/0/1 DESI FORWARDING NONE

    2 Ethernet0/0/2 DESI FORWARDING NONE

    [SW2]display stp brief

    MSTID Port Role STP State Protection

    0 Ethernet0/0/1 ROOT FORWARDING NONE

    0 Ethernet0/0/3 DESI FORWARDING NONE

    1 Ethernet0/0/1 ROOT FORWARDING NONE

    1 Ethernet0/0/3 DESI FORWARDING NONE

    2 Ethernet0/0/1 DESI FORWARDING NONE

    2 Ethernet0/0/3 DESI FORWARDING NONE

    [SW3]dis stp brief

    MSTID Port Role STP State Protection

    0 Ethernet0/0/2 ROOT FORWARDING NONE

    0 Ethernet0/0/3 ALTE DISCARDING NONE

    1 Ethernet0/0/2 ROOT FORWARDING NONE

    1 Ethernet0/0/3 ALTE DISCARDING NONE

    2 Ethernet0/0/2 ALTE DISCARDING NONE

    2 Ethernet0/0/3 ROOT FORWARDING NONE

    验证成功,对于PC1来说,所连接接口属于vlan2,对于vlan2来说SW3的 Ethernet0/0/3 是ALTE,即阻塞状态,因此PC1通过SW3的0/0/2接口访问Server1;对于PC2来说,所连接接口属于vlan3,对于vlan3来说SW3的 Ethernet0/0/2 是ALTE,即阻塞状态,因此PC2通过SW3的0/0/3接口访问Server1.

    分享到

    0

    0

    0

    展开全文
  • 多生成树MSTP的配置

    2022-04-20 21:04:27
    要求把vlan10 20 加入实例1 vlan30 40 加入实例2 网络拓扑图如下: 交换机1配置: [Huawei]vlan batch 10 20 30 40 [Huawei]int g0/0/1 [Huawei-GigabitEthernet0/0/1]port link-type trunk [Huawei-...

    配置需求:
    共有4个vlan 10 20 30 40
    要求把vlan10 20 加入实例1
    vlan30 40 加入实例2 

    网络拓扑图如下:

           

    交换机1配置:

    [Huawei]vlan batch 10 20 30 40
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port link-type trunk  
    [Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [Huawei-GigabitEthernet0/0/1]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type trunk  
    [Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    以上配置为创建VLAN并把所有端口都放行VLAN

    [Huawei]stp mode mstp         (stp模式设置为 mstp 华为交换机默认开启 mstp)
    [Huawei]stp region-configuration             (配置域)
    [Huawei-mst-region]region-name GRQ   (配置域名)
    [Huawei-mst-region]revision-level 10      (修订级别)
    [Huawei-mst-region]instance 1 vlan 10 20 (配置实例1并绑定vlan10 20)
    [Huawei-mst-region]instance 2 vlan 30 40 (配置实例2并绑定vlan30 40)  
    [Huawei-mst-region]active  region-configuration 【激活域配置(激活后才能生效)】
    以上配置要在其他交换机上保持一致

    交换机2配置:

    [Huawei]vlan batch 10 20 30 40
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port link-type trunk  
    [Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [Huawei-GigabitEthernet0/0/1]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type trunk  
    [Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [Huawei]stp mode mstp        
    [Huawei]stp region-configuration             
    [Huawei-mst-region]region-name GRQ   
    [Huawei-mst-region]revision-level 10      
    [Huawei-mst-region]instance 1 vlan 10 20 
    [Huawei-mst-region]instance 2 vlan 30 40 
    [Huawei-mst-region]active  region-configuration 
    以上配置与其他交换机保持一致

    [Huawei]stp instance 1 priority 0    (配置实例1的优先级为4096)
    [Huawei]stp instance 2 priority 4096  (配置实例2的优先级为0)
    [Huawei]stp instance 0 priority 0    (配置实例0的优先级为4096)(实例0为未加入实例的vlan,如vlan1)

    交换机3配置:

    [Huawei]vlan batch 10 20 30 40
    [Huawei]int g0/0/1
    [Huawei-GigabitEthernet0/0/1]port link-type trunk  
    [Huawei-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [Huawei-GigabitEthernet0/0/1]int g0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type trunk  
    [Huawei-GigabitEthernet0/0/2]port trunk allow-pass vlan all
    [Huawei]stp mode mstp        
    [Huawei]stp region-configuration             
    [Huawei-mst-region]region-name GRQ   
    [Huawei-mst-region]revision-level 10      
    [Huawei-mst-region]instance 1 vlan 10 20 
    [Huawei-mst-region]instance 2 vlan 30 40 
    [Huawei-mst-region]active  region-configuration 
    以上配置与其他交换机保持一致

    [Huawei]stp instance 1 priority 4096
    [Huawei]stp instance 2 priority 0   
    [Huawei]stp instance 0 priority 4096 
    以上配置与交换机2交叉
     

     在交换机1上查看配置是否正确

     如图:对于实例1来说,1号口为根端口,2号口为阻塞端口

    展开全文
  • CISCO MSTP多实例生成树

    2021-09-16 18:51:45
    拓扑图 ...层设备 SW1: spanning-tree mode mst #配置生成树模式为mst spanning-tree mst configuration #进入mst配置模式 name HWX #mst配置名称 revision 10 #修正版本号 instance 1 v.
  • 多生成树协议MSTP

    万次阅读 多人点赞 2017-10-03 12:20:54
    多生成树协议MSTP: 实验原理:由于传统生成树只是解决了单点故障问题,但是缺陷是没有解决负载分担,因此多生成树协议就是为了解决负载均衡的 实验目的:在实现网络冗余和可靠性的同时实现负载均衡(分担)...
  • MSTP多实例生成树(华为)

    千次阅读 2021-06-09 20:46:33
    多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE 802.1s中定义的生成树协议,通过生成生成树,来解决以太网环路问题。 目的 在以太网中部署MSTP协议后可实现如下功能: 形成棵无环路的树,...
  • 生成树实例弊端1.1 部分VLAN路径不通1.2 无法实现流量分担1.3 次优二层路径2. MSTP 原理 思维导图: MSTP实例生成树协议) RSTP的缺陷: RSTP在STP基础上进行了改进,实现了网络拓扑快速收敛。但由于局域网...
  • 内包含MSTP的详细解答,以及与前几代的生成树协议作对比
  • MSTP(Multiple Spanning Tree Protocol,多生成树协议),将环路网络修剪成为一个无环的树型网络,避免报文在环路网络中的增生和无限循环,同时还提供了数据转发的个冗余路径,在数据转发过程中实现 VL
  • MSTP多生成树协议

    千次阅读 2022-02-21 17:30:52
    MSTP基本定义 通过 MSTP 把一个交换网络划分成个域,每个... 每个域内形成生成树生成树之间彼此独立,每棵生成树叫做一个 MSTI(Multiple Spanning Tree Instance)。每个实例是由一个或者个vlan组成。 ...
  • 802.1S多实例生成树MSTP: RSTP和STP都存在了一个缺陷,即由于局域网内所有的VLAN共享一棵生成树,链路被阻塞后将不承载任何流量,造成带宽浪费,因此无法在VLAN间实现数据流量的负载均衡,还有可能造成部分VLAN的...
  • H3C多生成树MSTP)实验配置: 组网需求: 网络中所有设备都属于同一个MST域。SWA和SWB为汇聚层设备,SWC和SWD为接入层设备。 通过配置MSTP,使不同VLAN的报文按照不同的MSTI转发:VLAN 10的报文沿MSTI 1转发,VLA
  • 多生成树协议(MSTP

    2021-12-10 21:14:09
    MSTP主要目的是减少拓扑中产生的生成树实例的总数量,从而降低CPU的开销——将一个或者个vlan放入实例 在之前的STP,只存在一个实例,且每有一个vlan就会产生一个实例,且收敛速度很慢 之后有了RSTP,提高了生成树...
  • 文章目录一、STP(生成树协议)1、STP概述2、STP工作原理二、MSTP多生成树协议) 一、STP(生成树协议) 1、STP概述 (1)交换网络环产生的影响 广播风暴的形成:交换机之间两两互相广播,无限循环 帧复制:...
  • 二、组网拓扑:三、配置要点:开启生成树功能创建不同的实例实例配置优先级四、配置步骤:注意:配置之前建议使用 Ruijie#show interface status查看接口名称,常用接口名称有FastEthernet(百兆)、GigabitEthernet...
  • MSTP(Multiple Spanning tree Algorithm and protocol)是多生成树技术,允许在一个交换环境中运行生成树,每个生成树称为一个实例(instance)。实例时间的生成树彼此独立,如一个实例下的阻塞接口在另一个实例上...
  • 在STP中,由于STP存在次优路径等因素,我们在此实验中使用MSTP协议来完成,MSTP更好的解决的在网络中所存在的一些问题,并且MSTP还兼容STP和RSTP。 接下来我们看到配置实现: 步骤一:首先我们给PC添加P地址 ...
  • 多生成树协议MSTP实验

    千次阅读 2020-05-21 11:49:13
    多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE802.1s中定义的生成树协议,通过生成生成树,来解决以太网环路问题。 2、实验拓扑图 3、PC配置 4、交换机1配置 [SW1]vlan batch 100 ...
  • 多生成树-基本应用实例.docx
  • 本章目录一、STP(生成树协议)1、STP概述(1)交换网络环产生的影响(2)STP简介2、STP工作原理(1)生成树算法步骤(2)BPDU(桥协议数据单元)(3)交换机端口上的STP状态二、MSTP多生成树协议) 一、STP(生成...
  • MSTP多生成树协议)

    万次阅读 多人点赞 2020-05-15 22:22:53
    MSTP多生成树协议(华为交换机默认允许MSTP) 工作原理:将个VLAN捆绑在一起,运行在一个STP实例里面,不同实例间的STP互相独立 注:默认情况下所有VLAN都在实例0里面 SW1——创建VLAN <Huawei>...
  • 实验名称】多生成树协议MSTP【实验目的】在接入层和分布层交换机上配置MSTP并进行验证。【背景描述】某企业网络管理员认识到,传统的生成树协议(STP)是基于整个交换网络产生一个树形拓扑结构,所有的VLANs都共享一个...
  • 本篇文章主要记录多生成树协议MSTP的原理与配置方法,另外包括MSTP相关的生成树协议STP、快速生成树协议RSTP的简单介绍。 一、MSTP原理 1.与生成树相关的协议: (1)STP:生成树协议; (2)RSTP:快速生成...
  • MSTP区域生成树协议)

    千次阅读 2020-11-19 21:16:03
    多生成树协议MSTP(Multiple Spanning Tree Protocol)是IEEE 802.1s中定义的生成树协议,通过生成生成树,来解决以太网环路问题。 目的: 在以太网中部署MSTP协议后可实现如下功能: 形成棵无环路的树,解决...
  • 多生成树协议MSTP即能保证链路冗余备份,又能有效解决环路问题。1、 网络拓扑我们在eNSP模拟器中新建一个网络拓扑,拖入三台交换机如上图互联,模拟网络环路状态。切记,勿在真实网络环境下模拟。2、 业务需求a、 ...
  • 一.STP生成树 STP(Spanning Tree Protocol)是生成树协议的英文缩写,可应用于计算机网络中树形拓扑结构建立 1.1 主要作用 是防止网桥网络中的冗余链路形成环路工作。但某些特定因素会导致STP失败,要排除故障可能...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,618
精华内容 647
关键字:

多生成树实例mstp