精华内容
下载资源
问答
  • 数据结构实验

    2012-04-13 09:55:47
    一、实验目的 1.学会定义线性表的顺序存储类型,实现C程序的基本结构,对线性表的一些基本操作和具体的函数定义。 2.掌握顺序表的基本操作,实现顺序表的插入、删除、查找以及求并集等运算。 3.掌握对函数程序的...
  • 一、实验目的 熟悉SQL Server Management Studio界面;掌握通过图形化向导和执行Transact-SQL语句创建数据库的方法。 二、实验环境 Windows7操作系统,SQL Server软件。 三、实验课时 2课时。 四、实验内容 SQL ...
  • 华为eNSP:VRRP实验

    千次阅读 2020-07-01 19:34:28
    它使用IP播数据包进行封装,地址224.0.0.1 8,发布范围只限于同一局域网内。这保证了VRID在不同网络中可以重复使用。 因为这份笔记的主要目的是理解keepalived的原理,所以只介绍部分相关字段。 Virtual Rtr ID ...

    简介

    • 为了更好地解决网络中断的问题,网络开发者提出了VRRP,它既不需要改变组网情况,也不需要在主机上做任何配置,只需要在相关路由器上配置极少的几条命令,就能实现下一跳网关的备份,并且不会给主机带来任何负担。和其他方法比较起来,VRRP更加能够满足用户的需求。

    VRRP报文

    • VRRP控制报文只有一种: VRRP通告(advertisement)。 它使用IP多播数据包进行封装,组地址224.0.0.1
      8,发布范围只限于同一局域网内。这保证了VRID在不同网络中可以重复使用。
      因为这份笔记的主要目的是理解keepalived的原理,所以只介绍部分相关字段。
      Virtual Rtr ID (VRID) :虚拟路由器ID, 取值范围是1 ~ 255。
      Priority:发送报文的VRRP路由器在虚拟路由器中的优先级。取值范围是0~ 255,其中可用的范围是1 ~ 25
      4。0表示设备停止参与VRRP,用来使备份路由器尽快成为主路由器,而不必等到计时器超时; 255则保留

    • IP地址拥有者。缺省值是100。
      Count IP Addrs: VRRP广播中包含的虚拟IP地址个数。
      IP Address(es):虚拟路由器IP地址,地址个数是Count IP Addrs的值。

    实验拓扑图

    在这里插入图片描述

    配置命令

    LSW3上配置命令如下:

    vlan bratch 10 20
    
    interface Ethernet 0/0/1                         #定义端口类型为access,打上标签10
    port link-type access
    port default vlan 10
    
    interface Ethernet 0/0/2                         #定义端口类型为access,打上标签20                               
    port link-type access
    port default vlan 20
    
    interface GigabitEthernet 0/0/1                  #定义端口类型为trunk,允许VLAN 10 20数据通过
    port link-type trunk
    port trunk allow-pass  vlan 10 20
    
    interface GigabitEthernet 0/0/2                  #定义端口类型为trunk,允许VLAN 10 20数据通过               
    port link-type trunk 
    port trunk allow-pass  vlan 10 20
    

    LSW2上配置命令如下:

    vlan bratch 10 20 100
    
    interface GigabitEthernet 0/0/2                  #定义端口类型为trunk,允许VLAN 10 20数据通过
    port link-type trunk 
    port trunk allow-pass  vlan 10 20
    
    
    interface GigabitEthernet 0/0/1                  #定义端口类型为access,打上标签100
    port link-type access
    port default vlan 100
    
    interface vlanif 10                              #配置标签10的属性
    ip address 192.168.10.20 24
    vrrp vrid 1 virtual-ip 192.168.10.1              #配置虚拟浮动网关
    vrrp vrid 1 priority 115                         #配置路由网关的优先级
    
    interface vlanif 20                              #配置标签20的属性
    ip address 192.168.20.20 24
    vrrp vrid 2 virtual-ip 192.168.20.1              #配置虚拟浮动网关
    vrrp vrid 2 priority 120                         #配置路由网关的优先级
    vrrp vrid 2 track interface GigabitEthernet 0/0/1#监控此端口
    vrrp vrid 2 track interface GigabitEthernet 0/0/2#监控此端口
    
    interface vlanif 100                             #配置标签100的属性
    ip address 12.0.0.2 30
    
    ip route-static 0.0.0.0 0.0.0.0 12.0.0.1         #配置静态路由
    

    LSW1上配置命令如下:

    vlan bratch 10 20 100
    
    interface GigabitEthernet 0/0/2                  #定义端口类型为trunk,允许VLAN 10 20数据通过
    port link-type trunk 
    port trunk allow-pass  vlan 10 20
    
    
    interface GigabitEthernet 0/0/1                  #定义端口类型为access,打上标签100
    port link-type access
    port default vlan 100
    
    interface vlanif 10                              #配置标签10的属性
    ip address 192.168.10.10 24                      
    vrrp vrid 1 virtual-ip 192.168.10.1	             #配置虚拟浮动网关
    vrrp vrid 2 priority 120                         #配置路由网关的优先级
    vrrp vrid 2 track interface GigabitEthernet 0/0/1#监控此端口
    vrrp vrid 2 track interface GigabitEthernet 0/0/2#监控此端口
    
    interface vlanif 20                              #配置标签20的属性
    ip address 192.168.20.10 24
    vrrp vrid 2 virtual-ip 192.168.20.1	             #配置虚拟浮动网关
    vrrp vrid 2 priority 115                         #配置路由网关的优先级
    
    interface vlanif 100                             #配置标签100的属性    
    ip address 11.0.0.2 30
    
    ip route-static 0.0.0.0 0.0.0.0 11.0.0.1         #配置静态路由
    

    R1上配置命令如下:

    interface GigabitEthernet 0/0/0               
    ip address  11.0.0.1 30
    
    interface GigabitEthernet 0/0/1  
    ip address  12.0.0.1 30
    
    interface LoopBack 0
    ip address  1.1.1.1 24 
    
    ip route-static 192.168.10.0 24 11.0.0.2         #配置静态路由
    ip route-static 192.168.10.0 24 12.0.0.2 preference 70
    
    ip route-static 192.168.20.0 24 12.0.0.2         #配置静态路由
    ip route-static 192.168.20.0 24 11.0.0.2 preference 70
    
    
    展开全文
  • 一、实验目的:用高级语言编写和调试一个或个作业调度的模拟程序,以加深对作业调度算法的理解。 二、实验内容: 1.写并调试一个单道处理系统的作业等待模拟程序。 2.作业等待算法:分别采用先来先服务(FCFS)...
  • 一、 实验目的 1、熟悉该程控交换原理实验系统的电路组成与主要部件的作用。 2、体会程控交换原理实验系统进行电话通信时的工作过程。 3、了解CPU中央集中控制处理器电路组成及工作过程。 二、 预习要求 预习《程控...
  • 1. 实验目的及要求 掌握计算机机箱内个硬件的拆卸与组装方法,并且认识主机箱内的各种硬件,了解机箱内部的连接。 2. 实验地点及实验器材 博冠楼10205 计算机主机一台,十字螺丝刀2把,纸盒(储存拆下来的螺丝)...
  • 自适应随机休息(ART)努力使测试尽可能不同,以确保不会不必要地重复进行MFS的测试。 随机测试(RT)随机选择测试,而不考虑已处理的MFS。 在寻找相互作用触发的断层时,CT有望在RT上得到改善,但是一些研究报告...
  • 这项研究的目的是评估在马拉尼昂的塞拉地区,磷肥在玉米种植上对后续作物crop豆的残留效应。 该研究是在位于马萨诸塞州查帕丁哈市(3°44'30“ S,43°21'37''W)的马拉尼联邦大学(UFMA)的实验区进行的。随机区...
  • panel的设计其实很简单,根据实验目的来选择需要捕获的区域,我们需要做的就是把这些需要捕获的区域做成一个bed文件。 下面就以BRCA1/2两个基因来举例子,一般bed都是设计在基因的CDS区,因为内含子区域往往包含很...

    Panel的设计其实很简单,根据实验目的来选择需要捕获的区域,我们需要做的就是把这些需要捕获的区域做成一个bed文件。

    下面就以BRCA1/2两个基因来举例子,一般bed都是设计在基因的CDS区,因为内含子区域往往包含很多低复杂度区域(比如重复区域),所以内含子的捕获性能往往较差,后期分析难度也高。

    我们需要先准备基因组注释文件,我从NCBI下载的最新版gtf文件(https://ftp.ncbi.nlm.nih.gov/refseq/H_sapiens/annotation/GRCh37_latest/refseq_identifiers/GRCh37_latest_genomic.gtf.gz)

    下载下来可以直接解压

    wget https://ftp.ncbi.nlm.nih.gov/refseq/H_sapiens/annotation/GRCh37_latest/refseq_identifiers/GRCh37_latest_genomic.gtf.gz
    gzip -d GRCh37_latest_genomic.gtf.gz
    

    然后先观察文件格式

    less GRCh37_latest_genomic.gtf
    

    格式大概有以下几类

    #gtf-version 2.2
    #!genome-build GRCh37.p13
    #!genome-build-accession NCBI_Assembly:GCF_000001405.25
    #!annotation-date 10/22/2020
    #!annotation-source NCBI Homo sapiens Updated Annotation Release 105.20201022
    NC_000017.10	BestRefSeq	gene	41196312	41277381	.	-	.	gene_id "BRCA1"; transcript_id ""; db_xref "GeneID:672"; db_xref "HGNC:HGNC:1100"; db_xref "MIM:113705"; description "BRCA1 DNA repair associated"; gbkey "Gene"; gene "BRCA1"; gene_biotype "protein_coding"; gene_synonym "BRCAI"; gene_synonym "BRCC1"; gene_synonym "BROVCA1"; gene_synonym "FANCS"; gene_synonym "IRIS"; gene_synonym "PNCA4"; gene_synonym "PPP1R53"; gene_synonym "PSCP"; gene_synonym "RNF53";
    NC_000017.10	BestRefSeq	exon	41277199	41277381	.	-	.	gene_id "BRCA1"; transcript_id "NR_027676.2"; db_xref "GeneID:672"; gbkey "misc_RNA"; gene "BRCA1"; product "BRCA1 DNA repair associated, transcript variant 6"; exon_number "1";
    NC_000017.10	BestRefSeq	CDS	41219625	41219712	.	-	0	gene_id "BRCA1"; transcript_id "NM_007298.3"; db_xref "CCDS:CCDS11454.2"; db_xref "GeneID:672"; gbkey "CDS"; gene "BRCA1"; note "isoform 4 is encoded by transcript variant 4"; product "breast cancer type 1 susceptibility protein isoform 4"; protein_id "NP_009229.2"; exon_number "15";
    

    '#'开头的注释信息,第一列为染色体号(NC_000017.10对应chr17),第四列为起始位置,第五列为终止位置,我们按CDS区设计就只需要提取第三列为CDS的行(exon区域还包含两端的UTR区域,如果需要UTR区则按照exon设计)。

    接下来我们开始提取BRCA1及BRCA2的CDS区域,为了便于后期扩展,把基因名放到单独的列表里:

    gene.list
    ----
    BRCA1
    BRCA2
    

    然后新建一个python脚本,把GRCh37染色体对应信息写进去:

    make_bed.py
    ----
    chr_dic = {"NC_000001.10": '1',
               "NC_000002.11": "2",
               "NC_000003.11": "3",
               "NC_000004.11": "4",
               "NC_000005.9": "5",
               "NC_000006.11": "6",
               "NC_000007.13": "7",
               "NC_000008.10": "8",
               "NC_000009.11": "9",
               "NC_000010.10": "10",
               "NC_000011.9": "11",
               "NC_000012.11": "12",
               "NC_000013.10": "13",
               "NC_000014.8": "14",
               "NC_000015.9": "15",
               "NC_000016.9": "16",
               "NC_000017.10": "17",
               "NC_000018.9": "18",
               "NC_000019.9": "19",
               "NC_000020.10": "20",
               "NC_000021.8": "21",
               "NC_000022.10": "22",
               "NC_000023.10": "X",
               "NC_000024.9": "Y",
               "NC_012920.1": "MT"}
    

    接下来,将gtf文件转化为一个字典,字典的key为基因名,值为CDS起始与终止位置,基因名/转录本/外显子等信息都在gtf最后一列里提取

    def phase_gtf(gtf_path, extract_type='CDS'):
        gene_dict = {}
        trans_list = []
        with open(gtf_path, 'r') as f:
            datas = [l.rstrip().split('\t') for l in f.readlines() if not l.startswith('#')]
        datas = [x for x in datas if x[2] == extract_type and x[1] == 'BestRefSeq']
        for _data in datas:
            gene = _data[-1].split(';')[0].replace('gene_id ', '').replace('\"', '')
            trans = _data[-1].split(';')[1].replace('transcript_id ', '').replace('\"', '').replace(' ', '')
            exon = _data[-1].split(';')[-2].replace('exon_number', '').replace('\"', '').replace(' ', '')
            start = _data[3]
            end = _data[4]
            if _data[0] not in chr_dic:
                continue
            if gene not in gene_dict:
                gene_dict[gene] = [[trans, 'exon%s' % exon, chr_dic[_data[0]], start, end]]
            else:
                gene_dict[gene] = gene_dict[gene] + [[trans, 'exon%s' % exon, chr_dic[_data[0]], start, end]]
        return gene_dict
    

    然后从字典里拿出来放到文件里即可:

    gene_dict = phase_gtf('GRCh37_latest_genomic.gtf')
    
    with open('gene.list', 'r') as f, open('raw.bed', 'w+') as f_o:
        for l in f:
            l = l.rstrip()
            if l not in gene_dict:
                print(l, "gene name not found")
                continue
            gene_detail = gene_dict[l]
            for _trans, _exon, _chr, _start, _end in gene_detail:
                f_o.write('\t'.join([_chr, str(_start), str(_end), l, _trans, _exon])+'\n')
    

    把脚本合并起来:

    make_bed.py
    ----
    chr_dic = {"NC_000001.10": '1',
               "NC_000002.11": "2",
               "NC_000003.11": "3",
               "NC_000004.11": "4",
               "NC_000005.9": "5",
               "NC_000006.11": "6",
               "NC_000007.13": "7",
               "NC_000008.10": "8",
               "NC_000009.11": "9",
               "NC_000010.10": "10",
               "NC_000011.9": "11",
               "NC_000012.11": "12",
               "NC_000013.10": "13",
               "NC_000014.8": "14",
               "NC_000015.9": "15",
               "NC_000016.9": "16",
               "NC_000017.10": "17",
               "NC_000018.9": "18",
               "NC_000019.9": "19",
               "NC_000020.10": "20",
               "NC_000021.8": "21",
               "NC_000022.10": "22",
               "NC_000023.10": "X",
               "NC_000024.9": "Y",
               "NC_012920.1": "MT"}
               
    def phase_gtf(gtf_path, extract_type='CDS'):
        gene_dict = {}
        trans_list = []
        with open(gtf_path, 'r') as f:
            datas = [l.rstrip().split('\t') for l in f.readlines() if not l.startswith('#')]
        datas = [x for x in datas if x[2] == extract_type and x[1] == 'BestRefSeq']
        for _data in datas:
            gene = _data[-1].split(';')[0].replace('gene_id ', '').replace('\"', '')
            trans = _data[-1].split(';')[1].replace('transcript_id ', '').replace('\"', '').replace(' ', '')
            exon = _data[-1].split(';')[-2].replace('exon_number', '').replace('\"', '').replace(' ', '')
            start = _data[3]
            end = _data[4]
            if _data[0] not in chr_dic:
                continue
            if gene not in gene_dict:
                gene_dict[gene] = [[trans, 'exon%s' % exon, chr_dic[_data[0]], start, end]]
            else:
                gene_dict[gene] = gene_dict[gene] + [[trans, 'exon%s' % exon, chr_dic[_data[0]], start, end]]
        return gene_dict
     
    if __name__ == "__main__":
        gene_dict = phase_gtf('GRCh37_latest_genomic.gtf')
    
        with open('gene.list', 'r') as f, open('raw.bed', 'w+') as f_o:
            for l in f:
                l = l.rstrip()
                if l not in gene_dict:
                    print(l, "gene name not found")
                    continue
                gene_detail = gene_dict[l]
                for _trans, _exon, _chr, _start, _end in gene_detail:
                    f_o.write('\t'.join([_chr, str(_start), str(_end), l, _trans, _exon])+'\n')
    

    这样会生成一个文件,格式如下

    17   41258473        41258543        BRCA1   NM_007297.4     exon3
    17   41256885        41256973        BRCA1   NM_007297.4     exon4
    17   41256139        41256278        BRCA1   NM_007297.4     exon5
    17   41251792        41251897        BRCA1   NM_007297.4     exon6
    17   41249261        41249306        BRCA1   NM_007297.4     exon7
    

    当然这不是最终格式,因为这不合bed文件的规范,而且我习惯于把多个转录本的CDS区合并了过后设计,仔细看这份文件会发现它包含了多个转录本,也可以直接选最长的转录本,我们还是来合并CDS区间,另起一个python脚本

    先读取刚刚生成的文件

    def read_bed(bed_path):
        with open(bed_path, 'r') as f:
            datas = [l.rstrip().split('\t') for l in f.readlines() if not l.startswith('#')]
        datas = [[x[0], int(x[1]), int(x[2]), x[3], x[4]] for x in datas]
        chr_list = list(set([x[0] for x in datas]))
        return chr_list, datas
    

    然后我们需要对有重叠的区间合并,并在合并后对区间排序,这里设计成分染色体来处理

    def handle_chr(data, _chr):
        data = [x for x in data if x[0] == _chr]
        check_num = 0
        while check_num == 0:
            check_num = 1
            data_backup = data[:]
            for _idx, _data in enumerate(data):
                for i in range(_idx+1, len(data)):
                    if data[i][1] <= data[_idx][1] <= data[i][2] or data[i][1] <= data[_idx][2] <= data[i][2] or \
                            (data[_idx][1] <= data[i][1] and data[_idx][2] >= data[i][2]):
                        num_list = [data[i][1], data[i][2], data[_idx][1], data[_idx][2]]
                        num_list.sort()
                        new_line = [data[i][0], num_list[0], num_list[-1], data[i][3], data[i][4]]
                        data_backup.pop(i)
                        data_backup.pop(_idx)
                        data_backup.append(new_line)
                        check_num = 0
                        break
                if check_num == 0:
                    break
            data = data_backup[:]
        check_num = 0
        while check_num == 0:
            check_num = 1
            for i in range(0, len(data)-1):
                if data[i][1] > data[i+1][1]:
                    tmp_data = data[i][:]
                    data[i] = data[i+1][:]
                    data[i+1] = tmp_data[:]
                    check_num = 0
        return data
    

    然后就是写文件了,所以这个脚本合起来就是

    merge_bed.py
    ---
    def read_bed(bed_path):
        with open(bed_path, 'r') as f:
            datas = [l.rstrip().split('\t') for l in f.readlines() if not l.startswith('#')]
        datas = [[x[0], int(x[1]), int(x[2]), x[3], x[4]] for x in datas]
        chr_list = list(set([x[0] for x in datas]))
        return chr_list, datas
        
    def handle_chr(data, _chr):
        data = [x for x in data if x[0] == _chr]
        check_num = 0
        while check_num == 0:
            check_num = 1
            data_backup = data[:]
            for _idx, _data in enumerate(data):
                for i in range(_idx+1, len(data)):
                    if data[i][1] <= data[_idx][1] <= data[i][2] or data[i][1] <= data[_idx][2] <= data[i][2] or \
                            (data[_idx][1] <= data[i][1] and data[_idx][2] >= data[i][2]):
                        num_list = [data[i][1], data[i][2], data[_idx][1], data[_idx][2]]
                        num_list.sort()
                        new_line = [data[i][0], num_list[0], num_list[-1], data[i][3], data[i][4]]
                        data_backup.pop(i)
                        data_backup.pop(_idx)
                        data_backup.append(new_line)
                        check_num = 0
                        break
                if check_num == 0:
                    break
            data = data_backup[:]
        check_num = 0
        while check_num == 0:
            check_num = 1
            for i in range(0, len(data)-1):
                if data[i][1] > data[i+1][1]:
                    tmp_data = data[i][:]
                    data[i] = data[i+1][:]
                    data[i+1] = tmp_data[:]
                    check_num = 0
        return data
    
    if __name__ == "__main__":
        chr_list, datas = read_bed("raw.bed")
        total_data = []
        for i in range(1, 23):
            chr_data = handle_chr(datas, str(i))
            total_data += chr_data
        for _chr in ["X", "Y", "MT"]:
            total_data += handle_chr(datas, _chr)
        with open('merged_cds.bed', 'w') as f:
            f.write('\n'.join(["\t".join([str(y) for y in x]) for x in total_data])+'\n')
    

    运行完会生成merged_cds.bed,完成合并后检查检查,没问题就做成bed格式:

    awk '{print $1"\t"$2"\t"$3"\t+\t"$1"_"$2"_"$3}' merged_cds.bed > final.bed
    

    生成的文件格式如下:

    17   41258473        41258543        +   17_41258473_41258543
    17   41256885        41256973        +   17_41256885_41256973
    17   41256139        41256278        +   17_41256139_41256278
    

    (PS: 别忘了cat一个表头进去,有些软件需要表头)

    展开全文
  • 实验设计是按因子分解方案排列的随机区,即四个生长位点×15个单交玉米杂交种,以三个重复排列。 由籽粒产量和粗蛋白百分比组成的基因型指数是获得优良玉米基因型的最佳选择策略。 考虑谷物产量和粗蛋白的基因...
  • 按照随机区设计,每个实验均由三个重复组成。 开花的植物数量,每线性米的植物数量,第一穗的插入高度,成熟天数和生产力是评价的参数。 借助GENES计算应用程序将数据提交给统计分析。 基因型Q13-24显示出更适合...
  • 采用随机完全区设计(RCBD)实验设计,其中14种治疗重复三次。 处理方法为:不使用肥料的对照,NPK为180 Kgs N / ha / yr,仅施用绵羊粪肥,以及两种丰富的绵羊粪肥比率4:1和8:1,将其混合为(4:1)4份羊粪和1...
  • 实验是RCBD 3×2×3阶乘,具有四个重复样本,具有三个干豆品种,两个N育性水平,两个根瘤菌接种源以及一个非接种治疗。 2014年还对斑豆品种进行了评估。结果显示,每种植物的结节,活力,高度和1000种子重量的主要...
  • 1、实验目的 1)掌握C#命令行参数的接收; 2)掌握C#中的泛型用法; 3)掌握C#的基本流程语句; 4)掌握C#的随机数生成; 5)了解C#的异常处理流程; 6)掌握C#的计时器及对代码的性能优化。 7)本实验注重...
  • 数据结构(C++)有关练习题

    热门讨论 2008-01-02 11:27:18
    实验一 复习C++有关知识 实验目的: 通过实验掌握下列知识: 1、复习C++有关基本知识; 2、熟悉VC编程、编译和调试环境; 内容及步骤: 编写一个类Complex,定义复数的加法、减法、乘法和除法运算,...
  • TCP_IP详解卷1

    热门讨论 2010-12-29 10:53:54
    12.4.2 地址到以太网地址的转换 133 12.4.3 FDDI和令牌环网络中的播 134 12.5 小结 134 第13章 IGMP:Internet管理协议 136 13.1 引言 136 13.2 IGMP报文 136 13.3 IGMP协议 136 13.3.1 加入一个 ...
  • cpu模型机课程设计.zip

    2010-12-07 13:59:04
    一、教学目的、任务与实验设备 1. 教学目的 (1)融会贯通本课程各章节的内容,通过知识的综合运用,加深对计算机系统各模块的工作原理及相互联系的认识,加深计算机工作中“时间—空间”概念的理解,从而清晰地...
  • 重复10次,目的是检测在8820微秒内如果出现高电平就退出解码程序 ;识别连发码,和跳过4.5ma的高电平。 JNB P2.2, $ ;等待高电平避开9毫秒低电平引导脉冲 ACALL DELAY2400 JNB P2.2,IR_Rp ;这里为低电平,认为...
  • (1)针对窗口类浏览器模式问题,指出并分析了该问题存在的原因,利用Activity的运行机制,通过Fragment栈对主要模块的Webview进行管理,实现对不同模块之间切换的控制。 (2)针对跨域数据交互问题,指出并分析了...
  • WindowsXP安装SQL_server2000的过程图解

    热门讨论 2012-06-07 11:22:37
    SQL Server 2000可以在同一台服务器上安装个实例,也就是你可以重复安装几次。这时您就需要选择不同的实例名称了。建议将实例名限制在 10 个字符之内。实例名会出现在各种 SQL Server 和系统工具的用户界面中,...
  • 习 题 答 案 习题一答案 一、选择题 1. 软件的主要特性是(A B C)。... 中间层:表示某个加工分解为一子加工,其中的子加工还需进一步分解。 底层:由不再进行分解的基本加工组成。 4. 加工小说明有...
  • 本书的目的就是帮助读者了解c++是如何支持编程技术的,使读者能从中获得新的理解,从而成为一名优秀的编程人员和设计人员。适合做高校面向对象编程课程的教科书,也可作为c++爱好者的参考书。 [center] [a href=...
  • 本书的目的就是帮助读者了解c++是如何支持编程技术的,使读者能从中获得新的理解,从而成为一名优秀的编程人员和设计人员。适合做高校面向对象编程课程的教科书,也可作为c++爱好者的参考书。 [center] [a href=...
  • C++程序设计语言(特别版)--源代码

    热门讨论 2012-04-23 07:33:51
    本书的目的就是帮助读者了解c++是如何支持编程技术的,使读者能从中获得新的理解,从而成为一名优秀的编程人员和设计人员。适合做高校面向对象编程课程的教科书,也可作为c++爱好者的参考书。 [center] [a href=...
  • 尽管有很软件的实际功能与其宣传的效果大相径庭,但我们相信客观实验的力量。我们不妨选择最知名、最强大的几款黑客工具来对核盾数据卫士的硬盘写保护功能进行可重复检验的公正测试。 对核盾数据卫士的硬盘写保护...
  • 别忘了许多 css 的实验属性都需要加上浏览器前缀,除非用库把强大的 autoprefixer 再实现一遍。 使用 className 可以很好的加上前缀,在追查文件时能得到清晰的定位,下面是我们对 CSS 命名空间的...
  • 大学文献检索资料 DOC

    2009-11-28 10:35:24
    第二节 信息检索的目的和作用 1.通过科技文献检索能够打开人类知识宝库的钥匙。 2.通过科技文献检索能使科技工作者及时把握科技发展的动态和趋势。 3.通过科技文献检索能有助于开拓知识面,改善知识结构。 4....
  • 与开发人员在测试环境重复以上步骤,发现11群的计次表话单有时正常,有时其出中继群号就为一个随机值,发生异常的频率比较高。为什么其它群的话单正常,唯独11群不正常呢?11群是四个群中最小的群,其中继计...
  • c语言编写单片机技巧

    2009-04-19 12:15:17
    一般从大三会开始接触到一些专业课程,电子相关专业会开设相关的单片机应用课程并且会有简单的实验项目,那么要充分把握实验课的机会,多多地实际上机操作练习。平时可以看看相关的电子技术杂志网站,看看别人的...
  • 问题3-13:在问题3-12中,如果B发送的确认帧在传输过程中总是出错,那么A也是一直重复发送DATA0到DATA6这7个数据帧。在这种情况下,连续ARQ协议还正确吗? 问题3-14:能否归纳一下连续ARQ协议都有哪些主要功能和特别...

空空如也

空空如也

1 2
收藏数 31
精华内容 12
关键字:

多组重复实验目的