精华内容
下载资源
问答
  • MFC中组合框获取当前选中文本

    千次阅读 2016-11-20 17:34:50
    组合框获取当前选择的文本    int index = m_repeatCount.GetCurSel(); CString str; m_repeatCount.GetLBText(index,str); MessageBox(str);
    组合框获取当前选择的文本
    
      
        int index = m_repeatCount.GetCurSel();
    CString str;
    m_repeatCount.GetLBText(index,str);
    MessageBox(str);
    展开全文
  • 我新建了个窗体,插入了一个组合框...我想请教怎样弄,运行窗体时不让子窗体显示内容,一选中组合框的其中一,下边的子窗体显示对应的内容。比如组合框选了“液晶电视”,下边的子窗体就显示所有库存商品对应的行。
  • 单击右侧“Insert”按钮添加项,单击“删除”按钮删除选中的项,单击“上移”或“下移”按钮用来上移或下移选中项在控件显示的位置。勾选复选“允许在运行时有未定义值”表示可以有没有赋值的项存在。  图1 ...
  • LabVIEW的组合框

    2021-01-19 23:07:04
    单击右侧“Insert”按钮添加项,单击“删除”按钮删除选中的项,单击“上移”或“下移”按钮用来上移或下移选中项在控件显示的位置。勾选复选“允许在运行时有未定义值”表示可以有没有赋值的项存在。  图1 ...
  • 易语言VCL组合框功能扩展源码,VCL组合框功能扩展,VCL高级组合框_取现行选中项,VCL高级组合框_置现行选中项,VCL高级组合框_取项目文本
  • 易语言VCL高级组合框扩展源码,VCL高级组合框扩展,VCL高级组合框_取现行选中项,VCL高级组合框_置现行选中项,VCL高级组合框_取项目文本,FindWindowEx,SendMessageA,SendMessageA_String
  • 易语言自创高级组合框源码,自创高级组合框,消息处理,创建,加入项目,置现行选中项,取现行选中项,取项目数,取项目文本,取项目数值,删除项目,清空,置项目高度,加入图片从文件,加入图片从字节集
  • 组合框

    2019-10-01 23:10:38
    在Windows程序设计可以见到大量组合框的应用实例,例如文件对话框里的目录搜索组合框。 1.基础知识  组合框的风格主要有三种,分别是简单组合框( Simple ComboBox)、下拉式组合框(Dro...
                                                     组合框
      组合框兼具编辑框和列表框的功能,既能编辑选项,又能显示多个项。在Windows程序设计中可以见到大量组合框的应用实例,例如文件对话框里的目录搜索组合框。
    1.基础知识
      组合框的风格主要有三种,分别是简单组合框( Simple ComboBox)、下拉式组合框(DropDown ComboBox)和下拉式列表框( DropDown ListBox)。
      下拉式列表框和下拉式组合框平时只显示编辑区域,只在打开时才显示组合框的各项,这样有利于节省屏幕空间。这三种组合框的基本功能如表所示。
    组合框类型    是否有下拉式列表    是否有编辑区域
    简单组合框    无    有
    下拉式组合框    有    有
    下拉式列表框    有    无
      组合框的风格取值定义了组合框的具体属性,包括是否自动排序,是否有滚动条。这些风格取值如表所示。
    风格取值    描述
    CBS_AUTOHSCROLL    当用户在编辑区域键入字符时,列表框自动滚动,使当前项的名称与键入的字符排序相同
    CBS_DROPDOWN    创建一个下拉式组合框
    CBS_DROPDOWNLIST    创建一个下拉式列表框
    CBS_HASSTRINGS    让应用程序能够使用GetText取得组合框里的文本
    CBS_OEMCONVERT    把输入的文本将从ANSI码转换成OEM码,然后又转换成ANSI码;这样的目的是保证函数AnsiToOem的正确调用
    CBS_OWNERDRAWFIXED    父窗口负责重画组合框里的各项,并使各项的高度一致
    CBS_OWNERDRAWVARIABLE    父窗口负责重画组合框里的各项,各项的高度不一致
    CBS_SIMPLE    组合框显示所有的项,当前的选项在编辑区域中显示
    CBS_SORT    自动排序
    CBS_DISABLENOSCROLL    组合框有垂直滚动条,当组合框的项不足时,滚动条禁活;没有该风格,则滚动条隐藏
    CBS_NOINTEGRALHEIGHT    指定组合框的大小由程序精确控制,通常组合框的大小由组合框里项的数目决定
      创建一个组合框只需把CreateWindow的第一个参数设置为ComboBox,然后取表中的值即可。组合框创建后,需要初始化,即通过向组合框发送CB_ADDSTRING增加最初的项,这类似于列表框。如果没有定义CBS_SORT风格,新增的项将被增加到组合框的末尾。
      应用程序的父窗口主要通过 WM_COMMAND消息与组合框通信,应用程序可以用CB_FINDSTRINGEXACT搜索指定的项,还可以发送CB_DELETESTRING删除指定的项,当需要删除所有的项时,发送消息CB_RESETCONTENT即可。
      组合框的编辑区域用来显示当前选中的项或者编辑组合框里没有的项。可以用CB_LIMITTEXT来限制输入文本的大小;为了获得编辑区域的文本,可发送CB_GETTEXT消息,这样就把文本复制到指定的字符串中,当需要设置编辑区域的文本时,只需要发送CB_SETTEXT消息。
      Windows API为组合框提供了文件显示和搜索的功能,它们主要通过函数DlgDirListComboBox和DlgDirSelectComboBox来实现。本节的应用程序中将用到这些函数,并把文件的内容显示在窗口里。
    取 值    描 述
    CB_ADDSTRlNG    增加一项
    CB_DELETESTRING    删除指定的项
    CB_DIR    发送搜索目录的消息
    CB_FINDSTRING    搜索指定的项
    CB_FINDSTRINGEXACT    精确搜索指定的项
    CB_GETCOUNT    得到组合框中项的数目
    CB_GETCURSEL    得到当前选中项的序号
    CB_GETEDITSEL    得到编辑区域选中的文本
    CB_GETLBTEXT    得到编辑区域的文本
    CB_GETLBTEXTLEN    得到编辑区域中文本的长度
    CB_LIMITTEXT    发送限制编辑区域文本的消息
    CB_RESETCONTENT    删除所有的项
    CB_SELECTSTRING    选中指定的字符串
    CB_SETCURSEL    将光标设置在指定的位置
    CB_SETDROPPEDWIDTH    设置下拉的宽度
    CB_SETEDITSEL    选取编辑区域的文本
    CBN_CLOSEUP    关闭组合框
    CBN_DBLCLK    发送用户双击组合框中项的消息
    CBN_DROPDOWN    下拉时发送消息
    CBN_EDITCHANGE    发送编辑区域改变的消息
    CBN_EDITUPDATE    发送编辑区域改变的消息,但在更新之前发送
    CBN_ERRSPACE    发送内存不够的消息
    CBN_KILLFOCUS    当组合框失去输入焦点时发送该消息
    CBN_SETFOCUS    设置输入焦点

     

    转载于:https://www.cnblogs.com/IMyLife/p/4826061.html

    展开全文
  • 本课视频录制了组合框的项目数值关联列表框,并通过组合框写了一个简易的四则运算计算器。 视频链接: 78 组合框项目数值关联列表项目组合框源码: .版本 2 .局部变量 要找的项目数值 .局部变量 m, 整数型 ...

    本课视频录制了组合框的项目数值关联列表框,并通过组合框写了一个简易的四则运算计算器。

    视频链接:

    78

    组合框项目数值关联列表项目组合框源码:

    .版本 2
     
    .局部变量 要找的项目数值
    .局部变量 m, 整数型
    .局部变量 项目数值
    .局部变量 项目文本, 文本型
     
    要找的项目数值 = 到整数 (编辑框1.内容)
    编辑框2.内容 = “”
    .计次循环首 (组合框1.取项目数 (), m)
        项目数值 = 组合框1.取项目数值 (m - 1)
        .如果真 (项目数值 = 要找的项目数值)
            项目文本 = 组合框1.取项目文本 (m - 1)
            组合框1.选择 (项目文本)
            编辑框2.内容 = 项目文本
        .如果真结束
     
    .计次循环尾 ()

    计算器视频教程

    .版本 2
     
    .局部变量 a
    .局部变量 b
    .局部变量 c, 双精度小数型
    .局部变量 运算, 文本型
     
    运算 = 组合框1.取项目文本 (组合框1.现行选中项)
     
    a = 到数值 (编辑框1.内容)
    b = 到数值 (编辑框2.内容)
     
    .判断开始 (运算 = “+”)
        c = a + b
    .判断 (运算 = “-”)
        c = a - b
    .判断 (运算 = “*”)
        c = a × b
    .判断 (运算 = “/”)
        c = a ÷ b
    .默认
     
    .判断结束
    编辑框3.内容 = 到文本 (c)

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言教程选择框一键选中与取消

     

    展开全文
  • VC 在组合框的下拉列表框实现自动选择,当在Combobox组合框中键入字符时,组合框会根据用户的输入在列表框自动选择匹配的,其实就是大家熟悉的搜索提示,用户输入时,Combobox下拉框会智能匹配用户的输入内容...
  • 组合框函数

    千次阅读 2011-11-06 15:01:25
    在MFC,CComboBox类实现了对组合框控件的封装,它提供了组合框操作相关的函数,常用的函数及其功能如表7-16所示。 表7-16 CComboBox类主要成员函数及其功能 ...取得组合框的列表框当前选中项(如果有的话
      
    

    在MFC中,CComboBox类实现了对组合框控件的封装,它提供了组合框操作相关的函数,常用的函数及其功能如表7-16所示。

    表7-16 CComboBox类主要成员函数及其功能

    函数名称

    函数功能

    GetCount

    取得组合框的列表框中项的个数

    GetCurSel

    取得组合框的列表框中当前选中项(如果有的话)的下标

    SetCurSel

    在组合框的列表框中选择一个字符串

    GetEditSel

    取得组合框的编辑控件中当前选项的起止字符位置

    SetEditSel

    选中组合框的编辑控件中的字符

    SetItemData

    设置组合框中指定项的值

    GetItemData

    检索应用为组合框的项提供的值

    GetTopIndex

    返回组合框中列表框的第一个可见项的下标

    SetTopIndex

    让组合框的列表框显示指定下标所在的项

    SetHorizontalExtent

    设置组合框中列表框的水平宽度(以像素为单位),如果列表超过该宽度,将需要用滚动条

    GetHorizontalExtent

    返回组合框中列表框的水平宽度(以像素为单位)

    LimitText

    设置用户可以在组合框的编辑控件中输入的文本的最大长度

    SetItemHeight

    设置组合宽中列表框的项的高度或编辑控件(或静态控件)中文本的高度

    GetItemHeight   

    取得组合框中列表项的高度

    GetLBTextLen

    取得组合框的列表框中某个字符串的长度

    GetLBText

    从组合框的列表框中取得一个字符串

    GetDroppedState

    检测组合框的列表框是否可见(是否已经下拉)

    AddString

    在组合框的列表框的列表末尾添加一个字符串,或在具有CBS_ SORT风格的的列表框中按次序所在的位置插入一个字符串

    DeleteString

    删除组合框中的列表框中的一个字符串

    InsertString

    在组合框的列表框中插入一个字符串

    ResetContent

    删除组合框的列表框和编辑控件中的所有项

    FindString

    在组合框的列表框中查找具有指定前缀的第一个字符串

    FindStringExact

    在组合框的列表框中查找具有与指定字符串完全匹配的第一个字符串

    SelectString

    在组合框的列表框中查找字符串,找到后选中它,并把它复制到编辑控件中

    在对话框中,组合框的最常用操作就是获取用户的选择项,其使用可表示如下:

    CComboBox* m_combo=GetDlgItem(“IDC_COMBOBOX”)                     //获取组合框的指针

    int nselect= m_combo->GetCurSel();                                                             //获取当前组合框选项的索引

            CString szname;

            m_combo->GetLBText(nselect,szname);                                                        //组合框选项的标题

    另外,经常还需要通过AddString和DeleteString添加、删除组合框项。可见,其使用与列表框有很大的相似

    展开全文
  • 本节课通过自定义数据类型实现易语言组合框二级联动。 组合框列表项被选择源码: .版本 2 .局部变量 i, 整数型 .局部变量 当前省, 文本型 当前省 = 组合框1.取项目文本 (组合框1.现行选中项) 组合框2.清空 ...
  • MFC获取组合框中元素的索引值

    千次阅读 2013-05-03 23:33:27
    MFC中组合框控件的使用 分类: Windows(C/C++,MFC,C#) 2011-07-18 23:431254人阅读 评论(1)收藏 举报 mfc 由于是第一次使用组合框, 今天要使用组合框时还真是波折不少,所以将过程总结一下,避免下次...
  • 本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。...现行选中项), ) .否则 .如果结束 .子程序 列表框查找文本, 逻辑型 .参数 列表框, 列表框 .参数 要加入的文本, 文本型 .局部变量 i, 整数型 .计次
  • MFC编程之组合框控件

    2018-05-04 15:46:35
    什么是组合框? 在这里我做了一个例程,选择不同的边缘会又不一样的值,并且能修改和保存。 下面是效果图。...简易组合框中的列表框是一直显示的。 下拉式组合框默认不显示列表框,只有在点击了...
  • 易语言Access数据库添加至组合框源码,Access数据库添加至组合框,连接数据库
  • MFC,组合框使用

    2017-11-15 22:00:26
    Combo Box对应的控制变量CComboBox m_CbDrive; 绑定好控制变量后,直接在需要的地方使用以下...2、组合框中编辑框自动选中列表的一 m_CbDrive.SelectString(-1,"C:"); //第一个参数是-1时,从列表开始处开始搜索,
  • 易语言之删除选中项

    千次阅读 2018-01-29 18:45:23
    删除表项 (超级列表1.现行选中项) .子程序 超级列表1检查状态被改变 .参数 表项索引, 整数型 .参数 检查状态, 整数型 .判断开始 (检查状态 = 1) 超级列表1.现行选中项 = 表项索引 .默认
  • 下拉列表框和组合框

    2019-10-01 23:10:50
    组合框被操作时会向父窗口发送通知消息,这些通知... CBN_DBLCLK:用户在某列表上双击鼠标,只有简易组合框才会发送该通知消息 CBN_DROPDOWN:组合框的列表框组件下拉,简易式组合框不会发送该通知消息 CBN_...
  • 组合框控件

    2011-06-24 09:24:00
    用户既可以在编辑框输入,也可以从列表框选择一个列表来完成输入。组合框分为简易式(Simple combo box)、下拉式(Drop-down combo box)和下拉列表式(Drop-down list box)三种.简易式组合框包含一个编辑框和一...
  • 易语言组合框去重复到列表框

    千次阅读 2019-12-08 19:15:51
    在辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加到列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 列表框和组合框的区别1、自动排序方式不同:当列表框不能同时显示所有项目的时候,将自动添加滚动条,使用户可以...组合框是一个编辑框带一个可以下拉的列表框,用户在下拉框选择的会进入编辑框,再进行后续处...
  • 对话框添加组合框的应用

    千次阅读 2011-05-28 22:00:00
    需要注意的是,在Data页面的列表框,若想给组合框增加新的列表,必须使用Ctrl+Enter键才能回车到下一行增加新的列。该组合框在程序运行的时候也不允许用户再往里添值,因此,将该组合框的Type属性选择为 Drop ...
  • VS2015 MFC组合框控件

    千次阅读 2017-08-09 10:09:57
    MFC组合框控件用CComboBox类来表示。该控件可以看作是列表控件和编辑框控件的组合。一般情况下,在列表框选择了某之后,该的内容会在文本框显示出来。
  • 组合框ComboBox

    2020-01-01 18:22:45
    一、组合框ComboBox外观如下: 二、常用功能及作用 通过下拉箭头按钮可以弹出内含的备选项,可以实现类似于枚举的可视化功能。 三、属性详解 1、布局 ·Anchor //锚点,其作用在于将一个控件与容器的指定的...
  • XML如下图所示 后来分析: ...3.对于组合框中子只能有一个被选中,不能写两个 可以更改为如下的XML <Combo name="sig_age_com" float="true" pos="260,170,0,0" width="70" height="50" bkc...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 34,839
精华内容 13,935
关键字:

如何删除组合框中的选中项