精华内容
下载资源
问答
  • 一台三层交换机vlan间互通
    万次阅读
    2021-10-28 23:51:46

    本次使用ensp模拟器模拟两台华为三层交换机如何配置不同网段不同vlan之间如何互通。网络拓补图如下图所示:

    配置方法感觉非常奇怪,但是居然通信了。

    IP地址如下:

    pc1:10.1.1.2  / 24    pc2 :10.1.2.2 / 24   pc3:192.168.1.2  /24   pc4:192.168.2.2 / 24

    LSW1配置如下:

    <Huawei>system-view                    \\进入系统视图
    [Huawei]undo info-center enable        \\关闭日志
    [Huawei]vlan batch 5 to 8              \\创建vlan5.6.7.8
    [Huawei]interface vlan 5                \\进入vlan虚拟接口视图
    [Huawei-Vlanif5]ip address 10.1.1.254 24    \\配置接口ip
    [Huawei-Vlanif5]interface vlan 6
    [Huawei-Vlanif6]ip address 10.1.2.254 24
    [Huawei-Vlanif6]interface vlan 7
    [Huawei-Vlanif7]ip address 192.168.1.254 24
    [Huawei-Vlanif7]interface vlan 8
    [Huawei-Vlanif8]ip address 192.168.2.254 24
    [Huawei-Vlanif8]quit                         \\退出到系统视图
    [Huawei]interface GigabitEthernet 0/0/1      \\进入0/0/1端口
    [Huawei-GigabitEthernet0/0/1]port link-type access     \\配置端口模式为access
    [Huawei-GigabitEthernet0/0/1]port default vlan 5        \\将该端口划分至vlan 5中
    [Huawei-GigabitEthernet0/0/1]interface GigabitEthernet 0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type access
    [Huawei-GigabitEthernet0/0/2]port default vlan 6
    [Huawei-GigabitEthernet0/0/2]interface GigabitEthernet 0/0/3
    [Huawei-GigabitEthernet0/0/3]port link-type trunk             \\配置端口模式为trunk
    [Huawei-GigabitEthernet0/0/3]port trunk allow-pass vlan all   \\允许所有vlan通过该trunk端口
    [Huawei-GigabitEthernet0/0/3]return
    <Huawei>save

    LSW2配置如下:

    <Huawei>system-view                    \\进入系统视图
    [Huawei]undo info-center enable        \\关闭日志
    [Huawei]vlan batch 5 to 8              \\创建vlan5.6.7.8
    [Huawei]interface vlan 5                \\进入vlan虚拟接口视图
    [Huawei-Vlanif5]ip address 10.1.1.254 24    \\配置接口ip
    [Huawei-Vlanif5]interface vlan 6
    [Huawei-Vlanif6]ip address 10.1.2.254 24
    [Huawei-Vlanif6]interface vlan 7
    [Huawei-Vlanif7]ip address 192.168.1.254 24
    [Huawei-Vlanif7]interface vlan 8
    [Huawei-Vlanif8]ip address 192.168.2.254 24
    [Huawei-Vlanif8]quit                         \\退出到系统视图
    [Huawei]interface GigabitEthernet 0/0/1      \\进入0/0/1端口
    [Huawei-GigabitEthernet0/0/1]port link-type access     \\配置端口模式为access
    [Huawei-GigabitEthernet0/0/1]port default vlan 7        \\将该端口划分至vlan 5中
    [Huawei-GigabitEthernet0/0/1]interface GigabitEthernet 0/0/2
    [Huawei-GigabitEthernet0/0/2]port link-type access
    [Huawei-GigabitEthernet0/0/2]port default vlan 8
    [Huawei-GigabitEthernet0/0/2]interface GigabitEthernet 0/0/3
    [Huawei-GigabitEthernet0/0/3]port link-type trunk             \\配置端口模式为trunk
    [Huawei-GigabitEthernet0/0/3]port trunk allow-pass vlan all   \\允许所有vlan通过该trunk端口
    [Huawei-GigabitEthernet0/0/3]return
    <Huawei>save

     最终结果使用四台pc互ping,显示互相ping通

     还有一种方法为:不配置trunk链路,将LSW1交换机当作hub使用,不设置vlan,只在LSW2中划分vlan,将端口3加入,配置vlan多网关,使4台pc相互通信

    有不对的地方,希望各位大佬指点经验。

    更多相关内容
  • 使用三层交换机实现VLAN间通信 ** ** 、实验目的 子网划分与静态路由。 二、实验要求 192.168.1.0/24划分为5个子网 192.168.1.128/25 192.168.1.64/26 192.168.1.32/27 192.168.1.0/30 192.168.1.4/30 三、...

    **

    使用三层交换机实现VLAN间通信

    **
    **

    一、实验目的

    子网划分与静态路由。
    

    二、实验要求

    192.168.1.0/24划分为5个子网
    192.168.1.128/25 
    192.168.1.64/26
    192.168.1.32/27
    192.168.1.0/30   
    192.168.1.4/30 
    

    三、实验原理图

    在这里插入图片描述

    **

    四、给路由器的接口配置IP地址并启用该接口

    1.给六个PC配相应的IP地址、掩码、网关:
    PC1:192.168.1.33      255.255.255.224        192.168.1.62
    PC2:192.168.1.34      255.255.255.224        192.168.1.62
    PC3:192.168.1.65      255.255.255.192        192.168.1.126
    PC4:192.168.1.66      255.255.255.192        192.168.1.126
    PC5:192.168.1.129     255.255.255.128        192.168.1.254
    PC6:192.168.1.130     255.255.255.128        192.168.1.254
    
    2.输入命令:
    1)将如原理图所示的左边第一个交换机命名为RC,之后进行相应的配置,如下所示:
    RC(config)#int fa0/0
    RC(config-if)# ip address 192.168.1.62 255.255.255.224
    RC(config-if)#no shutdown
    RC(config)#int s2/0
    RC(config-if)#ip address 192.168.1.1 255.255.255.252
    RC(config-if)#no shutdown
    RC(config)#ip route 192.168.1.4   255.255.255.252  192.168.1.2
    RC(config)#ip route 192.168.1.64  255.255.255.192  192.168.1.2
    RC(config)#ip route 192.168.1.128 255.255.255.128  192.168.1.2
    
    2)将如原理图所示的左边第二个交换机命名为RB,之后进行相应的配置,如下所示:
    RB(config)#int fa0/0
    RB(config-if)#ip address 192.168.1.126 255.255.255.192
    RB(config-if)#no shutdown
    RB(config)#int s2/0
    RB(config-if)#ip address 192.168.1.2 255.255.255.252
    RB(config-if)clock rate 64000
    RB(config-if)#no shutdown
    RB#ping 192.168.1.1
    RB(config)#int s3/0
    RB(config-if)#ip address 192.168.1.5 255.255.255.252
    RB(config-if)clock rate 64000
    RB(config-if)#no shutdown
    RB(config)#ip route 192.168.1.32 255.255.255.224 192.168.1.1
    RB(config)#ip route 192.168.1.128 255.255.255.128 192.168.1.6
    
    3)将如原理图所示的左边第三个交换机命名为RA,之后进行相应的配置,如下所示:
    RA(config)#int fa0/0
    RA(config-if)#ip address 192.168.1.254 255.255.255.128
    RA(config-if)#no shutdown
    RA(config)#int s3/0
    RA(config-if)#ip address 192.168.1.6 255.255.255.252
    RA(config-if)#no shutdown
    RA(config)#ip route 0.0.0.0 0.0.0.0 192.168.1.5
    

    **

    五、运行结果

    **
    在这里插入图片描述
    在这里插入图片描述
    看到最后还不留下你的赞和小钱钱~
    在这里插入图片描述

    展开全文
  • 三层交换机实现VLAN通信

    万次阅读 2021-03-14 21:07:43
    目录前言、三层交换原理二、三层交换机实验 前言 、三层交换原理  三层交换技术可以实现VLAN间通信 三层交换 = 二层交换 + 三层路由转发  当三层设备接收到个数据帧,会拆除原数据帧,重新封装新的源...


    前言

     之前学习了单臂路由技术:当只有二层交换机时,又要实现不同vlan间通信时,需要用到单臂路由技术。

     我们今天学习的三层交换的出现,解决了局域网中网段划分之后,网段中子网必须依赖路由器进行管理的局面,从而缓解了由于路由器负担过重而造成的网络瓶颈问题。

    一、三层交换原理

    想要理解三层交换首先需要了解“虚接口”机制:

    • 虚接口是指通常所说的 VLAN接口,只不过是虚拟的,在三层交换机上配置的。
    • 三层交换机具备路由功能,所以两个VLAN之间可以互相访问,每个VLAN虚接口就是该网段的网关。

    由此我们可以引出三层交换的概念:

    • 三层交换技术可以实现不同VLAN之间的通信;
    • 三层交换 = 二层交换 + 三层转发;
    • 机相当于交换机的功能和路由器的功能结合

     当三层设备接收到一个数据帧,会拆除原数据帧,重新封装新的源MAC地址和目标MAC地址,并且因为帧头部的信息发生变化,最后的帧校验CRC也应当随之改变。

     在这个流中的多个数据包,其中只有第一个数据包是由三层交换机的三层引擎来处理的,处理的方式是软件方式,与答单臂路由工作方式相同,三层引擎获取了新的二层封装信息后,路由转发这个数据包。

     在第一个数据包转发完成后,在硬件中创建一个MLS条目,用于后续的数据包由硬件执行的重新封装和快速转发。二层数据帧会被重新封装为需要转发的下一个网段的帧格式。这就是MLS “一次路由,多次交换 ” 的原理


     工作原理:

    一次路由:第一个数据包是由三层交换机的三层路由引擎进行转发的。(与单臂路由工作原理相同:重新封装MAC地址与转换VLAN标签)

    多次交换:从第一个数据包之后,都是由二层交换机硬件转发, 硬件转发又是通过第一次路由转发时获悉的的重写信息在硬件中创建的 MLS条目。

     基于CEF(一种基于拓扑转发的模型)的MLS,其关键是两张转发信息表,转发信息库(FIB)与路由表一一对应,是路由表的一个镜像。路由表更新时,FIB随之变化,其中FIB包含邻接主机的IP地址与VLANID的对应关系。而邻接关系表包含邻接主机和交换机MAC地址的对应关系用来提供二层重写信息。

     基于CEF的MLS转发过程,即发送单播数据包,通过查找FIB和邻接关系表,重新封装数据帧,从相应端口进行转发。

    在这里插入图片描述

    在三层交换机上配置的VLAN接口为虚接口

    一个是三层交换机可以配置多个虚接口。

    三层交换机配置的命令:
    interface vlanif 10		#配置虚接口
    ip address 192.168.10.1 24
    #端口自动激活,不用执行un sh
     
    display ip interface brief 
    

    二、三层交换机实验

    2.1 实验一

    使用三层交换机实现下图中三个VLAN之间主机的的通信:
    在这里插入图片描述

    [SW1]vlan batch 10 20 30
    
    [SW1]int g0/0/1
    [SW1-GigabitEthernet0/0/1]p l a
    [SW1-GigabitEthernet0/0/1]p d v 10
    
    [SW1-GigabitEthernet0/0/1]int g0/0/2
    [SW1-GigabitEthernet0/0/2]p l a
    [SW1-GigabitEthernet0/0/2]p d v 20
    
    [SW1-GigabitEthernet0/0/2]int g0/0/3
    [SW1-GigabitEthernet0/0/3]p l a
    [SW1-GigabitEthernet0/0/3]p d v 30
    [SW1-GigabitEthernet0/0/3]q
    
    [SW1]int Vlanif 10
    [SW1-Vlanif10]ip address 192.168.10.1 24
    
    [SW1-Vlanif10]int Vlanif 20
    [SW1-Vlanif20]ip address 192.168.20.1 24
    
    [SW1-Vlanif20]int Vlanif 30
    [SW1-Vlanif30]ip address 192.168.30.1 24
    [SW1-Vlanif30]q
    
    
    [SW1]dis ip routing-table 
    [SW1]dis ip int brief
    

    PC1配置:192.168.10.10   网关为:192.168.10.1
    PC2配置:192.168.20.20   网关为:192.168.20.1
    PC3配置:192.168.30.30   网关为:192.168.30.1
    实验结果:
    三个不同VLAN之间的主机可以相互ping通。

    2.2 实验二

    在实验一的基础上,增加两台路由器 AR1 和 AR2,使不同VLAN100内的 PC4 可以和其他三个VLAN之间的主机进行通信。
    在这里插入图片描述

     配置重点:SW1 与 R1 配置时,三层交换机SW1都是在虚接口上配置的,如 int vlanif 100 ,然后在虚接口上配置网关。而三层交换机下又有三个网关,R1配置非直连静态路由时,都需要配置。

    配置步骤:
    【R1】
    [R1]int g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 10.0.0.1 24
    [R1-GigabitEthernet0/0/0]int g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 12.0.0.1 24
    [R1-GigabitEthernet0/0/1]q
    
    #跨网关需要配置静态路由
    [R1]ip route-static 192.168.10.0 24 10.0.0.254
    [R1]ip route-static 192.168.20.0 24 10.0.0.254
    [R1]ip route-static 192.168.30.0 24 10.0.0.254
    [R1]ip route-static 192.168.100.0 24 12.0.0.2
    
    【R2】
    [R2]int g0/0/0
    [R2-GigabitEthernet0/0/0]ip add 192.168.100.1 24
    [R2-GigabitEthernet0/0/0]un sh
    [R2-GigabitEthernet0/0/0]int g0/0/1
    [R2-GigabitEthernet0/0/1]ip add 12.0.0.2 24
    [R2-GigabitEthernet0/0/1]q
    
    #跨网关需要配置默认路由
    [R2]ip route-static 0.0.0.0 0.0.0.0 12.0.0.1
    
    
    【三层交换机 SW1】
    [SW1]vlan 100
    [SW1-vlan100]int vlanif 100
    [SW1-Vlanif100]ip add 10.0.0.254 24
    
    [SW1-Vlanif100]int g0/0/4
    [SW1-GigabitEthernet0/0/4]p l a
    [SW1-GigabitEthernet0/0/4]p d v 100
    [SW1-GigabitEthernet0/0/4]q
    
    #跨网关需要配置默认路由
    [SW1]ip route-static 0.0.0.0 0.0.0.0 10.0.0.1
    
    

    PC4配置:192.168.100.100   网关为:192.168.100.1
    实验结果:
    四个不同VLAN之间的主机可以相互ping通。


    注:像下面的三层交换机有四个接口,就要配置四个虚接口,然后在配置网关接口IP
    在这里插入图片描述

    展开全文
  • 通过三层交换机实现vlan间互通

    万次阅读 2017-11-21 21:34:21
    、配置思科2960交换机 创建vlan Switch> Switch>enable Switch#vlan database Switch(vlan)#vlan 10 name vlan10 VLAN 10 added:  Name: vlan10 Switch(vlan)#vlan 20 name vlan20 VLAN 20 added:  
    实验拓扑图:

    一、配置思科2960交换机

    创建vlan

    Switch>

    Switch>enable

    Switch#vlan database

    Switch(vlan)#vlan 10 name vlan10

    VLAN 10 added:

        Name: vlan10

    Switch(vlan)#vlan 20 name vlan20

    VLAN 20 added:

        Name: vlan20

    Switch(vlan)#exit


    分配端口(将f0/1-12端口划归vlan10,f0/13-f0/23端口划鬼vlan20)

    Switch#configure terminal

    Switch(config)#hostname L2-SW

    L2-SW(config)#

    L2-SW(config)#interface range f0/1-12

    L2-SW(config-if-range)#switchport mode access

    L2-SW(config-if-range)#switchport access vlan 10

    L2-SW(config-if-range)#interface range f0/13-23

    L2-SW(config-if-range)#switchport mode access

    L2-SW(config-if-range)#switchport access vlan 20

    L2-SW(config-if-range)#exit


    设置trunk

    L2-SW(config)#interface f0/24

    L2-SW(config-if)#switchport mode trunk

    L2-SW(config-if)#exit


    二、配置 Cisco3560交换机

    首先创建相同编号的vlan:

    Switch>enable

    Switch#vlan database

    Switch(vlan)#vlan 10 name vlan10

    VLAN 10 added:

        Name: vlan10

    Switch(vlan)#vlan 20 name vlan20

    VLAN 20 added:

        Name: vlan20

    Switch(vlan)#exit

    然后通过设置SVI交换虚拟接口,分别为每个VLAN设置IP:
    Switch#configure terminal

    Switch(config)#interface vlan 10

    Switch(config-if)#ip address 192.168.1.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    Switch(config)#interface vlan 20

    Switch(config-if)#ip address 192.168.2.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    Switch(config)#ip routing   #############启用三层交换机的路由功能,否则三层交换机只能使用其二层


    三、在PC上测试

    PC0  IP:192.168.1.2   GW:192.168.1.254

    PC1  IP:192.168.2.2   GW:192.168.2.254


    四、在三层交换机上在直接连接一个PC2,给个vlan10实现三台PC互通。

    在三层交换机上配置:

    Switch>enable

    Switch#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#interface f0/2

    Switch(config-if)#switchport mode access

    Switch(config-if)#switchport access vlan 10

    Switch(config-if)#no shutdown

    Switch(config-if)#exit

    测试联通性:

    设置PC2 IP:192.168.1.3  GW:255.255.255.0


    参考至:http://m.jb51.net/softjc/56598.html

    展开全文
  • 三层交换机不同vlan间相互通信
  • 三层交换机实现 VLAN 通信

    千次阅读 2021-11-24 14:44:58
    3. 验证三层交换机实现 VLAN 通信的过程 4. 区分 VLAN 关联的 IP 接口与路由器接口的差别 二、实验步骤 1.连接拓扑图 2.配置交换机vlan 2950switch0 给各个接口添加vlan(注意自己的接口号和我的不一样...
  • 使用指南:工作在trunk mode 下的端口称为 Trunk 端口,Trunk 端口可以通过多个 VLAN 的流量,通过 Trunk 端口之间的互联,可以实现不同交换机上的相同 VLAN互通;Trunk 端口的 PVID 的作用是当个 untagged的帧...
  • 华为交换机:三层交换机实现vlan间通信 实验环境介绍 、划分vlan并将相应的接口加入VLAN swh1配置 swh2配置 swh3配置 二、配置trunk并允许所有vlan通过 三、核心交换机swh4的配置 四、验证结果 实验环境介绍 、...
  • 华三三层交换机vlan互通配置的坑

    千次阅读 2021-11-06 15:58:48
    注:两电脑全部关闭防火墙 开始配置交换机 可以先关闭stp,然后提前把网线都插上,也可以先不插,按照后边的步骤一步一步来 [H3C]undo stp global enable #这是关闭指令 [H3C]stp global enable #这是开启指令 ...
  • ·掌握通过三层交换机实现VLAN间通信的配置方法 ·掌握通过以太网Trunk链路实现VLAN间通信的配置方法 拓扑图 图1.4 三层交换实验拓扑图 场景 在企业网络中,通过使用三层交换机可以简便的实现...
  • 一台交换机上不允许trunk端口和hybrid端口同时存在。1.先创建业务需要的vlan[SwitchA]vlan10[SwitchA]vlan20[SwitchA]vlan30[SwitchA]vlan40[SwitchA]vlan502.每个端口,都配置为hybrid状态[SwitchA]...
  • 利用三层交换机的路由功能,实现不同vlan间的通信
  • 配置要求:1.完成设备名称和IP地址等的设置。2.完成telnet线路配置使管理终端能够远程访问所有网络设备。...3.按图示完成端口汇聚设置。...S1、B1为服务器模式,其他设备为...6.指定S1为所有VLAN的根交换机,并确保B1-B...
  • 思科三层交换机实现不同VLAN互相访问配置案例解决:思科二层交换机不具备三层交换能力,无法在两个VLAN之间...思科三层交换机VLAN间路由配置步骤:1、配置干道(TRUNK)在接口模式下声明该接口为trunk模式的命令格...
  • 技术原理: 1. 三层交换机是带有三层路由功能的交换机,也就是这交换机的端口既有三层路由功能,也具有二层交换功能。...三层交换机给接口配置IP地址,采用SVI(交换虚拟接口)的方式实现VLAN间互连,SVI是指为交
  • 本次实验实现了使用三层交换机实现跨VLAN间的通信。主要步骤有建立网络拓扑、二层交换机的接口设置(创建VLAN、交换机的VLAN端口分配、交换机的端口分配)、三层交换机的接口设置(创建VLAN、交换机的端口分配、配置...
  • C\DocumentsandSettings\Joseph>ping{在PC1上做ping测试}192.168.10.254。C\DocumentsandSettings\Joseph>{在PC1上做ping测试}ping...Open{说明可以从其他的vlan远程登入到ED-SW作跨网段管理}{ED-SW可以与Core互通}...
  • 需求:实现交换机多个不同的网段(VLAN)可以互相通信。 例如:个网段**192.168.10. – 192.168.11. – 192.168.12.-- ** 实现3个网段互通。 第步:设置VLAN #进入交换机配置界面 system-view # 简写...
  • 利用三层交换机实现VLAN间路由。在交换机上使用interface VLANif命令创建VLANIF 接口,指定VLANIF接口所对应的 VLAN ID ,并进入 VLANIF接口视图,在接口视图下配置IP地址(192.168.1.254/24)。
  • 实验2:利用三层交换机实现vlan间的通信 、实验目的和要求 目的:掌握交换机各种端口的vlan配置方法;利用三层交换机实现vlan间通信的基本配置,并掌握链路聚合的相关配置方法。 要求:独立完成实验任务和实验报告...
  • 2、配置交换机LSW2 <Huawei>sys [Huawei]undo info-center enable [Huawei]vlan 2 [Huawei-vlan2]quit [Huawei]vlan 3 [Huawei-vlan3]quit [Huawei]int e0/0/1 [Huawei-Ethernet0/0/1]port link-type access ...
  • 三层交换机实现VLAN互连

    千次阅读 2020-05-09 19:19:10
    借助VLANIF接口,三层交换机就能实现路由转发功能。 主机发出数据包前,将会查看数据包中的目的IP地址,如果目的IP地址和本机IP地址在同个网段上,主机会直接发出个ARP请求数据包来请求对方主机的MAC地址,封装...
  • 使用三层交换机实现不同vlan互通

    千次阅读 2018-09-29 17:29:00
    如下拓扑图所示,要实现vlan10(192.168.10.0/24)与vlan 20...三层交换机配置: 创建vlan:Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit 创建vl...
  • 台三层华为交换机,两个不同的vlan, 配置互通, 请大神做个配置,跪拜。
  • eNSP三层交换机不同vlan间通信

    千次阅读 多人点赞 2021-03-30 20:18:37
    三台交换机(其中一台交换机为三层交换机),四台PC,实现不同vlan之间的通信。 二、实验拓扑图 实验中使用的交换机型号均为S3700,其中SW3我们选用成为三层交换机,其它两个交换机均为二层交换机 三、实验内容 ...
  • 二、二层交换机的配置 Switch# Switch#config t Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#exit Switch...
  • 三层交换机具备网络层的功能,实现VLAN相互访问的原理是:利用三层交换机的路由功能,通过识别数据包的IP地址,...掌握三层交换机VLAN路由的配置方法。通过三层交换机实现VLAN相互通信。掌握三层交换机基本配置方法。
  • H3C三层交换实验(不同vlan间互通三层交换实验(不同vlan间互通)拓扑图 三层交换实验(不同vlan间互通) 拓扑图 SW配置: # vlan 23 # vlan 45 # interface Vlan-interface23 ip address ...
  • 三层交换机配置: Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#vlan 20 Switch(config-vlan)#vlan 30 Switch(config-vlan)#vlan 40 Switch(config-vlan)#exit Switch...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 4,097
精华内容 1,638
热门标签
关键字:

一台三层交换机vlan间互通