精华内容
下载资源
问答
  • 交换机 几个端口镜像已经存在端口镜像 一对多端口镜像==交换机的同一个端口能否同时镜像给其他两个端口?不能。==端口镜像需要注意如下几点:以太网交换机支持多对一的镜像,即将多个端口的报文复制到一个观察端口...

    交换机 几个端口镜像

    已经存在端口镜像 

    一对多端口镜像

    ==

    交换机的同一个端口能否同时镜像给其他两个端口?

    不能。

    ==

    端口镜像需要注意如下几点:

    以太网交换机支持多对一的镜像,即将多个端口的报文复制到一个观察端口上。
    高端交换机支持跨板镜像,即观察端口和被观察端口可以位于不同的接口板。
    观察端口总共可以配置8个。
    同一块单板下行只能镜像到同一个观察端口。

    如果你真需要两个监控口,并且是光口的话,监控口可以接个分光器,1分2,就可以了。

    ==

    摘自锐捷交换机实施一本通

    一对多镜像,包含多对多镜像:当你需要把一台交换机上面的一个口或者是多个端口的流量,镜像(复制)到交换机上面的某几个端口的时候,就可以考虑采用交换机的一对多镜像功能。

    一对多镜像,通常在网络中有多台监控服务器(比如数据库操作审计服务器,日志记录服务器,上网行为管理服务器,流量统计或者监控服务器),视频加速


    端口镜像不会改变镜像报文的任何信息,也不会影响原有报文的正常转发。同时对于源端口,目的端口的介质类型没有要求,可以是光口镜像到电口,也可以是电口的流量镜像到光口。对于源端口,目的端口的属性没有要求,可以是access口镜像到trunk口,也可以是trunk口镜像到access口。

    注意:一对多(多对多)可以将一个端口的流量,镜像到多个目标端口,目前非11.x平台的交换机,支持一对多(多对多)的设备只有S8600、S12000、6220系列交换机。

    提示:对于不支持一对多的设备,可以通过普通RSPAN镜像功能(不使用自环口)将RSPAN目标端口再连接到一台空配置交换机上,划分多个接口到一个VLAN中(RSPAN使用的VLAN中)并关闭所有端口MAC地址学习功能(no mac-address-learning)和端口风暴控制(类似HUB泛洪,由于没有MAC地址学习,报文才会进行泛洪,所以需要关闭风暴控制防止镜像流量太多被抑制而丢弃),从而实现一对多功能。

    ==

    华为交换机配置多个镜像观察口

    实现原理:将所有端口镜像报文引入一个观察端口,通过观察端口内部环回(配置loopback internal),
    将报文在vlan内广播道其它若干实际观察端口,报文出端口时剥除vlan id。 


    配置举例: 

    预留vlan3500(for example) 

    #
    vlan batch 3 10 20 100 300 to 301 3000 to 3002 3500 4000

    观察端口 

    #
    observe-port 1 interface GigabitEthernet0/0/21 vlan 3500   //  G0/0/21是空口

    三个镜像端口: 

    #
    interface GigabitEthernet0/0/3
    port-mirroring to observe-port 1 both
    #
    interface GigabitEthernet0/0/4
    port-mirroring to observe-port 1 both
    #
    interface GigabitEthernet0/0/5
    port-mirroring to observe-port 1 both

    三个观察端口: 

    #
    interface GigabitEthernet0/0/23
    port link-type trunk
    undo port trunk allow-pass vlan 1
    port trunk allow-pass vlan 3500
    interface GigabitEthernet0/0/24
    port link-type trunk
    undo port trunk allow-pass vlan 1
    port trunk allow-pass vlan 3500
    #
    环回端口:
    #
    interface GigabitEthernet0/0/21
    description neibuhuanhui
    loopback internal
    mac-address learning disable
    port link-type trunk
    undo port trunk allow-pass vlan 1
    port trunk allow-pass vlan 3500
    stp disable 


    注意:如果交换机全局配置stp enable,需要在环回端口上配置stp disable,否则该端口如果接收到交换机自己发出去的stp报文,
    会将端口置为discarding状态,环回报文都会在入向被丢弃.

    H3C 多个目的镜像端口_百度文库

    ==

    down表示端口关闭,up表示端口开启。


    ==

    负载均衡 镜像

    负载均衡 端口镜像

    ...

    启明星辰 负载均衡 端口镜像

    启明星辰 天清 负载均衡 端口镜像

    启明星辰 天清 防火墙 端口镜像

    天清汉马 USG 防火墙 端口镜像

    ==

     防火墙 端口镜像

    ==


    展开全文
  • 端口镜像

    2018-07-24 09:11:54
    IDS 产品需要监听网络流量(网络分析仪同样也需要),但是在目前广泛采用的交换网络中监听所有流量有相当大的困难,因此需要通过配置交换机来把个或端口(VLAN)的数据转发到某端口来实现网络的监听。...

    把交换机一个或多个端口(VLAN)的数据镜像到一个或多个端口的方法。

    为什么需要端口镜像 ?

    通常为了部署 IDS 产品需要监听网络流量(网络分析仪同样也需要),但是在目前广泛采用的交换网络中监听所有流量有相当大的困难,因此需要通过配置交换机来把一个或多个端口(VLAN)的数据转发到某一个端口来实现对网络的监听。

    端口镜像的别名

    端口镜像通常有以下几种别名:

    ●Port Mirroring 通常指允许把一个端口的流量复制到另外一个端口,同时这个端口不能再传输数据。

    ●Monitoring Port 监控端口

    ●Spanning Port 通常指允许把所有端口的流量复制到另外一个端口,同时这个端口不能再传输数据。

    ●SPAN port 在 Cisco 产品中,SPAN 通常指 Switch Port ANalyzer。某些交换机的 SPAN 端口不支持传输数据。

    ●Link Mode port

    支持端口镜像的交换机

    大多数中档以上的交换机都支持端口镜像功能,但支持程度不同。

    端口镜像配置方法

    下面是几种交换机的端口镜像配置方法,主要来自于 Talisker Security Wizardry (http://www.securitywizardry.com/) 的 Switch Port Mirroring (http://www.securitywizardry.com/switch.htm)

    Cisco 交换机

    特点:
    ● Cisco 2900 和 Cisco 3500XL 系列交换机

    ● Cisco 2950、Cisco 3550 和 Cisco 3750 系列交换机 Cisco catylist 2550 Cisco catylist 3550 支持2组monitor session en password config term Switch(config)#monitor session 1 destination interface fast0/4(1为session id,id范围为1-2) Switch(config)#monitor session 1 source interface fast0/1 , fast0/2 , fast0/3 (空格,逗号,空格) Switch(config)#exit Switch#copy running-conf startup-conf Switch#show port-monitor

    Cisco 5000 系列交换机

    使用 CatOS 的 Cisco 4000 和 Cisco 6000 系列交换机

    使用 IOS 的 Cisco 4000 和 Cisco 6000 系列交换机

    Extreme 交换机

    特点:
    ●只能创建多对一或者一对一的镜像端口

    ●可以监听 VLAN 的流量

    ●Extreme 会镜像 IN 和 OUT 的流量。这就意味着在镜像 VLAN 的时候,会看到一个报文至少两次— —从 VLAN 的某个端口出来,并且进入 VLAN 的另一个端口。 版本高于4.1的 Extreme 交换机端口镜像配置方法 {enable | disable} mirroring on port 开启/关闭端口镜像功能,并且指定镜像流量从何端口流出,port-no 只能是一个端口 configure mirroring { add | delete } { vlan | port } 指定镜像哪个或哪些 VLAN 或端口的流量 { vlan | port } 部分可以重复多次 版本低于 4.1 的 Extreme 交换机端口镜像配置方法 enable mirror to port port-no 开启端口镜像功能,并且指定镜像流量从何端口流出,port-no 只能是一个端口 disable mirror 关闭端口镜像功能 config mirror add port 镜像端口 port-no 的流量,如果这个端口包含多个 VLAN 这些流量都会被镜像到目的端口 config mirror add port vlan 镜像端口 port-no 中指定 VLAN 的流量 config mirror add vlan 镜像端口中指定 VLAN 的所有端口的流量 config mirror del port 取消对 port-no 的端口镜像 config mirror del vlan 取消对指定 VLAN 的端口镜像 show mirror

    显示端口镜像情况

    Foundry 交换机

    特点:

    ●可以创建多对多的端口镜像 Foundry 交换机端口镜像配置方法 在配置模式中(Configuration Mode): interface port monitor { { rx | tx | both}} 确定镜像流量从哪个端口流出,修改此端口配置 指定要镜像哪些端口的哪些流量(rx 指接收的流量,tx 指发送的流量,both 指双向流量),{ { rx | tx | both}} 部分可以重复

    Juniper 交换机

    特点:

    ●每交换机只能有一个监听端口

    ●只能镜像 IPv4 的流量

    ●只能镜像发送(transit only)的流量,不能镜像接收的流量 Juniper M 系列和 T 系列端口镜像配置方法 usen@router# show forwarding-options port- mirroring { input {family inet; rate ; run- length ;} output interface {next-hop ;} no-filter-check;} }

    选择将抽样的流量发送到哪个目的端口 user@router# show firewall filter mirror-sample from {...} then {sample; accept;} 定义抽样过滤器,选择感兴趣的流量 user@router# show interface unit 0 family inet filter {input mirror-sample;} 选择将抽样的过滤器应用到某个端口 端口镜像的风险 加重交换机负载,造成设备不稳定 在某些情况下会丢包,不能保证 100% 镜像流量。例如,由于多个源端口镜像到一个目的端口,目的端口无法处理造成丢包
    端口镜像配置
    『环境配置参数』

    1. PC1接在交换机E0/1端口,IP地址1.1.1.1/24
    2. PC2接在交换机E0/2端口,IP地址2.2.2.2/24
    3. E0/24为交换机上行端口
    4. Server接在交换机E0/8端口,该端口作为镜像端口
      『组网需求』
    5. 通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。
    6. 按照镜像的不同方式进行配置:
      1) 基于端口的镜像
      2) 基于流的镜像
      2.数据配置步骤『端口镜像的数据流程』
      基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。
      【3026等交换机镜像】
      S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,有两种方法:
      方法一
    7. 配置镜像(观测)端口
      [SwitchA]monitor-port e0/8
    8. 配置被镜像端口
      [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2
      方法二
    9. 可以一次性定义镜像和被镜像端口
      [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2 observing-port Ethernet 0/8
      【8016交换机端口镜像配置】
    10. 假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。
      [SwitchA] port monitor ethernet 1/0/15
    11. 设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。
      [SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15
      也可以通过两个不同的端口,对输入和输出的数据分别镜像
    12. 设置E1/0/15和E2/0/0为镜像(观测)端口
      [SwitchA] port monitor ethernet 1/0/15
    13. 设置端口1/0/0为被镜像端口,分别使用E1/0/15和E2/0/0对输入和输出数据进行镜像。
      [SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15
      [SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 2/0/0

    『基于流镜像的数据流程』
    基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。
    【3500/3026E/3026F/3050】
    〖基于三层流的镜像〗

    1. 定义一条扩展访问控制列表
      [SwitchA]acl num 100
    2. 定义一条规则报文源地址为1.1.1.1/32去往所有目的地址
      [SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any
    3. 定义一条规则报文源地址为所有源地址目的地址为1.1.1.1/32
      [SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0
    4. 将符合上述ACL规则的报文镜像到E0/8端口
      [SwitchA]mirrored-to ip-group 100 interface e0/8

    〖基于二层流的镜像〗

    1. 定义一个ACL
      [SwitchA]acl num 200
    2. 定义一个规则从E0/1发送至其它所有端口的数据包
      [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2
    3. 定义一个规则从其它所有端口到E0/1端口的数据包
      [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1
    4. 将符合上述ACL的数据包镜像到E0/8
      [SwitchA]mirrored-to link-group 200 interface e0/8

    【5516/6506/6503/6506R】
    目前该三款产品支持对入端口流量进行镜像

    1. 定义镜像端口
      [SwitchA]monitor-port Ethernet 3/0/2
    2. 定义被镜像端口
      [SwitchA]mirroring-port Ethernet 3/0/1 inbound

    【补充说明】

    1. 镜像一般都可以实现高速率端口镜像低速率端口,例如1000M端口可以镜像100M端口,反之则无法实现
    2. 8016支持跨单板端口镜像
      3.测试验证在观测端口上通过工具软件可以看到被镜像端口的相应的报文,可以进行流量观测或者故障定位。

    转载于:https://blog.51cto.com/13553337/2149261

    展开全文
  • 端口镜像(port Mirroring)功能通过在交换机或路由器上,将个或个源端口的数据流量转发到某个指定端口来实现网络的监听。指定端口称之为“镜像端口”或“目的端口”,可以通过镜像端口网络的流量进行监控...

    端口镜像(port Mirroring)功能通过在交换机路由器上,将一个或多个源端口的数据流量转发到某一个指定端口来实现对网络的监听。指定端口称之为“镜像端口”或“目的端口”,

    可以通过镜像端口对网络的流量进行监控分析。

    常用到的配置命令。fra、frsta、frsto

    ==

    端口镜像通常有以下几种别名:
    ●Port Mirroring 通常指允许把一个端口的流量复制到另外一个端口,同时这个端口不能再传输数据。
    ●Monitoring Port 监控端口
    ●Spanning Port 通常指允许把所有端口的流量复制到另外一个端口,同时这个端口不能再传输数据。
    ●SPAN port 在 Cisco 产品中,SPAN 通常指 Switch Port ANalyzer。某些交换机的 SPAN 端口不支持传输数据。
    ●Link Mode port这样,这些流量就可以被一个特殊的设备监控。它对发现和修理故障有很大的帮助。

    ==

    SPAN(Switched Port Analyzer)  交换端口分析仪

    ==

     本地镜像:源端口和目的端口在同一个路由器上。

    远端镜像:源端口和目的端口分布在不同的路由器上,镜像流量经过某种封装,实现跨路由器传输。

    ==

    • 入口镜像:只对从该端口进入的流量进行镜像。
    • 出口镜像:只对该端口的发出的流量进行镜像。
    • 双向镜像:支持对该端口收到和发出的双向流量进行镜像。

    ==

    流镜像:如果端口上配置了ACL并启用,则认为是流镜像。 流镜像只采集经过ACL过滤后的数据包,否则认为是纯端口镜像。

    纯端口镜像:对端口进出的流量进行镜像。

    ==

    访问控制列表(Access Control List,ACL) 是路由器交换机接口的指令列表,用来控制端口进出的数据包。ACL适用于所有的被路由协议,如IP、IPX、AppleTalk等。

    其主要作用是 限制网络流量,提高网络性能

    限制网络流量,提高网络性能
    例如:某部门要求只能使用 WWW 这个功能,就可以通过ACL实现; 又例如,为了某部门的保密性,不允许其访问外网,也不允许外网访问它,就可以通过ACL实现。

    ==

    简历端口镜像方法

    Cisco CATALYST交换机端口监听配置
    Cisco CATALYST交换机分为两 种,在CATALYST家族中称侦听端口为分析端 口(analysis port)。
    1、Catalyst 2900XL/3500XL/2950系列交换机端口监听配 置 (基于CLI)
    以下命令配置端口监听
    port monitor
    例 如,F0/1和F0/2、F0/3同属VLAN1,F0/1监听F0/2、F0/3端口:
    interface FastEthernet0/1
    port monitor FastEthernet0/2
    port monitor FastEthernet0/3
    port monitor VLAN1

    ==

    配置命令:

    1. 指定分析口
    feature rovingAnalysis add,或缩 写 f r a,
    例 如:
    Select menu option: feature rovingAn alysis add
    Select analysis slot: 1?& nbsp;
    Select analysis port: 2
    2. 指定监听口并启动端口监听
    feature rovingAnalysis start,或缩 写 f r sta,
    例 如:
    Select menu option: feature rovingAn alysis start
    Select slot to monitor ?(1-12): 1
    Select port to monitor&nb sp;?(1-8): 3
    3. 停止端口监 听
    feature rovingAnalysis stop,或缩 写 f r sto

    ==

    Intel 称端口监听为“Mirror Ports”。 网络流量被监听的端口称作“源端 口”(Source Port),连接监听设备的端口称作“镜像 口”(Mirror Port)。
    配置端口监听步骤如下:
    1. 在 navigation菜单,点击Statistics下的Mirror Ports,弹出Mirror Ports信 息。
    2. 在Configure Source 列中点击端口来选择源端口, 弹出Mirror Ports Configuration。
    3. 进行源端口设 置:源端口镜像流量的来源口,镜像口是接收来自源端口流量的端 口, 点击Apply确定。
    可以选择三种监听的方 式:
    1.连续(Always):镜像全部流量。
    2.周期(Periodic):在一定周期内 镜像全部流量。镜像周期在Sampling Interval configuration中设置。
    3 .禁止(Disabled):关闭流量镜像

    在Avaya交换机用户手册中,端口监 听被称为“端口镜像”(Port Mirror)。
    以下命令配置端口监听:
    { set|clear } Port Mirror
    设置端口侦 听:set port mirror <mod-port-range> source-port ?<mod-port-range> mirror-port <mod-port-spec> sampling { always | disable | periodic } [ max-packets-sec <max-packets-sec-value>?& nbsp;] [ piggyback-port<mod-port-spec> ]?&nb sp;
    禁止端口监 听:clear port mirror <mod-port-range>
    命令 中,mod-port-range指定端口的范围;mod-port-spec指定特定的端口;piggyback-port指定双向镜像的端口;sampling指定镜像周期;max-packets-sec仅在sampling设置为periodic时使用,指定监听口每秒最多的数据报数量。

    华为交换机用户手册中,端口监听被称为“端口镜 像”(Port Mirroring)。
    使用Huawei Lanswitch View管 理系统添加一个镜像端口:
    ● 选 择Device Setup或Stack Setup。
    ● 点 击Port Mirroring。
    ● 点击Add按 钮。
    ● 对于堆叠,点击Switch并从列表选择一个交换 机。
    ● 点击Reflect from并选择流量将被镜像的端 口。
    ● 点击Reflect to并选上面所选择的端口。

    ==

    华为交换机如何配置端口镜像及删除端口镜像?


    一般具有管理功能的交换机都会有端口镜像这个功能,这个功能就是为了方便观察或者监控端口流量。今天就简答说下怎样配置端口镜像和怎样删除端口镜像。


    配置端口对端口镜像。将镜像端口GE0/0/2入方向的报文(即接收到的报文)复制到观察端口GE0/0/1上,GE0/0/1与监控设备直连。

    华为交换机如何配置端口镜像及删除端口镜像?



    ==

    system-view

    observe-port 1 interface gigabitehernet 0/0/1

    interface gigabitethernet 0/0/2

    port-mirroring to observe-port 1 inbound

    quit

    --

    系统视图

    观察端口 1  接口  千兆以太网   0/0/1

    接口  0/0/2

    0/0/2  端口镜像 到 观察端口 1  流入的。 (将镜像端口GE0/0/2入方向的报文(即接收到的报文)复制到观察端口GE0/0/1上

    0/0/2 退出

    ==

    gigabitethernet     吉比特以太网或称千兆以太网,(GbE, Gigabit Ethernet或 1 GigE) 是一个描述各种以吉比特每秒速率进行以太网帧传输技术的术语

    ==

    删除端口镜像。在镜像端口下执行命令undo port-mirroring,删除观察端口与镜像端口的绑定关系,恢复镜像端口为普通端口。


    在系统视图下执行命令undo observe-port,删除观察端口。

    ==

    端口镜像 防火墙

    ==

    系统集成工程师,经常要配置一些路由器、交换机、防火墙等,最近要给一些单位安装防火墙与入侵检测系统(IDS),IDS要检测内部局域网与外部网络之间的通信数据,这就需要IDS串接至一台能够配置端口镜像的交换机


    端口镜像也是一个经常用到的功能


    下面是一些常用的交换机的端口镜像命令

    华为3COM部分
    8016交换机
    1.假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。
    [SwitchA] port monitor ethernet 1/0/15
    2.设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。
    [SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15
    也可以通过两个不同的端口,对输入和输出的数据分别镜像
    1.设置E1/0/15和E2/0/0为镜像(观测)端口
    [SwitchA] port monitor ethernet 1/0/15
    2.设置端口1/0/0为被镜像端口,分别使用E1/0/15和E1/0/14对输入和输出数据进行镜像。
    [SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15
    [SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 1/0/14

    H3C 端口镜像配置过程详解~ - H3C技术论坛

    ===

    H3C各种型号交换机端口镜像配置方法总结~ 


    一、端口镜像概念:
    Port Mirror(端口镜像)是用于进行网络性能监测。可以这样理解:在端口A 和端口B 之间建立镜像关系,这样,通过端口A 传输的数据将同时复制到端口B ,以便于在端口B 上连接的分析仪或者分析软件进行性能分析或故障判断。

    二、端口镜像配置

    『环境配置参数』

    1. PC1接在交换机E0/1端口,IP地址1.1.1.1/24

    2. PC2接在交换机E0/2端口,IP地址2.2.2.2/24

    3. E0/24为交换机上行端口

    4. Server接在交换机E0/8端口,该端口作为镜像端口

    『组网需求』

    1. 通过交换机端口镜像的功能使用server对两台pc的业务报文进行监控。

    2. 按照镜像的不同方式进行配置:

    1) 基于端口的镜像

    2) 基于流的镜像

    2 数据配置步骤
    『端口镜像的数据流程』

    基于端口的镜像是把被镜像端口的进出数据报文完全拷贝一份到镜像端口,这样来进行流量观测或者故障定位。

    【3026等交换机镜像】

    S2008/S2016/S2026/S2403H/S3026等交换机支持的都是基于端口的镜像,有两种方法:

    方法一

    1. 配置镜像(观测)端口

    [SwitchA]monitor-port e0/8

    2. 配置被镜像端口

    [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2

    方法二

    1. 可以一次性定义镜像和被镜像端口

    [SwitchA]port mirror Ethernet 0/1 to Ethernet 0/2 observing-port Ethernet 0/8

    【8016交换机端口镜像配置】

    1. 假设8016交换机镜像端口为E1/0/15,被镜像端口为E1/0/0,设置端口1/0/15为端口镜像的观测端口。

    [SwitchA] port monitor ethernet 1/0/15

    2. 设置端口1/0/0为被镜像端口,对其输入输出数据都进行镜像。

    [SwitchA] port mirroring ethernet 1/0/0 both ethernet 1/0/15

    也可以通过两个不同的端口,对输入和输出的数据分别镜像

    1. 设置E1/0/15和E2/0/0为镜像(观测)端口

    [SwitchA] port monitor ethernet 1/0/15

    2. 设置端口1/0/0为被镜像端口,分别使用E1/0/15和E2/0/0对输入和输出数据进行镜像。

    [SwitchA] port mirroring gigabitethernet 1/0/0 ingress ethernet 1/0/15

    [SwitchA] port mirroring gigabitethernet 1/0/0 egress ethernet 2/0/0



    『基于流镜像的数据流程』

    基于流镜像的交换机针对某些流进行镜像,每个连接都有两个方向的数据流,对于交换机来说这两个数据流是要分开镜像的。

    【3500/3026E/3026F/3050】

    〖基于三层流的镜像〗

    1. 定义一条扩展访问控制列表

    [SwitchA]acl num 100

    2. 定义一条规则报文源地址为1.1.1.1/32去往所有目的地址

    [SwitchA-acl-adv-101]rule 0 permit ip source 1.1.1.1 0 destination any

    3. 定义一条规则报文源地址为所有源地址目的地址为1.1.1.1/32

    [SwitchA-acl-adv-101]rule 1 permit ip source any destination 1.1.1.1 0

    4. 将符合上述ACL规则的报文镜像到E0/8端口

    [SwitchA]mirrored-to ip-group 100 interface e0/8



    〖基于二层流的镜像〗

    1. 定义一个ACL

    [SwitchA]acl num 200 

    2. 定义一个规则从E0/1发送至其它所有端口的数据包

    [SwitchA]rule 0 permit ingress interface Ethernet0/1 egress interface Ethernet0/2

    3. 定义一个规则从其它所有端口到E0/1端口的数据包

    [SwitchA]rule 1 permit ingress interface Ethernet0/2 egress interface Ethernet0/1

    4. 将符合上述ACL的数据包镜像到E0/8

    [SwitchA]mirrored-to link-group 200 interface e0/8



    【5516/6506/6503/6506R】

    目前该三款产品支持对入端口流量进行镜像

    1. 定义镜像端口

    [SwitchA]monitor-port Ethernet 3/0/2 

    2. 定义被镜像端口

    [SwitchA]mirroring-port Ethernet 3/0/1 inbound 



    【补充说明】

    1. 镜像一般都可以实现高速率端口镜像低速率端口,例如1000M端口可以镜像100M端口,反之则无法实现

    ==





    限制网络流量,提高网络性能
    展开全文
  • 交换机mirroring-group 将端口(有的交换机最多8个..)monitor-port必须保证监视端口有且只有个,而且不做他用。 mirroring-group 1 mirroring-port e1/0/11 to e1/0/20 both==镜像端口的速率是个问题。它的...
    交换机mirroring-group 将多个端口(有的交换机最多8..

    monitor-port必须保证监视端口有且只有一个,而且不做他用。

     mirroring-group 1 mirroring-port e1/0/11 to e1/0/20 both

    ==

    镜像端口的速率是个问题。它的端口速率必须要高于所测试的端口流量。例如。如果主机A连接到100M 的端口。OPV 连接到10M 的端口。那么超出的流量就会丢弃掉,如下图:

    值得注意的是,如果要镜像的端口是100M全双工端口,那么总的流量可能会达到200M对于100M镜像端口,超过的部分会被丢弃,而且不做任何标记因此将所有的流量都镜像到一个无法提供足够带宽的慢速端口是无法完成故障诊断任务的。对于故障诊断,需要了解交换机的转发模式,大多数交换机默认的转发模式是“存储转发”式,这种方式是在转发数据帧之前要检查整个帧都是正确的,这样对于冲突或错误的数据就不会被转发。

     

    一般情况下,转发的流量也会从源端口送到镜像端口,但是对于故障诊断来讲,镜像有不足的地方,镜像数据中不包括错误的数据,除非这个交换机是采用一种低延时的直通式的转发方式,而且错误发生在决定转发的操作点这后。许多厂商在其产品中不再提供低延时的直通式转发方式,这样OPV-INA就不可能探测到有冲突和错误的数据,除非OPV-INA要探测的设备是通过集线器和OPV连接到一起的。当使用镜像技术进行测试或监测时。先了解一下所测试的交换机的数据转发技术是非常重要的。了解交换方式的方法是查看相关文档或查看交换机设置。

    ==


    展开全文
  • VPP端口镜像

    2020-06-04 10:57:01
    端口镜像(port Mirroring)功能通过在交换机或路由器上,将个或个源端口的数据流量转发到某个指定端口来实现网络的监听,指定端口称之为“镜像端口”或“目的端口”,在不严重影响源端口正常吞吐流量的情况...
  • 路由器端口镜像

    2020-10-25 21:43:10
    端口镜像(port Mirroring)功能通过在交换机或路由器上,将个或个源端口的数据流量转发到某个指定端口来实现网络的监听,指定端口称之为“镜像端口”或“目的端口”,在不严重影响源端口正常吞吐流量的情况...
  • 端口镜像(port Mirroring)功能是网络设备上常用的功能,将个或个端口的数据流量复制到某个指定端口来实现网络的监控。在不影响源端口正常吞吐流量的情况下,可以通过镜像端口网络的流量进行监控分析。端口...
  • 、组网需求“”公司研发部、研发二部和市场部通过Switch与外部Internet通信,...端口镜像多个镜像口:个观察口组网图二、配置思路:配置接口GE1/0/4~GE1/0/5为本地观察端口,负责向不同Server转发镜像报文...
  • 交换机端口镜像

    2016-12-05 19:05:54
    端口镜像,通过交换机或者路由器对一个或者个端口的数据流量转发到个指定端口进行流量监控分析。 镜像的功能简单地说就是将被监控流量镜像到监控端口,以便被监控流量进行故障定位、流量分析、流量备份等,...
  • 端口镜像和端口映射

    2011-08-21 21:17:42
    端口镜像的目的:由于部署IDS产品需要监听网络流量(网络分析仪同样也需要),但是在目前广泛采用的交换网络中监听所有流量有相当大的困难,因此需要通过配置交换机来把个或个端口(VLAN)的数据转发到某个端口...
  • 1. 通过交换机端口镜像的功能使用server两台pc的业务报文进行监控。2. 按照镜像的不同方式进行配置:1) 基于端口的镜像2) 基于流的镜像2 数据配置步骤『端口镜像的数据流程』基于端口的镜像是把被镜像端口的进出...
  • 端口镜像详解

    2011-03-24 08:20:03
    IDS 产品需要监听网络流量(网络分析仪同样也需要),但是在目前广泛采用的交换网络中监听所有流量有相当大的困难,因此需要通过配置交换机来把个或端口(VLAN)的数据转发到某端口来实现网络的监听。...
  • 端口镜像(port Mirroring)把交换机个或个端口(VLAN)的数据镜像到个或个端口的方法。端口镜像又称端口映射,是网络通信协议的种方式。目的为了方便对一个或个网络接口的流量进行分析(如 IDS 产品、...
  • 、组网需求:某公司科技部、...配置本地端口镜像组网图二、配置思路:在Switch进行如下配置,实现Server所有部门访问Internet的流量进行监控:配置接口GE0/0/4为本地观察端口,负责向Server转发镜像报文。配...
  • SPAN端口镜像

    2012-06-09 20:22:13
    把交换机个或个端口(VLAN)的数据镜像到个或个端口的方法。 2) 为什么需要端口镜像 ? 在进行网络故障排查、网络数据流量分析的过程中,有时需要网络节点或骨干交换机的某些端口进行数据流量监控分析...
  • tcpmirror将在端口上接收到的TCP通信复制到个目标端口。 目的地之是主服务器(端口),它响应传入的TCP通信。 其他流是重复流,并且来自各个服务器的任何响应都将被丢弃。 为什么 这在以下情况下很有用: ...
  • 下面YJBYS小编为大家整理了关于H3C交换机端口镜像配置的方法,希望你有所帮助。【3500/3026E/3026F/3050】、基于三层流的.镜像1. 定义条扩展访问控制列表[SwitchA]acl num 1002. 定义条规则报文源地址为1.1....

空空如也

空空如也

1 2 3 4 5 ... 12
收藏数 237
精华内容 94
关键字:

一对多端口镜像