精华内容
下载资源
问答
  • 2019-12-05 15:46:35

    VLAN原理

    VLAN(Virtual Local Area Network,虚拟局域网),VLAN是一种比较新的技术,工作在OSI参考模型的第2层和第3层,一个VLAN就是一个广播域,VLAN之间的通信是通过第3层的路由器来完成的。与传统的局域网技术相比较,VLAN技术更加灵活,它具有以下优点: 网络设备的移动、添加和修改的管理开销减少;可以控制广播活动;可提高网络的安全性。

    VLAN配置

    实验内容

    本实验模拟企业网络场景。公司内网是一个大的局域网,二层交换机S1放置在一楼,在一楼办公的部门有IT部和人事部;二层交换机S2放置在二楼,在二楼办公的部门有市场部和研发部。目前交换机连接的所有主机都能互相通信,公司策略是:不同部门之间的主机不能互相通信,同一部门内的主机才可以互相访问。

    实验拓扑

    VLAN基础配置

    实验步骤

    1.基础配置

    配置PC机的IP地址和子网掩码,使用ping命令检测各直连链路的连通性,所有的PC都能相互通信。

    PC>ping 10.1.1.2
    
    Ping 10.1.1.2: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.2: bytes=32 seq=1 ttl=128 time=47 ms
    From 10.1.1.2: bytes=32 seq=2 ttl=128 time=47 ms
    
    --- 10.1.1.2 ping statistics ---
      2 packet(s) transmitted
      2 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 47/47/47 ms
    
    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.3: bytes=32 seq=1 ttl=128 time=46 ms
    From 10.1.1.3: bytes=32 seq=2 ttl=128 time=32 ms
    
    --- 10.1.1.3 ping statistics ---
      2 packet(s) transmitted
      2 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 32/39/46 ms
    
    PC>ping 10.1.1.4
    
    Ping 10.1.1.4: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.4: bytes=32 seq=1 ttl=128 time=63 ms
    From 10.1.1.4: bytes=32 seq=2 ttl=128 time=62 ms
    
    --- 10.1.1.4 ping statistics ---
      2 packet(s) transmitted
      2 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/62/63 ms
    
    PC>ping 10.1.1.5
    
    Ping 10.1.1.5: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.5: bytes=32 seq=1 ttl=128 time=62 ms
    From 10.1.1.5: bytes=32 seq=2 ttl=128 time=63 ms
    From 10.1.1.5: bytes=32 seq=3 ttl=128 time=62 ms
    
    --- 10.1.1.5 ping statistics ---
      3 packet(s) transmitted
      3 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 62/62/63 ms
    

    2.创建VLAN

    创建VLAN有两种方式:一种是使用vlan命令一次创建单个VLAN,另一种是使用vlan batch命令一次创建多个VLAN。

    S1创建VLAN 10和VLAN 20
    [S1]vlan 10
    [S1-vlan10]vlan 20
    
    S1使用display vlan命令查看VLAN相关信息
    [S1-vlan20]display  vlan 
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/1(U)     Eth0/0/2(U)     Eth0/0/3(U)     Eth0/0/4(D)     
                    Eth0/0/5(U)     Eth0/0/6(D)     Eth0/0/7(D)     Eth0/0/8(D)     
                    Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    Eth0/0/12(D)    
                    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    Eth0/0/16(D)    
                    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    Eth0/0/20(D)    
                    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      GE0/0/2(D)      
    10   common  
    20   common  
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010                         
    20   enable  default       enable  disable    VLAN 0020
    
    	
    S2使用一条vlan batch创建VLAN 30和VLAN 40
    [S2]vlan batch 30 40
    

    可以观察到,S1和S2都成功创建了相应VLAN,但目前没有任何接口加入VLAN 10和20中,默认情况下交换机上所有接口都属于VLAN 1。

    3.配置Access接口

    使用port link-type access命令配置交换机连接PC的接口类型为Access类型接口,并使用port default vlan命令配置接口加入到VLAN中。

    S1配置e0/0/1接口的access接口类型和VLAN 10
    [S1-vlan20]int e0/0/1
    [S1-Ethernet0/0/1]port link-type access
    [S1-Ethernet0/0/1]port default vlan 10
    
    S1配置e0/0/2接口的access接口类型和VLAN 10
    [S1-Ethernet0/0/1]int e0/0/2
    [S1-Ethernet0/0/2]port link-type access 
    [S1-Ethernet0/0/2]port default vlan 10
    
    S1配置e0/0/3接口的access接口类型和VLAN 20
    [S1-Ethernet0/0/2]int e0/0/3
    [S1-Ethernet0/0/3]port link-type access 
    [S1-Ethernet0/0/3]port default vlan 20
    
    S2配置e0/0/1接口的access接口类型和VLAN 30
    [S2]int e0/0/1
    [S2-Ethernet0/0/1]port link-type access
    [S2-Ethernet0/0/1]port default vlan 30
    
    S2配置e0/0/2接口的access接口类型和VLAN 40
    [S2-Ethernet0/0/1]int e0/0/2
    [S2-Ethernet0/0/2]port link-type access 
    [S2-Ethernet0/0/2]port default vlan 40
    

    可以观察到S1和S2的接口都已经加入到对应的VLAN中了

    [S1-Ethernet0/0/3]dis vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/4(D)     Eth0/0/5(U)     Eth0/0/6(D)     Eth0/0/7(D)     
                    Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    Eth0/0/11(D)    
                    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    Eth0/0/15(D)    
                    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    Eth0/0/19(D)    
                    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    GE0/0/1(D)      
                    GE0/0/2(D)                                                      
    10   common  UT:Eth0/0/1(U)     Eth0/0/2(U)                                     
    20   common  UT:Eth0/0/3(U)                                                     
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    1    enable  default       enable  disable    VLAN 0001                         
    10   enable  default       enable  disable    VLAN 0010                         
    20   enable  default       enable  disable    VLAN 0020 
    
    
    [S2-Ethernet0/0/2]dis vlan
    The total number of vlans is : 3
    --------------------------------------------------------------------------------
    U: Up;         D: Down;         TG: Tagged;         UT: Untagged;
    MP: Vlan-mapping;               ST: Vlan-stacking;
    #: ProtocolTransparent-vlan;    *: Management-vlan;
    --------------------------------------------------------------------------------
    VID  Type    Ports                                                          
    --------------------------------------------------------------------------------
    1    common  UT:Eth0/0/3(D)     Eth0/0/4(D)     Eth0/0/5(U)     Eth0/0/6(D)     
                    Eth0/0/7(D)     Eth0/0/8(D)     Eth0/0/9(D)     Eth0/0/10(D)    
                    Eth0/0/11(D)    Eth0/0/12(D)    Eth0/0/13(D)    Eth0/0/14(D)    
                    Eth0/0/15(D)    Eth0/0/16(D)    Eth0/0/17(D)    Eth0/0/18(D)    
                    Eth0/0/19(D)    Eth0/0/20(D)    Eth0/0/21(D)    Eth0/0/22(D)    
                    GE0/0/1(D)      GE0/0/2(D)                                      
    30   common  UT:Eth0/0/1(U)                                                     
    40   common  UT:Eth0/0/2(U)                                                     
    VID  Status  Property      MAC-LRN Statistics Description      
    --------------------------------------------------------------------------------
    1    enable  default       enable  disable    VLAN 0001                         
    30   enable  default       enable  disable    VLAN 0030                         
    40   enable  default       enable  disable    VLAN 0040
    

    4.检查配置结果

    交换机接口加入不同的VLAN后,属于相同的VLAN的接口处于同一个广播域,可以相互通信。属于不同VLAN的接口处于不同的广播域,相互不能直接通信。

    PC>ping 10.1.1.2
    
    Ping 10.1.1.2: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.2: bytes=32 seq=1 ttl=128 time=46 ms
    From 10.1.1.2: bytes=32 seq=2 ttl=128 time=32 ms
    From 10.1.1.2: bytes=32 seq=3 ttl=128 time=31 ms
    From 10.1.1.2: bytes=32 seq=4 ttl=128 time=31 ms
    From 10.1.1.2: bytes=32 seq=5 ttl=128 time=31 ms
    
    --- 10.1.1.2 ping statistics ---
      5 packet(s) transmitted
      5 packet(s) received
      0.00% packet loss
      round-trip min/avg/max = 31/34/46 ms
    
    PC>ping 10.1.1.3
    
    Ping 10.1.1.3: 32 data bytes, Press Ctrl_C to break
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    From 10.1.1.1: Destination host unreachable
    
    --- 10.1.1.3 ping statistics ---
      5 packet(s) transmitted
      0 packet(s) received
      100.00% packet loss
    

    本实验中,只有同属于IT部门VLAN10的PC-1和PC-2之间可以相互通信,其他PC之间无法通信。

    更多相关内容
  • 交换机的基本配置VLAN配置

    千次阅读 2022-05-03 19:25:47
    实验五 交换机的基本配置 1实验目的 (1)了解多种品牌及多种系列的交换机,如Cisco、H3C锐捷(本实验将以锐捷系列交换机为例); (2)熟悉多种交换机的基本命令; (3)掌握交换机的各种参数配置、IP地址配置等;(4)掌握交换机...

    实验五 交换机的基本配置
    1实验目的
    (1)了解多种品牌及多种系列的交换机,如Cisco、H3C锐捷(本实验将以锐捷系列交换机为例);
    (2)熟悉多种交换机的基本命令;
    (3)掌握交换机的各种参数配置、IP地址配置等;(4)掌握交换机的本地管理、远程管理方法;
    (5)通过对交换机的管理配置,掌握网络工作原理及相关技术,同时熟练掌握网络管理的基本技能,为高级网络管理应用打下良好基础
    2 实验内容
    (1)基于物理控制线的连接及基本配置;
    (2)基于Telnet的远程登录配置;
    (3)对交换机进行命令配置,熟悉交换机常用命令。
    3 实验原理
    交换机(Switch)是可用于信号转发的设备,体现了桥接复杂交换技术在 OSI参考模刑中第二层操作的特点。交换机按每一个数据包中的MAC地址,相对简单地决策信息的转发。这种转发决策一般不考虑数据包中隐藏很深的其他信息,而且转发延迟很小,操作接近单个局域网性能,其性能远超普通桥接互联网之间的转发。
    (1)传统交换机。传统交换机工作在数据链路层上,根据 MAC 地址进行信息帧的转发,具有很高的端口密度,可以看成是一种多端口的高速网桥,如图 1-3所示。在交换机类型中有一种工作在OSI参考模型中第三层的特殊交换机。它既具有第三层的路由功能,也里有第二层的快速转发功能,该类型的交换机在实际网络场景中运用较为广泛,我们称这类交换机为路由交换机。
    (2)无线交换机。无线交换机提升了无线网络的可管理性、安全性和升级能力,降低了组网成本,成为无线局域网(WLAN)系统的“大脑”。WLAN 交换技术用于集中控制接入点和无线交换功能,具有提供跨无线基础设施保护用户身份的能力。
    4 实验步骤
    实验拓扑图:
    在这里插入图片描述

    图 1 实验拓扑图
    用户模式 switch>
    (1)进入特权模式 enable
    switch> enable
    switch#
    (2)进入全局配置模式 configure terminal
    switch> enable
    switch#configure terminal
    switch(conf)#
    (3)交换机命名 hostname host 以S1dongrui为例
    switch> enable
    switch#configure terminal
    switch(conf)#hostname S1dongrui
    S1dongrui(conf)#
    (4)配置使能口令(特权模式密码) enable password cisco
    switch> enable
    switch#configure terminal
    switch(conf)#hostname S1dongrui
    S1dongrui(conf)#enable password cisco
    (5)设置虚拟局域网vlan 1 interface vlan 1
    switch> enable
    switch#configure terminal
    switch(conf)#hostname host
    host (conf)# interface vlan 1
    host (conf)# ip address 192.168.1.1 255.255.255.0 //配置交换机端口IP 和子网掩码
    host (conf-if)#no shut //激活端口
    host (conf-if)#exit
    switch (conf)#ip default-gateway 192.168.254
    (6)查看命令show
    switch> enable
    switch# show version
    ②show interface vlan 1
    ③show running-configure(show run)
    ④show interface fastethernet 0/1
    show mac-address-table //查看mac 地址表
    show mac-address-table aging-time //查看mac 地址表自动化老化时间
    (7)交换机恢复出厂默认恢复命令
    switch> enable
    switch# erase startup-configure
    switch# reload
    (8)cdp相关命令
    switch>enable
    switch#show cdp
    switch#show cdp interface fastethernet 0/1
    switch#show cdp traffic //查看有关cdp包的统计信息
    switch#show cdp nerghbors //列出与设备相连的cisco设备
    (9)交换机telnet 远程登录设置:
    switch>en
    switch#configure terminal
    swich(conf)#enable password cisco //以cisco 为特权模式密码
    swich(conf)#interface vlan 1 //以vlan 1端口作为远程登录的接口,其他端口亦可
    swich(conf-if)#ip address 192.168.1.1 255.255.255.0
    swich(conf-if)#no shut
    swich(conf-if)#exit
    swich(conf)line vty 0 4 //设置0-4 个用户可以telnet 远程登陆
    swich(conf-line)#login
    swich(conf-line)#password 123456
    (14)主机设置,如图16所示
    ip 192.168.1.1 //主机的ip必须和交换机虚拟接口的地址在同一网络段
    netmask 255.255.255.0 //子网掩码
    gate-way 192.168.1.2 //网关地址是交换机虚拟接口地址
    在这里插入图片描述

    图 2 交换机配置
    (15)运行,如图17所示。
    telnet 192.168.1.2,进入telnet远程登录界面,
    password: 123456
    host>en
    password:cisco
    S1dongrui#
    在这里插入图片描述

    图 3 Telnet远程登录成功
    实验六 VLAN配置

    1实验目的
    (1)掌握VLAN 的原理与作用;
    (2)掌握VLAN的基本配置;
    (3)掌握VLAN的级联配置;
    (4)进一步理解交换机的工作原理。

    2 实验内容
    (1)VLAN建立;
    (2)端口划分;
    (3)主干道(trunk)配置;
    (4)通过交换机基本配置命令实现VLAN的配置。

    3 实验原理
    (1)VLAN(Virtual Local Area Network,虚拟局域网)是指在一个物理网段内,逻辑划分成若干个虚拟同域网。VLAN 的最大特点是不受物理位置的限制,可以进行灵活的划分。VLAN具备物理网段所具备的符点。
    (2)相同VLAN的主机之间可以互相直接访问,不同 VLAN 的主机之间的互相访问必须经由路由设备进行转发。广播数据包只可以在本VLAN 内进行传播,不能传输到其他VLAN 中。VLAN可以基于端口划分、基于MAC地址划分或基于IP地址划分。
    (3)基于端口的划分是实现VLAN的方式之一,也是最常用的一种划分,它利用交换机的端口进行 VLAN 的划分,一个端口只能属于一个VLAN。

    4、实验步骤
    (1)在完成VLAN 的相关配置后,要求同一VLAN内的PC可以互通,不同VLAN间的PC不能互通。首先按照上图连接各实验设备,然后配置PC0的IP为192.168.2.1,PC1的IP为192.168.3.1,PC2的IP为192.168.2.2,PC3的IP为192.168.3.2具体配置如下。
    (2)双交换机VLAN配置实验拓扑结构如图1所示。
    在这里插入图片描述

    图 4 网络拓扑图
    (3)建立 VLAN
    Switch> en
    Switch# configure terminal //进入路由器的配置模式
    Switch(config)#hostname 15a //配置路由器的名称
    15a (config)#vlan 2 //配置VLAN2
    15a(config-vlan)#name cwb //配置vlan的名称
    15a (config-vlan)#vlan 3 //配置VLAN3
    15a(config-vlan)#name rsb //配置vlan的名称
    (4)端口的划分
    当配置交换机端口属于特定VLAN时,有两种方法:一种是在VLAN配置模式下进行,一种是在端口配置模式下进行。
    15a
    15a>enable
    15a # configure terminal
    15a configuration commands, one per line. End with CNTL/Z.
    15a (config)#interface fastethernet0/1 //进入端口fastethernet0/1
    15a (config-if)#switchport mode access //进入端口分配模式
    15a (config-if)#switchport access vlan 2 //将端口分配给 vlan 2
    15a (corfig-if)#no shut //启动端口fastethernet0/1
    15a (config-if)#exit
    15a (config)#interface fastethernet1/1 //进入端口fastethernet1/1
    15a (config-if)#switchport mode access //进入端口分配模式
    15a (config-if)#switchport access vlan 3 //将端口分配给vlan 3
    15a (config-if)#no shut //启动端口 fastethernet1/1
    15a (config-if)#exit
    15a #end
    注:更多端口划分配置与此类同。
    在这里插入图片描述

    图 5 VLAN的建立和端口的划分
    (5)配置交换机之间的链路
    配置交换机之间的链路为trunk,连接两个交换机的端口为trunk端口,并且允许所有VLAN通过。
    命令如下:
    #conf t
    (config)#interface fastethernet2/1 //进入端口fastethernet2/1
    (config-if)#switchport mode trunk //进人主干道配置模式
    (config-if)#switchport trunk allowed vlan a1l //允许所有虚拟网络通过
    (config-if)#no shut //启动端口
    (config-if)#exit
    #end
    在这里插入图片描述

    图 6 配置交换机之间的链路
    配置完成后,可以有到同一VLAN内部的PC可以互相访问,不同VLAN间的PC不能够互相访问。
    若trunk(主干道)上只允许部分虚拟网络通过,如本例中只允许vlan2通过,则可以配置如下:
    Switch#conf t
    Switch(config)#interface fastethernet2/1 //进入端口fastethernet2/1
    Switch(config-if)#switchport mode trunk //进人主干道配置模式
    Switch(config-if)#switchport trunk allowed vlan 2 //允许虚拟网络2通过
    Switch(config-if)#no shut //启动端口
    Switch(config-if)#exit
    Switch#end
    也可以使用add,remove,except等命令实现某个或部分虚拟网络是否通过与否,实验者可一一尝试不同的命令并查看其效果。
    (注:多台交换机下,每台交换机的配置类同,可参看上述配置过程。)
    (6)测试四台PC机之间的连通性。如图8,9,10所示。因为PC0和PC2属于统一vlan,所以可以Ping通,而PC1和PC3属于另外一个vlan,所以不能Ping通
    在这里插入图片描述

    图 7 网络连通性测试

    展开全文
  • 交换机Access端口配置VLAN的创建

    千次阅读 2020-05-08 10:53:28
    一.为了避免冲突域,同时扩展传统局域网以接入更多计算机,可以局域网中使用二层交换机交换机能有效隔离冲突域,但是由于...VLAN技术把-一个物理的LAN逻辑划分成多个广播域。VLAN内的主机间可以直接通信,而...

    一.为了避免冲突域,同时扩展传统局域网以接入更多计算机,可以在局域网中使用二层交换机。交换机能有效隔离冲突域,但是由于所有计算机仍处于同一个广 播域,任意
    设备都能接收到所有报文,不但降低了网络的效率,而且降低了安全性,即广播域和信息安全问题依旧存在。为了能减少广播,提高局域网安全性,人们使用虛拟局域网即
    VLAN技术把-一个物理的LAN在逻辑上划分成多个广播域。VLAN内的主机间可以直接通信,而VLAN间不能直接互通。这样,广播报文被限制在一个VLAN内,同时也提高了网络安全性。不同的VLAN使用不同的VLAN ID区分,VLAN ID的范围是0–4095,可配置的值为1~4094,0和4095为保留值。二.Access接口是交换机上用来连接用户主机的接口。
    当Access接口从主机收到一个不带VLAN标签的数据帧时,会给该数据帧加上与PVID(端口所处得到Vlan ID) 一致的VLAN标签(PVID可手工配置,默认是1,即所有交换机上的接口默认都属于VLAN1)。
    当Access接口要发送一个带VLAN标签的数据帧给主机时,首先检查该数据帧的VLAN ID是否与自己的PVID相同,若相同,则去掉VLAN标签后发送该数据帧给主机:若不相同,直接丢弃该数据帧。
    三.本实验模拟企业网络场景。
    公司内网是一个大的局域网,二层交换机S1放置在一楼,在一楼办公的部门有IT部和人事部;二层交换机S2放置在二楼,在二楼办公的部门有市场部和研发部。由于交换机组成的是一个广 播网,交换机连接的所有主机都能互相通信,而公司策略是:不同部门之间的主机不能互相通信,同一部门内的主机才可以互相访问。因此需要在交换机上划分不同的VLAN,并将连接主机的交换机接口配置成Access接口划分到相应VLAN内。
    四.建立如图所示拓扑结构
    在这里插入图片描述五.配置(配置access端口)
    (1)在交换机中创建VLAN
    a.vlan id:可创建一个VLAN
    在这里插入图片描述
    b.vlan batch id id id:可批量创建多个VLAN
    在这里插入图片描述
    (2)配置端口类型,将端口加入VLAN
    a.port link-type 类型
    b.port default vlan ID
    在这里插入图片描述六.测试
    同意VLAN可接通,不同VLAN不同。
    在这里插入图片描述

    展开全文
  • 交换机配置vlan

    千次阅读 2021-08-07 09:16:32
    文章目录1.冲突域及广播域:2..vlan是啥?...集线器/交换机的冲突域:集线器所有接口都处于一个冲突域中,交换机一个接口一个冲突域; 本网段广播:发送的消息会传达给这个网段的全体成员; 广播域:网络中能接收任一设

    1.冲突域及广播域:

    冲突:两个节点同时发送数据的情况;
    冲突域:在同一个冲突域中的每一个节点都能收到所有被发送的帧(产生冲突的范围);
    集线器/交换机的冲突域:集线器所有接口都处于一个冲突域中,交换机一个接口一个冲突域;
    本网段广播:发送的消息会传达给这个网段的全体成员;
    广播域:网络中能接收任一设备发出的广播帧的所有设备的集合(广播扩撒的范围);
    交换机/路由器的广播域:交换机的所有接口都处于一个广播域中,路由器一个接口一个广播域;
    冲突域是基于第一层(物理层);
    广播域是基于第二层(链路层)

    2…vlan是啥?

    虚拟局域网(VLAN)是一组逻辑上的设备和用户,这些设备和用户并不受物理位置的限制,可以根据功能、部门及应用等因素将它们组织起来,相互之间的通信就好像它们在同一个网段中一样,由此得名虚拟局域网。

    物理位置不同的多个主机如果划分属于同一个VLAN,则这些主机之间可以相互通信。物理位置相同的多个主机如果属于不同的VLAN,则这些主机之间不能直接通信。VLAN通常在交换机或路由器上实现,在以太网帧中增加VLAN标签来给以太网帧分类,具有相同VLAN标签的以太网帧在同一个广播域中传送。
    实现的原理:一个VLAN=一个广播域=逻辑网段(子网)

    1.分割广播域:
    物理分割;
    逻辑分割;
    2.VLAN的优点:
    隔离了广播域(广播域越小越好)
    灵活性(更易于管理)
    安全性

    3.VLAN划分/管理的方式:

    静态VLAN:(经济,简单)
    基于端口划分静态VLAN;
    动态VLAN:(成本高,复杂)
    基于MAC地址划分动态VLAN;

    4.VLAN的范围:

    2-4094 可以随意控制
    0和4095保留
    1 默认vlan 不可删除

    5.静态VLAN的创建:

    下面我们根据拓扑图来帮助理解;

    一:创建vlan:

    1.创建一个vlan:
    [ huawei ] vlan 2

    2.创建多个不连续的vlan:
    如创建vlan3,6,9
    [huawei] vlan bat 3 6 9

    3.创建多个连续的vlan:
    [huawei] vlan bat 10 to 15

    4.查看vlan信息:
    [huawei] display vlan

    二:接口划分进对应的vlan

    1.进入接口:
    [] Interface e0/0/1
    2.进入该接口的链路类型:
    [] Port link-type access
    3.将该接口划分进对应的vlan:
    [] port default vlan 3
    补充:交换机根据连接对象不同,会有不同的链路类型

    交换机连接的对象是电脑—那么接口链路为access(接入),注意:access这种类型的接口只能属于一个vlan ;

    交换机连接的对象是交换机—那么接口链路类型为trunk(主干),注意:trunk不属于任何vlan,他是一条公有链路,用来在单条链路上承载不同的vlan 流量,让其通过;

    三.开启接口:

    清除接口下所有配置(初始化接口),会导致接口关闭,所以要重新开启接口;
    []clear configuration interface e0/0/1
    []undo shutdown

    6.vlan 实验:

    1.先创建一台交换机和三台PC机:
    分别为PC1,PC2,PC3分配IP地址和子网掩码;
    在这里插入图片描述

    2.用vlan进行逻辑分割,使PC1,PC2和PC3之间不能互相通信,对广播域进行隔离;
    1)先对交换机进行必备三步设置:

    1.用户视图设置关闭弹窗
    undo terminal monitor
    Info: Current terminal monitor is off.

    2.进入系统视图,重命名设备
    system-view
    [Huawei]sysname SW1

    3.设置永不超时
    [SW1]user-interface console 0
    [SW1-ui-console0]idle-timeout 0 0
    这里查看一下vlan:

    接下来,我们创建vlan,把三个接口放进三个不同vlan里面,再看PC1,PC2和PC3之间能否通信;

    1.先创建3个vlan:
    [SW1]vlan bat 2 3 5
    Info: This operation may take a few seconds. Please wait for a moment…done.
    2.将接口e0/0/1放进vlan2中
    [SW1]interface e0/0/1
    [SW1-Ethernet0/0/1]port link-type access
    [SW1-Ethernet0/0/1]port default vlan 2

    3.将接口e0/0/2放进vlan3中
    [SW1-Ethernet0/0/1]interface e0/0/2
    [SW1-Ethernet0/0/2]port link-type access
    [SW1-Ethernet0/0/2]port default vlan 3

    4.将接口e0/0/3放进vlan5中
    [SW1-Ethernet0/0/2]interface e0/0/3
    [SW1-Ethernet0/0/3]port link-type access
    [SW1-Ethernet0/0/3]port default vlan 5
    [SW1-Ethernet0/0/3]q
    [SW1]
    现在我们再查看一下vlan:
    在这里插入图片描述验证一下PC1,PC2和PC3之间是不是互通的;

    总结:

    1.了解VLAN是什么;
    2.知道VLAN的划分;
    3.创建vlan;

    展开全文
  • 交换机配置VLAN

    千次阅读 2021-08-31 22:37:29
    交换机配置LAN0进入交换机模式进入特权模式进入到全局模式1交换机配置命令1.1创建VLAN1.2进入交换的一个物理端口1.3设定端口的模式1.4将当前端口划入到VLAN10中显示VLAN信息 0进入交换机模式 连接交换机com路口或...
  • 4 交换机划分vlan配置

    千次阅读 2022-05-09 20:06:41
    交换机划分VLAN配置
  • 交换机VLAN配置

    千次阅读 2022-04-26 18:47:19
    交换机VLAN配置 一:什么是VLAN 一:什么是VLAN VLAN(Virtual LAN),翻译成中文是“虚拟局域网”。LAN可以是由少数几台家用计算机构成的网络,也可以是数以百计的计算机构成的企业网络。VLAN所指的LAN特指使用...
  • 华三交换机配置vlan命令教程

    千次阅读 2020-12-18 22:47:16
    华三交换机配置vlan命令教程[H3C]vlan 2[H3C]undo vlan all 删除除缺省VLAN外的所有VLAN,缺省VLAN不能被删除[H3C-vlan2]port Ethernet 0/4 to Ethernet 0/7 将4到7号端口加入到VLAN2中,此命令只能用来加access端口,...
  • 一、实验要求:实现跨交换地划分vlan配置任务,使同一vlan下的主机能相互通讯 二、拓扑图如下; 三、具体实验步骤: S1交换机配置: S1>enable--进入特权模式S1#config terminal--进入全局配置模式Enter ...
  • 交换机命令行配置VLAN

    千次阅读 2022-04-05 22:42:26
    首先,打开Cisco Packet Tracer ①点击下方的终端设备,... ②点击下方的交换机,选择2960,将其拖入空白区域,如下图 ...⑥重复⑤操作,将其它终端与交换机连接起来 ...⑥为各终端配置IP地址,例: ⑦点击交换...
  • 交换机VLANIF配置

    千次阅读 2021-05-31 23:41:15
    (2)0/0/1、0/0/2、0/0/4端口配置access类型并端口加入相应的vlan (3)0/0/4端口配置为trunk类型并允许所配置的三个vlan网段通过 【R1】 (1)创建子接口 (2)利用dot1q termination vid命令
  • 随着网络规模的不断扩大,接入的主机和设备也越来越多,随之的广播流量也就越大,这样也就加重了交换机的负担,可能会导致交换机死机,因此我们就引入了VLAN技术 1、VLAN的介绍 1.1、VLAN的概念 VLAN...
  • 交换机配置vlan

    2021-04-14 19:12:16
    交换机配置vlan 【1】 单交换机配置vlan 题目:单交换机配置 vlan;要求配置为 2-3 个 vlan,每个 vlan 下包含 2-3 个端 口,可实现同vlan 正常通讯(利用 ping 指令检查),不vlan 不能通讯。 单交换机 实验拓扑图...
  • 交换机配置VLAN(思科模拟器实现)

    万次阅读 2021-12-10 18:31:34
    文章目录一、新建项目二、搭建网络拓扑1. 创建交换机2....创建好项目以后进行网络拓扑的搭建,这里首先创建两个交换机 2. 连通交换机 创建好交换机后将两个交换机通过交叉线进行连通 3. 创建主机
  • 交换机划分Vlan配置

    万次阅读 多人点赞 2018-12-05 20:35:29
    一、将PC0、PC1、PC2、PC3 IP地址分别设置为192.168.1.2、192.168.1.3、192.168.1.4、192.168.1.5,子网掩码都设置为255.225.255.0,网关也都设置为192...第一台交换机配置如下: Switch>en Switch#con...
  • 掌握如何在交换机上划分基于端口的VLAN、如何给VLAN内添加端口,理解跨交换机之间VLAN的特点 通过划分Port VLAN实现交换机的端口隔离,然后使同一VLAN里的计算机系统能跨交换机进行相互通信,而不同VLAN里的...
  • ensp交换机划分VLAN配置

    千次阅读 2022-01-31 17:39:36
    [LSW1-Ethernet0/0/1]port link-type access [LSW1-Ethernet0/0/1]port default vlan 2 [LSW1-Ethernet0/0/1]int e0/0/2 [LSW1-Ethernet0/0/2]port link-type access [LSW1-Ethernet0/0/2]port default vlan 3 [LSW1...
  • 交换机原理及VLAN配置 ** ** 1.交换机工作原理 ** 1)首先,交换机mac地址表为空处于学习状态, 2)收到某个接口发来的以太网帧后,读出发信人的mac地址和这个接口建立起对应关系。 3)由于暂时还没有收信人的接口...
  • H3C_交换机_Vlan配置

    千次阅读 2022-03-21 22:15:35
    奶奶说,没事不要和小学生比爹。 一、实验环境 HCL v2.1.2 win7操作系统 二、拓扑结构 ... trunk(可以允许多个VLAN通过,能接收和发送多个VLAN报文,一般用于交换机之间的连接) hybrid(可以允许多个.
  • LSW5三层交换机配置: # sysname LSW5 # vlan batch 10 20 # dhcp enable # ip pool 1 gateway-list 192.168.1.254 network 192.168.1.0 mask 255.255.255.0 dns-list 8.8.8.8 # ip pool 2 gateway-list 192....
  • eNSP交换机配置VLAN

    千次阅读 2021-12-22 20:42:17
    一、VLAN配置过程 1. 搭建拓扑结构 运行eNSP>新建拓扑>搭建如下图的拓扑结构>启动设备 2.测试主机间连通性 四台主机基础配置如下 10.10.1.0/24 PC1: IP地址:10.10.1.1 子网掩码:255.255.255.0 ...
  • 交换机上VLAN配置 交换机VLAN划分方式 交换机能够对冲突域进行隔离。但是,并不能有效对广播域进行隔离,所以设备的运行中往往存在广播风暴,所有设备都能接收所有报文,从而增加了其完全风险问题。目前电信...
  • ENSP实验三——跨交换机配置VLAN

    千次阅读 2021-12-09 12:59:25
    不同交换机下同一VLAN的PC互通,通过添加静态路由使不同VLAN之间的PC互通。 二、拓扑图 三、配置 1,PC PC1:IP/掩码192.168.10.1/24,GW192.168.10.254 PC2:IP/掩码192.168.20.1/24,GW192.168.20.254 ...
  • 访问并配置命令历史记录 二、 实验步骤与结果 拓扑搭建 将交换机Switch0接口3设置为trunk,并允许所有流量通过 将交换机Switch0接口1,2设置为access,并划入vlan 1 将交换机Switch1接口1设置为trunk,并允许所有...
  • 思科交换机Vlan配置

    千次阅读 2020-09-22 11:41:08
    Port-VLan ...vlan vlan-id 生成一个ID,进入配置模型 name vlan-name 为VLan取名 exit 返回全局模式 设定访问链接,决定个端口分配属于哪个VLAN configure terminal interface interface-type i
  • 交换机vlan配置

    万次阅读 2019-05-15 13:45:44
    [这里插入图片描述](https://img-blog.csdnimg.cn/20190515134018573.png?x-oss-process=image/watermark,type_ZmFuZ3poZW5naGVpdGk,shadow_10,text_aHR0cHM6Ly9ibG9nLmNzZG4ubmV0L3dlaXhpbl80NDc3NDYzOA==,size_...
  • 华为三层交换机VLAN配置

    千次阅读 2020-10-30 00:16:26
    华为ensp软件手动配置三层交换机,实现不同VLAN间数据交互 实验步骤 #手动配置各个路由器端口的ip地址 #配置其环回地址 #设置下一跳地址 使其顺时针正常通信 #各个路由器ping其余两个能够正常通信 1.打开...
  • 一、H3C交换机的基本配置我们先来了解下h3c的配置命令与功能,都是常用的,基本大部分网络配置都少不了这些命令。1、基本配置 //用户直行模式提示符,用户视图system-view //进入配置视图[H3C] sysname xxx //设置...
  • 早期以太网是一种基于CSMA/CD(Carrier Sense Multiple ...这种情况下出现了VLAN技术,这种技术可以把一个LAN划分成多个逻辑的VLAN,每个VLAN是一个广播域,VLAN内的主机间通信就和一个LAN内一样,而VLAN间则不能
  • 交换机VLAN配置实验报告

    千次阅读 2021-01-14 02:28:48
    交换机VLAN配置实验报告一、实验目的1.了解交换机的基本功能2.掌握虚拟局域网VLAN的相关知识,配置交换机VLAN功能3.掌握VLAN的创建,4.掌握VLAN间路由的接口配置5.掌握通过交换机实现VLAN见通信的配置过程二、实验...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 23,263
精华内容 9,305
关键字:

如何在交换机上access配置vlan