精华内容
下载资源
问答
  • 类似于qq的登录历史账号右边的删除按钮,一般用于客户端的登录界面,vs2008编译通过,debug文件夹可查看编译好的exe
  • 发现 列表框中的数字很混乱 ,不是按照代码添加的次序显示原因一:在列表框中必须添加新数字序列时, 必须先清除列表框中原有数据,所以必须调用清除原有数据的函数。。。 int classNum=ChooseClass.GetCurSel...

     

    使用了下列代码

     

     

     

     

    发现 列表框中的数字很混乱 ,不是按照代码中的添加的次序显示

     

     

    原因一:

     

     

    在列表框中必须添加新数字序列时,  必须先清除列表框中原有数据,所以必须调用清除原有数据的函数。。。

     

     

     int classNum=ChooseClass.GetCurSel();
     CString studentID;

     

     ((CComboBox*)GetDlgItem(IDC_COMBO2))->ResetContent();      // 使用ResetContent()函数清除原有数据


     for (int i=1;i<stuNumChoose[classNum];i++)
     { 
     
      studentID.Format(_T("%d"),i);

      ((CComboBox*)GetDlgItem(IDC_COMBO2))->AddString(studentID);

     }

     

     

     

    修改后,发现列表框中数据有了变化,但是还是达不到想象中的效果。

     

     

     

     

    原因二:

     

    根据分析,程序已经没有问题

     

    那应该是组合框属性配置有问题

     

    首先 使 SORT属性值为FALSE 。。。。。。这个列表框中的数据次序才为代码中添加的次序

     

     

     

    另外 使NO Integral Height 属性设为TRUE。。。。。这样下拉列表框的高度才为初始设置的高度,否则则是有多少项便显示多少项的高度

     

     

    NO Integral Height   意为:没有完整的高度------》当为TRUE时,表示高度为自己设定的高度 当为FALSE时,表示显示完整的高度

     

     

    通过原因一、原因二进行修改后,已经达到了理想效果。

     

     

    参考资料:

    http://blog.csdn.net/dremi/archive/2007/11/22/1898527.aspx

    http://hi.baidu.com/songwentao/blog/item/4085a74514e0742ecffca3f0.html

    http://www.cnblogs.com/fence/archive/2010/01/09/1642861.html

     

    展开全文
  • 本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。 易语言组合框添加不重复文本到列表框视频交教程源码: .版本 2 .子程序 _按钮1_被单击 .局部变量 文本, 文本型 文本 = 组合框1.内容 .如果...

    本课视频通过5种方法实现了易语言组合框添加不重复文本到列表框。

    易语言组合框添加不重复文本到列表框视频交教程源码:

    .版本 2
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    
    文本 = 组合框1.内容
    
    .如果 (列表框查找文本 (列表框1, 文本) = 真)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    .否则
    
    .如果结束
    
    .子程序 列表框查找文本, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (列表框.取项目数 (), i)
    .如果真 (要加入的文本 = 列表框.取项目文本 (i - 1))
    返回 (假)
    .如果真结束
    .计次循环尾 ()
    返回 (真)
    
    .子程序 _按钮2_被单击
    .局部变量 文本, 文本型
    
    文本 = 组合框1.内容
    
    .如果 (列表框加入项目 (列表框1, 文本) = 真)
    信息框 (“加入成功”, 0, , )
    .否则
    信息框 (“该文本【” + 文本 + “】已经存在,不要重复加入”, 16, , )
    .如果结束
    
    .子程序 列表框加入项目, 逻辑型
    .参数 列表框, 列表框
    .参数 要加入的文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (列表框.取项目数 (), i)
    .如果真 (要加入的文本 = 列表框.取项目文本 (i - 1))
    返回 (假)
    .如果真结束
    
    .计次循环尾 ()
    列表框.加入项目 (要加入的文本, )
    返回 (真)
    
    .子程序 _按钮3_被单击
    
    .如果 (列表框1.选择 (组合框1.取项目文本 (组合框1.现行选中项)) = -1)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    
    .否则
    
    .如果结束
    
    .子程序 _按钮4_被单击
    .局部变量 文本, 文本型
    
    文本 = 组合框1.内容
    
    .如果 (SendMessageA (列表框1.取窗口句柄 (), 399, 0, 文本) = -1)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    
    .否则
    信息框 (“该文本【” + 文本 + “】已经存在,不要重复加入”, 16, , )
    .如果结束
    
    .子程序 _按钮5_被单击
    .局部变量 项目数量
    .局部变量 i
    
    项目数量 = 列表框1.取项目数 ()
    .判断开始 (项目数量 = 0)
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    .判断 (项目数量 > 0)
    .计次循环首 (项目数量, i)
    .如果 (寻找文本 (列表框1.取项目文本 (i - 1), 组合框1.取项目文本 (组合框1.现行选中项), , 假) ≠ -1)
    返回 ()
    
    .否则
    
    .如果结束
    
    .计次循环尾 ()
    列表框1.加入项目 (组合框1.取项目文本 (组合框1.现行选中项), )
    
    .默认
    
    .判断结束

    源码:511遇见易语言教程

               511遇见易语言教程视频链接

               易语言组合框添加不重复文本到列表框

     

     

    展开全文
  • 向工作表中添加列表框或组合框

    千次阅读 2012-05-04 10:29:40
    添加列表框(表单控件) 如果“开发工具”选项卡未显示,请显示它。 显示“开发工具”选项卡 单击“Office 按钮” ,然后单击“Excel 选项”。 “常用”类别的“使用 Excel 时采用的首选”下,...

    http://office.microsoft.com/zh-cn/excel-help/HP010236681.aspx

    添加列表框(表单控件)

    1. 如果“开发工具”选项卡未显示,请显示它。

    隐藏显示“开发工具”选项卡

    1. 单击“Office 按钮”按钮图像 ,然后单击“Excel 选项”
    1. “常用”类别中的“使用 Excel 时采用的首选项”下,选中“在功能区显示‘开发工具’选项卡”复选框,然后单击“确定”

     注释   功能区是 Microsoft Office Fluent 用户界面的一个组件。

    1. “开发工具”选项卡上的“控件”组中,单击“插入”,然后在“表单控件”下单击“列表框”按钮图像

    “控件”组

    1. 在工作表中单击该列表框的左上角要出现的位置。
    2. “开发工具”选项卡上的“控件”组中,单击“属性”“编辑代码”按钮

     提示   也可以右键单击该控件,然后单击“设置控件格式”

    若要指定控件属性,请执行下列操作:

    1. “数据源区域”框中,输入对某个区域的单元格引用,该区域中包含要在该列表框中显示的值。
    2. “单元格链接”框中,输入包含列表框选定内容的单元格引用。

    链接单元格返回列表框内的选定项目数。区域内的第一个项目将返回值 1,区域内的第二个项目将返回值 2,依此类推。

    在公式中使用此数字以返回数据源区域内的实际项目。

    例如,甜点喜好表单上有一个链接到单元格 C1 的列表框,该列表的数据源区域是 D1:D5,该区域中的项目有“冰淇淋”(D1)、“蛋糕”(D2)、“甜露酒”(D3)、“糖果”(D4) 和“巧克力”(D5)。如果 C1 的值是 3,则基于该列表框中的当前选定内容,在单元格 B1 中输入的以下公式将返回区域 D1:D5 中的值“甜露酒”。

    =INDEX(D1:D5,C1)

    1. “选定类型”下,通过执行下列操作之一指定如何在列表框中选择项目:
      • 若要创建单项选择列表框,请单击“单一”
      • 若要创建多项选择列表框,请单击“复选”
      • 若要创建扩展选择列表框,请单击“扩展”

     注释   如果将选定类型设置为“复选”“扩展”,则在“单元格链接”框中指定的单元格将返回值 0 并且将被忽略。“复选”“扩展”选定类型需要使用 Microsoft Visual Basic for Applications (VBA) 代码。在这些情况下,请考虑使用 ActiveX 列表框控件。

    返回页首 返回页首

    添加列表框(ActiveX 控件)

    1. 如果“开发工具”选项卡未显示,请显示它。

    显示显示“开发工具”选项卡

    1. 单击“Office 按钮”按钮图像 ,然后单击“Excel 选项”
    1. “常用”类别中的“使用 Excel 时采用的首选项”下,选中“在功能区显示‘开发工具’选项卡”复选框,然后单击“确定”

     注释   功能区是 Microsoft Office Fluent 用户界面的一个组件。

    1. “开发工具”选项卡上的“控件”组中,单击“插入”,然后在“ActiveX 控件”下单击“列表框”按钮图像

    “控件”组

    1. 在工作表中单击该列表框的左上角要出现的位置。
    2. 若要编辑 ActiveX 控件,请确保处于设计模式。在“开发工具”选项卡上的“控件”组中,打开“设计模式”按钮图像
    3. 若要指定控件属性,请在“开发工具”选项卡上的“控件”组中单击“属性”“编辑代码”按钮

     提示   也可以右键单击该控件,然后单击“属性”

    “属性”对话框随即出现。若要获取有关每个属性的详细信息,请选择该属性,然后按 F1 以显示 Visual Basic 帮助 (Visual Basic 帮助:要获得 Visual Basic 帮助,可指向“工具”菜单中的“宏”,然后单击“Visual Basic 编辑器”。在“帮助”菜单上,单击“Microsoft Visual Basic 帮助”。)主题。还可以在 Visual Basic 帮助的“搜索”框中键入该属性名称。下一部分总结了可用的属性。

    按功能类别划分的属性摘要

    如果要指定 请使用此属性
    常规: 
    打开工作簿时是否加载控件。(如果是 ActiveX 控件,则忽略。)AutoLoad (Excel)
    控件是否可以接收焦点并响应用户生成的事件。Enabled(表单)
    控件是否可编辑。Locked(表单)
    控件的名称。Name(表单)
    控件附加到其下方单元格的方式(自由浮动、移动但不调整大小,或者移动并调整大小)。Placement (Excel)
    控件是否可打印。PrintObject (Excel)
    控件是可见还是隐藏。Visible(表单)
    文本: 
    字体属性(加粗、倾斜、字号、删除线、下划线和粗细)。BoldItalicSizeStrikeThroughUnderlineWeight(表单)
    输入法编辑器 (IME) 的默认运行时模式。IMEMode(表单)
    控件的大小是否可调整以显示全部或部分文本行。IntegralHeight(表单)
    是否允许选择多个项目。MultiSelect(表单)
    控件中的文本。Text(表单)
    文本在控件中的对齐方式(左对齐、居中或右对齐)。TextAlign(表单)
    数据和绑定: 
    链接至控件值的区域。LinkedCell (Excel)
    控件的内容或状态。Value(表单)
    大小和位置: 
    高度或宽度(以磅为单位)。HeightWidth(表单)
    控件与工作表的左边缘或上边缘之间的距离。LeftTop(表单)
    格式设置: 
    背景色。BackColor(表单)
    边框的颜色。BorderColor(表单)
    边框的类型(无或单线)。BorderStyle(表单)
    前景色。ForeColor(表单)
    控件是否有阴影。Shadow (Excel)
    边框的可视外观(平面、凸起、凹陷、蚀刻或凸块)。SpecialEffect(表单)
    键盘和鼠标: 
    自定义鼠标图标。MouseIcon(表单)
    用户将鼠标放在特定对象上时显示的指针类型(例如标准指针、箭头或 I 型)。MousePointer(表单)
    特定于列表框: 
    多个列的数据源。BoundColumn(表单)
    要显示的列数。ColumnCount(表单)
    作为列标题的单个行。ColumnHeads(表单)
    每列的宽度。ColumnWidths(表单)
    用于填充列表的区域。ListFillRange (Excel)
    列表样式(普通、带有选项按钮或带有复选框)。ListStyle(表单)
    在用户键入时控件搜索其列表的方式(首字母、整个条目或者未指定)MatchEntry(表单)
    当用户选择一行时要存储到“Text”属性中的列。TextColumn(表单)
    出现在列表中的最顶端位置的项目。TopIndex(表单)

     注释 

    • 若要创建启用了多项选择或扩展选择的列表框,请使用“MultiSelect”属性。在这种情况下,“LinkedCell”属性将返回值“#N/A”。必须使用 VBA 代码来处理多项选择。
    • 若要创建具有列标题的两列列表框,请将“ColumnCount”设置为“2”,将“ColumnHeads”设置为“True”、将“ColumnWidths”设置为每列需要的宽度(例如,72pt;72pt),将“ListFillRange”设置为用于填充该列表的区域(例如,B2:C6),将“BoundColumn”设置为“1”或“2”(以指示要保存的列值),并将“LinkedCell”设置为包含选定值的单元格地址。默认情况下,将列标签用作列标题(例如,“列 B”和“列 C”)。若要使用您自己的列标题,在关闭“属性”对话框之前,请将它们(例如,B1 和 C1)放在“ListFillRange”中指定的第一个值的正上方。最后,调整列表框的大小以显示两个列。
    • 若要创建在列表框中显示一个值但将另一个值保存在链接单元格中的列表框,请创建一个两列列表框,然后通过将其中一列的“ColumnWidths”值设置为“0”来隐藏该列。例如,您可以设置一个两列列表框,其中一列包含节假日的名称,第二列包含与节假日相关的日期。若要向用户显示节假日名称,请将第一列指定为“TextColumn”。若要存储节假日的日期,请将第二列指定为“BoundColumn”。若要隐藏节假日的日期,请将第二列的“ColumnWidths”属性设置为“0”。

    返回页首 返回页首

    添加组合框(表单控件)

    1. 如果“开发工具”选项卡未显示,请显示它。

    显示显示“开发工具”选项卡

    1. 单击“Office 按钮”按钮图像 ,然后单击“Excel 选项”
    1. “常用”类别中的“使用 Excel 时采用的首选项”下,选中“在功能区显示‘开发工具’选项卡”复选框,然后单击“确定”

     注释   功能区是 Microsoft Office Fluent 用户界面的一个组件。

    1. “开发工具”选项卡上的“控件”组中,单击“插入”,然后在“表单控件”下单击“组合框”按钮图像

    “控件”组

    1. 在工作表中单击该组合框的左上角要出现的位置。

    在文本框折叠时会显示下拉箭头。

    1. 若要显示文本框,请将中间偏左处的尺寸控点拖到右侧。
    2. “开发工具”选项卡上的“控件”组中,单击“属性”按钮图像

     提示   也可以右键单击该控件,然后单击“设置控件格式”

    若要指定控件属性,请执行下列操作:

    1. “数据源区域”框中,输入对某个区域的单元格引用,该区域中包含要在组合框下拉列表中显示的值。
    2. “单元格链接”框中,输入包含组合框下拉列表中的选定内容的单元格引用。

    链接单元格将返回组合框下拉列表中的选定项目数。区域内的第一个项目将返回值 1,区域内的第二个项目将返回值 2,依此类推。

    在公式中使用此数字以返回数据源区域内的实际项目。例如,甜点喜好表单上有一个链接到单元格 C1 的组合框,该列表的数据源区域是 D1:D5,该区域中的项目有“冰淇淋”(D1)、“蛋糕”(D2)、“甜露酒”(D3)、“糖果”(D4) 和“巧克力”(D5)。如果 C1 的值是 3,则基于该组合框中的当前选定内容,在单元格 B1 中输入的以下公式将返回区域 D1:D5 中的值“甜露酒”。

    =INDEX(D1:D5,C1)

     注释   如果要创建一个让用户能够在文本框内编辑文本的组合框,请考虑使用 ActiveX 组合框控件。

    1. “下拉显示项数”框中,输入要在组合框的下拉列表中显示的项数。如果值:
      • 为 0,则忽略项数,且将项数当作 1。
      • 小于“数据源区域”框中指定的区域中的项数,则显示滚动条。
      • 等于或大于“数据源区域”框中指定的区域中的项数,则不显示滚动条。

    返回页首 返回页首

    添加组合框(ActiveX 控件)

    1. 如果“开发工具”选项卡未显示,请显示它。

    显示显示“开发工具”选项卡

    1. 单击“Office 按钮”按钮图像 ,然后单击“Excel 选项”
    1. “常用”类别中的“使用 Excel 时采用的首选项”下,选中“在功能区显示‘开发工具’选项卡”复选框,然后单击“确定”

     注释   功能区是 Microsoft Office Fluent 用户界面的一个组件。

    1. “开发工具”选项卡上的“控件”组中,单击“插入”,然后在“ActiveX 控件”下单击“组合框”按钮图像

    “控件”组

    1. 在工作表中单击该组合框的左上角要出现的位置。
    2. 若要编辑 ActiveX 控件,请确保处于设计模式。在“开发工具”选项卡上的“控件”组中,打开“设计模式”按钮图像
    3. 若要指定控件属性,请在“开发工具”选项卡上的“控件”组中单击“属性”“编辑代码”按钮

     提示   也可以右键单击该控件,然后单击“属性”

    “属性”对话框随即出现。若要获取有关每个属性的详细信息,请选择该属性,然后按 F1 以显示 Visual Basic 帮助 (Visual Basic 帮助:要获得 Visual Basic 帮助,可指向“工具”菜单中的“宏”,然后单击“Visual Basic 编辑器”。在“帮助”菜单上,单击“Microsoft Visual Basic 帮助”。)主题。还可以在 Visual Basic 帮助的“搜索”框中键入该属性名称。下一部分总结了可用的属性。

    按功能类别划分的属性摘要

    如果要指定 请使用此属性
    常规: 
    打开工作簿时是否加载控件。(如果是 ActiveX 控件,则忽略。)AutoLoad (Excel)
    控件是否可以接收焦点并响应用户生成的事件。Enabled(表单)
    控件是否可编辑。Locked(表单)
    控件的名称。Name(表单)
    控件附加到其下方单元格的方式(自由浮动、移动但不调整大小,或者移动并调整大小)。Placement (Excel)
    控件是否可打印。PrintObject (Excel)
    控件是可见还是隐藏。Visible(表单)
    文本: 
    单词或字符是否是用来扩展选定内容的基本单位。AutoWordSelect(表单)
    字体属性(加粗、倾斜、字号、删除线、下划线和粗细)。BoldItalicSizeStrikeThroughUnderlineWeight(表单)
    当控件没有焦点时所选文本是否仍然突出显示。HideSelection(表单)
    输入法编辑器 (IME) 的默认运行时模式。IMEMode(表单)
    用户可以输入的最大字符数。MaxLength(表单)
    用户是否可以通过单击文本左侧来选择一行文本。SelectionMargin(表单)
    控件中的文本。Text(表单)
    文本在控件中的对齐方式(左对齐、居中或右对齐)。TextAlign(表单)
    数据和绑定: 
    链接至控件值的区域。LinkedCell (Excel)
    控件的内容或状态。Value(表单)
    大小和位置: 
    控件的大小是否可以自动调整以显示所有内容。AutoSize(表单)
    高度或宽度(以磅为单位)。HeightWidth(表单)
    控件与工作表的左边缘或上边缘之间的距离。LeftTop(表单)
    格式设置: 
    背景色。BackColor(表单)
    背景样式(透明或不透明)。BackStyle(表单)
    边框的颜色。BorderColor(表单)
    边框的类型(无或单线)。BorderStyle(表单)
    前景色。ForeColor(表单)
    控件是否有阴影。Shadow (Excel)
    边框的可视外观(平面、凸起、凹陷、蚀刻或凸块)。SpecialEffect(表单)
    键盘和鼠标: 
    在用户输入控件的最大字符数后是否发生自动制表符操作。AutoTab(表单)
    是否启用拖放功能。DragBehavior(表单)
    进入控件时的选择行为(全选或不变)。EnterFieldBehavior(表单)
    自定义鼠标图标。MouseIcon(表单)
    用户将鼠标放在特定对象上时显示的指针类型(例如标准指针、箭头或 I 型)。MousePointer(表单)
    特定于组合框: 
    多个列的数据源。BoundColumn(表单)
    要显示的列数。ColumnCount(表单)
    作为列标题的单个行。ColumnHeads(表单)
    每列的宽度。ColumnWidths(表单)
    在下拉按钮上显示的符号(下箭头、普通、省略号或下划线)。DropButtonStyle(表单)
    用于填充列表的区域。ListFillRange (Excel)
    要在列表中显示的最大行数。ListRows(表单)
    列表样式(普通、带有选项按钮或带有复选框)。ListStyle(表单)
    列表的宽度。ListWidth(表单)
    在用户键入时控件搜索其列表的方式(首字母、整个条目或者未指定)MatchEntry(表单)
    作为文本输入的值是否必须与现有列表中的条目相匹配。MatchRequired(表单)
    何时显示下拉按钮(从不、有焦点时或者始终)。ShowDropButtonWhen(表单)
    用户选择或设置值的方式(下拉组合框或下拉列表)。Style(表单)
    当用户选择一行时要存储到“Text”属性中的列。TextColumn(表单)
    出现在列表中的最顶端位置的项目。TopIndex(表单)

     注释 

    • 若要创建具有列标题的两列组合框,请将“ColumnCount”设置为“2”,将“ColumnHeads”设置为“True”,将“ColumnWidths”设置为每列需要的宽度(例如,72pt;72pt),将“ListFillRange”设置为用于填充该列表的区域(例如,B1:C6),将“BoundColumn”设置为“1”或“2”(以指示要保存的列值),将“TextColumn”设置为要在组合框的文本框部分中显示的数据列(可与“BoundColumn”值相同或不同),并将“LinkedCell”设置为将包含选定值的单元格地址。默认情况下,将列标签用作列标题(例如,“列 B”和“列 C”)。若要使用您自己的列标题,在关闭“属性”对话框之前,请将它们(例如,B1 和 C1)放在“ListFillRange”中指定的第一个值的正上方。最后,调整组合框的大小以显示两个列。
    • 若要创建在组合框中显示一个值但将另一个值保存在链接单元格中的组合框,请创建一个两列组合框,然后通过将其中一列的“ColumnWidths”值设置为“0”来隐藏该列。例如,您可以设置一个两列组合框,其中一列包含节假日的名称,第二列包含与节假日相关的日期。若要向用户显示节假日名称,请将第一列指定为“TextColumn”。若要存储节假日的日期,请将第二列指定为“BoundColumn”。若要隐藏节假日的日期,请将第二列的“ColumnWidths”属性设置为“0”。
    • 若要创建不允许用户输入新值的组合框,请将“Style”设置为“2”。若要创建允许用户输入列表中没有的新值的组合框,请将“Style”设置为“1”(默认值)。在这种情况下,如果要动态更新列表值,必须编写 VBA 代码。

     

    展开全文
  • 组合框或列表框添加元素一、RowSource属性添加元素二、为工作表的ActiveX控件的列表框添加元素三、使用list属性添加元素四、使用additem方法添加列表项五、列表框的其他属性 一、RowSource属性添加元素 ...

    一、RowSource属性添加元素

    Private Sub UserForm_Initialize()
        Dim i As Long
        i = Sheet5.Cells(Rows.Count, 1).End(3).Row
        ListBox1.RowSource = "产品表!a1:a" & i
    End Sub
    	ListBox1.ColumnHeads = True
    

    或者是

    Private Sub UserForm_Initialize()
        Dim i As Long
        i = Sheet5.Cells(Rows.Count, 1).End(3).Row
        ListBox1.RowSource = Sheet5.Range("a1:a" & i).Address(External:=True)
        ListBox1.ColumnHeads = True
    End Sub
    
    • 如果rowsource属性指定的工作表区域不是活动工作表,那么address属性的external参数是必须的,表示外部引用。
    • 只有rowsource才能显示标题,其他additem、list或column赋值的listbox无法显示标题

    二、为工作表中的ActiveX控件中的列表框添加元素

    Private Sub ListBox1_GotFocus()
        Dim i As Long
        i = Sheet5.Cells(Rows.Count, 1).End(3).Row
        Me.ListBox1.ListFillRange = "产品表!a1:a" & i
    End Sub
    

    三、使用list属性添加元素

    Private Sub UserForm_Initialize()
    	Dim i As Long, arr
        i = Sheet5.Cells(Rows.Count, 1).End(3).Row
        arr = Sheet5.Range("a1:b" & i)
        ListBox1.List = arr
    End Sub
    
    • list用法——list(row,column),row是从0开始到listbox1.listcount-1,column是从0开始到listbox1.columncount-1
    • ListBox1.List = arr也可以写成ListBox1.List = Range(“a1”).Value

    四、使用additem方法添加列表项

    Private Sub UserForm_Initialize()
    	Dim i As Long
    	For i = 1 To Sheet5.Cells(Rows.Count, 1).End(3).Row
            ListBox1.AddItem Sheet5.Cells(i, 1)
        Next
    End Sub
    

    五、列表框的其他属性

    Private Sub UserForm_Initialize()
        Dim i As Long
        i = Sheet5.Cells(Rows.Count, 1).End(3).Row - 1
        With ListBox1
            .BackColor = RGB(0, 255, 0)
            .BorderColor = 255
            .BorderStyle = fmBorderStyleNone
            .ColumnCount = 2
            .ColumnWidths = .Width / 2
            .ColumnHeads = True
            .RowSource = "产品表!a1:a" & i
            .ControlTipText = "欢迎录入"
            .Enabled = True
            With .Font
                .Size = 10
                .Bold = True
                .Italic = False
                .Underline = True
            End With
            .ForeColor = 38
            .Height = 500
            .Width = 500
            .Left = 0
            .Top = 0
            .ListStyle = fmListStyleOption
            .ListIndex = 0
            .MultiSelect = fmMultiSelectExtended
            .TextAlign = fmTextAlignCenter
        End With
    End Sub
    

    ListBox基本属性和方法详情

    展开全文
  • 我想实现,模态对话框编辑框里输入几个值,然后点击确定按钮将其添加组合框列表中,当点击组合框列表里刚添加时响应相应消息(如:我模态对话框四个编辑框输入a、b、c、d,然后点击确定按钮,将a、b、c...
  • 易语言组合框去重复到列表

    千次阅读 2019-12-08 19:15:51
    辅助开发时,我们需要通过组合框控制一些功能,或者获取一些数据,比如把组合框里 的值添加列表框,这里就需要去除重复的,以下代码实现了这个功能。 .版本 2 .支持库 spec .支持库 EDataStructure .程序集 ...
  • 可以添加不重复的内容,添加组合框列表中
  • 本节视频教程通过三种方法实现了防止组合框重复添加项目。 易语言防止组合框重复添加项目的三种方法源码: .版本 2 .子程序 _按钮2_被单击 .如果 (组合框1.选择 (编辑框1.内容) = -1) 组合框1.加入项目 ...
  • 对话框中添加组合框的应用

    千次阅读 2011-05-28 22:00:00
    需要注意的是,Data页面的列表框,若想给组合框增加新的列表项,必须使用Ctrl+Enter键才能回车到下一行增加新的列。该组合框在程序运行的时候也不允许用户再往里添值,因此,将该组合框的Type属性选择为 Drop ...
  • 在列表框中必须添加新数字序列时, 必须先清除列表框中原有数据,所以必须调用清除原有数据的函数。。。   int classNum=ChooseClass.GetCurSel(); CString studentID; ((CComboBox*)GetDlgItem(IDC_COMBO2...
  • 组合框添加复选框的方法

    千次阅读 2013-06-02 17:15:37
    组合框可以看作是列表框和文本框的组合,因其占据的空间少,使用操作方便,常被界面设计人员用于界面开发设计有限个输入的条件下,组合框常用来代替文本框,这样从用户使用角度来看,更趋人性化,所见即所得。...
  • 摘要:C#源码,控件类库,Combox,图形组合框 C#窗体使用允许带图形(图像)的Combox组合框,这WEB已得到广泛应用,像百度空间、QQ空间用于设置用户模板的时候,可Combox下拉列表的每一最前端添加一...
  •  右键单击组合框控件,弹出的快捷菜单选择“编辑...”进入字符串编辑对话框,或选择“属性→编辑”选项卡,如图8-8所示。勾选复选框“值与值匹配”表示值与一致,确定以后不能修改值。单击右侧...
  • Java列表组合框

    千次阅读 2018-08-15 13:43:02
    列表组合框是又一类供用户选择的界面组件,用于一组选择项目选择,组合框还可以输入新的选择。 列表 列表(JList)界面表现为列表框,是JList类或它的子类的对象。程序可以在列表加入多个文本选择条目...
  • 易语言精华→ 正文 超级列表框高级应用—表弹出选择列表(组合框) 添加时间:2007-11-10 原文发表:2007-11-10 人气:675 200632620214531755.e 下载: e 文件 逆风编程技术 作者:易官方论坛 TLSWR我是借虎画猫,哈~都有...
  • 组合框列表框都可以界面上同时显示多内容,并且允许用户选中其中的某内容,列表框还允许同时选择多。这两种控件的使用,有很多相似之处;2.3.1 技术要点: Windows 预先定义了一系列“CB_ ”开头的消息...
  • LabVIEW的组合框

    2021-01-19 23:07:04
     右键单击组合框控件,弹出的快捷菜单选择“编辑...”进入字符串编辑对话框,或选择“属性→编辑”选项卡,如图8-8所示。勾选复选框“值与值匹配”表示值与一致,确定以后不能修改值。单击右侧...
  • 我原来设定组合框的类型为Drop List,下拉列表组合框的编辑框是不能编辑的,因而不能添加字符串类,改为允许编辑的Dropdown即可。 顺便介绍一下几种类型的组合框: 1.简易组合框(Simple) 简易组合框中列表...
  • 列表框和组合框 列表框是CListBox类的对象,组合框是CComboBox的对象。 列表框 属性设置 列表框的重要属性有: Selection 该属性决定用户的选择方式,缺省值为 Single 。属性值有: ①:Single ── 单项...
  • 启动窗口上添加个odbC源(拖入就可以了) b.外部数据库1.打开SQL数据库 (“192.168.202.132”, “sa”, “123456”, “tempdb”, , )---- ps:四个参数分别表示:数据库ip地址,用户名,密码,和数据库名 c....
  • 列表框、组合框

    千次阅读 2010-04-08 15:54:00
    如果项目总数超过了列表框可显示的项目数,列表框会自动添加滚动条,可以方便用户以滚动的方式来选择列表框列表框的常用属性·listcount属性:用于返回列表框中的所有选项的个数,该属性只能程序代码调用和设置...
  • 本课首先录制了易语言组合框渐变背景颜色,然后通过读写配置文件ini来实现组合框加入项目,添加项目列表 视频链接: 77 组合框读取写配置文件和列表项目视频教程源码: .版本 2 .程序集 窗口程序集_启动窗口...
  • 一、Combo Box组合框 QComboBox小部件是一个组合按钮...组合框可以编辑,允许用户修改列表中的每个组合框可以包含pixmap和字符串;insertItem()和setItemText()函数被适当重载。对于可编辑组合框,提供函数...
  • VC++60 第十二章 列表框和组合框

    千次阅读 2016-10-13 17:49:48
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框选择的会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、添加和删除...
  • 列表框和组合框的使用

    千次阅读 2010-06-24 15:21:00
    组合框是一个编辑框带一个可以下拉的列表框,用户下拉框选择的会进入编辑框,再进行后续处理,选择也可以用键盘的光标键。编辑框也可以直接输入。   本章要点 1 列表框的设计、添加...
  • 窗体上建立一个简单组合框在组合框的文本框输入数字字符,按回车键后加入到组合框列表框内,如图E.8所示;单击“交换”按钮,将列表最小值项目和第0个项目交换;最大值与最后项目交换,如图所示: 提示...
  • 易语言超级列表框表弹出选择列表源码,超级列表框表弹出选择列表,添加组合框列表内容,取表坐标信息,取表结构信息

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 68,897
精华内容 27,558
关键字:

如何在组合框中添加列表项