精华内容
下载资源
问答
  • 光纤无线电系统,具有可调的毫米波产生能力和用于上行链路连接的波长复用
  • 上行链路与下行链路

    千次阅读 2021-04-02 09:30:11
    上行链路 上行是指信号从移动台(一般指手机)到基站(2G叫BTS,3G叫NODEB,4G叫eNODEB)到BSC;如果再通俗的讲,移动通信系统中,上行链路是指信号从移动台到基站的物理通道。 移动台 (MS,Mobile station)就是...

    通信的时候在逻辑上需要两条链路:一条是出去的,一条是进来的(上行和下行)。

    上行链路
    上行是指信号从移动台(一般指手机)到基站(2G叫BTS,3G叫NODEB,4G叫eNODEB)到BSC;如果再通俗的讲,移动通信系统中,上行链路是指信号从移动台到基站的物理通道。
    移动台 (MS,Mobile station)就是各种制式的手机。其实,MS是对GSM制式手机的称呼,对于UMTS、LTE等制式的手机,现在通常称之为(User Equipment)
    用手机往外发送消息,就是一条上行链路。就像向网络传送文件,通常叫做“上传 ”一样。

    下行链路
    下行是指信号从BSC到基站(2G叫BTS,3G叫NODEB)到移动台 (一般指手机);移动通信系统中,下行链路是指信号从基站到移动台的物理信道。

    这两条链路 必须要分开,否则通信无法正常进行,由此产生双工模式。双工模式有两种,时分双工(TDD)和频分双工(FDD)
    在TDD中,上下行链路靠时隙来区分,频率是一样的,比如TD-SCDMA
    在FDD中,上下行链路靠不同的频率来区分,同时收发,比如WCDMA为了有效地区分开上下行频率,上行频率与下行频率必须有一定的间隔(保护带)一般下行频率高于上行频率

    补充说明
    无线通信网络系统的定义
    利用电磁波的辐射和传播,经过空间传送的信息 的通信方式称之为 无线电通信(Radio Communication),也 称为无线通信.
    天线:把射频载波信号变成电磁波或者把电磁波变为射频载波信号
    馈线:把发射机输出的射频载波信号高效地送至天线。

    SPI (Serial Peripheral interface) 串行外设接口(全双工bidirectional、高速的)
    AXI(Advanced extensible interface)是一种总线协议

    展开全文
  • 具有解耦上行链路/下行链路和全球覆盖性能评估的三层Hetnet的跨层双连接性设计
  • 您是否与多个提供商建立了多个Internet连接上行链路)? 您是否要透明地使用所有可用带宽? 即使某些上行链路出现故障,您是否仍要保持在线状态? 该工具可能对您有帮助! 更正式的描述 容错路由器是一个后台程序...
  • 我们还应用了统计分析,该统计分析通过考虑稳健性,参考短期变化并确定与弱连接相比的良好上行链路来量化稳定性水平。 结果表明,蜂窝上行链路的健壮性存在不可预测的时间,并且低于人们的希望。 超过50%的上​​...
  • 应答器传输模块上行链路测试信号生成的研究,骆轩,吕旌阳,应答器传输模块作为实现铁路系统地车间实时通信的核心部分,是连接地面应答器和车上列控系统的关键枢纽。随着高铁系统在国内越来
  • ProCurve Switch 2600-8-PWR是一款全面的网管型、可堆叠交换机,它配有8个自动适应10/100 PoE端口和1个双功能千兆上行链路。此款交换机在低密度外形中集成了PoE和企业级软件特性,因此更加经济有效,并且能够更好地...
  • 上行链路的热备份网关冗余

    千次阅读 2018-09-14 20:23:29
    上行的热备份网关冗余 如上图,r9为isp,8.8.8.8为r9的一个环回,模拟为外网网站,r1和r8为公司的内网核心层路由器,配置有nat转换。 r1的公网ip为19.1.1.1/24 r8的公网ip为89.1.1.8 相当于r1链接电信宽带,r8...

    双上行的热备份网关冗余

    双上行的热备份网关冗余

    如上图,r9为isp,8.8.8.8为r9的一个环回,模拟为外网网站,r1和r8为公司的内网核心层路由器,配置有nat转换。
    r1的公网ip为19.1.1.1/24 r8的公网ip为89.1.1.8 相当于r1链接电信宽带,r8链接联通宽带。在做了热备份以后,可以由r1和r8模拟出2个缺省路由指向的地址,即相当于网关的存在,然后公司的汇聚层交换机sw2和sw3写一条缺省路由指向虚拟网关ip,可实现对虚拟网关的备份,具体可使用hsrp。
    sw2为vlan2的树根和网关,vlan3的备份
    sw3为vlan3的树根和网关,vlan2的备份
    vpc6为vlan2的用户
    vpc7为vlan3的用户

    R9:

    hostname r9
    interface Loopback0
    ip address 8.8.8.8 255.255.255.0 环回接口
    interface Ethernet0/0
    ip address 19.1.1.9 255.255.255.0
    interface Ethernet0/1
    ip address 89.1.1.9 255.255.255.0
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login

    R1:

    interface Loopback0
    ip address 172.16.5.1 255.255.255.0
    !
    interface Ethernet0/0
    ip address 172.16.1.1 255.255.255.0
    ip nat inside
    ip virtual-reassembly in
    standby 1 ip 172.16.1.254 作为sw2的缺省路由地址
    standby 1 priority 101 修改优先级为101,并对上行链路e0/2口追踪
    standby 1 preempt 开启抢占性
    standby 1 track 1 decrement 10 当e0/2口的线路协议down后,优先级下降10,降为91,可被r8的100把虚网关的活动状态抢走。
    !
    interface Ethernet0/1
    ip address 172.16.4.1 255.255.255.0
    ip nat inside 定义为内网区域
    standby 2 ip 172.16.4.254 虚拟为sw3的缺省ip172.16.4.254
    standby 2 preempt 开启抢占性 (优先级默认100)
    !
    interface Ethernet0/2
    ip address 19.1.1.1 255.255.255.0
    ip nat outside 定义为外网区域
    track 1 interface Ethernet0/2 line-protocol 对e0/2口进行上行链路追踪

    router ospf 1 起路由保证内网连同性
    router-id 1.1.1.1
    network 172.16.0.0 0.0.255.255 area 0

    access-list 1 permit 172.16.0.0 0.0.255.255 写nat需要转换的acl列表
    ip nat inside source list 1 interface Ethernet0/2 overload 端口映射 将内网的ip转化为公网ip

    R8:

    interface Loopback0
    ip address 172.16.8.8 255.255.255.0
    interface Ethernet0/0
    ip address 172.16.1.8 255.255.255.0
    ip nat inside

    standby 1 ip 172.16.1.254 作为sw2的备份虚网关
    standby 1 preempt

    interface Ethernet0/1
    ip address 172.16.4.8 255.255.255.0
    ip nat inside 定义内网区域

    standby 2 ip 172.16.4.254 作为sw3的主(活动)虚网关
    standby 2 priority 101 修改优先级为101
    standby 2 preempt 开启抢占性
    standby 2 track 1 decrement 10 对e0/2口上行链路追踪

    interface Ethernet0/2
    ip address 89.1.1.8 255.255.255.0
    ip nat outside 定义外网区域

    router ospf 1 起路由保证内网连通性
    router-id 8.8.8.8
    network 172.16.0.0 0.0.255.255 area 0

    track 1 interface Ethernet0/2 line-protocol 定义追踪列表

    access-list 1 permit 172.16.0.0 0.0.255.255 定义转换的acl列表
    ip nat inside source list 1 interface Ethernet0/2 overload 端口映射

    sw2:

    spanning-tree mode mst 运行mst生成树协议
    spanning-tree extend system-id
    spanning-tree mst configuration
    instance 1 vlan 2
    instance 2 vlan 3
    spanning-tree mst 1 priority 24576
    spanning-tree mst 2 priority 28672
    定义2个上行追踪列表,可实现断一个链路不切换vlan2的网关,2条链路都断才将网关切到sw3
    track 1 interface Ethernet1/1 line-protocol
    track 2 interface Ethernet0/0 line-protocol

    interface Port-channel1
    switchport trunk encapsulation dot1q 修改封装类型为dot1q
    switchport mode trunk 建立trunk

    将连接r1的e0/0口划分为access接口化为vlan4同时将e1/1口也划分为vlan4,r1可与r8在二层下通信,为hsrp热备份创建同一冲突域的条件。
    interface Ethernet0/0
    switchport access vlan 4
    switchport mode access
    interface Ethernet1/1
    switchport access vlan 4
    switchport mode access

    与sw3连接的e0/1和e0/2口开启trunk 并聚合为channel接口
    interface Ethernet0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    !
    interface Ethernet0/2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    向下用dtp协议建立trunk
    interface Ethernet0/3
    switchport trunk encapsulation dot1q
    switchport mode dynamic desirable

    interface Ethernet1/0
    switchport trunk encapsulation dot1q
    switchport mode dynamic desirable

    interface Vlan2
    ip address 172.16.2.1 255.255.255.0
    standby 1 ip 172.16.2.254 虚拟vlan2的网关172.16.2.254
    standby 1 priority 111 修改优先级为111,一条链路断后降为101,2条都断后降为91,2条都断才会被sw3把vlan2的网关抢去
    standby 1 preempt
    standby 1 track 1 decrement 10
    standby 1 track 2 decrement 10
    !
    interface Vlan3
    ip address 172.16.3.2 255.255.255.0
    standby 2 ip 172.16.3.254 虚拟vlan3的网关172.16.3.254 并作为备份
    standby 2 preempt

    interface Vlan4
    ip address 172.16.1.100 255.255.255.0

    启动ospf路由,在内网通信时,不同vlan通信需要三层通信,必须有路由条目
    router ospf 1
    router-id 2.2.2.2
    network 172.16.0.0 0.0.255.255 area 0

    ip route 0.0.0.0 0.0.0.0 172.16.1.254 !!!将缺省路由指向172.16.1.254,r1和r8虚拟出的内外网网关,r1为172.16.1.254的主

    sw3:

    spanning-tree mode mst
    spanning-tree extend system-id
    !
    spanning-tree mst configuration
    instance 1 vlan 2
    instance 2 vlan 3
    !
    spanning-tree mst 1 priority 28672
    spanning-tree mst 2 priority 24576

    track 1 interface Ethernet0/0 line-protocol
    track 2 interface Ethernet1/1 line-protocol

    interface Port-channel1
    switchport trunk encapsulation dot1q
    switchport mode trunk

    interface Ethernet0/0
    switchport access vlan 4
    switchport mode access
    !
    interface Ethernet0/1
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    !
    interface Ethernet0/2
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 1 mode on
    !
    interface Ethernet0/3
    switchport trunk encapsulation dot1q
    switchport mode dynamic desirable
    !
    interface Ethernet1/0
    switchport trunk encapsulation dot1q
    switchport mode dynamic desirable
    !
    interface Ethernet1/1
    switchport access vlan 4
    switchport mode access

    interface Vlan2
    ip address 172.16.2.2 255.255.255.0
    standby 1 ip 172.16.2.254 虚拟vlan2的网关伟172.16.2.254,sw3为备份,sw2为主
    standby 1 preempt

    interface Vlan3
    ip address 172.16.3.1 255.255.255.0
    standby 2 ip 172.16.3.254 虚拟vlan3的网关为172.16.3.254
    standby 2 priority 111 修改优先级为111,一条链路断后降为101,2条都断后降为91,2条都断才会被sw2把vlan3的网关抢去
    standby 2 preempt
    standby 2 track 1 decrement 10
    standby 2 track 2 decrement 10
    !

    interface Vlan4
    ip address 172.16.4.100 255.255.255.0

    router ospf 1
    router-id 3.3.3.3
    network 172.16.0.0 0.0.255.255 area 0

    ip route 0.0.0.0 0.0.0.0 172.16.4.254 !!!将缺省路由指向172.16.4.254,r1和r8虚拟出的内外网网关,r8为172.16.4.254的主

    sw4:

    spanning-tree mode mst
    spanning-tree extend system-id
    !
    spanning-tree mst configuration
    instance 1 vlan 2
    instance 2 vlan 3

    interface Ethernet0/2 将vpc6划入vlan2
    switchport access vlan 2
    switchport mode access

    sw5:

    spanning-tree mode mst
    spanning-tree extend system-id
    !
    spanning-tree mst configuration
    instance 1 vlan 2
    instance 2 vlan 3

    interface Ethernet0/2 将vpc7划入vlan3
    switchport access vlan 3
    switchport mode access

    vpc6:

    NAME : VPCS[1]
    IP/MASK : 172.16.2.5/24
    GATEWAY : 172.16.2.254
    DNS :
    MAC : 00:50:79:66:68:06
    LPORT : 20000
    RHOST:PORT : 127.0.0.1:30000
    MTU : 1500

    vpc7:

    VPCS> show ip

    NAME : VPCS[1]
    IP/MASK : 172.16.3.5/24
    GATEWAY : 172.16.3.254
    DNS :
    MAC : 00:50:79:66:68:07
    LPORT : 20000
    RHOST:PORT : 127.0.0.1:30000
    MTU : 1500

    测试:先用vpc6 ping 8.8.8.8 然后关闭sw2的e0/0口 然后关闭sw2的e1/1口 然后关闭sw3的e1/1口以检测vlan2的备份情况:

    84 bytes from 8.8.8.8 icmp_seq=1 ttl=253 time=2.491 ms
    84 bytes from 8.8.8.8 icmp_seq=2 ttl=253 time=11.634 ms
    84 bytes from 8.8.8.8 icmp_seq=3 ttl=253 time=5.541 ms
    84 bytes from 8.8.8.8 icmp_seq=4 ttl=253 time=11.073 ms 正常情况下可以ping通
    84 bytes from 8.8.8.8 icmp_seq=8 ttl=253 time=9.661 ms
    84 bytes from 8.8.8.8 icmp_seq=9 ttl=253 time=2.930 ms
    8.8.8.8 icmp_seq=10 timeout sw2的e0/0口关闭 切换中
    8.8.8.8 icmp_seq=11 timeout
    8.8.8.8 icmp_seq=12 timeout
    8.8.8.8 icmp_seq=13 timeout
    8.8.8.8 icmp_seq=14 timeout
    84 bytes from 8.8.8.8 icmp_seq=15 ttl=253 time=3.743 ms 切换到sw2的e1/1口
    84 bytes from 8.8.8.8 icmp_seq=16 ttl=253 time=3.320 mss
    84 bytes from 8.8.8.8 icmp_seq=18 ttl=253 time=9.783 ms
    84 bytes from 8.8.8.8 icmp_seq=19 ttl=253 time=8.727 ms
    8.8.8.8 icmp_seq=20 timeout sw2的e1/1口关闭 切换vlan2的网关到sw3
    84 bytes from 8.8.8.8 icmp_seq=21 ttl=253 time=3.583 ms
    84 bytes from 8.8.8.8 icmp_seq=22 ttl=253 time=4.622 ms
    84 bytes from 8.8.8.8 icmp_seq=28 ttl=253 time=3.579 ms 切换成功 网关为sw3
    84 bytes from 8.8.8.8 icmp_seq=30 ttl=253 time=9.523 ms
    84 bytes from 8.8.8.8 icmp_seq=31 ttl=253 time=9.445 ms
    8.8.8.8 icmp_seq=32 timeout 关闭sw3的e1/1口 切换到e0/0口
    8.8.8.8 icmp_seq=33 timeout
    8.8.8.8 icmp_seq=34 timeout
    8.8.8.8 icmp_seq=35 timeout
    8.8.8.8 icmp_seq=36 timeout
    84 bytes from 8.8.8.8 icmp_seq=37 ttl=253 time=5.043 ms
    84 bytes from 8.8.8.8 icmp_seq=38 ttl=253 time=9.316 ms
    84 bytes from 8.8.8.8 icmp_seq=39 ttl=253 time=6.617 ms 切换成功
    84 bytes from 8.8.8.8 icmp_seq=40 ttl=253 time=3.890 ms
    84 bytes from 8.8.8.8 icmp_seq=41 ttl=253 time=6.340 ms

    先用vpc7 ping 8.8.8.8 然后关闭sw3的e1/1口 然后关闭sw3的e0/0口 然后关闭sw2的e0/0口以检测vlan3的备份情况:

    vpc7:
    84 bytes from 8.8.8.8 icmp_seq=2 ttl=253 time=2.901 ms
    84 bytes from 8.8.8.8 icmp_seq=4 ttl=253 time=7.527 ms 正常情况下可以ping通
    84 bytes from 8.8.8.8 icmp_seq=5 ttl=253 time=7.845 ms
    84 bytes from 8.8.8.8 icmp_seq=6 ttl=253 time=4.367 ms
    84 bytes from 8.8.8.8 icmp_seq=7 ttl=253 time=2.544 ms
    84 bytes from 8.8.8.8 icmp_seq=8 ttl=253 time=7.339 ms
    84 bytes from 8.8.8.8 icmp_seq=9 ttl=253 time=8.954 ms
    84 bytes from 8.8.8.8 icmp_seq=10 ttl=253 time=8.961 ms
    84 bytes from 8.8.8.8 icmp_seq=11 ttl=253 time=3.850 ms
    84 bytes from 8.8.8.8 icmp_seq=12 ttl=253 time=4.344 ms
    84 bytes from 8.8.8.8 icmp_seq=13 ttl=253 time=3.215 ms
    84 bytes from 8.8.8.8 icmp_seq=14 ttl=253 time=5.376 ms
    8.8.8.8 icmp_seq=15 timeout
    8.8.8.8 icmp_seq=16 timeout sw3的e1/1口关闭 切换中
    8.8.8.8 icmp_seq=17 timeout
    8.8.8.8 icmp_seq=18 timeout
    84 bytes from 8.8.8.8 icmp_seq=19 ttl=253 time=3.335 ms 切换到sw3的e0/0口
    84 bytes from 8.8.8.8 icmp_seq=20 ttl=253 time=7.560 ms
    84 bytes from 8.8.8.8 icmp_seq=21 ttl=253 time=13.036 ms
    84 bytes from 8.8.8.8 icmp_seq=22 ttl=253 time=3.071 ms
    84 bytes from 8.8.8.8 icmp_seq=23 ttl=253 time=6.625 ms
    84 bytes from 8.8.8.8 icmp_seq=25 ttl=253 time=7.870 ms
    8.8.8.8 icmp_seq=26 timeout sw3的e0/0口关闭 切换vlan3的网关到sw2
    8.8.8.8 icmp_seq=27 timeout
    8.8.8.8 icmp_seq=28 timeout
    8.8.8.8 icmp_seq=29 timeout
    8.8.8.8 icmp_seq=30 timeout
    8.8.8.8 icmp_seq=31 timeout
    8.8.8.8 icmp_seq=32 timeout
    8.8.8.8 icmp_seq=42 timeout
    8.8.8.8 icmp_seq=43 timeout
    84 bytes from 8.8.8.8 icmp_seq=44 ttl=253 time=9.832 ms 切换成功 网关为sw2
    84 bytes from 8.8.8.8 icmp_seq=45 ttl=253 time=7.751 ms
    84 bytes from 8.8.8.8 icmp_seq=46 ttl=253 time=5.898 ms
    84 bytes from 8.8.8.8 icmp_seq=47 ttl=253 time=4.153 ms
    84 bytes from 8.8.8.8 icmp_seq=49 ttl=253 time=3.697 ms
    84 bytes from 8.8.8.8 icmp_seq=50 ttl=253 time=4.934 ms
    84 bytes from 8.8.8.8 icmp_seq=51 ttl=253 time=8.375 ms
    8.8.8.8 icmp_seq=52 timeout 关闭sw2的e0/0口 切换到e1/1口
    8.8.8.8 icmp_seq=53 timeout
    8.8.8.8 icmp_seq=54 timeout
    8.8.8.8 icmp_seq=55 timeout
    8.8.8.8 icmp_seq=56 timeout
    8.8.8.8 icmp_seq=57 timeout
    8.8.8.8 icmp_seq=58 timeout
    84 bytes from 8.8.8.8 icmp_seq=59 ttl=253 time=4.356 ms 切换成功
    84 bytes from 8.8.8.8 icmp_seq=63 ttl=253 time=12.860 ms
    84 bytes from 8.8.8.8 icmp_seq=64 ttl=253 time=15.578 ms
    84 bytes from 8.8.8.8 icmp_seq=67 ttl=253 time=6.494 ms
    84 bytes from 8.8.8.8 icmp_seq=68 ttl=253 time=10.027 ms

    测试:用vpc6ping8.8.8.8 中间关闭r1的e0/2口 看能否切换sw2网关为r8:

    84 bytes from 8.8.8.8 icmp_seq=1 ttl=253 time=3.659 ms
    84 bytes from 8.8.8.8 icmp_seq=16 ttl=253 time=6.953 ms
    *172.16.1.1 icmp_seq=17 ttl=254 time=2.462 ms (ICMP type:3, code:1, Destination host unreachable)
    *172.16.1.1 icmp_seq=18 ttl=254 time=7.438 ms (ICMP type:3, code:1, Destination host unreachable) nat网关由r1切换到r8
    *172.16.1.1 icmp_seq=19 ttl=254 time=4.389 ms (ICMP type:3, code:1, Destination host unreachable)
    84 bytes from 8.8.8.8 icmp_seq=20 ttl=253 time=3.958 ms
    84 bytes from 8.8.8.8 icmp_seq=21 ttl=253 time=8.083 ms
    84 bytes from 8.8.8.8 icmp_seq=22 ttl=253 time=3.387 ms

    用vpc7ping 8.8.8.8 中间关闭r8的e0/2口 看能否切换sw3网关为r1:
    84 bytes from 8.8.8.8 icmp_seq=1 ttl=253 time=3.110 ms
    84 bytes from 8.8.8.8 icmp_seq=6 ttl=253 time=3.120 ms
    84 bytes from 8.8.8.8 icmp_seq=7 ttl=253 time=6.918 ms
    84 bytes from 8.8.8.8 icmp_seq=8 ttl=253 time=4.089 ms
    *172.16.4.8 icmp_seq=9 ttl=254 time=2.206 ms (ICMP type:3, code:1, Destination host unreachable)
    *172.16.4.8 icmp_seq=10 ttl=254 time=12.947 ms (ICMP type:3, code:1, Destination host unreachable)
    *172.16.4.8 icmp_seq=11 ttl=254 time=2.560 ms (ICMP type:3, code:1, Destination host unreachable)
    84 bytes from 8.8.8.8 icmp_seq=12 ttl=253 time=4.803 ms
    84 bytes from 8.8.8.8 icmp_seq=13 ttl=253 time=3.181 ms
    84 bytes from 8.8.8.8 icmp_seq=14 ttl=253 time=3.582 ms
    可以看到两个位置的热备份冗余都成功实现。

    总结:通过hsrp技术我们可以做到内网的不同vlan的网关的备份,同时,我们也可以实现汇聚层三层交换机对上行的热备份,在核心层有2台路由器的情况下,一条线路断掉后可以通过另一台路由器上外网,2条线路断裂的情况下可以切换二层网关,实现上网。 同时 使用hsrp还可以做到对路由器连接外网的线路的追踪,比路由协议的自动选路更加快速和强大。

    展开全文
  • 4.在AP的上行链路开启完整性测试功能并验证 wlan uplink-interface G1/0/1 使用STA连接SSID,并在AP上查看客户端列表 dis wlan client 使用命令关闭AP的上行接口 interface G 1/0/1 shutdown 再次在AP上查看...
  • Catalyst 2948G-L3交换机IP上行链路重定向功能将在高速以太网接口接收的业务重定向至某个千兆以太网接口。 当业务来源于高速以太网接口上的某个主机而前往另一个高速以太网接口上的主机时,2948G - L3交换机将该...

    介绍
    Catalyst 2948G-L3交换机IP上行链路重定向功能将在高速以太网接口接收的业务重定向至某个千兆以太网接口。

    当业务来源于高速以太网接口上的某个主机而前往另一个高速以太网接口上的主机时,2948G - L3交换机将该业务重定向至千兆以太网接口而非直接在这两个高速以太网接口之间对该业务进行路由。

    IP上行链路重定向功能使服务供应商能够向不同客户(例如对于网络主机)提供高速以太网接口,但拒绝对分配给其它客户的接口的访问。换言之,大多数业务位于互联网与单个共置的网络服务器之间,前者使用千兆以太网接口连接,而后者连接至高速以太网接口。

    IP上行链路重定向要求在路由表中装入一静态默认路由,该路由表指向连接到千兆以太网接口的一个上流路由器。重定向的业务转发至该上流路由器,该路由器将业务的路由返回至2948G - L3并向外转发至适当的接口。

    如果要阻止连接至高速以太网接口的主机间的某些通讯或者全部通讯,您可以在千兆以太网接口上应用访问控制表(ACL)来执行所需的业务过滤。IP上行链路重定向功能此时可发挥作用,因为Catalyst 2948G - L3交换机上的高速以太网接口不支持ACL。

    警告: IP上行链路重定向功能仅影响IP单播第3层(L3)交换业务。对于第2层(L2)交换业务或者非IP单播L3交换业务(例如IP组播或者网络数据包交换(IPX)),该功能将没有影响。此类业务将照常在高速以太网接口之间进行桥接或路由。

    对于在Catalyst 2948G - L3交换机上使用网桥群组虚拟接口(BVI)实现IP上行链路重定向功能,本文提供了一个样本配置。在Catalyst 2948G - L3交换机上,仅 Cisco IOS ® 版本12.0(10)W5(18e)以及更新的版本支持IP上行链路重定向功能。

    该样本配置并不讨论IP上行链路重定向功能对于服务供应商的有用之处。有关服务供应商如何使用该功能来隔离客户服务器之间直接通讯的信息,请参阅下面的文档:

    在Catalyst 2948G - L3交换机上配置IP上行链路重定向

    本文中的配置实例在实验室环境中产生,使用了以下设备:


    运行Cisco IOS版本12.0(10)W5(18e)的Catalyst 2948G - L3

    一个路由器(无特殊的硬件或者IOS)

    两个配置为终端站的交换机(无特殊的硬件或者IOS) 
    注意: 两个配置为终端站的两个交换机有一个分配至管理接口的IP地址和一个ip默认网关 ip_addr 声明。

    本文基于独立实验室环境中实施的的配置。在使用所有配置或者命令之前确保您了解它们的潜在影响。所有设备上的配置使用write erase 命令清除,并重新加载以确保这些设备采用默认配置。

    IP上行链路重定向配置样本1

    配置Cat2948G - L3以使station_B属于一网桥群组,且station_A连接至一路由接口。BVI用于实现通讯。

    网络图

    Figure 1: IP Uplink Redirect Example 1

    样本配置
    Cat2948G-L3#show run 
     ... 
     bridge irb 
     !-- 该命令激活完整的路由和桥接接口 (IRB)。
     ... 
     interface Fast Ethernet20 
      ip address 10.1.20.2 255.255.255.0 
      no ip directed-broadcast 
      duplex full 
      speed 100 
     ! 
     interface Fast Ethernet21 
      no ip address 
      no ip directed-broadcast 
      duplex full 
      speed 100 
      bridge-group 21
      !-- 该命令将路由接口转换成桥接接口
     ... 
     interface GigabitEthernet49 
      ip address 10.1.22.2 255.255.255.0 
      no ip directed-broadcast 
     ... 
     interface BVI21
     !--  该逻辑接口用于路由桥接接口所接受到的流量
      ip address 10.1.21.2 255.255.255.0 
      no ip directed-broadcast 
      no ip route-cache cef 
     ! 
     router rip 
      network 10.0.0.0 
     ! 
     bridge 21 protocol ieee
     !-- 该命令在此交换路由上激活桥接。
      bridge 21 route ip
     !-- 该命令在接口21上激活路由。

    检验

    IP上行链路重定向功能尚未启动,如下所示:

    Cat2948G-L3#show ip uplink 
     IP Uplink Redirect Configuration: 
     
     Running Configuration : no ip uplink-redirect 
     !-- 未激活IP上行链路重新定向功能。
     Configuration on next reload : no ip uplink-redirect
     

    该结构中对配置IP上行链路重定向的处理如下所示:

    Cat2948G-L3#configure t 
     Enter configuration commands, one per line.  End with CNTL/Z. 
     Cat2948G-L3(config)#ip uplink-redirect
     !-- 此全局配置命令激活IP上行链路重新定向功能,
     !-- 但必须在重新加载后才能生效。   
     Please save configuration and reload for this command to take effect  
     
     Cat2948G-L3#show ip uplink
     
     IP Uplink Redirect Configuration: 
     
     Running Configuration : no ip uplink-redirect 
     Configuration on next reload : ip uplink-redirect
     !-- 该功能被激活,但在重新后加载才能生效。
     
     Cat2948G-L3#reload 
     
     System configuration has been modified. Save? [yes/no]: y 
     Building configuration... 
     [OK] 
     Proceed with reload? [confirm]
     

    After reload:

    Cat2948G-L3#show ip uplink
     
     IP Uplink Redirect Configuration: 
     
     Running Configuration : ip uplink-redirect
     !-- T激活IP上行链路重新定向功能.
     Configuration on next reload : ip uplink-redirect 
     

    为了在Cat2948G - L3上完成IP上行链路重定向配置,您必须配置一静态默认路由并指向上流路由器的接口IP地址。

    在本例中,路由器的接口gig 49为上流路由器接口。接口gig 49的IP地址为10.1.22.1。您无法在ip route命令中指定一个出口接口,您必须指定下一个跳IP地址。

    Cat2948G-L3(config)#ip route 0.0.0.0 0.0.0.0 10.1.22.1
     

    路由器中的基本路由配置如下:

    路由器配置
    router#show run 
     ... 
     interface GigabitEthernet49 
      ip address 10.1.22.1 255.255.255.0 
      no ip directed-broadcast 
     ... 
     router rip 
      network 10.0.0.0 

    路由器中的路由表如下:

     router#show ip route 
     Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP 
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default 
            U - per-user static route, o - ODR 
     
     Gateway of last resort is not set 
     
          10.0.0.0/24 is subnetted, 3 subnets 
     R       10.1.20.0 [120/1] via 10.1.22.2, 00:00:21, GigabitEthernet49 
     R       10.1.21.0 [120/1] via 10.1.22.2, 00:00:21, GigabitEthernet49 
     C       10.1.22.0 is directly connected, GigabitEthernet49
     router#
     

    警告:如果上流路由器有一更好的可选路径通过Catalyst 2948G - L3高速以太网接口返回IP网络,将使用该路径,这可能导致路由环路。

    通过BVI21/路由器/gig来确保station_A和station_B之间的连通性,如下所示。

    station_A#traceroute 10.1.21.1 
     Type escape sequence to abort. 
     Tracing the route to 10.1.21.1 
     
       1 10.1.20.2 0 msec 0 msec 3 msec 
       2 10.1.22.1 0 msec 0 msec 3 msec 
       3 10.1.22.2 2 msec 0 msec 2 msec 
       4 10.1.21.1 3 msec 3 msec * 
     station_A#
     

    在本例中,通过Catalyst 2948G - L3接口fast 20(10.1.20.2 0)的轨迹重定向至上流路由器的接口gig 49(10.1.22.1),路由返回至Catalyst 2948G - L3的接口gig 49(10.1.22.2),然后再到station_B(10.1.21.1)。

    如果有需要,您可以在Cat2948G - L3的接口gig 49上应用ACL来控制站之间的接入。在下例中,对接口gig 49上应用一个输入接入表来阻止两个站的通讯:

    Cat2948G-L3#show run 
     ... 
     interface GigabitEthernet49 
      ip address 10.1.22.2 255.255.255.0 
      ip access-group 1 in 
      no ip directed-broadcast 
     ... 
     access-list 1 deny   10.1.20.1 
     access-list 1 permit any 
       
     station_A#traceroute 10.1.21.1 
     
     Type escape sequence to abort. 
     Tracing the route to 10.1.21.1 
     
       1 10.1.20.2 3 msec 0 msec 2 msec 
       2 10.1.22.1 0 msec 0 msec 3 msec 
       3  *  *  * 
       4  *  *  * 
       5  *  * 
     

    虽然此类输入ACL的方法可能并不是实现这个目标的最有效方法,但仍选择它来说明业务流量。来自station_A的业务实际上在从路由器返回至Cat2948G - L3的gig接口时被过滤。

    警告: 特定IP数据包类型(例如具有IP选项的数据包)经过交换处理。CPU根据IOS路由表对数据包进行交换。经过交换处理的数据包将不遵循IP上行链路重定向路径,且不应用所有千兆以太网接口上配置的ACL。

    [page]

    IP上行链路重定向配置样本2

    修改配置以使两个站属于两个不同的网桥群组。两个BVI使它们实现通讯。业务过滤的情况会怎样?

    网络图

    Figure 2: IP Uplink Redirect Example 2

    样本配置
    Cat2948G-L3#show run 
     ... 
     ip uplink-redirect
     !-- 该命令激活IP上行链路重新定向功能,
     !-- 并在重新加载后生效。
     bridge irb
     !-- 该命令激活IRB。
     ... 
     interface Fast Ethernet20 
      no ip address 
      no ip directed-broadcast 
      duplex full 
      speed 100 
      bridge-group 20
     !-- 该命令将路由的接口转换
     !-- 成桥接组20中的桥接接口。       
     ! 
     interface Fast Ethernet21 
      no ip address 
      no ip directed-broadcast 
      duplex full 
      speed 100 
      bridge-group 21
     !-- 该命令将路由的接口转换
     !-- 成桥接组21中的桥接接口。
      ... 
     interface GigabitEthernet49 
      ip address 10.1.22.2 255.255.255.0 
      no ip directed-broadcast 
     ... 
     interface BVI20
     !-- 该逻辑接口用于路由桥接组20中的桥接接口所
     !-- 接受到的流量
      ip address 10.1.20.2 255.255.255.0 
      no ip directed-broadcast 
      no ip route-cache cef 
      ! 
     interface BVI21
     !-- 该逻辑接口用于路由桥接组21中的桥接接口所
     !-- 接受到的流量
      ip address 10.1.21.2 255.255.255.0 
      no ip directed-broadcast 
      no ip route-cache cef 
     ! 
     router rip 
      network 10.0.0.0 
     ! 
     ip route 0.0.0.0 0.0.0.0 10.1.22.1 
     ! 
     access-list 1 deny   10.1.20.1 
     access-list 1 permit any 
     ... 
     bridge 20 protocol ieee 
      bridge 20 route ip
     !-- 该命令激活接口BVI 20上的IP路由。
     bridge 21 protocol ieee 
      bridge 21 route ip
     !-- 该命令激活接口BVI 21上的IP路由。

    检验

    如下例所示,通过Catalyst 2948G - L3上接口fast 20(10.1.20.2 0)的业务重定向至上流路由器的接口gig 49(10.1.22.1),路由返回至Catalyst 2948G - L3上的接口gig 49(10.1.22.2),然后再到(10.1.21.1):

    station_A#traceroute 10.1.21.1 
     Type escape sequence to abort. 
     Tracing the route to 10.1.21.1 
     
       1 10.1.20.2 3 msec 0 msec 2 msec 
       2 10.1.22.1 3 msec 0 msec 2 msec 
       3 10.1.22.2 3 msec 0 msec 2 msec 
       4 10.1.21.1 3 msec 0 msec *

    如下应用ACL:

     Cat2948G-L3(config)#int gig 49 
     Cat2948G-L3(config-if)#ip access-group 1 in
     

    如前所述,来自station_A的业务已经在从路由器返回至Cat2948G - L3的gig接口时被过滤,以防止两个站进行通讯。

    station_A#traceroute 10.1.21.1 
     Type escape sequence to abort. 
     Tracing the route to 10.1.21.1 
     
       1 10.1.20.2 0 msec 0 msec 3 msec 
       2 10.1.22.1 3 msec 0 msec 3 msec 
       3  *  *  * 
       4  *
    总结:没有启用上行链路重定向会由于L3交换机上存在明细条目而直接在两个快速以太网接口转发流量,而启用特性之后,本地路由表即使有这个目的明细,也会先重定向到直连的路由接口再返回来,这是该特性最显著的作用。
    展开全文
  • 2-扩展带宽 当交换机上行带宽增加时,可以增加新交换机与原交换机组成堆叠系统,将成员交换机的多条物理链路配置成一个聚合组,提高交换机的上行带宽。 3-简化组网 网络中的多台设备组成堆叠,虚拟成单一的逻辑设备...

    点击蓝字关注我们

    9da240abb0806445898af8bfa1f4891e.png

    4fbb832303e323b25f08e6b10ea9a027.png

    97847cd412b3e3aa5e659763c95fbd3d.png

    //一 交换机的堆叠iStack和集群CSS

    1- iStack

    iStack,全称Intelligent Stack--智能堆叠,是指将多台支持堆叠特性的交换机设备组合在一起,从逻辑上组合成一台整体交换设备。此特性适用于华为S系列盒式交换机S2700、S3700、S5700和S6700中低端交换机。

    2- CSS

    CSS,全称Cluster Switch System---集群,是指将两台支持集群特性的交换机设备组合在一起,从逻辑上组合成一台交换设备。,此特性适用于华为框式交换机如S7700、S9300、S9700等高端交换机,数据中心交换机 CE12800 CE16800等

    3- 作用

    堆叠iStack和集群CSS技术原理是将多台物理交换机在逻辑上合并成一台交换机,以实现将交换机性能翻倍,增加交换机接口数量、背板带宽、转发速率、提高可靠性等。在华为交换机中,iStack最多支持9台交换机合并,而在CSS中只支持2台交换机合并。

    //二 交换机的堆叠iStack

    1- iStack

    堆叠iStack(Intelligent Stack),是指将多台支持堆叠特性的交换机设备组合在一起,从逻辑上组合成一台整体交换设备。

    c109dc6ccfca848ca48c51488679a9d2.png

    2- iStack中的成员角色

    (1)主交换机:负责管理整个堆叠系统,一个堆叠系统中有且只有一个,显示为master

    (2)备用交换机:负责在主交换机故障时进行接替,一个堆叠系统中有且只有一个,显示为Standby

    (3)从交换机:一个堆叠系统中除了主交换外的所有交换机都是从交换机(包括备交换机),显示为Slave

    9ba901dec99584c9eed51b0628b5505d.pngeaa3b012cc2dc4121be0181e256b97a2.png

    3- iStack中的成员内容

    1--堆叠ID

    为了方便管理堆叠中的交换机,在一个堆叠内每一个交换机都有唯一的一个堆叠ID,可手工配置默认为0,堆叠ID对交换端口的编号有影响,具体表现为,当交换机加入一个堆叠后,它的端口号将变为:堆叠ID/子卡号/端口号(如未加入堆叠前接口为G0/0/1,加入堆叠后,如果该交换机的堆叠ID是2,那么端口G0/0/1的编号就变成了G2/0/1)

    2--堆叠优先级 Priority

    用于在堆叠中选择主和备交换机,选举原则是优先级大的为主,除了主交换机外优先级最大的为备。当优先级一样时候看MAC地址,小的成为主,堆叠系统的MAC地址是主交换机的MAC地址(这个选举和生成树中Root--根桥的选举刚好互反)

    3--堆叠的物理成员端口

    就是交换机堆叠之间连接的物理端口(根据交换机的型号不同,有固定的端口),用于收发堆叠交换机 之间的堆叠协议报文。

    4--堆叠(逻辑)端口

    堆叠的逻辑端口,需要和物理端口绑定,堆叠中所有交换机只支持2个堆叠逻辑端口(各需要绑定一个物理端口)。堆叠的逻辑端口的编号为:Stack-portn/1-2,其中n是本堆叠的ID号,如本交换机的堆叠ID为3,那么逻辑堆叠端口就是Stack-port3/1和Stack-port3/2

    5--主交换机选举

    (1)比较运行状态,优先选举最先处于启动状态的交换机成为主(备)交换机

    (2)如果堆叠中已经有多台启动成员,那么比较优先级,最高的成为主(备)交换机

    (3)如果优先级一样那么比较MAC地址,小的成为主(备)交换机

    4- iStack中折叠的实现

    1- 堆叠的的连接拓扑有两种:

    一种链式(点对点串联起来);

    901bf5e46176a0549722e33613e19dcf.png

    一种环形连接(手拉手形成环):

    25ddc25f6c6fc2a616c2260e60d389e3.png

    2- 堆叠的的连接方式

    (1) 堆叠卡的连接

     a设备之间通过专用的堆叠插卡ETPC及专用的堆叠线缆连接

     b高速稳定

     c不占用业务口

    d1706bea9661cf98d7829ed6322d948b.png

    (2)业务口连接

     a设备之间通过堆叠端口绑定的堆叠物理成员端口相连,不需要专用的堆叠插卡

     b但对具体使用的端口和线缆有要求

    96543b3b93e907d9e6256f623a12dfad.png

    //三 交换机的堆叠iStack的配置

    1- -堆叠的配置流程

    dd91d2b42e141f109e192cf4f0d66ef1.png

    2- -堆叠配置通用命令

    (1)配置SW的业务口到堆叠逻辑接口

    Switch的业务口GigabitEthernet0/0/27、GigabitEthernet0/0/28为物理成

    源端口,并加入到相应的逻辑堆叠端口。

    system-view

    [HUAWEI] sysname SwitchA----------------------------------------修改SW的名称为SwitchA

    [SwitchA] interface stack-port 0/1---------------------------------进入堆叠逻辑接口 1

    [SwitchA-stack-port0/1] port interface gigabitethernet 0/0/27 enable--------物理接口G0/0/27划入堆叠逻辑接口1中

    [SwitchA-stack-port0/1] quit

    [SwitchA] interface stack-port 0/2----------------------------------进入堆叠逻辑接口 2

    [SwitchA-stack-port0/2] port interface gigabitethernet 0/0/28 enable

    [SwitchA-stack-port0/2] quit

    丢失

    (2) 配置堆叠ID和堆叠优先级

    [SwitchA] stack slot 0 priority 200----------------------------- SwitchA的堆叠优先级为200。[SwitchA] stack slot 0 renumber 1------------------------------SwitchA的堆叠ID为1

    --------******完成配置后重新启动所有交换机使配置生效******--------------

    (3) 查看本交换机堆叠系统的基本信息。

    display stack

    //四 交换机的堆叠iStack的应用场景

    1-扩展端口数量

    ae5641a95e356d21ca3476e7e1d6e0d8.png

    当接入的用户数增加到原交换机端口密度不能满足接入需求时,可以通过组建堆叠或者在原有的堆叠系统中增加新的交换机而得到满足。

    2-扩展带宽

    301d3de9eb88df913ca7559a8c61f377.png

    当交换机上行带宽增加时,可以增加新交换机与原交换机组成堆叠系统,将成员交换机的多条物理链路配置成一个聚合组,提高交换机的上行带宽。

    3-简化组网

    fefa40e06e353ac5808a37c52db39c31.png

    网络中的多台设备组成堆叠,虚拟成单一的逻辑设备。简化后的组网不再需要使用MSTP、VRRP等协议,简化了网络配置,同时依靠跨设备的链路聚合,实现快速收敛,提高了可靠性。

    //五 结语

    本期对华为交换机的堆叠介绍就是以上内容,堆叠是一种通用技术,各个网络厂商都有自己的堆叠平台。

    运行的原理(将多台SW逻辑为一台)和运作目标(增加端口数量,增加带宽,逻辑设备为1台)乃至连接方式(专用堆叠线缆)都大体一致,区别主要在配置命令上。

    另外在交换机里我们会经常把端口聚合;堆叠;虚拟化这 三个放在一起说或者做一个比较,因为这三者有非常大的相似之处,总的来说端口聚合用于交换机自身物理接口的链路逻辑捆绑,只是单纯增加链路带宽;二堆叠适用于同型号交换机自身进行逻辑统一;虚拟化则更加灵活可以做到逻辑组成员不是同型号设备或者直连的情况。

    97847cd412b3e3aa5e659763c95fbd3d.png

    扫码

    加入课堂

    8caf234ca5251aa1d436e755eeb0de7c.png

    每晚七点半

    腾讯课堂  精彩开启

    15266a1a51f4165a8ee9e18da5d8bc10.png

    方便来自五湖四海的网络爱好者

    共同讨(吹)论(牛)交(逗)流(趣)

    热烈欢迎大家加入专属QQ群:

    ca44ab72539df52e545e835351bfa980.png

    加入即可领取:

    1、实用模拟器安装包

    2、内部精选电子书籍

    3、精品实用工程案例

    特殊时期,自我充实

    群内资料定期上传更有讲师全天技术答疑 

    f13d55e34ae796e5f87387d80f762c77.png

    展开全文
  • 上行链路的计算机网络是指从一个有线或无线连接局域网到广域网。家用路由器上的上行链路端口是一个特殊端口,用于连接到宽带调制解调器,并最终连接到互联网。某些计算机网络硬件具有设计用于插入网络电缆的上行...
  • 在实际的网络环境中,物理环路可以提高网络的可靠性,当一条线路断掉的时候,另一条链路仍然可以传输数据。但是,在交换的网络中,当交换机接收到一个求知目的地址的数据帧时,交换机的操作是将这个数据帧广播出去,...
  • 上行和下行的链路

    2007-10-13 09:09:33
    • 例一,假设核心层交换机所使用的连接数为8,而每个端口下连交换机的带宽是100M,也使用了8个端口,在交换机满负荷工作概率为60%的条件下,按照交换机的特点,干线容量的计算方式为: 8×100Mbps×60%=480Mbps ...
  • 软路由连接NAS做链路聚合

    千次阅读 2021-01-17 15:43:41
    链路聚合功能在原版OpenWRT和较老的LEDE固件上不可用,针对于软路由设备,需要注意网口速度等因素,旁路由会影响最大上行带宽,因此这里不推荐使用旁路由设置。 采用LACP的链路方案,从而实现双通道并行加速 勾选...
  • 透明的代理网关程序,用于将http,https流量传输到指定的上行链路http代理。 将为https连接透明地准备CONNECT方法(不进行中间人解密)。 GOMAXPROCS=4 https_proxy -in [::]:3128 -out gw.local:8080 如果省略,...
  • ensp-链路聚合实验

    千次阅读 2020-04-14 09:34:17
    三层链路连接两台设备,可以起到节省IP地址的作用。 二层环境中多条上行链路: 三层环境中部署有多条上行链路: 链路聚合的模式 手动模式:将多条连接同一台交换机的端口都添加到这个Eth-Trunk当中,然后再在对端...
  • 通过wifi建立p2p连接后,设备将继续保持移动设备或任何其他可用网络上的上行链路连接以实现Internet连接。 有关更多信息,请参阅 要求 最低SDK为API级别14。 一些例子 RxWifiP2pManager的实例化 mRxWifiP2pManager ...
  • 以下是我个人对LTE的理解: 首先,对于手机来说,支持我们上网的是流量,而这个网络就是所谓的4G网络。无论是联通还是移动来说,都是LTE,只...首先,你要下载东西必须连接网络吧。那么你所用的移动网络都是要经过基...
  • 在上行链路或下行链路中,多个MAC PDUs可能被连接成一个传输,图1表示了一个上行突发传输的概念。因为每 个MAC PDU由一个唯一的CID标识,接收的MAC实体能够把MAC SDU(从一个或...对上行链路连接,由BS进行分段;对下行
  • 链路聚合

    万次阅读 2019-04-14 18:56:52
    链路聚合的概念 1.常见的端口类型名称: (1)发送/接收速率为10Mbit/s的以太网端口长被称为标准以太网端口,或标准以太口、10兆以太网端口、10兆以太口、10M以太网端口、10M以太口,或10M口; (2)发送/接收...
  • 一、导论: ...如:传统以太网、 HFC 上行链路、802.11 无线局域网 研究一个对链路层很重要的问题:如何协调多个发送和接收节点对一个共享广播信道的访问,这就是多路访问问题 **多路访问协议:**节点通过

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 7,142
精华内容 2,856
关键字:

上行链路连接