精华内容
下载资源
问答
  • 下列不属于计算机网络硬件的是()以下不属于计算机硬件系统的是()。下列()不属于计算机的组成。A.软件B.硬件C.外部设备D.电源系统冯诺依曼结构计算机及特点:下列各项中不属于计算机硬件系统的主要组成部件的是()。...

    相关题目与解析

    下列不属于计算机硬件系统的是()。

    下列不属于计算机网络硬件的是()

    以下不属于计算机硬件系统的是()。

    下列()不属于计算机的组成。A.软件B.硬件C.外部设备D.电源系统

    冯诺依曼结构计算机及特点:下列各项中不属于计算机硬件系统的主要组成部件的是()。

    下列各项中.不属于计算机硬件设备的是()。A.输入设备B.输出设备C.处理设备

    计算机硬件是计算机系统中各种物理装置的总称,以下不属于计算机硬件的是?()

    一般计算机硬件系统的主要组成部件有五大部分,下列选项不属于这五部分的是()。

    下列各项中不属于计算机的硬件系统的是____。A.运算器B.控制器C.I/O设备D.软件

    下列不属于计算机网络的基本功能的是()。A.软、硬件共享B.资料共享C.负荷均衡与分布处理D.系统的

    下列选项中,()不属于基于计算机的系统的系统要素。

    下列设备中()不属于计算机网络系统中的硬件设备。A.接入设备B.接出设备c.交换设备D.服务器

    关于计算机硬件系统,下列()说法是正确的。A.软驱属于主机,软磁盘本身属于外部设备B.硬盘和显示器

    计算机控制系统包括硬件和软件,以下不属于硬件系统的是()。

    一般计算机硬件系统的主要组成部分有五大部分,下列不属于五大部分的是()A.运算器B.操作系统C.输

    计算机硬件系统的主要组成部件有五大部分,下列各项中不属于这五大部分的是()。A.运算器B.软

    展开全文
  • 下列网络设备中,能够抑制网络风暴的是( ) Ⅰ.中继器 Ⅱ.集线器 Ⅲ.网桥 Ⅳ.路由器 A.仅Ⅰ和Ⅱ B.仅Ⅲ C.仅Ⅲ和Ⅳ D.仅Ⅳ 正确答案 C 答案解析 [解析] 考查网络设备与网络风暴。 广播域是指网段上所有设备的...

    下列网络设备中,能够抑制网络风暴的是( )
    Ⅰ.中继器 Ⅱ.集线器 Ⅲ.网桥 Ⅳ.路由器

    A.仅Ⅰ和Ⅱ
    B.仅Ⅲ
    C.仅Ⅲ和Ⅳ
    D.仅Ⅳ

    正确答案
    C

    答案解析
    [解析] 考查网络设备与网络风暴。
    广播域是指网段上所有设备的集合。这些设备收听送往那个网段的所有广播。
    [*]
    冲突域:在同一个冲突域中的每一个节点都能收到所有被发送的帧;
    冲突域是基于第一层(物理层);
    广播域是基于第二层(链路层);
    中继器和集线器属于第一层设备,所以分割不了冲突域;物理层设备中继器和集线器既不隔离冲突域也不隔离广播域;
    交换机和网桥属于第二层设备,所以能分割冲突域;网桥可隔离冲突域,但不隔离广播域;
    路由器属于第三层设备,所以既能分割冲突域又能分割广播域。
    VLAN(即虚拟局域网)也可隔离广播域。
    对于不隔离广播域的设备,它们互连的不同网络都属于同一个广播域,因此扩大了广播域的范围,更容易产生网络风暴。

    转载于:https://www.cnblogs.com/benjaminfee/p/10195802.html

    展开全文
  • 设置访问网络设备特权模式口令 cisco>enable cisco#config terminal cisco(config)#enable password 密码 enable password存在的问题是它将口令以可阅读文本的形式储存在 running-config和startup-config中 ...

    一.进入 特权模式 密码
    设置访问网络设备特权模式口令
    cisco>enable
    cisco#config terminal
    cisco(config)#enable password 密码

    enable password存在的问题是它将口令以可阅读文本的形式储存在 running-config和startup-config中

    特别说明:
    Router(config)#enable password ?

         7          Specifies a HIDDEN password will follow

        LINE     The UNENCRYPTED (cleartext) 'enable' password

        level      Set exec level password


    7

            是思科自有的加密协议type7,比较简单,容易破解,这里的用法是  enable password 7  ……
    后面是加入密文才有效。这个密文通常要在以前备份的配置里拷贝才行,用于配置恢复时使用。
    比如你设置enable password cisco
    然后使用service password-encryption命令开启加密
    在show running-config里面能够看到enable password 7 104D000A0618
    104D000A0618这个值你就可以直接写在enable password 7后面,实际就是cisco密文加密的结果

     

    LINE

            直接输入密码,不加密,明文显示
     

    level   (后面讲)
             设置用户级别密码 指定密码作用于哪个级别(实际操作中会将密码加密保存)
              共15个等级  最低为1   最高为15(相当于root权限)
              进入对应的级别输入 相应的密码 
              如:Router>enable 5   (此时应输入5级密码)

     

    在网络设备中,默认情况下,除了使能加密口令外,其它所有口令都以明文格式储存在startup-config 和 running-config中。使用 service password-encryption 命令后,所有系统口令都将以加密形式存储。

    加密系统所有口令
    cisco(config)# service password-encryption 
    加密的方式是cisco私有加密方式


    取消系统口令加密
    cisco(config)# no service password-encryption 
    取消加密不会将已加密的口令恢复为可阅读文本,但是新设置的密码将会以明文存在


    二.使能密码

            思科引入新的口令控制特权模式访问,即加密口令,使能密码
    设置访问网络设备特权模式加密口令
    cisco>enable
    cisco#config terminal
    cisco(config)#enable secret 密码
    采用了MD5加密,如果配置了加密口令,则不在使用未加密口令,两种口令不能并列使用

             

     特别说明:
          
    Router(config)#enable secret ?

            0      Specifies an UNENCRYPTED password will follow

            5      Specifies an ENCRYPTED secret will follow

           LINE The UNENCRYPTED (cleartext) 'enable' secret

           level   Set exec level password


           其实对于Secret 选项来说,密码肯定是会被加密的。
           假设我要设置的密码为cisco


         0 是指:我现在即将输入的密码是原始密码,是:cisco
         5 是指:就是输入cisco 的MD5值:$1$XNRo$8FSa/XSF9DbmF6VbK6L6K
         level   :    设置用户级别密码 指定密码作用于哪个级别

     

     

    三.控制台登录密码

    配置console 访问密码

    cisco>enable
    cisco# config terminal
    cisco(config)# line console 0            切换为控制台0号 线路配置模式
    cisco(config)# password  密码           设置密码
    cisco(config)# login               将控制台线路设置为登陆需要输入口令 才能访问(否则即使设置密码也不需要输入)

    四.辅助线路

    配置vty访问密码

    cisco>enable
    cisco#config terminal
    cisco(config)#line aux 0             对aux0号 线路进行配置
    cisco(config)#password 密码     设置密码
    cisco(config)#login                   将控制台线路设置为登陆需要输入口令 才能访问(否则即使设置密码也不需要输入)

    五.虚拟终端线路(vty 同步)(tty异步) telnet  ssh

    配置vty访问密码

    cisco>enable
    cisco#config terminal
    cisco(config)#line vty 0 15 对vty0到15号 线路进行配置(最大允许16个人同时登陆,VTY线路的编号)
    cisco(config)#password 密码 设置密码
    cisco(config)#login       将控制台线路设置为登陆需要输入口令 才能访问(否则即使设置密码也不需要输入)
                                             

     

    特别说明:
       
    Router(config-line)#login ?

            authentication    authenticate using aaa method list

              local Local       password checking

       authentication    配置Telnet口登录进行AAA认证(后面讲)

     

       local        如果设置 local 则指明使用本地数据库进行身份验证,将要输入 用户名 和 密码
                      首先必须要用username xxx  password xxx命令
                      来创建你的用户并且给你的用户设置密码

     

            特别说明,在默认情况下,除了password secret外,所有cisco密码都以明文形式,存贮在路由器的配置,这些密码通过 show running-config命令来查看。这是非常不安全的行为。

            为提高密码安全性,可进行如下配置。

    1.设置最短密码长度
          cisco IOS 12.3 以后的版本,可以利用命令
          security passwords min-length 长度   
          
    设置0~16位的最短字符长度,启用后,user passwords、enable secret、line passwords、都会遵循此设置

     

    2.禁用无用连接
        在线路配置模式下,使用
        Router(config-line)#exec-timeout  时间
        该命令来控制管理接口连接时间,

     

    3.加密配置文件中的所有密码
         加密系统所有口令
         cisco(config)# service password-encryption 
        加密的方式是cisco私有加密方式,是一种可逆的加密,建议使用与enable 不同的密码


        取消系统口令加密
        cisco(config)# no service password-encryption 
        取消加密不会将已加密的口令恢复为可阅读文本,但是新设置的密码将会以明文存在

      

    4.使用本地数据库中的用户和密码执行登陆验证,有两种配置方式
          Router(config)# username 用户名  passwords 密码
          Router(config)# username 用户名 secret  密码   (用md5加密,安全性更高)

         然后在线路配置中,启用本地登陆验证
         Router(config-line)#login local

     

    5.其它的登陆安全措施

    R1(config)#login block-for 60 attempts 3 within 30
                                        //30s内连续登录失败3次后,等待60s(进入安静期)后才能再次登录
    R1(config)#login quiet-mode access-class 10  
                                           //安静期内ACL10指定的计算机仍可以远程访问本路由器
    R1(config)#login delay 2                 //登录成功后有2s延迟,即2s后才能再次登录
    R1(config)#login on-failure log        //登录失败会在日志中记录
    R1(config)#login on-success log        //登录成功会在日志中记录
    R1(config)#security authentication failure rate 5 log
                                      //连续登录失败5次后,默认等待15s后才能再次登录,并会产生日志,IOS12.3(1)
     验证配置可以使用  show login 

     

    6.设置标语
        

    配置旗标消息:

    R1(config)#banner motd @        @        //每日报告旗标(MOTD Message-of-the-day banner)   连接时

    R1(config)#banner login@        @        //登录旗标          登录前

    R1(config)#banner exec @        @        //EXEC旗标      登陆后

    R1(config)#banner incoming@        @        //传入旗标 
                                                                    在与反向Telnet线路连接的终端上显示,该旗标有助于向用户提供指令;

    R1(config)#banner slip-ppp@        @        //SLIP-PPP旗标

                           常用于兼容非Cisco系列线路Internet协议(如:SLIP和PPP拨号软件连接中),如果使用默
                                   认旗标,会导致连接问题。

     

     

     

     

     

    用户级别控制:

     

    Cisco IOS提供从0到15的16个优先权等级:

    ①默认情况下IOS有3个预定义的用户等级,分别为:

        优先权等级0:包括disable、enable、exit、help和logout命令;

        优先权等级1:User EXEC mode,即用户模式(R1>)的所有用户级命令;

        优先权等级15:Privileged EXEC mode(启用模式),包括R1#提示的所有启动级命令。


             ②2至14等级用于用户自定义的模式;
                          cisco(config)# enable secret level  级别 密码
                                                          
    设置从用户模式进入各级别 特权模式的密码
                            R1(config)# username user3 privilege 5 secret 密码
                                                          
    创建优先权等级5的user3用户

     

    ③ R1(config)# privilege mode level 级别 命令
                      命令可以更改、移动或设置上述任一级别的命令优先权,

              mode:是指路由器上的不同模式
                                    cisco(config)#privilege ?

                                           configure      Global configuration mode

                                           exec             Exec mode

                                           interface      Interface configuration mode

                                           line               Line configuration mode

                                           router           Router configuration mode

        示例:          R1(config)#privilege configure level 5 interface  
                                       //移动等级15的“interface”命令到等级5
                                      R1(config)#privilege configure level 5 ping
                                            //等级5及以上才可以使用  ping 命令

                        

     

    ④“R1(config-line)#privilege level level              命令可以修改给定线路的优先权等级。

        示例:R1(config)#line vty 3 4 

              R1(config-line)#privilege level 1        //修改VTY线路3-4的默认优先权等级为1

               使用  show privilege  命令显示当前级别 

     

     

    AAA认证:
     
    一、简介
            AAA是Authentication(认证)Authorization授权 Account记帐的简称;
            它们不是必须的也不是要同时一起使用的;
            他们可以使用路由器设备本地数据库,也可以使用外部数据库(ACS);
                    首先我们要认证,即通过密码验证;我们就算没有设置其实也用到了认证,就是登陆路由器要输入的密码,
            这个叫enable
             我们在配置了,username abc password aaa 
                                         username abc secret password
                    
    使用这个帐号的话,叫local;
             这二种是本地的数据库。
             
    如果要用到认证服务器,如 tacacs+ radius 就属于group 服务器组方式了,这时你必须要在tacacs+ radius中选一个,同时还最多可选三个其它的认证方式;当然如果你对你的服务器和网络环境有信心的话可以不选。 

    二、配置教程
    1、使用它们都是三个步骤
      1、建立帐户数据库(本地或认证服务器);
      2、定义列表;
      3、应用到接口和链路;
    2、首先我们要启用AAA功能 
      Router(config)# aaa new-model

    3、一般来说第二步定义一个本地数据库防止配置失误造成无法登陆
      Router(config)# Username abc password aaa

    4、定义认证配置
      认证相当于在问你是谁,你要回答我是哪个;但不可能不停的在问就算不烦嗓子也疼啊,只有在进门时我会问下你是谁,开保险柜时我在问下你是谁,或者是检查指纹测试瞳孔什么的等等;所以我们要对动作进行认证定义。
       Router(config)#aaa authentication  行为 列表名 认证方法
         行为主要有以下三种:
       aaa authentication login ――――――当有一个登陆行为时进行认证;
       aaa authentication ppp ――――――对基于PPP协议的一些网络应用进行认证;
       aaa authentication enable ――――――对使用enable命令进入特权模式时进行认证;
            列表名是自己定义的,这样我们可以把各种认证方式互相组合保存成一个个列表,用的时候方便,修改起来也方便,我改了一个列表里的认证方式那么所有使用这个列表的地方都改了,不需要去一个个地方去改了。
      Dedautl列表是一个系统自己建立的列表名作为缺省列表。它与我们自己建的列表没有任何区别,只不过他是系统建的而已。
    3、认证方法,就是指我们是查口令呢还是看指纹还是其它等等,也就是把我们的回答和谁进行分析比较。主要有以
      下几种:


    关键字

    描述
    enable使用enabel口令认证;
    krb5使用Kerberos5来认证;
    line使用线路口令来认证;
    local使用本地用户数据库来认证;
    none不认证;
    group radius使用radius服务器来认证;
    group tacacs+使用tacacs+服务器来认证;

     local-case           使用本地验证(对大小写敏感)


    每个列表中必须定义一种认证方法,最多可以定义四种方法,当第一种认证不通过再使用第二种,以此类推。 
    例如我们定义
    Router(config)# aaa authentication login 二号方案 group tacacs+ local
    //我们定义了一个名叫二号方案认证方式,就是先去tacacs+服务器验证,如果不成功在试试用本地帐号来试;
    Router(config)# aaa authentication login 三号方案 group local enable
    //我们定义了一个名叫三号方案认证方式,就是先用本地帐号验证,如果不成功就用enable密码来验证;

    五、应用到接口和链路
    我们上面做了那么多但是还没有效果为什么呢,就好像我们做好了报警器,指纹验证器但没装到门上你说可有效果,那当然是不行的了,我们是定义了当登陆时就启用一个列表名字叫二号方案的认证方式,但只有我们把他装到门上才能有效果啊,有人说太麻烦应该定义好了就能用,那就惨了,你给自己家的门上装了二号方案没关系,如果楼道门、院子门,都给装上了那就有问题了,所以我们要把定义好的认证方法列表装到我们需要使用认证的门上,例如我们可能对Telnet要认证,但通过console登陆的就不要认证。
    Router(config)# line vty 0 //我们先要进入接口
    Router(config-line)# aaa authentication 二号方案   //线路vty0使用名为二号方案的方式进行认证;
    或者:
    Router(config)# line vty 1
    Router(config-line)# login  authentication 三号方案


     

    aaa的一些其他命令:
        锁死失败超过限制的账号
       Router(config)# aaa local authentication at tempts max-fail 失败次数

     
    显示所有被锁死的用户
      Router# show aaa local user lockout 

      
    解除锁定
      Router(config)# clear aaa local user lockout {username 用户名| all}

     只显示aaa认证授权的用户
     Router# show aaa  user  {all | 唯一id}

     显示一个会话的唯一id
     Router# show aaa  sessions 
       

     

    AAA授权:

    配置供用户通过认证之后的AAA授权
         aaa authorization 命令
         aaa authorization {network | exec | commands level | reverse-access | configuration} {default
    |list-name}  method1 [method2~~~]
         network 为所有网络相关的服务请求进行授权,包括SLIP,PPP,PPP NCP和ARA
         exec      使用授权,以确定是否用户可以运行一个EXEC shell.
         commands 为所有处于规定的特权级别的命令使用授权
         level     规定应该被授权的命令级别,有效值 0-15
         reverse-access   为反向访问连接使用授权,例如反向Telnet
         configuration   从AAA服务器上下载配置

         default         使用此变量后列出的认证方法,作为缺省方法列表供认证
         listname        用来命令认证方法列表的字符串

         method 规定以下关键字的至少一种
           group 用radius或tacacs+服务器的一个子集来认证,这些服务器定义在aaa group server radius
    或aaa group server tacacs+命令中
           if-authenticated   如果用户为认证,允许用户访问请求的功能;
           krb5-instance      使用被kerberos instance map命令定义的实例;
           local              用本地用户名数据库来授权
           none                不用授权
    例子:
         enable secret level 1 ***    为级别1的用户建立一个enable secret口令
         enable secret level 15 ***    为级别15的用户建立一个enable secret口令
         aaa new-model   启用AAA
         aaa authentication login default enable     将enable口令作为缺省的登入方式
         aaa authentication login console-in group tacacs+ local     无论何时使用名为console-in的列
    表,都使用TACACS+认证,如果TACACS+认证失败,己用本地用户名和口令
         aaa authentication login dial-in group tacacs+    无论何时使用名为dial-in的列表,都使用
    TACACS+认证.
         username *** password ****         建立一个本地用户名和口令,最可能与console-in登录方法列
    表一起使用
         aaa authorization commands 1 alpha local    用本地用户名数据库来为所有级别1命令的使用进行
    授权  www.2cto.com  
         aaa authorization commands 15 bravo if-authenticated group tacplus local   如果用户已经认
    证了,让其运行级别15的命令,如果还未认证,在允许其访问级别15的命令之前,必须基于tacplus组中的
    TACACS+服务器来认证
         aaa authorization network charlie local none   使用本地数据库来对所有网络服务的使用授权,
    如果本地服务器不可用,此命令执行并不授权,用户能使用所有的网络服务
         aaa authorization exec delta if-authenticated group tacplus    如果用户已经认证,让其运行
    EXEC过程,如果没有认证,在允许EXEC之前,必须基于tacplus组中的TACACS+服务器来认证
         privilege exec level 1 ping   为级别1的用户启用PING
         line console 0 
         login authentication console-in   使用console-in列表作为控制台端口0的登录认证
         line s3/0
         ppp authentication chap dial-in   使用dial-in列表作接口S3/0 的PPP CHAP的登录认证

     

     

    AAA记账:

    配置规定如何写记帐记录的AAA记帐
         aaa accounting [auth-proxy |system |network |exec |connection |commands level]{default
    |list-name} [vrf vrf-name] [start-stop|stop-only|none][broadcast][method][method2]
          auth-proxy   提供有关所有认证代理用户事件的信息
          system       为所有非用户相关的系统级事件执行记帐
          network      为所有网络相关的服务请求运行记帐
          exec         为EXEC shell会话运行记帐。
          connection    提供所有有关源子NAS的外出连接的信息
          commands      为所有处于特定特权级别的命令运行记帐,有效的特权级别取值0-15
          default       使用本参数之后列出的记帐方式
          list-name     用来命令记帐方式列表的字符串
          vrf vrf-name 规定一个VRF配置
          start-stop    在一个过程的开端,发送一个开始记帐通知,在过程结束时,发送一个停止记帐通知

          stop-only     在被请求用户工程结束时发送一个停止记帐通知
          none          禁止此链路或接口上的记帐服务
          broadcast           启用发送记帐记录到多个3A服务器,同时向每个组中第一台服务器发送记帐记
    录  www.2cto.com  
          method 规定一下关键子中的至少一个
             group radius   用所有RADIUS服务器列表作为记帐
             group tacacs+ 用所有列出的TACACS+服务器来记帐
             group group-name 用RADIUS或TACACS+服务器的一个子集作为记帐
        在路由器上启用下列命令以启用几张
       aaa accounting system wait-start local   用记帐方法审计系统事件
       aaa accounting network stop-only local   当网络服务中断,发送停止记录通知
       aaa accounting exec start-stop local     当EXEC过程开始时,发送一个开始记录通知,结束时,发
    送停止记录
       aaa accounting commands 15 wait-start local   在任何级别15的命令开始之前,发送一个开始记录通
    知,并等待确认,当命令中止时,发送一个停止记录通知。
           
    6 校验配置
       debug aaa authentication 显示有关认证功能的调试信息
       debug aaa authorization 显示有关授权功能的调试信息
       debug aaa accounting     显示有关记帐功能的调试信息
     

    展开全文
  • 华为网络设备基本配置

    千次阅读 2019-09-18 07:42:23
    (一)华为网络设备的链路聚合的相关概念总揽。1、链路聚合是什么? 2、成员接口有什么限制?3、链路聚合的工作模式有哪些?4、活动接口与非活动接口的概念。5、主动端与被动端的概念。6、负载均衡模式有哪几种? ...

    本博文将围绕一个综合的网络拓扑图,把华为路由器、交换机的一些基本配置写下来。并且解释链路聚合的相关概念。

    博文大纲:

    • (一)华为网络设备的链路聚合的相关概念总揽。
      1、链路聚合是什么?
      2、成员接口有什么限制?
      3、链路聚合的工作模式有哪些?
      4、活动接口与非活动接口的概念。
      5、主动端与被动端的概念。
      6、负载均衡模式有哪几种?
    • (二)华为网络设备配置命令。
    • (三)总结

    (一)华为网络设备的链路聚合的相关概念总揽:

    • 1、链路聚合是什么?
    • 2、成员接口有什么限制?
    • 3、链路聚合的工作模式有哪些?
    • 4、活动接口与非活动接口的概念。
    • 5、主动端与被动端的概念。
    • 6、负载均衡模式有哪几种?

    1、链路聚合是什么?

    链路聚合(link aggregation)是将多个物理接口当做一个逻辑接口,以增加带宽和提供线路冗余。链路聚合的带宽理论上相当于所包含的物理接口带宽总和,非常适用于企业核心网络中,同时参与捆绑的某个成员接口或链路损坏,不影响聚合链路的正常工作,提供了冗余性。华为设备支持的链路聚合协议是LACP(link aggregation control protocol)。在华为设备中,由多个物理接口捆绑成逻辑接口,该接口被称为Eth-Trunk接口。

    2、成员接口有什么限制?

    将成员接口加入Eth-Trunk时,需要注意以下问题:

    • 每个Eth-Trunk接口下最多可以包含8个成员接口;
    • 成员接口不能单独配置任何功能和静态MAC地址;
    • 成员接口加入Eth-Trunk时,必须为默认的hybrid类型接口(该类型是华为设备默认的接口类型);
    • Eth-Trunk接口不能嵌套,即成员接口不能是Eth-Trunk;
    • 一个以太网接口只能加入一个Eth-Trunk接口,如果需要加入其它Eth-Trunk接口,必须先退出原来的Eth-Trunk接口;
    • 一个Eth-Trunk接口中的成员接口必须是同一类型,即FE口和GE口不能加入同一个Eth-Trunk接口。
    • 可以将不同接口板上的以太网接口加入同一个Eth-Trunk。
    • 如果本地设备使用了Eth-Trunk,与成员接口直连的对端接口也必须捆绑为Eth-Trunk接口,这样两端才能正常通信。
    • 当成员接口的速率不一致时,实际使用中速率小的接口可能会出现拥塞,导致丢包。
    • 当成员接口加入Eth-Trunk后,学习MAC地址时是按照Eth-Trunk来学习的,而不是按照成员接口来学习的。

    3、链路聚合的工作模式有哪些?

    华为网络设备支持的链路聚合模式有手工负载分担模式和静态LACP模式:

    • 手工负载分担模式:该模式中没有LACP协议报文的参与,所有的配置均由手工完成,如加入多个成员接口。该模式下所有接口均处于转发状态,实现链路的负载分担。它支持的负载分担方式宝库目的MAC、源MAC、源MAC异或目的MAC、源IP、目的IP、源IP异或目的IP。手工负载模式通常应用于对端设备不支持LSCP协议的情况下。
    • 静态LACP模式:该模式是线路两端利用LACP协议进行协商,从而确定活动接口和非活动接口的链路聚合方式,在该模式下,创建Eth-Trunk、加入Eth-Trunk成员接口需要手工完成,而确定活动接口和非活动接口由LACP协议进行协商。静态LACP模式也称为M : N模式。这种方式可以实现链路负载分担和冗余备份的双重功能。在链路聚合组中M条链路处于活动状态,转发数据并负载分担,而另外N条链路 处于非活动状态,不转发数据,当M条链路中有链路出现故障时,系统会自动从N条备份链路中选择优先级最高的接替故障链路,并开始转发数据。

    静态LACP模式与手工负载分担模式的主要区别为静态LACP模式可以有备份链路,而手工负载分担模式中所有成员接口均处于转发状态,分担负载流量,除非线路故障。

    4、活动接口与非活动接口的概念。

    处于活动状态并负责转发数据的接口称为活动接口。相反,处于非活动状态并禁止转发数据的接口被称为非活动接口。活动接口和非活动接口一般不需要人为干预,在静态LACP模式中可以配置活动接口数量的上限以及下限。

    根据配置的工作模式不同,角色分工如下:

    • 手工负载分担模式:正常情况下,所有接口都属于活动接口,除非这些接口出现链路故障。
    • 静态LACP模式:M条链路对应的接口为活动接口并负责转发数据,N条链路对应的接口为非活动接口并负责冗余备份。

    5、主动端与被动端的概念。

    在静态LACP模式下,聚合组两端的设备中,需要选择一端为主动端,而另一端为被动端。通常情况下,LACP优先级较高的一端为主动端,LACP优先级较低的一端为被动端。如果优先级一样,那么通常选择MAC地址小的一段为主动端。(优先级的数值越小,优先级越高)。

    区分主动端与被动端的目的是保证两端设备最终确认的活动接口一致,否则两端都按照本端各自的接口优先级来选择活动接口,最终两端所确定的活动接口很有可能不一致,聚合链路也就无法建立。如下所示:
    华为网络设备基本配置

    SwitchA选择上面的两个接口为活动接口,而SwitchB选择下面的两个接口为活动接口,因为SwitchA的优先级比较高,所以最终的活动接口两端都以SwitchA为准,因此应首先确定主动端,被动端按照主动端侧的接口优先级来选择活动接口。

    6、负载均衡模式有哪几种?

    链路聚合的主要作用是提高带宽以及增加冗余,而普遍的做法就是在多条物理链路上实行负载分担。

    常用的负载分担模式包括:

    • dst-ip(目的IP地址)模式:从目的IP地址、出端口的TCP/UDP端口号中分别选择指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • dst-mac(目的MAC地址)模式:从目的MAC地址、VLAN ID、以太网类型及入端口信息中分别指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-ip(源IP地址)模式:从源IP地址、入端口的TCP/UDP端口号中分别指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-mac(源MAC地址)模式:从源MAC地址、VLAN ID、以太网类型及入端口信息中分别指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-dst-ip(源IP地址与目的IP地址的异或)模式:对目的IP地址、源IP地址两种负载分担模式的运算结果进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。
    • src-dst-mac(源MAC地址与目的MAC地址的异或)模式:对目的MAC地址、源MAC地址、VLAN ID、以太网类型及入端口信息中分别选择指定位的3bit数值进行异或运算,根据运算结果选择Eth-Trunk表中对应的出接口。

    (二)华为网络设备配置命令:

    这里从一个大型的网络拓扑图的配置说起,将华为网络设备的基础配置命令写下来,可以下载我提供的拓扑图(提取码:ay6t ),该拓扑图不以实用性为目的,而是以涉及更多的配置命令及技术为目的。网络拓扑图如下:

    华为网络设备基本配置

    该拓扑图涉及的命令如下:

    • 链路聚合
    • vlan划分
    • 单臂路由及三层交换
    • OSPF及RIP的动态路由配置
    • 路由重分发
    • PAT及静态NAT的配置
    • 基本ACL及高级ACL配置

    网络拓扑分析:

    1)OSPF和RIP部分:
    R2为公司的网关路由器,R1模拟公网路由器,所以不可配置去往公司内部的路由。公司内网使用了两种动态路由协议,RIP和OSPF,R2的GE0/0/0、GE0/0/1两个接口和SW1、SW2使用了OSPF动态路由,属于area0。R2的GE0/0/2以及R3和R4 都是用了动态路由协议RIP。所以需要在R2路由器上进行路由重分发。从而使不同的路由协议相互学习。R2作为网关路由器,需要有一条默认路由指向公网,并且需要将这条默认路由重分发到OSPF及RIP协议里。

    2)链路聚合:

    SW1和SW2使用链路聚合将两条物理链路聚合成一条逻辑链路,用于实现负载分担和备份。设置SW1为LACP主动端,逻辑链路基于MAC方式进行负载分担。

    3)NAT及ACL:

    模拟内网中192.168.10.0/24和192.168.11.0/24这两个网段不可以连接公网,所以需要设置ACL。Windows server 2016搭建一个web服务器,使用静态NAT发布到公网,使win 7 客户端可以访问到web服务器。

    4)公司内部所有的网段都是192.168.X.0/24的网段。

    开始配置:

    网络拓扑比较大,我们分为多个部分来配置。

    第一部分的配置:

    第一部分首先从R2路由器的GE0/0/0和GE0/0/1开始往下配置,依次配置路由器接口IP地址、OSPF、三层交换机的接口、vlan、链路聚的配置、二层交换机的接口配置以及划分vlan,最终测试最下面的PC是否可以ping通路由器的GE0/0/0接口(需要在配置完OSPF后才可ping通)。

    R2路由器配置如下:
    <R2>un ter mo           <!--关闭日志提示消息(很烦人的一个东西)-->
    <R2>sys                     <!--进入系统视图-->
    [R2]ip route-static 0.0.0.0 0.0.0.0 200.0.0.2               <!--配置一个指向公网的默认路由-->
    [R2]int g0/0/0                   <!--进入该接口-->
    [R2-GigabitEthernet0/0/0]ip add 192.168.7.2 24 <!--配置接口IP,默认接口处于开启状态,所以不用开启接口-->
    [R2-GigabitEthernet0/0/0]int g0/0/1             <!--进入该接口-->
    [R2-GigabitEthernet0/0/1]ip add 192.168.8.2 24               <!--配置接口IP-->
    [R2-GigabitEthernet0/0/1]ospf 10                          <!--进入OSPF进程,指定进程号为10-->
    [R2-ospf-10]area 0                               <!--进入area0 区域-->
    [R2-ospf-10-area-0.0.0.0]net 192.168.7.0 0.0.0.255           <!--宣告相应网段-->
    [R2-ospf-10-area-0.0.0.0]net 192.168.8.0 0.0.0.255            <!--宣告相应网段-->
    [R2-ospf-10-area-0.0.0.0]quit              <!--退出area 0区域-->
    [R2-ospf-10]default-route-advertise         <!--注入一条默认路由(前提是该路由器有默认)-->
    SW1配置如下:
    <SW1>un ter mo              <!--关闭日志提示消息-->
    <SW1>sys                      <!--进入系统视图-->
    [SW1]vlan ba 2 to 8               <!--创建vlan2到vlan8-->
    [SW1]in vlan 7                        <!--进入vlan7-->
    [SW1-Vlanif7]ip add 192.168.7.1 24             <!--给vlan配置IP地址-->
    [SW1-Vlanif7]in vlan 2                           <!--进入vlan2-->
    [SW1-Vlanif2]ip add 192.168.2.254 24               <!--给vlan配置IP地址-->
    [SW1-Vlanif2]in vlan 3                                <!--进入vlan3-->
    [SW1-Vlanif3]ip add 192.168.3.254 24                   <!--给vlan配置IP地址-->
    [SW1-Vlanif3]in vlan 4                         <!--进入vlan4-->
    [SW1-Vlanif4]ip add 192.168.4.254 24                    <!--给vlan配置IP地址-->
    [SW1-Vlanif4]in g0/0/1                              <!--进入接口g0/0/1-->
    [SW1-GigabitEthernet0/0/1]port link-type access             <!--更改接口类型为access-->
    [SW1-GigabitEthernet0/0/1]port default vlan 7              <!--将接口添加到vlan 7-->
    <!--因为华为的三层交换机不可以直接在物理接口配置IP地址,
    所以只能把IP配在vlan,然后将物理接口添加到VLAN中-->
    [SW1-GigabitEthernet0/0/1]lacp pri 1000                  <!--更改该交换机的LACP优先级-->
    [SW1]int Eth-Trunk 12               <!--创建链路聚合逻辑接口,指定ID为12-->
    [SW1-Eth-Trunk12]mode lacp-static                <!--配置静态LACP模式-->
    [SW1-Eth-Trunk12]load-balance dst-mac          <!--配置负载均衡模式为目标MAC地址-->
    [SW1-Eth-Trunk12]trunkport g0/0/23                     <!--添加成员接口g0/0/23-->
    [SW1-Eth-Trunk12]trunkport g0/0/24                          <!--添加成员接口g0/0/24-->
    [SW1-Eth-Trunk12]port link-type trunk                    <!--配置链路聚合模式为trunk-->
    [SW1-Eth-Trunk12]port trunk allow-pass vlan all           
    <!--允许所有vlan通过,华为设备默认不允许除vlan1以外的所以vlan通过,所以要手动允许。-->
    [SW1-Eth-Trunk12]in g0/0/2                        <!--进入g0/0/2接口-->
    [SW1-GigabitEthernet0/0/2]port link-type trunk               <!--配置接口类型为trunk-->
    [SW1-GigabitEthernet0/0/2]port trunk allow-pass vlan all           <!--允许所有vlan通过-->
    [SW1-GigabitEthernet0/0/2]in g0/0/3           <!--进入g0/0/3接口-->
    [SW1-GigabitEthernet0/0/3]port link-type trunk            <!--配置接口类型为trunk-->
    [SW1-GigabitEthernet0/0/3]port trunk allow-pass vlan all            <!--允许所有vlan通过-->
    [SW1]ospf 10                       <!--配置OSPF-->
    [SW1-ospf-10]area 0                  <!--进入area 0-->
    [SW1-ospf-10-area-0.0.0.0]net 192.168.2.0 0.0.0.255         <!--将所有直连网段声明-->
    [SW1-ospf-10-area-0.0.0.0]net 192.168.3.0 0.0.0.255
    [SW1-ospf-10-area-0.0.0.0]net 192.168.4.0 0.0.0.255
    [SW1-ospf-10-area-0.0.0.0]net 192.168.7.0 0.0.0.255
    SW2配置如下:
    <SW2>un ter mo                         <!--关闭日志消息-->
    <SW2>sys                      <!--进入系统视图-->
    [SW2]vlan ba 2 to 8            <!--创建vlan-->
    [SW2]in vlan 8                 <!--进入vlan8-->
    [SW2-Vlanif8]ip add 192.168.8.1 24                 <!--给vlan配置IP地址-->
    [SW2-Vlanif8]in vlan 6              <!--进入vlan6-->
    [SW2-Vlanif6]ip add 192.168.6.254 24                  <!--给vlan配置IP地址-->
    [SW2-Vlanif6]in vlan 5               <!--进入vlan5-->
    [SW2-Vlanif5]ip add 192.168.5.254 24                  <!--给vlan配置IP地址-->
    [SW2-Vlanif5]in g0/0/1                 <!--进入接口g0/0/1-->
    [SW2-GigabitEthernet0/0/1]port link-type access           <!--将接口类型改为access-->
    [SW2-GigabitEthernet0/0/1]port default vlan 8             <!--将接口添加到vlan8-->
    [SW2]int Eth-Trunk 12             <!--创建聚合链路,以便与SW1对应-->
    [SW2-Eth-Trunk12]mode lacp-static               <!--配置静态LACP模式-->
    [SW2-Eth-Trunk12]trunkport g0/0/23               <!--添加成员接口g0/0/23-->
    [SW2-Eth-Trunk12]trunkport g0/0/24               <!--添加成员接口g0/0/24-->
    [SW2-Eth-Trunk12]port link-type trunk                <!--将接口类型改为trunk-->
    [SW2-Eth-Trunk12]port trunk allow-pass vlan all        <!--允许所有vlan通过-->
    [SW2-Eth-Trunk12]in g0/0/2                  <!--进入g0/0/2接口-->
    [SW2-GigabitEthernet0/0/2]port link-type trunk           <!--配置接口类型为trunk-->
    [SW2-GigabitEthernet0/0/2]port trunk allow-pass vlan all           <!--允许所有vlan通过-->
    [SW2-GigabitEthernet0/0/2]in g0/0/3                     <!--进入g0/0/3接口-->
    [SW2-GigabitEthernet0/0/3]port link-type trunk              <!--配置接口类型为trunk-->
    [SW2-GigabitEthernet0/0/3]port trunk allow-pass vlan all          <!--允许所有vlan通过-->
    [SW2]ospf 10                           <!--配置OSPF-->
    [SW2-ospf-10]area 0                 <!--进入area 0-->
    [SW2-ospf-10-area-0.0.0.0]net 192.168.8.0 0.0.0.255                  <!--将所有直连网段声明-->
    [SW2-ospf-10-area-0.0.0.0]net 192.168.5.0 0.0.0.255
    [SW2-ospf-10-area-0.0.0.0]net 192.168.6.0 0.0.0.255
    
    SW4配置如下:
    SW4>undo ter mo                <!--关闭日志消息-->
    <SW4>sys                 <!--进入系统视图-->
    [SW4]vlan ba 2 to 8             <!--创建vlan,其实这里只创建vlan2和vlan3就可以了-->
    [SW4]in g0/0/1                   <!--进入该接口-->
    [SW4-GigabitEthernet0/0/1]port link-type trunk           <!--配置接口类型为trunk-->
    [SW4-GigabitEthernet0/0/1]port trunk allow-pass vlan all          <!--允许所有vlan通过-->
    [SW4-GigabitEthernet0/0/1]in g0/0/3          <!--进入该接口-->
    [SW4-GigabitEthernet0/0/3]port link-type access                <!--将接口类型改为access-->
    [SW4-GigabitEthernet0/0/3]port default vlan 2                 <!--将接口添加到vlan2-->
    [SW4-GigabitEthernet0/0/3]in g0/0/2                  <!--进入该接口-->
    [SW4-GigabitEthernet0/0/2]port link-type access                  <!--将接口类型改为access-->
    [SW4-GigabitEthernet0/0/2]port default vlan 3                 <!--将接口添加到vlan3-->
    SW5配置如下:
    <SW5>undo ter mo                <!--关闭日志消息-->
    <SW5>sys                      <!--进入系统视图-->
    [SW5]vlan 4                  <!--创建vlan4-->
    [SW5-vlan4]quit
    [SW5]in g0/0/1             <!--进入该接口-->
    [SW5-GigabitEthernet0/0/1]port link-type trunk         <!--配置接口类型为trunk-->
    [SW5-GigabitEthernet0/0/1]port trunk allow-pass vlan all             <!--允许所有vlan通过-->
    [SW5-GigabitEthernet0/0/1]in g0/0/2               <!--进入该接口--> 
    [SW5-GigabitEthernet0/0/2]port link-type access         <!--将接口类型改为access-->
    [SW5-GigabitEthernet0/0/2]port default vlan 4                 <!--将接口添加到vlan4-->

    由于SW6、SW7和SW5的配置相比起来没有太大的差别,都是改一下接口类型,创建相应的vlan,将接口添加到vlan中,trunk接口允许所有vlan的信息通过,所以,SW6和SW7就不写注释了,相应的注释可以参考SW5的配置。

    SW6配置如下:
    <SW6>undo ter mo
    <SW6>sys
    [SW6]vlan 5
    [SW6-vlan5]in g0/0/1
    [SW6-GigabitEthernet0/0/1]port link-type trunk 
    [SW6-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [SW6-GigabitEthernet0/0/1]in g0/0/2
    [SW6-GigabitEthernet0/0/2]port link-type access 
    [SW6-GigabitEthernet0/0/2]port default vlan 5
    SW7配置如下:
    <SW7>un ter mo
    <SW7>sys
    [SW7]vlan 6
    [SW7-vlan6]in g0/0/1
    [SW7-GigabitEthernet0/0/1]port link-type trunk 
    [SW7-GigabitEthernet0/0/1]port trunk allow-pass vlan all
    [SW7-GigabitEthernet0/0/1]in g0/0/2
    [SW7-GigabitEthernet0/0/2]port link-type access 
    [SW7-GigabitEthernet0/0/2]port default vlan 6

    经过以上配置,下面的网络部分已经通了,可以自行使用PC进行ping测试。
    华为网络设备基本配置

    第二部分的配置:

    第二部分开始配置R2路由器的GE0/0/2接口到R4路由器及下面的交换机,首先配置R2路由器的GE0/0/2接口IP并配置RIP,进行OSPF和RIP的路由重分发,配置R3的接口IP及RIP路由,最后配置R4的接口IP、单臂路由及RIP路由。

    R2路由器配置如下:
    [R2]in g0/0/2                    <!--进入该接口--> 
    [R2-GigabitEthernet0/0/2]ip add 192.168.12.1 24                 <!--配置接口IP-->
    [R2-GigabitEthernet0/0/2]rip                  <!--进入RIP-->
    [R2-rip-1]ver 2                     <!--开启RIP版本2-->
    [R2-rip-1]undo summary                     <!--关闭路由自动汇总-->
    [R2-rip-1]net 192.168.12.0                    <!--声明网段信息-->
    [R2-rip-1]import-route ospf 10                 <!--充分发OSPF路由信息-->
    [R2-rip-1]default-route originate              <!--注入默认路由,前提是本设备有默认路由-->
    [R2-rip-1]ospf 10                  <!--进入OSPF-->
    [R2-ospf-10]import-route rip 1                      <!--重分发RIP路由信息,默认RIP进程号为1-->
    R3路由器配置如下:
    <R3>undo ter mo                        <!--关闭日志信息-->
    <R3>sys              <!--进入系统视图-->
    [R3]in g0/0/0                   <!--进入该接口-->
    [R3i-GigabitEthernet0/0/0]ip add 192.168.12.2 24                     <!--配置接口IP-->
    [R3-GigabitEthernet0/0/0]in g0/0/1                         <!--进入该接口-->
    [R3-GigabitEthernet0/0/1]ip add 192.168.13.1 24                <!--配置接口IP-->
    [R3-GigabitEthernet0/0/1]rip             <!--进入RIP-->
    [R3-rip-1]ver 2                   <!--指定RIP版本为2-->
    [R3-rip-1]un sum                 <!--关闭路由自动汇总-->
    [R3-rip-1]net 192.168.12.0              <!--声明相应的直连网段-->
    [R3i-rip-1]net 192.168.13.0
    
    R4路由器配置如下:
    <R4>un ter mo           <!--关闭日志信息-->
    <R4>sys                    <!--进入系统视图-->
    [R4]in g0/0/1              <!--进入该接口-->
    [R4-GigabitEthernet0/0/1]ip add 192.168.13.2 24            <!--配置接口IP-->
    [R4-GigabitEthernet0/0/1]in g0/0/0.10                   <!--配置单臂路由-->
    [R4-GigabitEthernet0/0/0.10]ip add 192.168.10.1 24               <!--配置子接口的IP地址-->
    [R4-GigabitEthernet0/0/0.10]dot ter vid 10                    <!--子接口和vlan  10 关联-->
    [R4-GigabitEthernet0/0/0.10]arp bro ena                         <!--子接口打开ARP广播-->
    [R4-GigabitEthernet0/0/0.10]in g0/0/0.11                    <!--进入子接口g0/0/0.11-->
    [R4-GigabitEthernet0/0/0.11]ip add 192.168.11.1 24              <!--配置子接口的IP地址-->
    [R4-GigabitEthernet0/0/0.11]dot1q ter vid 11                   <!--子接口和vlan  11 关联-->
    [R4-GigabitEthernet0/0/0.11]arp broadcast enable                   <!--子接口打开ARP广播-->
    [R4]rip                            <!--进入RIP-->
    [R4-rip-1]ver 2                  <!--指定RIP版本为2-->
    [R4-rip-1]un sum                 <!--关闭路由自动汇总-->
    [R4-rip-1]net 192.168.13.0                 <!--声明直连网段-->
    [R4-rip-1]net 192.168.10.0
    [R4-rip-1]net 192.168.11.0
    
    SW3交换机配置如下:
    <SW3>un ter mo                     <!--关闭日志信息-->
    <SW3>sys                    <!--进入系统视图-->
    [SW3]vlan ba 10 to 11               <!--创建响应vlan-->
    [SW3]in g0/0/1                   <!--进入该接口-->                
    [SW3-GigabitEthernet0/0/1]port link-type trunk                   <!--将接口模式改为trunk-->
    [SW3-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 to 11 <!--允许相应vlan通过,“10 to  11”也可换成“all”-->
    [SW3-GigabitEthernet0/0/1]in g0/0/2             <!--进入该接口-->
    [SW3-GigabitEthernet0/0/2]port link-type access                 <!--将接口模式改为access-->
    [SW3-GigabitEthernet0/0/2]port default vlan 10                   <!--将接口添加到vlan 10-->
    [SW3-GigabitEthernet0/0/2]in g0/0/3             <!--进入该接口-->
    [SW3-GigabitEthernet0/0/3]port link-type access                  <!--将接口模式改为access-->
    [SW3-GigabitEthernet0/0/3]port default vlan 11              <!--将接口添加到vlan 11-->

    经过上面的配置,下面这些网络就全部搞定了,可以自行使用PC机进行ping测试。

    华为网络设备基本配置

    第三部分的配置:

    现在就需要配置Internet部分了,从R2路由器的GE3/0/0接口开始配置,首先配置该接口的IP地址,然后在配置Internet路由器R1的相应接口IP地址,注意,Internet路由器R1不可配置路由表,但依然要求所有内网可以ping通win 7客户端,因为在实际中,公司内部的私网地址不可能在公网上进行路由,公网上的路由器也不可能配置路由表直接指向公司内部,这就需要用到了NAT。为了引出ACL的配置方法,就指定PC5和PC6不可以和公网进行通信,剩下的都可以。

    R2路由器配置如下:
    [R2]in g3/0/0                   <!--进入该接口-->
    [R2-GigabitEthernet3/0/0]ip add 200.0.0.1 24            <!--配置接口IP-->
    [R2-GigabitEthernet3/0/0]quit                      <!--退出该接口-->
    [R2]nat address-group 1 200.0.0.100 200.0.0.100                      <!--配置NAT组-->
    [R2]acl 2000                      <!--编写编号为2000的基本ACL-->
    [R2-acl-basic-2000]rule 0 per source any                      <!--允许所有源地址通过-->
    [R2-acl-basic-2000]quit                      <!--退出-->
    [R2]acl 3000                          <!--编写编号为3000的高级ACL-->
    [R2-acl-adv-3000]rule deny ip source 192.168.10.0 0.0.1.255 destination 200.0.0.0 0.0.0.255
    <!--拒绝某个地址访问指定地址,“192.168.10.0”是一个汇总后的地址,从反掩码可以看出-->
    [R2-acl-adv-3000]rule deny ip source 192.168.10.0 0.0.1.254 destination 201.0.0.0 0.0.0.255
    <!--拒绝某个地址访问指定地址-->
    [R2-acl-adv-3000]quit                      <!--退出-->
    [R2]in g3/0/0                      <!--进入连接Internet的接口-->
    [R2-GigabitEthernet3/0/0]nat outbound 2000 address-group 1   <!--NAT转换,2000为ACL-->
    [R2-GigabitEthernet3/0/0]nat server global 200.0.0.200 inside 192.168.2.10 
    <!--配置NAT映射,将内网服务器映射为公网IP“200.0.0.200”-->
    [R2-GigabitEthernet3/0/0]quit                      <!--退出-->
    [R2]in g0/0/2                      <!--进入该接口-->
    [R2-GigabitEthernet0/0/2]traffic-filter inbound acl 3000      <!--应用拒绝的ACL-->
    R1路由器配置如下:
    <!--只是给接口配相应的IP地址,耐心快消耗没了,就不注释了-->
    <R1>sys
    [R1]in g0/0/0
    [R1-GigabitEthernet0/0/0]ip add 200.0.0.2 24
    [R1-GigabitEthernet0/0/0]in g0/0/1
    [R1-GigabitEthernet0/0/1]ip add 201.0.0.1 24

    现在所有配置均以完成,自行配置win7和win server 2016进行测试吧,注意,win7和内网进行ping测试或访问Windows server 2016的服务时,需要ping内网映射出来的地址和服务器映射出的公网地址,而不是内网服务器的真实地址。原本打算将ACL的配置写的更详细些,但是这篇博文已经写了五个多小时了,实在没耐心了。

    附带一些用于排错的命令:

    [R2]display current-configuration              <!--查看当前设备的所有配置-->
    [R2]display ip routing-table               <!--查看路由表-->
    [SW1]display vlan               <!--查看vlan信息-->
    [SW1]display ip interface brief                              <!--查看接口状态-->
    [SW1]display current-configuration interface vlan 2 <!--查看某一个接口的当前配置信息-->
    [R2]display nat session all               <!--查看NAT转换条目-->
    [R2]display ospf peer brief                              <!--查看OSPF邻居信息-->
    [R2]display acl all                  <!--查看ACL信息-->
    [SW1]display eth-trunk 12                            <!--查看链路聚合信息-->

    (三)总结:

    该网络拓扑图需知道以下几个知识点:

    • 即使某些交换机上并没有相应vlan的客户端,但依然要创建相应vlan,如上面拓扑图中的SW1和SW2,因为当交换机收到来自某vlan的数据包时,如果他没有该vlan,那么将丢弃该数据包,但是如果中间经过了路由器,那就不一样了。
    • 华为的trunk通道默认不允许除vlan 1以外的所有vlan通信,而Cisco设备的trunk默认允许所有vlan通信,所以在配置华为设备时,在配置完基本的trunk配置后,一定要加上允许相关vlan通过trunk的命令。
    • 在配置链路聚合时,LACP的优先级值越小,优先级越高,默认情况下,系统LACP优先级为32768。在两端设备中选择LACP优先级较小的一端作为主动端,如果系统LACP优先级相同,则选择MAC地址较小的一端作为主动端。
    • 在配置OSPF是,如果想要指定router-id,可以在进入进程模式时追加router-id,如将R2的router-id设置为1.1.1.1 :“[R2]ospf 10 router-id 1.1.1.1”。
    • 华为三层交换机的二层接口没有直接提升为三层接口的命令,如Cisco中的“no switchport”,所以在和路由器直连时,只能配置vlan虚接口,然后将物理接口添加到vlan中。
    • 在华为中,只能以标准的方式宣告RIP网络,如网段进行子网划分后为“10.10.5.0/24”,在宣告网段时,也只能宣告为“10.0.0.0”,但是需要注意,如果网络中有经过子网划分的网络,那么一定要使用RIP的版本2(默认为1),并且关闭自动汇总。
    • 华为的NAT转换直接配置在外部接口模式下,需要转换的内部流量需要通过ACL来定义,而转换后的内部全局地址通过配置NAT组来实现。
    • 华为的ACL与Cisco基本相似,华为的ACL分为基本和高级两种,类似于Cisco的标准和扩展。其中基本的编号为2000~2999,高级的编号为3000~3999,rule命令字后面可以加编号,也可以省略,默认每个rule之间相隔5个数,因为ACL的规则是匹配即停,所以这样使为了方便以后更改rule时,可以插入到某个rule之前。
    展开全文
  •  设备下列两种情况下进行注册: 1)加载NIC驱动时 2)插入热插拔设备时  这里NIC与热插拔设备有些不同。a.对于非热插拔NIC来说,NIC的注册是伴随着其驱动的发生的,而NIC可以内建到内核,也可以作为模块载入,...
  • 6.for i in range(2,n):if n%i==0:breakif i==n-1:print('是素数')...8.对于有else子句的for循环和while循环,但循环因循环条件成立而自然结束时__会__(会或不会)执行else中的代码。10.已知x='hello world.',那...
  • 13.在各类程序设计语言中,相比较而言,执行效率最高的是( C ) A.高级语言编写的程序B.汇编语言编写的程序C....在下列字符中,其ASCII码值最大的一个是( D ) A.ZB.9C.空格字符D.a 16.计算机字长是( A ...
  • 六万字 HTTP 必备干货学习,程序员网络怎么行,一篇HTTP入门收藏都可惜!网络知识入门必备,学习起来!
  • 相关题目与解析涉密计算机、涉密存储设备不得接入互联网及其他公共信息网络。()将涉密计算机、涉密存储设备接入互联网及其他公共...()下列行为中属于违反涉密计算机信息系统管理的有()。A.将涉密计算机、涉密存储...
  • 本书结构是自顶向下的,所以请按下列顺序阅读: 1.计算机网络自顶向下--应用层2.计算机网络自顶向下--运输层 3.计算机网络自顶向下--网络层4.计算机网络自顶向下--链路层 网络层 概述 转发和路由选择 网络层的...
  • 1.下列技术中,不属于网络...下列漏洞中不属于网络设备漏洞的是( ) A.交换机设备漏洞;B.Windows系统漏洞;C.防火墙漏洞;D.网络摄像头漏洞 正确答案是:B 3.体域网是附着在人体身上的一种网络,由一套小巧可移动
  • 计算机网络之第3章 数据链路层

    千次阅读 2020-10-07 20:39:48
    下列不属于数据链路层功能的是 拥塞控制 共享式以太网的媒体接入控制协议和802.11局域网的媒体接入控制协议分别是 CSMA/CD, CSMA/CA 下列属于数据链路层的互连设备是 网桥和交换机 封装成帧 某个数据链路层协议...
  • 计算机三级网络技术考过指南

    万次阅读 多人点赞 2018-03-10 19:18:36
    计算机三级网络技术考过指南 原文链接:计算机三级网络技术考过指南 题库下载链接(50积分是CSDN上调的,不是我上传时设置的。更新版本请大家自行搜索):计算机三级网络技术无纸化考试模拟软件(2018.3) 用...
  • 计算机网络期末复习题

    万次阅读 2020-12-31 08:48:25
    2、下列传输介质中,哪种传输介质的抗干扰性最好? A、双绞线 B、光缆 C、同轴电缆 D、无线介质 3、采用全双工通信方式,数据传输的方向性结构为______。 A、可以在两个方向上同时传输 B、只能在一个方向上传...
  • 对外互联通信线路 局域网维护 监视网络运行 网络设备的维护 网络服务器...下列不属于光导纤维的优点是 A频带宽 B.无光泄露 C.电磁绝缘性能好 D.成本较低适宜结构化综合布线 答D 171.非屏蔽双绞线最长传输为 A.185米
  • 华为网络技术大赛模拟题答案详解

    万次阅读 多人点赞 2016-05-09 17:20:00
    华为网络技术大赛模拟题答案详解 一、判断题 (1)VLSM的作用是:在有类的IP地址基础上,从主机位部分划分出相应的位数做为网络位。但是在路由器上部署时,需要路由协议的支持。 【解释】对,VLSM=Variable Length ...
  • 【计算机网络】谢希仁笔记 应用层

    千次阅读 多人点赞 2019-05-05 10:40:54
    目录 域名系统 DNS 域名系统概述 互联网的域名结构 域名服务器 文件传送协议 FTP 概述 FTP 的基本工作原理 简单文件传送协议 TFTP ...社交网络 电子邮件 电子邮件概述 简单邮件传送协议 SMT...
  • 计算机网络基本概念相关习题

    千次阅读 2020-08-23 22:12:40
    3.下列不属于计算机网络功能的是()。 A.提高系统可靠性 B.提高工作效率 C.分散数据的综合处理 D.使各计算机相对独立 4.计算机网络系统的基本组成是()。 A.局域网和广域网 B.本地计算机网和通信网 C.
  • 大学计算机网络复习题

    万次阅读 多人点赞 2013-01-13 10:09:00
    、在当前的网络系统中,由于网络覆盖面积的大小、技术条件和工作环境不同,通常分为广域网、  局域网 、和城域网三种。 3、常用的通信介质主要有有线介质和   无线 介质两大类。  4、网络服务器有文件...
  • 网络基础——牛客网刷题第一波

    千次阅读 2019-05-21 20:39:13
    之前两篇都是编程基础,感觉比较混乱,本次专注于网络基础方向的题目,这也是我本科的主要方向,没想到两年没看照常被虐的稀烂,开始吧…… 1. 接收邮件时,使用了如下哪种协议(C) A. FTPB. UDPC. TCPD. SMTP ...
  • OSI七层参考模型的各个层次的划分遵循下列原则: 同一层中的各网络节点都有相同的层次结构,具有同样的功能。 同一节点内相邻层之间通过接口(可以是逻辑接口)进行通信。 七层结构中的每一层使用下一层提供的服务,...
  • 1、下列选项中,不属于网络体系结构所描述的内容是© A、网络的层次 B、每一层使用的协议 C、协议的内部实现细节 D、每一层必须完成的功能 体系:计算机网络的各层及其协议的集合(抽象的) 内部的实现细节是由具体设备...
  • 校招面试知识点复习之计算机网络

    千次阅读 多人点赞 2017-03-14 16:19:31
    拥塞控制:防止过多的数据注入到网络中,这样可以使网络中的路由器至于过载。拥塞控制的前提是:网络能够承受现有的网络负荷。 流量控制:点对点通信量的控制。控制发送端的发送数据的速率。 这里要特别...
  •  对3G移动通信系统的网络安全问题进行了探讨,国内开展的4G系统及工程的建设已经开始安全性改造的工程,此举具有特别重要的意义。  安全性问题自移动通信技术问世以来就已产生。第一代移动通信的模拟蜂窝移动通信...
  • 思科 计算机网络 所有测试答案

    万次阅读 多人点赞 2020-06-11 13:38:49
    下列哪种网络特征将允许员工获得对公司网络的安全远程访问? 选择一项: A.ACL B.IPS C.VPN D.BYOD 3.ISP 是什么? 选择一项: A.它是一个专门开发网络布线和连线标准的标准化实体。 B.它是一个协议,用于确定本地...
  • 计算机网络复习题(全套)

    万次阅读 多人点赞 2017-11-25 19:40:43
    3、随着电信和信息技术的发展,国际上出现了所谓“三网融合”的趋势,下列属于三网之一的是(ABC) A.传统电信网 B.计算机网 C.有线电视网 D.卫星通信网 4、通信系统必须具备的三个基本要素是( C ) A、终端、电缆...
  • 网络基础题

    千次阅读 2011-12-27 21:44:41
    一、单选题 0.在www.hbsi.edu.cn这个域名中,edu... A.商业机构B.非赢性的组织机构C.教育D....A....网络D....2.下列哪项不属于Internet的主要应用( )。 A.网上聊天B.电子邮件服务C.文件传输服务D.文件管理 3.局域网的英文缩
  • IEEE ISO INTERNET IETF B 2 能保证数据端到端可靠传输能力的是相应OSI的 传输层 数据链路层 会话层 网络层 A 3 在TCP/IP网络中传输层什么进行区分服务 IP地址 端口号 主机名 MAC地址 B 4 下列哪个协议不属于传输层...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 33,623
精华内容 13,449
关键字:

下列不属于网络设备的是