精华内容
下载资源
问答
  • NPOI之Excel——自动筛选数字格式

    千次阅读 2016-01-14 11:53:45
    设置Excel的自动筛选功能 最新导出数据需要使用Excel的筛选功能,网上多方查找,终于在一个繁体的网站上找到了方法,呃,这个网站还是Java的,讲的是POI,不过.NET的NPOI也就一样用了。 CellRangeAddress c = ...

    设置Excel的自动筛选功能

    最新导出数据需要使用Excel的筛选功能,网上多方查找,终于在一个繁体的网站上找到了方法,呃,这个网站还是Java的,讲的是POI,不过.NET的NPOI也就一样用了。

    CellRangeAddress c = CellRangeAddress.ValueOf("A1");
    sheet.SetAutoFilter(c);

    通过设置要进行自动筛选的单个单元格或者多个单元格,然后在sheet上进行设置自动筛选。

    (参考:http://www.javaworld.com.tw/jute/post/view?bid=11&id=301435

    顺便一起说一个

    单元格数字格式的问题

    NPOI向Excel文件中插入数值时,可能会出现数字当作文本的情况(即左上角有个绿色三角),这样单元格的值就无法参与运算。这是因为在SetCellValue设置单元格值的时候使用了字符串进行赋值,默认被转换成了字符型。如果需要纯数字型的,请向SetCellValue中设置数字型变量。

    以上两个问题的示例代码如下:

    //建立空白工作薄
    IWorkbook workbook = new HSSFWorkbook();
    
    //在工作薄中建立工作表
    ISheet sheet = workbook.CreateSheet();
    
    //填充筛选的内容
    sheet.CreateRow(0).CreateCell(0).SetCellValue("省份");
    sheet.CreateRow(1).CreateCell(0).SetCellValue("河北省");
    sheet.CreateRow(2).CreateCell(0).SetCellValue("湖南省");
    
    //验证数字格式问题
    sheet.GetRow(1).CreateCell(2).SetCellValue("123");
    sheet.GetRow(2).CreateCell(2).SetCellValue(123);
    
    //设置Excel的自动筛选
    CellRangeAddress c = CellRangeAddress.ValueOf("A1");
    sheet.SetAutoFilter(c);
    
    //写文件
    using (FileStream fs = new FileStream("haha.xls", FileMode.Create, FileAccess.Write))
    {
        workbook.Write(fs);
    }

    最终的效果显示:

    QQ截图20130708153031


    from:http://www.cnblogs.com/xwgli/archive/2013/07/08/3178153.html

    展开全文
  • 易语言如何识别文本是否全是数字

    千次阅读 2016-11-12 19:10:25
    这里提供两种简单办法可以应对所有情况 .版本 2 .....参数 数值文本, 文本型 ....局部变量 文本数值, 文本型 ...文本数值 = 到文本 (到数值 (数值文本)) ' 输出调试文本 (“转换:” + 文本数值 + “/原

    这里提供两种简单办法可以应对所有情况

    .版本 2


    .子程序 是否全部为数值, 逻辑型, , 此方法不完善,是数值返回真,不是返回假
    .参数 数值文本, 文本型
    .局部变量 文本数值, 文本型


    ' 到数值后,后面的“.0”会丢失了,如果仅 整数型 数值对比可用此方法
    文本数值 = 到文本 (到数值 (数值文本))
    ' 输出调试文本 (“转换:” + 文本数值 + “/原始:” + 数值文本)
    .如果真 (文本数值 = 数值文本)
        返回 (真)
    .如果真结束
    返回 (假)


    .子程序 是否全部为数值_Code, 逻辑型, , 此方法比较完善,是数值返回真,不是返回假
    .参数 数值文本, 文本型
    .局部变量 bin, 字节集
    .局部变量 pos, 整数型
    .局部变量 小数, 逻辑型


    ' 此方法比较完善,可以满足所有需求
    bin = 到字节集 (数值文本)
    .计次循环首 (取字节集长度 (bin), pos)
        .如果真 (bin [pos] > 47 且 bin [pos] < 58)
            到循环尾 ()
        .如果真结束
        .如果真 (bin [pos] = 45)  ' 负数
            .如果真 (pos = 1)
                到循环尾 ()
            .如果真结束
            返回 (假)
        .如果真结束
        .如果真 (bin [pos] ≠ 46)  ' 小数
            返回 (假)
        .如果真结束
        .如果真 (小数)
            返回 (假)
        .如果真结束
        小数 = 真
    .计次循环尾 ()
    返回 (真)

    
    

    展开全文
  • UITextField 文本输入筛选

    千次阅读 2012-05-04 10:45:36
    有时,我们希望确保用户仅输入限定范围的...但对于已筛选数据,依据规则集检查输入的每个新字符更容易些。  在输入字符时,UITextField委托可以捕获这些字符,并不决定是否将该字符添加到活动文本字段中。可选的 te

      有时,我们希望确保用户仅输入限定范围的字符。例如:你可能希望创建一个不处理字母的数值型文本字段,

    尽管你可以使用谓词通过正则表达式(NSPredicate 类的MATCH 运算符 支持正则表达式值) 测试最终输入,

    但对于已筛选数据,依据规则集检查输入的每个新字符更容易些。

      在输入字符时,UITextField委托可以捕获这些字符,并不决定是否将该字符添加到活动文本字段中。可选的

    textField : shouldChangeCharactersInRange:replacementString: 委托方法返回一个值:YES或NO, 前者允许有

    新字符输入,而后者不允许。在实践中,这时逐字符运行的。每次用户点击键盘后调用该方法。

      所以,以下仅限字母文本的输入,数值型输入,带小数点的数值型输入,以及字母数字混合输入。

    其中,第三钟输入类型。即带小数点的数字,使用一点小技巧来确保只可以输入一个小数点。如果在相关文本字段中

    找到点(.)它将接受的字符从带点切换到不带点。是的,你可以使用粘贴操作来暗中解决这个问题。尽管用户不太可

    能使用这个种方法。


    代码: 筛选用户文本输入


    #define SEGMENT    [(UISegmentedControl *)self.navigationItem.titleView selectedSegmentIndex]

    #define ALPHA    @"ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz "
    #define NUMBERS    @"0123456789"
    #define ALPHANUM @"ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz0123456789 "
    #define NUMBERSPERIOD    @"0123456789."

    @interface TestBedViewController : UIViewController <UITextFieldDelegate>
    @end

    @implementation TestBedViewController
    - (BOOL)textFieldShouldReturn:(UITextField *)textField
    {
        [textField resignFirstResponder];
        return YES;
    }

    - (BOOL)textField:(UITextField *)textField shouldChangeCharactersInRange:(NSRange)range replacementString:(NSString *)string
    {
        NSCharacterSet *cs;
        
        switch (SEGMENT)
        {
            case 0:
                cs = [[NSCharacterSet characterSetWithCharactersInString:ALPHA] invertedSet];
                break;
            case 1:
                cs = [[NSCharacterSet characterSetWithCharactersInString:NUMBERS] invertedSet];
                break;
            case 2:
                cs = [[NSCharacterSet characterSetWithCharactersInString:NUMBERS] invertedSet];
                if ([textField.text rangeOfString:@"."].location == NSNotFound)
                    cs = [[NSCharacterSet characterSetWithCharactersInString:NUMBERSPERIOD] invertedSet];
                break;
            case 3:
                cs = [[NSCharacterSet characterSetWithCharactersInString:ALPHANUM] invertedSet];
                break;
            default:
                break;
        }

        NSString *filtered = [[string componentsSeparatedByCharactersInSet:cs] componentsJoinedByString:@""];
        BOOL basicTest = [string isEqualToString:filtered];
        
        // Add any predicate testing here
        
        return basicTest;
    }

    - (void) segmentChanged: (UISegmentedControl *) seg
    {
        [(UITextField *)[self.view viewWithTag:101] setText:@""];
    }

    - (void) viewDidLoad
    {
        self.navigationController.navigationBar.tintColor = COOKBOOK_PURPLE_COLOR;
        self.title = @"Keyboard Dismissal";
        
        // Text field defined in interface builder
        [(UITextField *)[self.view viewWithTag:101] setDelegate:self];

        // Add segmented control with entry options
        UISegmentedControl *seg = [[UISegmentedControl alloc] initWithItems:[@"ABC 123 2.3 A2C" componentsSeparatedByString:@" "]];
        seg.segmentedControlStyle = UISegmentedControlStyleBar;
        seg.selectedSegmentIndex = 0;
        [seg addTarget:self action:@selector(segmentChanged:) forControlEvents:UIControlEventValueChanged];
        self.navigationItem.titleView = seg;
        [seg release];
    }
    @end

    展开全文
  • 导入一个Excel到Sql,好方便进行数据的筛选,但是却发现,在导入后,电话字段有很多数据丢失...将Excel中的该列单元格格式改为 文本 格式,再导入,已经不行。 搜索一番,发现有一个方法,不过这个方法只针对于完全数字

    导入一个Excel到Sql,好方便进行数据的筛选,但是却发现,在导入后,电话字段有很多数据丢失,变成了Null,经过仔细检查,发现丢失的都是包含有字符型的(如区号与号码之间的-),再查看一下导入后的sql表,电话所在字段类型为float类型~~~难怪会有很多数据丢失了。。
    将Excel中的该列单元格格式改为 文本 格式,再导入,已经不行。

    搜索一番,发现有一个方法,不过这个方法只针对于完全数字格式的字段,如若想导入的是数字格式,而非字符串格式,就需要这样的做法:

    Excel导入数据到Sql Server

    Excel导入数据到Sql Server

    1、将导入的过程存为DTS包,将此DTS包找到

    2、在刚才保存的DTS包上右键,编辑包

    3、在编辑器里右键单击空白处,选择“脱接属性”命令。

    4、依次展开“连接”——excel的那个连接——>“OLE DB属性“,找到“Extended Properties”属性。

    5、将右边的“Value”属性的值改为“Excel 8.0;HDR=YES;IMEX=1”

    6、保存此包、并运行即可。

    关于第五步中的IMEX设置有如下解释:

    IMEX是用来告诉驱动程序使用Excel文件的模式,其值有0、1、2三种,分别代表导出、导入、混合模式。当我们设置 IMEX=1时将强制混合数据转换为文本,但仅仅这种设置并不可靠,IMEX=1只确保在某列前8行数据至少有一个是文本项的时候才起作用,它只是把查找前8行数据中数据类型占优选择的行为作了略微的改变。例如某列前8行数据全为纯数字,那么它仍然以数字类型作为该列的数据类型,随后行里的含有文本的数据仍然变空。
    另一个改进的措施是IMEX=1与注册表值TypeGuessRows配合使用,TypeGuessRows 值决定了ISAM 驱动程序从前几条数据采样确定数据类型,默认为“8”。可以通过修改“HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft \Jet\4.0\Engines\Excel”下的该注册表值来更改采样行数。但是这种改进还是没有根本上解决问题,即使我们把IMEX设为“1”, TypeGuessRows设得再大,例如1000,假设数据表有1001行,某列前1000行全为纯数字,该列的第1001行又是一个文本,ISAM驱动的这种机制还是让这列的数据变成空。

    但是这也仅仅是导入数字类型的字段,如果要导入为字符型的,比如说我们的电话号码形式的(010-21345678),这种做法是行不通的,但是还有另外一种很简单的方法,就是将Excel文件导出成Csv格式的文件,再将csv导入到Sql,就可以很方便的把电话号码导入进去了。这种做法也仅限于导入字符型的数据,因为CSV格式为文本格式,不包括数据类型,如果需要导入后数据为数字类型,就需要用上边的方法了。

    展开全文
  • Excel容易引起误会的莫过于设置数字格式了,这个改变的只是显示方式,而并没有真正改变存储的格式,所以一旦要运用到格式的函数(如vlookup,match,offset等),就会报错,然后不知云里雾里,本篇总结了最常见的...
  • Linux日志&文本筛选

    2016-11-02 10:59:49
    sort -t ',' -k 2 -n wenjian.txt #以,为分隔符,对第二个字段,按照数字大小生序排序 # -k2,2 表示从第二字段开始到第二字段结束。 # -k2 表示 从第二字段开始到行尾结束。 # -k2.2,2.5 表示从第二字段第二字符...
  • 需要从text特征中提取形如 13.5/10 这样的字符串,再分别提取分子分母。 1)可以利用str.extract()方法。 2)利用正则表达式\d+\.?\d*\/\d+进行匹配 3)再利用.split()方法提取分子分母 id lable ...
  • 我的数据库里有一些数值型文本,它们实际上是数字,但是为了编程方便在数据库中我把它们定义为文本。 在将gridcontrol的数据源指定到我的数据库后,gridcontrol为这些数值文本提供的筛选器为文本型,如下图: ![文本...
  • 需要从text特征中提取形如 13.5/10 这样的字符串,再分别提取分子分母。 1)可以利用 str.extract() 方法。 2)利用正则表达式 \d+.?\d*/\d+ 进行匹配 3)再利用 .split() 方法提取分子分母 代码: ...
  • Python文本操作---数据筛选

    千次阅读 2018-09-11 17:39:54
    2.open():方法打开文本 3.find():文本中找到相符和的值 4.write():写入文件 #字符串检索, #find函数找到返回位置 import codecs #编码 #第一个参数路径,第二个参数,rb二进制读写 第三个参数汉字编码,第...
  • 字符串中筛选数字

    千次阅读 2014-11-18 10:45:22
    java从字符串中提取数字  随便给你一个含有数字的字符串,比如: String s="eert343dfg56756dtry66fggg89dfgf"; 那我们如何把其中的数字提取出来呢?大致有以下几种方法,正则表达式,集合类,还有就是String类...
  • 文本处理

    千次阅读 2020-10-23 09:12:16
    在下一章中, 我们将查看更多的文本处理程序,但主要集中于文本格式化输出程序和其它一些人们需要的工具。 这一章会重新拜访一些老朋友,并且会给我们介绍一些新朋友: cat – 连接文件并且打印到标准输出 sort ...
  • 使用python正则表达式筛选txt文本并重新写入txt文件

    千次阅读 多人点赞 2019-04-10 10:17:48
    **#打开test.txt文本,将里边得文本使用正则表达式筛选数字那一部分,再存入test1.txt文件中 import re f = open("test.txt", "r", encoding='utf-8') #打开test.txt文件,以只读得方式,注意编码格式,含中文 ...
  • 所以没有出现网上那些数字格式是excel的日期格式问题,但是在点击筛选日期内容是无法获取日期,必须双击每个单元格的日期,把它从文本格式转成值,因为php输出excel是复制文本粘帖,格式是文本值,excel没有编辑识别...
  • 5.过滤中英文标点符号、字母及数字 6.过滤表情 1.过滤中文标点符号 import re import zhon from zhon.hanzi import punctuation #过滤中文标点符号 def filter_punc(desstr,restr=''): patt...
  • 如果表格中既有字母也有数字,现在需要对该表格区域进行排序,用户可以先按数字排序,再按字母排序,达到最终排序的效果。具体操作步骤如下: 选择D列任一单元格,在【数据】选项卡的【排序和筛选】组中,单击...
  • 运行代码前先导入jxl架包,以下代码仅供参考: 测试excel文件(我要获取该excel的内容为省、县、乡、村、组和PH的值):     ExcelTest01类代码如下: ...生成txt文本内容如下:  
  • #! /bin/bash ave=0 for i in `seq 1 6` do x=`echo "speed 234m/s"` y=`echo $x|grep -o '[0-9]\+...`linux command`、$(linux command)即命令替换会把linux command的多行结果合并为一行文本,并以空格分隔开。
  • PHPExcel输出时间格式支持筛选

    千次阅读 2018-05-29 15:58:39
    一般输出的时间为文本格式,excel是按照数据进行排序的,所以需要将日期数值化: 注:php时间戳开始时间:1970-1-1 excel开始时间:1900-1-1根据时间戳先将日期数值化: 例:time()/86400 + 25569 (excel里1970-1-1 代表...
  • 原因:主要是一些从网上拷贝过来的日期或数字excel默认为文本格式或特殊-中文数字格式大小写。 手动设置单元格,将格式改成日期格式,但仍不能参与计算。 只有挨个单元格双击,才能生效;才可以计算。 解决: ...
  • 本节主要使用WHERE语句筛选数字类型的属性。 条件查询语法 SELECT column, another_column, … FROM mytable WHERE condition AND/OR another_condition AND/OR …; 注:这里的 condition 都是描述属性列的,...
  • public class TestFileStream { public static void main(String[] str) throws IOException{ File file = new File("E:\\a.txt");/*只含字母数字文本文档a.text*/ FileReader reader = new FileReader(fil
  • 第六章 文本编辑框QTextEdit和文本浏览框QTextBrowser 6.1同步显示文本 6.2小结 6.1同步显示文本 相信通过这两个控件的中文名大家应该也知道这两个控件的功能是什么了,前者用来编辑文本,后者无法编辑,只用于...
  • 数字格式的数据一样会被扔掉,尽管数字可以毫无问题的转成文本。 DSN设置那里根本就没给我们提供加“IMEX=1”的地方,这个字符串是给ADO用的,如果你要编程读取Excel中的数据就用得着它了。不过MS说用这样的连接...
  • Excel中的数据筛选和高级筛选

    千次阅读 2018-12-20 15:07:40
    转载自 ...nbsp; Excel中提供了自动筛选(包括数字筛选文本筛选和自定义筛选)、和高级筛选两种数据筛选操作。 Excel会根据数据类型来自动判断显示数字筛选文本筛选...
  • 1.选择要转换的文本格式单元格,选择:数据--分列--原始数据类型(分隔符号)--分隔符号(全不选)--列数据格式选【日期(YMD)】,目标区域,选刚才插入的新行或列的单元格作为转换区域的起点(默认区域是直接替换...
  • 基于gibbsLDA的文本分类

    千次阅读 2016-05-06 21:07:25
    由于LDA对于短文本的效果并不好,所以我们针对语料进行了筛选, 选择了文本长度大于5000的文章 ,当然这个是我自己定义的,不一定具备什么道理,经过这个处理之后,训练文本的数量减少到了126个测试文本数量减少到了...
  • 右键列中任一单元格-设置数字格式 即可完成对该列格式设置 自定义列字段求值 分析-字段项目和集(计算)-计算字段 在公式中插入对应字段做需要的运算即可 空值和错误值的显示方式 右键任意表内单元格,选择表选项-...
  • 文本分类

    千次阅读 2019-07-30 09:29:05
    在大数据时代,网络上的文本数据日益增长。采用文本分类技术对海量数据进行科学地组织和管理显得尤为重要。 文本作为分布最广、数据量最大的信息载体,如何对这些数据进行有效地组织和管理是亟待...常用于数字化图...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 37,033
精华内容 14,813
关键字:

如何筛选文本格式数字