精华内容
下载资源
问答
  • 2020-06-12 09:11:25

    游戏登录 我们可以通过大漠插件实现一键登录,设置多线程登录,下面给出流程和思路仅供参考。

    我们建立几个子程序,按照以下顺序调用:

    1、启动游戏

    2、绑定游戏

    3、进入游戏

    4、选择私服

    5、输入账号

    6、输入密码

    7、选择角色

    8、进入成功

    9、解除绑定

    具体原文:易语言大漠一键登录步骤

    更多相关内容
  • DNF 客户Duan自动登录游戏 自动前往目的地 发送物品邮件 多段卡点自动处理 之前帮一个客户写的, 现在分享给大家,重在参与嘛
  • 热血江湖快捷上号源码,新手,有需要的拖走!!非常有用的,一键 上号!!
  • Autohotkey自动登录系统

    2020-06-12 11:03:59
    自己写的代码,可以自动登录每天需要登录的系统,不需要自己再输入账号密码,简化每天重复性的工作内容,提高工作效率。
  • 游戏平台及自动登录功能 以下原代码为本人原创,仅供交流使用,不做任何其他功能,如作他用后果自负 import time from os import getcwd from xunlu1_1 import ImgPro, KeyBord from subprocess import Popen USER =...

    某游戏平台及自动登录功能

    以下原代码为本人原创,仅供交流使用,不做任何其他功能,如作他用后果自负

    import time
    from os import getcwd
    from xunlu1_1 import ImgPro, KeyBord
    from subprocess import Popen
    
    USER = '123456789'
    PASSWOED = '......'
    WeGame_path = 'E:\Program Files (x86)\WeGame\wegame.exe'
    
    
    class DengLu():
    
        def __init__(self, WeGame_path, opt='DNF'):
            self.WeGame_path = WeGame_path
            self.g = ImgPro()  # 运行前需要获得句柄参数,否则无法截图  图片处理工具类
            self.key = KeyBord()  # 配置参数port   键鼠模拟工具类
            self.g.play_name = "WeGame"
            self.J_PATH = getcwd() + '/'  # 绝对路径
            self.opt = opt
    
        def __del__(self):
            print('模拟键盘关闭')
            self.key.close()
    
        # 打开Wegame
        def open_wegame(self, We=None):
            if We is None:
                Popen(self.WeGame_path)
            for i in range(10):
                time.sleep(0.5)
                if self.g.get_handle():
                    self.g.set_window()
                    # print("已打开界面")
                    return True
            print("打开界面失败")
    
        # 输入
        def __shuru(self):
            for i in range(10):
                time.sleep(0.5)
                try:
                    log_gin = self.g.temp_late(self.J_PATH + 'img_page/denglu_img/01.png', xishu=0.85)
                    if log_gin:
                        self.key.click_left(log_gin[0] + 100, log_gin[1] + 186)  # 账号位置186
                        for i in range(13):
                            self.key.down_up("backspace")
                        self.key.down_up(USER)
                        self.key.click_left(log_gin[0] + 100, log_gin[1] + 222)  # 密码位置222
                        time.sleep(1)
                        self.key.down_up(PASSWOED)
                        self.key.click_left(log_gin[0] + 100, log_gin[1] + 320)  # 确认登录位置320
                        print('输入账号登录成功')
                        return True
                except:
                    print('输入账号错误次数:', i)
            print("输入账号失败...")
    
        # Wegame选择游戏
        def __opt_game(self):
            row = 200
            if self.opt == 'LOL':
                row = row + 50
            for i in range(10):
                time.sleep(0.5)
                try:
                    if not self.open_wegame(We=True):
                        break
                    log_gin = self.g.temp_late(self.J_PATH + 'img_page/denglu_img/02.png', xishu=0.85)
                    if log_gin:
                        self.key.click_left(log_gin[0] + 350, log_gin[1])
                        time.sleep(0.8)
                        self.key.click_left(log_gin[0] + 30, log_gin[1] + row)  # 第一个游戏
                        time.sleep(1)
                        print("WeGame选择游戏成功")
                        return True
                except:
                    print('WeGame登录错误次数:', i)
            print("选择游戏错误")
    
        # 启动游戏
        def __qidong(self):
            for i in range(10):
                time.sleep(0.5)
                try:
                    log_gin = self.g.temp_late(self.J_PATH + 'img_page/denglu_img/03.png', xishu=0.85)
                    if log_gin:
                        self.key.click_left(log_gin)
                        print("登录中")
                        return True
                except:
                    print('识别启动失败次数:', i)
            print("启动游戏点击失败")
    
        # 是否完成登录
        def __is_login(self):
            self.g.play_name = '地下城与勇士'
            st1 = time.time()
            while True:
                time.sleep(1)
                if time.time() - st1 > 60:
                    print('登录超时....')
                    return
                if self.g.get_handle():
                    print("运行DNF成功")
                    return True
    
        # DNF选择角色
        def opt_hero(self):
            if self.__is_login():
                for i in range(31):
                    time.sleep(2)
                    print('登陆中', i)
                    try:
                        log_gin = self.g.temp_late(self.J_PATH + 'img_page/denglu_img/04.png', xishu=0.93)
                        if log_gin:
                            try:
                                self.g.set_window()
                            except:
                                continue
                            self.key.click_left(log_gin)
                            print("选择常用角色")
                            time.sleep(1)
                            self.key.click_left(log_gin)
                            time.sleep(3)
                            self.key.down_up('esc')
                            return True
                    except:
                        print('识别选择角色失败次数:', i)
                print("选择角色失败")
    
        # 登录游戏
        def run_denglu(self):
            if self.open_wegame():
                self.__shuru()
            if self.__opt_game():
                self.__qidong()
                self.opt_hero()
    
        # 重新启动游戏
        def run_chongqi(self):
            self.open_wegame()
            if self.__opt_game():
                pass
                self.__qidong()
                self.opt_hero()
    
        # 登录WEgame
        def Wegame_denglu(self):
            if self.open_wegame():
                self.__shuru()
                self.__opt_game()
    
    
    if __name__ == '__main__':
        # o = DengLu(WeGame_path, opt='LOL')
        o = DengLu(WeGame_path)
    

    其中的ImgPro, KeyBord为自己封装的图片处理识别,键盘模拟库

    展开全文
  • 易语言百度自动登录

    2020-08-19 23:23:55
    百度自动登录易语言源码系统结构:读用户,批量加入, ======窗口程序集1 || ||------_按钮1_被单击 || ||------__启动窗口_创建完毕 || ||------读用户 || ||------_按钮2_被单击 || ||------_按钮3_被单击
  • 一键登录进入游戏,改变了大漠模块的调用方法,使用全局变量dm,让它的类型为E大漠,从而实现...开始登录游戏 .版本 2 .支持库 spec .子程序 开始游戏 .局部变量 pos, 文本型 .局部变量 p_array, 文本型, , "0" ..

    一键登录进入游戏 ,改变了大漠模块的调用方法,使用全局变量dm,让它的类型为E大漠,从而实现免注册到系统,免360之类的查杀,同时讲解了延时延迟的区别,和处理事件()的作用。关键是在找字时,改用了FindStrFastE()命令,应为它的识别速度快,更兼容于易语言。

    第八课511遇见易语言大漠一键登录进入游戏二(FindStrFastE)

    511yj.com

    开始登录游戏

    511yj.com

    .版本 2
    .支持库 spec
    
    .子程序 开始游戏
    .局部变量 pos, 文本型
    .局部变量 p_array, 文本型, , "0"
    .局部变量 i, 整数型
    
    i = 0
    .判断循环首 (i = 0)
        延迟 (time)
        pos = dm.FindStrFastE (394, 572, 489, 598, “西山居”, “ddddbb-000000”, 1)
        p_array = 分割文本 (pos, “|”, )
        延迟 (time)
        .如果 (到整数 (p_array [1]) ≠ -1)
            延迟 (time)
            dm.MoveTo (到整数 (p_array [2]), 到整数 (p_array [3]) - 198)
            延迟 (time)
            dm.LeftClick ()
            延迟 (time)
            dm.KeyPress (13)
            延迟 (time)
            dm.KeyPress (13)
            延迟 (time)
            i = 1
    
        .否则
    
        .如果结束
        处理事件 ()
    .判断循环尾 ()
    

    源码:易语言大漠综合游戏外挂进入游戏二(FindStrFastE)

     

    展开全文
  • /*初始化APP自动登陆 * 您也可以在任何地方进行用户登陆验证 *用法:首先在js文件中定义 var app = getApp(); app.getUserDataToken(); */ this.getUserDataToken(); }, getUserDataToken:function(){ var that = ...
  • 易语言注册表自动登录设置源码
  • 热血江湖自动登陆易语言源代码 热血江湖登陆器 用易语言编写的源码,可以正常编译
  • 断线重连的需求一断线重连原理二...这个时候如果直接让玩家退出游戏,重新登录,无疑是非常影响用户体验的事情。所以根据这个需求,就有需要程序来实现断线后自动重连回去的技术,是用户能够再次快速开始游戏进行战斗。
  • 自动登录 PC 游戏星际争霸 2 或虫群之心的应用程序。 在 64 位和 32 位 PC 上支持最新版本 2.0.11。 请留下反馈和评分 :D :P. 该脚本经过全面测试,大多数使用问题与不正确的设置有关。
  • 自动输入账号和密码是游戏辅助的必然环节,现在很多游戏都屏蔽了键盘的发生命令,所以要根据自己的游戏尝试多种命令,SendString、SendString2、等等。 1、GetWords 通过dm.GetWords识别这个范围内所有满足条件的...

    自动输入账号和密码是游戏辅助的必然环节,现在很多游戏都屏蔽了键盘的发生命令,所以要根据自己的游戏尝试多种命令,SendString、SendString2、等等。

    511遇见(www.511yj.com)

    1、GetWords
    通过dm.GetWords识别这个范围内所有满足条件的词组. 比较适合用在未知文字的情况下,进行不定识别,因为我们事先不知道账号输入框里是否有字符,有的登录后会记忆,有的不记忆,如果不记忆的话,可以直接输入字符串,这里是按照加入账号输入框里有上次登录的信息的。如果识别识别,直接调用退格键循环删除一下字符,这样更简单。

    s=dml.GetWords (323, 212, 488, 238, “160f09-000000”, 1)

    2、GetWordResultCount
    在使用GetWords进行词组识别以后,可以用此接口进行识别词组数量的计算.

    count = dm.GetWordResultCount (s)

    3、GetWordResultStr

    函数简介:
    在使用GetWords进行词组识别以后,可以用此接口进行识别各个词组的内容
    函数原型:
    string GetWordResultStr(str,index)
    参数定义:
    str 字符串: GetWords的返回值
    index 整形数: 表示第几个词组
    返回值:
    字符串:
    返回的第index个词组内容
    示例:
    
    s = dm.GetWords(0,0,2000,2000,"000000-000000",1.0)
    count = dm.GetWordResultCount(s)
    index = 0
    Do While index < count
        word = dm.GetWordResultStr(s,index)
        MessageBox word 
        index = index + 1 
    Loop

    4、SendString2
    我们通过dm.sendstring2向账号和密码框发送账号和密码,也可以尝试SendString,如果两个都被游戏屏蔽了,那么只能模拟键盘输入账号密码。

    函数简介:
    向指定窗口发送文本数据
    函数原型:
    long SendString2(hwnd,str) 
    参数定义:
    hwnd 整形数: 指定的窗口句柄
     
    str 字符串: 发送的文本数据
    返回值:
    整形数:
    0: 失败
    1: 成功
    示例:
     
    dm.SendString2 hwnd,"我是来测试的" 
     
    注: 此接口为老的SendString,如果新的SendString不能输入,可以尝试此接口.

     易语言源码:

    511yj.com

    .版本 2
    .支持库 spec
    
    .子程序 输入账号密码
    .局部变量 word, 文本型
    .局部变量 w_array, 文本型, , "0"
    .局部变量 i, 整数型
    
    i = 0
    .判断循环首 (i = 0)
        延迟 (time)
        word = dm.FindStrFastE (491, 287, 547, 308, “记住账号”, “ffff00-000000”, 1)
        w_array = 分割文本 (word, “|”, )
        .如果 (到整数 (w_array [1]) ≥ 0)
            dm.MoveTo (到整数 (w_array [2]) - 18, 到整数 (w_array [3]) - 65)
            延迟 (time)
            dm.LeftClick ()
            延迟 (time)
            .计次循环首 (50, )
                dm.KeyPress (8)
            .计次循环尾 ()
            i = 1
    
        .否则
    
        .如果结束
        处理事件 ()
    .判断循环尾 ()
    ' 输入账号
    dm.SendString2 (hwnd, 账号)
    延迟 (time)
    dm.KeyPress (13)
    延迟 (time)
    dm.SendString2 (hwnd, 密码)
    延迟 (time)
    dm.KeyPress (13)
    

    源码:易语言大漠一键登录输入账号密码

            511遇见易语言大漠游戏外挂系列免费教程

    展开全文
  • 这是一个简单的python3.7脚本,它利用和以无头模式运行chrome,导航到epicgames商店,登录到您的帐户并赎回所有可用的每周免费游戏。 所有这些都在docker容器中。 入门 就我个人而言,我避免在计算机上托管此类进程...
  • 游戏自动喊话

    千次阅读 2020-11-25 13:53:17
    打开记事本,模拟游戏输入框,实现自动喊话。省约时间,直接上代码及运行效果。 代码如下: /** **功能例子说明:打开记事本,模拟游戏输入框,实现自动喊话 **仅发表于:CSDN **作者:大叔obnijeh **时间:2020年...
  • 自动弹出游戏网页怎么办?网页是一个文件,他存放在世界某个角落的某一部计算机中,而这部计算机必须是与互联网相连的。好的网页带给用户信息,但要是老是弹出无聊的广告网页那就有点烦了。那么,如何还电脑一个干净?...
  • #-*- coding: utf-8 -*- import win32api,win32...label = u腾讯游戏平台 #根据窗口名获取窗口句柄, h = win32gui.FindWindow('Edit','') #Ex = win32gui.FindWindowEx(h,None,None,None) #print(h) #print(Ex) win32g
  • 超牛!用Python自动玩转2048游戏

    千次阅读 2020-12-29 14:19:34
    本篇作者:BlueDamage近来在折腾selenium自动化, 感觉配合爬虫很有意思, 大多数以前难以模拟登录的网站都可以爬了,折腾了这么久, 于是想自动玩个2048游戏!嘿嘿, 我是一个不擅长玩游戏的人, 以前玩2048就经常得了很...
  • android 实现记住密码和自动登录功能代码,代码清晰!注解详细!
  • 主要介绍了shell脚本自动检测网络掉线和自动重连,这篇文章介绍的是自动检测连接网络的解决方法,需要的朋友可以参考下
  • 检测游戏账号密码,是指对...程序集 集_登录游戏 .子程序 子_账号检测 账号 = _启动窗口.编辑框_账号.内容 密码 = _启动窗口.编辑框_密码.内容 .如果 (账号 = “”) _启动窗口.气球提示框1.弹出提示框 (_启动窗
  • 这些都是在用户登录时,会自动加载的执行脚本,而在系统开机时自动加载的脚本就不再这人配置和显示了,这里主要介绍用户登陆时需要执行的脚本配置。下面通过两个示例来具体看看如何配置用户登录自动加载的执行脚本...
  • 网络游戏-网络摄像机自动认证识别登录系统.zip
  • 这个时候如果直接让玩家退出游戏,重新登录,无疑是非常影响用户体验的事情。所以根据这个需求,就有需要程序来实现断线后自动重连回去的技术,是用户能够再次快速开始游戏进行战斗。 一、断线重连原理 原来其实很...
  • 网络游戏-使用嵌入元数据的自动无线网络登录.zip
  • 下面是一段自动登录360传奇霸业游戏的脚本:from pymouse importPyMouseimporttimeimportwebbrowserfrom pykeyboard importPyKeyboardurl= ...
  • epic每日自动领取游戏(docker+win10)

    千次阅读 2021-12-25 09:33:43
    epic不做过多介绍,由于每次领游戏都要经过忘记密码的烦恼,因此采用docker自动领取每日免费游戏,非常的不错。 第一步:安装并运行Docker 点击链接,选择for windows 打开已下载的文件,不用选择路径,一路next就...
  • 一.引言 众所周知在App应用开发时我们会有不同的服务器环境来进行开发调试,例如测试环境,预发布环境,正式服环境.由于环境众多所以在测试工程师反馈问题时总要不断...对于Android手机屏幕的自动化控制有很多种方案。
  • docker自动领取epic免费游戏之一劳永逸

    千次阅读 热门讨论 2021-11-23 17:42:07
    docker自动领取epic免费游戏之一劳永逸 安装docker(已安装的请忽略此步骤) 拉取镜像 创建并启动容器(非一劳永逸) 创建自动化脚本并每日执行一次(真-一劳永逸) 补充更新1(2021-12-25) 补充更新2(2022-01-21) 补充更新...
  • 介绍 最近学了一段时间的Android开发为了给Android Reverse做准备,这里就...开心连连看之----实现登陆界面 &amp;amp;lt;二&amp;amp;gt;开心连连看之----构思游戏逻辑 &amp;amp;lt;三&amp;amp;gt

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 62,481
精华内容 24,992
关键字:

如何自动登录游戏