精华内容
下载资源
问答
  • 如何获取地址
    千次阅读
    2019-11-28 00:42:40

    交换机端口自动获取地址或手动修改地址

    为了解决在某些情况下交换机端口需要支持自动获取地址和手动修改地址。
    技术原理:IP子网VLAN+端口VLAN

    配置示例:
    这里以H3C交换机的Ethernet 1/0/1口为例:
    [H3C]vlan 10
    [H3C-vlan10]ip-subnet-vlan 1 ip 172.16.10.0 255.255.255.0
    [H3C-vlan10]ip-subnet-vlan 2 ip 172.16.20.0 255.255.255.0
    [H3C-vlan10]quit
    [H3C]interface Vlan-interface 10
    [H3C-Vlan-interface10]ip address 172.16.10.254 24
    [H3C-Vlan-interface10]ip address 172.16.20.254 24 sub
    [H3C-Vlan-interface10]quit

    [H3C]vlan 100
    [H3C-vlan100]quit
    [H3C]interface Vlan-interface 100
    [H3C-Vlan-interface100]ip address 172.16.100.254 24
    [H3C-Vlan-interface100]dhcp select server     #地址池自己配置
    [H3C-Vlan-interface100]quit
    [H3C]dhcp enable

    [H3C]interface Ethernet 1/0/1
    [H3C-Ethernet1/0/1]port link-type hybrid
    [H3C-Ethernet1/0/1]port hybrid ip-subnet-vlan vlan 10    #启用IP子网VLAN,支持手动修改地址
    [H3C-Ethernet1/0/1]port hybrid pvid vlan 100    #启用端口VLAN,支持DHCP获取地址
    [H3C-Ethernet1/0/1]port hybrid vlan 10 100 untagged
    [H3C-Ethernet1/0/1]display this
    #
    interface Ethernet1/0/1
    port link-type hybrid
    port hybrid vlan 1 10 100 untagged
    port hybrid pvid vlan 100
    port hybrid ip-subnet-vlan vlan 10
    #
    return

    ----------------------------------------------------------------------

    更多相关内容
  • 经纬度获取地址 AMap.plugin('AMap.Geocoder', function () { var geocoder = new AMap.Geocoder({ radius: 1000, extensions: "all" }); geocoder.getAddress(lnglatXY, function (status, result) { if (status ==...

     1.引入

    <script type="text/javascript" src="https://webapi.amap.com/maps?v=1.4.14&key=xxxxxxxxxxxxxx"></script>

    2.初始化地图

          let that = this;

          that.map = new AMap.Map('carContainer', {

            resizeEnable: true,

          })

          // 为地图注册click事件获取鼠标点击出的经纬度坐标

          that.map.on('click', function (e) {

            var lnglatXY = [e.lnglat.getLng(), e.lnglat.getLat()];

            that.init(lnglatXY)

          });

    3.地址获取经纬度

    let _this = this;

          window.AMap.plugin('AMap.PlaceSearch', function () {

            var autoOptions = {

              city: '全国',

              map: _this.map, // 展现结果的地图实例

              pageSize: 1, // 单页显示结果条数

              pageIndex: 1, // 页码

              autoFitView: true // 是否自动调整地图视野使绘制的 Marker点都处于视口的可见范围

            };

            var placeSearch = new window.AMap.PlaceSearch(autoOptions);

            placeSearch.search(_this.formInline.text, function (status, result) {

              // 搜索成功时,result即是对应的匹配数据

              if (status == 'complete') {

                if (result.poiList.pois.length = 0) {

                  ElMessage.error('没有查询到对应的地址');

                }else{    

                     let lng = result.poiList.pois[0].location.lng;

                     let lat = result.poiList.pois[0].location.lat

                }

              } else if (status == 'no_data') {

                ElMessage.error('没有查询到对应的地址');

              }

            });

          });

    4.经纬度获取地址

    AMap.plugin('AMap.Geocoder', function () {

            var geocoder = new AMap.Geocoder({

              radius: 1000,

              extensions: "all"

            });

            geocoder.getAddress(lnglatXY, function (status, result) {

              if (status === 'complete' && result.info === 'OK') {

                var address = result.regeocode.formattedAddress;

                that.address = address  //兑换地址

                that.$emit('getaddress', that.address, lnglatXY)

              } else {

                ElMessage.error('无地址,请重新选择');

              }

            });

            // 清除所有标记

            that.map.clearMap();

            var marker = new AMap.Marker();

            that.map.add(marker);

            marker.setPosition(lnglatXY);

          })

     完整代码

    <template>
      <el-dialog
        title="客户地址"
        v-model="Visible"
        :close-on-click-modal="false"
        :close-on-press-escape="false"
        width="1000px"
        @close="addressClose"
      >
        <div>
          <el-form
            :inline="true"
            :model="formInline"
            class="demo-form-inline"
          >
            <el-form-item
              label="查询"
              v-if="0"
            >
              <el-input
                v-model="formInline.text"
                placeholder="请输入要搜索的地址"
              ></el-input>
            </el-form-item>
            <el-form-item>
              <el-input
                v-model="formInline.text"
                placeholder="请输入要搜索的地址"
                style="width:500px;"
                clearable
              ></el-input>
            </el-form-item>
            <el-form-item>
              <el-button
                type="primary"
                @click="onQuery"
              >查询</el-button>
            </el-form-item>
          </el-form>
          <div id="carContainer"></div>
        </div>
      </el-dialog>
    </template>
    
    <script>
    import AMap from 'AMap'
    import { ElMessage } from "element-plus";
    export default {
      props: {
        locationVisible: {
          type: Boolean,
          default: true
        },
        customerAddress: {
          type: String,
          default: ''
        }
      },
      emits: ['getaddress', 'addressClose'],//这里需要写出定义的事件名
      data () {
        return {
          formInline: {
            text: ''
          },
          map: null,
          address: '',
          Visible: false
        };
      },
      watch: {
        locationVisible (val) {
          if (val) {
            this.Visible = true
            // 在这里使用$nextTick初始化地图插件即可
            this.$nextTick(() => {
              this.ready()
            });
          } else {
            this.Visible = false
          }
        },
        customerAddress (val) {
          this.formInline.text = val
        }
      },
      mounted () {
        window.onLoadMap = () => {
          this.ready();
        };
      },
      methods: {
        addressClose () {
          this.$emit('addressClose')
        },
        // 查询
        onQuery () {
          this.init1()
        },
        // 初始化
        ready () {
          let that = this;
          that.map = new AMap.Map('carContainer', {
            resizeEnable: true,
          })
          // 为地图注册click事件获取鼠标点击出的经纬度坐标
          that.map.on('click', function (e) {
            var lnglatXY = [e.lnglat.getLng(), e.lnglat.getLat()];
            that.init(lnglatXY)
          });
          if (this.formInline.text) {
            that.onQuery()
          }
        },
        // 地址获取经纬度  
        // let lng = result.poiList.pois[0].location.lng;
        // let lat = result.poiList.pois[0].location.lat;
        // _this.longAndLat = lng + ',' + lat;
        // _this.addMarker(lng, lat);
        init1 () {
          let _this = this;
          window.AMap.plugin('AMap.PlaceSearch', function () {
            var autoOptions = {
              city: '全国',
              map: _this.map, // 展现结果的地图实例
              pageSize: 1, // 单页显示结果条数
              pageIndex: 1, // 页码
              autoFitView: true // 是否自动调整地图视野使绘制的 Marker点都处于视口的可见范围
            };
            var placeSearch = new window.AMap.PlaceSearch(autoOptions);
            placeSearch.search(_this.formInline.text, function (status, result) {
              // 搜索成功时,result即是对应的匹配数据
              if (status == 'complete') {
                if (result.poiList.pois.length = 0) {
                  ElMessage.error('没有查询到对应的地址');
                }
              } else if (status == 'no_data') {
                ElMessage.error('没有查询到对应的地址');
              }
            });
          });
        },
        //经纬度获取地址
        init (lnglatXY) {
          var that = this
          AMap.plugin('AMap.Geocoder', function () {
            var geocoder = new AMap.Geocoder({
              radius: 1000,
              extensions: "all"
            });
            geocoder.getAddress(lnglatXY, function (status, result) {
              if (status === 'complete' && result.info === 'OK') {
                var address = result.regeocode.formattedAddress;
                that.address = address  //兑换地址
                that.$emit('getaddress', that.address, lnglatXY)
              } else {
                ElMessage.error('无地址,请重新选择');
              }
            });
            // 清除所有标记
            that.map.clearMap();
            var marker = new AMap.Marker();
            that.map.add(marker);
            marker.setPosition(lnglatXY);
          })
        },
      }
    }
    </script>
    
    <style lang="scss" scoped>
    .el-dialog {
      #carContainer {
        width: 100%;
        height: 500px;
      }
    }
    </style>

     

    展开全文
  • js获取地址栏(或者指定地址)参数

    千次阅读 2021-10-24 16:16:53
      自己写了个方法,使用原生js获取地址栏(或者指定地址)的参数 getParams(name,url) 1、name,需要获取参数的名称,为空的话,直接返回参数的json对象 2、url , 需要传入的地址,默认为浏览器的地址 /** * @...

      自己写了个方法,使用原生js获取地址栏(或者指定地址)的参数

    getParams(name,url)
    1、name,需要获取参数的名称,为空的话,直接返回参数的json对象
    2、url , 需要传入的地址,默认为浏览器的地址

    
    /**
     * @function 获取浏览器地址的参数
     * @param {String} [name=''] 获取值的key,默认为空,为空时,函数返回json对象
     * @param {String} [url=window.location.href] 地址,默认为浏览器的url
     * @example  getParams('aa', 'https://www.baidu.com?aa=101')       //101
     */
    const getParams = (name = '', url = window.location.href) => {
        let endVal = '';
        if (url.indexOf("?") != -1) {   //判断url中有没有出现?
            let arrs = url.substring(url.indexOf("?") + 1).split('&');  //截取字符串,获取到?后面的那部分内容;以&符号为准,分割成数组
            arrs = arrs.filter(item => item);     //原有数组过滤为空的值
            let obj = {};
            for (let i = 0; i < arrs.length; i++) {
                let index = arrs[i].indexOf("=");
                let keys = arrs[i].substring(0, index);       //第一个等号前面的那部分
                let vals = arrs[i].substring(index + 1);      //第一个等号后面的内容
                if (keys) {     //keys不为空时,追加到obj对象里
                    obj[keys] = decodeURI(vals);    //解码输出,值含有中文字符的情况
                }
            }
            if (arrs.length > 0) {  //先判断数组是不是为空,在判断name是不是有值传过来
                if (name) {
                    endVal = obj[name] || '';
                } else {
                    endVal = obj;
                }
            }
        }
        return endVal;
    }
    
    展开全文
  • 如何根据经纬度获取地址名称

    万次阅读 2020-11-21 12:54:02
    根据经纬度获取对应地址名称 /** * 获取地理位置名称 * * param location * 经纬度坐标,经度在前,纬度在后,经纬度间以“,”分割 * return */ public static String getAddressNameByGeocoder1(String...

    根据经纬度获取对应地址名称

    /**
    	 * 获取地理位置名称
    	 *
    	 * param location
    	 *            经纬度坐标,经度在前,纬度在后,经纬度间以“,”分割
    	 * return
    	 */
    	public static String getAddressNameByGeocoder1(String location) {
    		String jsonString = sendGet(getRegeoUrl(location));
    		JSONObject jsonObject = JSONObject.parseObject(jsonString);
    		String addressName = jsonObject.getJSONObject("regeocode").getString("formatted_address");
    		return addressName;
    	}
     
    	/**
    	 * 向指定URL发送GET方法的请求
    	 *
    	 * param url
    	 *            发送请求的URL
    	 * return URL 所代表远程资源的响应结果
    	 */
    	public static String sendGet(String url) {
    		String result = "";
    		BufferedReader in = null;
    		try {
    			String urlNameString = url;
    			URL realUrl = new URL(urlNameString);
    			// 打开和URL之间的连接
    			URLConnection connection = realUrl.openConnection();
    			// 设置通用的请求属性
    			connection.setRequestProperty("accept", "*/*");
    			connection.setRequestProperty("connection", "Keep-Alive");
    			connection.setRequestProperty("user-agent", "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1;SV1)");
    			// 建立实际的连接
    			connection.connect();
    			// 定义 BufferedReader输入流来读取URL的响应
    			in = new BufferedReader(new InputStreamReader(connection.getInputStream(), "UTF-8"));
    			String line;
    			while ((line = in.readLine()) != null) {
    				result += line;
    			}
    		} catch (Exception e) {
    			return null;
    		} finally { // 使用finally块来关闭输入流
    			try {
    				if (in != null) {
    					in.close();
    				}
    			} catch (Exception e2) {
    				e2.printStackTrace();
    			}
    		}
    		return result;
    	}
     
     
    	/**
    	 * 逆地理编码url
    	 *
    	 * param location
    	 *            经纬度坐标,经度在前,纬度在后,经纬度间以“,”分割
    	 * return
    	 */
    	public static String getRegeoUrl(String location) {
    		return "http://restapi.amap.com/v3/geocode/regeo?location=" + location
    				+ "&key=17479d86c0c6a0305024e1142351a0a4";
    	}
    

    转载自https://blog.csdn.net/z_740771101/article/details/90174656

    展开全文
  • 用JS获取地址栏参数的方法

    千次阅读 2021-01-05 16:20:47
    采用正则表达式获取地址栏参数: getQueryString(name){ var reg = new RegExp("(^|&)"+ name +"=([^&]*)(&|$)"); var r = window.location.search.substr(1).match(reg); if(r!=null)return ...
  • vue获取地址栏参数值

    万次阅读 2020-07-02 17:10:06
    第一种方式: ...this.$route.fullPath 获取地址连接 const url = this.$route.fullPath.split("?")[1] const kv = url.split("&") const list = [] for(var i=0;i<kv.length;i++){ .
  • 如何获取地址栏的id (参数)

    千次阅读 2019-10-13 19:58:11
    获取地址栏的id 需求:获取到地址栏传递过来的id值 代码: 方法一:(需要兼容性好) //创建URLSeachParams对象,使用对象来获取地址栏的参数 var temp = new URLSearchParams(location.search); var id = temp.get...
  • console.log('详细地址:' + res.address); console.log('纬度:' + res.latitude); console.log('经度:' + res.longitude); } }) } ##关注、支持弟弟一下,感谢!
  • 腾讯地图如何根据经纬度获取地址

    万次阅读 2021-01-29 18:00:51
    腾讯地图如何根据经纬度获取地址 /** * //GET请求 * * lat<纬度>,lng<经度> */ @GetMapping("tencentGetLonAndLat/{lat}/{lng}") public RestResponse tencentGetLonAndLat(@PathVariable ...
  • uni-app获取地址栏参数

    千次阅读 2020-01-09 14:17:04
    onLoad: function (option) { //option为object类型,会序列化上个页面传递的参数 console.log(option.id); //打印出上个页面传递的参数。 console.log(option.name); //打印出上个页面传递的参数。...
  • VUE中获取地址参数

    千次阅读 2019-09-25 10:09:37
    此种方式获取到的是解析后的数据,不能用作访问其他地址作为参数使用,可以获取解析参数内容后并使用 方式二:this.$route.fullPath 获取路由地址,手动截取,可用作访问其他地址作为参数使用 letpath=this.$route...
  • 百度地图点击地图获取地址

    千次阅读 2017-11-15 16:12:00
    <!doctype html> ,chrome=1"> 百度地图点击地图获取地址信息 body, html,#map {width: 100%;height: 100%;overf
  • 但是deepin在安装完之后,却发现只要重启,有线网络便不可使用,一直都是获取网络地址。 那么产生此问题的原因是驱动不匹配,只需要更换deepin需要的驱动匹配即可。 1. 查看驱动 sudo lshw -C network 最...
  • 如何获取地址栏中的参数

    万次阅读 2019-03-28 13:43:16
    两种方法获取地址栏中传递的参数 第一种:字符串拆分法 window.location.href 或者 location.href 或者 window.location 获得地址栏中的所有内容 decodeURI() 可以解码地址栏中的数据 恢复中文数据 window....
  • vue获取地址栏参数

    万次阅读 2019-06-14 16:41:43
    因为vue默认使用的hash模式,你会发现打印出来的window.location.search等于空,这样的话,通过... // 获取url参数 getUrlKey(name) { return decodeURIComponent((new RegExp('[?|&]' + name + '=' + '([...
  • 首先将路由器,交换机和终端如图连接 ...[Huawei-GigabitEthernet0/0/0]ip address 192.168.1.1 255.255.255.0 配置接口的ip地址 同理配置右侧 [Huawei]dhcp enable 先在设备上开启DHCP服务 在设备上创建名为zuo的D
  • html获取地址栏参数

    千次阅读 2018-07-03 10:46:56
    1.采用正则的方法获取地址栏参数(非常好用)地址栏地址为:abc.html?id=123&amp;url=http://www.youtao.com方法: function GetQueryString(name) { var reg = new RegExp("(^|&amp;)"+ name +...
  • python通过经纬度获取地址信息

    千次阅读 2020-01-13 16:52:41
    爬取社交数据时,有时候会碰到用经纬度表示地理位置信息,这种情况下需要进行转换以获取地理位置信息。 例如获取到的数据是{"business_id":"1SWheh84yJXfytovILXOAQ","name":"Arizona Biltmore Golf Club","address...
  • 最近有添加用户收货地址需求(外卖项目),需要获取用户当前位置。 第一步 说白了,就是微信需要让用户确定是否允许你获取它的位置,如果你不授权,将弹框提示。 首先,你必须进行 授权 ,无论是哪种获取用户地址...
  • vue获取地址栏参数方法

    千次阅读 2019-04-28 07:49:38
    export function getUrlKey(name){ return decodeURIComponent((new RegExp('[?|&]' + name + '=' + '([^&;]+?)(&|#|;|$)').exec(location.href) || [, ""])[1].replace(/\+/g, '%20')) || null }
  • 【Js】获取地址栏参数(超简单)

    万次阅读 2018-11-21 14:07:06
    3、采用正则表达式获取地址栏参数: function getUrlSearch(name) { // 未传参,返回空 if (!name) return null; // 查询参数:先通过search取值,如果取不到就通过hash来取 var after = window.location....
  • 采用正则表达式获取地址栏参数:( 强烈推荐,既实用又方便!) function GetQueryString(name) {  var reg = new RegExp("(^|&)"+ name +"=([^&]*)(&|$)");  var r = window.location.search....
  • React Js Router 获取地址栏url参数

    万次阅读 2017-05-05 14:59:09
    本文出自: ...有两种方式获取:请用的第二种/** * 获取url地址 * @param name */common.getQueryString = function (name) { let reg = new RegExp("(^|&)" + name + "=([^&]*)(&|$)", "i"); l
  • 百度地图根据坐标获取地址名称

    千次阅读 2018-10-13 12:02:07
    接到这个需求,查了下如何实现,基本都是说在js调百度地图api转换,代码贴上: ... //坐标转地址——暂时不用 function getAddress(pos) { var pos_list = pos.split(','); var lng = pos_list[0]; var lat = po...
  • 百度地址主要通过GeoCoder来获取经纬度附近信息,包括所在地址 初始化GeoCoder private GeoCoder geoCoder; private void initGeoCoder() { geoCoder = GeoCoder.newInstance(); geoCoder....
  • JAVA获取域名或者ip相关信息的方法 request.getServerName() 返回被请求服务器域名,如果没有域名则返回IP地址:10.0.4.214 request.getServerPort() 返回被请求服务器端口:8081 request.getRemoteHost(...
  • 地址解析(坐标位置描述) 申请开发者密钥(key)与设置 个人使用:登录,点击“key管理”,进入设置,选择“WebServiceAPI”,如果没有小程序ID,勾选“授权IP”,如果有小程序ID,勾选“域名白名单”,且...
  • vue 获取地址栏的各个部分内容

    千次阅读 2019-02-20 18:12:07
    vue 获取地址栏的各个部分内容 vue中常用到的就是 this.$route this.$route.query 等 但是this.$route 到底是啥 打印一下 console.log(this.$route) 结果: 可以看出 this.$route 是一个对象,包含parmas、query、...
  • Jquery如何获取地址栏传递的参数,网上很多方法写着都不对
  • 如图三台电脑分别在不同的vlan下,地址、掩码、网关自动获取并指定所有电脑的dns192.168.1.254 ...4.把电脑都设成自动获取地址 现在电脑都能自动获取地址和dns了 不同vlan下的获取的网段不同 同时还是能互访的 ...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 2,478,877
精华内容 991,550
关键字:

如何获取地址