精华内容
下载资源
问答
  • Eclipse安装Maven插件后,Eclipse启动问题:Maven Integration for Eclipse ...1. 设置Eclipse使用的JRE为本机安装的JDK目录:  1.1 在eclipse.ini中添加两行  -vm  C:\Program Files\Java\jdk1.6.0_10\bin\jav
      
    
    Eclipse安装Maven插件后,Eclipse启动问题:Maven Integration for Eclipse JDK Warning。
    解决方法:
    1. 设置Eclipse使用的JRE为本机安装的JDK目录:
        1.1 在eclipse.ini中添加两行

        -vm

        C:\Program Files\Java\jdk1.6.0_10\bin\javaw.exe

        注意: 要写在两行,写在一行不能生效;这两行要定在-vmargs之前,不然也不能生效。

       1.2  或设置Eclipse--Windows--Preferences--Java--Installed JREs将JRE home改成jdk目录。

       经试验发现第1.2步可以不做,但建议配置开发环境是配置着一步,而且第一步的两行也可以写成

         -vm

        C:\Program Files\Java\jdk1.6.0_10\bin\

    2. 配置eclipse.ini文件:
        先解释该文件-vmargs下常见参数的意思:
        -vmargs
        -Xms40m
        -Xmx256m
        -XX:PermSize=64M
        -XX:MaxPermSize=128M
       
        -vmargs:说明后面是VM的参数
        -Xms40m:虚拟机占用系统的最小内存,初始分配
        -Xmx256m:虚拟机占用系统的最大内存,按需分配
        -XX:PermSize:最小堆大小。一般报内存不足时,都是说这个太小, 堆空间剩余小于5%就会警告,建议把这个稍微设
                                大一点,不过要视自己机器内存大小来设置,但不能超过MaxPermSize。
        -XX:MaxPermSize:最大堆大小。这个也适当大些所以若出现问题,首先请调整 -Xms40m:将其设置的小一些,
                                就 可以解决问题。
        PermSize和MaxPermSize指虚拟机为java永久生成对象(Permanate generation)等这些可反射对象分配内
        存的限制,这些内存不包括在Heap(堆内存)区之中。

    3.  解决Failed to creat java virtual machine问题:

         打开eclipse安装目录下的eclipse.ini文件,修改:

         --launcher.XXMaxPermSize

         256M改成128M;

         --launcher.XXMaxPermSize
        256m

        128m;

        可参考:http://blog.csdn.net/yuanfei_1988/archive/2010/10/02/5919168.aspx

    展开全文
  • 设置eclipse默认JDk版本

    2020-02-25 13:23:03
    具体步骤: window —>... Installed JRES (这里是安装java时候的JDK的目录) 安装自己的JDK到MyEclipse 选择使用自己的JDK 改变JDK后,记得更改MyEclipse的编译版本。以适合自己的JDK版本 ...

    具体步骤: window —> preferences —> java —> Installed JRES (这里是安装java时候的JDK的目录)
    在这里插入图片描述
    在这里插入图片描述
    安装自己的JDK到MyEclipse
    在这里插入图片描述
    在这里插入图片描述
    选择使用自己的JDK
    在这里插入图片描述
    改变JDK后,记得更改MyEclipse的编译版本。以适合自己的JDK版本
    在这里插入图片描述

    展开全文
  • 怎么设置eclipsejdk版本

    千次阅读 2017-12-03 22:17:22
    //配置maven工程jdk版 < profile >    < id >jdk1.7 id >    < activation >    < activeByDefault >true activeByDefault >    < jdk >1.7 jdk >    activation >    < ...

    点击window->preferences

    对话框中选择java->complier

     

    maven 中jre报错

    点击window->preferences

    复制路径找到settings.xml文件

    D:\soft\apache-maven-3.5.2\conf\settings.xml

    这里可以使用阿里的jar包镜像仓库 速度块

     

     <mirrors>
        <mirror>
          <id>alimaven</id>
          <name>aliyun maven</name>
          <url>http://maven.aliyun.com/nexus/content/groups/public/</url>
          <mirrorOf>central</mirrorOf>        
        </mirror>
      </mirrors>
    //配置maven工程jdk版

    <profile>   

        <id>jdk1.7</id>    

        <activation>   

            <activeByDefault>true</activeByDefault>    

            <jdk>1.7</jdk>   

        </activation>    

        <properties>   

            <maven.compiler.source>1.7</maven.compiler.source>    

            <maven.compiler.target>1.7</maven.compiler.target>    

            <maven.compiler.compilerVersion>1.7</maven.compiler.compilerVersion>   

        </properties>   

    </profile>

     

    展开全文
  • Eclipse JDK配置与版本切换问题

    千次阅读 2018-06-11 10:33:09
    一、Eclipse JDK配置  window—Preferences—Installed JREs—Add—JDK目录 二、Eclipse JDK切换  1、右键项目—Build Path—Configure Build Path—Labraries—选择JDK  2、更改编译版本:   右键项目—...

    一、Eclipse JDK配置

     window—Preferences—Installed JREs—Add—JDK目录

    二、Eclipse JDK切换

     1、右键项目—Build Path—Configure Build Path—Labraries—选择JDK

     2、更改编译版本:

      右键项目—Properties—Java Compiler—Compiler compliance level—选择相应版本

    展开全文
  • 本包 包含: JDK 8 64位 JDK 7 64位 JDK 7 32位 ...安卓开发集成环境 SDK ADT eclipse JDK adt bundle windows x86 64 20140321 不用装SDK ADT 用集成 里面什么都有 就能开发 更稳定 更快 更好
  • eclipse 设置启动jdk版本

    千次阅读 2019-03-20 10:38:37
    打开eclipse安装目录下的eclipse.ini文件,将内容加入开头 -vm D:/software/jdk_1.8u91/bin(jdk版本)
  • ubuntu_eclipse启动设置jdk环境变量,其他设置
  • Eclipse安装Maven插件后,Eclipse启动问题:Maven Integration for Eclipse ...1. 设置Eclipse使用的JRE为本机安装的JDK目录:  1.1 在eclipse.ini中添加两行  -vm  C:\Program Files\Java\jdk1.6.0_10\bin\ja
  • eclipse设置默认JDK版本

    千次阅读 2019-09-25 17:57:31
    具体步骤: window —>... Installed JRES (这里是安装java时候的JDK的目录) 安装自己的JDK到MyEclipse 选择使用自己的JDK 改变JDK后,记得更改MyEclipse的编译版本。以适合自己的JDK版本 ...
  • Maven Integration for Eclipse JDK Warning

    千次阅读 2014-02-24 10:42:37
    现象:Eclipse安装Maven插件后,启动时弹出警告:Maven Integration for Eclipse JDK Warning。 原因:默认Eclipse使用的是Jre,Maven推荐使用Jdk。...1. 设置Eclipse使用的JRE为本机安装的JDK目录:  
  • eclipse jdk官网下载不了

    千次阅读 2018-10-31 08:21:21
    最近在学习java的简单语法,在下载eclipse时受挫,通过浏览器怎么都下载不下来。 最后,我是通过迅雷下载的,速度杠杠滴。哈哈,莫名给迅雷打个call。 1、eclipse下载地址:...2、下载JDK安装包同理。下载地址...
  • Eclipse+jdk安装包

    2018-04-12 20:00:07
    Eclipse+jdk安装包;Eclipse+jdk安装包;Eclipse+jdk安装包
  • 关于配置eclipseJDK环境变量!!!

    千次阅读 2018-08-09 23:01:25
    相信大多数java开发工作人员在初次接触eclipseJDK环境配置的时候都很头大,每次电脑重装系统或还原都会出问题,本文将详细解答eclipseJDK环境配置相关信息(笔者刚重装过系统,把电脑的所有配置又搞了一遍,有问题...
  • eclipse 创建maven项目设置默认jdk版本

    千次阅读 2017-07-11 10:27:48
    eclipse 设置默认jdk的版本
  • maximo eclipsejdk和库设置图解
  • 如何设置Eclipse关联JDK文档或源码

    千次阅读 2011-08-17 20:38:39
    其实看文档已经没什么意思了,因为源码都可以看了嘛。java doc无非是把源码的注释给你整理一下啊。 步骤如下: Window->Preferences->Java->Installed...这个源码可以从jdk中的src.zip文件解压得到。
  • eclipse-jee-luna-SR2中安装Hibernate Tools 4.2.3版本之后,发现找不到Hibernate ...以下通过更改eclipse.ini设置jdk路径,添加下面两句即可:-vm C:\bin\java\jdk1.7.0_71\bin完整的配置:-startup plugins/org.ecl
  • eclipse手动设置jdk路径

    千次阅读 2016-04-05 11:24:39
    studio用的是64位,所以我吧电脑的环境变量配成了64位的jdk,但是eclipse是32位的,为了不改变系统的环境变量,只能手动设置eclipsejdk路径 :只需把下面红色部分替换为自己电脑的路径,注意位置。。。。 -...
  • 如图 Version 1.6.0_161 of the JVM is not suitable for this product.Version:1.8 or greater is required. ...解决方法2:在eclipse目录下的eclipse.ini文件前面添加两行 -vm C:/Program Files/Jav...
  • eclipse更换jdk版本

    万次阅读 多人点赞 2018-12-19 10:44:12
    1.Window—Preferences—Java—Compiler—右侧面板设置为1.6 ...以上已经完成eclipsejdk的变更 3.在你需要变更jdk版本的项目右键选择 可以编辑你的jdk和添加jdk 4.与Java Build Path同级目录下...
  • JDK版本兼容性问题以及在Eclipse设置不同jdk版本编译
  • eclipse 更换 JDK 版本后报错

    千次阅读 2017-06-01 22:41:09
    在实际开发过程中,可能由于项目的需要,我们需要更换 JDK 的版本。但是更换后会报错,如下: Java compiler level does not match the version ...第一步:设置 eclipse JDK 版本 Windows---->Preferences---->J
  • eclipse为项目设置jdk

    千次阅读 2018-01-05 09:22:07
    (1)在项目上右键选中properties,会进入如下界面 (2)然后点击Add Library,进入设置Library的界面 (3)选中JRE System Library进入下一界面就可以设置jdk
  • Eclipse设置项目jdk的问题

    千次阅读 2013-08-16 10:30:26
    因为要修改一个以前的老项目,老项目用的jdk是1.4版本,遂在项目右键Properties-Java Compiler中将Compiler compliance level 设成了1.4. 以为万事大吉了呢,昨晚上因为Integer的一个方法发现了问题  Integer...
  • eclipse配置JDK

    万次阅读 多人点赞 2019-03-13 18:42:07
    2、进入设置界面之后,找到“Java”选项,单击“Installed JRES”,可以看到右侧已有的JDK配置; 3、单击“add”,在弹出的对话框,单击“next”; 4、添加安装目录;安装jdk的时候有2个目录,一个是jdk,一个...
  • eclipse配置JDK设置编译版本的几种方法

    万次阅读 多人点赞 2016-12-13 16:08:45
    注:截图时使用的eclipse4.6、jdk1.8、jdk1.7一、eclipse配置JDK打开window–>preferences,弹出的页面里选择java–>Installed JREs,打开如下图界面: 然后点击右侧add按钮,打开add jre对话框: 点击下一步...
  • Eclipse配置jdk

    万次阅读 2017-10-01 18:56:21
    推荐文章: java程序员常用软件官方下载...~~~~~~~~~~~~~~~华丽的分割线~~~~~~~~~~~~~~~~~~~~在开发的时候有时候需要使用不同的jdk版本,这里就讲解一下怎样添加不同版本的jdk上步骤: 1.打开eclipse→Windows→Pref

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 206,331
精华内容 82,532
关键字:

如何设置eclipse的jdk