精华内容
下载资源
问答
  • 主要介绍了Vue+iview+webpack ie浏览器兼容简单处理,文中通过示例代码介绍的非常详细,对大家的学习或者工作具有一定的参考学习价值,需要的朋友们下面随着小编来一起学习学习吧
  • HTML在线浏览pdf文件,有两种方式,可以自行选择,下载后可以直接使用,里面有使用教程,,,,,,
  • 主要介绍了Vue iview IE浏览器不兼容报错的决绝方法,由于Iview编译使用到了es6的一些新特性,但是在IE中不支持ES6的新特性,本文就介绍一下如何解决这些问题
  • 用于兼容IE浏览器使用RSA加密的工具类,直接引入,并且使用new ecrypt()即可使用,官网的js会倒是IE浏览器报错SCRIPT1010错误,原因为逗号(,)关键字(default,delete)等。
  • pdf.js插件,支持ie浏览器等,是一款特别好用的浏览pdf插件的工具,强烈推荐,不用再去考虑不兼容ie浏览器问题
  • 优化过的ajaxfileupload.js文件 兼容IE,但是用的时候需要引用jquery1.8左右 能用1.9以上版本
  • 最近发现,video标签在IE浏览器无法播放视频,网上查阅资料得知,可以引用html5media.js,亲测可以解决
  • 主要介绍了JS 组件系列之Bootstrap Table 冻结列功能IE浏览器兼容性问题解决方案,需要的朋友可以参考下
  • 解决vue不兼容ie浏览器的方法

    解决vue不兼容ie浏览器的方法

    参考文章:

    (1)解决vue不兼容ie浏览器的方法

    (2)https://www.cnblogs.com/maibao666/p/11081188.html


    备忘一下。


    展开全文
  • 解决VUE项目不兼容IE浏览器问题

    万次阅读 2018-10-11 19:14:01
    非常简单,只需要两步就能解决: 1、 安装插件babel-polyfill   npm install --save-dev babel-polyfill  2、在你的VUE项目的src目录下找到main.js ...最后,重新打开浏览器,应该就能兼容打开页面了。...

    非常简单,只需要两步就能解决:

    1、 安装插件babel-polyfill 

          npm install --save-dev babel-polyfill   

    2、在你的VUE项目的src目录下找到main.js

         添加下面一行代码:

         import 'babel-polyfill'

    最后,重新打开浏览器,应该就能兼容打开页面了。

    展开全文
  • vue 配置兼容ie浏览器

    2020-12-20 21:21:10
    Vuevue 配置兼容ie浏览器发布时间:2018-11-26 10:39:46作者:wangjian浏览量:843点赞量:0vue框架使用了ES6,然而ie浏览器不支持ES6语法,导致使用vue搭建的项目在ie浏览器上面无法运行,这里解决vue框架兼容ie(9+)...

    您现在的位置是:网站首页>>前端技术>>Vue

    vue 配置兼容ie浏览器

    发布时间:2018-11-26 10:39:46作者:wangjian浏览量:843点赞量:0

    vue框架使用了ES6,然而ie浏览器不支持ES6语法,导致使用vue搭建的项目在ie浏览器上面无法运行,这里解决vue框架兼容ie(9+)浏览器问题

    1:安装babel-polyfill(解决ie不支持promise对象的问题)npm install --save-dev babel-polyfill

    2:使用babel-polyfill插件

    在main.js文件的第一行引入babel-polyfill(这里注意第一行引入)import "babel-polyfill"

    引入成功后,如果项目还不可以在ie浏览器上正常运行的话,可能是项目中安装了babel-preset-es2015和babel-preset-stage-*,在网上查到的资料大部分安装的是babel-preset-stage-2,然而我的项目安装的项目是babel-preset-stage-3,

    3:配置babel-preset-es2015和babel-preset-stage-*

    (1)在.babelrc里面进行配置{

    "presets": ["stage-3","es2015"],  #如果安装的是babel-preset-stage-2使用stage-2

    "plugins": ["transform-vue-jsx", "transform-runtime"]

    }

    (2):配置webpack.base.config.js

    在module里配置需要进行编译的文件夹(如下)module:{

    rules:[

    {

    test: /\.js$/,

    loader: 'babel-loader',

    include: [

    resolve('../src'), resolve('../config'),

    resolve('../libs'), resolve('../node_modules/iview')

    ],

    query: {

    presets: ['es2015']

    }

    },

    ]

    }

    重新运行项目,这时候发现报错

    Module build failed: ReferenceError: Unknown plugin "transform-vue-jsx"

    这是由于webpack无法解析vue-jsx的语法问题

    解决:

    安装依赖 [babel-plugin-transform-vue-jsx][1]npm install\

    babel-plugin-syntax-jsx\

    babel-plugin-transform-vue-jsx\

    babel-helper-vue-jsx-merge-props\

    --save-dev

    到此vue配置兼容ie(9+)浏览器问题完美解决

    0

    +1

    展开全文
  • IETab.crx 谷歌浏览器兼容性模式 谷歌浏览器ie 谷歌浏览器兼容模式设置步骤及插件ietab
  • 360兼容模式进入页面模式空白 安装npm install --save babel-polyfill main.js 引用 import ‘babel-polyfill’ resolve('node_modules/element-ui/src'),resolve('node_modules/element-ui/package/input/src')

    360兼容模式进入页面模式空白
    安装npm install --save babel-polyfill
    main.js 引用 import ‘babel-polyfill’

    resolve('node_modules/element-ui/src'),resolve('node_modules/element-ui/package/input/src')
    

    添加resolve('node_modules/element-ui/src'),resolve('node_modules/element-ui/package/input/src')

    展开全文
  • vue3.0项目不兼容ie浏览器问题

    千次阅读 2020-12-14 15:25:16
    本人也是菜逼一枚,目前问题还未得到解决,有大佬有解决方法可以给我指点一下谢谢,目前了解到就是ie兼容proxy,如果要兼容ie得放弃vue3的proxy,我想了想v3放弃proxy还用v3的意义何在,所以当场放弃了ie浏览器 ...
  • 对于经常用js的朋友,有时候一段脚本并是两个浏览器都兼容的,下面一些对ie和firefox都兼容的一些代码,大家可以学习下。
  • 安装babel-polyfill 插件 npm install --save-dev babel-polyfill 或者 npm install babel-polyfill --save-dev 或者 npm install babel-polyfill -D 在src目录中找到main.js,将该插件引入到项目中 ...
  • CDN引入vue不兼容IE浏览器

    千次阅读 2020-07-03 15:23:21
    // 兼容IE写法 data: function{ return {} } 2、es6箭头函数也兼容 // 异步写法 async getData(){ const res = await axios.get(""); } // 异步写法和箭头函数需要改为function getData(){ const that = ...
  • vue3.0 兼容ie浏览器

    千次阅读 2021-06-10 15:19:37
    vue3.0 兼容ie浏览器 安装babel/polyfill npm install --save @babel/polyfill 在main.js里面引入 (一定要在最上面,第一行) import '@babel/polyfill' 安装完成后会有babel.config.js文件,需手动定义...
  • vue项目兼容IE浏览器

    万次阅读 热门讨论 2018-08-17 11:04:56
    vue项目兼容IE浏览器 利用vue写出的项目打包后在IE浏览器下显示空白,是因为缺少babel-polyfill的缘故。 解决方法: 1、安装babel-polyfill包; 2、在main.js文件中引入babel-polyfill; 3、在...
  • 如何让你写的代码更兼容火狐和IE...本文将总结总结CSS中火狐浏览器与IE浏览器兼容代码,兼容兼容主要是语法规范问题,你写CSS写规范了,就都兼容了,其他的就是一些浏览器的BUG了,发一些技巧给你看看,或许有用。
  • 解决webSocket不兼容IE浏览器问题

    千次阅读 2019-09-06 08:37:09
    解决webSocket不兼容IE浏览器问题浏览器问题解决办法 浏览器问题 webSocket这一通信方式随着html5而来,但在浏览器支持上会有一些问题 有一些方法可以通过降级的方式去做兼容,为了适应一些浏览器,如一些低版本的IE...
  • 兼容IE浏览器的全屏机制

    千次阅读 2018-05-03 23:06:23
    由于IE浏览器较某些版本支持H5的全屏机制,因此需要对全屏做兼容处理,以方便人们的使用。 首先我们要介绍两个方法: 1. 请求进入全屏模式 element.requestFullscreen() 该方法用于发出异步请求使元素进入...
  • easyUI各版本与ie浏览器兼容问题
  • vue-cli3.0兼容IE浏览器

    2021-02-26 13:43:03
    因为项目中一些功能用到了IE的ocx组件部分,必须在IE环境下运行,按正常vue支持来说,IE8+应该是支持的,可能ES6写法需要进行兼容,我的项目就是在IE中无法打开,空白,也报一些 未定义什么的错误。 为了解决这个...
  • 1 解决IE5、IE6、IE7与W3C标准的冲突,使用(IE7.js IE8.js)兼容 http://apps.hi.baidu.com/share/detail/15407414 2 IE7.JS解决IE兼容性问题方法 http://www.chonggou.net/show/2824.html 3 消除IE浏览器系列的相关...
  • 为了帮助确保你的网页在所有未来的IE版本都有一致的外观,IE8引入了文件兼容性。在IE6中引入一个增设的兼容性模式,文件兼容性使你能够在IE呈现你的网页时选择特定编译模式。新的IE为了确保网页在未来的版本中都有一...
  • Vue - webpack 打包不兼容IE浏览器

    千次阅读 2019-03-28 16:19:18
    Vue - webpack 打包不兼容IE浏览器 参考:Vue - webpack 打包兼容 360 浏览器和 IE 浏览器 & webpack打包vue项目ie浏览器下报promise 未定义 问题描述 webpack打包vue项目在ie浏览器下页面空白,报错...
  • 解决ie浏览器兼容ES6语法问题

    千次阅读 2019-12-19 14:15:57
    ie浏览器中es6这种语法兼容,为了兼容ie呢,我们需要引入browser.min.js,下载browser.min.js链接如下:最关键的一点是要将script标签的type属性改为如下状态,完美解决。 在浏览器中输入...
  • 主要介绍了针对IE浏览器兼容问题小结,需要的朋友可以参考下

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 71,216
精华内容 28,486
关键字:

不兼容ie浏览器怎么办