精华内容
下载资源
问答
  • 二层交换机实现不同vlan通信
    千次阅读
    2019-09-18 05:16:31

     实验需求:
    PC1属于vlan10
    PC2属于vlan20
    实现PC1与pc2互通
    实验拓扑:
    二层交换机实现不同vlan通信
     实验过程:
     第一种实现方式:
    sw1:
    vlan batch 10 20
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 10
    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk pvid vlan 10 //默认为1,为了去标签改成10
    port trunk allow-pass vlan 2 to 4094
    sw2:
    vlan batch 10 20
    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk pvid vlan 20 //无标签打上20为了能够发到vlan20
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/2
    port link-type trunk
    port trunk pvid vlan 10 //无标签打上10为了能够发到vlan10
    port trunk allow-pass vlan 2 to 4094
    sw3:
    vlan batch 10 20
    interface GigabitEthernet0/0/1
    port link-type trunk
    port trunk pvid vlan 20 //为了去标签
    port trunk allow-pass vlan 2 to 4094
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 20
     实验结果:
    二层交换机实现不同vlan通信
     实验原理:
    Access链路
    收包时打标签 pvid
    发包时去标签
    Trunk链路
    发包时如果pvid相同则去标签(默认pvid=1)可以修改,如果pvid不同直接发送不改标签
    收包时如果有标签直接收,无标签打标签转发

     第二种实现方式:所有链路类型改成access
    Sw1
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 10
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 10
    sw2
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 20
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 20
    sw3
    interface GigabitEthernet0/0/1
    port link-type access
    port default vlan 20
    interface GigabitEthernet0/0/2
    port link-type access
    port default vlan 20
     第三种实现方式:Hybrid类型
    Sw1
    interface GigabitEthernet0/0/1
    port hybrid pvid vlan 10
    port hybrid untagged vlan 10 20
    interface GigabitEthernet0/0/2
    port hybrid tagged vlan 10 20
    sw2
    interface GigabitEthernet0/0/1
    port hybrid tagged vlan 10 20
    interface GigabitEthernet0/0/2
    port hybrid tagged vlan 10 20
    sw3
    interface GigabitEthernet0/0/1
    port hybrid tagged vlan 10 20
    interface GigabitEthernet0/0/2
    port hybrid pvid vlan 20
    port hybrid untagged vlan 10 20
    实验原理:
    通过tag和untag确定哪种数据帧通过

    更多相关内容
  • 三层交换技术就是二层交换技术加三层路由转发技术,传统的交换技术在数据链路... 了解了三层交换技术,我们下面通过交换机的VTP技术来实现不同Vlan、网络间的通信,之所以使用VTP技术主要原因在于大大减轻了我们对Vlan
  • 三层交换技术就是二层交换技术加三层路由转发技术,传统的交换技术在数据链路层进行... 了解了三层交换技术,我们下面通过交换机的VTP技术来实现不同Vlan、网络间的通信,之所以使用VTP技术主要原因在于大大减轻了我们
  • 我会通过一系列场景,给大家分析一下网络通信的原理,但是三种方式内容太多,所以今天就先给大家讲讲纯二层网络下,如何实现同网段不同vlan通信,后续再给大家分享另外两种方式。 拓扑如图,pc1属于vlan10,pc2...

    你知道纯二层网络,如何实现同网段不同vlan通信吗?

    你知道通过代理ARP,如何实现同网段不同vlan通信吗?

    你知道Vxlan架构,如何实现同网段不同vlan通信吗?

    我会通过一系列场景,给大家分析一下网络通信的原理,但是三种方式内容太多,所以今天就先给大家讲讲纯二层网络下,如何实现同网段不同vlan通信,后续再给大家分享另外两种方式。

    拓扑如图,pc1属于vlan 10,pc2属于vlan 20

    两台交换机互连接口为trunk模式,左边交换机trunk口的pvid是10,右边交换机的pvid是20

     

    通信原理:

    1. PC1访问PC2,判断目标主机是否同网段,是
    2. PC1发出针对PC2的ARP请求,ARP报文进入左边的交换机
    3. 左边的交换机会从trunk口将arp报文发出,因为pvid=10,所以属于vlan 10 的PC1的报文不带tag
    4. 右边的交换机从trunk口收到一个不带tag的arp报文,会查看这个接口的pvid是多少,发现pvid是20,那么就认为这个报文属于vlan 20
    5. 右边交换机从vlan 20的access接口将arp报文发出,PC2收到
    6. PC2给PC1回应ARP,完成ARP解析,接下来正常封装数据报文,实现双方的通信。

    配置过程:

    左边交换机配置

    interface GigabitEthernet0/0/1

     port link-type access

     port default vlan 10

    #

    interface GigabitEthernet0/0/3

     port link-type trunk

     port trunk pvid vlan 10

     port trunk allow-pass vlan 10

    右边交换机

    interface GigabitEthernet0/0/1

     port link-type access

     port default vlan 20

    #

    interface GigabitEthernet0/0/3

     port link-type trunk

     port trunk pvid vlan 20

     port trunk allow-pass vlan 20

    结果测试:

     

    小思考:如果两台交换机不用trunk互连,而是用access互连,是否可以实现PC间通信?

    在《纯二层网络,如何实现同网段不同VLAN通信》的内容已经讲完啦,喜欢记得点赞收藏哦~

       当然,如果你需要网工学习资料,可以私我哦~
     

     

    展开全文
  • 配置要求:1.完成设备名称和IP地址等的设置。2.完成telnet线路配置使管理终端能够远程访问所有网络设备。...3.按图示完成端口汇聚设置。...S1、B1为服务器模式,其他设备为...6.指定S1为所有VLAN的根交换机,并确保B1-B...

    配置要求:

    1.完成设备名称和IP地址等的设置。

    2.完成telnet线路配置使管理终端能够远程访问所有网络设备。远程访问密码为:123456,enable密码为1234。

    3.按图示完成端口汇聚设置。

    4.建立VTP域,域名mydomain1,密码111111。S1、B1为服务器模式,其他设备为客户端模式。(暂不配置)

    5.按图示完成VLAN及端口配置。

    6.指定S1为所有VLAN的根交换机,并确保B1-B2、B3-B4间链路处于阻断状态。(咱不配置)

    7.实现VLAN间的通信,确保各培训部间终端能够ping通。

    拓扑结构

    企业网络典型组网拓扑图

    设备配置

    (1)为每台PC和Server配置IP地址、子网掩码和网关(网关为interface vlan X 的ip地址)

    网关用于实现设备之间的三层通信,即路由,默认网关可先不填,因为还没有配置逻辑接口vlan的ip地址;也可以先填写,一般网关地址都为x.x.x.254,这里可以先写上192.168.2.254,后面再进行配置,其他PC配置略。

    配置PC的ip地址、子网掩码以及默认网关

    (2)为每台网络设备配置管理IP,配置命令如下,其他配置略:

    Switch>enable

    Switch#configure terminal

    #进入逻辑vlan接口1

    Switch(config)#interface vlan 1

    #配置ip地址,用于远程管理telnet登录使用

    Switch(config-if)#ip address 192.168.1.3 255.255.255.0

    #激活逻辑端口

    Switch(config-if)#no shutdown(用于激活接口,必须)

    网络设备管理地址配置

    (3)完成telnet线路配置

    #进入特权模式

    Switch>enable

    #进入配置模式

    Switch#configure terminal

    #配置进入到路由器特权模式的密码

    Switch(config)#enable password 1234

    #进入路由器的 VTY 虚拟终端下,“vty 0”表示用户连接数,共1个虚拟终端

    Switch(config)#line vty 0

    #配置 vty 的密码,即 telnet 密码

    Switch(config-line)#password 123456

    Switch(config-line)#login

    Switch(config-line)#end

    telnet线路配置

    其中 enable password 1234,用于配置进入特权模式所需要的密码

    password 123456,用于配置telnet管理员的远程登录密码

    配置完成后使用管理终端进行telnet连接,如图所示

    使用终端远程登录网络设备

    其他设备telnet配置略

    (4)端口汇聚配置

    构成EtherChannel的端口必须具有相同的特性,如双工模式、速度、Trunking的状态等。

    在两台三层交换机上分别配置链路聚合:

    Switch>enable

    Switch#configure terminal

    #创建以太通道,要指定一个唯一的通道组号,组号的范围是1~6的正整数。要取消EtherChannel时用“no interface port-channel 1”

    Switch(config)#interface port-channel 1

    Switch(config-if)#exit

    #进入端口21-22

    Switch(config)#interface range fastEthernet 0/21-22

    #将物理接口指定到已创建的通道中。

    Switch(config-if-range)#channel-group 1 mode desirable

    Switch(config-if-range)#no shutdown

    Switch(config-if-range)#end

    Switch#write

    3560交换机链路聚合配置

    配置完成后,使用show etherchannel summary命令,查看链路聚合配置情况

    查看链路聚合结果

    (5)trunk模式配置

    根据拓扑结构,在每台交换机上分别将用于连接网络设备的端口改为trunk模式。

    2960配置命令如下:

    配置二层交换机之间互连的端口为trunk类型

    Switch>enable

    Switch#configure terminal

    Switch(config)#interface fastEthernet 0/24

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    2960二层交换机trunk口配置

    对于3560三层交换机,需要将封装类型改为dot1q,再将端口类型设置为trunk,配置如下:

    Switch>enable

    Switch#configure terminal

    Switch(config)#interface f0/1

    #配置 trunk 链路的封装类型,同一链路的两端封装要相同。有的交换机,例如 2950只能封装 dot1q,因此无需执行该命令。

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    Switch(config)#interface f0/2

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    #同时对于链路聚合的port-channel 1 也要设置为trunk模式,配置通道中的物理接口的属性

    Switch(config)#interface port-channel 1

    Switch(config-if)#switchport trunk encapsulation dot1q

    Switch(config-if)#switchport mode trunk

    Switch(config-if)#switchport trunk allowed vlan all

    #另外一台3560交换机trunk模式配置相同

    3560三层交换机trunk口配置

    (6)VLAN配置

    在4个二层交换机上配置相应VLAN

    #创建VLAN2,VLAN3

    Switch(config)#vlan 2

    Switch(config-vlan)#vlan 3

    Switch#configure terminal

    Switch(config)#interface range f0/1-8

    #将接口f0/1-8划分到vlan2中,把交换机端口的模式改为 access 模式,说明该端口是用于连接计算机的,而不是用于 trunk

    Switch(config-if-range)#switchport access vlan 2

    Switch(config)#interface range f0/9-16

    #将接口f0/9-16划分到vlan3中

    Switch(config-if-range)#switchport access vlan 3

    对接入层交换机进行VLAN划分

    (7)单臂路由配置

    不同VLAN之间的通信,需要借助第三层设备,二层设备无法实现不同VLAN间的通信,可以选择路由器,三层交换机,本实验使用三层交换机进行实现,方法类似于华为设备中的VLANIF实现方式,配置逻辑接口VLAN,不同的VLAN对应配置不同的逻辑接口interface vlan x,并在接口下配置ip地址及子网掩码,此ip地址就是前文中提到的各终端设备的默认网关,对于不同VLAN中的终端设备,默认网关设置对应逻辑vlan中的ip地址即可实现三层交换机的路由功能。

    在S1交换机上创建单臂路由,配置命令如下:

    #在其中一台三层交换机S1上创建vlan即可,无需两台设备都配置,即一台作为路由器使用,另一台仍作为交换机使用

    Switch(config)#vlan 2

    Switch(config-vlan)#vlan 3

    Switch(config-vlan)#vlan 4

    Switch(config-vlan)#vlan 5

    Switch(config-vlan)#exit

    #开启三层交换机路由模式

    Switch(config)#ip routing

    #创建对应的逻辑接口vlan x

    Switch(config)#interface vlan 2

    #配置接口的IP地址及子网掩码

    Switch(config-if)#ip address 192.168.2.254 255.255.255.0

    #激活逻辑接口

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 3

    Switch(config-if)#ip address 192.168.3.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 4

    Switch(config-if)#ip address 192.168.4.254 255.255.255.0

    Switch(config-if)#no shutdown

    Switch(config)#interface vlan 5

    Switch(config-if)#ip address 192.168.5.254 255.255.255.0

    Switch(config-if)#no shutdown

    配置单臂路由

    若按照题目中要求,运行部内部电脑能够跨交换机通信,运行部和检修部之间无法ping通,信息培训部和通信培训部之间能够ping通,那么只需要将3560S1三层交换机中允许vlan2,3,4,5通过、并配置interface vlan 4 和 interface vlan 5 的ip地址即可,无需配置interface vlan2 和interface vlan 3 的ip地址(若配置会导致运行部和检修部之间也能ping通,),3560S2三层交换机中配置允许 vlan4和vlan5通过即可。

    未完待续。。。

    展开全文
  • 不同VLAN之间的通信

    2021-11-13 16:08:35
    为了实现不同VLAN间的通信,除了使用hybrid外,我们还可以使用单臂路由实现不同VLAN间的通信。当然我们也可以通过交换机来实现。 1、单臂路由实现不同VLAN间的通信 1.1、单臂路由的工作原理 单臂路由是指在...

    目录

    前言

    1、单臂路由实现不同VLAN间的通信

       1.1、单臂路由的工作原理

       1.2、单臂路由的配置实例

    2、三层交换机实现不同VLAN间的通信

       2.1、三层交换机的工作原理

       2.2、三层交换机的配置实例  


    目录

    前言

    1、单臂路由实现不同VLAN间的通信

       1.1、单臂路由的工作原理

       1.2、单臂路由的配置实例

    2、三层交换机实现不同VLAN间的通信

       2.1、三层交换机的工作原理

       2.2、三层交换机的配置实例  

    结语


    前言

    为了实现不同VLAN间的通信,除了使用hybrid外,我们还可以使用单臂路由实现不同VLAN间的通信。当然我们也可以通过三层交换机来实现。

    1、单臂路由实现不同VLAN间的通信

       1.1、单臂路由的工作原理

    单臂路由是指在路由器的一个接口上通过配置子接口(或"逻辑接口",并不存在真正物理接口)的方式,实现原来相互隔离的不同VLAN(虚拟局域网)之间的互联互通

       1.2、单臂路由的配置实例

    使用单臂路由技术实现不同VLAN间的通信

     

    AR1的配置:

    <Huawei>undo terminal monitor 

    <Huawei>system-view 

    [Huawei]sysname AR1

    [AR1]user-interface console 0

    [AR1-ui-console0]idle-timeout 0 0 

    [AR1]vlan batch 10 20

    [AR1]int g0/0/0.1                                 进入子接口

    [AR1-GigabitEthernet0/0/0.1]dot1q termination vid 10      配置封装协议及VLAN标签

    [AR1-GigabitEthernet0/0/0.1]ip add 192.168.10.1 24        配置IP地址

    [AR1-GigabitEthernet0/0/0.1]arp broadcast enable           开启ARP广播

    [AR1]int g0/0/0.2

    [AR1-GigabitEthernet0/0/0.1]dot1q termination vid 20

    [AR1-GigabitEthernet0/0/0.1]ip add 192.168.20.1 24

    [AR1-GigabitEthernet0/0/0.1]arp broadcast enable 

    [AR1]int g0/0/0 

    [AR1-GigabitEthernet0/0/0]un sh                                  激活接口

    LSW1的配置:

    <Huawei>undo terminal monitor          

    <Huawei>system-view                         

    [Huawei]sysname LSW1                     

    [LSW1]user-interface console 0

    [LSW1-ui-console0]idle-timeout 0 0    

    [LSW1]vlan batch 10 20                    

    [LSW1]int e0/0/1                                

    [LSW1-Ethernet0/0/1]port link-type access         

    [LSW1-Ethernet0/0/1]port default vlan 10           

    [LSW1-Ethernet0/0/1]undo shutdown               

    [LSW1-Ethernet0/0/1]int e0/0/2           

    LSW1-Ethernet0/0/2]port link-type trunk        

    [LSW1-Ethernet0/0/2]port trunk allow-pass vlan 10 20          

    [LSW1-Ethernet0/0/1]undo shutdown                

    [LSW1-Ethernet0/0/2]int g0/0/1        

    [LSW1-GigabitEthernet0/0/1]port link-type trunk      

    [LSW1-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 20   

    [LSW1-Ethernet0/0/1]undo shutdown                

    LSW2的配置:

    <Huawei>undo terminal monitor          

    <Huawei>system-view                         

    [Huawei]sysname LSW2                     

    [LSW2]user-interface console 0

    [LSW2-ui-console0]idle-timeout 0 0    

    [LSW2]vlan batch 10 20                    

    [LSW2]int e0/0/1                                

    [LSW2-Ethernet0/0/1]port link-type access         

    [LSW2-Ethernet0/0/1]port default vlan 10           

    [LSW2-Ethernet0/0/1]undo shutdown               

    [LSW2-Ethernet0/0/1]int e0/0/2           

    LSW2-Ethernet0/0/2]port link-type trunk        

    [LSW2-Ethernet0/0/2]port trunk allow-pass vlan 10 20          

    [LSW2-Ethernet0/0/1]undo shutdown                

    PC1:

     PC2:

    测试:

    PC1:

    PC2:

    2、三层交换机实现不同VLAN间的通信

       2.1、三层交换机的工作原理

    一次路由,多次交换
    一次路由:传输的第一个数据包,有三层引擎,MAC重新封装,路由转发
    多次交换:三层交换,硬件转发,基于FIB(转发数据库),邻接关系表。
    FIB包括:邻接主机和vlanid
    邻接关系表:包括邻接主机MAC地址
    通过查询FIB和邻接关系表重新封装数据中,从相应端口转发数据

       2.2、三层交换机的配置实例  

    使用三层交换技术实现不同VLAN间的通信

    LSW1的配置:

    <Huawei>undo terminal monitor          

    <Huawei>system-view                         

    [Huawei]sysname LSW1                     

    [LSW1]user-interface console 0

    [LSW1-ui-console0]idle-timeout 0 0    

    [LSW1]vlan batch 10 20 

    [LSW1]int vlan 10                                         进入虚拟接口

    [LSW1-Vlanif10]ip add 192.168.10.1 24      配置ip

    [LSW1-Vlanif10]int vlan 20

    [LSW1-Vlanif20]ip add 192.168.20.1 24

    [LSW1-Vlanif20]quit

    [LSW1]int g0/0/1

    [LSW1-GigabitEthernet0/0/1]port link-type access

    [LSW1-GigabitEthernet0/0/1]port default vlan 10

    [LSW1-GigabitEthernet0/0/1]int g0/0/2

    [LSW1-GigabitEthernet0/0/2]port link-type access

    [LSW1-GigabitEthernet0/0/2]port default vlan 20

    PC1:

    PC2:

    测试:

    PC1:

    PC2: 

    结语

    只有二层交换机,用二层交换机+路由器,通过单臂路由技术实现不同VLAN间的路由通信。

    有三层交换机,用三层交换技术实现不同VLAN的路由通信。

    展开全文
  • 实验:利用三层交换机实现不同VLAN通信 设备选用 三层设备选用 1-s3760-1 二层设备选用 1-s2328G-1 三台电脑 4根双绞线
  • 不同vlan之间通信(三交换机)

    千次阅读 2021-08-10 22:16:02
    操作步骤及命令 查看命令: [sw1]display mac-...[sw1-vlanif 2]display fip //转发表 sw1 <Huawei>undo t <Huawei>undo terminal m <Huawei>undo terminal monitor Info: Current te...
  • 1 ,实验名称:二层交换机不同VLAN实现互通 (华为)2,实验环境:(1)PC1 PC2(2)二层交换机两台(3)三层交换机一台(路由功能)3,实验拓扑:2 配置步骤:(1)配置PC1:IP :192.168.10.1子网掩码:255.255.255.0网关:192...
  • 层交换机是不能实现vlan间通讯的,这就需要三层路由功能,而3560默认情况下是二层交换机,这就需要多交换机进行一些配置,实现vlan间的通讯,下面通过具体实验对其进行讲解,需要的朋友可以参考下
  • 1.给出需要实现功能的拓扑图。 2.给两台pc机配置ip地址和子网掩码。 ...vlan 10 vlan 20 vlan 10 ...port trunk permit vlan 10 20 qu int g1/0/1 port link-aggregation g 1 qu int g1/0/2 port li...
  • 1.配置Vlan 2.配置接口的链路类型access 3.配置acess接口的缺省Vlan vlan bath 10 20 int e0/0/1 port link-type access port default vlan 10 int e0/0/2 port link-type access port default vlan 10 int e0/0/3 ...
  • 这是三层交换机跨Vlan通信实验的Cisco Packet Tracer文件。实验包括有两个vlan,两个二层交换机,一个三层交换机。
  • 一、VLAN能解决什么问题? VLAN是一种交换基础技术。又称虚拟局域网。 用户无法根据以往需要灵活的在交换机进行广播域的隔离,使用VLAN技术则可以解决这个问题...将交换机的接口根据业务需要添加到不同VLAN中,从...
  • 本资源详细的陈述了二层交换机的VLAN实验过程,与命令。文件内容丰富,有分步的实验截图,包括访问交换机,进入cfg模式,以及使用CMD对其进行互Ping的实验步骤与截图,欢迎大家下载查看。
  • 主机的IP地址以及子网掩码已列出,下面将讲解如何配置利用三交换机来实现不同VLAN间的相互通信 SW1的命令: en //进入特权模式 conf t //全局模式 vlan 10 //创建一个VLAN10 ex // 返回上一级 vlan 20 //...
  • vlan是什么-为什么要用vlan-vlan的作用-vlan的基本知识-如何实现交换机之间的vlan通信-vlan帧格式的字段解释-vlan ID的类型和范围-Trunk的模式-Trunk的模式协商结果-三交换机-三交换机和路由器的区别
  • eNSP三交换机不同vlan通信

    千次阅读 2021-03-30 20:18:37
    实验中使用的交换机型号均为S3700,其中SW3我们选用成为三层交换机,其它两个交换机均为二层交换机 三、实验内容 配置确定 VLAN: VLAN:PC1 PC3 VLAN:PC2 PC4 网段: 192.168.1.0/24 192.168.2.0/24 主机...
  • 不同VLAN之间通信的原理

    千次阅读 2019-04-03 17:05:09
    在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信,可以采取以下方案。 1.三层VLANIF接口方案 这是一种通过计算机网络体系结构中第三层(网络层)来实现VLAN间通信的解决方案。每个VLAN都...
  • 利用三交换机实现不同VLAN间的通信 一、实验目的 利用三交换机实现不同VLAN间的通信 、实验设备 3560-24MultilayeSwitch交换机一台, 2950T24Switch交换机三台, 工作站PC三台, 直连网线六条。 三、实验内容...
  • VLAN层通信

    2021-08-27 13:51:57
    同一个VLAN的计算机之间可以进行二层通信(交换数据帧)。不同VLAN的计算机之间必须通过三层接口(网关)进行三层通信(交换IP数据包)。 多臂路由器实现VLAN三层通信 单臂路由器实现VLAN三层通信(子接口) 三层...
  • Cisco中不同VLAN之间进行通信

    千次阅读 2021-12-26 19:28:54
    不同VLAN之间进行通信
  • 不同VLAN间是如何通信的?

    万次阅读 2021-07-08 09:28:57
    前言 Vlan的作用是隔离不同广播域,但是在实际应用当中,我们经常需要不同vlan之间的互通访问,但是不同VLAN间是无法直接互通的,那么...单臂路由技术-------二层交换机+路由器 2.三层交换技术-------三层交换机 ...
  • 不同vlan之间的通信原理

    千次阅读 2020-08-12 19:17:09
    交换机只能向端口转发相同标记的数据帧,如果要实现不同vlan之间相互通信,就需要靠路由器的路由表转发,通过查找ip的方式实现路由转发 ,实现不同vlan之间的通信。 单臂路由实现不同vlan之间的通信原理的原理 在...
  • 解决的方法要么是二层交换机加路由器,要么就是直接使用三层交换机,为什么要使用三层交换机呢? 1、三层交换机 三层交换机,本质上就是“带有路由功能的(二层)交换机”。路由属于OSI参照模型中第三层网络层的功能...
  • 学习笔记|不同VLAN之间相互通信

    万次阅读 多人点赞 2018-11-02 16:51:04
    在划分VLAN后,不同VLAN之间不能直接进行二层通信。如果要实现VLAN间通信。下面通过三种方法实现不同VLAN之间相互通信。 1、单臂路由 单臂路由(router-on-a-stick)是指在路由器的一个接口上通过配置子接...
  • 交换机实现不同vlan通信

    万次阅读 2018-10-31 20:19:13
    二层交换机为神州数码DCS-3950,路由交换机为神州数码DCRS-5650,路由器为神州数码DCR-2600。 2.原理 2.1交换机的带外管理和带内管理 交换机的管理方式可以分为带内管理和带外管理两种管理模式。所谓带内管理,是...
  • VLAN间的三层通信

    千次阅读 2019-04-30 18:50:00
    通过多臂路由实现VLAN间的三层通信 路由器的作用实质上就是在不同二层网络(二层广播域)之间建立三层通道。不同VLAN其实就是不同二层网络(二层广播域),所有路由器当然也可以在不同VLAN之间建立起三层...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 23,881
精华内容 9,552
关键字:

不同的vlan通过二层通信