精华内容
下载资源
问答
  • 如何设置vlan的ip
    千次阅读
    2020-09-24 18:59:02

    1.增加vlan

    [root]# ip link add link eth0 name eth0.1 type vlan id 1

    [root]# ip link add link eth0 name eth0.2 type vlan id 2

    [root]# ip addr add 192.168.1.1/24 dev eth0.1 brd +

    [root]# ip addr add 192.168.2.1/24 dev eth0.2 brd +

    [root]# ip link set eth0.1 up

    [root]# ip link set eth0.2 up

    在eth0网络接口上增加两个vlan,并设置ip地址,然后启用两个虚拟接口,brd +表示广播地址后24位全部为1 (192.255.255.255)

    2.查看vlan

    [root]# ip link show

    [root]# ip addr show

    3.删除vlan

    [root]# ip link delete eth0.1 type vlan

    [root]# ip link delete eth0.2 type vlan

    更多相关内容
  • IP175D VLAN寄存器设置说明,用于指导配置交换芯片175D。
  • 思科路由器如何配置VLANIP

    千次阅读 2021-07-20 02:25:01
    我们的思科路由器如何配置VLANIP呢?想必很多网络技术的新手都不清楚,所以小编这里就推荐下配置VLANIP方法和介绍VLAN给你们认识认识。VLAN:英文全称为Virtual Local Area Network,中文称虚拟局域网,VLAN其实...

    我们的思科路由器如何配置VLAN的IP呢?想必很多网络技术的新手都不清楚,所以小编这里就推荐下配置VLAN的IP方法和介绍VLAN给你们认识认识。

    VLAN:英文全称为Virtual Local Area Network,中文称虚拟局域网,VLAN其实就相当于一个小型网络的统称,如校园网内有三个不同网段,分别为10.0.0.0、172.16.1.0和192.168.1.0,我们可以分别将这三个网段划分为三个不同的VLAN,以便于管理。举个例子,只允许10.0.0.0网段访问172.16.1.0网段,不能访问192.168.1.0网段,此时VLAN的好处显露无疑。今天笔者同大家分享思科路由器如何配置VLAN的IP。

    1、启动计算机并连接到思科路由器,进入VLAN配置模式。在命令行提示符下键入以下命令,然后按ENTER键

    host1(config)#interface fastEthernet 4/0

    请注意,在这个例子中,我们指定的VLAN使用的是快速以太网连接,标有“快速以太网”。

    2、对VLAN进行封装,输入以下命令:

    host1(config-if)#encapsulation vlan

    3、创建一个子接口的VLAN,这将主机的IP,通过添加一个子识别号码。键入以下命令,然后按ENTER键。

    host1(config-if)#interface fastEthernet 4/0.35

    4、指定的VLAN ID,通过键入以下命令

    Read more: How to Configure a VLAN IP | eHow.com "host1(config-if)#vlan id 333",

    5、分配给VLAN的IP地址,在命令提示符下键入以下命令,然后按回车键。

    host1(config-if)#IP address 192.168.1.13 255.255.255.0

    通过这5个命令,你就成功在路由器上的VLAN配置了IP地址了,是不是很简单呢。

    小编这里再给大家推荐下思科路由器常见的配置,以便于你们接下来的学习。

    怎么给路由器配置IP?

    router(config)#interface fastethernet 0/1

    router(config-if)#ip address 192.168.1.100 255.255.255.0

    router(config-if)#no shutdown

    怎么给交换机配置IP?

    switch(config)#interface vlan 1

    switch(config-if)#ip address 192.168.1.100 255.255.255.0

    switch(config-if)#no shutdown

    静态路由配置方式:

    router(config)#ip route 192.168.1.0 255.255.255.0 192.168.10.1

    默认路由配置方式:

    router(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1

    浮动路由配置:

    router(config)#ip route 192.168.1.0 255.255.255.0 192.168.10.1 50

    router(config)#ip route 0.0.0.0 0.0.0.0 192.168.10.1 50

    给交换机配置默认网关,方便管理

    switch(config)#ip default-gateway 192.168.2.254

    辅助地址配置:

    switch(config-if)#ip address 192.168.1.1 255.255.255.0 secondary

    展开全文
  • vlan:virtual local area network,虚拟局域网 交换机6种模式 用户模式到特权模式 switch> switch>enable switch# 特权模式到用户模式 switch#disable switch> 特权模式到全局配置模式 switch#conf t ...

    前言

    思科仿真是指Cisco Packet Tracer软件,仿真网络连接和交换机的一些东西。

    vlan:virtual local area network , 虚拟局域网

    交换机6种模式

    用户模式到特权模式
    switch>
    switch>enable
    switch#
    
    特权模式到用户模式
    switch#disable
    switch>
    
    特权模式到全局配置模式
    switch#conf t               或者configure terminal
    switch(config)#
    
    全局配置模式到特权模式
    switch(config)#exit
    switch#
    
    
    除了用户模式外,其他模式退到特权模式
    快捷键CTRL+Z
    
    
    

    vlan设置

    
    全局模式下改名字
    switch(config)#hostname demllie
    
    
    
    增加加vlan2,vlan3等除了默认vlan1外的其他vlan
    switch(config)#vlan 2
    switch(config-vlan)#exit
    switch(config)#vlan 3
    switch(config-vlan)#exit
    switch(config)#^Z
    swtich#show vlan            显示vlan信息
    
    
    
    将端口添加到某个vlan上
    switch(config)#int f0/1
    switch(config-if)#switch access vlan 2
    switch(config-if)#exit
    
    
    将多个端口添加到某个vlan上
    switch(config)#int range f0/2-f0/3
    switch(config-if-range)#switch access vlan 3
    switch(config-if-range)#exit
    
    
    设置vlan的ip地址
    switch(config)#int vlan 2
    swtich(config-if)#ip add 192.168.1.1 255.255.255.0          add可写成address
    switch(config-if)#no shut								   shut可写成shutdown
    
    
    
    显示交换机信息
    switch#show running-config
    
    
    
    显示端口信息
    switch#show int f0/1
    
    显示vlan信息
    switch#show int vlan 1
    
    
    将端口设为全双工工作方式
    switch(config)#int f0/1
    switch(config-if)#duplex full
    
    
    

    telnet远程登录

    
    1.将交换机的用户TELNET登录密码设为:123456
    switch(config)#enable password s1234560
    switch(config)#line vty 0
    switch(config-line)#password s1234560
    switch(config-line)#login local
    switch(config-line)#exit
    switch(config)#username demllie password s1234560
    
    
    2.在PC上完成远程登录
    PC>telnet 192.168.1.1                    PC的ip是192.168.1.2, 子网掩码255.255.255.0
    Trying 192.168.1.1 ...Open
    User Access Verification
    Username: demllie			             输入用户名
    Password: 						          输入密码,这里是不显示的
    switch>
    
    
    

    路由器连接两个vlan

    交换机----路由器---交换机
    
    左边的交换机的端口都放入一个vlan中,设置其vlan的ip,
    右边的交换机端口放入另一个vlan中,设置其vlan的ip
    
    
    在路由器中,设置连接左边的交换机的端口为左边的vlan的ip,
    设置右边的交换机的端口为右边的lvlan的ip
    router(config)#int f0/0
    router(config-if)#ip add 192.168.1.1 255.255.255.0
    router(config-if)#no shut
    router(config-if)#exit
    router(config)#int f0/1
    router(config-if)#ip add 192.168.3.1 255.255.255.0
    router(config-if)#no shut
    router(config-if)#exit
    
    

    一般适用于交换机的操作也适用于路由器

    展开全文
  • cisco配置vlanip

    千次阅读 2020-10-26 19:00:45
    创建vlan vlan 2 name v2 exit 将交换机端口分配给vlan 2.1 分配接入端口 interface FasEthernet0/1 switchport mode access switchport access clan 2 exit 2.2 分配共享端口 interface FastEthernet0/3 ...
    1. 进入特权模式
    enable
    configuration terminal
    
    1. 创建vlan
    vlan 2
    name v2
    exit
    
    1. 将交换机端口分配给vlan
      2.1 分配接入端口
    interface FasEthernet0/1
    switchport mode access
    switchport access clan 2
    exit
    

    2.2 分配共享端口

    interface FastEthernet0/3
    switchport mode trunk
    switchport trunk allowed vlan 2,3
    exit
    

    2.3 指定三层交换机主干端口封装格式

    intreface FastEthernet0/3
    switchport trunk encapsulation dot1q
    switchport mode trunk
    

    第二行命令的作用是:指定802.1Q封装格式作为经过主干端口输入输出的MAC帧的封装格式。(对于三层交换机,这条命令不能少)
    3. 定义三层交换机的ip接口

    interface vlan 2
    ip address 192.168.1.2 255.255.255.0
    exit
    
    1. 启动三层交换机的路由功能
    ip routing
    
    展开全文
  • 大神教你如何配置vlan?简单易懂!

    万次阅读 2021-03-17 17:11:33
    为pc机如图分别配置IP地址; 在交换机LSW1上配置相应命令,配置命令如下: sys [SW1]vlan 10 //创建vlan10 [SW1-vlan10]q [SW1]vlan 20  [SW1-vlan20]q [SW1]int eth0/0/1 [SW1-Ethernet0/0/1]port link...
  • MacvlanIPvlan

    千次阅读 2021-02-08 11:17:31
    本文主要就macvlanipvlan的工作模式以及差异做简要介绍;同时,为便于形象的理解,还会涉及到一些实际操作命令。 macvlan 这里的macvlan是linux kernel提供的一种network driver类型,它有别于传统交换机上提供的...
  • 首先通过CONSOLE口或Telnet连接交换机,连接成功后,进入用户视图模式<H3C>然后输入sys进入系统视图模式[H3C]<H3C>...[H3C]vlan 10[H3C-vlan10]quit[H3C]vlan 20[H3C-vlan20]quit[H3C]vl...
  • vlan macvlan ipvlan

    千次阅读 2018-07-23 14:39:52
    VLAN VLAN 技术主要就是在二层数据包的包头加上tag 标签,表示当前数据包归属的vlan 号。VLAN的主要优点: (1)广播域被限制在一个VLAN内,节省了带宽,提高了网络处理能力。 (2)增强局域网的安全性:VLAN间不能直接通信...
  • 使用IP和vconfig配置vlan子接口

    千次阅读 2021-05-15 14:33:26
    一、使用IP命令配置此前 Arch Linux 用vconfig命令设置 VLANs ,该命令已被ip命令取代。下面的范例假定网口是enp125s0f0,名字是enp125s0f0.100,vlan id是100。1. 创建 VLAN 设备用下列命令添加 VLAN 网口:# ip ...
  • ESXI 6.5 配置 VLAN

    千次阅读 2022-02-17 15:05:51
    ESXI 6.5配置VLAN 背景介绍 ESXI 标准 vSwitch 支持自定义 VLAN ID,以实现网络隔离! 根据 VLAN ID 的不同,可分为三种网络: VLAN ID 0 阻止任何携带了 VLAN tag 的数据包 VLAN ID 4095 允许通过携带任何 VLAN tag...
  • [root]# ip link add link eth0 name eth0.1 type vlan id 1 [root]# ip link add link eth0 name eth0.2 type vlan id 2 [root]# ip addr add 192.168.1.1/24 dev eth0.1 brd + [root]# ip addr add 192.168.2.1...
  • 基于IP地址划分VLAN

    万次阅读 2020-05-08 22:31:58
    1、当检测IP在192.168.10.0./24时,PC接入交换机时,将其划分为VLAN 10,且可以和VLAN 10的服务器通信 2、当检测IP在192.168.20.0/24时,PC接入交换机时,将其划分为VLAN 20,且可以和VLAN 20的服务器通信 SW1 <...
  • 虚拟网络技术:ipvlan

    千次阅读 2019-09-07 13:28:52
    本文首发于我的公众号码农之屋(id:Spider1818),专注于干货分享,包含但不限于Java编程...=4.2,和macvlan类似,都是从一个主机接口虚拟出多个虚拟网络接口,ipvlan虚拟出的子接口共有物理接口的mac地址,但可配置...
  • 项目中设备网遇到的问题,...当配置了subnet口,它会根据数据包的源ip来确定源ip所属的vlan,并把数据报放进对应的vlan中,这样就达到了,一个接口适宜多个vlan,对于终端来说就是实现一根网线多VLAN业务接入普通电脑.
  • docker网络--多机通信--2--ipvlan笔记

    千次阅读 2022-03-29 13:22:19
    docker网络--多机通信--1--macvlan介绍单vlan通信(Bridge mode) 介绍 单vlan通信(Bridge mode)
  • AthTek IP-MAC Scanne局域网IP-MAC扫描器英文版支持跨网段VLAN 可扫IP MAC 主机名 工作组 打印机名 ARP和UDP两种扫描方式
  • 通过查看核心交换机Log正常,查看汇聚层交换机,发现个IP冲突导致广播风暴,经查,由于多台华三交换机默认存在VLAN1 的IP为192.168.0.233致使广播风暴产生,日志如下: 查看交换机VLAN1默认IP为192.168.0.233 如下...
  • 六、IP地址子网划分与VLAN

    千次阅读 2020-10-20 15:12:45
    ip地址分为五大类: 特殊ip地址 1. 网络地址:用于表示网络本身,具有正常的网络号部分,而主机号部分全部为0的ip地址称之为网络地址. 2. 广播地址:用于向网络中的所有的设备进行广播。具有正常的网络号部分,而...
  • Docker容器获取局域网ip(使用macvlan)

    千次阅读 2022-04-14 23:00:20
    由于日常开发需要多个开发环境的获取单独的局域网ip,docker默认的网卡配置无法满足在局域网内互通的需求,偶然发现docker带有macvlan的功能,以下是配置的一些信息记录 下文仅对网络配置有较为详细的介绍,docker的...
  • H3C模拟器划分VLAN配置IP

    千次阅读 2019-09-18 05:29:00
    总部设有研发、市场、供应链、售后等 4 个部门,统一进行 IP 及业务资源的规划和分配。 公司规模在 2016 年快速发展,业务数据量和公司访问量增长巨大。为 了更好管理数据,提供服务,公司决定建立自己的小型数据...
  • 参考:...所有端口默认情况下就是vlan1的1.输入”system-view“(简写”sys“),进入系统配置模式,system-view[H3C]2.取消默认管理vlan,如下即可取消交换机默认管理 vlan 1[H3C]undo ...
  • 华为配置telnet登录,以及简单的划分vlan
  • 基于ip子网划分vlan

    千次阅读 2020-07-16 18:13:50
    VLAN的高级配置二(基于ip子网划分vlan) 1.实验目的:掌握基于ip子网划分vlan的操作方法。 2.实验拓扑: 3.配置步骤。 3.1 LSW1的GE0/0/1口做trunk;LSW4的GE0/0/1口做trunk interface GigabitEthernet0/0/1 port ...
  • 3.给vlan分配一个ip地址命令: 先进入网络配置模式 config router set ipport 0 ipaddress 192.168.0.2 255.255.255.0 set ipport 0 vlan 100 set ipport 0 enable 4.删除给vlan分配的ip地址命令: 先进入...
  • 虚拟局域网VLAN设置

    千次阅读 2021-08-06 20:42:09
    昨天我们讲了交换机的配置,然后讲了一个小实验,结果后台收到一些小伙伴的私信,表示很喜欢这种类型,他们觉得不无聊,而且很有挑战性,所以今天想给大家讲一下虚拟局域网VLAN设置,同样也有一个小实验,希望大家...
  • cisco交换机设置vlan和相互连通

    千次阅读 2022-03-15 10:51:31
    目的:测试cisco环境下vlan之间...1, 设置vlan10和vlan20 Vlan10: Switch(config)#vlan 10 Switch(config-vlan)#interface vlan 10 Switch(config-if)# %LINK-5-CHANGED: Interface Vlan10, changed state to up Swit
  • Docker macvlan 网络驱动

    千次阅读 2021-12-16 12:56:23
    当你为macvlan设置的网段和宿主机同一个网段的情况下,这个自动分配的IP并不是从路由器DHCP服务获取的,所以很容易出现IP冲突问题,故强烈建议当macvlan的网段和宿主机网段同网段时候要手工指定一个没有给宿主机网络...

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 90,406
精华内容 36,162
关键字:

如何设置vlan的ip