精华内容
下载资源
问答
  • 像下面这样,用easyui的combobox做的下拉列表,要使它只可以选择列表里面的值,不可以直接输入或删除值 data-options在支持HTML5的浏览器中有效,如果浏览器版本较低,那么最好直接把配置写成属性,例如: ...

    像下面这样,用easyui的combobox做的下拉列表,要使它只可以选择列表里面的值,不可以直接输入或删除值

    http://c.hiphotos.baidu.com/zhidao/pic/item/77094b36acaf2edd19e1c6528e1001e93901937d.jpg


    data-options在支持HTML5的浏览器中有效,如果浏览器版本较低,那么最好直接把配置写成属性,例如:


    <input id="demoCombo" type="text" class="easyui-combobox" editable="false"/>


    或者不行的话就用js来控制:


    $("#demoCombo").combobox({editable:false});



    展开全文
  • (最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置) 代码 .版本 2 .支持库 iext .程序集 窗口程序集_启动窗口 .子程序 __启动窗口_创建完毕 .局部变量 i, 整数型 超级列表框1....

    属性

    首先将属性-是否有检查框设置成真。(最好也将类型设置成报表列表框,不然无法显示报表列,同时选择框也不能按列放置)

    代码

    .版本 2
    .支持库 iext
    
    .程序集 窗口程序集_启动窗口
    
    .子程序 __启动窗口_创建完毕
    .局部变量 i, 整数型
    
    超级列表框1.插入列 (, , , , , )
    .计次循环首 (10, i)
        超级列表框1.插入表项 (, 到文本 (i), , , , )
        超级列表框1.置状态图片 (i - 1, 选择 (超级列表框1.取当前状态图片 (i - 1) = 0, 1, 0))
    .计次循环尾 ()
    

    如下图:

    易语言 超级列表框 设置选中状态-选择框的 方法

    运行效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    解释

    置状态图片:

    设置指定表项的状态图片。如果“是否有检查框”属性为真,调用“置状态图片 (表项索引, 0)”或“置状态图片 (表项索引, 1)”可以设置表项检查框的选中状态(前者为不选中,后者为选中)。

    取当前状态图片:

    取回指定表项的当前状态图片索引,图片索引指向状态图片组属性中的某一图片,从 0 开始,-1 表示无图片。如果“是否有检查框”属性为真,返回值是当前检查框的选中状态,1表示被选中,0表示未选中。

    更多

    判断是否表项选中:

    .版本 2
    .支持库 iext
    
    .子程序 _按钮1_被单击
    .局部变量 文本, 文本型
    .局部变量 i, 整数型
    
    .计次循环首 (超级列表框1.取表项数 (), i)
        .如果真 (超级列表框1.取当前状态图片 (i - 1) = 1)
            编辑框1.内容 = 编辑框1.内容 + “表项” + 到文本 (i) + “被选中” + “    ”
        .如果真结束
    
    .计次循环尾 ()
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    实际运行效果:
    易语言 超级列表框 设置选中状态-选择框的 方法

    添加全选取消全选功能:

    在启动窗口添加一个“选择框”,并将属性-选中设置为“真”

    .版本 2
    .支持库 iext
    
    .子程序 _选择框1_被单击
    .局部变量 i, 整数型
    
    .如果 (选择框1.选中 = 真)
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 1)
        .计次循环尾 ()
    
    .否则
        .计次循环首 (超级列表框1.取表项数 (), i)
            超级列表框1.置状态图片 (i - 1, 0)
        .计次循环尾 ()
    
    .如果结束
    

    易语言 超级列表框 设置选中状态-选择框的 方法

    取消全选后的效果:

    易语言 超级列表框 设置选中状态-选择框的 方法

    其他

    视频教程: https://www.eyuyan.tv/p1289

    展开全文
  • 安卓源码--修改设置语言选择列表

    千次阅读 2015-12-25 12:41:26
    查找过程 切换中文:setting下grep查找: 语言和输入法 找到两个 ...在src目录下查找LocalePicker类,发现在类中locale属性(也就是语言list)并不是在这里之中初始化,这时根据...就修改了设置中的语言列表选项。

    查找过程

    切换中文:setting下grep查找:语言和输入法
    找到两个
    这里写图片描述
    自我感觉是第二个:
    这里写图片描述
    在manifest查到如下内容:
    这里写图片描述
    发现跳转到InputMethodAndLanguageSettings类,在packages\apps\Settings\src\com\android\settings\inputmethod\InputMethodAndLanguageSettings.java
    在onCreate方法中有添加xml文件
    这里写图片描述
    在res目录下查找language_settings.xml
    这里写图片描述

    在src目录下查找LocalePicker类,发现在类中locale属性(也就是语言list)并不是在这里之中初始化,这时根据继承的父类LocalePicker再查找。
    这里写图片描述

    internal是在frameworks下的,所以很快就能找到父类的位置是在frameworks\base\core\java\com\android\internal\app\ LocalePicker.java的同名文件
    连蒙带猜的方式,修改调试就会发现,语言列表是在 ArrayList localeList = new ArrayList(Arrays.asList(Resources.getSystem().getAssets().getLocales()));初始化

    修改

    将这句修改为

            //ArrayList<String> localeList = new ArrayList<String>(Arrays.asList(
            //        Resources.getSystem().getAssets().getLocales()));
    
            ArrayList<String> localeList = new ArrayList<String>();
            localeList.add("zh_CN");
            localeList.add("en_US");

    就修改了设置中的语言列表选项。

    展开全文
  • //创建下拉列表框离开焦点事件 添加该事件是为了删除动态事件 以免多次调用 (e.Control as ComboBox).Leave += new EventHandler(ComboBox_Leave); } } //离开焦点事件 private void ComboBox_Leave(object ...
        private void DataGridView_EditingControlShowing(object sender, DataGridViewEditingControlShowingEventArgs e)
            {
    
                if (StoreSwap_Tab_DataGridView.CurrentCell != null && e.Control.GetType() == typeof(DataGridViewComboBoxEditingControl))
                {
                    //创建下拉列表框改变事件
                    (e.Control as ComboBox).SelectedIndexChanged += new EventHandler(ComboBox_SelectedIndexChanged);
                    //创建下拉列表框离开焦点事件 添加该事件是为了删除动态事件 以免多次调用
                    (e.Control as ComboBox).Leave += new EventHandler(ComboBox_Leave);
                }
            }
            //离开焦点事件
        private void ComboBox_Leave(object sender, EventArgs e)
            {
                //删除动态调用
                (sender as ComboBox).SelectedIndexChanged -= new EventHandler(ComboBox_SelectedIndexChanged);
                (sender as ComboBox).Leave -= new EventHandler(ComboBox_Leave);
            }
            //下拉列表框改变事件
        private void ComboBox_SelectedIndexChanged(object sender, EventArgs e)
            {
    
            }   

    展开全文
  • Word2016设置多级列表

    万次阅读 2018-05-13 16:10:27
    2.设置多级列表。注意:多级列表在“开始”菜单里面。--&gt;在这个属性界面同样的方式设置二级标题:你有多少级设置多少级。设置完成“确认”。结果如图:遗憾的是:第二章的编号依然以1.x开始。下...
  • html如何设置下拉列表

    千次阅读 2020-05-24 15:39:23
    可以用许多方法完成下拉列表的功能。介绍在htlm中下拉列表的实现,html中下拉列表由select和option这两个表单标签一起使用来完成下拉功能的。 代码: <!DOCTYPE html> <html> <head> <meta ...
  • 【Android开发】基本组件-列表选择

    千次阅读 2015-04-01 12:45:29
    Android中提供的列表选择框(Spinner)相当于在网页中常见的下拉列表框,通常用于提供一系列可选择的列表项共用户选择。 Android中,可以使用两种方法向屏幕中添加列表选择框,一种是通过在XML布局文件中使用标记添加...
  • ExtJS中设置下拉列表不可编辑

    千次阅读 2014-04-29 10:45:12
    ExtJS中设置下拉列表框不可编辑  ExtJS这个框架,并没有学习和用过,只知道是一个流行的前段框架,和Easy UI,BUI,DWZ等这些框架都是差不多的,只不过比他们更加强大而已,之所以写这个,我觉得还是很有帮助的。 ...
  • IntelliJ IDEA 编译方式介绍及编译器的设置选择

    万次阅读 多人点赞 2017-03-22 21:57:54
    相对于 Eclipse 的实时自动编译,IntelliJ IDEA 的编译更加手动化,虽然 IntelliJ IDEA 也可以通过设置开启实时编译,但是太浪费资源了,因此不建议这样做。IntelliJ IDEA 编译方式除了手工点击编译按钮进行编译之外...
  • 下拉框设置下拉列表宽度

    千次阅读 2017-09-25 10:14:00
    panelWidth: 100, 转载于:https://www.cnblogs.com/tldxh/p/7590661.html
  • 在js代码里设置一个下拉列表选中项的方法如下: var obj = document.getElementById('selAppType'); $.each(obj .options, function (i, n) {  if (n.value === 'hello') {  n.selected = ...
  • SVN设置忽略文件列表

    千次阅读 2016-04-08 17:16:18
    本来想找到和git一样,可以通过配置文件来设置忽略文件的,可惜没有找到。转载一下下面的文章。 原文链接 在git工具中,设置忽略文件只需要修改版本库根目录下的.gitignore文件就可以了,没有的话创建一个,非常...
  • Java设置Excel下拉列表

    千次阅读 2019-08-04 13:06:12
    //设置下拉列表作用的单元格(firstrow, lastrow, firstcol, lastcol) CellRangeAddressList regions = new CellRangeAddressList(1, 100, 0, 0); //生成并设置数据有效性验证 DVConstraint constraint = ...
  • 下拉框设置默认选择

    千次阅读 2018-09-30 13:12:05
    if($("#slt").get(0).options[i].text == supv) { $("#slt").get(0).options[i].selected = true; break; }
  • MFC 下拉列表框的设置

    千次阅读 2019-11-06 10:33:27
    设置下拉列表框: 步骤1:打开VS2015,新建项目工程,选择模块下的Visual C++-->MFC-->MFC应用程序,设定好项目文件名和路径,点击确定。 步骤2:进入应用程序类 型界面。勾选“基于对话框”,在“MFC的...
  • https://jingyan.baidu.com/article/a24b33cd28f4ff19ff002b7a.html将所有的1——N级标题先... 下面我们设置第一步:设置每个标题的格式(以一级标题为例)①选中正文中标题1的文字,点击快速样式中的标题1。②在快...
  • 最近在研究Cortex-M系列CPU,整了一个...换句话说就是,只有一个工程项目文件,将所有涉及到的代码文件全部关联进去,但是在编译的时候可以自由的选择不同的目标平台,进而由编译器自动纳入所需要的源文件进行编译。
  • jquery bootstrap下拉列表设置最大高度

    万次阅读 2016-10-30 15:17:22
    项目中需要点击弹出下拉框,使用了常用的bootstrap提供的Dropdowns下拉列表的插件,在使用中,为了设置表格的哪些列 需要隐藏与否,由于表格的列达到了50多行,点击之后,需要将整个界面下拉,导致很丑,所以需要重新修改...
  • Spinner控件的使用(设置下拉列表

    千次阅读 2018-11-11 16:08:12
    有意思的是他会需要多设置一下,哪一部分呢?Spinner总共分成两部分,一部分是已经显示的部分,还有一部分是下拉列表。两种的显示都可以自定义,下面为大家展示一下代码: 第一步:定义带有Spinner控件的布局 &...
  • 在项目中需要为Ant Design Vue 的 select 组件设置一个默认值,如下图所示的状态下拉选择框,默认选择全部 代码如下: 1 <a-select v-model="queryParam.status"> 2 <a-select-option :value="0">...
  • excel单元格设置下拉列表

    千次阅读 2005-02-01 14:59:00
    1、选中单元格2、点击工具栏上的“数据”菜单,选择“有效性”;3、在数据有效性窗口中的有效性条件中选“序列”;4、在来源中填入下拉列表内容:“一大队,二大队,三大队,四大队”,这样就可以了!!
  • QComboBox设置下拉列表中子项的样式

    千次阅读 2017-12-18 11:40:54
    在Qt Designer里使用了一个QComboBox: ui->comboBox_2->...//这样设置是可以改变弹出项的宽度(使其大于QComboBox框),但是同样的方式设置高度就不行,高度可以在样式表里设置,不明白。。。 官方文档给出的设
  • 原型库网站—讲师金乌原创发布,可自由转载,请注明出处! ...   《AxureRP7.0部件详解》 List Box 列表选择框 ...如果你想让用户查看所有选项而不需要点击选择的话,就使用列表...与下拉列表不同的是,列表选择框允许
  • 1、选中单元格,点击数据-数据有效性 2、设置中有效性条件,允许-序列,勾选 提供空值 和提供下拉箭头 3、来源中可手动输入需要的值,中间以英文状态下的逗号隔开
  • 带有单选按钮的下拉列表Combo: 1、 参数设置需要在data-options中设置 2、 Combo的属性参数配置 Width:设置select的宽度,默认为auto panelWidth:下拉列表的宽度,默认为...separator:设置当多重选择选择项之间
  • element-ui中的select下拉列表如何设置默认值?在element-ui的运用中,涉及到了select下拉列表。项目中需要将select的默认值给展示出来那如何修改呢?上element-ui中的代码片段 请选择"> v-for="item in
  • IOS10系统 app没有出现在系统设置-通知列表处理 app 有推送功能,安装后却没有出现在 系统设置-通知列表 处理 App推送收不到,使用 [[UIApplication sharedApplication] isRegisteredForRemoteNotifications] 检测通...
  • 试过在方法中,加height,minheight,但这个高度改变的是下拉列表的高度,不是控件的高度。 要怎么改变控件本身的高度呢? 控件的源码是 $.widget("ech.multiselect", { // default options options: { ...
  • Android Studio启动时,...所以呢,我想这是在Android Studio在启动时,就直接打开欢迎界面,也就是Welcome to Android Studio界面,在这里选择我最近打开过的工程,则可以通过设置Settings来设置:(1)打开settings对

空空如也

空空如也

1 2 3 4 5 ... 20
收藏数 1,049,062
精华内容 419,624
关键字:

如何设置列表选择