精华内容
下载资源
问答
  • 一、企业网络实例:实现不同vlan间的通信为了安全及便于管理,企业为服务器专门划分VLAN,用户属于VLAN 10,服务器属于VLAN 20。用户与服务器间跨接入、汇聚和核心交换机,其中接入是二层交换机,汇聚、核心是三层...
    展开全文
  • Vlan间互通技术是我们学习网络的一个基本技术,如果是一台路由器连接一台二层交换机,为了实现二层交换机下不同vlan的PC机实现互通,需要配置普通的单臂路由技术。但是单臂路由会出现可靠性和性能问题,所以后来出现...

    一个人的知识,通过学习可以得到;一个人的成长,就必须通过磨练。若是自己没有尽力,就没有资格批评别人不用心。开口抱怨很容易,但是闭嘴努力的人更加值得尊敬。

    8573957acf72281a55b145a3bcb21997.gif

    Vlan间互通技术是我们学习网络的一个基本技术,如果是一台路由器连接一台二层交换机,为了实现二层交换机下不同vlan的PC机实现互通,需要配置普通的单臂路由技术。但是单臂路由会出现可靠性和性能问题,所以后来出现了三层交换机,通过给不同的vlan赋予IP地址,实现不同vlan互通。今天的技术帖我们给大家介绍一个非常有趣的vlan间互通实验,当然,只作研究,不作实际使用。

    拓扑图如下图所示:

    7a7765258f996d55b35934e3048c0924.png

    PC3和PC4分别是属于vlan10和vlan20,两台PC机都连接在二层交换机SW上,两台PC的网关是RT,RT上分别给vlan10和vlan20配置网关192.168.1.1/24和192.168.2.1/24,现需要实现不同vlan下的PC通过三层实现vlan间互通。

    分析:

    大家看到这张图之后最先想到的实现vlan间互通的方法就是使用普通的单臂路由技术了,但是除了之前NE学习过的方法之外,还有什么方法实现vlan间互通呢?我们给大家演示以下。

    SW的配置如下所示:

    [SW]vlan 10

    [SW-vlan10]port GigabitEthernet 1/0/2

    [SW]vlan 20

    [SW-vlan20]port GigabitEthernet 1/0/3

    [SW]vlan 30

    [SW-vlan30]port GigabitEthernet 1/0/1

    [SW]interface GigabitEthernet 1/0/2

    [SW-GigabitEthernet1/0/2]port link-type hybrid

    [SW-GigabitEthernet1/0/2]port hybrid vlan 10 30untagged

    [SW]interface GigabitEthernet 1/0/3

    [SW-GigabitEthernet1/0/3]port link-type hybrid

    [SW-GigabitEthernet1/0/3]port hybrid vlan 20 30untagged

    [SW]interface GigabitEthernet 1/0/1

    [SW-GigabitEthernet1/0/1]port link-type hybrid

    [SW-GigabitEthernet1/0/1]port hybrid vlan 10 2030 untagged

    之前NE课程中大家学习过hybrid端口,hybrid端口有一个untag表,在untag表中的vlan号可以用来去掉报文的vlan标签

    RT的配置如下所示:

    [RT]interface GigabitEthernet 0/0

    [RT-GigabitEthernet0/0]ip address 192.168.1.124

    [RT-GigabitEthernet0/0]ip address 192.168.2.124 sub//物理接口配置主从地址

    思路:

    因为SW连接PC3、PC4和RT的端口已经配置成了hybrid端口,那么PC3和PC4原本是不能通信的,因为各自的hybrid端口untag表中没有对方的vlan号,但是PC3和PC4通信的报文进入SW的G1/0/2后会打上vlan10的标记,从G1/0/1接口出去会去掉vlan号,此时报文会交给网关192.168.1.1,也就是RT设备,RT发现目的地址是PC4的IP地址,所以查看路由表找到192.168.2.0/24的出接口,此时RT上在G0/0接口下面配置了主地址和从地址,报文还是从G0/0接口发送出去,进入SW的G1/0/1接口,打上vlan30的标记,此时G1/0/3端口是hybrid端口,untag表中有vlan30,可以去标签交给PC4,实现PC3和PC4之间互通。

    配置成功之后进行验证,发现两台PC之间可以互通,如下图所示:

    756fbdeeb1f5aad0eb357a7d6a1ac209.png

    如果您对技术帖有任何疑问,请联系官方邮箱jcit@jiancenj.com

    欢迎广大学员踊跃投稿,一经录用,有稿费酬谢

    END

    vlan技术的微妙之处

    组播静态路由对RPF机制的实现

    如何从服务器处获取地址

    Linux系统文件目录管理常用命令

    4a4248434006973cd37cc0babf504013.png

    展开全文
  • 交换机的配置一直是弱电人的难点,尤其是在大型网络中,前面我们曾提到关于华为、h3c、锐捷等品牌交换机基本配置,本期我们将通过一个大型网络的实际案例,来详细了解清楚交换机的vlan创建以及不同vlan间的通信。...

    交换机的配置一直是弱电人的难点,尤其是在大型网络中,前面我们曾提到关于华为、h3c、锐捷等品牌交换机基本配置,本期我们将通过一个大型网络的实际案例,来详细了解清楚交换机的vlan创建以及不同vlan间的通信。

    这个实例基本包括了交换机在配置vlan过程中的大部分问题,了解清楚了,基本上能够解决大部分项目配置,以华为交换机为例。

    一、企业网络实例:实现不同vlan间的通信

    为了安全及便于管理,企业为服务器专门划分VLAN,用户属于VLAN 10,服务器属于VLAN 20。用户与服务器间跨接入、汇聚和核心交换机,其中接入是二层交换机,汇聚、核心是三层交换机。由于业务需要现要求用户与服务器间可以互通。

    70a73cb2b8114da59db924ca908605a7.png

    配置思路

    采用如下的思路配置不同网段之间通过静态路由进行通信:

    1、在接入交换机上配置基于接口划分VLAN,实现二层通信。

    2、在汇聚交换机AGG上配置VLANIF10,作为用户的网关,在核心交换机CORE上配置VLANIF20,作为服务器的网关。

    3、在汇聚交换机AGG上配置从AGG到达VLANIF20网段的静态路由,在核心交换机CORE上配置从CORE到VLANIF10网段的静态路由,实现跨网段通信。

    配置步骤如下:

    1、配置接入交换机ACC1

    # 创建VLAN。

     system-view     //进入配置视图[HUAWEI] sysname ACC1   //修改设备的名称为ACC1,便于识别[ACC1] vlan batch 10         //批量创建VLAN 10

    # 将接口加入相应VLAN。

    [ACC1] interface gigabitethernet 1/0/1      //进入端交换机ACC1的1/0/1端口

    [ACC1-GigabitEthernet1/0/1] port link-type access     //将与用户相连接口的接口类型设置为access

    [ACC1-GigabitEthernet1/0/1] port default vlan 10     //将用户划分到VLAN 10

    [ACC1-GigabitEthernet1/0/1] quit

    [ACC1] interface gigabitethernet 1/0/2          //进入端交换机ACC1的1/0/2端口

    [ACC1-GigabitEthernet1/0/2] port link-type trunk    //将与汇聚交换机相连接口的接口类型设置为trunk

    [ACC1-GigabitEthernet1/0/2] port trunk allow-pass vlan 10   //透传VLAN 10到汇聚交换机AGG

    [ACC1-GigabitEthernet1/0/2] quit

    2、配置接入交换机ACC2

    # 创建VLAN。

    system-view

    [HUAWEI] sysname ACC2    //修改设备的名称为ACC2

    [ACC2] vlan batch 20       //批量创建VLAN 20

    # 将接口加入相应VLAN。

    [ACC2] interface gigabitethernet 1/0/1       //进入端交换机ACC2的1/0/1端口

    [ACC2-GigabitEthernet1/0/1] port link-type access    //将与服务器相连接口的接口类型设置为access

    [ACC2-GigabitEthernet1/0/1] port default vlan 20  //将用户划分到VLAN 20

    [ACC2-GigabitEthernet1/0/1] quit

    [ACC2] interface gigabitethernet 1/0/2      //进入端交换机ACC2的1/0/2端口

    [ACC2-GigabitEthernet1/0/2] port link-type trunk  //将与核心交换机相连接口的接口类型设置为trunk

    [ACC2-GigabitEthernet1/0/2] port trunk allow-pass vlan 20  //透传VLAN 20到核心交换机

    [ACC2-GigabitEthernet1/0/2] quit

    3、配置汇聚交换机AGG

    # 创建VLAN。

    system-view

    [HUAWEI] sysname AGG  //修改设备的名称为AGG

    [AGG] vlan batch 10 30  //批量创建VLAN 10和VLAN 30

    # 将接口加入相应VLAN。

    [AGG] interface gigabitethernet 1/0/2

    [AGG-GigabitEthernet1/0/2] port link-type trunk      //将接口类型设置为trunk

    [AGG-GigabitEthernet1/0/2] port trunk allow-pass vlan 10   //透传用户的VLAN 10

    [AGG-GigabitEthernet1/0/2] quit

    [AGG] interface gigabitethernet 1/0/3

    [AGG-GigabitEthernet1/0/3] port link-type trunk      //将接口类型设置为trunk

    [AGG-GigabitEthernet1/0/3] port trunk allow-pass vlan 30   //透传和核心交换机互连的VLAN 30

    [AGG-GigabitEthernet1/0/3] quit

    # 创建VLANIF10并配置对应的IP地址,作为用户的网关。

    [AGG] interface vlanif 10       //创建VLANIF10接口

    [AGG-Vlanif10] ip address 10.1.1.1 24     //配置IP地址,此IP地址是用户的网关地址

    [AGG-Vlanif10] quit

    # 创建VLANIF30和对应的IP地址。

    [AGG] interface vlanif 30  //创建VLANIF30接口

    [AGG-Vlanif30] ip address 10.10.30.1 24  //配置互连的IP地址,此IP地址不能和用户、服务器的IP地址冲突

    [AGG-Vlanif30] quit

    # 配置静态路由,使用户PC可以访问服务器。

    [AGG] ip route-static 192.168.1.0 255.255.255.0 10.10.30.2  

    //目的IP是192.168.1.0/24网段的报文,转发下一跳是核心交换机VLANIF30的IP地址10.10.30.2

    4、配置核心交换机CORE

    # 创建VLAN。

    system-view

    [HUAWEI] sysname CORE  //修改设备的名称为CORE

    [CORE] vlan batch 20 30  //批量创建VLAN 20和VLAN 30

    # 将接口加入相应VLAN。

    [CORE] interface gigabitethernet 1/0/2

    [CORE-GigabitEthernet1/0/2] port link-type trunk  //将接口类型设置为trunk

    [CORE-GigabitEthernet1/0/2] port trunk allow-pass vlan 20  //透传服务器的VLAN 20

    [CORE-GigabitEthernet1/0/2] quit

    [CORE] interface gigabitethernet 1/0/3

    [CORE-GigabitEthernet1/0/3] port link-type trunk  //将接口类型设置为trunk

    [CORE-GigabitEthernet1/0/3] port trunk allow-pass vlan 30  //透传和汇聚交换机互连的VLAN 30

    [CORE-GigabitEthernet1/0/3] quit

    # 创建VLANIF20并配置对应的IP地址,作为服务器的网关。

    [CORE] interface vlanif 20  //创建VLANIF20接口

    [CORE-Vlanif20] ip address 192.168.1.1 24  //配置IP地址,此IP地址是服务器的网关地址

    [CORE-Vlanif20] quit

    # 创建VLANIF30和对应的IP地址。

    [CORE] interface vlanif 30  //创建VLANIF30接口

    [CORE-Vlanif30] ip address 10.10.30.2 24  //配置互连的IP地址

    [CORE-Vlanif30] quit

    # 配置静态路由,使服务器和访问用户PC。

    [CORE] ip route-static 10.1.1.0 255.255.255.0 10.10.30.1  

    //目的IP是10.1.1.0/24网段的报文,转发下一跳是汇聚交换机VLANIF30的IP地址10.10.30.1

    5、检查配置结果

    在VLAN 10中的用户PC上配置IP地址为10.1.1.2/24,缺省网关为VLANIF10接口的IP地址10.1.1.1。

    在VLAN 20中的服务器上配置IP地址为192.168.1.2/24,缺省网关为VLANIF20接口的IP地址192.168.1.1。

    配置完成后,VLAN 10内的用户PC与VLAN 20内的服务器能够相互访问。

    整体的思路就是,将相连的交换机之间,创建了多个vlanif(三层接口),相当于桥梁,便于vlan10与vlan20之间的通信。这种思路在大型网络通信中会频率的用到。

    这里面补充下:

    什么是vlanif?它与vlan的区别?

    有不少朋友多次问到这个vlanif接口,这里面弱电君补充下:

    vlanif就是创建三层接口时来用的,它是虚接口,可以配置IP地址;而vlan就是纯属二层vlan ID标识符,相当于对数据打标签。

    划分VLAN后,同一VLAN内的用户可以互相通信,但是属于不同VLAN的用户不能直接通信。为了实现VLAN间通信,可通过配置逻辑的三层接口(VLANIF接口)来实现。

    当交换机需要与网络层的设备通信时,可以在交换机上创建基于VLAN的VLANIF接口,用于通信,所以文中配置了多个vlanif,可以把vlanif想象成路由器的一个端口就更加容易理解了。

       大家好,我是老季,一个做弱电的民工,我将尽我最大的努力做好这个公众号,和大家一起分享,一起学习。这是我的个人微信号,想加入弱电圈子可以添加我的个人号,圈子里都是做弱电的,资源互相补充,实时资源多多。

    c90740c317492341d05fadc1ede7fc12.png

    扫一扫,关注本公众号,成为弱电行业高手

    23c676c05b3f645375ed6778e675b43f.png

    喜欢这篇文章,在右下角点个在看,点个赞,谢谢

    展开全文
  • 交换机的配置一直是弱电人的难点,尤其是在大型网络中,前面我们曾提到关于华为、h3c、锐捷等品牌交换机基本配置,本期我们将通过一个大型网络的实际案例,来详细了解清楚交换机的vlan创建以及不同vlan间的通信。...
    展开全文
  • [SW1]display current-configuration#sysname SW1#undo info-center enable#vlan batch 10 to 12 20#cluster enablentdp enablendp enable#drop illegal-mac alarm#diffserv domain default#drop-profile default#aa...
  • 前面我们曾提到关于vlan组网及一些配置,仍然有不少的朋友问到关于交换机的配置?尤其是三层交换机在项目中的应用配置,本期我们用一个实例来讲解vlan的创建及组网过程,且所有的命令都有解释,我们一起来看下。一、...
  • 1、相同网段 不同VLAN第一、不同VLAN就意味着不能通过二层通信,广播根本发送不过去第二、同网段就意味着路由器的两个接口要配置为同一个网段,但是这个根本就不符合路由器的配置规范,单臂路由行不通的。2、思路分析...
  • 以太网子接口常用于vlan间的三层互通和局域网与广域网间的互联。因传统的三层网接口不支持vlan,当收到...不同Vlan互通可以通过vlanif接口来实现,也可以通过路由器的子接口来实现。下面的例子通过子接口来实现vl...
  • 在局域网内,我们会用 VLAN不同的用户、不同的部门、不同用途的区域进行分组,一个 VLAN 区分一组用户,便于管理和使用。 什么是 VLAN ?...如何实现不同 VLAN 间的主机通信呢? VLAN 隔离二层
  • [SW1-vlan10]vlan 20 [SW1-vlan20]vlan 30 [SW1-vlan30]q [SW1-GigabitEthernet0/0/1]port link-type access [SW1-GigabitEthernet0/0/1]port default vlan 10 [SW1-GigabitEthernet0/0/1]undo shut [SW1-...
  • 一、同一个vlan中,不同网段的主机如何互通同一个vlan不同网段的主机如何互通,这个在小型网络中用的比较多,我们一起来看案例。1、拓扑图要求:实现拓扑图中,两个主机之间互访,他们同属于一个vlan2、案例交换机...
  • 一、同一个vlan中,不同网段的主机如何互通同一个vlan不同网段的主机如何互通,这个在小型网络中用的比较多,我们一起来看案例。1、拓扑图要求:实现拓扑图中,两个主机之间互访,他们同属于一个vlan2、案例交换机...
  • 前段时间弱电君分享了关于...一、同一个vlan中,不同网段的主机如何互通同一个vlan不同网段的主机如何互通,这个在小型网络中用的比较多,我们一起来看案例。1、拓扑图要求:实现拓扑图中,两个主机之间互访,他们...
  • 为了更好理解本文,强烈建议先阅读上一篇文章:两个vlan互通和划分到同一个vlan有何区别?本文是上一篇文章的姊妹篇。有读者会说,这还不容易啊?一根网线的两端同时插入交换机,网线的一段连VLAN 1端口(假定端口1)...
  • 实验任务:(1) 掌握和完成设置不同vlan间通过路由器互通的方法;(2) 完成同vlan间计算机的测试。2. 实验目的:(1) 进一步熟悉交换机vlan间互通的配置方法;(2) 熟悉和掌握不同vlan互通的测试方法。二、原理(条件)1....
  • 在交换机组网项目中,我们经常会提到关于不同vlan间的互通,那么在同一个vlan中如何实现端口相互隔离呢?对于有些项目,项目本身不需要不同vlan之间进行互访,比如有些监控项目就只需要内网访问,那么就没有必要创建...
  • 其实不同VLAN之间相互通信的两种方式,单臂路由、三层交换机,它们分别如何配置呢?哪一种好呢?今天我们来看下,这两种方式是如何来实现vlan间的通信。本篇文章要从三个问题开始说起?1、实现vlan间的通信有...
  • 原标题:如何实现交换机不同VLAN、不同网段之间互访?前段时间弱电君分享了关于多台路由器,不同网段的设备之间如何互访?有朋友提到关于交换机如何实现不同网段的互访?这个交换机完全可以实现,在实际项目中,...
  • 方法一:单臂路由实现不同VLAN之间互通什么是单臂路由呢?其实单臂路由就是指在路由器的一个接口上通过配置子接口的方式,实现原来相互隔离的不同VLAN之间互通。有什么优缺点呢?优点:实现不同vlan之间...
  • 为了更好理解本文,强烈建议先阅读上一篇文章:两个vlan互通和划分到同一个vlan有何区别?本文是上一篇文章的姊妹篇。有读者会说,这还不容易啊?一根网线的两端同时插入交换机,网线的一段连VLAN 1端口(假定端口1)...
  • 现在,二层交换机上的管理VLAN50,三层交换机的管理VLAN50,不同VLAN要处在不同的网段,那么如何用PC2或PC3来登入到管理VLAN50?这种拓朴下,二层交换机的默认网关该如何来设置? 解答: 1、同一个交换机上(即...
  • 对于有些项目,项目本身不需要不同vlan之间进行互访,比如有些监控项目就只需要内网访问,那么就没有必要创建vlan了,节约网络设备资源,但是要防止网络风暴,怎么办呢?采用端口隔离功能,可以实现同一VLAN内端口...
  • 1、实验要求:两台PC机vlan不相同网关不相同,要求互通2、实验步骤;--配置终端IP;--交换机创建vlan ,把 对应的端口加入vlan;--配置路由器网关;--验证两台PC机之间的互通。3、实验拓扑图;-物理接口4、配置命令;...
  • 1. 同台交换机不同VLAN间的网络互通,逻辑拓扑图如下: 需求:实现VLAN 100、VLAN 200、VLAN300之间的PC网络互通在LSW 11交换机进行如下命令行配置:system-view #进入系统视图模式[Huawei]sysname test department...
  • 时可以利用hybrid属性定义分属于不同vlan的端口之间的互访,这是access和trunk端口所不能实现的。在一台交换机上不允许trunk端口和hybrid端口同时存在。1.先创建业务需要的vlan[SwitchA]vlan10[SwitchA]vlan20...
  • 一、同一个vlan中,不同网段的主机如何互通同一个vlan不同网段的主机如何互通,这个在小型网络中用的比较多,我们一起来看案例。1、拓扑图要求:实现拓扑图中,两个主机之间互访,他们同属于一个vlan2、案例交换机...
  • 新朋友请点上方蓝字“中博智能”免费关注前段时间弱电君分享了关于多...一、同一个vlan中,不同网段的主机如何互通同一个vlan不同网段的主机如何互通,这个在小型网络中用的比较多,我们一起来看案例。1、拓扑图要...
  • 时可以利用hybrid属性定义分属于不同vlan的端口之间的互访,这是access和trunk端口所不能实现的。在一台交换机上不允许trunk端口和hybrid端口同时存在。1.先创建业务需要的vlan[SwitchA]vlan10[SwitchA]vlan20...
  • 今天我们就从基础到深入来了解网络间如何才能互通如何才能不通,前面的文章也提过这方面的内容,以案例的方式来详细讲解,一文了解清楚vlan的使用与配置,方便后面应用于项目中。因为根据弱电VIP技术群朋友反映,...

空空如也

空空如也

1 2 3 4
收藏数 68
精华内容 27
关键字:

不同vlan如何互通